XLaunch Session type Launch

XLaunch Wizard

XLaunch is a wizard to make starting [WWW] Xming sessions easy.
You can just simply start the [WWW] X [WWW] server and run X clients latter by hand, but stating XDMCP or one X client automatically (via SSH if remote) is provided.

Authors

XLaunch was written by Alexander Gottwald and has been extensively upgraded and extended by Colin Harrison.

XLaunch Display settings

Display settings

This dialog sets the way Xming displays programs. Select the display settings appropriate to your requirements.

Multiple windows

Start the integrated Microsoft Windows-based window manager which launches each top-level X window in its own Windows window. Use this mode if you don't understand the others. An exception is X windows of type '_net_wm_window_type_dock' which are rendered frameless and topmost (e.g. kde's kicker).

One window

The X server appears as a single Windows window and all X windows are contained within this window. This mode requires an external window manager. Typically this mode would be used for [WWW] XDMCP login to a remote machine.

The window size can be altered using the -screen parameter, for example enter

-screen 0 1024x768+125+100@1
on the Additional parameters page of this wizard for a 1024x768 window size, offset 125,100 on the 1st monitor (the default).

Fullscreen

This mode is like single window mode except that the X server window takes the full screen, covering completely the Windows desktop. This mode requires an external window manager.

One window without titlebar

This mode is like single window mode except that the X server window does not have a title bar or border, thus maximizing the amount of space available for X windows within the X server window. This mode requires an external window manager.

Display number

The display (or X Window server) number (default 0). The phrase 'display' is usually used to refer to a collection of monitors that share a common keyboard and mouse.
On first glance the terms client and server in an X Window system appear backwards. Think of the server as the end providing the service. The service provided by X is access to the window, keyboard and mouse. On starting, the server creates a TCP end point and does a passive open on port 6000+n, where n is the display number. When a client is started on another host, it creates a TCP end point and performs an active open to port 6000+n on the server. Each client gets its own TCP connection to the server.

Copyright © 2005, 2006 Colin Harrison All rights reserved


XLaunch Session type

Session type

On this dialog select the client type you want (if any).

Start no client

This will just start Xming. You will be able to start X clients later.
Select this option if you don't understand the others.

Start a program

This will start one local or remote program which will automatically run with Xming. Remote programs are started using [WWW] SSH.

Open session via XDMCP

This will start a remote [WWW] XDMCP session. Starting local clients later is limited.
This option is not available with the 'Multiple windows' mode.


XLaunch Start program

Start program

Enter the name and parameters of a program you want to start and display on the server. For example, to run an 'xeyes' on display-number 0
xeyes -display localhost:0
You can also select a program from a list of up to ten X clients. This list can be customised by adding tags Program1="a" to Program10="j" to a config.xlaunch file (i.e. a previously saved XLaunch configuration file).

Run Local

Start the chosen or entered program (with parameters as required) on the local machine.

Run Remote

As above but the program will be run on a remote machine.
Using PuTTY
An X client program can be started remotely via PuTTY SSH (plink.exe command-line connection tool).

[WWW] PuTTY is run without an msdos console, as the password can be entered in advance. A password is not needed if using authentication agent 'Pageant' (one of the PuTTY toolset).

My typical PuTTY settings...

SSH 2 preferred.

Private key file. Use SSH X11 forwarding.
The SSH X11 forwarding options are important, notice the 'localhost:2', so run XLaunch 'Display number 2' to suite (the default is display-number 0) and enable it in the 'sshd' daemon (sshd_config) on the remote machine...

X11Forwarding yes
X11DisplayOffset 10
X11UseLocalhost yes
The PuTTY Password entry is not saved to the 'config.xlaunch' XML file by default, for security. When a Password has been entered a tag PasswordStart="True" is added to the file so that on reuse a warning can be issued prior to the wizard starting.
The Finish configuration page has an option for overriding this by allowing saving of any PuTTY Password as insecure clear text to 'config.xlaunch'.

The command run automatically after the X server has started is

plink -ssh -X <user@computer> <program>
    or
plink -ssh -X -pw <password> <user@computer> <program>
i.e. no password is needed if using 'Pageant', then just leave the wizard 'Password' field blank.

Try this by hand, from 'Command Prompt', if you have problems.

Using OpenSSH
An X client program can be started remotely via Cygwin SSH (ssh.exe client tool).

[WWW] Cygwin OpenSSH is run with an msdos console, as the password has to be entered interactively.
ssh-agent is no use from 'Command Prompt', since no tty. From Cygwin bash you can daemon ssh-agent and run using

$ keychain id_rsa
$ . ~/.keychain/$HOSTNAME-sh
$ cd 'C:/Program Files/Xming'
$ ./XLaunch -run my_ssh.xlaunch
then XLaunch detects 'SSH_AGENT_PID' and runs ssh without an msdos console.
When finished with ssh-agent
$ keychain -k; unset SSH_AGENT_PID; unset SSH_AUTH_SOCK

The command run automatically after the X server has started is

ssh -Y <user@computer> <program>
Try this by hand, from 'Command Prompt', if you have problems.


XLaunch XDMCP settings

XDMCP settings

Settings for the [WWW] XDMCP mode. This mode is the most problematic, is not very secure, and usually requires altering of the remote machine's settings. The XDMCP protocol will send and receive data on port 177/UDP. But the actual connections will be made to the local port 6000+n /TCP, where n is the display number.

Connect to host

Enables XDMCP and sends 'Query' UDP packets to the specified host.
If you are having problems use Ethereal or equivalent to monitor UDP traffic on the remote host and look for the sequence 'Query' 177/UDP, 'Willing' x/UDP, 'Request' 177/UDP, 'Accept' x/UDP, 'Manage' 177/UDP and see where it stops. If it gets through the sequence then try local and remote 'xeyes' in -multiwindow, because the Display Manager acts as an X client from then on in to provide its login window.
Use indirect connect
Enables XDMCP and sends 'IndirectQuery' packets to the specified host, configured as an XDMCP server. The XDMCP server presents a list of hosts to choose from.

Search for hosts (broadcast)

Enables XDMCP and broadcasts 'BroadCastQuery' packets to the network. The first responding display manager will be chosen for the session.

XDMCP remote settings

A quick and insecure guide to setting XDMCP mode on a remote machine running kdm, gdm or xdm...

On the remote Linux/UNIX/*NIX*/*BSD machine edit the following files, restart the X Display Manager and run at 'init 5'.

  • Edit the file Xaccess (you have to find it first, and each Display Manager will have one, so edit the correct file!). Make sure you have a line like this that is uncommented.
    *     	#any host can get a login window
  • Edit the X Display Manager config file (kdmrc, gdm.config, xdm-config or wdm-config) and change
    [Xdmcp]
Enable=false (may shown as 0 in some distributions)
  to
[Xdmcp]
Enable=true (or 1 in some distributions)
    or for a xdm style configuration
    DisplayManager.requestPort:	0
  to
!DisplayManager.requestPort:	0

Copyright © 2005, 2006 Colin Harrison All rights reserved


XLaunch Additional parameters

Additional parameters

This is where the more obtuse settings can be made. If in doubt enter nothing.

Clipboard

Enables the integration between the Xming clipboard and Windows clipboard. This is usually a good thing to have enabled.

Remote font server (if any)

Enter the hostname of a [WWW] font server on your network, typically a Unix or Linux machine with this capability. The font server is assumed to be available on port 7100/TCP.
If you have no font server then you must have [WWW] Xming Fonts installed with Xming.

Additional parameters for Xming

Enter all other command line parameters needed by you for Xming. If unsure enter nothing.
For a list of parameters read the [WWW] Xming Manual.


XLaunch Finish configuration

Finish configuration

This is the last page of the XLaunch wizard.
Select Finish to run the options selected and start the X server and any additional X client selected.

Save configuration

Click this option to save your configuration for reuse.
You can use XLaunch to start Xming with a saved configuration by clicking the .xlaunch file or like this
XLaunch -run <config.xlaunch>

To use a configuration as preset for new configurations right-click 'Edit' the .xlaunch file or

XLaunch -load <config.xlaunch>

Include PuTTY Password as insecure clear text

The PuTTY Password entry is not saved to the 'config.xlaunch' XML file by default, for security. When a Password has been entered a tag PasswordStart="True" is added to the file so that on reuse a warning can be issued prior to the wizard starting.
Selection of this option overrides this security measure and saves the PuTTY Password as insecure clear text to 'config.xlaunch'.

Finish

The wizard is closed and Xming is run with your settings, followed automatically by any X client chosen.


.topic 500
Display Help.

.topic 501
Clients Help.

.topic 502
Program Help.

.topic 503
XDMCP Help.

.topic 504
Clipboard Help.

.topic 505
Finish Help.