1

ВВЕДЕНИЕ

Данная книга является описанием встроенного языка системы 1С:Предприятие и предназначена для специалистов, выполняющих конфигурирование системы для решения конкретной задачи автоматизации учета.

1С:Предприятие является гибкой настраиваемой системой, с помощью которой можно решать широкий круг задач в сфере автоматизации деятельности предприятий. Специфические алгоритма конфигурации описываются в системе 1С:Предприятие в режиме запуска Конфигуратор (далее по тексту - конфигуратор) в программных модулях, содержащих тексты на встроенном языке системы 1С:Предприятие.

Назначение и краткая характеристика встроенного языка

Встроенный язык системы 1С:Предприятие предназначен для описания (на стадии разработки конфигурации) алгоритме! функционирования прикладной задачи.

Встроенный язык (далее по тексту - язык) представляет собой предметно-ориентированный язык программирования, специально разработанный с учетом возможности его применения не только профессиональными программистами. В частности, все операторы языка имеют как русское, так и англоязычное написание которые можно использовать одновременно в одном исходном тексте. Основной язык, описываемый в данной книге - русский однако для каждого оператора языка приводится его англоязычный синоним.

При своей относительной простоте язык обладает некоторыми объектно-ориентированными возможностями, например, правиле доступа к свойствам и методам специализированных типов данных (документам, справочникам и т.п.) подобны свойствам и методам объектов, используемых в других объектно-ориентированных языках. Однако специализированные типы данных не могут определяться средствами самого языка, а задаются в визуальном режиме конфигуратора.

Типизация переменных в языке не жесткая, т.е. тип переменной определяется ее значением. Переменные не обязательно объявлять в явном виде. Неявным определением переменной является ее первое упоминание в левой части оператора присваивания. Возможно также явное объявление переменных при помощи соответствующего оператора. Допускается применение массивов.

Формат описания элементов языка

Каждый элемент (конструкция) языка, упомянутый в этом руководстве, печатается таким шрифтом. Информация по компонентам языка приводится в виде синтаксической диаграммы, подробного описания и примера исходного текста.

Соглашения и обозначения, принятые в синтаксических диаграммах

В синтаксических диаграммах используются следующие символы:

Символ Значение

[] В квадратных скобках заключаются необязательные синтаксические элементы.

( ) Круглые скобки заключают в себе список параметров.

| Вертикальной линией разделяются синтаксические элементы, среди которых нужно выбрать только один.

Синтаксическая диаграмма описания элемента встроенного языка

Формат описания элемента языка, используемый в данном руководстве, иллюстрируется синтаксической диаграммой, приведенной ниже.

ЭлементЯзыка (АнглоязычныйСиноним)

Синтаксис:

ЭлементЯзыка (<Параметр 1>, <Параметр 2>, ...) [ДобКлючевоеСлово]

Англоязычный синтаксис: (в случае языковых конструкций)

Keyword(<Параметр1>,<Параметр2>, ...) [AddKeyWord]

Англоязычный синоним: (когда необходим)

Keyword

Параметры:

<Параметр 1>

Обязательный / Необязательный

Описание параметра.

<Параметр 2>

Обязательный / Необязательный

Описание параметра.

Возвращаемое значение:

Тип и краткое описание возвращаемого значения.

Описание:

Описание того, что реализует ЭлементЯзыка.

Примечание:

Примечание к изложенному описанию.

Пример:

// текст примера с комментариями

См.также:

Ссылки на другие методы, процедуры и функции.


1-005 Глава 1. Общее описание языка

Глава 1. Общее описание языка

Формат исходных текстов программных модулей

Что такое программный модуль?

Программные модули в конфигурации системы 1С:Предприятие не являются самостоятельными программами в общепринятом понимании этого слова, поскольку они являются только частью всей конфигурации. Программный модуль - это текст на встроенном языке, в котором размещены тексты процедур и функций с необходимыми алгоритмами, вызываемые системой во время работы системы в определенные моменты. Поэтому программный модуль не имеет формальных границ своего описания типа: «Начало модуля» - «Конец модуля».

Место размещения конкретного программного модуля предоставляется конфигуратором в тех точках конфигурации, которые требуют описания специфических алгоритмов функционирования. Эти алгоритмы следует оформлять в виде процедур или функций, которые будут вызваны самой системой в заранее предусмотренных ситуациях (например, при нажатии кнопки в диалоговом окне).

Каждый отдельный программный модуль воспринимается системой как единое целое, поэтому все процедуры и функции программного модуля выполняются в едином контексте.

Контекст выполнения программного модуля

Каждый программный модуль связан с остальной частью конфигурации. Эта связь называется контекстом выполнения модуля. Следует различать два вида контекста:

• глобальный контекст задачи;

• локальный контекст выполнения конкретного модуля.

Глобальный контекст

Глобальный контекст образуется:

• значениями свойств и методов глобального контекста;

• функциями встроенного языка и языковыми конструкциями;

• переменными, процедурами и функциями глобального программного модуля и общих модулей, объявленными с ключевым словом Экспорт.

Глобальный контекст виден всем программным модулям и определяет общую языковую среду конфигурации.

Локальный контекст

Локальный контекст модуля образуется тем конкретным местом конфигурации задачи, для которого использован программный модуль. Локальный контекст виден только конкретному программному модулю и определяет для модуля набор непосредственно доступных модулю объектов, их свойств и методов (см. «Виды программных модулей»),

Виды программных модулей

В системе 1C-Предприятие существуют несколько видов программных модулей. Они различаются по месту размещения и доступному контексту.

Общие модули

Общие модули располагаются в отдельной ветке дерева метаданных. Основным назначением общих модулей является содержание общих алгоритмов конфигурации, доступных из разных модулей. В общих модулях отсутствует раздел определения переменных и раздел основной программы, то есть они содержат только раздел процедур и функций (см. раздел «Структура программного модуля»).

В любом общем модуле возможно объявление и описание процедур и функций, которые будут доступны в любом модуле конфигурации, кроме других общих модулей, дополняя глобальный контекст прикладной задачи.

Для общих модулей конфигурации предусмотрен признак выполнения «Предпочтительно на сервере». Это означает, что данный модуль будет предпочтительно исполняться на сервере 1C: Предприятия. Если исполнение модуля происходит на сервере, то выполнение операторов, приводящих к интерактивному диалогу с пользователем или выводу сообщений на экран, в теле процедур и функций такого модуля будет приводить к ошибке выполнения. Например, вызов диалогов ввода данных, выдача предупреждений и тому подобные действия. Это относится и ко всем процедурам и функциям, вызываемым в процессе выполнения. Исключение составляет метод глобального контекста Сообщить.

Важно! При проектировании процедур и функций общих модулей следует иметь в виду, что в одном общем модуле не доступны процедуры и функции, объявленные в другом общем модуле с ключевым словом Экспорт.

Глобальный модуль

Глобальный модуль располагается в корневом разделе конфигурации. В нем располагаются процедуры-обработчики событий, которые инициализируются при старте и окончании работы системы. В глобальном модуле возможно объявление переменных, а также объявление и описание процедур и функций, которые будут доступны в любом модуле конфигурации, кроме общих, дополняя глобальный контекст прикладной задачи.

Существует набор правил взаимодействия глобального модуля и общих модулей:

• в общих модулях недоступны переменные, процедуры и функции, объявленные в глобальном модуле с ключевым словом

Экспорт;

• в глобальном модуле доступны процедуры и функции, объявленные в общих модулях с ключевым словом Экспорт;

Модули прикладных объектов

Набор прикладных объектов имеет собственные модули. К таким объектам относятся:

• справочники;

• документы;

• отчеты;

• обработки.

Модули располагаются в ветках конфигурации, в которых содержатся сами объекты и являются свойствами объектов. Каждый объект имеет свой индивидуальный модуль. В этих модулях возможно объявление переменных, процедур и функций, которые будут доступны при работе с объектом извне во встроенном языке, дополняя контекст объекта.

Модули форм

Эти модули содержатся в формах конфигурации. Каждая форма имеет свой индивидуальный модуль. В этих модулях возможно объявление переменных, процедур и функций, которые будут доступны при работе с формой извне во встроенном языке, дополняя контекст формы.


1-008 Формат программного модуля

Формат программного модуля

Исходный текст программного модуля может состоять из операторов и комментариев.

Комментарии

Комментарий используется для размещения в исходном тексте программного модуля всякого рода пояснений к работе модуля. Хорошим тоном программирования считается, когда исходный текст содержит исчерпывающий комментарий с описанием алгоритма. В режиме исполнения программы комментарии пропускаются. В тексте программного модуля комментарий начинается парой символов "//" и заканчивается концом строки. Это значит, что комментарий можно начинать с начала строки или записывать его после оператора на той же строке. После начала комментария писать оператор на той же строке нельзя, необходимо закончить комментарий концом строки.

Пример:

А=В; // Это - комментарий // Это тоже комментарий

Формат операторов

Операторы имеют вид стандартного обращения к процедуре, за исключением оператора присваивания (А = В;) и синтаксических конструкций встроенного языка (например, таких как Для, Пока, Если). Между собой операторы обязательно следует разделять символом ";" (точкой с запятой). Конец строки не является признаком конца оператора, т.е. операторы могут свободно переходить через строки и продолжаться на другой строке. Можно располагать произвольное число операторов в одной строке, разделяя их символом ";".

Операторы языка в программном модуле можно подразделить на две категории: операторы объявления переменных и исполняемые

операторы. Операторы объявления переменных создают имена переменных, которыми манипулируют исполняемые операторы. Любой исполняемый оператор может иметь метку, используемую в качестве точки перехода в операторе Перейти.

В общем случае формат оператора языка следующий:

-метка: Оператор[(параметры) ] [ДобключевоеСлово];

В качестве меток используются специальные идентификаторы, начинающиеся с символа '~' (тильда) и состоящие из последовательности букв, цифр и символов '_' (подчеркивание). Чтобы пометить оператор, надо поместить перед ним метку и следующий за ней символ ":".

Пример:

-метка:А=В;

Имена переменных, процедур и функций

Именем переменной, объявленной процедуры или функции, может быть любая последовательность букв, цифр и знаков подчеркивания "_", начинающаяся с буквы или знака подчеркивания "_". Вновь создаваемые имена не должны совпадать с зарезервированными словами языка или именами свойств, непосредственно доступных в текущем контексте. Распознавание имен переменных, процедур и функций ведется без учета регистра букв.

Язык написания программных модулей

Встроенный язык 1С:Предприятия является двуязычным. Почти все зарезервированные слова, имена типов значений, свойств, методов, событий имеют два имени: русское и английское. Исключение составляю слова, не имеющие аналогов в русском языке. В тесте программных модулей эти имена можно свободно смешивать, используя то русские, то английские имена без каких-либо ограничений.

Регистры букв при написании программных модулей

Регистр букв (строчные или заглавные) при написании имен переменных, свойств, методов, процедур, функций, а также функций встроенного языка не имеет значения.

Зарезервированные слова

Приведенные далее ключевые слова являются зарезервированными и не могут использоваться в качестве создаваемых имен переменных, реквизитов объектов конфигурации и объявляемых процедур и функций. В данном варианте языка каждое из ключевых слов имеет два представления - русское и английское.

Русское имя | Английское имя
Если | If
Тогда | Then
ИначеЕсли | Elsif
Иначе | Else
КонецЕсли | End If
Для | For
Каждого | Each
Из | In
По | To
Пока | While
Цикл | Do
КонецЦикла | End Do
Процедура | Procedure
Функция | Function
КонецПроцедуры | End Procedure
КонецФункции | EndFunction
Перем | Var
Перейти | Goto
Возврат | Return
Продолжить | Continue
Прервать | Break
И | And
Или | Or
Не | Not
Попытка | Try
Исключение | Except
ВызватьИсключение | Raise
КонецПопытки | EndTry
Новый | New
Выполнить | Execute


1-012 Структура программного модуля

Структура программного модуля

Структуру программного модуля можно подразделить на следующие разделы:

• раздел определения переменных;

• раздел процедур и функций;

• раздел основной программы.

В конкретном программном модуле любой из разделов может отсутствовать.

Раздел определения переменных размещается от начала текста модуля до первого оператора Процедура или оператора Функция или любого исполняемого оператора. В этом разделе могут находиться только операторы объявления переменных Перем.

Раздел процедур и функций размещается от первого оператора Процедура или оператора Функция до любого исполняемого оператора вне тела описания процедур или функций.

Раздел основной программы размещается от первого исполняемого оператора вне тела процедур или функций до конца модуля. В этом разделе могут находиться только исполняемые операторы. Раздел основной программы исполняется в момент инициализации модуля. Обычно в разделе основной программы имеет смысл размещать операторы инициализации переменных какими-либо конкретными значениями, которые необходимо провести до первого вызова любой из процедур или функций модуля.

Специальные символы, используемые в исходном тексте

// | Двумя знаками «косая черта» начинается комментарий. Комментарием считается весь текст от знака "//" до конца текущей строки.
| | Вертикальная черта в начале строки используется только в строковых константах и означает, что данная строка является продолжением предыдущей (перенос строки).
~ | Знаком тильда начинается метка оператора.
: | Двоеточием заканчивается метка оператора.
; | Точка с запятой является символом разделения операторов.
() | В круглые скобки заключается список параметров методов, процедур, функций и конструкторов. Также они используются в выражениях встроенного языка.
[] | С помощью оператора «квадратные скобки» производится обращение к свойствам объекта по строковому представлению имени свойства. Также возможно обращение к элементам коллекций по индексу или Другому параметру.
, | Запятая разделяет параметры в списке параметров методов, процедур, функций и конструкторов.
"" | В двойные кавычки заключаются строковые литералы. В одинарные кавычки заключаются литералы даты.
. | Десятичная точка в числовых литералах. Разделитель, используемый для обращения к свойствам и методам объектов встроенного языка.
+ | Символ «плюс» обозначает операцию сложения и конкатенации.
- | Символ «минус» обозначает операцию вычитания.
* | Символ «звездочка» обозначает операцию умножения.
/ | Символ «косая черта» обозначает операцию деления.
> | Правая угловая скобка обозначает логическую операцию «больше».
>= | Логическая операция «больше или равно».
< | Левая угловая скобка обозначает логическую операцию «меньше».
<= | Логическая операция «меньше или равно».
= | Знак равенства обозначает присвоение или логическую операцию «равно».
<> | Две угловые скобки обозначают логическую операцию «не равно».


1-014 Примитивные типы данных

Примитивные типы данных

Во встроенном языке 1C: Предприятия поддерживается набор примитивных типов данных. Для большинства примитивных типов данных предусмотрена возможность использования в тексте модуля литералов, то есть указание значения соответствующего типа непосредственно в модуле.

Пример:

// Пример использования литерала типа Строка А = "Моя строка" ;
// Пример использования литерала типа Булево Б = истина;
// Пример использования
литерала типа Число В = 12345.6789;

Null

Описание:

Значения данного типа используются исключительно для определения отсутствующего значения при работе с базой данных, например, при соединении таблиц.

Литералы:

Null

Булево (Boolean)

Описание:

Значения данного типа имеют два значения Истина и Ложь, задаваемых соответствующими литералами. Значения данного типа возвращаются в качестве результата вычисления логических выражений.

Примечание:

В операциях сравнения встроенного языка используются логические выражения. Это означает, что в выражении сравнения не обязательно писать

Если МояПеременная = Истина Тогда КонецЕсли ;

достаточно написать

Если МояПеременная Тогда КонецЕсли;

Литералы:

Истина(True) Ложь (False)

Дата (Date)

Описание:

Значения данного типа содержит дату от Рождества Христова (с 01 января 0001 года) и время с точностью до секунды.

Литералы:

Срока цифр, заключенная в одинарные кавычки вида:

'YYYYMMDDHHMMSS'

ТПТМ МДДччммсс' где:

• ГГГГ - четыре цифры года (включая век);

• MM - две цифры месяца:

• ДД - две цифры даты;

• чч - две цифры часа (в 24-х часовом формате);

• мм - две цифры минут;

• ее - две цифры секунд;

Допускается при указании литералов типа Дата опускать последние символы (секунды, минуты, часы и т.д.). Это означает, что данные параметры будут равны нулю (для времени) или единице (для даты). В вырожденном случае дата может задаваться как " (две одинарные кавычки подряд), это будет равнозначно дате '00010101000000' или при преобразованию к строке для России -«01.01.0001 0:00:00».

Неопределено (Undefined)

Описание:

Значение данного типа применяются, когда необходимо использовать пустое значение, не принадлежащее ни к одному другому типу. Например, такое значение изначально имеют реквизиты с составным типом значения. Существует одно единственное значение данного типа, задаваемое литералом.

Литералы:

Неопределено (Undefined)

Строка (String)

Описание:

Значения данного типа содержат строку в формате Unicode произвольной длины.

Литералы:

Литералы строкового типа представляют собой набор символов заключенных в кавычки. Для задания в строке символа " (кавычка) необходимо записать две кавычки подряд.

Кроме того, допускаются «многострочные» строковые константы. В исходном тексте многострочные константы могут задаваться двумя способами:

• Между фрагментами, представляющими отдельные строки многострочной строки, не должно встречаться никаких символов, за исключением пробелов, переводов строки и строк комментариев.

• Каждая отдельная составляющая не замыкается кавычками, а на каждой последующей строке помещен символ переноса строки | (горизонтальная черта). В этом варианте комментарии между открывающей и закрывающей кавычками не допускаются.

Пример:

// Пример строки МояСтрока =
"Это правильная строка";
// Пример 1 многострочной строки
МояМногострочнаяСтрока = 'Это
| правильная
| многострочная
| строка" ;

// Пример 2 многострочной строки МояМногострочнаяСтрока = "Это тоже" //Здесь можно указать комментарии
"правильная"
" многострочная"
"строка" ;

// Пример строки с кавычками НазваниеФирмы = "000 "Василек"";

Тип (Type)

Описание:

Значения данного типа используются для идентификации типов значений. Это необходимо для определения и сравнения типов. Данный тип не имеет литералов и возвращается функциями встроенного языка ТипЗнч и Тип (см. ниже).

Число (Number)

Описание:

Числовым типом может быть представлено любое десятичное число. Над данными числового типа определены основные арифметические операции: сложение, вычитание, умножение и деление. Максимально допустимая разрядность числа 38 знаков.

Литералы:

Набор цифр, написанных непосредственно в тексте модуля. В качестве разделителя целой и дробной части используется . (точка).

Пример:

А = 15;
Б = -968.612;


1-018 Оператор присваивания

Оператор присваивания

Синтаксис:

<Назначение> = <Источник>;

Параметры:

<Назначения>

В качестве <Назначения> может выступать переменная или свойство объекта встроенного языка, которое допускает запись.

<Источник>

Выражение, значение которого необходимо присвоить.

Описание:

Оператор присваивания (символ "=") означает присваивание значения <Источник> переменной, обозначенной как <Назначение>.

Пример:

А = В;
Стр1 = "777";
ДатаДокумента= '20020717';

Выражения языка

Выражение — это математическая, логическая или строковая формула, состоящая из соответствующих операций, по которой вычисляется значение. Математическое и логическое выражение может стоять справа от знака равенства в операторах присваивания, быть параметром процедур или функций. Логическое выражение также может быть условием в управляющих конструкциях Если, Пока, Для. Выражения состоят из констант, переменных и функций, связанных символами логических и/или арифметических операций.

Арифметические операции

В языке определены следующие виды арифметических операций:

сложение (Оп1 + Оп2)

вычитание (Оп1 - Оп2)

умножение (Оп1 * Оп2)

деление (Оп1 / Оп2)

остаток от деления (Оп1 % Оп2)

унарный минус (-Оп1)

Арифметические операции имеют один или два операнда, в зависимости от типа которых, операция имеет ту или иную семантику. Тот или иной семантический вариант операции определяется по первому операнду. В случае несовпадения типа второго операнда с требуемым, значение преобразуется к требуемому типу в соответствии с правилами преобразования типов. Если тип первого операнда не соответствует ни одному из допустимых типов, то в зависимости от ситуации может производиться преобразование типов или возбуждаться состояние ошибки выполнения.

Сложение определено для следующих типов операндов:

Число+Число Дата+ Число (к дате прибавляется число дней)

Вычитание определено для следующих типов операндов:

Число-Число Дата-Число (от даты отнимается число дней)

Дата-Дата (результатом является число дней между датами)

Умножение:

Число*Число

Деление:

Число/Число

Остаток от деления:

Число%Число

Замечание! При выполнении операции % (остаток отделения) оба операнда операции округляются до целого значения.

Операция конкатенации

Операция конкатенации ("+") используется для того, чтобы присоединить одну строку к другой. Длина результирующей строки равна сумме длин соединяемых строк. В случае несовпадения типа данных второго или последующих операндов со строковым типом, их значение преобразуется к строковому типу в соответствии с правилами преобразования типов.

Пример:

ФИО = Фамилия + " " + Имя + " " + Отчество;

Логические операции

Логическая операция сравнивает операнды и вырабатывает значение типа Булево: Истина или Ложь. Существует два вида логических операций: операции сравнения и булевы операции. В операциях сравнения сравниваются два значения. Булевы операции выполняются над значениями типа Булево, реализуя булеву алгебру. Символы булевых операций могут комбинироваться, образуя составные операции.

Операции сравнения:

В языке определены следующие виды операций сравнения:

больше (Оп1 > Оп2)
больше или равно (Оп1 >= Оп2)
равно (Оп1 = Оп2)
не равно (Оп1 <> Оп2)
меньше (Оп1 < Оп2)
меньше или равно (Оп1 <= Оп2)

Операции сравнения определены для следующих типов операндов:

больше Число>Число Строка>Строка Дата>Дата
больше или равно: Чиcлo>=Чиcлo Строка> = Строка Дата>=Дата
меньше: Число<Число Строка<Строка Дата<Дата
меньше или равно: Число<=Число Строка<= Строка Дата<=Дата
равно: Любой тип=Любой тип
не равно: Любой тип <> Любой тип

Булевы операции:

В языке определены следующие виды булевых операций:

И (AND) конъюнкция (булево И)
ИЛИ (OR) дизъюнкция (булево ИЛИ)
НЕ (NOT) логическое отрицание (булево отрицание НЕ)

Логические выражения вычисляются слева направо. Для того, чтобы избежать неоднозначности и управлять последовательностью операндов, следует применять круглые скобки.

Уровни старшинства логических операций:

Уровень 1 операнды заключенные в скобки
Уровень 2 НЕ
Уровень 3 И
Уровень 4 ИЛИ

Замечание! При вычислении логического выражения вычисляются только необходимые части выражения. Например, в выражении "(Цена > 0) И ПроверкаСуммы()", если Цена <" 0, то функция ПроверкаСуммы() не вызывается.


1-022 Операторы и синтаксические конструкции

Операторы и синтаксические конструкции

? (вычислить выражение по условию)

Синтаксис:

? {<Логическое выражение>, <Выражение 1>, <Выражение 2>)

Параметры:

<Логическое выражение>

Логическое выражение, результат вычисления которого определяет одно из результирующих выражений, которые будут вычислены. Если результат его вычисления Истина, то будет вычисляться <Выражение 1>. Если результат Ложь - то <Выражение 2>.

<Выражение 1>

Результирующее выражение, которое будет вычисляться, если результат логического выражения Истина.

<Выражение 2>

Результирующее выражение, которое будет вычисляться, если результат логического выражения Ложь.

Возвращаемое значение:

Результат вычисления одного из результирующих выражений.

Описание:

Позволяет вычислить одно из двух заданных выражений в зависимости от результата вычисления логического выражения.

Пример:

Статус = ?(ПолучитьСкидку() > 10, "Особый
клиент", "Обычный клиент");
Предупреждение(Статус)
;

Выполнить (Execute)

Синтаксис:

Выполнить(<Строка>)

Параметры:

<Строка>

Срока, содержащая текст исполняемого кода.

Описание:

Позволяет выполнить фрагмент кода, который передается ему в качестве строкового значения.

Замечание! Исполняемый код не должен содержать в себе отдельных процедур или функций, т.к. исполнение кода само по себе идет в рамках процедуры или функции, в которой использован этот оператор. А также не должен содержать явного объявления переменных.

Важно! Не рекомендуется реализовывать с помощью этого метода существенную часть функциональности прикладных решений.

Пример:

// Выводит в окно сообщений текущую дату.
Выполнить ("Сообщить (ТекущаяДата ())");

Для (For)

Синтаксис:

Для <Имя переменной > = <Выражение 1 > По <Выражение 2> Цикл

// Операторы [Прервать;I

// Операторы [Продолжить ; ]

// Операторы

КонецЦикла ;

Параметры:

<Имя переменной>

Идентификатор переменной (счетчика цикла), значение которой автоматически увеличивается на 1 при каждом повторении цикла.

Так называемый счетчик цикла.

<Выражение 1>

Числовое выражение, которое задает начальное значение, присваиваемое счетчику цикла при первом проходе цикла.

По

Синтаксическая связка для параметра <Выражение 2>.

<Выражение 2>

Максимальное значение счетчика цикла. Когда переменная <Имя переменной> становится больше чем <Выражение 2>, выполнение оператора цикла Для прекращается.

Цикл

Операторы, следующие за ключевым словом Цикл, выполняются, пока значение переменной <Имя переменной> меньше значения <Выражение 2>.

// Операторы

Исполняемый оператор или последовательность таких операторов.

Прервать

Позволяет прервать выполнение цикла в любой точке. После выполнение этого оператора управление передается оператору, следующему за ключевым словом КонецЦикла.

Продолжить

Немедленно передает управление в начало цикла, где производится вычисление и проверка условий выполнения цикла. Операторы, следующие в теле цикла за ним, на данной итерации обхода не выполняются.

КонецЦикла

Ключевое слово, которое завершает структуру оператора цикла.

Описание:

Оператор цикла Для предназначен для циклического повторения операторов, находящиеся внутри конструкции Цикл-КонецЦикла. Перед началом выполнения цикла значение <Выражение 1> присваивается переменной <Имя переменной>. Значение <Имя переменной> автоматически увеличивается при каждом проходе цикла. Величина приращения счетчика при каждом выполнении цикла равна 1. Цикл выполняется пока значение переменной <Имя_переменной> меньше или равно значению <Выражение 2>. Условие выполнения цикла всегда проверяется вначале, перед выполнением цикла.

Пример:

// Перебор дней текущего месяца
ПоследнийДеньМесяца = День(КонецМесяца(РабочаяДата));
Для ТекДень = 1 по
ПоследнийДеньМесяца Цикл
Состояние("Обрабатывается
день: " + ТекДень);
// Операторы обработки
очередного дня месяца
КонецЦикла;


1-026 Операторы и синтаксические конструкции

Для каждого (For each)

Синтаксис:

Для каждого <Имя переменной 1> Из <Имя переменной 2> Цикл

// Операторы [Прервать;]

// Операторы [Продолжить;]

// Операторы

КонецЦикла

Параметры:

<Имя переменной 1>

Переменная, которой при каждом повторении цикла присваивается значение очередного элемента коллекции.

Из

Синтаксическая связка для параметра <Имя переменной 2>.

<Имя переменной 2>

Переменная или выражение, предоставляющее коллекцию. Элементы этой коллекции будут присваиваться параметру <Имя переменной 1>.

Цикл

Операторы, следующие за ключевым словом Цикл, выполняются пока значение переменной <Имя переменной> меньше значения <Выражение 2>.

// Операторы

Исполняемый оператор или последовательность таких операторов.

Прервать

Позволяет прервать выполнение цикла в любой точке. После выполнение этого оператора управление передается оператору, следующему за ключевым словом КонецЦикла.

Продолжить

Немедленно передает управление в начало цикла, где производится вычисление и проверка условий выполнения цикла. Операторы, следующие в теле цикла за ним, на данной итерации обхода не выполняются.

КонецЦикла

Ключевое слово, которое завершает структуру оператора цикла.

Описание:

Оператор цикла Для каждого предназначен для циклического обхода коллекций значений. При каждой итерации цикла возвращается новый элемент коллекции. Обход осуществляется до тех пор, пока не будут перебраны все элементы коллекции.

Пример:

// Перебор строк табличной части документа.
НужныйДокумент = Документы.РасходнаяНакладная.НайтиПоКоду(1234 5);
// Проверим найден нужный нам документ или нет
Если Не НужныйДокумент.Пустая() Тогда
Для каждого СтрокаСостава из НужныйДокумент.Состав Цикл
Состояние("Строка: " + Состав.Индекс(СтрокаСостава) + 1);
// Операторы обработки очередной строки табличной части
КонецЦикла ;

Если (If)

Синтаксис:

Если <Логическое выражение > Тогда

// Операторы [ИначеЕсли] <Логическое выражением Тогда]

// Операторы [Иначе]

// Операторы

КонецЕсли ;

Параметры:

<Логическое выражение>

Логическое выражение.

Тогда

Операторы, следующие за Тогда, выполняются, если результатом логического выражения является значение Истина.

// Операторы

Исполняемый оператор или последовательность таких операторов.

ИначеЕсли

Логическое выражение, следующее за ключевым словом ИначеЕсли вычисляется только тогда, когда условия в Если и всех предшествующих ИначеЕсли оказались равны Ложь. Операторы, следующие за конструкцией ИначеЕсли — Тогда, выполняются, если результат логического выражения в данном ИначеЕсли равен Истина.

Иначе

Операторы, следующие за ключевым словом Иначе, выполняются, если результаты логических выражений в конструкции Если и всех предшествующих конструкциях ИначеЕсли оказались равны Ложь.

КонецЕсли

Ключевое слово, которое завершает структуру оператора условного выполнения.

Описание:

Оператор Если управляет выполнением программы, основываясь на результате одного или более логических выражений. Оператор может содержать любое количество групп операторов, возглавляемых конструкциями ИначеЕсли — Тогда.

Пример:

Если ДеньНедели(РабочаяДата) = 6 Тогда
Сообщить("Сегодня суббота.") ;
ИначеЕсли ДеньНедели(РабочаяДата) = 7 Тогда
Сообщать("Сегодня воскресенье.") ;
Иначе
Сообщить("Сегодня рабочий день.");
КонецЕсли;

Новый (New)

Синтаксис:

Новый <имя типа>[(<Парам 1>, ..., <Парам №>)}

Параметры:

Имя типа

Указывается имя типа, значение которого создается.

<Парам 1>, ..., <Парам N>_

После имени типа в скобках могут указываться параметры, если они определены в конструкторах для данного типа. Допустимое количество параметров и их назначение указывается в описании конструкторов объекта.

Описание:

Оператор позволяет создать значение указанного типа. Допустим только для тех типов, для которых разрешено создание новых значений.

Пример:

// Пример создания массива из трех элементов.
Массив = Новый Массив(З);

См. также:

Встроенные функции языка, функция СоздатьОбъект.

Перейти (Goto)

Синтаксис:

Перейти <Метка>;

Описание:

Безусловная передача управления на другой оператор программы. Передает управление от одного оператора к другому.

Область действия оператора ограничивается программным модулем, процедурой или функцией; он не может передать управление за пределы программного модуля, процедуры или функции.

Замечание! Метка в этом операторе не должна быть меткой перехода на оператор Процедура или Функция.

Замечание! Оператор безусловного перехода не может бьть использован для передачи управления на операторы, находящиеся внутри конструкций: Пока - КонецЦикла, Для КонецЦикла, Для каждого - КонецЦикла, Если КонецЕсли, Попытка - Исключение - КонецПопытки извне этих конструкций.

Пример:

Перейти -Метка1;
- Метка1: Сообщить("Осуществлен переход по метке.");

Перем

Синтаксис:

Перем <Имя переменной 1> [Экспорт] [, <Имя переменной 2>, ...]

Параметры:

<Имя переменной 1>[, <Имя переменной 2>, ...]

Задается имя или имена объявляемых переменных.

Экспорт

Необязательное ключевое слово. Указывает, что данная переменная доступна при обращении к контексту этого модуля из других модулей. Данное ключевое слово необходимо указывать для каждой объявляемой переменной отдельно. Не имеет смысла при объявлении переменных отдельных процедур или функций.

Описание:

Позволяет в явном виде объявить переменную.

Пример:

// Пример объявления одной переменной
Перем А Экспорт;
Перем Б;
// Пример объявления нескольких переменных одним оператором
Перем А, Б Экспорт;

Неявное объявление переменных:

В языке переменные не обязательно объявлять в явном виде. Неявным определением переменной является первое ее появление в левой части оператора присваивания. Тип переменной определяется типом присвоенного ей значения. Не допускается использование в выражениях переменных не объявленных ранее в явном или неявном виде.

Область использования переменной:

Область использования переменных зависит от места их определения в конфигурации задачи. Существует три области, в которых можно объявить переменные:

• В разделе определения переменных глобального программного модуля.

• В разделе определения переменных модуля. Это переменные модуля.

• В процедуре или функции. Это локальные переменные.

Глобальные переменные, объявленные с ключевым словом Экспорт, доступны для использования в исполняемых операторах, выражениях, в любой процедуре и функции любого программного модуля конфигурации задачи.

Переменные модуля доступны для использования в исполняемых операторах, выражениях, в любой процедуре и функции того программного модуля, в пределах которого они объявлены. Если они объявлены с ключевым словом Экспорт, то они доступны из других модулей через контекст модуля, в котором они объявлены.

Локальные переменные доступны в пределах той процедуры или функции, в которой они объявлены.

Если переменная определена как глобальная переменная, то она видна из всех процедур и функций любого программного модуля конфигурации задачи. Если же переменная определена внутри процедуры, то ее областью видимости является данная процедура или функция. Таким образом, если две переменные с одинаковыми именами используются в двух различных процедурах модуля, и имя этой переменной не упоминается как глобальная переменная, то это две различные переменные, локальные для процедур. Если же переменная определена как глобальная переменная, то любое использование имени этой переменной будет приводить к обращению к одной и той же переменной.

Единственный способ создать для процедуры локальную переменную с именем, совпадающим с именем переменной, определенной как глобальная переменная — это объявить ее явно при помощи оператора Перем.


1-033 Операторы и синтаксические конструкции

Пока (While)

Синтаксис:

Пока
<Логическое выражение> Цикл
// Операторы
[Прервать;]
// Операторы
[Продолжить;]
// Операторы
КонецЦикла ;

Параметры:

<Логическое выражение>

Логическое выражение.

Цикл

Операторы, следующие за ключевым словом Цикл, выполняются, пока результат логического выражения равен Истина.

// Операторы

Исполняемый оператор или последовательность таких операторов.

Прервать

Позволяет прервать выполнение цикла в любой точке. После выполнение этого оператора управление передается оператору, следующему за ключевым словом КонецЦикла.

Продолжить

Немедленно передает управление в начало цикла, где производится вычисление и проверка условий выполнения цикла. Операторы, следующие в теле цикла за ним, на данной итерации обхода не выполняются.

КонецЦикла

Ключевое слово, которое завершает структуру оператора цикла.

Описание:

Оператор цикла Пока предназначен для циклического повторения операторов, находящиеся внутри конструкции Цикл КонецЦикла. Цикл выполняется, пока логическое выражение равно Истина. Условие выполнения цикла всегда проверяется вначале, перед выполнением цикла.

Пример:

ВыборкаДок = Документы. РасходнаяНакладная. Выбрать();
// Цикл по всем документам
Пока ВыборкаДок.Следующий() Цикл
// отобразим Документ в строке состояния
Состояние ("Обрабатывается документ: " + ВыборкаДок.Номер);
// Операторы выполнения действий над документом
КонецЦикла;

Попытка (Try)

Синтаксис:

Попытка

// Операторы попытки

Исключение

// Операторы исключения

[ВызватьИсключение ; ]

// Операторы исключения

КонецПопытки ;

Параметры:

// Операторы попытки

Исполняемый оператор или последовательность таких операторов.

Исключение

Операторы, следующие за ключевым словом Исключение, выполняются, если при выполнении последовательности операторов произошла ошибка времени выполнения.

// Операторы исключения

Исполняемый оператор или последовательность операторов, которые обрабатывают исключительную ситуацию.

ВызватьИсключение

Оператор позволяет вызвать исключение, в тех случаях, когда, несмотря на отработку исключительной ситуации операторами исключения, необходимо прервать выполнение модуля с ошибкой времени выполнения. Оператор допустим только внутри операторных скобок Исключение - КонецПопытки.

Выполнение данного оператора прекращает выполнение последовательности операторов исключения и производится поиск более «внешнего» обработчика исключения (при вложенных попытках). Если таковой есть, то управление передается на его первый оператор. Если нет, то исключительная ситуация обрабатывается системно, выдается сообщение о первоначально возникшей ошибке, а выполнение модуля прекращается.

КонецПопытки

Ключевое слово, которое завершает структуру оператора обработки исключительных ситуаций.

Описание:

Оператор Попытка управляет выполнением программы, основываясь на возникающих при выполнении модуля ошибочных (исключительных) ситуациях и определяет обработку этих ситуаций.

В качестве ошибочных (исключительных) ситуаций воспринимаются ошибки времени выполнения модуля. Не предусмотрено определяемых пользователем исключений.

Если при выполнении последовательности операторов попытки произошла ошибка времени выполнения, то выполнение оператора, вызвавшего ошибку, прерывается и управление передается на первый оператор последовательности операторов исключения. При этом управление будет передано даже в том случае, если ошибку вызвал оператор, находящийся в процедуре или функции, вызванной из операторов попытки. Если ошибка произошла в вызванной процедуре или функции, то ее выполнение будет прервано, а локальные переменные - уничтожены. Это справедливо для любой вложенности вызовов. После выполнения последовательности операторов исключения управление передается на следующий за ключевым словом КонецПопытки оператор. Если же последовательность операторов попытки выполнилась без ошибок, то последовательность операторов исключения будет пропущена и управление также будет продолжено с оператора, следующего за ключевым словом КонецПопытки.

Конструкции Попытка - Исключение - КонецПопытки могут быть вложенными. При этом, при возникновении исключительной ситуации управление передается на тот обработчик, в попытке которого произошла ошибка. Если же в последовательности операторов исключения этого обработчика выполняется оператор ВызватьИсключение, выполнение передается вышестоящему обработчику исключения и так далее. Если вышестоящего обработчика нет исключительная ситуация обрабатывается системно с прекращением выполнения программного модуля.

В выдаче диагностики помощь может оказать встроенная функция ОписаниеОшибки (см. описание функций встроенного языка).

Пример:

Процедура СформироватьВЕхсеl()
Попытка
// Пытаемся обратиться к программе MS Excel
Табл = СоздатьОбъект("Excel.Application");
Исключение
Предупреждение(ОписаниеОшибки);
Возврат;
КонецПопытки;
// Операторы формирования отчета
КонецПроцедуры


1-037 Процедура и Функция

Процедура (Procedure)

Синтаксис:

Процедура <Имя_процедуры>([[Знач] <Парам 1> [=<ДефЗнач>], ... , [Знач] <Парам N> [=<ДефЗнач>]])[Экспорт] [Далее]

// Объявления локальных переменных;

// Операторы ;

[Возврат;]

// Операторы ;

КонецПроцедуры

Параметры:

<Имя_процедуры>

Назначает имя процедуры.

Знач

Необязательное ключевое слово, которое указывает на то, что следующий за ним параметр передается по значению, т.е. изменение значения формального параметра при выполнении процедуры никак не повлияет на фактический параметр, переданный при вызове процедуры. Если это ключевое слово не указано, то параметр процедуры передается по ссылке, то есть изменение внутри процедуры значения формального параметра приведет к изменению значения соответствующего фактического параметра.

<Парам 1>, . . . , <Парам N>

Необязательный список формальных параметров, разделяемых запятыми. Значения формальных параметров должны соответствовать значениям передаваемых при вызове процедуры фактических параметров. В этом списке определяются имена каждого из параметров так, как они используются в тексте процедуры. Список формальных параметров может быть пуст.

=<ДефЗнач>

Необязательная установка значения параметра по умолчанию. Параметры с установленными значениями по умолчанию можно располагать в любом месте списка формальных параметров (подробнее см. раздел «Передача параметров процедур и функций»).

Экспорт

Необязательное ключевое слово, которое указывает на то, что данная процедура является доступной из других программных

модулей.

Далее

Ключевое слово обозначающее, что это предварительное описание процедуры. Если в конце описания процедуры строит это ключевое слово, тело процедуры не пишется (подробнее см. раздел «Предварительное описание процедур и функций»).

// Объявления локальных переменных

Объявляются локальные переменные, на которые можно ссылаться только в рамках этой процедуры (см. оператор Перем).

// Операторы

Исполняемые операторы процедуры.

Возврат

Необязательное ключевое слово, которое завершает выполнение процедуры и осуществляет возврат в точку программы, из которой было обращение к процедуре. Использование данного оператора в процедуре не обязательно.

КонецПроцедуры

Обязательное ключевое слово, обозначающее конец исходного текста процедуры, завершение выполнения процедуры. Возврат в точку, из которой было обращение к процедуре.

Описание:

Ключевое слово Процедура начинает секцию исходного текста, выполнение которого можно инициировать из любой точки программного модуля, просто указав Имя_процедуры со списком параметров (если параметры не передаются, то круглые скобки, тем не менее, обязательны). Если в глобальном или общем программном модуле в теле описания процедуры использовано ключевое слово Экспорт, то это означает, что данная процедура является доступной из всех других программных модулей конфигурации.

При выполнении оператора Возврат процедура заканчивается и возвращает управление в точку вызова. Если в тексте процедуры не встретился оператор Возврат, то после выполнения последнего исполняемого оператора происходит выполнение неявного оператора Возврат. Конец программной секции процедуры определяется по оператору КонецПроцедуры.

Переменные, объявленные в теле процедуры в разделе Объявления локальных переменных, являются локальными переменными данной процедуры, поэтому доступны только в этой процедуре (за исключением случая передачи их как параметров при вызове других процедур, функций или методов).

Замечание! ключевые слова Процедура, КонецПроцедуры, являются не операторами, а операторными скобками, поэтому не должны заканчиваться точкой с запятой (это может приводить к ошибкам выполнения модуля).

Пример :

Перем Глоб;
// Описание процедуры
Процедура мояПроцедура(Пар1, Пар2, ПарЗ) Экспорт
Глоб = Глоб + Пар1 + Пар2 + ПарЗ;
Возврат;
КонецПроцедуры
Глоб = 123;
МояПроцедура(5, 6, 7); // Вызов процедуры

Функция (Function)

Синтаксис:

Функция <Имя_функции>([ [Знач] <Парам1>[=<ДефЗнач>], ... , [Знач] <ПарамN[=<ДефЗнач>]])(Экспорт] [Далее]

//Объявления локальных переменных;

// Операторы ;

Возврат <Возвращаемое значение >;

// Операторы ;

КонецФункции

Параметры :

<имя_функции>

Назначает имя функции.

Знач

Необязательное ключевое слово, которое указывает на то, что следующий за ним параметр передается по значению, т.е. изменение значения формального параметра при выполнении функции никак не повлияет на фактический параметр, переданный при вызове функции. Если это ключевое слово не указано, то параметр функции передается по ссылке, то есть изменение внутри функции значения формального параметра приведет к изменению значения соответствующего фактического параметра.

<Парам 1>, ..., <Парам N>

Необязательный список формальных параметров, разделяемых запятыми. Значения формальных параметров должны соответствовать значениям передаваемых при вызове функции фактических параметров. В этом списке определяются имена каждого из параметров так, как они используются в тексте функции. Список формальных параметров может быть пуст.

=<ДефЗнач>

Необязательная установка значения параметра по умолчанию. Параметры с установленными значениями по умолчанию можно располагать в любом месте списка формальных параметров (подробнее см. раздел «Передача параметров процедур и функций»).

Экспорт

Необязательное ключевое слово, которое указывает на то, что данная функция является доступной из других программных модулей.

Далее

Ключевое слово обозначающее, что это предварительное описание функции. Если в конце описания функции строит это ключевое слово, тело функции не пишется (подробнее см. раздел «Предварительное описание процедур и функций»).

// Объявления локальных переменных

Объявляются локальные переменные, на которые можно ссылаться только в рамках этой функции (см. оператор Перем).

// Операторы

Исполняемые операторы функции.

Возврат <Возвращаемое значение>

Ключевое слово, которое завершает выполнение функции и возвращает указанное значение в выражение, в котором используется функция. Использование данного ключевого слова в функции обязательно.

В качестве возвращаемого значения может выступать выражение или переменная, значение которого содержит результат обращения к функции.

КонецФункции

Обязательное ключевое слово, обозначающее конец исходного текста функции.

Описание:

Ключевое слово Функция начинает секцию исходного текста функции, выполнение которой можно инициировать из любой точки программного модуля, просто указав Имя_функции со списком параметров (если параметры не передаются, то круглые скобки, тем не менее, обязательны). Если в глобальном или общем программном модуле в теле описания функции использовано ключевое слово Экспорт, то это означает, что данная функция является доступной из всех других программных модулей конфигурации.

Выполнение функции заканчивается обязательным оператором Возврат. Функции отличаются от процедур только тем, что возвращают ВозвращаемоеЗначение. Конец программной секции функции определяется по оператору КонецФункции.

Вызов любой функции в тексте программного модуля можно записывать как вызов процедуры, т.е. в языке допускается не принимать от функции возвращаемое значение.

Переменные, объявленные в теле функции в разделе Объявления локальных переменных, являются локальными переменными данной функции, поэтому доступны только в этой функции (за исключением случая передачи их как параметров при вызове других процедур, функций или методов).

Замечание! ключевые слова Функция, КонецФункции являются не операторами, а операторными скобками, поэтому не должны заканчиваться точкой с запятой (это может приводить к ошибкам выполнения модуля).

Пример:

Перем Глоб;
// Описание функции
Функция МояФункция(Пар1, Пар2, ПарЗ) Экспорт
Глоб = Глоб + napl + Пар2 + ПарЗ;
Возврат Глоб;
КонецФункции
Глоб =123;
Рез = МояФункция(5, 6, 7); // Вызов функции


1-044 Основные приемы работы

Основные приемы работы

Обращение к свойствам объектов

Помимо основного обращения через точку, в языке 1С:Предприятия предусмотрен механизм обращения к свойствам объектов по строке с именем свойства с помощью оператора [] (квадратные скобки).

Синтаксис:

<Объект> [.<Имя свойства;]

Параметры:

<Объект>

Объект, к свойству которого идет обращение.

[.<Имя свойства;]

Имя свойства, к которому необходимо обратиться.

Описание:

Такая конструкция позволяет обращаться к свойствам объектов так же, как это делается через точку с указанием имени свойства.

Пример:

Спр = Справочники.Номенклатура.НайтиПоКоду(ИскомыйКод);
// Обращение к наименование справочника по строке с именем свойства
А = Спр["Наименование"];
// Обращение к наименованию справочника по имени свойства
А = Спр.Наименование;
// Оба эти обращения к свойству абсолютно равнозначны

Дополнение контекста объектов и форм

В языке есть возможность, при обращении к объектам и формам извне, из других программных модулей, обращаться к переменным, процедурам и функциям этих модулей, как к свойствам и методам самих объектов и форм. Можно обращаться к тем переменным, процедурам и функциям, которые объявлены с ключевым словом Экспорт. Для форм дополнительно возможно обращение к реквизитам формы.

Пример:

// Пример использования
процедуры печати документов из журнала
// документов. Допустим, у нас есть
несколько различных документов,
// причем у всех есть процедура Печать().
Модуле журнала документов
// располагается кнопка «Печать», которая вызывает
процедуру печати
// текущего документа журнала.
Процедура
ПечатьНажатие(Элемент)
// Получим текущий документ, на котором установлен курсор.
ТекДок = ЭлементыФормы.ЖурналСписок.ТекущаяСтрока;
// Получим основную форму текущего документа.
ФрмТекДок = ТекДок.ПолучитьФорму() ;
// Вызовем
процедуру печати, расположенную в модуле формы
документа.
ФрмТекДок.Печать() ;
КонецПроцедуры

Передача параметров процедур и функций

По умолчанию параметры методов, процедур и функций передаются по ссылке, то есть изменение внутри процедуры или функции значения формального параметра ведет к изменению значения соответствующего фактического параметра. При передаче параметра по значению изменение значения формального параметра никак не влияет на фактический параметр вызова процедуры. Для указания того, что тот или иной параметр следует передавать по значению, следует в исходном тексте процедуры или функции перед именем параметра записать ключевое слово Знач

Если параметру задано значение по умолчанию, и он является последним в списке, то при вызове процедуры его можно опускать в списке передаваемых фактических параметров и не ставить запятую перед опущенным параметром.

Если параметру не задано значения по умолчанию, то при вызове процедуры его можно опускать в списке передаваемых фактических параметров, но разделительную запятую надо ставить.

Если параметр при вызове процедуры опущен, то он принимает либо установленное по умолчанию значение (если оно есть) либо значение Неопределено.

Если при вызове метода, процедуры или функции параметры не передаются (пустой список параметров), то, тем не менее, круглые скобки обязательно требуется ставить.

Пример:

Перем
Глоб;
// Описание функции
Функция
МояФункция(Знач Пар1, Пар2, ПарЗ) Экспорт
лок = Глоб + Пар1 + Пар2 + ПарЗ;
Пар1 =40;
Возврат Лок;
КонецФункции
;

// Описание функции
Процедура МояПроцедура(Пар1, Пар2, ПарЗ) Экспорт
Лок = Глоб + Пар1 + Пар2 + ПарЗ;
Пар1 = 40;
КонецПроцедуры ;

Глоб = 100; А = 10;
Рез = МояФункция(А, 10, 10); // Вызов функции
// Здесь Рез =130, а переменная А = 10, несмотря на то, что в теле
// функции значение параметра Пар1 изменено на 40.
МояПроцедура(А, 10, 10); // Вызов процедура
// Здесь переменная А = 40, поскольку в теле
// процедуры значение параметра Пар1 изменено на 40.

Работа с коллекциями значений

Ряд объектов в языке 1С:Предприятия представляют собой коллекции значений. Большинство коллекций имеют набор схожих методов и свойств, таких как Количество(), Индекс(), Добавить(), Удалить() и т.д. В качестве свойств коллекции, как правило, выступают ее элементы. Для коллекций доступен обход элементов коллекции посредством конструкции Для каждого - Из -Цикл. Для большинства коллекций доступно обращение к элементам коллекции с помощью оператора [<Аргумент>] (квадратные скобки). Как правило, в качестве аргумента передается индекс элемента коллекции. Индексирование элементов; коллекции начинается с 0. Это означает, что индекс последнего элемента равен количеству элементов в коллекции минус 1.

Подробнее описание конкретных коллекций, их свойств, методов и приемов работы с ними см. в описаниях конкретных объектов.

Использование номеров и индексов

В языке 1С:Предприятия есть ряд объектов, отдельные части которых имеют нумерацию. К таким объектам, например, относится строка, символы которой имеют номер в строке, или табличный документ, строки и колонки которого имеют номер и т.п. При обращении к частям объектов обычно используется понятие Номер. Номера начинаются с 1.

При обращении к элементам коллекций используется понятие Индекс. Индексирование элементов коллекций начинается с 0.

Работа с системными перечислениями

Во встроенном языке 1С:Предприятия существует понятие системных перечислений. Они предназначены для определения некоторого ограниченного набора предопределенных значений. Доступ к системным перечислениям осуществляется как к свойствам глобального контекста его имени. Конкретные значения указываются через точку от имени системного перечисления. Системные перечисления используются, как правило, для задания значений параметров системных методов или свойств объектов, а также в качестве возвращаемых значений методов.

Использование процедур и функций

В зависимости от установленных компонент можно организовать выполнение различных процедур и функций общих модулей на сервере приложений или клиентском месте.

Для этих целей используют указание препроцессору.

Для выполнения на сервере:

#Если Сервер Тогда
...
#КонецЕсли

Для выполнения на клиентском месте:

#Если Клиент Тогда
...
#КонецЕсли


1-051 Функции работы со значениями типа Строка

Глава 2. Встроенные функции языка

Функции работы со значениями типа Строка

Врег (Upper)

Синтаксис:

Врег(<Строка>)

Параметры:

<Строка> Обязательный

Тип: Строка. Исходная строка.

Возвращаемое значение:

Тип: Строка. Строка, полученная в результате преобразования.

Описание:

Преобразует все символы строки в верхний регистр.

Пример:

ВрегГосНомер = Врег(ОС.Госномер);

КодСимвола (CharCode)

Синтаксис:

КодСимвола(< Строка>, <Номер символа>)

Параметры:

<Строка> Обязательный

Тип: Строка. Исходная строка.

<Номер символа> Необязательный.

Тип: Число. Номер символа в строке, код которого необходимо получить. Нумерация символов в строке начинается с 1.

Значение по умолчанию: 1.

Возвращаемое значение:

Тип: Число. Код переданного символа. Код возвращается в соответствии с кодировкой Unicode.

Описание:

Получает код символа, расположенного в переданной строке в позиции с указанным номером.

Пример:

КодПервогоСимволаФамилия = КодСимвола(Сотрудник.Фамилия);

Лев (Left)

Синтаксис:

Лев (<Строка>, <Число символов>)

Параметры:

<Строка> Обязательный

Тип: Строка. Исходная строка.

<Число символов> Обязательный

Тип: Число. Количество выбираемых символов.

Возвращаемое значение:

Тип: Строка. Строка выбранных символов.

Описание:

Выбирает первые слева символы строки.

Пример:

ИницИмени = Лев(Сотрудник.Имя,
1);
ИницОтчества = Лев(Сотрудник.Отчество,
1);
ФИО
=
Сотрудник.Фамилия + " " + ИницИмени + "."
+ ИницОтчества + ".";

Найти (Find)

Синтаксис:

Найти(<Строка>, <Подстрока поиска>)

Параметры:

<Строка> Обязательный

Тип: Строка. Исходная строка.

<Подстрока поиска> Обязательный

Тип: Строка. Искомая подстрока.

Возвращаемое значение:

Тип: Число. Позиция первого знака найденной подстроки. Нумерация символов в строке начинается с 1. Если не находит -возвращает 0.

Описание:

Находит вхождение искомой строки как подстроки в исходной строке.

Пример:

Если Найти(Сотрудник.ФИО, "Борис") > 0 Тогда
Сообщить(Сотрудник.ФИО + " таб. №" + Сотрудник.Код);
КонецЕсли ;

Hper (Lower)

Синтаксис:

Hpeг(<Строка>)

Параметры:

<Строка> Обязательный

Тип: Строка. Исходная строка.

Возвращаемое значение:

Тип: Строка. Строка, полученная в результате преобразования.

Описание:

Преобразует все символы строки в нижний регистр.

Пример:

НрегГосНомер = Нрег(ОС.Госномер);

Прав (Right)

Синтаксис:

Прав(<Строка>, <Число символов>)

Параметры:

<Строка> Обязательный

Тип: Строка. Исходная строка.

<Число символов> Обязательный

Тип: Число. Количество выбираемых символов.

Возвращаемое значение:

Тип: Строка. Строка выбранных символов.

Описание:

Выбирает последние справа символы строки.

Пример:

// Пусть номер автомобиля в справочнике основных средств задается
//в виде х999хх99, где последние две цифры - код региона.
// Получим код региона из номера.
КодРегиона = Прав(ОС.Госномер,2) ;


1-055 Функции работы со значениями типа Строка

ПустаяСтрока (IsBlankString)

Синтаксис:

ПустаяСтрока(<Строка>}

Параметры:

<Строка>_Обязательный

Тип: Строка. Исходная строка.

Возвращаемое значение:

Тип: Булево. Истина, если строка не содержит значащих символов или не содержит ни одного символа (пустая).

Ложь, если строка содержит значащие символы.

Описание:

Проверяет строку на наличие значащих символов.

Пример:

Если ПустаяСтрока(Сотрудник.Фамилия) Тогда
Предупреждение("Укажите фамилию сотрудника.");
КонецЕсли;

Символ (Char) _

Синтаксис:

Символ(<Код символа>)

Параметры:

<Код символа> Обязательный

Тип: Число. Код получаемого символа. Код задается в соответствии с кодировкой Unicode.

Возвращаемое значение:

Тип: Строка. Результирующий символ.

Описание:

Преобразует код символа в строку, содержащую символ.

Пример:

Буква_я = Символ(1103);

СокрЛ (TrimL)

Синтаксис:

СокрЛ(<Строка>)

Параметры:

<Строка>_обязательный

Тип: Строка. Исходная строка.

Возвращаемое значение:

Тип: Строка. Строка, полученная в результате отсечения пробелов .

Описание:

Отсекает пробелы, стоящие слева от первого значащего символа в строке.

Пример:

НаименованиеДляПечати = СокрЛ(Товар.Наименование);

СокрЛП (TrimAII)

Синтаксис:

СокрЛП(<Строка>)

Параметры:

<Строка>Обязательный

Тип: Строка. Исходная строка.

Возвращаемое значение:

Тип: Строка. Строка, полученная в результате отсечения пробелов .

Описание:

Отсекает пробелы, стоящие слева от первого значащего символа в строке, и пробелы, стоящие справа от последнего значащего символа в строке.

Пример:

НаименованиеДляПечати = СокрЛП(Товар.Наименование);

СокрП (TrimR)

Синтаксис:

СокрП(<Строка>)

Параметры:

<Строка>_Обязательный

Тип: Строка. Исходная строка.

Возвращаемое значение:

Тип: Строка. Строка, полученная в результате отсечения пробелов .

Описание:

Отсекает пробелы, стоящие справа от последнего значащего символа в строке.

Пример:

НаименованиеДляПечати = СокрП(Товар.Наименование);

Сред (Mid)

Синтаксис:

Сред(<Строка>, <Начальный номер> , < Число символов>)

Параметры:

<Строка>_Обязательный

Тип: Строка. Исходная строка.

<Начальный номер> - Обязательный

Тип: Число. Начальный номер символа, с которого начинается выборка. Нумерация символов в строке начинается с 1.

<Число символов Необязательный

Тип: Число. Количество выбираемых символов.

Значение по умолчанию: Если параметр не указан, то выбираются символы до конца строки.

Возвращаемое значение:

Тип: Строка. Строка выбранных символов.

Описание:

Позволяет выбрать строку символов начиная с символа <Начальный номер> общим количеством <Число символов>.

Пример:

// Пусть номер
автомобиля в справочнике основных средств задается
// в виде х999хх99,
где последние две цифры - код региона.
// Получим цифровую часть номера.
ЦифрыНомера = Сред(ОС.Госномер,
2, 3);

СтрДлина (StrLen)

Синтаксис:

СтрДлина (<Строка>)

Параметры:

<Строка>Обязательный

Тип: Строка. Исходная строка.

Возвращаемое значение:

Тип: Число. Длина строки.

Описание:

Позволяет получить количество символов в строке.

Пример:

ДлинаНаименования = СтрДлина (Товар. Наименование);

СтрЗаменить (StrReplace)

Синтаксис:

СтрЗаменить(<Строка>, <Подстрока лоиска> , <Подстрока замены>}

Параметры:

<Строка>_Обязательный

Тип: Строка. Исходная строка.

<Подстрока поиска> _Обязательный

Тип: Строка. Искомая подстрока.

<Подстрока замены> Обязательный

Тип: Строка. Подстрока, на которую будет заменена подстрока поиска.

Возвращаемое значение:

Тип: Строка. Строка, полученная в результате замены.

Описание:

Находит в исходной строке все вхождения подстроки поиска и заменяет ее на подстроку замены.

Пример:

Результат = СтрЗаменить(Номенклатура.Наименование, "_", " ");

СтрПолучитьСтроку (StrGetLine)

Синтаксис:

СтрПолучитьСтроку (< Строка>, <Номер строки>)

Параметры:

<Строка> - Обязательный

Тип: Строка. Исходная строка.

<Номер строки> - Обязательный

Тип: Число. Номер получаемой строки. Нумерация строк в многострочной строке начинается с 1.

Возвращаемое значение:

Тип: Строка. Полученная строка.

Описание:

Позволяет получить строку многострочной строки по номеру.

Пример:

Для х = 1 по СтрЧислоСтрок(ИсхТекст) Цикл
ТекСтр = СтрПолучитьСтроку(ИсхТекст, х);
КонецЦикла;

СтрЧислоВхождений

Синтаксис:

СтрЧислоВхождений(< Строка>, <Подстрока поиска>)

Параметры:

<Строка> - Обязательный

Тип: Строка. Исходная строка.

<Подстрока поиска> - Обязательный

Тип: Строка. Искомая подстрока.

Возвращаемое значение:

Тип: Число. Число вхождений.

Описание:

Позволяет вычислить число вхождений подстроки поиска в исходной строке.

Пример:

Результат = СтрЧислоВхождений(ИсходиыйТекст, "Число");
Сообщить ("Слово "Число" встречается " + Результат + " раз.");

СтрЧислоСтрок (StrLineCount)

Синтаксис:

СтрЧислоСтрок(<Строка>)

Параметры:

<Строка> - Обязательный

Тип: Строка. Исходная строка.

Возвращаемое значение:

Тип: Число. Число строк.

Описание:

Позволяет посчитать число строк в многострочной строке. Строки в многострочной строке разделены символами перевода строк

(Символы.ПС).

Пример:

Для х = 1 по СтрЧислоСтрок(ИсхТекст) Цикл
КонецЦикла;


1-061 Функции работы со значениями типа Число

Функции работы со значениями типа Число

ACos

Синтаксис:

ACos(<Число>)

Параметры:

<Число> - Обязательный

Тип: Число. Аргумент функции. Определен в диапазоне -1 ... 1.

Описание:

Вычисляет арккосинус от аргумента <Число>.

ASin

Синтаксис:

ASin(<Число>)

Параметры:

<Число> - Обязательный

Тип: Число. Аргумент функции. Определен в диапазоне -1 ... 1.

Описание:

Вычисляет арксинус от аргумента <Число>.

ATan

Синтаксис:

ATan(<Число>)

Параметры:

<Число> - Обязательный

Тип: Число. Аргумент функции.

Описание:

Вычисляет арктангенс от аргумента <Число>.

Cos

Синтаксис:

Cos(<Угол>)

Параметры:

<Угол> - Обязательный

Тип: Число. Аргумент функции.

Описание:

Вычисляет косинус от аргумента <Угол>, заданного в радианах.

Exp

Синтаксис:

Exp(<Число>)

Параметры:

<Число> - Обязательный

Тип: Число. Аргумент функции.

Описание:

Вычисляет результат возведения основания натурального логарифма (числа е) в степень <Число>.

Log

Синтаксис:

Log(<Число>)

Параметры:

<Число> - Обязательный

Тип: Число. Исходное число, больше 0.

Возвращаемое значение:

Тип: Число. Значение результата вычисления логарифма.

Описание:

Вычисляет натуральный логарифм числа.

Log10

Синтаксис:

Log10(<Число>}

Параметры:

<Число> - Обязательный

Тип: Число. Исходное число, больше 0.

Возвращаемое значение:

Значение результата вычисления логарифма.

Описание:

Вычисляет десятичный логарифм числа.

Pow

Синтаксис:

Pow(<X>,<Y>)

Параметры:

<X> - Обязательный

Тип: Число. Основание.

<Y> - Обязательный

Тип: Число. Показатель степени.

Возвращаемое значение:

Тип: Число. Результат возведения в степень.

Описание:

Возводит число <X> в степень <Y>.

Sin

Синтаксис:

Sin(<Угол>)

Параметры:

<Угол> - Обязательный

Тип: Число. Аргумент функции.

Описание:

Вычисляет синус от аргумента <Угол>, заданного в радианах.

Sqrt

Синтаксис:

Sqrt(<Число>)

Параметры:

<Число> - Обязательный

Тип: Число. Аргумент функции. Неотрицательное число.

Возвращаемое значение:

Тип: Число. Результат вычисления квадратного корня.

Описание:

Вычисляет квадратный корень числа.

Tan

Синтаксис:

Tan(<Угол>)

Параметры:

<Угол> - Обязательный

Тип: Число. Аргумент функции.

Описание:

Вычисляет тангенс от аргумента <Угол>, заданного в радианах.

Окр (Round)

Синтаксис:

Окр (< Число>, <Разрядность> , <Режим округления>)

Параметры:

<Число> - Обязательный

Тип: Число. Исходное число.

<Разрядность> - Необязательный

Тип: Число. Определяет число знаков дробной части, до которых производится округление. Если параметр отрицательный, то число округляется до соответствующего разряда в целой части, начиная с младших разрядов.

Значение по умолчанию: 0.

<Режим округления> Необязательный

Тип: РежимОкругления. Определяет режим округления. Помимо системного перечисления допускается использование числового параметра: 0 - если при округлении 1.5 = 1;

1 - если при округлении 1.5 = 2.

Значение по умолчанию: Значение, установленное в свойствах конфигурации.

При определении значения параметра используется системное перечисление РежимОкругления (RounoMode).

Перечисление содержит следующие значения:

Окр15как10 - При округлении 1.5 будет округлено до 1.

Окр15как20 - При округлении 1.5 будет округлено до 2.

Возвращаемое значение:

Тип: Число. Число, полученное в результате округления.

Описание:

Округляет исходное число до нужной разрядности в соответствии с заданным режимом округления.

Пример:

// Округлим цену до
сотен рублей
ОкруглЦена = Окр(Цена, -2);
// Округлим цену до копеек
ОкруглЦена = Окр(Цена, 2);

Цел (Int)

Синтаксис:

Цел(<Число>)

Параметры:

<Число> - Обязательный

Тип: Число. Исходное число.

Возвращаемое значение:

Тип: Число. Результат выделения целой части.

Описание:

Возвращает целую часть переданного числа, полностью отсекая дробную часть.

Пример:

МожноКупить = Цел(Наличность/Цена);


1-064 Функции работы со значениями типа Дата

Функции работы со значениями типа Дата

Год

Синтаксис:

Год(<Дата>)

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Число. Год в указанной дате.

Описание:

Определяет год в указанной дате.

День (Day)

Синтаксис:

День(<Дата>)

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Число. День в указанной дате.

Описание:

Определяет день в указанной дате.

ДеньГода (DayOfYear)

Синтаксис:

ДеньГода(<Дата>)

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Число. Номер дня в году.

Описание:

Определяет номер дня в году для указанной даты.

ДеньНедели (WeekDay)

Синтаксис:

ДеньНедели (<Дата>)

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Число. Номер дня недели.

Описание:

Определяет номер дня недели для указанной даты.

ДобавитьМесяц (AddMonth)

Синтаксис:

ДобавитьМесяц (<Дата>, <Число месяцев> )

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

<Число месяцев> - Обязательный

Тип: Число. Количество месяцев, которое необходимо добавить к исходной дате.

Возвращаемое значение:

Тип: Дата. Дата, полученная в результате добавления.

Описание:

Добавляет к указанной дате заданное число месяцев.

КонецГода (EndOfYear)

Синтаксис:

КонецГода(<Дата>)

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Дата. Дата и время конца года.

Описание:

Определяет дату и время конца года для указанной даты.

КонецДня (EndOfDay)

Синтаксис:

КонецДня(<Дата>)

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Дата. Дата и время конца дня.

Описание:

Определяет дату и время конца дня для указанной даты.

КонецКвартала (EndOfQuarter)

Синтаксис:

КонецКвартала(<Дата>)

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Дата. Дата и время конца квартала.

Описание:

Определяет дату и время конца квартала для указанной даты.

КонецМесяца (EndOfMonth)

Синтаксис:

КонецМесяца(<Дата>)

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Дата. Дата и время конца месяца.

Описание:

Определяет дату и время конца месяца для указанной даты.

КонецМинуты (EndOfMinute)

Синтаксис:

КонецМинуты(<Дата>)

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Дата. Дата и время конца минуты.

Описание:

Определяет дату и время конца минуты для указанной даты.

КонецНедели (EndOfWeek)

Синтаксис:

КонецНедели(< Дага>)

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Дата. Дата и время конца недели.

Описание:

Определяет дату и время конца недели для указанной даты.

КонецЧаса (EndOfHour)

Синтаксис:

КонецЧаса(<Дата>)

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Дата. Дата и время конца часа.

Описание:

Определяет дату и время конца часа для указанной даты.


1-070 Функции работы со значениями типа Дата

Месяц (Month)

Синтаксис:

Месяц(<Дата>)

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Число. Месяц в указанной дате.

Описание:

Определяет месяц в указанной дате.

Минута (Minute)

Синтаксис:

Минута (<Дата>)

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Число. Минута в указанной дате.

Описание:

Определяет минуту в указанной дате.

НачалоГода (BeginOfYear)

Синтаксис:

НачалоГода (< Дата> )

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Дата. Дата и время начала года.

Описание:

Определяет дату и время начала года для указанной даты.

НачалоДня (BeginOfDay)_

Синтаксис:

НачалоДня(<Дата>)

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Дата. Дата и время начала дня.

Описание:

Определяет дату и время начала дня для указанной даты.

НачалоКвартала (BeginOfQuarter)

Синтаксис:

НачалоКвартала (< Дата>)

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Дата. Дата и время начала квартала.

Описание:

Определяет дату и время начала квартала для указанной даты.

НачалоМесяца (BeginOfMonth)

Синтаксис:

НачалоМесяца(< Дата>)

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Дата. Дата и время начала месяца.

Описание:

Определяет дату и время начала месяца для указанной даты.

НачалоМинуты (BeginOfMinute)

Синтаксис:

НачалоМинуты (< Дата>)

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Дата. Дата и время начала минуты.

Описание:

Определяет дату и время начала минуты для указанной даты.

НачалоНедели (BeginOfWeek)

Синтаксис:

НачалоНедели(<Дата>)

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Дата. Дата и время начала недели.

Описание:

Определяет дату и время начала недели для указанной даты.

НачалоЧаса (BeginOfHour)

Синтаксис:

НачалоЧаса(<Дата>)

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Дата. Дата и время начала часа.

Описание:

Определяет дату и время начала часа для указанной даты.

Неделя Года (WeekOfYear)

Синтаксис:

НеделяГода(<Дата>)

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Число. Номер недели в году.

Описание:

Определяет номер недели в году для указанной даты.

Секунда (Second)

Синтаксис:

Секунда(<Дата>)

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Число. Секунда в указанной дате.

Описание:

Определяет секунду в указанной дате.

ТекущаяДата (CurrentDate)

Синтаксис:

ТекущаяДата()

Возвращаемое значение:

Тип: Дата. Текущая (системная) дата.

Описание:

Определяет текущую (системную) дату на компьютере.

Час (Hour)

Синтаксис:

Час(<Дата>)

Параметры:

<Дата> - Обязательный

Тип: Дата. Исходная дата.

Возвращаемое значение:

Тип: Число. Час в указанной дате.

Описание:

Определяет час в указанной дате.


1-075 Функции преобразования значений

Функции преобразования значений

Булево (Boolean)

Синтаксис:

Булево(<3начение>}

Параметры:

<3начение>_ Обязательный

Тип: Число. Исходное значение.

Возвращаемое значение:

Тип: Булево. Полученное значение.

Описание:

Преобразует полученный параметр в значение типа Булево.

Преобразование числа в строку производится по следующим правилам:

• 0 преобразуется в Ложь;

• остальные значения преобразуются в Истина.

Дата (Date)

Синтаксис:

Дата(<Значение>)

Параметры:

<3начение> Обязательный

Тип: Строка. Исходное значение.

Возвращаемое значение:

Тип: Дата. Полученное значение.

Описание:

Преобразует полученный параметр в значение типа Дата.

При преобразовании, строка должна содержать дату в каноническом формате "ГГГГММДДччммсс" (см. раздел "Примитивные

типы данных").

Строка (String)

Синтаксис:

Строка(<3начение>)

Параметры:

<3начение> Обязательный

Тип: Произвольный. Исходное значение.

Возвращаемое значение:

Тип: Строка. Полученное значение.

Описание:

Преобразует полученный параметр в значение типа Строка.

При преобразовании к строке числа формируется его полное представление в стандартном читабельном виде, соответствующем национальным установкам.

Преобразование значений типа Булево зависит от национальных установок и содержит строковое представление этих значений.

При преобразовании к строке даты формируется ее полное представление в стандартном читабельном виде, соответствующем национальным установкам.

Преобразование к строке значений остальных типов производится по мере возможности и обычно содержит читабельное представление значения.

Число (Number)

Синтаксис:

Число(<3начение>)

Параметры:

<3начение> Обязательный

Тип: Строка, Булево. Исходное значение.

Возвращаемое значение:

Тип: Число. Полученное значение.

Описание:

Преобразует полученный параметр в значение типа Число.

Значение типа Строка преобразуется в число если строка представляет из себя правильное строковое представление литерала численного типа. В противном случае будет выдано сообщение об ошибке выполнения функции.

Значение типа Булево преобразуется в число по следующим правилам:

• Ложь преобразуется в 0;

• Истина преобразуется в 1.


1-078 Функции форматирования

Функции форматирования

Формат (Format)

Синтаксис:

Формат(<Значение> , <Форматная строка>)

Параметры:

<3начение> - Обязательный

Тип: Число, Дата, Булево. Форматируемое значение.

<Форматная строка> - Необязательный

Тип: Строка. Форматная строка представляет собой строковое значение, включающее параметры форматирования. Параметры форматирования перечисляются через символ ";". Наличие параметра означает отличие форматирования от стандартного. Если параметр не указывается, используется стандартное форматирование.

Каждый параметр задается именем параметра, символом "=" и значением параметра. Значение параметра может указываться в одинарных или двойных кавычках. Это необходимо, если значение параметра содержит символы, используемые в синтаксисе форматной строки. Внутри значения параметра могут указываться произвольные символы, которые при формировании результирующей строки будут отображаться как есть. Таким образом, например, можно указывать разделители часов, минут и секунд при форматировании времени. Если эти символы совпадают с значениями форматной строки их необходимо заключать в одинарные кавычки.

Имена и значения параметров форматной строки:

• Л (L) - Имя языка, страны, для которых будет выполняться стандартное форматирование.

Доступные имена языков:

be_BY - Белорусский (Белоруссия);

de_DE - Немецкий (Германия);

de_LI - Немецкий (Лихтенштейн);

en_GB - Английский (Великобритания);

en_US - Английский (США);

en_ZA - Английский (Южная Африка);

es_ES_MO - Испанский (Испания, современная сортировка);

es_ES_TR - Испанский (Испания, традиционная сортировка);

fi_FI - Финский (Финляндия);

fr_FR - Французский (Франция);

it_IT - Итальянский (Италия);

ru_RU - Русский (Россия);

uk_UA - Украинский (Украина).

• ЧЦ (ND) - Общее число отображаемых десятичных разрядов целой части. Исходное число округляется при этом в соответствии с правилами округления, заданными для конфигурации. Если указан этот параметр, то для отображения дробной части числа обязательно указание параметра ЧДЦ, иначе дробная часть отображаться не будет.

• ЧДЦ (NFD) - Число десятичных разрядов в дробной части. Исходное число округляется при этом в соответствии с правилами округления, заданными для конфигурации.

• ЧС (NS) - Сдвиг разрядов: положительный - деление, отрицательный - умножение. Другими словами, это означает, что исходное число будет умножено или поделено на 10*С, где С - значение параметра по модулю.

• ЧРД (NDS) - Символ-разделитель целой и дробной части.

• ЧРГ (NGS) - Символ-разделитель групп целой части числа.

• ЧН (NZ) - Строка, представляющая нулевое значение числа.

• ЧВН (NLZ) - Нужно ли выводить лидирующие нули. Значение данного параметра не задается, собственно наличие параметра определяет вывод лидирующих нулей.

• ЧГ (NG) - Порядок группировки разрядов числа. В качестве значения указываются числа, через запятую, обозначающие количество группируемых разрядов справа налево. Чтобы указать, что последнее число группировки должно повторяться для всех старших разрядов, то после него через запятую указывается 0.

• ЧО (NN) - Представление отрицательных чисел.

0 - строка вида "(1,1)";

1 - строка вида "-1,1";

2 - строка вида "- 1,1";

3 - строка вида "1,1-";

4 - строка вида "1,1 -".

• ДФ (DP) - Формат даты.

• д (d) - день месяца (цифрами) без лидирующего нуля;

• дд (dd) - день месяца (цифрами) с лидирующим нулем;

• ддд (ddd) - краткое название дня недели;

• дддд (dddd) - полное название дня недели;

• М (М) - номер месяца (цифрами) без лидирующего нуля;

• MM (MM) - номер месяца (цифрами) с лидирующим нулем;

• МММ (МММ) - краткое название месяца;

• ММММ (ММММ) - полное название месяца;

• к(q) - номер квартала в году;

• г (у) - номер года без века и лидирующего нуля;

• гг (уу) - номер года без века с лидирующим нулем;

• гггг (уууу) - номер года с веком;

• ч (h) - час в 12 часовом варианте без лидирующих нулей;

• чч (hh) - час в 12 часовом варианте с лидирующим нулем;

• Ч (H) - час в 24 часовом варианте без лидирующих нулей;

• ЧЧ (HH) - час в 24 часовом варианте с лидирующим нулем;

• м (m) - минута без лидирующего нуля;

• мм (mm) - минута с лидирующим нулем;

• с (s) - секунда без лидирующего нуля;

• сс (ss) - секунда с лидирующим нулем;

• tt - отображение половины дня АМ/РМ (действительно только для языков поддерживающих 12 часовой вариант представления времени).

• ДЛФ (DLF) - Локальный формат даты. Указывается вариант отображения частей даты.

• Д (D) - дата;

• ДД (DD) - длинная дата;

• В (Т) - время, дата может объединяться со временем.

• ДП (DE) - Строка, представляющая пустую дату '00010101000000'.

• БЛ (BF) - Строка, представляющая логическое значение Ложь.

• БИ (ВТ) - Строка, представляющая логическое значение Истина.

Для параметров определяющих отображение нулевого числа и даты '00010101000000' наличие параметра без конкретного значение означает использование стандартного преобразования числа и даты к строке.

Значение по умолчанию: Если параметр не задан, то применяется стандартное форматирование, которое в основном соответствует преобразованию значения к строке. Однако для значений типа Число и Дата по умолчанию (0 и 01.01.0001 00:00:00 соответственно) будет выдаваться пустая строка.

Возвращаемое значение:

Тип: Строка. Строка, полученная в результате форматирования переданного значения.

Описание:

Позволяет сформировать читабельное представление значений. Полезно использование в отчетах и при прочем визуальном отображении значений.

Пример:

// Примеры форматирования чисел
А = Формат(123456.789, "ЧЦ=10; ЧДЦ=2">;
// А = "123 456,79"
А = Формат(123456.789, "ЧРД=--");
// А = "-123 456-789"
А = Формат(-123456.789, "ЧО=0");
// А = "(123 456,789)"

// Примеры форматирования дат
А = Формат('20020820153309', "ДФ="ДД ММММ
ГГГГ Т.' ЧЧ:ММ:СС'"") ;
// А = 20 августа 2002 г. .15:33:09"
А = Формат('20020820153309', "ДФ=" "дд/ММ-ггрг"")
;
// А = 20/08-2002"
А = Формат('20020820153309', "ДЛФ=ДД");
// А = 20 августа 2002 г.";
А = Формат( 20020820153309', "ДЛФ=Д");
// А = 20.08.2002";
А = Формат; 20020820153309', "ДЛФ=В");
// А = 15:33:09";

// Примеры форматирования логических выражений
А = Формат(Истина, "БЛ=Нет; БИ=Есть");
// А = "Есть"


1-084 Прочие встроеннные функции

Прочие

Вычислить (Eval)

Синтаксис:

Вычислить (< Выражение>)

Параметры:

<Выражение> -_Обязательный

Тип:Строка.

Возвращаемое значение:

Результат вычисления выражения. Тип возвращаемого значения зависит от типа выражения.

Описание:

Позволяет выполнить переданное выражение. С помощью метода можно вычислять математические и логические выражения, а также операции конкатенации. Подробнее про выражения см. раздел "Выражения языка".

Пример:

А = Вычислить("500 +
500*20/100") ;
А = Вычислить("Истина и Ложь");
А = Вычислить
("" "Иван"" + "" "" +
""Иванович"");

Макс (Мах)

Синтаксис:

Макс(<Значение 1>, ..., <3начение N> )

Параметры:

<3начение 1>, . .., <3начение N> - Обязательный

Тип: Число, Строка, Дата, Булево. Набор параметров, который определяет перечень значений для сравнения.

Возвращаемое значение:

Возвращается максимальное из полученных значений.

Описание:

Определяет максимальное значение из полученных параметров.

Тот или иной семантический вариант функции определяется по типу данных первого параметра. В случае несовпадения типа второго и последующих параметров с требуемым, их значения преобразуются к требуемому типу в соответствии с правилами преобразования типов. Если тип первого параметра не соответствует ни одному из допустимых типов, то в зависимости от ситуации может производиться преобразование типов или возбуждаться состояние ошибки исполнения.

Пример:

// Пример для чисел
А = Макс(1, 2, 3); // A = 3

//    Пример для строк
А = Макс ("ААА", "БББ", "ЯЯЯ");
// А = "ЯЯЯ"

// Пример для дат
А = Макс('20020715220000', '20020714', '20020714091500'); // А = '20020715220000' .

// Пример для значений булевого типа
А = Макс(Истина, Ложь); // А = Истина

Мин (Min)

Синтаксис:

Мин(<Значение 1>, .. ., <3начение N>)

Параметры:

<3начение 1>, . . ., <Значение N>_- Обязательный

Тип: Число, Строка, Дата, Булево. Набор параметров, который определяет перечень значений для сравнения.

Возвращаемое значение:

Возвращается минимальное из полученных значений.

Описание:

Определяет минимальное значение из полученных параметров.

Тот или иной семантический вариант функции определяется по типу данных первого параметра. В случае несовпадения типа второго и последующих параметров с требуемым, их значения преобразуются к требуемому типу в соответствии с правилами преобразования типов. Если тип первого параметра не соответствует ни одному из допустимых типов, то в зависимости от ситуации может производиться преобразование типов или возбуждаться состояние ошибки исполнения.

Пример:

// Пример для чисел
А = Мин(1, 2, 3);        //
А = 1

// Пример для строк
А = Мин("ААА", "БББ", "ЯЯЯ");
// А = "ААА"
А = Макс('20020715220000', '20020714',
'20020714091500');    // А = '20020714'

// Пример для значений булевого типа
А = Макс(Истина, Ложь); // А = Ложь

ОписаниеОшибки (ErrorDescription)

Синтаксис:

ОписаниеОшибки()

Возвращаемое значение:

Возвращает описание ошибки, такое же, какое было бы выдано в окне сообщений в случае отсутствия обработчика исключительной ситуации, за исключением описания модуля и строки, в которой ошибка возникла.

Описание:

Предназначена для определения описания ошибки. Применять данную функцию имеет смысл только внутри операторных скобок Исключение - КонецПопытки, так как в ином случае она вернет пустую строку. Помогает в выдаче диагностики при возникновении ошибок.

СоздатьОбъект (CreateObject)

Синтаксис:

СоздатьОбъект(<Тип>, <Массив параметров конструкторов>)

Параметры:

<Тил>_Обязательный

Тип: Строка, Тип. Определяет тип создаваемого значения. Может задаваться в виде строки с именем типа или непосредственно значением типа Тип.

<Массив параметров конструкторов>_Не обязательный

Тип: Массив. В качестве второго параметра может быть передан массив, содержащий параметры конструкторов, если таковые допустимы для данного типа.

Возвращаемое значение:

Созданное значение.

Описание:

Позволяет создать значение указанного типа.

Пример:

М = Новый Массив (11) ;
М[0] = "C:\Temp\temp.txt";
Ст = СоздатьОбъект("Файл",М);
Сообщить(Ст.ЭтоКаталог());

Тип (Type)

Синтаксис:

Тип(<Имя типа>)

Параметры:

<Имя типа>Обязательный

Тип: Строка. Имя получаемого типа.

Возвращаемое значение:

Тип: Тип. Полученный тип значения.

Описание:

Позволяет получить тип по его строковому имени.

Пример:

Если ТипЗнч (ТекОбъект) = Тип ("СправочникСсылка. Номенклатура") Тогда
КонецЕсли;

ТипЗнч (TypeOf)

Синтаксис:

ТипЗнч(< Значение>)

Параметры:

<3начение> - Обязательный

Тип: Произвольный. Значение, тип которого необходимо получить.

Возвращаемое значение:

Тип: Тип. Полученный тип значения.

Описание:

Позволяет получить тип полученного значения.

Пример:

Если ТипЗнч (ТекОбъект) = Тип ("СправочникСсылка. Номенклатура") Тогда
КонецЕсли;


1-091 Глава 3. Глобальный контекст. Свойства

Глава 3. Глобальный контекст

Глобальный контекст инициализируется при открытии конфигурации 1C: Предприятия в режиме Предприятия и существует вплоть до ее закрытия. Все свойства, процедуры и функции глобального контекста доступны в любом программном модуле конфигурации.

Доступ к свойствам, процедурам и функциям глобального контекста может осуществляется непосредственно из любого программного модуля, используя их имена (без ссылки на какой-либо объект).

Важно! У всех событий глобального контекста назначены предопределенные процедуры-обработчики. Имена процедур соответствуют именам событий. Все процедуры должны располагаться в глобальном модуле конфигурации.

Свойства

БиблиотекаСтилей (StyleLib)

Использование:

Только чтение.

Описание:

Тип: БиблиотекаСтилей. Используется для доступа к определенным в конфигурации стилям.

См. также:

БиблиотекаСтилей.

ВнешниеОбработки (External Processings)

Использование:

Только чтение.

Описание:

Тип: МенеджерВнешнихОбработок. Используется для доступа к внешним обработкам.

См. также:

МенеджерВнешнихОбработок.

ГлавныйИнтерфейс (Mainlnterface)

Использование:

Только чтение.

Описание:

Тип: Управление интерфейсом. Используется для доступа к определенным в конфигурации пользовательским интерфейсам.

См. также:

Управление интерфейсом.

Документы (Documents)

Использование:

Только чтение.

Описание:

Тип: ДокументыМенеджер. Используется для доступа к определенным в конфигурации документам.

См. также:

ДокументыМенеджер.

ЖурналыДокументов

Использование:

Только чтение.

Описание:

Тип: ЖурналыДокументовМенеджер. Используется для доступа к определенным в конфигурации журналам документов.

См. также:

ЖурналыДокументовМенеджер.

ИспользованиеРабочейДаты (WorkingDateUse)

Использование:

Только чтение.

Описание:

Тип: системное перечисление РежимРабочейДаты. Определяет режим использования рабочей даты.

См. также:

Глобальный контекст, свойство РабочаяДата.

Константы (Constants)

Использование:

Только чтение.

Описание:

Тип: КонстантыМенеджер. Используется для доступа к определенным в конфигурации константам.

См.также:

КонстантыМенеджер.

КритерииОтбора (Filters)

Использование:

Только чтение.

Описание:

Тип: КритерииОтбораМенеджер. Используется для доступа к определенным в конфигурации критериям отбора.

См.также:

КритерииОтбораМенеджер.

Метаданные (Metadata)

Использование:

Только чтение.

Описание:

Тип: Объект описания конфигурации. Используется для доступа к структуре метаданных конфигурации.

См. также:

Объект описания конфигурации.

Обработки (Processings)

Использование:

Только чтение.

Описание:

Тип: ОбработкиМенеджер. Используется для доступа к определенным в конфигурации обработкам.

См. также:

ОбработкиМенеджер.

Отчеты (Reports)

Использование:

Только чтение.

Описание:

Тип: ОтчетыМенеджер. Используется для доступа к определенным в конфигурации отчетам.

См. также:

ОтчетыМенеджер.

Перечисления (Enums)

Использование:

Только чтение.

Описание:

Тип: ПеречисленияМенеджер. Используется для доступа к определенным в конфигурации перечислениям.

См.также:

ПеречисленияМенеджер.

ПланыВидовРасчета

Использование:

Только чтение.

Описание:

Тип: ПланыВидовРасчетаМенеджер. Используется для доступа к менеджеру всех планов видов расчета.

РабочаяДата (WorkingDate)

Использование:

Чтение и запись.

Описание:

Тип: Дата. Содержит рабочую дату, используемую в текущем сеансе работы с конфигурацией. Доступно для записи в случае, если свойство ИспользованиеРабочейДаты имеет значение Назначать.

См. также:

Глобальный контекст, свойство ИспользованиеРабочейДаты.

РегистрыНакопления (AccumulationRegisters)

Использование:

Только чтение.

Описание:

Тип: РегистрыНакопленияМенеджер. Используется для доступа к определенным в конфигурации регистрам накопления.

См. также:

РегистрыНакопленияМенеджер.

РегистрыРасчета

Использование:

Только чтение.

Описание:

Тип: РегистрыРасчетаМенеджер. Используется для доступа к менеджеру всех регистров расчета.

РегистрыСведений (InformationRegisters)

Использование:

Только чтение.

Описание:

Тип: РегистрыСведенийМенеджер. Используется для доступа к определенным в конфигурации регистрам сведений.

См. также:

РегистрыСведенийМенеджер.

Справочники (Catalogs)

Использование:

Только чтение.

Описание:

Тип: СправочникиМенеджер. Используется для доступа к определенным в конфигурации справочникам.

См. также:

СправочникиМенеджер.


1-098 Процедуры и функции интерактивной работы

Процедуры и функции интерактивной работы

Вопрос (DoQueryBox)

Синтаксис:

Вопрос(<Текст вопроса> , <Режим>, <Таймаут>)

Параметры:

<Текст вопроса> - Обязательный

Тип: Строка. Текст задаваемого вопроса.

<Режим> - Обязательный

Тип: системное перечисление РежимДиалогаВопрос. Задает состав кнопок диалога и возможные варианты ответов.

<Таймаут> - Необязательный

Тип: Число. Интервал времени в секундах, в течение которого система будет ожидать ответа пользователя. По истечении интервала окно вопроса будет закрыто.

Значение по умолчанию: Если параметр не указан или равен 0, то время ожидания не ограничено.

Возвращаемое значение:

Тип: системное перечисление КодВозвратаДиалога. В зависимости от реакции пользователя возвращается одно из значений системного перечисления.

Описание:

Выводит на экран окно вопроса.

Пример:

Режим = РежимДиалогаВопрос.ДаНет;
Ответ = Вопрос("Продолжить выполнение операции?",
Режим,0) ;
Если Ответ = КодВозвратаДиалога.Нет Тогда
Возврат ;
КонецЕсли ;

См. также:

Глобальный контекст, метод Предупреждение.

ОбработкаПрерыванияПользователя

Синтаксис:

ОбработкаПрерыванияПользователя()

Описание:

Метод предназначен для прерывания работы встроенного языка при нажатии пользователем комбинации клавиш Ctrl+Break.

Метод проверяет, была ли нажата пользователем комбинация Ctrl+Break. Если да, то выполнение встроенного языка прекращается и выдается соответствующее сообщение. Рекомендуется использовать в длительных циклических операциях. Метод будет иметь действия, если операция инициирована определенным интерактивным действием пользователя:

- нажатие кнопки на форме;
- выбор пункта меню или кнопки панели инструментов (форме или интерфейса);
- действия инициируемые обработчиками событий "Выбор" элементов управления.

Пример:

// ТабДокФ - элемент управления типа "Табличный документ";
ТабДок = ЭлементФормы.ТабДокФ;
Выборка = Справочник.Номенклатура.Выбрать();
Пока Выборка.Следующий() Цикл
Если Выборка.ПометкаУдаления Тогда
Продолжить;
КонецЕсли;
Секция = Макет.ПолучитьОбласть("Строка");
Секция.Параметры.СвойствоТекст = Выборка.Наименование;
ТабДок.Вывести(Секция);
ОбработкаПрерыванияПользователя();
КонецЦикла;

Оповестить (Notify)

Синтаксис:

Оповестить(<Имя события> , <Параметр> , <Источник>)

Параметры:

<Имя события> - Необязательный

Тип: Строка. Имя события. Может быть использовано для идентификации сообщений принимающими их формами.

<Параметр> - Необязательный

Тип: Произвольный. Параметр сообщения. Могут быть переданы любые необходимые данные.

<Источник>_- Необязательный

Тип: Произвольный. Источник события. Например, в качестве источника может быть указана другая форма.

Описание:

Посылает оповещение всем открытым формам. Если для формы задана процедура-обработчик события ОбработкаОповещения, то она будет запущена, в процедуру будут переданы указанные параметры.

Данный механизм может, например, применяться для организации обмена сообщениями между открытыми формами.

Пример:

Оповестить("ЗакрытьФорму", ЭтаФорма);

См. также:

Форма, событие ОбработкаОповещения.

ОткрытьЗначение (OpenValue)

Синтаксис:

ОткрытьЗначение (< Значение>)

Параметры:

<3начение> - Обязательный

Тип: Произвольный. Значение любого типа, который может быть показан системой в диалоге.

Описание:

Показывает в диалоге переданное значение. Вид диалога зависит от типа переданного значения.

Пример:

Товар = Справочники.Номенклатура.НайтиПоКоду(КодТовара);
ОткрытьЗначение(Товар);

ОткрытьИндексСправки (OpenHelpIndex)

Синтаксис:

ОткрытьИндексСправки(<Текст для поиска>)

Параметры:

<Текст для поиска> (необязательный)

Тип: Строка. Начальный текст для позиционирования в списке ключевых слов и выражений справки по приложению.

Возвращаемое значение:

Тип: Булево.

Описание:

Открывает окно со списком ключевых слов и выражений (индексом) справки по приложению.

ОткрытьСодержаниеСправки (OpenHelpContent)

Синтаксис:

ОткрытьСодержаниеСправки()

Возвращаемое значение:

Тип: Булево.

Описание:

Открывает окно с содержанием справки по приложению.

ОткрытьСправку (OpenHelp)

Синтаксис:

ОткрытьСправку(<Объект метаданных>)

Параметры:

<Объект метаданных> (необязательный)

Тип: Объект описания метаданного. Объект метаданных, по которому требуется вывести справочную информацию.

Возвращаемое значение:

Тип: Булево.

Описание:

Открывает окно со справочной информацией по объекту метаданных.

Пример:

ОткрытьСправку (Метаданные.Справочник.Контрагенты);

ОчиститьСообщения (ClearMessages)

Синтаксис:

ОчиститьСообщения()

Описание:

Очищает окно сообщений.

Пример:

ОчиститьСообщения();

Предупреждение (DoMessageBox)

Синтаксис:

Предупреждение (< Текст предупреждения> , <Таймаут>}

Параметры:

<Текст предупреждения> - Обязательный

Тип: Строка. Текст предупреждения.

<Таймаут> - Необязательный

Тип: Число. Интервал времени в секундах, в течение которого система будет ожидать ответа пользователя. По истечении интервала окно предупреждения будет закрыто.

Значение по умолчанию: Если параметр не указан или равен 0, то время ожидания не ограничено.

Описание:

Выводит на экран окно предупреждения.

Пример:

Предупреждение("Выберите документ!", 10);

Сигнал (Веер)

Синтаксис:

Сигнал()

Описание:

Воспроизводит звуковой сигнал. Устройство, воспроизводящее звук, а также характер звукового сигнала зависят от программно-аппаратного состава компьютера и звуковых установок ОС.

Пример:

Сигнал() ;

Сообщить (Message)

Синтаксис:

Сообщить(<Текст сообщения>, <Статус>)

Параметры:

<Текст сообщения> - Обязательный

Тип: Строка. Текст сообщения.

<Статус> - Необязательный

Тип: системное перечисление СтатусСообщения. Статус сообщения, определяет вид пиктограммы.

Значение по умолчанию: Обычное.

Описание:

Выводит текст сообщения в окно сообщений. Если в момент вызова окно сообщений отсутствует, то будет открыто новое окно сообщений. Сообщение, в зависимости от его смысловой нагрузки, можно пометить одной из пиктограмм, входящих в предопределенный набор.

Пример:

Сообщить("Выбранный товар отсутствует на складе!", СтатусСообщения.Важное) ;

Состояние (Status)

Синтаксис:

Состояние(<Техст сообщения>)

Параметры:

<Текст сообщения> Необязательный

Тип: Строка. Строка, предназначенная для вывода в строку состояния.

Значение по умолчанию: Если параметр не указан, возобновляется вывод системного текста в окно состояния.

Описание:

Выводит текст в строку состояния.

Пример:

Состояние("Выполняется обновление информационной базы');


1-105 Функции для вызова диалога ввода данных

Функции для вызова диалога ввода данных

ВвестиДату (InputDate)

Синтаксис:

ВвестиДату(<Дата>, <Подсказка>, <Часть даты>)

Параметры:

<Дата> Обязательный

Тип: Дата. Имя доступной в модуле переменной. В эту переменную будет помещено введенное значение даты. Начальное значение переменной будет использовано в качестве начального значения в диалоге.

<Подсказка> Необязательный

Тип: Строка. Текст заголовка окна диалога ввода даты. Может использоваться в качестве подсказки пользователю.

Значение по умолчанию: Пустая строка.

<Часть даты> Необязательный

Тип: ЧастиДаты. Вводимая в диалоге часть (или части) даты. Значение по умолчанию: ДатаВремя.

При определении значения параметра используется системное перечисление ЧастиДаты (DateFractions) . Перечисление содержит следующие значения:

Время (Time) - Значение состоит только из времени (без даты).
Дата (Date) - Значение состоит только из даты (без времени).
ДатаВремя (DateTime) - Значение состоит из даты и времени.

Возвращаемое значение:

Тип: Булево. Истина - дата введена. Ложь - пользователь отказался от ввода даты.

Описание:

Вызывает диалог для ввода даты.

Пример:

ДатаНапоминания = РабочаяДата;
Подсказка = "Введите дату и время";
ЧастьДаты = ЧастиДаты.ДатаВремя;
Если ВвестиДату(ДатаНапоминания,
Подсказка, ЧастьДаты) Тогда
// запомнить дату напоминания
КонецЕсли ;

ВвестиЗначение (InputValue)

Синтаксис:

ВвестиЗначение(< Значение>, <Подсказка>, <Тмп>)

Параметры:

<3начение> Обязательный

Тип: Произвольный. Имя доступной в модуле переменной. В эту переменную будет помещено введенное значение. Если параметр Тип не задан или имеет пустое значение, тип данной переменной используется в качестве типа вводимого в диалоге данного. Начальное значение переменной будет использовано в качестве начального значения в диалоге.

<Подсказка> Необязательный

Тип: Строка. Текст заголовка окна диалога ввода значения. Может использоваться в качестве подсказки пользователю.

Значение по умолчанию: Пустая строка

<Тип> Необязательный

Тип: Тип, ОписаниеТипов. Тип вводимого значения.

Значение по умолчанию: Если параметр не указан, используется тип параметра <3начение>

Возвращаемое значение:

Тип: Булево. Истина - в диалоге было введено значение, Ложь - пользователь отказался от ввода значения.

Описание:

Вызывает диалог для ввода значения заданного типа.

Пример:

ВыбЗнач = "" ;
М = Новый Массив;
М.Добавить(Тип("Число"));
М.Добавить(Тип("Строка"));
М.Добавить(Тип("Дата"));
КЧ = Новый КвалификаторыЧисла(12,2);
КС = Новый КвалификаторыСтроки(20);
КД = Новый КвалификаторыДаты(ЧастиДаты.Дата);
ОписаниеТипов = Новый ОписаниеТипов (М,КЧ, КС, КД);
Если
ВвестиЗначение(ВыбЗнач, "Введите значение", ОписаниеТипов) Тогда
//
обработка введенного значения
КонецЕсли;

ВвестиСтроку (InputString)

Синтаксис:

ВвестиСтроку(< Строка>, <Подсказка>, <Длина>, <Многострочность>}

Параметры:

<Строка> Обязательный

Имя доступной в модуле переменной. В эту переменную будет помещена введенная в диалоге строка. Начальное значение переменной будет использовано в качестве начального значения в диалоге.

<Подсказка> Необязательный

Тип: Строка. Текст заголовка окна диалога ввода строки. Может использоваться в качестве подсказки пользователю.

Значение по умолчанию: Пустая строка.

<Длина> Необязательный

Тип: Число. Длина вводимой строки.

Значение по умолчанию: Если параметр не указан или 0 - строка неограниченной длины.

<Многострочность> Необязательный

Тип: Булево. Признак ввода многострочного текста: Истина -ввод многострочного текста с разделителями строк, Ложь -ввод простой строки.

Значение по умолчанию: Ложь.

Возвращаемое значение:

Тип: Булево. Истина - строка введена. Ложь - пользователь отказался от ввода строки.

Описание:

Вызывает диалог для ввода строки.

Пример:

Текст = "";
Подсказка = "Введите текст напоминания";
Если ВвестиСтроку (Текст,Подсказка, 0, истина) Тогда
// запомнить текст напоминания
КонецЕсли;

ВвестиЧисло (InputNumeric)

Синтаксис:

ВвестиЧисло(< Число, <Подсказка>, <Длина>, <Точность>)

Параметры:

< Число> Обязательный

Тип: Число. Имя доступной в модуле переменной. В эту переменную будет помещено введенное число. Начальное значение переменной будет использовано в качестве начального значения в диалоге.

<Подсказка> Необязательный

Тип: Строка. Текст заголовка окна диалога ввода числа. Может использоваться в качестве подсказки пользователю.

Значение по умолчанию: Пустая строка.

<Длина> Необязательный

Тип: Число. Длина вводимого числа включая дробную часть (символы разделителей не учитываются).

Значение по умолчанию: 0.

<Точность> Необязательный

Тип: Число. Количество знаков в дробной части вводимого числа.

Значение по умолчанию: 0.

Возвращаемое значение:

Тип: Булево. Истина - число введено, Ложь - пользователь отказался от ввода.

Описание:

Вызывает диалог для ввода числа.

Пример:

КолВо = 1;
Если ВвестиЧисло(КолВо, "Введите количество", 10, 2) Tогда
// обработка введенного количество
КонецЕсли;


1-110 Функции форматирования и обращения к конфигурации

Функции форматирования

НСтр (NStr)

Синтаксис:

НСтр(<Исходная строка>)

Параметры:

< Исходная строка > Обязательный

Тип: Строка. Строки на разных языках, разделенные символом ";" (точка с запятой). Строка на одном языке состоит из кода языка, указанного в метаданных, символа "=" (равно) и собственно строки текста на данном языке в одинарных кавычках, двойных кавычках или без кавычек.

Возвращаемое значение:

Тип: Строка. Строка, соответствующая языку пользователя или основному языку конфигурации.

Описание:

Позволяет получить строку на языке пользователя или основном языке конфигурации из набора строк на разных языках конфигурации.

Пример:

Текст = "ru = "Добрый вечер!""; en = ""Good Evening!"";
Сообщить(Нстр(Текст)) ;

ПредставлениеПериода

Синтаксис:

ПредставлениеПериода(<ДатаНачалаПериода>, <ДатаОкончанияПериода>, <Форматная строка>)

См. ХЕЛП:

ЧислоПрописью (SpellNumeric)

Синтаксис:

ЧислоПрописью(<Число>, <Форматная строка> , <Параметры предмета исчисления> )

Параметры:

<Числе> Обязательный

Тип: Число. Число, которое необходимо преобразовать в строку прописью.

<Форматная строка> Необязательный

Тип: Строка. Форматная строка представляет собой строковое значение, включающее параметры форматирования. Параметры форматирования перечисляются через символ ";" (точка с запятой). Если параметр не указывается, используется значение параметра по умолчанию.

Каждый параметр задается именем параметра, символом "=" (равно) и значением параметра. Значение параметра может указываться в одинарных или двойных кавычках. Это необходимо, если значение параметра содержит символы, используемые в синтаксисе форматной строки.

• Л (L) - Код локализации. По умолчанию используется код локализации, установленный в операционной системе. Примеры кодов локализации: ru_RU - Русский (Россия); en_US -Английский (США). Все доступные коды локализации для преобразования числа в пропись указаны в файле loclinfo.txt, входящем в комплект поставки системы 1C: Предприятие.

• НП (SN) - Включать/не включать название предмета исчисления (логический), по умолчанию - Истина.

• НД (FN) - Включать/не включать название десятичных частей предмета исчисления (логический), по умолчанию -Истина.

• ДП (FS) - Дробную часть выводить прописью/числом (логический), по умолчанию - Ложь.

<Параметры предмета исчисления> Обязательный

Тип: Строка. Представляет собой строковое значение, определяющее параметры предмета исчисления. Параметры предмета исчисления перечисляются через "," (запятая). Формат строки зависит от кода локализации.

• Для русского языка формат следующий: "рубль, рубля, рублей, м, копейка, копейки, копеек, ж, 2", где

• "рубль, рубля, рублей, м" - предмет исчисления целой части, а "копейка, копейки, копеек, ж, 2" - дробная часть (может отсутствовать).

• рубль - единственное число именительный падеж;

• рубля - единственное число винительный падеж;

• рублей - множественное число винительный падеж;

• м - мужской род (ж - женский род);

• копейка - единственное число именительный падеж;

• копейки - единственное число винительный падеж;

• копеек - множественное число винительный падеж;

• ж - женский род (м - мужской род);

• 2 - количество разрядов дробной части (может отсутствовать, по умолчанию равно 2).

• Для английского языка формат следующий: "dollar, dollars, cent, cents, 2", где "dollar, dollars" - предмет исчисления целой части, a "cent, cents, 2" - дробная часть.

• dollar - единственное число;

• dollars - множественное число;

• cent - единственное число;

• cents - множественное число;

• 2 - количество разрядов дробной части (может отсутствовать, по умолчанию равно 2).

Ознакомиться со всеми доступными вариантами форматной строки для преобразования числа в пропись можно в файле loclinfo.txt, входящим в комплект поставки системы 1 С: Предприятие.

Возвращаемое значение:

Тип: Строка. Представление числа прописью.

Описание:

Формирует представление числа прописью в соответствии с заданными форматной строкой и параметрами предмета исчисления.

Пример:

// Пример форматной строки для вывода-числа прописью на
русском
// языке, с выводом целой и дробной части прописью и выводом
//
предмета исчисления.
ФормСтрока = "Л = ru_RU;
ДП = Истина";
ПарПредмета = 'рубль, рубля,
рублей, м, копейка, копейки, копеек, ж";
ПрописьЧисла = ЧислоПрописью(2341.56,
ФормСтрока,
ПарПредмета);
// "Две тысячи триста сорок один рубль пятьдесят
шесть копеек"

Функции обращения к конфигурации

ПолучитьОбщийМакет(ОеЮоттопТетр1а1е)

Синтаксис:

ПолучитьОбщийМакет(<Общий макет>)

Параметры:

<Общий макет> Обязательный

Тип: Строка, Объект описания метаданного. Имя общего макета, как оно задано в конфигураторе или объект описания метаданного общего макета.

Возвращаемое значение:

Тип: ТабличныйДокумент. Макет табличного документа.

Описание:

Позволяет получить один из общих макетов конфигурации.

Пример:

// Получение общего макета по имени
МакетСтруктурыКонфигураци = ПолучитьОбщийМакет("СтруктураКонфигурации");

// Получение общего макета по объекту описания негаданного
МакетСтруктурыКонфигураци = ПолучитьОбщийМакет(Метаданные.ОбщиеМакеты.СтруктураКонфигурации) ;

ПолучитьОбщуюФорму (GetCommonForm)

Синтаксис:

ПолучитьОбщуюФорму(<Форма>, <Владелец>, <Ключ уникальности>)

См. ХЕЛП:


1-114 Процедуры и функции сеанса работы

Процедуры и функции сеанса работы

ЗаблокироватьРаботуПользователя (LockUserWork)

Синтаксис:

ЗаблокироватьРаботуПользователя()

Описание:

Блокирует работу пользователя, минимизирует окно 1C: Предприятия и выводит диалог авторизации. Продолжение работы возможно только после ввода пароля.

ЗавершитьРаботуСистемы (ExitSystem)_

Синтаксис:

ЗавершитьРаботуСистемы (<Запрашивать возможности>)

Параметры:

<3апрашивать возможность> Необязательный

Тип: Булево. Если значение параметра Истина, то будет выполняться запрос возможности закрытия для каждого открытого окна и для всего приложения. Если Ложь, то завершение работы программы будет выполнено безусловно.

Значение по умолчанию: Истина.

Описание:

Позволяет принудительно вызвать завершение работы 1C: Предприятия. В зависимости от переданного параметра может выполнять запросы на возможность закрытия окон и завершения работы системы или завершить работу безусловно.

Пример:

// безусловное завершение работы программы
ЗавершитьРаботуСистемы();

ИмяКомпьютера (ComputerName)

Синтаксис:

ИмяКомпьютера()

Возвращаемое значение:

Тип: Строка. Сетевое имя компьютера.

Описание:

Получает сетевое имя компьютера.

Пример:

СетевоеИмяКомпьютера = ИмяКомпьютера();

Имя Пользователя (UserName)

Синтаксис:

ИмяПользователя()

Возвращаемое значение:

Тип: Строка. Имя пользователя.

Описание:

Получает имя пользователя, указанного при запуске программы.

Пример:

ТекущийПользователь = ИмяПользователя();

См. также:

Глобальный контекст, метод ПолноеИмяПользователя.

КаталогВременныхФайлов (TempFilesDir)

Синтаксис:

КаталогВременныхФайлов()

Возвращаемое значение:

Тип: Строка. Имя каталога временных файлов программы.

Описание:

Получает имя каталога, который используется программой для размещения временных файлов.

Пример:

ГдеИскать = КаталогВременныхФайлов();

КаталогПрограммы (BinDir)

Синтаксис:

КаталогПрограммы()

Возвращаемое значение:

Тип: Строка. Имя каталога исполняемых файлов программы.

Описание:

Получает имя каталога, в котором расположены исполняемые файлы программы.

Пример:

ГдеИскать = КаталогПрограммы();

ОтключитьОбработчикОжидания

Синтаксис:

ОтключитьОбработчикОжидания(<Имя процедуры>)

Параметры:

<Имя процедуры> Обязательный

Тип: Строка. Имя процедуры глобального или общего модуля, используемой в качестве обработчика ожидания.

Описание:

Отключает подключенный ранее при помощи процедуры ПодключитьОбработчикОжидания вызов процедуры через определенный интервал времени.

Пример:

Процедура ОтчетОПродажахЗаДень()
// ...
КонецПроцедуры;
//...
ПодключитьОбработчикОжидания("ОтчетОпродажахЗаДень", 60);
//...
ОтключитьОбработчикОжидания("ОтчетОпродажахЗаДень");

См. также:

Глобальный контекст, метод ПодключитьОбработчикОжидания.

ПодключитьОбработчикОжидания (AttachldleHandler)

Синтаксис:

ПодключитьОбработчикОжидания(< Имя процедуры> , <Интервал>)

Параметры:

<Имя процедуры>_ Обязательный

Тип: Строка. Имя процедуры глобального или общего модуля.

<Интервал> Обязательный

Тип: Число. Интервал времени в секундах, через который будет осуществляться вызов процедуры (положительное число).

Описание:

Подключает вызов указанной процедуры глобального или общего модуля через определенный интервал времени. Вызов будет осуществляться только в "состоянии покоя", то есть в тот момент, когда программа не выполняет никаких действий.

Пример:

Процедура ОтчетОПродажахЗаДень()
// .. .
КонецПроцедуры;
//...
ПодключитьОбработчикОжидания("
ОтчетОпродажахЗаДень", 60);

См. также:

Глобальный контекст, метод ОтключитьОбработчикОжидания.

ПолноеИмяПользователя (UserFullName)

Синтаксис:

ПолноеИмяПользователя()

Возвращаемое значение:

Тип: Строка. Полное имя пользователя.

Описание:

Получает полное имя пользователя, указанного при запуске программы.

Пример:

ФИОПользователя = ПолноеИмяПользователя();

См. также:

Глобальный контекст, метод ИмяПользователя.

ПолучитьЗаголовокСистемы (GetSystemCaption)

Синтаксис:

ПолучитьЗаголовокСистемы()

Возвращаемое значение:

Тип: Строка. Заголовок главного окна программы.

Описание:

Получает текст заголовка главного окна программы.

Пример:

СтарыйЗаголовок =
ПолучитьЗаголовокСистемы();
НовыйЗаголовок = СтарыйЗаголовок + " " + ИмяПользователя();
УстановитьЗаголовокСистемы(НовыйЗаголовок);

См. также:

Глобальный контекст, метод УстановитьЗаголовокСистемы.

ПравоДоступа (AccessRight)

Синтаксис:

ПравоДоступа(<Право>, <Объект метаданного> )

Параметры:

<Право> Обязательный

Тип: Строка. Название права доступа. Могут быть использованы следующие значения:

• "Проведение" ("Post") - проведение документов;

• "ОтменаПроведения" ("Unpost") - отмена проведения документов;

• "УправлениеИтогами" ("TotalsControl") - управление итогами;

• "ИнтерактивноеПроведение" ("InteractivePost") - интерактивное проведение;

• "ИнтерактивнаяОтменаПроведения" ("InteractiveUnpost") -интерактивная отмена проведения;

• "ИнтерактивноеОткрытиеВнешнихОбработок" - интерактивное открытие внешних обработок;

• "Чтение" ("Read") - чтение;

• "Добавление" ("Insert") - добавление;

• "Изменение" ("Update") - изменение;

• "Удаление" ("Delete") - удаление;

• "Использование" ("Use") - использование;

• "Просмотр" ("View") - просмотр;

• "ИнтерактивноеДобавление" ("Interactivelnsert") - интерактивное добавление;

• "Редактирование" ("Edit") - редактирование;

• "ИнтерактивноеУдаление" ("InteractiveDelete") - интерактивное непосредственное удаление;

• "ИнтерактавнаяПометкаУдаления" - интерактивная пометка на удаление;

• "ИнтерактивноеСнятиеПометкиУдаления" - интерактивное снятие пометки на удаление;

• "Интерактивное УдалениеПомеченных" - интерактивное удаление помеченных объектов;

• "Администрирование" ("Administration") - администрирование;

• "МонопольныйРежим" ("ExclusiveMode") - использование монопольного режима;

• "АктивныеПользователи" ("ActiveUsers") - просмотр списка активных пользователей.

<0бъект метаданных> Обязательный

Тип: Объект описания метаданного. Объект метаданных.

Возвращаемое значение:

Тип: Булево. Истина - есть право доступа. Ложь - нет права доступа.

Описание:

Определяет установку права доступа к объекту метаданных для текущего пользователя.

Примечание:

Права доступа к объектам метаданных устанавливаются при конфигурировании ролей.

Пример:

ТипСправочника = Метаданные.Справочники.Конкуренты;
Если Не ПравоДоступа ("Чтение" , ТипСправочника) Тогда
Предупреждение ("Доступ: к данному справочнику закрыт!");
КонецЕсли;

ПрекратитьРаботуСистемы (TerminateSystem)

Синтаксис:

ПрекратитьРаботуСистемы()

Описание:

Завершает работу системы не зависимо от наличия модальных диалогов, открытых редактируемых форм документов и справочников и т.д. При этом не вызываются процедуры-обработчики событий завершения работы системы.

РольДоступна (IsRoleAvailable)

Синтаксис:

РольДоступна(< Роль>)

Параметры:

<Роль> Обязательный

Тип: Строка, Объект описания метаданного. Название роли как она задана в конфигураторе или объект описания метаданного роли.

Возвращаемое значение:

Тип: Булево. Истина - роль доступна текущему пользователю, Ложь - роль текущему пользователю не доступна.

Описание:

Определяет доступность указанной роли текущему пользователю.

Пример:

Если Не РольДоступна("Менеджер") Тогда
Сообщить("Просмотр заявок от покупателей: не разрешен!");
КонецЕсли;

УстановитьЗаголовокСистемы

Синтаксис:

УстановитьЗаголовокСистемы(< Заголовок>)

Параметры:

<3аголовок> Обязательный

Тип: Строка. Текст, устанавливаемый в качестве заголовка главного окна программы.

Описание:

Устанавливает новый заголовок главного окна программы.

Пример:

НовыйЗаголовок = "Торговый дом";
УстановитьЗаголовокСистемы(НовыйЗаголовок)
;

См. также:

Глобальный контекст, метод ПолучитьЗаголовокСистемы.


1-123 Процедуры и функции сохранения значений

Процедуры и функции сохранения значений

ВосстановитьЗначение (RestoreValue)

Синтаксис:

ВосстановитьЗначение(< Имя>)

Параметры:

<Имя> Обязательный

Тип: Строка. Имя сохраненного значения.

Возвращаемое значение:

Тип: Произвольный. Восстановленное значение; если восстановить не удалось, то Неопределено.

Описание:

Получает значение, сохраненное ранее с помощью процедуры СохранитьЗначение.

Пример:

СрокИсполнения = ВосстановитьЗначение("СрокИсполненияЗаказа");
ДатаИсполнения = ДатаДокумента + Макс(СрокИсполнения, 5);

См. также:

Глобальный контекст, метод СохранитьЗначение.

ЗначениеВСтрокуВнутр

Синтаксис:

ЗначениеВСтрокуВнутр(<Значение>}

Параметры:

<3начение> Обязательный

Тип: Произвольный. Преобразуемое значение.

Возвращаемое значение:

Тип: Строка. Системное представление значения в информационной базе.

Описание:

Получает системное строковое представление переданного значения.

См. также:

Глобальный контекст, метод ЗначениеИзСтрокиВнутр.

ЗначениеВФайл (ValueToFile) _

Синтаксис:

ЗначениеВФайл(< Имя файла>, <3начение>}

Параметры:

<Имя файла> Обязательный

Тип: Строка. Имя файла. Не может быть пустым. Если включает путь к существующему каталогу, то значение будет сохранено в файле, созданном или найденном в этом каталоге, в противном случае будет использован каталог исполняемых файлов программы.

<3начение> Обязательный

Тип: Произвольный. Сохраняемое значение.

Возвращаемое значение:

Тип: Булево, Истина - сохранение значения выполнено, Ложь - сохранение значения не выполнено.

Описание:

Позволяет сохранить любое значения в файле.

См. также:

Глобальный контекст, метод ЗначениеИзФайла.

ЗначениеИзСтрокиВнутр (ValueFromStringlntemal)_

Синтаксис:

ЗначениеИзСтрокиВнутр(<Строка>)

Параметры:

<Строка> Обязательный

Тип: Строка. Системное представление значения в строковом виде.

Возвращаемое значение:

Тип: Произвольный. Значение, полученное из строкового системного представления.

Описание:

Преобразует значение из строкового системного представления во внутреннее.

Примечание:

Строковое представление данных имеет специальный системный формат, использующий идентификацию данных внутри одной информационной базы.

См. также:

Глобальный контекст, метод ЗначениеВСтрокуВнутр.

ЗначениеИзФайла (ValueFromFHe)

Синтаксис:

ЗначениеИзФайла(< Имя файла>)

Параметры:

<Имя файла> Обязательный

Тип: Строка. Имя файла. Не может быть пустым. Если включает путь к существующему каталогу, то значение будет извлекаться из файла, найденного в этом каталоге, в противном случае будет использован каталог исполняемых файлов программы.

Возвращаемое значение:

Тип: Произвольный.

Описание:

Получает из файла значение, ранее сохраненное в нем при помощи функции ЗначениеВФайл. Тип возвращаемого значения определяется типом значения, сохраненного в файле.

См. также:

Глобальный контекст, метод ЗначениеВФайл.

СохранитьЗначение (SaveValue)

Синтаксис:

СохранитьЗначение(<Имя>, <3начение>)

Параметры:

<Имя> Обязательный

Тип: Строка. Имя, с которым сохраняется значение, используется для идентификации сохраняемых значений.

<3начение> Обязательный

Тип: Произвольный. Сохраняемое значение.

Описание:

Сохраняет значение для использования не только в текущем, но и в последующих сеансах работы с программой. Значение хранится индивидуально для каждой пары информационная база - пользователь. Например, можно сохранять значения по умолчанию, используемые данным пользователем.

Пример:

СохранитьЗначение("СрокИсполненияЗаказа", СрокИсполнения);
СохранитьЗначение("СкладПоУмолчанию", МестоХранения);

См. также:

Глобальный контекст, метод ВосстановитьЗначение.


1-127 Процедуры и функции работы с операционной системой и внешними компонентами

Процедуры и функции работы с операционной системой

ЗапуститьПриложение (RunApp)

Синтаксис:

ЗапуститьПриложение (<Строка команды>)

Параметры:

<Строка команды> Обязательный

Тип: Строка. Командная строка для запуска приложения либо имя файла, ассоциированного с некоторым приложением.

Описание:

Выполняет запуск внешнего приложения либо открытие файла с использованием ассоциированного с ним приложения.

Примечание:

В отличие от функции КомандаСистемы запуск приложения выполняется непосредственно, минуя командный интерпретатор.

Пример:

// открытие файла MS Excel
ЗапуститьПриложение("Таблица.xls");

КомандаСистемы (System)

Синтаксис:

КомандаСистемы (< Строка команды>)

Параметры:

<Строка команды> _Обязательный

Тип: Строка. Команда системы.

Описание:

Вызывает на исполнение команду операционной системы, как если бы она была введена в командной строке.

Примечание:

После загрузки Windows-приложения управление возвращается в 1C: Предприятие и исполнение модуля продолжается.

Пример:

// получение/установка текучего системного времени
КомандаСистемы( "time" );

Процедуры и функции работы с внешними компонентами

ЗагрузитьВнешнююКомпоненту

Синтаксис:

ЗагрузитьВнешнююКомпоненту(< Имя файла>)

Параметры:

<Имя файла> Обязательный

Тип: Строка. Имя файла внешней компоненты.

Возвращаемое значение:

Истина - компонента успешно загружена. Ложь - при загрузке компоненты произошла ошибка.

Описание:

Загружает внешнюю компоненту и подключает ее объекты к 1С:Предприятию. Файл внешней компоненты должен находиться в каталоге исполняемых файлов программы.

Примечание:

Внешние компоненты совместимы с компонентами 1С:Предпрятия 7.7.

Пример:

Попытка
ЗагрузитьВнешнююКомпоненту("scanopos.dll");
Сообщить('Компонента scanopos загружена");
Исключение
Сообщить("Компонента scanopos не найдена!", '!');
КонецПопытки

См. также:

Глобальный контекст, метод ПодключитьВнешнююКомпоненту.

Глобальный контекст, событие ОбработкаВнешнегоСобытия.

ПодключитьВнешнююКомпоненту (AttachAddIn)

Синтаксис:

ПодключитьВнешнююКомпоненту (< Идентификатор объекта>)

Параметры:

<Идентификатор объекта> Обязательный

Тип: Строка. ProgID (Programmatic Identifier) объекта внешней компоненты. Должно соответствовать информации, находящейся в регистрационной базе данных системы (Registry).

Возвращаемое значение:

Истина - компонента успешно подключена. Ложь - при подключении компоненты произошла ошибка.

Описание:

Подключает объекты внешней компоненты к 1C:Предприятию.

Примечание:

Внешние компоненты совместимы с компонентами 1С:Предпрятия 7.7.

Пример:

Попытка
ПодклочитьВнешнююКомпоменту("Addin .Scanner");
Сообщить ("Компонента для сканера штрих-кодов загружена");
Исключение
Сообщить("Компонента для сканера штрих-кодов не загружена");
КонецПопытки

См.также:

Глобальный контекст, метод ЗагрузитьВнешнююКомпоненту.

Глобальный контекст, событие ОбработкаВнешнегоСобытия.


1-130 Процедуры и функции работы с файлами

Процедуры и функции работы с файлами

КопироватьФайл (FileCopy)

Синтаксис:

КопироватьФайл(< Имя файла источника> , <Имя файла приемника>)

Параметры:

<Имя файла источника> Обязательный

Тип: Строка. Полное имя файла-источника.

<Имя файла приемника> Обязательный

Тип: Строка. Полное имя файла-приемника.

Описание:

Позволяет скопировать файл-источник в файл-приемник.

Примечание:

Не допускается перезапись файла-приемника, т.е. его не должно быть до исполнения метода.

Файл-приемник при создании будет иметь права доступа, аналогичные назначаемым при создании новых файлов (т.е. права доступа к файлу-источнику не копируются).

Пример:

КопироватьФайл("С:\Тетр\Order.htm1", "С:\Му Documents\Order.htm1");

НайтиФайлы (FindFiles)

Синтаксис:

НайтиФайлы(< Путь>, <Маска>)

Параметры:

<Путь> Обязательный

Тип: Строка. Путь к каталогу, в котором производится поиск.

<Маска> Необязательный

Тип: Строка. Маска выбора файлов. В строке маски допускается использование символа "*" (звездочка), обозначающего любое число произвольных символов, и "?" (знак вопроса), обозначающего один произвольный символ.

Возвращаемое значение:

Тип: Массив. Массив из значений типа Файл, содержащий найденные файлы.

Описание:

Позволяет найти файлы и каталоги по заданной маске, лежащие в заданном каталоге.

Пример:

НайденныеФайлы = НайтиФайлы("С:\Temp", "*.cdx");

ПереместитьФайл (MoveFile)

Синтаксис:

ПереместитьФайл (< Имя файла источника> , <Имя файла приемника> )

Параметры:

<Имя файла источника> Обязательный

Тип: Строка. Полное имя файла-источника (полное исходное имя файла).

<Имя файла приемника> Обязательный

Тип: Строка. Полное имя файла-приемника (полное новое имя файла).

Описание:

Позволяет выполнить перемещение (переименование) указанного файла.

Пример:

ПереместитьФайл ("С: \Temp\Order.htm", "С:\Му Documents\Order.htm") ;

СоздатьКаталог (CreateDirectory)

Синтаксис:

СоздатьКаталог(< Имя каталога>)

Параметры:

<Имя каталога> Обязательный

Тип: Строка. Полное имя создаваемого каталога.

Описание:

Создает новый каталог файлов.

Пример:

СоздатьКаталог ("С:\_1CV80");

УдалитьФайлы (DeleteFiles)

Синтаксис:

УдалитьФайлы(<Путь>, <Маска>)

Параметры:

<Путь> Обязательный

Тип: Строка. Путь к удаляемым файлам.

<Маска> Необязательный

Тип: Строка. Маска для выбора удаляемых файлов. В строке маски допускается использование символа "*" (звездочка), обозначающего любое число произвольных символов, и "?" (знак вопроса), обозначающего один произвольный символ.

Описание:

Позволяет удалить указанные файлы.

Примечание:

Для удаления одного файла, можно передать его полное имя через первый параметр, либо передать путь к нему через первый параметр, а его короткое имя - через второй.

Пример:

УдалитьФайлы("С:\ Temp", "*. cdx");


1-132 Процедуры и функции работы с информационной базой

Процедуры и функции работы с информационной базой

ЗаписьЖурналаРегистрации (WriteLogEvent)

Синтаксис:

ЗаписьЖурналаРегистрации(<Событие>, <Уровень>, <Объект метаданных>, <Данные>, <Комментарий>)

ЗафиксироватьТранзакцию

Синтаксис:

ЗафиксироватьТранзакцию()

Описание:

Завершает успешную транзакцию. Все изменения, внесенные в информационную базу в процессе транзакции, будут записаны.

Пример:

ЗафиксироватьТранзакцию();

См. также:

Глобальный контекст, метод НачатьТранзакцию.
Глобальный контекст, метод ОтменитьТранзакцию.

МонопольныйРежим (ExclusiveMode)

Синтаксис:

МонопольныйРежим()

Возвращаемое значение:

Тип: Булево. Истина - используется монопольный режим, Ложь - монопольный режим не используется.

Описание:

Проверяет, используется ли в данный момент монопольный режим работы с информационной базой.

Пример:

Если МонопольныйРежим() Тогда
// Выполнить обработку
Иначе
Текст = "Для выполнения обработки необходим монопольный режим";
Предупреждение(Текст, 10);
КонецЕсли;

НачатьТранзакцию (BeginTransaction)

Синтаксис:

НачатьТранзакцию()

Описание:

Открывает транзакцию. Транзакция предназначена для записи в информационную базу согласованных изменений. Все изменения, внесенные в информационную базу после начала транзакции, будут затем либо целиком записаны, либо целиком отменены.

Пример:

// Увеличение закупочной цены
на 5%
ВыборкаТоваров
= Справочники. Номенклатура. Выбрать();
НачатьТранзакцию();
Пока
ВыборкаТоваров.Следующий() Цикл
ТоварОбъект = ВыборкаТоваров.ПолучитьОбъект();
ЗакупочнаяЦена = ТоварОбъект.ЗакупочнаяЦена;
Если ЗахупочнаяЦена <> 0 Тогда
ТоварОбъект.ЗакупочнаяЦена =
ЗакупочнаяЦена * 1.05;
ТоварОбъект.Записать();
КонецЕсли;
КонецЦикла;
ЗафиксироватьТранзакцио();

См. также:

Глобальный контекст, метод ЗафиксироватьТранзакцию.

Глобальный контекст, метод ОтменитьТранзакцию.

ОтменитьТранзакцию (RollBackTransaction)

Синтаксис:

ОтменитьТранзакцию()

Описание:

Отменяет открытую ранее транзакцию. Все изменения, внесенные в информационную базу в процессе транзакции, будут отменены.

Пример:

Если ОбнаруженыОшибки Тогда
ОтменитьТранзакцию();
КонецЕсли;

См. также:

Глобальный контекст, метод НачатьТранзакцию.

Глобальный контекст, метод ЗафиксироватьТранзакцию.

ПолучитьОперативнуюОтметкуВремени (GetOperativeTimestamp)

Синтаксис:

ПолучитьОперативнуюОтметкуВремени()

УстановитьМонопольныйРежим (SetExclusiveMode)

Синтаксис:

УстановитьМонопольныйРежим(< Монопольный режим> }

Параметры:

<Монопольный режим> Обязательный

Тип: Булево. Истина - установить монопольный режим, Ложь - снять монопольный режим.

Описание:

Устанавливает и отключает использование монопольного режима работы с информационной базой.

Примечание:

Монопольный режим может быть установлен, если в данный момент в режиме 1С:Предприятие с данной информационной базой работает только один пользователь, в сеансе работе которого устанавливается монопольный режим. Если установить монопольный режим не удалось, то будет выдано сообщение об ошибке.

Пример:

Попытка
УстановитьМонопольныйРежим(Истина);
Исключение
Текст = "С информационной базой работают другие пользователи.
| В данный момент невозможно установить монопольный режим";
Предупреждение(Текст, 10);
КонецПопытки;

Процедуры и функции работы с данными информационной базы

НайтиПомеченныеНаУдаление (FindMarkedForDelete)

Синтаксис:

НайтиПомеченныеНаУдаление()

Возвращаемое значение:

Тип: Массив. Массив со списком ссылок помеченных на удаление объектов.

Описание:

Находит все помеченные на удаление объекты

Пример:

ПомеченныеОбъекты = НайтиПомеченныеНаУдаление();
Для Каждого ПомеченныйЭлемент Из ПомеченныеОбъекты Цикл
Сообщить ("Помечен на удаление:" + ПомеченныйЭлемент);
КонецЦикла ;

НайтиПоСсылкам (FindDataByRef)

Синтаксис:

НайтиПоСсылкам (< Список ссылок> )

Параметры:

<Список ссылок> Обязательный

Тип: Массив. Массив со списком ссылок на объекты, ссылки на которые нужно найти.

Возвращаемое значение:

Тип: ТаблицаЗначений. Таблица значений, состоящая из колонок с индексами: 0 - Искомая ссылка; 1 - Ссылка на объект, который содержит искомую ссылку.

Описание:

Осуществляет поиск ссылок на объекты.

Пример:

Ссылки = НайтиПомечеаныеНаУдаление();
ТабСсылок = НайтиПоСсылкам (Ссылки);
Для Каждого Ссылка из ТабСсылок Цикл
Сообщить (" " + Сокр(Ссылка[0]) + " " + Сокр(Ссылка[1]));
КонецЦикла;

УдалитьОбъекты (DeleteObjects)

Синтаксис:

УдалитьОбъекты (< Список ссылок> , <Проверять> , <Найденные данные> )

Параметры:

<Список. ссылок> Обязательный

Тип: Массив. Список ссылок на объекты, которые нужно удалить.

<Проверять> Необязательный

Тип: Булево. Параметр определяет, выполнять ли контроль ссылочной целостности при выполнении процедуры. Истина -перед удалением проверяется, нет ли ссылок на удаляемый объект. Если есть, то объект не удаляется, а ссылки помещаются в таблицу значений <Найденные данные>. Ложь - проверка не выполняется.

Значение по умолчанию: Ложь.

<Найденные данные> Необязательный

Тип: ТаблицаЗначений. Таблица значений, в которую помещаются найденные ссылки на объект, содержит колонки с индексами:

0 - Искомая ссылка, 1 - Ссылка на объект, который содержит искомую ссылку.

Описание:

Удаляет объекты.

Пример:

// удаление помеченных объектов с
контролем ссылочной целостности
Помеченные = НайтиПомеченныеНаУдаление();
Найденные = 0;
УдалитьОбъекты(Помеченные, Истина,
Найденные);
Для Каждого Ссылка из Найденные Цикл
СтрНеУдален = "Объект не удален:
" + Сокр(Ссылка[0]);
СтрСсылка = ", используется в
" + Сокр(Ссылка.[1]);
Сообщить (СтрНеУдален + СтрСсылка);
КонецЦикла ;


1-139 События

События

ПередНачаломРаботыСистемы(BeforeStartSystem)

Синтаксис:

ПередНачаломРаботыСистемы (<Отказ>)

Параметры:

<Отказ>

Тип: Булево. Отказ от запуска программы. Если в теле процедуры-обработчика присвоить данному параметру значение Истина, то программа не будет запущена.

Описание:

Возникает при запуске в режиме 1С:Предприятие до открытия главного окна. В процедуре-обработчике данного события могут быть выполнены необходимые проверки и, при необходимости, установлен параметр отказа от запуска программы.

Примечание:

В данной процедуре не допускаются открытие форм и других окон, не поддерживаются выдача сообщений, установка строки состояния, а также другие действия, требующие наличия главного окна.

См. также:

Глобальный контекст, событие ПриНачалеРаботыСистемы.

ПриНачалеРаботыСистемы (OnStartSystem)

Синтаксис:

ПриНачалеРаботыСистемы()

Описание:

Возникает при запуске в режиме 1С:Предприятие после открытия главного окна. В процедуре-обработчике могут быть выполнены

различные действия, необходимые при запуске программы, например, открыты некоторые формы.

См.также:

Глобальный контекст, событие ПередНачаломРаботыСистемы.

ПередЗавершениемРаботыСистемы (BeforeFinishSystem)

Синтаксис:

ПередЗавершениемРаботыСистемы(< Отказ>)

Параметры:

<Отказ>_

Тип: Булево. Отказ от выхода из программы. Если параметру присвоить значение Истина, то работа с программой не будет завершена.

Описание:

Возникает перед завершением работы в режиме 1С:Предприятие до закрытия главного окна. В процедуре-обработчике могут быть выполнены необходимые проверки и, при необходимости, может быть установлен параметр отказа от выхода из программы.

См. также:

Глобальный контекст, событие ПриЗавершенииРаботыСистемы.

ПриЗавершенииРаботыСистемы (OnFinishSystem)

Синтаксис:

ПриЗавершенииРаботыСистемы ()

Описание:

Возникает перед завершением работы в режиме 1С:Предприятие после закрытия главного окна. В данной процедуре могут быть выполнены действия, необходимые при выходе из программы.

Примечание:

В данной процедуре не допускаются открытие форм и других окон, не поддерживаются выдача сообщений, установка строки состояния, а также другие действия, требующие наличия главного окна.

См. также:

Глобальный контекст, событие ПередЗавершениемРаботыСистемы.

ОбработкаВнешнегоСобытия (ProcessExtemalEvent)

Синтаксис:

ОбработкаВнешнегоСобытия (< Источник> , <Событие> ,<Данные> )

Параметры:

<Источник>

Тип: Строка. Источник события.

<Событие>_

Тип: Строка. Наименование события.

<Данные>

Тип: Строка. Данные для события.

Описание:

Возникает при посылке внешним приложением сообщения, сформированного в специальном формате. Внешнее событие сначала обрабатывается всеми открытыми формами, имеющими процедуру-обработчик этого события, а затем может быть обработано в процедуре-обработчике глобального модуля.

См. также:

Форма, событие ОбработкаВнешнегоСобытия.

Глобальный контекст, метод ЗагрузитьВнешнююКомпоненту.

Глобальный контекст, метод ПодключитьВнешнююКомпоненту.


1-143 Глава 4. Общие объекты

Глава 4. Общие объекты

В этой главе освещены основные объекты встроенного языка 1С:Предприятия. Эти объекты могут использоваться при решении практически любых прикладных задач, независимо от направленности конфигурации. К таким объектам относится табличный документ, текстовый документ, объекты для работы с метаданными и т.д.

ХранилищеЗначения (ValueStorage)

Объект предназначен для хранения значения в специальном формате. Он может быть записан в поля информационной базы, имеющие соответствующий тип. Это позволят сохранять в информационной базе значения, тип которых не может быть выбран в качестве типа поля, например, Картинка.

Большинство объектов, которые имеют неизменяемое значение, также универсальные коллекции может быть преобразовано в значение ХранилищеЗначения. К значению, хранящемуся в объекте нельзя обращаться, его можно только извлечь из хранилища.

Замечание! Не рекомендуется хранить в реквизитах типа ХранилищеЗначения ссылки на другие объекты информационной базы.

Важно! В системе не поддерживается ссылочная целостность по объектам, сохраненным в информационной базе в полях типа ХранилищеЗначений. Это означает, что при попытке удаления, например, элементов справочников система не контролирует ссылки на эти элементы, сохраненные в ХранилищеЗначений.

Пример:

МояКартинка = Новый
Картинка("С:\Мои рисунки\Картинка1.bmр");
ХранилищеКартинки = Новый
ХранилищеЗначения(МояКартинка);
НовНоменклатура = Справочники.
Номенклатура. СоздатьЭлемент() ;
НовНоменклатура.Наименование = "Диван
""Маргарита""";
НовНоменклатура.Изображение = ХранилищеКартинки;
НовНоменклатура.Записать();

Методы

Получить (Get)

Синтаксис:

Получить()

Возвращаемое значение:

Тип: Произвольный. Значение, содержащееся в хранилище.

Описание:

Метод позволяет извлечь из хранилища сохраненное в нем значение.

Пример:

МояКартинка = ХраиилищеКартинки.Получить();

Конструкторы

Основной

Синтаксис:

Новый Хранилище3начения(< Значение>)

<3начение> Обязательный .

Тип: Произвольный. Значение, которое должно быть помещено в хранилище.

Описание:

Создает новый объект и помещает в него заданное значение.

Картинка (Picture)

Объект представляет собой картинку из коллекции картинок, пустую картинку, либо загруженную из внешнего файла.

Свойства

Вид (Kind)

Использование:

Только чтение.

Описание:

Тип: ВидКартинки. Содержит вид картинки.

При определении значения свойства используется системное перечисление ВидКартинки.

Методы

Записать (Write)

Синтаксис:

Записать(<Имя файла> )

Параметры:

<Имя файла> Обязательный

Тип: Строка. Полное имя файла, в котором будет сохранена картинка. Если имя каталога не указано, то картинка будет сохранена в каталог исполняемых файлов программы.

Описание:

Позволяет сохранить картинку в файл с указанным именем.

Пример:

Картинка.Записать("С:\Му Documents\My Pictures\Miome.bmp");

ФильтрИменФайлов (FileNameFilter)

Синтаксис:

ФильтрИменФайлов()

Возвращаемое значение:

Тип: Строка. Фильтр для диалога выбора файлов.

Описание:

Позволяет получать фильтры для диалога выбора файлов, соответствующие формату картинки.

Пример:

ФильтрДиалога = Картинка.ФильтрИменФайлов();

Конструкторы

Основной

Синтаксис:

Новый Картинка(<Имя файла>)

Параметры:

<Имя файла > Обязательный

Тип: Строка. Имя файла, из которого будет загружена картинка.

Описание:

Позволяет загрузить картинку из указанного файла картинки.

Формирование пустой картинки

Синтаксис:

Новый Картинка()

Описание:

Позволяет сформировать пустую картинку.

УникальныйИдентификатор (GUID)

Объект предназначен для создания и хранения глобального уникального идентификатора GUID.

Конструкторы

По умолчанию

Синтаксис:

Новый УникальныйИдентификатор()

Описание:

Позволяет создать новый гарантированно уникальный идентификатор.

Из строки

Синтаксис:

Новый УникальныйИдентификатор (<Строка>)

Параметры:

<Строка> Обязательный

Тип: Строка. Строка GUID. Строка задается в виде "ХХХХХХХХ-ХХХХ-ХХХХ-ХХХХ-ХХХХХХХХХХХХ", где Х -символы обозначающие шестнадцатиричное число.

Описание:

Позволяет создать уникальный идентификатор из указанной строки GUID. Уникальность полученного таким образом идентификатора не гарантирована.

ФиксированнаяКоллекция

Объект представляет собой системную коллекцию значений и используется в качестве значений свойств других объектов. Заполняется системой при инициализации объектов данного типа.

Создать этот объект из языка нельзя. Набор свойств этого объекта определяется в зависимости от контекста его использования и описан подробнее в описании тех свойств, где он используется.

Данный объект является коллекцией значений. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции. Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс элемента.

Методы

Индекс

Синтаксис:

Индекс(Значение)

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество элементов в коллекции.

Описание:

Позволяет получить количество элементов в коллекции.

Найти

Синтаксис:

Найти(Наименование элемента)


1-149 ТекстовыйДокумент

ТекстовыйДокумент (TextDocument)

Текстовый документ предназначен для работы с текстами. Объект позволяет получать и сохранять текст в файле, работать со строками, открывать текст в текстовом редакторе 1 С:Предприятия.

Свойства

ТолькоПросмотр (Readonly)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак того, что табличный документ открыт в режиме просмотра. В режиме просмотра содержимое текстового документа недоступно для редактирования.

Методы

ВставитьСтроку (InsertLine)

Синтаксис:

ВставитьСтроку (<Номер строки> , < Строка>)

Параметры:

<Номер строки> Обязательный

Тип: Число. Номер вставляемой строки.

<Строка> Обязательный

Тип: Строка. Вставляемая строка.

Описание:

Вставляет в текстовый документ строку с указанным номером.

Пример:

ТекстДок.ВставитьСтроку(23, "Новая строка");

ДобавитьСтроку (AddLine)

Синтаксис:

ДобавитьСтроку (<Строка>)

Параметры:

<Строка> Необязательный

Тип: Строка. Добавляемая строка.

Описание:

Добавляет строку в конец текстового документа.

Пример:

ТекстДок.ДобавитьСтроку("Новая строка");

ЗаменитьСтроку (Replaceline)

Синтаксис:

ЗаменитьСтроку (<Номер строки> , <Строка>)

Параметры:

<Номер строки> Обязательный

Тип: Число. Номер замещаемой строки.

<Строка> Обязательный

Тип: Строка. Замещающая строка.

Описание:

Заменяет строку с указанным номером на переданную.

Пример:

ТекстДок.ЗаменитьСтроку(23, "Строка с исправлениями");

Записать (Write)

Синтаксис:

Записать(<Имя файла>, <Тип файла>)

Параметры:

<Имя файла> Обязательный

Тип: Строка. Имя файла для сохранения текста.

<Тип файла> Необязательный

Тип: ТипКодировкиТекста. Тип кодировки файла. Значение по умолчанию: UTF8.

При определении значения параметра используется системное перечисление ТипКодировкиТекста.

Описание:

Записывает текстовый документ в файл с указанным именем.

Пример:

ТекстДок.Записать("price.txt");

КоличествоСтрок (LinesCount)

Синтаксис:

КоличествоСтрок()

Возвращаемое значение:

Тип: Число. Количество строк в тексте.

Описание:

Получает количество строк в тексте.

Пример:

ВсегоСтрок = Текст.КоличествоСтрок();

Очистить (Clear)

Синтаксис:

Очистить()

Описание:

Очищает содержимое текстового документа.

Пример:

ТекстДок.Очистить();

Показать (Show)

Синтаксис:

Показать (< Заголовок> , <Имя файла>)

Параметры:

<3аголовок> Необязательный

Тип: Строка. Заголовок окна редактирования. Значение по умолчанию: Пустая строка.

<Имя файла> Необязательный

Тип: Строка. Имя файла, в котором будет предлагаться сохранение текста при закрытии окна текстового редактора. Если файла с указанным именем не существует, то будет создан новый файл с таким именем для сохранения текста.

Значение по умолчанию: Пустая строка - не предлагать сохранение текста в файле.

Описание:

Открывает текст в текстовом редакторе 1C: Предприятия для просмотра и редактирования.

Пример:

ТекстДок.Показать("Редактирование прайс-листа", "catalog.txt");

ПолучитьСтроку (GetLine)

Синтаксис:

ПолучитьСтроку(< Номер строки> )

Параметры:

<Номер строки> Обязательный

Номер строки текста.

Возвращаемое значение:

Тип: Строка.

Описание:

Получает строку текстового документа по номеру.

Пример:

Стр = Текст.ПолучитьСтроку(Ном);

ПолучитьТекст (GetText)

Синтаксис:

ПолучитьТекст()

Возвращаемое значение:

Тип: Строка. Строка, содержащая текст из текстового документа.

Описание:

Получает текст, находящийся в текстовом документе.

Прочитать (Read)

Синтаксис:

Прочитать(<Имя файла>, <Tип файла>)

Параметры:

<Имя файла> Обязательный

Тип: Строка. Имя текстового файла.

<Тип файла> Необязательный

Тип: ТипКодировкиТекста. Тип кодировки текстового файла. Значение по умолчанию: UTF8.

При определении значения параметра используется системное перечисление ТипКодировкиТекста.

Описание:

Считывает текстовый документ из файла.

Пример:

ТекстДок.Прочитать("catalog.txt"); :

УдалитьСтроку (DeleteLine)

Синтаксис:

УдалитьСтроку(<Номер строки>)

Параметры:

<Номер строки> Обязательный

Тип: Число. Номер удаляемой строки.

Описание:

Удаляет из текстового документа строку с указанным номером.

Пример:

ТекстДок.УдалитьСтроку(23);

УстановитьТекст (SetText)

Синтаксис:

УстановитьТекст (< Текст для установки> )

Параметры:

<Текст для установки> Обязательный

Тип: Строка. Текст, помещаемый в текстовый документ.

Описание:

Помещает в текстовый документ текст из переданной строки. Текст, содержащийся в текстовом документе до исполнения метода, удаляется.

Пример:

ТекстовыйДокумент.УстановитьТекст("
|Этот
| текст
| установлен на строки");

Конструкторы

Основной

Синтаксис:

Новый ТекстовыйДокумент()

Описание:

Позволяет создать новый текстовый документ.


1-156 Табличный документ

Табличный документ

Табличный документ предназначен для формирования печатных форм первичных документов, отчетов, при размещении на форме также может использоваться в качестве средства интерактивного ввода данных. Табличные документы вида "Макет" служат прообразами для других табличных документов. Макеты могут содержать параметры, предназначенные для заполнения конкретными данными. Перед выводом области макета в результирующую таблицу параметрам можно присвоить значения и результаты выражений. Также макеты могут иметь параметры расшифровки, значения которых задаются аналогично параметрам. Расшифровка не влияет на внешний вид результирующей таблицы и используется для создания связанных отчетов, открытия форм или иных действий.

ТабличныйДокумент (TableDocument)

Используется для доступа к свойствам и методам табличного документа в целом. При помощи этого объекта возможно управление общими характеристиками табличного документа, получение его областей, а также присоединение к табличному документу других табличных документов, группировка строк табличного документа.

Свойства

Автомасштаб (FitToPage)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак автоматического масштабирования изображения при печати.

ВерхнийКолонтитул (Header)

Использование:

Только чтение.

Описание:

Тип: КолонтитулТабличногоДокумента. Содержит верхний колонтитул табличного документа.

См. также:

КолонтитулТабличногоДокумента.

ВстроенныеТаблицы (EmbeddedTables)

Использование:

Только чтение.

Описание:

Тип: КоллекцияВстроенныхТаблиц. Содержит коллекцию сводных таблиц табличного документа.

ВысотаТаблицы (TableHeight)

Использование:

Только чтение.

Описание:

Тип: Число. Содержит количество строк в таблице.

Защита (Protection)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак защиты таблицы от редактирования и копирования. В режиме защиты таблица может быть

только распечатана.

ИмяПараметровПечати (PrintParametersName)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя значения, в котором сохраняются параметры печати таблицы. Параметры печати, настроенные и сохраненные с данным именем, впоследствии восстанавливаются при следующем показе таблицы.

ИмяПринтера (PrinterName)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя принтера, известного в системе, на который будет выводиться табличный документ при печати.

ИмяСохраненияПоложенияОкна (WindowOptionsName)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя значения, в котором сохраняются параметры окна, в котором отображается таблица. Параметры окна, настроенные и сохраненные с данным именем, впоследствии восстанавливаются при следующем показе таблицы.

ИтогиСнизу (TotalsBelow)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Определяет расположение маркеров секций, сворачивающих горизонтальные группы таблицы. Если значение свойства Истина, то маркеры будут располагаться внизу группы, в противном случае - вверху.

Следует иметь в виду, что при сворачивании группы видимой остается только строка, рядом с которым расположен маркер секции. Как правило, расположение маркеров связано с расположением итоговых строк в результирующей таблице по отношению к детализирующим.

ИтогиСправа (TotalsOnRight)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Определяет расположение маркеров секций, сворачивающих вертикальные группы таблицы. Если значение свойства Истина, то маркеры будут располагаться на правой стороне группы, в противном случае - на левой.

Следует иметь в виду, что при сворачивании группы видимой остается только столбец, рядом с которым расположен маркер секции. Как правило, расположение маркеров связано с расположением итоговых столбцов в результирующей таблице по отношению к детализирующим.

КоличествоЭкземпляров (Copies)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит количество экземпляров для вывода табличного документа на печать.

МасштабПечати (PrintScale)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит масштаб изображения таблицы при выводе на печать в процентах.

Примечание:

Имеет смысл, если свойство Автомасштаб имеет значение Ложь.

НаправлениеПерехода

Использование:

Чтение и запись.

Описание:

Тип: ТипНаправленияПереходаТабличногоДокумента. Определяет направление перехода при завершении редактирования ячейки таблицы.

При определении значения свойства используется системное перечисление ТипНаправленияПереходаТабличногоДокумента.

НижнийКолонтитул (Footer)

Использование:

Только чтение.

Описание:

Тип: КолонтитулТабличногоДокумента. Содержит нижний колонтитул табличного документа.

См. также:

КолонтитулТабличногоДокумента

Области (Areas)

Использование:

Только чтение.

Описание:

Тип: КоллекцияОбластейТабличногоДокумента. Содержит коллекцию именованных областей таблицы.

См. также:

ТабличныйДокумент, РисунокТабличногоДокумента.

ОбластьПечати (PrintArea)

Использование:

Чтение и запись.

Описание:

Тип: ОбластьЯчеекТабличногоДокумента. Содержит область табличного документа, которая будет выводиться на печать.

ОриентацияСтраницы (PageOrientation)

Использование:

Чтение и запись.

Описание:

Тип: ОриентацияСтраницы. Содержит ориентацию страницы при выводе таблицы на печать.

При определении значения свойства используется системное перечисление ОриентацияСтраницы (PageOrientation). Перечисление содержит следующие значения:

Ландшафт (Landscape)

Портрет (Portrait)

ОтображатьЗаголовки

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак отображения заголовков колонок и строк таблицы. Заголовки содержат номера колонок и строк и выводятся сверху и слева от таблицы.

ОтображатьСетку (ShowGrid)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак отображения сетки таблицы.

Параметры (Parameters)

Использование:

Только чтение.

Описание:

Тип: ПараметрыМакетаТабличногоДокумента. Содержит коллекцию параметров макета табличного документа.

См. также:

ПараметрыМакетаТабличногоДокумента.


1-164 Табличный документ

ПовторятьПриПечатиСтолбцы (RepeatedColumns)

Использование:

Чтение и запись.

Описание:

Тип: ОбластьЯчеекТабличногоДокумента. Содержит область столбцов, которая будет повторяться при печати каждого нового листа табличного документа.

ПовторятьПриПечатиСтроки (RepeatedRows)

Использование:

Чтение и запись.

Описание:

Тип: ОбластьЯчеекТабличногоДокумента. Содержит область строк, которая будет повторяться при печати каждого нового листа табличного документа.

ПолеСверху (TopField)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит ширину поля сверху при печати (в миллиметрах).

ПолеСлева (LeftField)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит ширину поля слева при печати (в миллиметрах).

ПолеСнизу (BottomField)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит ширину поля снизу при печати (в миллиметрах).

ПолеСправа (RightField)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит ширину поля справа при печати (в миллиметрах).

РазборПоКопиям (Collate)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак разбора по копиям при выводе таблицы на печать.

PaзмepKoлoнтитулаCвepxy(HeaderSize)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит размер верхнего колонтитула (в миллиметрах).

См. также:

КолонтитулТабличногоДокумента.

РазмерКолонтитулаСнизу (FooterS ize)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит размер нижнего колонтитула (в миллиметрах).

См. также:

КолонтитулТабличногоДокумента.

Рисунки (Drawings)

Использование:

Только чтение.

Описание:

Тип: КоллекцияРисунковТабличногоДокумента. Содержит коллекцию рисунков табличного документа.

СохранятьСвойстваОтображения (SaveViewProperties)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак сохранения свойств отображения табличного документа: отображения заголовков, сетки, групп, имен, позиции фиксации.

ТекущаяОбласть (CurrentArea)

Использование:

Чтение и запись.

Описание:

Тип: ОбластьЯчеекТабличногоДокумента. Содержит текущую активную область или рисунок табличного документа.

Примечание:

В случае отсутствия визуального представления табличного документа имеет значение Неопределено.

См. также:

ТабличныйДокумент. РисунокТабличногоДокумента.

ТолькоПросмотр (Readonly)

Использование:

Чтение и запись.

Описание:

Тип- Булево. Содержит признак того, что табличный документ открыт в режиме просмотра. В режиме просмотра в таблице недоступны для редактирования ячейки и рисунки, у которых установлено свойство Защита.

Примечание:

Если табличный документ расположен на форме, то у него могут возникать события Выбор и ОбработкаРасшифровки только в режиме просмотра.

ФиксацияСверху (FixedTop)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит количество зафиксированных сверху строк. Зафиксированные строки не исчезают из поля таблицы при вертикальной прокрутке.

ФиксацияСлева (FixedLeft)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит количество зафиксированных слева столбцов. Зафиксированные столбцы не исчезают из поля таблицы при горизонтальной прокрутке.

ФиксированныйФон (FixedBackground)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак зафиксированного фона табличного документа. Зафиксированный фон остается неподвижным при прокрутке таблицы.

ФоноваяКартинка

Использование:

Чтение и запись.

Описание:

Тип: Картинка. Содержит фоновую картинку таблицы.

ЦветТекстаГруппировки (GroupsTextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста области группировки.

ЦветТекстаЗаголовков (HeadersTextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста заголовков колонок и строк

табличного документа.

ЦветФонаГруппировки (GroupsBackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона области Группировки.

ЦвeФонаЗаголовков(HeadersBackColor)

Использование:

Чтение и запись. '

Описание:

Тип: Цвет. Содержит цвет фона заголовков колонок и строк табличного документа.

ЧерноБелаяПечать (BlackAndWhite)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак печати таблицы в черно-белом режиме.

ЧерноБелыйПросмотр

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак показа таблицы в черно-белом режиме.

ШиринаТаблицы (TableWidth)

Использование:

Только чтение.

Описание:

Тип: Число. Содержит количество столбцов в таблице.

ЭкземпляровНаСтранице

Использование:

Чтение и Запись.

Описание:

Тип: Число. Содержит количество страниц на листе при выводе табличного документа на печать. Допустимые значения: 1 - одна страница, 2 - две страницы, 0 - автоматическое определение.


1-171 Табличный документ. Методы

Методы

ВставитьОбласть (InsertArea)

Синтаксис:

ВставитьОбласть(< Исходная область>, <Область приемник>, <Сдвиг>)

Параметры:

<Исходная область> Обязательный

Тип: ОбластьЯчеекТабличногоДокумента. Исходная область.

<0бласть приемник> Необязательный

Тип: ОбластьЯчеекТабличногоДокумента. Область-приемник.

Значение по умолчанию: Если параметр не задан, то сразу за исходной областью.

<Сдвиг> Необязательный

Тип: ТипСмещенияТабличногоДокумента. Определяет смещение ячеек таблицы при вставке.

Значение по умолчанию: БезСмещения.

При определении значения параметра используется системное перечисление ТипСмещенияТабличногоДокумента.

Описание:

Вставляет копию исходной области табличного документа в область-приемник.

Примечание:

Если размеры исходной области не соответствуют результирующей области, то при выполнении метода возникает ошибка.

Пример:

ТабДок = Новый ТабличныйДокумеит;
ИТОГ = 0;
Для К=1 По 10 Цикл
    ТабДок.Область("R" + (K+1) +"С1").Текст = "Строка "+К;
    ТабДок.О6ласть("R" + (К+1) + "С2").Текст = К*10;
    Итог = Итог+К*10;
КонецЦикла;
ТабДок.ВставитьОбласть(ТабДок.Область("R2"), ТабДок.Область("R3"),
    ТипСмещенияТабличногоДокумента.ПоГоризонтали);
ТабДок.Область("R2C1").Текст = "Итого:";
ТабДок.Область("R2C2").Текст = Итог;
Рамка = Новый Линия(ТипЛинииЯчейкиТабличногоДокумента.Сплошная, 1);
ТабДок.Область("R2С1:R2С2").Обвести(,Рамка,,Рамка);
ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Истина;
ТабДок.Показать("Пример использования метода ВставитьОбласть()");

Вывести (Place)

Синтаксис:

Вывести (< Таблица>, <Уровень> , <Имя группы>, <Открыта>)

Параметры:

<Таблица> Обязательный

Тип: ТабличныйДокумент. Выводимая таблица.

<Уровень> Необязательный

Тип: Число. Уровень используется для автоматической группировки строк табличного документа. Соседние строки с одинаковым уровнем будут отнесены к одной группе.

<Имя группы> Необязательный

Тип: Строка. Название группы, к которой относятся выводимые строки.

Значение по умолчанию: Пустая строка.

<Открыта> Необязательный

Тип: Булево. Истина - выведенная группа будет открыта, Ложь - группа будет выведена в свернутом виде.

Значение по умолчанию: Истина.

Описание:

Выводит табличный документ в результирующий табличный документ, добавляя его со следующей строки вслед за самой нижней выведенной строкой, начиная с первой колонки.

Пример:

ТабДок = Новый ТабличныйДокумент;
Секция = ТабДок.ПолучитьОбласть("R1");
Секция.Область("R1C1").Текст = "Численность сотрудников";
ТабДок.НачатьАвтогруппировкуСтрок();
ТабДок.Вывести(Секция,1,"Группа",Истина);
Итого = 0;
Для Н=1 По 3 Цикл
Значение = Н; Итог = 0;
Секция.Область("R1С1").Текст =
"Отдел "+Н;
Секция.Область("R1C2") .Текст = "";
ТабДок.Вывести(Секция,2,"Группа 1",Истина);
Секция.Область("R1C1").Текст = "Группа";
Секция.Область("R1C2") .Текст = "Численность";
ТабДок.Вывести(Секция,2,"Группа 1",Истина);
Для К=1 По 10 Цикл
Секция.Область("R1C1").Текст = "А"+Н+К;
Секция.Область("R1C2").Текст =
Значение;
ТабДок.Вывести(Секция,3,"Группа
2",Истина);
Итог = Итог + Значение;
Значение = Значение + 10;
КонецЦикла;
Секция.Область("R1C1").Текст = "Итого"+Н;
Секция.Область("R1C2").Текст = Итог;
ТабДок.Вывести(Секция,2,"Группа 1",Истина);
Секция.Область("R1C1:R1C2").Текст = "";
ТабДок.Вывести(Секция);
Итого = Итого + Итог;
КонецЦикла;
Секция.Область("R1С1").Текст = "Всего:";
Секция.Область("R1C2").Текст = Итого;
ТабДок.Вывести(Секция,1,"Группа",Истина);
ТабДок.ЗакончитьАвтогруппировкуСтрок();
ТабДок.ИтогиСнизу = Истина;
ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Истина;
ТабДок.Показать("Пример использования верт. группировки");

См. также:

ТабличныйДокумент, метод Присоединить.

ВывестиВертикальныйРазделительСтраниц (PutVerticalPageBreak)

Синтаксис:

ВывестиВертикальныйРазделительСтраниц()

Описание:

Вставляет в результирующую таблицу вертикальный разделитель страниц.

Пример:

ТабДок.ВывестиВертикальныйРазделительСтраниц() ;

ВывестиГоризонтальныйРазделительСтраниц (PutHorizontalPageBreak)

Синтаксис:

ВывестиГоризонтальныйРазделительСтраниц()

Возвращаемое значение:

Тип: Число.

Описание:

Вставляет в результирующую таблицу горизонтальный разделитель страниц.

Пример:

ТабДок.ВывестиГоризонтальныйРазделительСтраниц() ;

ЗакончитьАвтогруппировкуКолонок (EndColumnsAutoGroup)

Синтаксис:

ЗакончитьАвтогруппировкуКолонок()

Описание:

Заканчивает автоматическую группировку колонок, ранее начатую методом НачатьАвтогруппировкуКолонок.

Пример:

ТабДок.ЗакончитьАвтогруппировкуКолонок();

См. также:

ТабличныйДокумент, метод НачатьАвтогруппировкуКолонок.

ЗакончитьАвтогруппировкуСтрок(EndRowsAutoGroup)

Синтаксис:

ЗакончитьАвтогруппировкуСтрок()

Описание:

Заканчивает автоматическую группировку строк, ранее начатую при помощи метода НачатьАвтогруппировкуСтрок.

Пример:

ТабДок.ЗакончитьАвтогруппировкуСтрок() ;

См. также:

ТабличныйДокумент, метод НачатьАвтогруппировкуСтрок.

3aкончитьГруппуКолонок(EndColumnsGroup)

Синтаксис:

ЗакончитьГруппуКолонок()

Описание:

Закадчивает последнюю из начатых ранее групп колонок.

Пример:

ТабДок.НачатьГруппуКолонок("По всем складам", Истина);
//...
ТабДок.начатьГруппуКолонок("На складе", Истина);
//...
ТабДок.ЗакончитьГруппуКолонок (); // окончить группу "На складе"
ТабДок.ЗакончитьГруппуКолонок(); // окончить группу "По всем складам"

См. также:

ТабличныйДокумент, метод НачатьГруппуКолонок.

ЗакончитьГруппуСтрок(EndRowsGroup)

Синтаксис:

ЗакончитьГруппуСтрок()

Описание:

Заканчивает последнюю из начатых ранее групп строк.

Пример:

ТабДок.НачатьГруппуСтрок("Сводно за месяц", Истина);
ТабДок.НачатьГруппуСтрок("По дням", Истина);
//...
ТабДок. ЗакончитьГруппуСтрок (); // закончить группу "По дням"
ТабДок.ЗакончитьГруппуСтрок(); // закончить группу "Сводно за месяц"

См. также:

ТабличныйДокумент, метод НачатьГруппуСтрок.

Записать (Write)

Синтаксис:

Записать(<Имя файла>. <Тип файла таблицы> )

Параметры:

<Имя файла> Обязательный

Тип: Строка. Имя файла, в котором сохраняется табличный документ.

<Тип файла таблицы> Необязательный

Тип: ТипФайлаТабличногоДокумента. Формат, в котором будет сохранен табличный документ.

Значение по умолчанию: MXL.

При определении значения параметра используется системное перечисление ТипФайлаТабличногоДокумента.

Описание:

Записывает табличный документ в файл.

Пример:

ТабДок.Записать("С: \Му Documents \Таблица2.mxl ");

НайтиЗначение (FindValue)

Синтаксис:

Найти3начение(<3начение> , <Начало> , <Где>, <Искать по строкам>, <Искать вперед>)

Параметры:

<3начение> Обязательный

Тип: Произвольный. Искомое значение.

<Начало> Необязательный.

Тип: ОбластьЯчеекТабличногоДокумента. Область, после которой начинать поиск.

Значение по умолчанию: Если параметр не задан, то поиск с начала таблицы.

<Где> Необязательный

Тип: ОбластьЯчеекТабличногоДокумента. Область, в которой осуществляется поиск.

Значение по умолчанию: Если параметр не задан, то поиск во всей таблице.

<Искать по строкам> Необязательный

Тип: Булево. Определяет последовательность обхода ячеек при поиске.

Истина - искать по текущей строке, затем переходить на следующую и т.д. в общем направлении поиска. Ложь - искать по текущему столбцу, затем переходить на следующий и т.д. в общем направлении поиска.

Значение по умолчанию: Истина.

<Искать вперед> Необязательный

Тип: Булево. Направление поиска:

Истина - искать вперед, Ложь - искать назад. Значение по умолчанию: Истина.

Возвращаемое значение:

Тип: ОбластьЯчеекТабличногоДокумента, РисунокТабличногоДокумента. Область, содержащая искомое значение. Если значение не найдено - значение Неопределено.

Описание:

Позволяет искать значение в ячейках табличного документа.

Пример:

Если Не ТабДок.НайтиЗначение(ВыбЗнач) Тогда
Сообщить("Значение не найдено!");
Иначе
Сообщить("Значение найдено.");
КонецЕсли;

НайтиТекст (FindText)

Синтаксис:

НайтиТекст(< Строка>, <Начало>, <Где>, <Искать по строкам>, <Ячейка целиком> , <Искать вперед> , <Чувствительность к регистру> )

Параметры:

<Строка> Обязательный

Тип: Строка. Искомый текст.

<Начало> Необязательный

Тип: ОбластьЯчеекТабличногоДокумента. Область, после которой начинать поиск.

Значение по умолчанию: Если параметр не задан, то поиск с начала таблицы.

<Где> Необязательный

Тип: ОбластьЯчеекТабличногоДокумента. Область, в которой осуществляется поиск.

Значение по умолчанию: Если параметр не казан, то вся таблица.

<Искать по строкам> Необязательный

Тип: Булево. Определяет последовательность обхода ячеек при поиске.

Истина - искать по текущей строке, затем переходить на следующую и т.д. в общем направлении поиска. Ложь - искать по текущему столбцу, затем переходить на следующий и т.д. в общем направлении поиска.

Значение по умолчанию: Истина.

<Ячейка целиком> Необязательный

Тип: Булево. Истина - искать только такие ячейки, в которых с искомым текстом совпадает весь текст ячейки, Ложь -искать часть текста ячейки.

Значение по умолчанию: Ложь.

<Искать вперед> Необязательный

Тип: Булево. Направление поиска:

Истина - искать вперед, Ложь - искать назад.

Значение по умолчанию: Истина.

<Чувствительность к регистру> Необязательный

Тип: Булево. Истина - поиск с учетом регистра. Ложь - без учета регистра.

Значение по умолчанию: Ложь.

Возвращаемое значение:

Тип: ОбластьЯчеекТабличногоДокумента, РисунокТабличногоДокумента. Область, содержащая искомый текст. Если текст не найден - значение Неопределено.

Описание:

Позволяет искать текст в ячейках табличного документа.

Пример:

// чтобы посмотреть работу данного метода, добавьте
// следующие строки в конец примера метода НачатьГруппуСтрок()
Отдел = "Итого2";
Обл=ТабДок.НайтиТекст(Отдел);
Если ТипЗнч(Обл)=Тип("Неопределено") Тогда
Сообщить("Значение не найдено!");
Иначе
Поз = Найти(Обл.Имя,"С");
Имя= Лев(Обл.Имя,Поз)+Строка(Число(Прав(Обл.Имя,СтрДлина(Обл.Имя)-Поз)
)+1);
Сообщить ("Итог по отделу 2 = " + ТабДок.Область(Имя).Текст);
КонецЕсли;

Напечатать (Print)

Синтаксис:

Напечатать(<Диалог печати> )

Параметры:

<Диалог печати> Необязательный

Тип: Булево. Показ диалога перед печатью:

Истина - выводить диалог печати. Ложь - не выводить диалог печати.

Значение по умолчанию: Ложь.

Описание:

Выводит табличный документ на печать.

Пример:

ТабДок.Напечатать();


1-180 Табличный документ. Методы

НачатьАвтогруппировкуКолонок

Синтаксис:

НачатьАвтогруппировкуКолонок()

Описание:

Начинает автоматическую группировку колонок. При автоматической группировке учитываются значения уровней, заданные при выводе колонок методом Присоединить.

Пример:

ТабДок. НачатьАвтогруппировку Колонок();

См. также:

ТабличныйДокумент, метод ЗакончитьАвтогруппировкуКолонок.

НачатьАвтогруппировкуСтрок (StartRowsAutoGroup)

Синтаксис:

НачатьАвтогруппировкуСтрок()

Описание:

Начинает автоматическую группировку строк. При автоматической группировке учитываются значения уровней, заданные при выводе строк методом Вывести.

Пример:

ТабДок.НачатьАвтогруппировкуСтрок();

См.также:

ТабличныйДокумент, метод ЗакончитьАвтогруппировкуСтрок.

НачатьГруппуКолонок()

Синтаксис:

НачатьГруппуКолонок(< Имя группы> , <Открыта ли группа>)

Параметры:

<Имя группы> Необязательный

Тип: Строка.

<Открыта ли группа> Необязательный

Тип: Булево. Истина - выведенная группа будет открыта, Ложь - группа будет выведена в свернутом виде.

Значение по умолчанию: Истина.

Описание:

Начинает новую группу колонок. Можно создавать вложенные группы колонок.

Пример:

ТабДок.НачатьГруппуКолонок("По всем складам",Истина);

См. также:

ТабличныйДокумент, метод ЗакончитьГруппуКолонок.

HaчaтьГpynnyCтpoк(StartRowsGroup)

Синтаксис:

НачатьГруппуСтрок(<Имя группы>, <Открыта ли группа>}

Параметры:

<Имя группы> Необязательный

Тип: Строка. Название группы.

<Открыта ли группа> Необязательный

Тип: Булево. Истина - выведенная группа будет открыта, Ложь - группа будет выведена в свернутом виде.

Значение по умолчанию: Истина.

Описание:

Начинает новую группу строк. Можно создавать вложенные группы строк.

Пример:

ТабДок = Новый ТабличныйДокумент;
Секция = ТабДок.ПолучитьОбласть("R1") ;
Секция.Область("R1C1") .Текст = "Численность сотрудников";
ТабДок.Вывести(Секция);
ТабДок.НачатьГруппуСтрок("По всем
подразделениям", Истина);
Всего = 0;
Для Н=1 По 3 Цикл
Значение = Н; Итог = 0;
Секция.Область("R1C1").Текст = "Отдел
"+Н;
Секция.Область("R1C2").Текст
= "";
ТабДок.Вывести(Секция);
ТабДок.НачатьГруппуСтрок("Отдел
"+Н, Истина);
Секция.Область("R1C1").Текст =
"Группа";
Секция.Область("R1C2").Текст
= "Численность";
Секция.Область("R1C2").ГоризонтальноеПоложение
= ГоризонтальноеПоложение.Авто;
ТабДок,Вывести(Секция);
ТабДок.НачатьГруппуСтрок("Группа
"+Н, Истина);
Для К=1 По 4 Цикл
Секция.Область("R1C1").Текст
= "А"+Н+К;
Секция.Область("R1C2").Текст
= Значение;
ТабДок.Вывести(Секция);
Итог = Итог
+ Значение;
Значение =
Значение + 10;
КонецЦикла;
ТабДок.ЗакончитьГруппуСтрок();
// окончить группу " Группа"
ТабДок.ЗакончитьГруппуСтрок(); //
окончить группу "Отдел"
Секция.Область("R1C1").Текст = "Итого"+Н;
Секция,Область("R1C2").Текст = Итог;
ТабДок.Вывести(Секция);
Секция.Область("R1C1:R1C2").Текст =
"';
ТабДок.Вывести(Секция);
Всего = Всего + Итог;
КонецЦикла;
ТабДок.ЗакончитьГруппуСтрок(); // окончить группу "По
всем отделам"
Секция.Область("R1C1").Текст = "Всего:";
Секция.Область("R1C2").Текст = Всего;
ТабДок.Вывести(Секция);
ТабДок.ИтогиСнизу = Ложь;
ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Истина;
ТабДок.Показать("Пример использования метода
НачатьГруппуСтрок");

См.также:

ТабличныйДокумент, метод ЗакончитьГруппуСтрок.

Область (Area)

Вариант синтаксиса: По имени

Используется для получения области табличного документа по имени.

Синтаксис:

Область(<Имя области>)

Параметры:

<Имя области> Обязательный

Тип: Строка. Имя области или адрес в формате "R1C1:R2C2", где число после "R" обозначает номер строки, число после "С" -номер столбца, символом ":" (двоеточие) разделяются координаты левого верхнего и правого нижнего угла области. В качестве имени также можно передавать пересечение двух областей, записываемое как "<Имя области 1> | <Имя области 2>".

Вариант синтаксиса: По адресу

Используется для получения области табличного документа по номерам строк и столбцов.

Если последняя строка и последний столбец отсутствуют, то область задана единственной ячейкой. Если строки или столбцы отсутствуют, то область задана диапазоном строк или столбцов соответственно. Если метод вызван без параметров, то область задана всей таблицей.

Синтаксис:

Область(<Номер первой строки> , <Номер первого столбца>, <Номер последней строки> , <Номер последнего столбца>)

Параметры:

<Номер первой строки> Необязательный

Тип: Число. Номер первой строки области таблицы.

<Номер первого столбца> Необязательный

Тип: Число. Номер первого столбца области таблицы.

<Номер последней строки> Необязательный

Тип: Число. Номер последней строки области таблицы.

<Номер последнего столбца> Необязательный

Тип: Число. Номер последнего столбца области таблицы.

Возвращаемое значение:

Тип: ОбластьЯчеекТабличногоДокумента.

Описание:

Позволяет получить область табличного документа. Область может состоять из нескольких расположенных подряд строк или столбцов, либо быть прямоугольной областью таблицы.

Пример:

ШапкаДокумента
= ТабДок.Область("Шапка");
Ячейка = ТабДок.Область("R2C5");
ПрямоугольнаяОбласть = ТабДок.Область("R2C2:R5C5");
ОбластьСтрока = ТабДок.Область("R2");
ОбластьСтрок = ТабДок.Область("R2:R4");
ОбластьСтолбец = ТабДок.Область("C4");
ОбластьСтолбцов = ТабДок.Область("С4:С5");

См. также:

ОбластьЯчеекТабличногоДокумента.

Очистить (Clear)

Синтаксис:

Очистить()

Описание:

Очищает табличный документ.

Пример:

ТабДок.Очистить();

Показать (Show)

Синтаксис:

Показать(<3аголовок> , <Имя файла> , <Активизация> )

Параметры:

<3аголовок> Необязательный

Тип: Строка. Заголовок окна табличного документа

<Имя файла > Необязательный

Тип: Строка. Имя файла для сохранения табличного документа. Если значение не пустое, то при закрытии окна будет предложено сохранить табличный документ в указанный файл.

<Активизация> Необязательный

Тип: Булево. Истина - активизировать открываемое окно табличного документа, Ложь - открывать окно без активизации.

Значение по умолчанию: Истина.

Описание:

Открывает окно для показа и редактирования табличного документа.

Пример:

ТабДок.Показать("Заявки от покупателей", "Заявки.mxl") ;

ПолучитьОбласть (GetArea)

Вариант синтаксиса: По имени

Используется для получения области табличного документа по имени.

Синтаксис:

ПолучитьОбласть(< Имя области>)

Параметры:

<Имя области> Обязательный

Тип: Строка. Имя области или адрес в формате "R1C1:R2C2", где число после "R" обозначает номер строки, число после "С" -номер столбца, символом ":" (двоеточие) разделены координаты левого верхнего и правого нижнего угла области. В качестве имени также можно передавать пересечение двух областей, записываемое как "<Имя области 1> | <Имя области 2>".

Вариант синтаксиса: По адресу

Используется для получения области табличного документа по номерам строк и столбцов.

Синтаксис:

ПолучитьОбласть(<Номер первой строки> , <Номер первого столбца> , <Номер последней строки> , <Номер последнего столбца> )

Параметры:

<Номер первой строки> Необязательный

Тип: Число. Номер первой строки области таблицы.

<Номер первого столбца> Необязательный

Тип: Число. Номер первого столбца области таблицы.

<Номер последней строки> Необязательный

Тип: Число. Номер последней строки области таблицы.

<Номер последнего столбца> Необязательный

Тип: Число. Номер последнего столбца области таблицы.

Возвращаемое значение:

Тип: ТабличныйДокумент. Область как новый табличный документ.

Описание:

Позволяет получить область табличного документа. Область может состоять из нескольких расположенных подряд строк или столбцов, либо прямоугольной областью таблицы.

Пример:

Макет = Документы.РасходнаяНакладная.ПолучитьМакет("Накладная");
Шапка = Макет.ПолучитьОбласть("Шапка");

См. также:

ТабличныйДокумент, метод Область.

Присоединить (Attach)

Синтаксис:

Присоединить (< Таблица> , <Уровень> , <Имя группы>, <Открыта>)

Параметры:

<Таблица> Обязательный

Тип: ТабличныйДокумент. Выводимая таблица.

<Уровень> Необязательный

Тип: Число. Уровень используется для автоматической группировки столбцов табличного документа. Соседние столбцы с одинаковым уровнем будут отнесены к одной группе.

<Имя группы> Необязательный

Тип: Строка. Название группы, к которой относятся выводимые столбцы.

<Открыта> Необязательный

Тип: Булево. Истина - выведенная группа будет открыта, Ложь - группа будет выведена в свернутом виде.

Описание:

Присоединяет табличный документ к результирующему табличному документу, помещая его в следующей колонке правее самой правой выведенной колонки, начиная со строки, с которой выводился предыдущий табличный документ.

Пример:

ТабДок = Новый ТабличныйДокумент;
Секция = ТабДок.ПолучитьОбласть("R1C1");
ТабДок.НачатьАвтогруппировкуКолонок();
Секция.Область("R1C1").Текст = "Параметр";
ТабДок.Вывести(Секция,1,"Группа 1",Ложь);
Для К=1 По 10 Цикл
Секция = ТабДок.ПолучитьОбласть("R1C1") ;
Секция.Область().Текст = "А"+К;
Секция.Область().ГоризонтальноеПоложение =
ГоризонтальноеПоложение.Право;
ТабДок.Присоединить(Секция, 2, "Группа 2 ", Истина);
КонецЦикла;
Секция.Область("R1C1").Текст = "Итого:";
ТабДок.Присоединить(Секция,1,"Группа 2",Ложь);
Секция.Область("R1C1").Текст = "Значение";
ТабДок.Вывести(Секция,1,"Группа 2",Ложь);
Цена = 10; Итог = Цена;
Для К=1 По 10 Цикл
Секция = ТабДок.ПолучитьОбласть("R1C1");
Секция.Область().Текст = Цена;
ТабДок.Присоединить(Секция,2,"Группа 2",Истина);
Цена = Цена +10;
Итог = Итог + Цена;
КонецЦикла;
Секция.Область("R1C1").Текст = Итог;
ТабДок.Присоединить(Секция,1,"Группа 2",Ложь);
ТабДок. ЗакончитьАвтогруплировкуКолонок();
ТабДок.ИтогиСправа = Истина;
ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Истина;
ТабДок.Показать("Пример использования гор. автогруппировки");

См. также:

ТабличныйДокумент, метод Вывести.

ПроверитьВывод (CheckPut)

Синтаксис:

ПроверитьВывод (< Таблицы>)

Параметры:

<Таблицы> Обязательный

Тип: Массив. Массив из проверяемых таблиц.

Возвращаемое значение:

Тип: Булево. Истина, если умещаются. Ложь в противном случае.

Описание:

Позволяет проверить, умещаются ли переданные таблицы на страницу при печати.

Пример:

Т.Добавить(ШапкаДокумента) ;
Т. Добавить (СтрокаДокумента);
Т.Добавить(ПодвалДокумента);
Если Не ТабДок.ПроверитьВывод(Т) Тогда
Сообщить ("Документ не
умещается на страницу");
КонецЕсли;

См. также:

ТабличныйДокумент, метод ПроверитьПрисоединение.

ПроверитьПрисоединение (CheckAttachment)

Синтаксис:

ПроверитьПрисоединение (< Таблицы>)

Параметры:

<Таблицы> _ Обязательный

Тип: Массив. Массив из проверяемых таблиц.

Возвращаемое значение:

Тип: Булево. Истина, если умещаются, Ложь в противном случае.

Описание:

Позволяет проверить, умещаются ли переданные таблицы по ширине страницы при печати.

Пример:

Таблицы.Добавить(Столбец);
Если Не ТабДок.ПроверитьПрисоединение(Таблицы) Тогда
Сообщить("Документ не умещается но ширине страницы!");
КонецЕсли;

См.также:

ТабличныйДокумент, метод ПроверитьВывод.

Прочитать (Read)

Синтаксис:

Прочитать(<Имя файла>)

Параметры:

<Имя файла> Обязательный

Тип: Строка. Имя файла табличного документа.

Описание:

Позволяет считать табличный документ из файла.

Пример:

ТабДок = Новый ТабличныйДокумент;
ТабДок.Прочитать("С :\Мои документы\Tаблица.mxl") ;

Скрыть (Hide)

Синтаксис:

Скрыть()

Описание:

Скрывает окно табличного документа.

Пример:

ТабДок.Скрыть() ;

УдапитьОбласть (DeleteArea)

Синтаксис:

УдалитьОбласть(< Исходная область>, <Сдвиг>)

Параметры:

<Исходная область> Обязательный

Тип: ОбластьЯчеекТабличногоДокумента. Удаляемая область.

<Сдвиг> Необязательный

Тип: ТипСмещенияТабличногоДокумента. Определяет смещение ячеек таблицы при удалении.

Значение по умолчанию: БезСмещения.

При определении значения параметра используется системное перечисление ТипСмещенияТабличногоДокумента.

Описание:

Удаляет область из табличного документа.

Пример:

Смещать =
ТипСмещенияТабличногоДокумента.ПоВертикали;
Область = ТабДок.Область("R2C2:R2C2")
;
ТабДок.УдалитьОбласть(Область,
Смещать);

Конструкторы

Основной

Синтаксис:

Новый ТабличныйДокумент()

Описание:

Позволяет создать новый табличный документ.


1-191 КоллекцияОбластейТабличногоДокумента

КоллекцияОбластейТабличногоДокумента (TableDocumentAreasCollection)

Представляет собой коллекцию областей табличного документа, включая именованные рисунки.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа ОбластьЯчеекТабличногоДокумента или РисунокТабличногоДокумента. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции. Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс элемента.

Свойства

<Имя области>_

Использование:

Только чтение.

Описание:

Тип: ОбластьЯчеекТабличногоДокумента, РисунокТабличногоДокумента. Набор свойств содержит области и рисунки табличного документа. Имена свойств совпадают с именами областей или рисунков табличного документа.

Методы

Индекс (Count)

Синтаксис:

Индекс(Область)

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Количество элементов в коллекции.

Описание:

Получает количество элементов в коллекции.

Найти (Count)

Синтаксис:

Найти(НаименованиеОбласти)


1-192 ОбластьЯчеекТабличногоДокумента

ОбластьЯчеекТабличногоДокумента (TableDocumentRange)

Используется для доступа к области табличного документа.

Свойства

АвтоОтметкаНезаполненного

Использование:

Чтение и запись.

Описание:

Тип: Булево. Необходимо ли выделять ячейку, в которой не заполнено значение, либо оно выставлено в значение по умолчанию.

ВертикальноеПоложение (VerticalAlignment)

Использование:

Чтение и запись.

Описание:

Тип: ВертикальноеПоложение. Содержит способ вертикального выравнивания текста в ячейках области.

При определении значения свойства используется системное перечисление ВертикальноеПоложение.

Видимость (Visible)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак видимости области.

Примечание:

Свойство доступно на запись только для областей из строк или столбцов.

Верх

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит номер верхней ячейки области.

ВместеСоСледующим (KeepWithNext)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Объединяет строки или столбцы области таким образом, чтобы при разделении на страницы они всегда оказывались на одной странице.

Примечание:

Применимо только к областям, состоящим из строк или столбцов.

ВыделятьОтрицательные (MarkNegatives)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак выделения текста ячеек, содержащего отрицательные числа, специальным цветом стиля ЦветОтрицательныхЧисел.

ВысотаСтроки (RowHeight)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит высоту строк в области (в пунктах).

Гиперссылка (HyperLink)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Признак того, что область является гиперссылкой. Команды обработки для области, являющейся гиперссылкой, вызываются по одинарному щелчку мыши на области.

ГоризонтальноеПоложение (HorizontalAlignment)

Использование:

Чтение и запись.

Описание:

Тип: ГоризонтальноеПоложение. Содержит способ горизонтального выравнивания текста в области.

При определении значения свойства используется системное перечисление ГоризонтальноеПоложение.

ГраницаСверху (TopBorder)

Использование:

Чтение и запись.

Описание:

Тип: Линия. Содержит рамку сверху области.

ГраницаСлева (LeftBorder)

Использование:

Чтение и запись.

Описание:

Тип: Линия. Содержит рамку слева области.

ГраницаСнизу (BottomBorder)

Использование:

Чтение и запись.

Описание:

Тип: Линия. Содержит рамку снизу области.

ГраницаСправа (RightBorder)

Использование:

Чтение и запись.

Описание:

Тип: Линия. Содержит рамку справа области.

Защита (Protection)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак защиты области от редактирования. В режиме просмотра в таблице недоступны для редактирования ячейки и рисунки, у которых установлено свойство Защита.

См. также:

ТабличныйДокумент, свойство ТолькоПросмотр.

Значение (Value)

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Содержит значение ячеек области.

Примечание:

Свойство доступно, только если ячейка содержит значение (свойство СодержитЗначение равно Истина). Свойство применимо только для прямоугольных областей.

Имя (Name)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя области.

ИспользованиеРасшифровки

Использование:

Чтение и запись.

Описание:

Тип: ИспользованиеРасшифровкиТабличногоДокумента. Содержит тип использования расшифровки.

При определении значения свойства используется системное перечисление ИспользованиеРасшифровкиТабличногоДокумента.

КонецСтраницы (PageBottomBreak)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Признак того, что данная область находится последней на странице.

Примечание:

Применимо только для областей строк/столбцов.

Лево

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит номер левой ячейки области.

НачалоСтраницы (PageTopBreak)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак того, что область нужно выводить со следующей страницы.

Примечание:

Применимо только для областей из строк или столбцов.

Низ

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит номер нижней ячейки области.

ОриентацияТекста (TextOrientation)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит угол наклона текста по отношению к горизонтальному положению в градусах.

ОтметкаНезаполненного

Использование:

Чтение и запись.

Описание:

Тип: Булево. Необходимость помечать область ячеек.

ПоВыделеннымКолонкам

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак горизонтального выравнивания по выделенным колонкам.

Право

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит номер правой ячейки области.

Примечание (Comment)

Использование:

Чтение и запись.

Описание:

Тип: РисунокТабличногоДокумента. Содержит примечание к области.

Примечание:

Применимо только для прямоугольных областей.

РазмещениеТекста (TextPlacement)

Использование:

Чтение и запись.

Описание:

Тип: ТипРазмещенияТекстаТабличногоДокумента. Содержит тип размещения текста в области.

При определении значения свойства используется системное перечисление ТипРазмещенияТекстаТабличногоДокумента.

Расшифровка (Details)

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Содержит расшифровку ячеек области.

Примечание:

Применяется только для прямоугольных областей.

СодержитЗначение (ContainValue)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак того, что ячейки области содержат значения.

Примечание:

Применимо только для прямоугольных областей.

Текст (Text)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит значение текста ячеек области.

Примечание:

1.Свойство доступно для записи, если ячейка не содержит значения (свойство СодержитЗначение равно Ложь).

2. Применимо только для прямоугольных областей.

Тип

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ТипОбластиЯчеекТабличногоДокумента. Содержит тип области табличного документа.

ТипЗначения (ValueType)

Использование:

Чтение и запись.

Описание:

Тип: ОписаниеТипов. Содержит объект, описывающий допустимые типы значений для ячеек области.

Примечание:

Свойство доступно только если ячейка содержит значение (свойство СодержитЗначение равно Истина).

Применимо только для прямоугольных областей.

Узор (Pattern)

Использование:

Чтение и запись.

Описание:

Тип: ТипУзораТабличногоДокумента. Содержит узор фона области. При определении значения свойства используется системное перечисление ТипУзораТабличногоДокумента.

Формат (Format)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит строку, задающую формат вывода данных в ячейках таблицы.

См. также:

Встроенные функции языка, метод Формат.

ЦветРамки (BorderColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет рамки области.

ЦветТекста (TextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста в ячейках области.

ЦветУзора (PattemColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет узора фона области.

ЦветФона (BackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона области.

ШиринаКолонки

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит ширину столбцов в области (в так называемых средних символах шрифта).

Шрифт (Font)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Содержит шрифт ячеек области.

ЭлементУправления (Control)

Использование:

Только чтение

Описание:

Содержит элемент управления ячеек области.

Примечание:

1.Свойство доступно, только если ячейка содержит значение (свойство СодержитЗначение равно Истина).

2. Применимо только для прямоугольных областей.


1-205 ЭлементУправления

Методы

Обвести (Outline)

Синтаксис:

Обвести(<Граница сверху> , <Граница слева> , <Граница справа>, <Граница снизу>)

Параметры:

<Граница сверху > Необязательный

Тип: Линия. Задает тип верхней границы.

Значение по умолчанию: Если параметр не указан, верхняя граница не рисуется.

<Граница слева> Необязательный

Тип: Линия. Задает тип границы слева.

Значение по умолчанию: Если параметр не указан, граница слева не рисуется.

< Граница справа > Необязательный

Тип: Линия. Задает тип границы справа.

Значение по умолчанию: Если параметр не указан, граница справа не рисуется.

<Граница снизу> Необязательный

Тип: Линия. Задает тип нижней границы.

Значение по умолчанию: Если параметр не указан, нижняя граница не рисуется.

Описание:

Обводит область рамкой.

Объединить (Merge)

Синтаксис:

Объединить()

Описание:

Объединяет ячейки области.

Пример:

Область = ТабДок.Область(2,2,3,3);
Область.Объединить();

См. также:

ОбластьЯчеекТабличногоДокумента, метод Разъединить.

Очистить (Clear)

Синтаксис:

Очистить ( <Очищать текст> , <Очищать форматирование , <Очищать рамки> )

Параметры:

<Очищать текст> Необязательный

Тип: Булево. Истина - очищать текст ячеек таблицы. Ложь - не очищать текст ячеек.

Значение по умолчанию: Истина.

«Очищать форматирование> Необязательный

Тип: Булево. Истина - очищать формат ячеек таблицы, Ложь - не очищать формат ячеек.

Значение по умолчанию: Ложь.

<Очищать рамки> Необязательный

Тип: Булево. Истина - удалять рамки ячеек области. Ложь - не удалять рамки ячеек.

Значение по умолчанию: Ложь.

Описание:

Очищает содержимое области.

Пример:

Область.Очистить() ;

Разгруппировать (Ungroup)

Синтаксис:

Разгруппировать()

Описание:

Позволяет разгруппировать строки или столбцы области. Может использоваться только для областей, состоящих из строк или

столбцов.

Пример:

Область.Разгруппировать();

См. также:

ОбластьЯчеекТабличногоДокумента, метод Сгруппировать.

Разъединить (Unmerge)

Синтаксис:

Разъединить()

Описание:

Разъединяет объединенные в области ячейки.

Пример:

Область = ТабДок.Область(2,2,3,3) ;
Область.Объединить();
Область.Разъединить();

См. также:

ОбластьЯчеекТабличногоДокумента, метод Объединить.

Сгруппировать (Group)

Синтаксис:

Сгруппировать(< Имя группы>}

Параметры:

<Имя группы>Необязательный

Тип: Строка. Название группы.

Описание:

Позволяет сгруппировать область, состоящую из строк или столбцов.

Пример:

Область.Сгруппировать("Товар");

См. также:

ОбластьЯчеекТабличногоДокумента, метод Разгруппировать.

УстановитьЭлементУправления (SetControl)

Синтаксис:

УстановитьЭлементУправления (< Тип элемента управления> )

Параметры:

<Тип элемента управления> Обязательный

Тип: Тип. Тип устанавливаемого элемента управления.

Описание:

Устанавливает элемент управления, которым будут изменяться ячейки в области табличного документа.


1-210 КоллекцияРисунковТабличногоДокумента

КоллекцияРисунковТабличногоДокумента (TableDocumentDrawingsCollection)

Представляет собой коллекцию рисунков, вставленных в табличный документ.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа РисунокТабличногоДокумента. Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс рисунка.

Свойства

<Имя рисунка>

Использование:

Только чтение.

Описание:

Тип: РисунокТабличногоДокумента. Набор свойств содержит рисунки табличного документа. Имена свойств совпадают с именами рисунков табличного документа.

Методы

Добавить (Add)

Синтаксис:

Добавить(< Тип рисунка>)

Параметры:

<Тип рисунка> Обязательный

Тип: системное перечисление ТипРисункаТабличногоДокумента. Тип добавляемого рисунка.

Возвращаемое значение:

Тип: РисунокТабличногоДокумента. Добавленный рисунок.

Описание:

Добавляет рисунок в коллекцию рисунков табличного документа.

Индекс (IndexOf)

Синтаксис:

Индекс(< Рисунок>)

Параметры:

<Рисунок> Обязательный

Тип: РисунокТабличногоДокумента. Рисунок табличного документа, индекс которого нужно определить.

Возвращаемое значение:

Тип: Число. Индекс рисунка в коллекции.

Описание:

Позволяет определить индекс рисунка в коллекции.

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество рисунков в коллекции.

Описание:

Получает количество рисунков в коллекции.

Очистить (Clear)

Синтаксис:

Очистить()

Описание:

Удаляет все рисунки из табличного документа.

Удалить (Remove)

Синтаксис:

Удалить(< Рисунок>)

Параметры:

<Рисунок> Необязательный

Тип: РисунокТабличногоДокумента. Удаляемый рисунок.

Описание:

Удаляет рисунок из коллекции рисунков табличного документа.


1-213 РисунокТабличногоДокумента

РисунокТабличногоДокумента (TableDocumentDrawing)

Представляет собой рисунок табличного документа.

Свойства

АвтоОтметкаНезаполненного

Использование:

Чтение и запись.

Описание:

Тип: Булево. Необходимо ли выделять рисунок, в которой не заполнено значение, либо оно выставлено в значение по умолчанию.

Примечание:

Применимо для рисунков типа Текст.

Авторазмер (AutoSize)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак автоматического расчета размера для рисунка.

Примечание:

Применимо для рисунков типа Текст, Примечание.

ВертикальноеПоложение (VerticalAlignment)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ВертикальноеПоложение. Определяет горизонтальное выравнивание текста в рисунке.

Примечание:

Применимо для рисунков типа Текст, Примечание.

Верх (Тор)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит положение верхней границы рисунка, отсчитываемое от верхней стороны табличного документа (в миллиметрах).

ВыводитьНаПечать (Printable)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак вывода рисунка на печать.

ВыделятьОтрицательные

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак выделения текста, содержащего отрицательные числа.

Примечание:

Применимо для рисунков типа Текст, Примечание.

Высота (Height)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит высоту рисунка (в миллиметрах).

Гиперссылка (HyperLink)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Признак того, что рисунок является гиперссылкой. Все команды обработки для рисунка, являющегося гиперссылкой, вызываются по одинарному щелчку мыши на рисунке.

ГоризонтальноеПоложение (HorizontalAlignment)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ГоризонтальноеПоложение. Определяет горизонтальное выравнивание текста в рисунке.

Примечание:

Применимо для рисунков типа Текст, Примечание.

ГраницаСверху (TopBorder)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак наличия верхней границы у рисунка. Если значение свойства Истина, рисунок будет иметь верхнюю границу.

Примечание:

Применимо для рисунков типа Текст, Прямоугольник, Примечание. '

ГраницаСлева (LeftBorder)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак наличия левой границы у рисунка. Если значение свойства Истина, рисунок будет иметь левую границу.

Примечание:

Применимо для рисунков типа Текст, Прямоугольник, Примечание.

ГраницаСнизу (BottomBorder)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак наличия нижней границы у рисунка. Если значение свойства Истина, рисунок будет иметь нижнюю границу.

Примечание:

Применимо для рисунков типа Текст, Прямоугольник, Примечание.

ГраницаСправа (RightBorder)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак наличия правой границы у рисунка. Если значение свойства Истина, рисунок будет иметь правую границу.

Примечание:

Применимо для рисунков типа Текст, Прямоугольник, Примечание.

Защита (Protection)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак защиты рисунка от изменений.

Значение (Value)

Использование:

Чтение и запись.

Описание:

Содержит значение рисунка.

Примечание:

Доступно только для рисунков типа Текст если в рисунке хранится значение (свойство СодержитЗначение равно Истина).

Имя (Name)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя рисунка.

Картинка (Picture)

Использование:

Чтение и запись.

Описание:

Тип: Картинка. Содержит картинку рисунка.

Примечание:

Применимо только для рисунков типа Картинка.

Лево (Left)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит положение левой границы рисунка, отсчитываемое от левой стороны табличного документа (в миллиметрах).

Линия (Line)

Использование:

Чтение и запись.

Описание:

Тип: Линия. Содержит тип линии рисунка.

Объект (Object)

Использование:

Только чтение.

Описание:

Тип: Произвольный. Содержит объект, содержащийся в рисунке.

Примечание:

Применимо только для рисунков типа Объект и Диаграмма.

ОриентацияТекста (TextOrientation)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит угол наклона текста по отношению к горизонтальному положению в градусах.

Примечание:

Применимо для рисунков типа Текст, Примечание.

ОтметкаНезаполненного

Использование:

Чтение и запись.

Описание:

Тип: Булево. Необходимость помечать рисунок.

РазмерКартинки (PictureSizeMode)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление РазмерКартинки. Содержит способ приспособления оригинальных размеров картинки к размеру рисунка.

Примечание:

Применимо только для рисунков типа Картинка.


1-222 РисунокТабличногоДокумента

РазмещениеТекста (TextPlacement)

Использование:

Чтение и запись.

Описание:

Тип: ТипРазмещенияТекстаТабличногоДокумента. Содержит тип размещения текста рисунка.

При определении значения свойства используется системное перечисление:

ТипРазмещенияТекстаТабличногоДокумента
Авто | Не помещающийся по ширине текст будет показан в соседних по горизонтали ячейках, если в них нет текста
Забивать | Видимая часть текста будет ограничена левой и правой границами ячейки, если при этом текст не умещается полностью, то все символы видимой части будут отображаться как "#". (Применяется для предотвращения неправильного восприятия обрезанного текста)
Обрезать | Видимая часть текста будет ограничена левой и правой границами ячейки
Переносить | Не помещающийся по ширине текст будет переноситься на следующие строки ячейки

Примечание:

Применимо для рисунков типа Текст, Примечание.

Расшифровка (Details)

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Содержит значение расшифровки рисунка.

СодержитЗначение (ContainValue)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак того, что ячейки области содержат значения.

Примечание:

Применимо только для рисунков типа Текст.

Текст (Text)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст рисунка.

Примечание:

Применимо для рисунков типа Текст, Примечание.

ТипЗначения (VaiueType)

Использование:

Чтение и запись.

Описание:

Тип: ОписаниеТипов. Содержит объект, описывающий допустимые типы значений для рисунка.

Примечание:

Доступно только для рисунков типа Текст если в рисунке хранится значение (свойство СодержитЗначение равно Истина).

ТипРисунка (DrawingType)

Использование:

Только чтение.

Описание:

Тип: системное перечисление ТипРисункаТабличногоДокумента. Содержит тип рисунка.

Узор (Pattern)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ТипУзораТабличногоДокумента. Содержит узор рисунка.

Примечание:

Не применимо для рисунков типа Прямая.

Формат (Format)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит строку формата значения.

Примечание:

Применимо только для рисунков типа Текст.

ЦветЛимии (LineColor)

Использсвание:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет линий рисунка.

Примечание:

Не применимо для рисунков типа Картинка.

ЦветТекста (TextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста рисунка.

Примечание:

Применимо для рисунков типа Текст, Примечание.

ЦветУзора (PattemColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет узора рисунка.

Примечание:

Не применимо для рисунков типа Прямая.

ЦветФона (BackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона рисунка.

Примечание:

Не применимо для рисунков типа Прямая.

Ширина (Width)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит ширину рисунка (в миллиметрах).

Шрифт (Font)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Содержит шрифт текста рисунка.

Примечание:

Применимо для рисунков типа Текст, Примечание.

ЭлементУправления (Control)

Использование:

Только чтение.

Описание:

Содержит элемент управления рисунка.

Примечание:

Доступно только для рисунков типа Текст если в рисунке хранится значение (свойство СодержитЗначение равно Истина).

Методы

Расположить (Place)

Синтаксис:

Расположить(< Область ячеек>)

Параметры:

<Область ячеек> Обязательный

Тип: ОбластьЯчеекТабличногоДокумента. Область, в которой будет расположен рисунок.

Описание:

Позволяет расположить рисунок в указанной области ячеек табличного документа.

Пример:

ТабДок = Новый ТабличныйДокумент;
МояКартинка = Новый Картинка( "C:\My
Documents\qwerty .bmp") ;
Рис=ТабДок.Рисунки.Добавить(ТилРисункаТабличногоДокумента.Картинка) ;
Индекс=ТабДок,Рисунки.Индекс(Рис);
ТабДок.Рисунки[Индекс].Картинка = МолКартинка;
ТабДок.Рисунки[Индекс].Расположить(ТабДок.Область("R1C1:R4C4"));
ТабДок.Показать();

УстановитьЭлементУправления (SetControl)

Синтаксис:

УстановитьЭлементУправления (< Тип элемента управления>)

Параметры;

<Тип элемента управления> Обязательный

Тип: Тип. Задает тип элемента управления, который устанавливается.

Описание:

Позволяет установить элемент управления для редактирования значения рисунка типа "Текст".

Примечание:

Применяется только для рисунков типа Текст. Доступно, если свойство СодержитЗначение равно Истина.


1-230 ПараметрыМакетаТабличногоДокументa

ПараметрыМакетаТабличногоДокументa (TableDocumentTemplateParameters)

Представляет собой коллекцию параметров, используемых в ячейках макета табличного документа.

Данный объект является коллекцией значений. Возможно обращение к значению параметра посредством оператора [...]. В качестве аргумента передается индекс параметра.

См.также:

ТабличныйДокумент, свойство Параметры.

Свойства

<Имя параметра>

Использование:

Чтение и запись.

Описание:

Набор свойств содержит параметры, используемые в ячейках макета табличного документа. Имена свойств совпадают с именами параметров.

Параметры служат для вывода в ячейках табличного документа данных, содержащихся в информационной базе, либо получаемых в результате расчетов. Для этого параметрам табличного документа нужно присвоить необходимые по смыслу значения.

Методы

Заполнить

Синтаксис:

Заполнить(Объект)

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество параметров в коллекции.

Описание:

Получает количество параметров в коллекции.

КолонтитулТабличногоДокумента (TableDocumentHeaderFooter)

Используется для доступа к колонтитулам табличного документа. Колонтитул является специальным текстом, выводимым вверху или внизу каждой страницы при выводе документа на печать.

См. также:

ТабличныйДокумент, свойство ВерхнийКолонтитул. ТабличныйДокумент, свойство НижнийКолонтитул.

Свойства ВертикальноеПоложение (VerticalAlignment)

Использование:

Чтение и запись.

Описание:

Тип: ВертикальноеПоложение. Содержит способ выравнивания текста колонтитула по вертикали.

При определении значения свойства используется системное перечисление ВертикальноеПоложение.

Выводить (Enabled)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак вывода колонтитула на печать.

НачальнаяСтраница (StartPage)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит номер страницы, начиная с которой будет выводиться колонтитул.

ТекстВЦентре (CenterText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст в центре колонтитула.

См. также:

КолонтитулТабличногоДокумента, свойство ТекстСлева.

ТекстСлева (LeftText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст в левой части колонтитула. В тексте колонтитула можно использовать следующие управляющие конструкции:

• [&НомерСраницы] ([&PageNumber]) - при печати в данном месте будет выведен номер страницы,

• [&СтраницВсего] ([&PagesTotal]) - при печати в данном месте будет выведено общее количество страниц,

• [&Дата] ([&Date]) - при печати в данном месте будет выведена текущая дата,

• [&Время] ([&Time]) - при печати в данном месте будет выведено текущее время.

ТекстСправа (RightText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст в правой части колонтитула.

См. также:

КолонтитулТабличногоДокумента, свойство ТекстСлева.

Шрифт (Font)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Содержит шрифт колонтитула.


1-234 Работа с объектами метаданных

Работа с объектами метаданных

В системе предусмотрена возможность работы с метаданными конфигурации, обращения к свойствам объектов метаданных. Данная возможность является дополнительной возможностью и применяется в специальных случаях, например, для создания универсальных отчетов или обработок, которые обращаются к объектам различных типов (документам, справочникам и т.п.). В основных алгоритмах конфигурации данная возможность, как правило, не используется.

Объект описания конфигурации

Объект предназначен для обращения к метаданным конфигурации. Доступ к объекту осуществляется через свойство глобального контекста Метаданные. Объект предоставляет доступ к общим свойствам конфигурации и к основным коллекциям описаний свойств объектов метаданных (документам, справочникам и т.п.). Полученный из свойств этой коллекции объект метаданных предоставляет в свою очередь доступ к свойствам документа и к коллекциям объектов метаданных подчиненного класса (например, реквизитам, табличным частям справочника и т.п.) и так далее.

Таким образом, общую схему объектов метаданных конфигурации можно представить так:

<Объект описания конфигурации> ->
<Коллекция объектов описания метаданных> ->
<Объект описания метаданных> ->
<Коллекция объектов описания метаданных> ->
<Объект описания метаданных>... и т.д.

Важно! Данному объекту доступны все свойства и методы объекта Объект описания метаданного.

См.также:

Глобальный контекст, свойство Метаданные.

Свойства

СвойстваОбъектов (ObjectsProperties)

Использование:

Только чтение.

Описание:

Тип: Свойства объектов метаданных. Предоставляет доступ к системным перечислениям, которые используются в объектах метаданных.

Объект описания метаданного

Объект предназначен для обращения к метаданным конфигурации. Доступ к объекту осуществляется через свойство объекта Коллекция объектов описания метаданных.

Свойства

<Имя подчиненного кпасса>

Использование:

Только чтение.

Описание:

Тип: Коллекция объектов описания метаданных. Набор свойств содержит коллекции объектов описания метаданных данного объекта метаданных. Конкретный состав коллекций зависит от типа объекта метаданных.

Примечание:

Ознакомиться с составом и именами подчиненных классов можно в режиме конфигурирования, выведя описание конфигурации.

<ИмяСвоиства>

Использование:

Только чтение.

Описание:

Набор свойств содержит значения свойств объекта метаданных. Конкретный состав свойств зависит от типа объекта метаданных.

Примечание:

Ознакомиться с составом и именами свойств можно в режиме конфигурирования, выведя описание конфигурации.

Методы

Представление (Presentation)

Синтаксис:

Представление()

Возвращаемое значение:

Тип: Строка.

Описание:

Возвращает строковое представление объекта метаданных. Как правило, в качестве строкового представления выступает синоним, а при его отсутствии имя объекта метаданных, как оно задано в конфигураторе.

Пример:

Для каждого Объект Из Метаданные.Справочники Цикл
Сообщить(Объект.Представление());
КонецЦикла;

Родитель (Parent)

Синтаксис:

Родитель()

Возвращаемое значение:

Тип: Объект описания метаданного.

Описание:

Позволяет определить объект описания метаданного, которому подчинен данный объект.

Пример:

// В данном примере метод вернет значение
// Метаданные.Документы.РасхНакладная
Метаданные.Документы.РасхНакладная.Реквизиты.Цена.Родитель();

Коллекция объектов описания метаданных

Объект представляет собой коллекцию объектов описания метаданных определенного типа.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа Объект описания метаданного. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции.. Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс объекта в дереве метаданных.

Свойства

<Имя объекта описания метаданного>

Использование:

Только чтение.

Описание:

Тип: Объект описания метаданного. Набор свойств содержит объекты описания подчиненного класса объектов метаданных. Имена свойств совпадают с именами объектов метаданных, как они заданы или обозначены в конфигураторе.

Примечание:

Ознакомиться с составом и именами объектов метаданных можно в режиме конфигурирования, выведя описание конфигурации.

Методы

Индекс

Синтаксис:

Индекс(ОписаниеМетаданного)

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество элементов коллекции.

Описание:

Позволяет определить количество элементов коллекции.

Найти

Синтаксис:

Найти(Наименование)


1-239 Свойства объектов метаданных

Перечислимые свойства объектов метаданных

Объект предоставляет доступ к системным перечислениям, выступающим в качестве значений свойств объектов метаданных. Состав и описание системных перечислений объектов метаданных описан в разделе "Системные перечисления свойств объектов метаданных".

Системные перечисления свойств объектов метаданных

Системные перечисления предназначены для определения некоторого набора предопределенных значений. Доступ к системным перечислениям этой группы осуществляется как к свойствам объекта Свойства объектов метаданных. Конкретные значения указываются через точку от имени системного перечисления. Системные перечисления этой группы используются, как правило, для определения значений свойств объектов метаданных в логических выражениях.

ВариантВстроенногоЯзыка

Английский Определяет варианты используемого встроенного языка
Русский

ВидРегистраНакопления

Обороты | Регистр оборотов
Остатки | Регистр остатков

ВидЭлементаСтиля

Рамка | Рамка
Цвет | Цвет
Шрифт | Шрифт

Индексирование (набор вариантов индексирования
по реквизиту справочника, документа, измерению регистра)

Индексировать | Индексировать
ИндексироватьСДопУпорядочиванием | Индексировать с дополнительным упорядочиванием
НеИндексировать | Не индексировать

ИспользованиеРеквизита (набор вариантов использования
реквизита справочника для групп и элементов)

ДляГруппы | Использовать реквизит только для групп
ДляОбоих | Использовать реквизит для элементов и для групп
ДляЭлемента | Использовать реквизит только для элементов

РежимОкругления

Окр15как10 | При округлении 1.5 будет округлено до 1
Окр15как20 | При округлении 1.5 будет округлено до 2

ОсновноеПредставлениеСправочника

ВВидеКода | Основное представление - код
ВВидеНаименования | Основное представление - наименование

ПериодичностьНомераДокумента

Год | В пределах года
День | В пределах дня
Квартал | В пределах квартала
Месяц | В пределах месяца
Непериодический | Непериодический

ПериодичностьРегистраСведений

Год | В пределах года
День | В пределах дня
Квартал | В пределах квартала
Месяц | В пределах месяца
Непериодический | Непериодический
ПозицияРегистратора | По позиции регистратора. Используется, если запись регистра подчинена регистратору
Секунда | В пределах одной секунды

Проведение (возможность/невозможность проведения документа)

Запретить | Запретить проведение
Разрешить | Разрешить проведение

РежимЗаписиРегистра (варианты режима записи регистра сведений)

Независимый | Независимый режим записи
ПодчинениеРегистратору | Подчиненный регистратору режим записи

СерииКодовСправочника (варианты диапазона проверки кода
на уникальность и автоматического присвоения кодов элементов справочника)

ВоВсемСправочнике | Уникальность кода проверяется среди всех элементов справочника
ВПределахПодчинения | Уникальность кода проверяется только в пределах подчинения элемента справочника

СпособРедактирования

ВДиалоге | Использовать форму элемента для ввода и редактирования информации
ВСписке | Использовать форму списка для ввода и редактирования информации
ОбоимиСпособами | Можно использовать как форму списка, так и форму элемента для ввода и редактирования информации

ТипКодаСправочника

Строка | Строковый
Число | Числовой

ТипНомераДокумента

Строка | Строковый
Число | Числовой

УдалениеДвижений (варианты удаления движений документа по
регистрам при проведении и отмене проведения)

НеУдалятьДвиженияАвтоматически | Не удалять движения документа
УдалятьДвиженияАвтоматически | Автоматически удалять движения документа


1-246 Работа с файлами

Работа с файлами

Для работы с файлами в 1C: Предприятии используются объекты Файл и ДиалогВыбораФайла.

Файл является средством управления параметрами файлов.

ДиалогВыбораФайла представляет собой диалог специального вида для открытия или сохранения файлов.

Файл (File)

Используется для доступа к параметрам файлов или каталогов. Необходимо отметить, что данный объект не предназначен для чтения и записи из файлов.

Пример:

ИмяФайла = "C:\Test\readme.txt";
ВыбФайл = Новый Файл(ИмяФайла);
Если ВыбФайл.Существует() Тогда
Стр = "Результат выполнения:"+Символа.ПС+
+"Файл: "+ВыбФайл.ПолноеИмя+Символы.ПС+
+"Имя: "+ ВыбФайл.Имя+Символы.ПС+
+"Имя без расширения: "+Вы6Файл.ИмяБезРасширения+Символы.ПС+
+"Расширение: " +ВыбФайл. Расширение+Символы. ПС+
+"Путь: "+ВыбФайл.Путь+Символы.ПС+
+"Размер: "+ВыбФайл.Размер()+Символы.ПС+
+"Это файл: "+ВыбФайл.ЭтоФайл()+Символы.ПС+
+"Время изменения: "+ВыбФайл.ПолучитьВремяИзменения()+Символы.ПС+
+"Только чтение: "+ВыбФайл.ПолучитьТолькоЧтение( )+Символы.ПС+
+"Невидимость: "+Вы6Файл.ПолучитьНевидимость() ;
Сообщить(Стр);
Иначе
Предупреждение("Файл не найден!");
КонецЕсли

Результат выполнения:

Файл: C:\Test\readme.txt
Имя: readme.txt
Имя без расширения: readme
Расиирение: .txt
Путь: C:\Test\
Размер: 916
Это файл: истина
Время изменения: 31.10.2000 12:42:04
Только чтение: истина
Невидимость: ложь

Свойства

Имя (Name)

Использование:

Только чтение.

Описание:

Тип: Строка. Содержит имя файла, с которым связан объект.

ПолноеИмя (FullName)

Использование:

Только чтение.

Описание:

Тип: Строка. Содержит полное имя файла (включающее путь к файлу), с которым связан объект.

Методы

ПолучитьВремяИзменения

Синтаксис:

ПолучитьВремяИзменения()

Возвращаемое значение:

Тип: Дата. Время последнего изменения файла.

Описание:

Позволяет получить время последнего изменения файла.

Примечание:

Применим только к файлам или каталогам, которые реально существуют.

Пример:

ВремяИзмекения = ВыбФайл.ПолучитьВремяИзменения();

ПолучитьНевидимость (GetHidden)

Синтаксис:

ПолучитьНевидимость()

Возвращаемое значение:

Тип: Булево. Истина - у файла установлен атрибут "Скрытый", Ложь - у файла атрибут "Скрытый" не установлен.

Описание:

Получает значение атрибута файла "Скрытый" ("Hidden").

Примечание:

Применим только к файлам или каталогам, которые реально существуют.

Пример:

Невидимость = ВыбФайл.ПолучитьНевидимость();

ПолучитьТолькоЧтение (GetReadOnly)

Синтаксис:

ПолучитьТолькоЧтение()

Возвращаемое значение:

Тип: Булево. Истина - у файла установлен атрибут "Только чтение", Ложь - у файла атрибут "Только чтение" не установлен.

Описание:

Получает значение атрибута файла "Только чтение" ("Read only').

Примечание:

Применим только к файлам или каталогам, которые реально существуют.

Пример:

ТолькоЧтение = ВыбФайл.ПолучитьТолькоЧтение();

Размер (Size)

Синтаксис:

Размер()

Возвращаемое значение:

Тип:Число.

Описание:

Позволяет определить размер файла (в байтах).

Примечание:

Применим только к файлам, которые реально существуют.

Пример:

РазмерФайла = ВыбФайл.Размер();

Существует (Exist)

Синтаксис:

Существует()

Возвращаемое значение:

Тип: Булево. Истина - файл существует, Ложь - файл не существует.

Описание:

Определяет, существует ли файл, соответствующий данному объекту.

Пример:

Если Не ВыбФайл-Существует() Тогда
Предупреждение ('Указанный файл не существуете);
КонецЕсли ;

УстановитьВремяИзменения (SetModifiedTime)

Синтаксис:

УстановитьВремяИзменения(< Время изменения>)

Параметры:

<Время иэмвнения> _Обязательный

Тип: Дата. Устанавливаемое время изменения файла или каталога.

Описание:

Устанавливает время последнего изменения файла.

Примечание:

Применим только к файлам или каталогам, которые реально существуют.

Пример:

ВыбФайл.УстановитьВремяИзменения (ТекущаяДата ());

УстановитьНевидимость (SetHidden)

Синтаксис:

УстановитьНевидимость (< Невидимость>)

Параметры:

<Невидимость> Обязательный

Тип: Булево. Истина - установить атрибут "Скрытый", Ложь - снять атрибут "Скрытый".

Описание:

Устанавливает значение атрибута файла "Скрытый" ("Hidden").

Примечание:

Применим только к файлам или каталогам, которые реально существуют.

Пример:

ВыбФайл.УстановитьНевидимость(Истина);

УстановитьТолькоЧтение (SetReadOnly)

Синтаксис:

УстановитьТолькоЧтение (< Только чтение> )

Параметры:

<Толъко чтение> Обязательный

Тип: Булево. Истина - установить атрибут "Только чтение", Ложь - снять атрибут "Только чтение".

Описание:

Устанавливает значение атрибута файла "Только чтение" ("Read only").

Примечание:

Применим только к файлам или каталогам, которые реально существуют.

Пример:

ВыбФайл.УстановитьТолькоЧтение(Истина);

ЭтоКаталог (IsDirectory)

Синтаксис:

ЭтоКаталог()

Возвращаемое значение:

Тип: Булево. Истина - объект соответствует каталогу. Ложь - объект соответствует файлу.

Описание:

Позволяет определить, соответствует файловый объект каталогу или файлу.

Примечание:

Применим только к файлам, которые реально существуют.

Пример:

Если Не ВыбФайл.ЭтоКаталог() Тогда
Предупреждение("Укажите каталог!");
КонецЕсли;

Этофайл (IsFile)

Синтаксис:

ЭтоФайл()

Возвращаемое значение:

Тип: Булево. Истина - объект соответствует файлу. Ложь -объект соответствует каталогу.

Описание:

Позволяет определить, соответствует файловый объект файлу или каталогу.

Примечание:

Противоположен методу ЭтоКаталог. Применим только к файлам, которые реально существуют.

Пример:

Если Не ВыбФайл.ЭтоФайл() Тогда
Предупреждение("Укажите файл!");
КонецЕсли;

Конструкторы

Файл

Синтаксис:

Новый Файл(< Имя>)

Параметры:

<Имя>Обязательный

Полное имя файла или каталога, с которым будет связан конструируемый объект.

Описание:

Позволяет создать новый файловый объект, связанный с указанным файлом.


1-252 ДиалогВыбораФайла

ДиалогВыбораФайла (FileDialog)

Представляет собой диалог специального вида для открытия файла или нескольких файлов, сохранения файла или выбора каталога.

Пример:

Режим = РежимДиалогаВыбораФайла.Открытие;
ДиалогОткрытияФайла = Новый
ДиалогВыбораФайла(Режим);
ДиалогОткрытияФайла.ПолноеИмяФайла
= "';
Фильтр = "Текст (*.txt) |*.txt";
ДиалогОткрытияФайла.Фильтр = фильтр ;
ДиалогОткрытияФайла.МножественныйВыбор = Истина;
ДиалогОткрытияФайла.Заголовок = "Выберите файлы";
Если ДиалогОткрытияФайла.Выбрать() Тогда
МассивФайлов = ДиалогОткрытияФайла.ВыбранныеФайлы;
Для каждого ИмяФайла Из МассивФайлов Цикл
ВыбФайл = Новый Файл(ИмяФайла);
Сообщить(ИмяФайла+"; Размер = "+ВыбФайл.Размер());
КонецЦикла;
Иначе
Предупреждение("Файл(ы)
не выбран!");
КонецЕсли;

Свойства

ВыбранныеФайлы (SelectedFiles)

Использование:

Только чтение.

Описание:

Тип: Массив. Содержит массив строк с полными именами файлов, выбранных в диалоге.

Примечание:

В режиме выбора каталога содержит пустой массив.

Заголовок (Title)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст заголовка окна диалога выбора файла (файлов).

ИндексФильтра (Filterindex)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит индекс активного фильтра в списке фильтров.

Каталог (Directory)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит значение текущего каталога. В режиме выбора каталога может использоваться для определения выбранного каталога.

МножественныйВыбор (Multiselect)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак множественного выбора файлов.

Примечание:

Не используется в режимах сохранения или выбора каталога.

ПолноеИмяФайла (FullFileName)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит начальное полное имя файла. После выбора файла содержит имя выбранного файла (кроме режима множественного выбора файлов или выбора каталога).

ПредварительныйПросмотр (Preview)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак показа окна предварительного просмотра файлов.

Примечание:

Не используется в режиме выбора каталога.

ПроверятьСуществованиеФайла

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак проверки существования выбираемого файла.

Примечание:

Не используется в режиме выбора каталога.

Расширение (DefaultExt)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит расширение файла по умолчанию, которое будет использоваться системой при записи файла.

Режим (Mode)

Использование:

Только чтение.

Описание:

Тип: РежимДиалогаВыбораФайла. Содержит режим диалога для выбора файла.

Фильтр (Filter)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит строку с набором файловых фильтров. Фильтр состоит из двух частей, разделенных символом "|" (вертикальная черта): строки представления, которая отображается в окне выбора файла, и строки маски. В строке маски допускается использование символа "*" (звездочка), обозначающего любое число произвольных символов, и "?" (знак вопроса), обозначающего один произвольный символ. Можно последовательно перечислить несколько фильтров, разделенных символом "|" (вертикальная черта).

Пример строки: "Текстовый документ(*.tхt|*.(х1.|Табличный до-кумент(*.тх1)|*.тх1" ??????????????

Методы

Выбрать (Choose)

Синтаксис:

Выбрать()

Возвращаемое значение:

Тип: Булево. Истина - выбор/сохранение завершено успешно, Ложь - иначе.

Описание:

Открывает окно диалога выбора файла.

Пример:

ДиалогОткрытияФайда.Выбрать();

Конструкторы

Основной

Синтаксис:

Новый ДиалогВыбораФайла(< Режим работы>)

Параметры:

<Режим работы> Обязательный

Тип: РежимДиалогаВыбораФайла. Режим работы конструируемого диалога.

Описание:

Позволяет создать диалог выбора файла с заданным режимом работы.


1-258 XBase

XBase

Для работы с базами данных формата DBF в системе может использоваться специальный объект - XBase. Механизм работы с базами данных формата DBF предназначен для обеспечения возможности манипулирования ими непосредственно из встроенного языка 1C: Предприятия. Каждый объект XBase может быть связан с одним файлом базы данных.

Основные понятия

Для облегчения понимания материала данного раздела читателем, не имеющим опыта работы с базами данных, ниже приводятся пояснения терминов, использованных при описании средства встроенного языка для работы с базами данных - объекта XBase.

Поля и записи

Если Вы не знакомы с концепцией базы данных, то ее можно себе представить в виде упорядоченного хранилища информации типа картотеки. Хорошим примером базы данных может служить телефонный справочник организации. Он содержит фамилии, номера телефонов и номера комнат всех сотрудников организации. Каждая строка справочника соответствует одной записи, а каждая колонка - полю. Каждое поле имеет наименование и характеристики информации, для хранения которой оно предназначено: тип, длина, точность. Содержимое поля для конкретной записи называется значением поля. Напри-мер, телефонный справочник, может быть организован в виде таблицы с колонками (полями) "Фамилия Имя Отчество", "№ комнаты", "Телефон", каждая строка (запись) содержит информацию об одном абоненте.

Таблица, структура таблицы, файл базы данных

Весь справочник целиком в терминах баз данных называется таблицей. Состав входящих в таблицу полей определяет структуру таблицы, а состав входящих в таблицу записей - ее содержание. Каждая запись в таблице состоит из того же набора полей, что и таблица целиком, поэтому иногда употребляется термин структура записи. Это понятие адекватно структуре таблицы, хотя употребление первого термина представляется более корректным, т.к. таблица имеет структуру независимо от того, имеется ли в ней хотя бы одна запись.

Реализация баз данных формата DBF подразумевает, что каждая таблица хранится в отдельном файле. Поэтому в дальнейшем мы будем применять термин "файл базы данных" или "файл БД", имея в виду таблицу базы данных.

Индексы, выражения индекса и фильтра, индексный файл

Для организации упорядочивания содержимого файла БД и поиска в ней по значению одного или нескольких полей применяется механизм индексов. Его применение можно сравнить с сортировкой картотеки по определенному признаку (совокупности признаков). Однако, в отличие от картотеки, файл БД может иметь сразу несколько индексов, и, соответственно, являться упорядоченным одновременно по нескольким признакам. Каждый индекс имеет наименование, признак уникальности, выражение индекса и фильтр. Наименование индекса используется для идентификации индекса. Выражение индекса и фильтр представляют собой написанные на специальном языке выражения, вычисление значения которых для каждой записи позволяет определить ее место при упорядочивании и необходимость помещения ее в упорядоченный список (индекс может содержать упоминание не обо всех записях таблицы, а только об удовлетворяющих выражению фильтра). Уникальный индекс (имеющий установленным признак уникальности) позволяет иметь в индексе ссылки на записи только с различным значением индексного выражения.

Индексы хранятся в индексном файле. Индексный файл может содержать информацию более чем об одном индексе.

Запись изменений в базу данных

Каждый объект представляет собой структуру данных, расположенных в памяти компьютера и изменение содержимого его свойств не вызывает немедленного изменения в файлах базы данных. При включенном режиме автосохранения запись содержимого объекта в файлы БД происходит при изменении позиционирования (переход с следующей записи, поиск по ключу и т.д.), при выключенном режиме автосохранения запись изменений происходит только при вызове соответствующего метода объекта.

Работа с индексными файлами

Следует иметь в виду, что одновременно XBase-объект может быть связан не более, чем с одним индексным файлом. Все изменения в базе данных, сделанные в сеансе работы с одним индексным файлом, никак не отражаются на остальных. Поэтому не рекомендуется иметь более одного индексного файла для БД. В противном случае, после каждого открытия БД с индексным файлом, отличным от открытого в предыдущем сеансе работы с базой, следует производить переиндексацию (обновление содержимого индексного файла).

Удаление записей

Удаление записи из базы данных не приводит к физическому уничтожению ее на диске. В этом случае в специальном служебном поле записи, не доступном обычными средствами, ставится пометка об удалении. На записи, помеченные удаленными, позиционирования не происходит, если не включен специальный режим просмотра удаленных записей. Имеется свойство, управляющее специальным режимом просмотра, а также набор методов для определения, является ли спозиционированная запись удаленной, и восстановления удаленной записи.

Метод сжатия базы вызывает физическое уничтожение записей, помеченных как удаленные. Метод очистки базы вызывает физическое уничтожение всех записей. После применения этих методов восстановление удаленных записей становится невозможным.

Создание базы данных, индекса, индексного файла

Помимо работы с существующими базами данных, объект XBase имеет набор методов, позволяющих создать новую базу данных произвольной структуры, новые индексы и новый индексный файл. Следует отметить, что, если использование методов, изменяющих структуру БД, возможно только для объектов, не связанных с существующей базой данных (т.е. для вновь создаваемых БД), то создание новых индексов и индексного файла возможно как для создаваемых БД, так и для уже существующих и открытых.

Ограничения

Основное назначение объектов XBase - организация экспорта-импорта информации в/из внешних файлов формата DBF.

Объекты XBase не поддерживают поля типа memo.

Объекты XBase поддерживают только монопольный доступ к файлам.

XBase-объекты поддерживают индексные файлы в формате CDX. Однако, использование внешними программами (например, FoxBase) индексных файлов, созданных с помощью объектов XBase, так же, как и использование объектами индексных файлов, созданных внешними программами, не рекомендуется из-за возможной несовместимости версий.

XBase (XBase)

Основной объект для работы с таблицами баз данных в формате DBF. Предоставляет доступ к коллекции полей и индексов таблицы, позволяет открывать и записывать файлы таблиц, работать с записями таблицы.

Свойства

<Имя поля>

Использование:

Чтение и запись.

Описание:

Набор свойств содержит значения полей в текущей записи таблицы базы данных формата DBF, состав и тип которых зависит от структуры файла базы данных, с которым связан конкретный объект. Имена свойств совпадают с именами полей таблицы базы данных.

Автосохранение (AutoSave)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак автоматического сохранения изменений в базе данных.

Индексы (Indexes)

Использование:

Только чтение.

Описание:

Тип: Коллекция индексов XBase. Содержит коллекцию индексов таблицы базы данных формата DBF.

См. также:

Коллекция индексов XBase.

Ключ (Key)

Использование:

Чтение и запись.

Описание:

Предоставляет доступ к объекту Ключ. Объект этого типа имеет только свойства. Состав свойств объекта повторяет набор свойств <Поле> XBase-объекта. Значения свойств используются для вычисления выражения индекса при использовании метода НайтиПоКлючу.

См. также:

XBase, метод НайтиПоКлючу.

ОтображатьУдаленные (ShowDeleted)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак показа удаленных записей.

Поля (Fiedls)

Использование:

Только чтение.

Описание:

Тип: Коллекция полей XBase. Содержит коллекцию полей таблицы базы данных формата DBF.

См. также:

Коллекция полей XBase.

ТекущийИндекс (Currentlndex)

Использование:

Чтение и запись.

Описание:

Тип: Индекс XBase. Содержит текущий используемый индекс. Установка текущего индекса работы с таблицей базы данных оказывает влияние на работу методов поиска и позиционирования: Найти, НайтиПоКлючу, Первая, Последняя, Следующая, Предыдущая.


1-264 Методы объекта XBase

Методы

ВКонце (EOF)

Синтаксис:

ВКонце()

Возвращаемое значение:

Тип: Булево. Истина - указатель в файле находится за последней записью; Ложь - конец файла не достигнут.

Описание:

Получает признак достижения указателем текущей записи конца файла.

Пример:

// Максимальное значение поля COST
хВ.Первая() ;
МаксСтоимость = 0 ;
Пока Не хВ.ВКонцеО Цикл
Если xB.COST > МаксСтоимость Тогда
МаксСтоимость = xB.COST;
КонецЕсли ;
хВ.Следующая();
КонецЦикла;

ВНачале (ВОF)

Синтаксис:

ВНачале()

Возвращаемое значение:

Тип: Булево. Истина - указатель в файле находится перед первой записью; Ложь - начало файла не достигнуто.

Описание:

Получает признак достижения указателем текущей записи начала файла.

Пример:

// Среднее
значение поля
COST
хВ.Последняя();
Стоимость =
0;
Записей
=0;
Пока Не хВ.ВНачале() Цикл
Стоимость = Стоимость +
xB.COST;
Записей = Записей +1;
хВ.Предыдущая();
КонецЦихла;
Если Записей >
0 Тогда
Стоимость = Стоимость / Записей ;
КонецЕсли;

Восстановить (Recall)

Синтаксис:

Восстановить()

Описание:

Снимает с текущей записи пометку удаления.

Пример:

// Восстановление всех удаленных
записей
хВ.ПоказыватьУдаленные = истина;
хВ.Первая();
Пока Не хВ.Вконце() Цикл;
хВ. Восстановить();
хВ.Следующая();
КонецЦикла;          .

Добавить (Add)

Синтаксис:

Добавить()

Описание:

Добавляет новую пустую запись. При этом поля и свойства объекта Ключ очищаются. Для записи изменений в таблицу базы данных необходимо инициировать запись.

Пример:

хВ.Добавить();
xB.CODE = "00004";
xB.NAME = "Клавиатура";
хВ.Записать();

ЗакрытьФайл (CloseFile)

Синтаксис:

ЗакрытьФайл()

Описание:

Закрывает ранее открытую или созданную таблицу базы данных формата DBF.

Пример:

Если хВ.Открыта() Тогда;
хВ.ЗакрытьФайл();
КонецЕсли;

Записать (Save)

Синтаксис:

Записать()

Описание:

Выполняет запись изменений в таблицу базы данных. До его вызова все изменения объекта производились только в памяти и будут потеряны при осуществлении перехода к другой записи или закрытии таблицы базы данных, если отключен режим автосохранения.

См. также:

XBase, свойство Автосохранение.

ЗаписьУдалена (RecDeleted)

Синтаксис:

ЗаписьУдалена()

Возвращаемое значение:

Тип: Булево. Истина - запись удалена; Ложь - запись не удалена.

Описание:

Получает пометки удаления текущей записи.

Пример:

хВ.ПоказыватьУдаленные = Истина;
хВ.Первая();
Пока Не хВ.ВконцеО Цикл
Если хВ.ЗаписьУдалена () Тогда
Сообщить("Удаленная
запись: " + хВ.НомерЗаписи());
КонецЕсли;
хВ.Следующая();
КонецЦикла;

КодОшибки (ErrorCode)

Синтаксис:

КодОшибки()

Возвращаемое значение:

Тип: Число. Код последней ошибки. Возвращаемые коды ошибок:

• -10 - Ошибка закрытия файла;

• -20 - Ошибка создания файла;

• -30 - Ошибка определения длины файла;

• -40 - Ошибка установки длины файла;

• -50 - Ошибка при попытке заблокировать файл;

• -60 - Ошибка при открытии файла;

• -70 - Ошибка чтения файла;

• -80 - Ошибка удаления файла;

• -90 - Ошибка переименования файла;

• -100 - Ошибка позиционирования в файле;

• -110 - Ошибка снятия блокировки с файла;

• -120 - Ошибка записи в файл;

• -200 - Файл не является базой данных DBF-формата;

• -210 - Неопознанное имя поля;

• -220 - Неопознанный тип поля;

• -230 - Запись слишком длинная;

• -300 - Индексный файл не содержит информации о записи;

• -310 - Нарушение структуры индексного файла;

• -330 - Указанное имя индекса недоступно;

• -340 - Ошибка уникальности индекса;

• -400 - Ожидается запятая или скобка;

• -410 - Выражение не завершено;

• -422 - IIF() требует параметров одинаковой длины;

• -425 - У STR() и SUBSTR() 2-й и 3-й параметры - константы;

• -430 - Неверное число параметров;

• -440 - Слишком сложное выражение;

• -450 - Пропущена правая скобка;

• -460 - Неверный тип подвыражения;

• -470 - Неопознанная функция;

• -480 - Неопознанный оператор;

• -490 - Неопознанное значение;

• -500 - Выражение не завершено символом двойной кавычки;

• -920 - Недостаточно памяти.

Описание:

Получает код завершения последней выполненной операции.

Пример:

Если хВ.КодОшибки () = -60 Тогда
Сообщить("Не удалось открыть файл DBF");
КонецЕсли ;

КоличествоЗаписей (RecCount)

Синтаксис:

КоличествоЗаписей()

Возвращаемое значение:

Тип: Число. Количество записей в базе.

Описание:

Получает количество записей в таблице базы данных вместе с помеченными на удаление записями.

Пример:

Предупреждение(" Записей " + Строка (хВ.КодичествоЗаписей ()));

Найти (Find)

Синтаксис:

Найти(<Ключ>, <Режим>)

Параметры:

<Ключ> Обязательный

Тип: Строка. Значение выражения текущего индекса.

<Режим> Обязательный

Тип: Строка. Режим поиска записей:

"=" - ищет запись на точное соответствие ключу;

">=" - ищет запись на точное соответствие с ключом или большую;

">" - ищет запись с большим ключом;

"<=" - ищет запись на точное соответствие с ключом или меньшую;

"<" - ищет запись с меньшим ключом.

Возвращаемое значение:

Тип: Булево. Истина - запись найдена; Ложь - запись не найдена.

Описание:

Позволяет найти запись, соответствующую указанному значению ключа по текущему индексу и режиму поиска, переданному в качестве параметра. Указатель устанавливается на найденную запись.

Примечание:

Следует отметить, что вычисление значения индекса при работе XBase-объекта с таблицей базы данных производится объектом самостоятельно на основании выражения, переданного ему при создании ключа. При вызове данного метода значение Ключ должно быть вычислено средствами встроенного языка, что может представлять определенные трудности, если индекс составной, поля, включенные в выражение индекса, отличны от строковых, и т.д. Поэтому применимость данного метода ограничена случаем использования простых строковых выражений индекса. В более сложных случаях следует применять универсальный метод НайтиПоКлючу.

Пример:

// Поиск записи по значению ключа
хВ.ТекущийИндекс = хВ.Индексы.IDXCODE; // индекс CODE
ЗаписьНайдена = хВ.Найти("00001" , ">=");

См. также:

XBase, свойство ТекущийИндекс.

НайтиПоКлючу (FindByKey)

Синтаксис:

НайтиПоКлючу (< Режим> )

Параметры:

<Peжим> Обязательный

Тип: Строка. Режим поиска записей:

"=" - ищет запись на точное соответствие ключу;
">=" - ищет запись на точное соответствие с ключом или большую;
">" - ищет запись с большим ключом;
"<=" - ищет запись на точное соответствие с ключом или меньшую;
"<" - ищет запись с меньшим ключом.

Возвращаемое значение:

Тип: Булево. Истина - запись найдена; Ложь - запись не найдена.

Описание:

Позволяет найти запись, соответствующую значениям свойств объекта типа Ключ XBase-объекта по текущему индексу и режиму поиска, переданному в качестве параметра. Указатель устанавливается на найденную запись. Перед вызовом метода следует установить значения всех свойств объекта типа Ключ, которые участвуют в вычислении выражения текущего индекса.

Пример:

// Поиск по составному ключу
хВ.ТекущийИндекс = хВ.Индексы.IDXCNAME; // индекс
CODE + TRIM(NAME)
хВ.Ключ. CODE = "00001";
хВ.Ключ. NAME = "Системный блок";
ЗаписьНайдена = хВ.НайтиПоКлючу("=");

См. также:

XBase, свойство Ключ. XBase, свойство ТекущийИндекс.

НомерЗаписи (RecNo)

Синтаксис:

НомерЗаписи()

Возвращаемое значение:

Тип: Число. Номер текущей записи.

Описание:

Получает физический порядковый номер текущей записи в таблице базы данных, начиная с единицы. Результат не зависит от установки текущего индекса.

Пример:

Если хВ.ЗаписьУдалена() Тогда
Сообщить ("Удаленная запись: " + хВ. НомерЗаписи());
КонецЕсли;


1-264 Методы объекта XBase (2)

Открыта (IsOpen)

Синтаксис:

Открыта()

Возвращаемое значение:

Тип; Булево. Истина - файл открыт, Ложь - файл не открыт.

Описание:

Позволяет определить, открыт ли файл таблицы базы данных.

Пример:

Если Не хВ.Открыта() Тогда
Предупреждение(" Не удалось открыть указанный файл!");
КонецЕсли;

ОткрытьФайл (OpenFile)

Синтаксис:

ОткрытьФайл (< Путь к базе> , <Путь к индексу >, <Только чтение> )

Параметры:

<Путь к базе> Обязательный

Тип: Строка. Полное имя открываемого файла таблицы базы данных в формате DBF.

<Путь к индексу> Необязательный

Тип: Строка. Полное имя открываемого индексного файла таблицы базы данных.

Значение по умолчанию: Если параметр не указан, индексный файл не открывается.

< Только чтение > Необязательный

Тип: Булево. Истина - файл открывается в режиме только чтения; ложь - файл открывается в режиме полного доступа.

Значение по умолчанию: Ложь.

Описание:

Позволяет открыть существующий файл таблицы базы данных в формате DBF и, если необходимо, соответствующий файл индекса.

Пример:

хВ.ОткрытьФайл("с:\test.dbf", "c:\test.cdx") ;

Отменить (Cancel)

Синтаксис:

Отменить()

Описание:

Отменяет запись изменений в таблицу базы при смене текущей записи, если установлен признак Автосохранение.

Пример:

Текст = "Сохранить изменения?";
Режим = РежимДиалогаВопрос.ДаНет;
Если Вопрос(Текст, Режим) = КодВозвратаДиалога.Нет Тогда
хВ.Отменить();
КонецЕсли;

См. также:

XBase, свойство Автосохранение.

Очистить (Clear)

Синтаксис:

Очистить()

Описание:

Очищает свойства объекта XBase, соответствующие полям таблицы базы данных.

Пример:

// Очищает значения всех полей
первой записи записей
хВ.Первая() ;
хВ.Очистить();
хв.Записать() ;

ОчиститьФайл (Zap)

Синтаксис:

ОчиститьФайл()

Описание:

Позволяет удалить все записи в таблице. При этом все существующие записи удаляются физически и не могут быть впоследствии восстановлены.

Пример:

Текст = 'Все записи будут удалены.
Продолжить?";
Режим = РежимДиалогаВопрос.ДаНет;
Если Вопрос(Текст, Режим) =
КодВозвратаДиалога.Да Тогда
хВ ОчиститьФайл() ;
КонецЕсли;

Первая (First)

Синтаксис:

Первая()

Возвращаемое значение:

Тип Булево. Истина - первая запись получена, Ложь -первая запись не получена.

Описание:

Позиционирует объект на первой записи. Если не установлен текущий индекс, объект позиционируется на первую запись в таблице базы данных, если установлен - на запись, имеющую самое младшее значение выражения текущего индекса (если индекс создавался с установленным флагом "Убывание", то наоборот).

Пример:

хВ. Первая();

Переиндексировать (Reindex)

Синтаксис:

Переиндексировать()

Описание:

Выполняет пересчет индекса таблицы базы данных. Объекты XBase автоматически выполняют индексацию при изменениях в таблице базы данных, однако, при работе более чем с одним индексным файлом или после аварийных завершений может потребоваться принудительная переиндексация.

Пример:

Если ФлагАварийногоЗавериения Тогда
хВ.Переиндексировать()
;
КонецЕсли ;

Перейти (GoTo)

Синтаксис:

Перейти(<Номер записи>)

Параметры:

<Номер записи> Обязательный

Тип: Число. Физический порядковый номер записи в базе данных.

Возвращаемое значение:

Тип: Булево. Истина - получена искомая запись, Ложь -искомая запись не найдена.

Описание:

Позволяет перейти на запись по ее физическому порядковому номеру в таблице базы данных. Метод позволяет перейти на запись, помеченную удаленной, даже если не установлен режим просмотра удаленных записей.

Пример:

хВ.Перейти(НомерЗаписи) ;

Последняя (Last)

Синтаксис:

Последняя()

Возвращаемое значение:

Тип: Булево. Истина - последняя запись получена. Ложь -последняя запись не получена.

Описание:

Позиционирует объект на последней записи. Если не установлен текущий индекс, объект позиционируется на последнюю запись в таблице базы данных, если установлен - на запись, имеющую самое старшее значение выражения текущего индекса (если индекс создавался с установленным флагом "Убывание", то наоборот).

Пример:

хВ. Последняя() ;

Предыдущая (Prev)

Синтаксис:

Предыдущая()

Возвращаемое значение:

Тип: Булево. Истина - получена предыдущая запись; Ложь - предыдущая запись не найдена.

Описание:

Позиционирует объект на предыдущей записи. В зависимости от того, установлен ли текущий индекс, позиционирование происходит либо в порядке убывания физического номера записи, либо в порядке убывания значения выражения текущего индекса (если индекс создавался с установленным флагом "Убывание", то в порядке возрастания).

Пример:

// Подсчет суммы в поле COST
СуммаВсего = 0;
Пока Истина Цикл
СуммаВсего = СуммаВсего + xB.COST;
Если Не хв.Предыдущая() Тогда
Прервать;
КонецЕсли ;
КонецЦикла ;

Сжать (Pack)

Синтаксис:

Сжать()

Описание:

Уменьшает размер файла таблицы базы данных, убирая из него записи, помеченные как удаленные.

Пример:

Текст = "Удаленные записи будут уничтожены. Продолжить?";
Режим = РежимДиалогаВопрос.ДаНет;
Если Вопрос(Текст, Режим) = КодВозвратаДиалога.Да Тогда
хВ.Сжать();
КонецЕсли ;

Скопировать (Copy)

Синтаксис:

Скопировать()

Описание:

Добавляет новую запись, копирующую текущую запись. Для записи изменений в таблицу базы данных необходимо инициировать запись.

Пример:

хВ.Скопировать();
хВ.Записать();

Следующая (Next)

Синтаксис:

Следующая()

Возвращаемое значение:

Тип: Булево. Истина - получена следующая запись. Ложь -следующая запись не найдена.

Описание:

Позиционирует объект на следующей записи. В зависимости от того установлен ли текущий индекс, позиционирование происходит либо в порядке возрастания физического номера записи, либо в порядке возрастания значения выражения текущего индекса (если индекс создавался с установленным флагом "Убывание", то в порядке убывания).

Пример:

// Обнуляет значения всех
полей всех существующих записей
хВ.Первая();
Пока Истина
Цикл
хВ.Очистить();
хВ.Записать();
Если Не хВ.Следующая() Тогда
Прервать;
КонецЕсли;
КонецЦикла;

СоздатьИндексныйФайл (Createlndex)

Синтаксис:

СоздатьИндексныйФайл(< Имя файла>)

Параметры:

<Имя файла> Обязательный

Тип: Строка. Полное имя создаваемого индексного файла.

Возвращаемое значение:

Тип: Булево. Истина - индексный файл создан. Ложь -индексный файл не создан.

Описание:

Создает индексный файл. Создаваемый индексный файл будет содержать все индексы, которые были созданы на текущий момент.

Пример:

хВ.СоздатьИндексныйФайл(ИмяФайлаИндекса);

СоздатьФайл (CreateFile)

Синтаксис:

СоздатьФайл (<Путь к базе> , <Путь к индексу> )

Параметры:

<Путь к базе> Обязательный

Тип: Строка. Полное имя создаваемого файла таблицы базы данных в формате DBF.

<Путь к индексу> Необязательный

Тип: Строка. Полное имя создаваемого индексного файла.

Значение по умолчанию: Если параметр не указан, индексный файл не создается.

Описание:

Позволяет создать новый файл таблицы базы данных в формате DBF и соответствующий ему индексный файл. Создаваемый файл таблицы базы данных будет содержать все созданные на текущий момент поля, индексный файл - все созданные индексы.

Пример:

ИмяФайлаБазы = "c:\test.dbf";
ИмяФайлаИндекса = "c:\test.cdx";
хВ.СоэдатьФайл(ИмяФайлаБазы, ИмяФайлаИндекса);

Удалить (Delete)

Синтаксис:

Удалить()

Описание:

Ставит пометку "удалена" на текущую запись. Физически запись ид таблицы базы данных не удаляется и может быть впоследствии восстановлена. Полное удаление записей из таблицы базы данных с освобождением дискового пространства, занятого ими, производится вызовом методов Сжать и ОчиститьФайл.

Пример:

// Удаление всех записей:
хВ.Первая();
Пока Не хВ.Вконце() Цикл
хВ.Удалить();
хВ.Следующая();
КонецЦикла;

Конструкторы

Основной

Синтаксис:

Новый XBase(<Путь к базе>. <Путь к индексу> , <Только чтение>}

Параметры:

<Путь к базе> Необязательный

Тип: Строка. Полное имя файла таблицы базы данных в формате DBF.

<Путь к индексу> Необязательный

Тип: Строка. Путь к индексному файлу таблицы.

<Только чтение> Необязательный

Тип: Булево. Истина - открывать файл только для чтения, Ложь - открывать файл для чтения и записи.

Значение по умолчанию: Ложь

Описание:

Позволяет создать объект XBase. При создании могут быть сразу открыты файлы таблицы и индекса.

См. также:

XBase, метод ОткрытьФайл.


1-282 Поля и индексы XBase

Коллекция полей XBase

Представляет собой коллекцию полей таблицы базы данных формата DBF.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа Поле XBase. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции.

Свойства

<Имя поля>

Использование:

Только чтение.

Описание:

Тип: Поле XBase. Набор свойств содержит поля коллекции Xbase. Имена свойств совпадают с названиями полей таблицы базы данных.

Методы

Добавить (Add)

Синтаксис:

Добавить(<Имя>, <Тип>, <Длина>, <Точность>)

Параметры:

<Имя> Обязательный

Тип: Строка. Имя добавляемого поля. Поддерживаются только латинские имена полей длиной до 10 символов.

<Тип> Обязательный

Тип: Строка. Тип создаваемого поля: "N" - число, "S" - строка, "D" - дата, "L" - логическое, "F" - аналогично "N" - число, "М" -мемополе (не поддерживается).

<Длина> Обязательный

Тип: Число. Общая длина создаваемого поля.

<Точность> Необязательный

Тип: Число. Длина дробной части (только для числовых полей). Значение по умолчанию: 0.

Описание:

Добавляет новое поле в описание структуры таблицы базы данных.

Пример:

хВ.Поля.Добавить( "CODE", "S", 5);
хВ.Поля.Добавить( "NAME", "S", 40);
хВ.Поля.Добавить ("COST", "N", 14, 2);
хВ.СоздатьФайл("с:\ТЕСТ.DBF");

См. также:

XBase, метод СоздатьФайл. Коллекция индексов XBase, метод Добавить.

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип:Число.

Описание:

Позволяет получить количество полей в таблице базы данных.

Пример:

Сообщить(" Всего полей в таблице: " + хВ.Поля.Количество());

Поле XBase

Представляет собой поле таблицы базы данных в формате DBF. Используется для получения свойств поля.

Свойства

Длина (Length)

Использование:

Только чтение.

Описание:

Тип: Число. Содержит общую длину поля.

Имя (Name)

Использование:

Только чтение.

Описание:

Тип: Строка. Содержит имя поля.

Тип (Type)

Использование:

Только чтение.

Описание:

Тип: Строка. Содержит тип поля: "S"- строка, "N" - число, "D" -дата, "L" - булево, "F" - число, "М" - мемо поле (не поддерживается).

Точность (Precision)

Использование:

Только чтение.

Описание:

Тип: Число. Содержит количество разрядов дробной части.

Примечание:

Используется для числовых полей.

Коллекция индексов XBase

Представляет собой коллекцию индексов таблицы базы данных.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа Индекс XBase. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции

Свойства

<Имя индекса>

Использование:

Только чтение.

Описание:

Тип: Индекс XBase. Набор свойств содержит значения индексов коллекции. Имена свойств совпадают с названиями индексов таблицы базы данных.

Методы

Добавить (Add)

Синтаксис:

Добавить(<Имя>, <Выражение>, <Уникальность>, <У6ывание>, <Фильтр>)

Параметры:

<Имя> Обязательный

Тип: Строка. Имя создаваемого индекса. Поддерживаются только латинские имена индексов длиной до 10 символов.

<Выражение> Обязательный

Тип: Строка. Выражение индекса.

<Уникальность> Необязательный

Тип: Булево. Признак уникальности создаваемого индекса. Истина - уникальный. Ложь - неуникальный.

Значение по умолчанию: Ложь.

<Убывание> Необязательный

Тип: Булево. Признак того, что создаваемый индекс будет убывающим. Истина - убывает. Ложь - возрастает.

Значение по умолчанию: Ложь.

<Фильтр> Необязательный

Тип: Строка. Выражение фильтра индекса. Значение по умолчанию: ".Т.".

Описание:

Добавляет новый индекс в коллекцию индексов таблицы базы данных.

Пример:

хВ = новый xBase;
хВ.поля.добавить ("CODE", "S", 5);
ХВ.Поля.Добавить("NАМЕ","S" , 40);
// Дбавим индекс по полю CODE:
хВ.Индексы.Добавить(" IDXCODE" , "CODE" ,
Истина) ;
хВ.СоздатьФайл("с:\test.dbf", "c:\test.cdx") ;

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество индексов таблицы.

Описание:

Позволяет получить количество индексов таблицы базы данных.

Примечание:

Количество индексов отлично от нуля, если открыт либо создан индексный файл.

Пример:

хВ = Новый xBase;
xB.OткрытьФайл("c:\test.dbf"',"c:\test.cdx");
// Получим количество индексов
КоличествоИндексов = хВ.Индексы.Количество();


1-288 Индекс XBase

Индекс XBase

Представляет собой индекс таблицы базы данных. Используется для получения свойств индекса.

Свойства

Выражение (Expression)

Использование:

Только чтение.

Описание:

Тип: Строка. Выражение индекса.

Имя (Name)

Использование:

Только чтение.

Описание:

Тип: Строка. Имя индекса.

Убыв (Descend)

Использование:

Только чтение.

Описание:

Тип: Булево. Признак убывания индекса.

Уникальность (Unique)

Использование:

Только чтение.

Описание:

Тип: Булево. Признак уникальности индекса.

Фильтр (Filter)

Использование:

Только чтение.

Описание:

Тип: Строка. Выражение фильтра индекса.

Функции, применяемые в выражении и фильтре индекса

При работе с индексами во время исполнения 1С:Предприятия XBase-объекты производят вычисление выражения индекса и фильтра. Выражение индекса и фильтра - это строковые выражения, составленные на специальном языке объектов XBase.

Выражение индекса используется для вычисления значения ключа для каждой записи базы данных. Результатом вычисления выражение должно быть значение одного из следующих типов: числовое, строковое, дата или булево. Выражение фильтра должно возвращать результат типа булево. Если значение выражения фильтра для конкретной записи базы данных равно истине, информация об этой записи будет включена в индексный файл, в противном случае индексный файл не будет содержать информацию об этой записи, и позиционирование на эту запись XBase-объекта с данным текущим индексом производиться не будет.

Свойства объекта XBase (кроме Ключ), константы и функции могут быть использованы как части выражений. Части выражения могут объединяться с помощью других функций или операторов. Простейшим выражением может быть имя свойства, например "FULL_NAME". В таком случае тип выражения будет соответствовать типу свойства.

Константы могут иметь числовой, строковый и булевый тип. Строковые константы заключаются в одиночные кавычки ('Строковая константа'). При необходимости включить в состав строковой константы символа двойной кавычки, его следует предварять обратной косой чертой, например, 'Фирма \"Вега\" '. Булевы константы записываются как .TRUE. или .Т. для обозначения истины и .FALSE. или .F. в противном случае.

Операторы используются для объединения частей выражения. Части выражения должны иметь тип, соответствующий оператору, например, оператор "/" (деление) работает с двумя числовыми значениями.

Порядок выполнения операторов в выражении соответствует общепринятому - с учетом скобок и приоритетов операторов. Например выражение "1+2*3" возвратит 7, а "(1+2)*3" возвратит 9.

Числовые операторы:

• Сложение. Обозначается символом +. Приоритет 5.
• Вычитание. Обозначается символом -. Приоритет 5.
• Умножение. Обозначается символом *. Приоритет 6.
• Деление. Обозначается символом /. Приоритет 6.
• Возведение в степень. Обозначается символами ** или ^. Приоритет 7.

Строковые операторы:

• Объединение 1. Обозначается символом +. Приоритет операции 5
• Объединение 2. Обозначается символом -. Приоритет операции 5

Оператор "Объединение 2" немного отличается тем, что пробелы в конце первой строки будут перемещены в конец результата. Например, результатом вычисления выражения " 'Иванов ' + 'И.И.' " будет 'Иванов И.И.', а " 'Иванов ' - 'И.И.' " -'ИвановИ.И.'.

Операторы отношений:

• Равно. Обозначается символом =. Приоритет операции 4
• Не равно. Обозначается символом о или #. Приоритет операции 4
• Меньше. Обозначается символом < Приоритет операции 4
• Больше. Обозначается символом >. Приоритет операции 4
• Меньше или равно. Обозначается символом <=. Приоритет операции 4
• Больше или равно. Обозначается символом >=. Приоритет операции 4
• Содержит. Обозначается символом $. Приоритет операции 4

Пример:

" 'CD' $ 'ABCD'" вернет ".Т."
" 8 < 7 " вернет ".F."

Логические операторы:

• Отрицание. Обозначается строкой .NOT. Приоритет операции 3

• И. Обозначается строкой .AND. Приоритет операции 2

• Или. Обозначается строкой .OR. Приоритет операции 1

CTOD

Синтаксис:

CTOD(<String>)

Параметры:

<String> Обязательный

Тип: Строка. Представление даты в формате ДД/ММ/ГГГГ

Возвращаемое значение:

Тип: Дата. Преобразованное в дату значение исходной строки.

DATE

Синтаксис:

DATE()

Возвращаемое значение:

Тип: Дата. Системная дата.

DEL

Синтаксис:

DEL()

Возвращаемое значение:

Тип: Строка. "*" (звездочка) - если запись помечена на удаление, "" - иначе

DELETED

Синтаксис:

DELETED()

Возвращаемое значение:

Тип: Булево. Булево .TRUE. - если запись помечена на удаление, .FALSE. - иначе.

DTOC

Синтаксис:

DTOC(<Дата>)

Параметры:

<Дата> Обязательный

Тип:Дата.

Возвращаемое значение:

Тип: Строка. Представление даты в формате ММ/ДД/ГГ.

DTOS

Синтаксис:

DTOS(<Date>)

Параметры:

<Date> Обязательный

Тип: Дата.

Возвращаемое значение:

Тип: Строка. Представление даты в формате ГПТММДД.

IIF

Синтаксис:

IIF(<Log> , <lfTrue> , <IfFalse>)

Параметры:

<Log> Обязательный

Тип:Булево.

<IfTrue> Обязательный

Должны иметь одинаковую длину и тип с IfFalse.

<IfFalse> Обязательный

Должны иметь одинаковую длину и тип с IfTrue.

Возвращаемое значение:

Возвращает <IfTrue>, если значение вычисленного выражения <Log> равно истине, и <IfFalse> в противном случае.

LTRIM

Синтаксис:

LTRIM(<String>)

Параметры:

<String> Обязательный

Тип:Строка.

Возвращаемое значение:

Тип: Строка. Исходная строка без ведущих пробелов.

MONTH

Синтаксис:

MONTH (<Date>)

Параметры:

<Date> Обязательный

Тип: Дата.

Возвращаемое значение:

Тип: Число. Номер месяца в году.

RECCOUNT

Синтаксис:

RECCOUNT()

Возвращаемое значение:

Тип: Число. Общее количество записей в таблице базы данных.

RECNO

Синтаксис:

RECNO()

Возвращаемое значение:

Тип: Число. Номер текущей записи.

STOD

Синтаксис:

STOD(<String>)

Параметры:

<String> Обязательный

Тип: Строка. Представление даты в формате ГГГГММДД

Возвращаемое значение:

Тип: Дата. Преобразованное в дату значение исходной строки.

STR

Синтаксис:

STR(<Number>, <Length>, <Decim>)

Параметры:

<Number> Обязательный

Тип: Число. Преобразуемое число.

<Length> Обязательный

Тип: Число. Количество символов в возвращаемой строке, включая десятичную точку.

<Decim> Обязательный

Тип: Число. Желаемое количество знаков после точки.

Возвращаемое значение:

Тип: Строка. Результат преобразования числа в строковое представление.

SUBSTR

Синтаксис:

SUBSTR (< String> , <StartPos> , <Num> )

Параметры:

< Siring > Обязательный

Тип: Строка. Исходная строка.

<StartPos> Обязательный

Тип: Число. Начальная позиция.

<Num> Обязательный

Тип: Число. Кол-во символов.

Возвращаемое значение:

Подстрока, состоящая из <Num> символов от начальной позиции исходной строки

TIME

Синтаксис:

TIME()

Возвращаемое значение:

Тип Строка. Системное время в представлении ЧЧ:ММ:СС

TRIM

Синтаксис:

TRIM(<String>)

Параметры:

<Stnng> Обязательный

Тип Строка.

Возвращаемое значение:

Тип Строка. Исходная строка без заключительных пробелов.

UPPER

Синтаксис:

UPPER(<String>)

Параметры:

<Stnng> Обязательный

Тип Строка.

Возвращаемое значение:

Тип Строка. Строка, символы которой преобразованы к верхнему регистру.

VAL

Синтаксис:

VAL(<String>)

Параметры:

<String> Обязательный

Тип: Строка

Возвращаемое значение:

Тип Число. Результат преобразования строки в число.

YEAR

Синтаксис:

YEAR(<Date>)

Параметры:

<Date> Обязательный

Тип Дата.

Возвращаемое значение:

Год даты.


1-297 ОписаниеТипов Значений

Описание типов значений

Для описания допустимых типов значений свойств различных объектов в системе используется специальный объект ОписаниеТипов При помощи данного объекта можно описывать допустимые типы значений, которые можно будет присваивать свойствам. Для дополнительного ограничения возможных значений примитивных типов Число, Строка и Дата предусмотрены квалификаторы. Квалификаторы описывают такие параметры как длина строки или числа, допустимые части даты и т.п.

ОписаниеТипов (TypesDescription)

Представляет собой объект для управления допустимыми типами значений. В основном предназначен для присвоения в качестве значений соответствующим свойствам других объектов. Набор допустимых типов и квалификаторы примитивных типов задаются при создании объекта.

Пример:

// Создание описателя типов для таблицы значений
КЧ = Новый КвалификаторыЧисла(12,2);
КС = Новый КвалификаторыСтроки(20);
М = Новый Массив;
М.Добавить(Тип("Строка"));
ОписаниеТиповС = Новый ОписаниеТипов(М, , КС);
М.Очистить();
М. Добавить(Тип("Число"));
ОписаниеТиповЧ = Новый ОписаниеТипов(М, , ,КЧ);
// Создание таблицы значений
Табл = Новый ТаблицаЗначений;
// добавим в таблицу значений три колонки
Табл.Колонки,Добавить("Отдел",ОписаниеТиповС, "Отдел",20);
Табл.Колонки.Добавить("Сотрудник", ОписаниеТиповС," Фамилия сотрудника",20);
Табл.Колонки.Добавить("Оклад",ОписаниеТиповЧ,"Оклад",10);

Свойства

КвалификаторыДаты (DateQualifiers)

Использование:

Только чтение.

Описание:

Тип: КвалификаторыДаты. Содержит квалификаторы даты -объект, используемый для описания допустимых значений типа Дата.

Примечание:

Имеет смысл, если в описании типов используется тип Дата.

См. также:

КвалификаторыДаты.

КвалификаторыСтроки (StringQualifiers)

Использование:

Только чтение.

Описание:

Тип: КвалификаторыСтроки. Содержит квалификаторы строки, используемые для описания допустимых значений строкового типа.

Примечание:

Имеет смысл, если в описании типов используется тип Строка.

См. также:

КвалификаторыСтроки.

КвалификаторыЧисла (NumericQualifiers)

Использование:

Только чтение.

Описание:

Тип: КвалификаторыЧисла. Содержит квалификаторы числа, используемые для описания допустимых значений числового типа.

Примечание:

Имеэт смысл, если в описании типов используется тип Число.

См. также:

КвалификаторыЧисла.

Методы

СодержитТип (ContainsType)

Синтаксис:

СодержитТип (< Тип>)

Параметры:

<Тип> Обязательный

Тип: Тип. Тип, вхождение которого проверяется.

Возвращаемое значение:

Тип: Булево. Истина - указанный тип входит в используемые типы, Ложь - указанный тип не входит в используемые типы.

Описание:

Позволяет определить, входит ли указанный тип в используемые данным объектом типы.

Пример:

ПроверяемыйТип = Тип( "Строка");
Если ДопустимыеТипы.СодержитТип(ПроверяемыйТип) Тогда
Сообщить("Описание типов содержит тип " + ПроверяемыйТип);
Иначе
Сообщить("Описание типов не содержит тип " + ПроверяемыйТип);
КонецЕсли;

Типы (Types)

Синтаксис:

Типы()

Возвращаемое значение:

Тип: Массив. Массив значений типа Тип, состоящий из используемых типов.

Описание:

Позволяет получить типы, используемые в объекте.

Пример:

ИспользуемыеТипы = ДопустимыеТипы.Типы();
Для каждого ИспользуемыйТип Из ИспользуемыеТипы Цикл
Сообщить(ИспользуемыйТип);
КонепЦикла;

Конструкторы

Основной

Синтаксис:

Новый ОписаниеТипов(<Типы> , <Квалификаторы числа> , <Квалификаторы строки> , <Квалификаторы даты>)

Параметры:

<Типы> Обязательный

Тип: Массив. Массив значений типа Тип, состоящий из типов, которые будут использованы в объекте.

<Квалификаторы числа> Необязательный

Тип: КвалификаторыЧисла. Квалификаторы числа, описывающие допустимые значения числового типа.

Значение по умолчанию: Если не указан, числа хранить нельзя.

<Квалификаторы строки> Необязательный

Тип: КвалификаторыСтроки. Квалификаторы строки, описывающие допустимые значения строкового типа.

Значение по умолчанию: Если не указан, используется неограниченная длина строки.

<Квалификаторы даты> Необязательный

Тип: КвалификаторыДаты. Квалификаторы даты, описывающие допустимые значения типа Дата.

Значение по умолчанию: Если не указан, используются обе части даты (дата + время)

Описание:

Позволяет создать описание типов на основании заданных типов и квалификаторов для типов Число, Строка, Дата.

На основании объекта ОписаниеТипов

Синтаксис:

Новый ОписаниеТипов (<Исходное ОписаниеТипов > , <Добавляемые типы> , <Вычитаемые типы> , <Квалификаторы числа> , <Квалификаторы строки> , <Квалификаторы даты> )

Параметры:

<Исходное ОписаниеТипов> Необязательный

Тип: ОписаниеТипов. Исходное описание типов, на основании которого будет строиться новое.

<Добавляемые типы> Необязательный

Тип: Массив. Массив, содержащий значения типа Тип, добавляемые к типам, используемых в исходном описании типов.

<Вычитаемые типы> Необязательный

Тип: Массив. Массив, содержащий значения типа Тип, исключаемые из типов, используемых в исходном описании типов.

<Квалификаторы числа> Необязательный

Тип: КвалификаторыЧисла. Квалификаторы числа, описывающие допустимые значения числового типа.

<Квалификаторы строки> Необязательный

Тип: КвалификаторыСтроки. Квалификаторы строки, описывающие допустимые значения строкового типа.

<Квалификаторы даты> Необязательный

Тип: КвалификаторыДаты. Квалификаторы даты, описывающие допустимые значения типа Дата.

Описание:

Позволяет создать описание типов на основании другого описания типов, путем добавления одних и исключения других типов. Если новый квалификатор не указан, будут оставлены Квалификаторы исходного описания типов.

КвалификаторыЧисла (NumericQualifiers)

Используется для описания допустимых значений числового типа.

Пример:

Знак = ДопустимыйЗнак.Неотрицательный;
ПараметрыЧисла = Новый КвалификаторыЧисла
(10, 2, Знак);

См. также:

ОписаниеТипов, свойство КвалификаторыЧисла.

Свойства

ДопустимыйЗнак (AllowedSign)

Использование:

Только чтение.

Описание:

Тип: системное перечисление ДопустимыйЗнак. Определяет допустимый знак числа.

Разрядность (Digits)

Использование:

Только чтение.

Описание:

Тип: Число. Содержит общее количество разрядов числа (количество разрядов целой части плюс количество разрядов дробной части).

РазрядностьДробнойЧасти (Fraction Digits)

Использование:

Только чтение.

Описание:

Тип: Число. Содержит число разрядов дробной части.

Конструкторы

Основной

Синтаксис:

Новый КвалификаторыЧисла(< Число разрядов> , <Число разрядов дробной части> , <Допустимый знак> )

Параметры:

<Число разрядов> Необязательный

Тип: Число. Общее число разрядов числа.

Значение по умолчанию: 0

<Число разрядов дробной части> Необязательный

Число разрядов дробной части числа.

Значение по умолчанию: 0

<Допустимый знак> Необязательный

Тип: системное перечисление ДопустимыйЗнак. Допустимый знак числа.

Значение по умолчанию: Любой.

Описание:

Позволяет создать объект, задав общее число разрядов, число разрядов дробной части и допустимый знак.

КвалификаторыСтроки (StringQualifiers)

Используется для описания допустимых значений строкового типа.

Пример:

ПараметрыСтроки = Новый КвалификаторыСтроки(20);

См. также:

ОписаниеТипов, свойство КвалификаторыСтроки.

Свойства

Длина (Length)

Использование:

Только чтение.

Описание:

Содержит длину строки в символах. Строка неограниченной длины имеет длину строки, равную 0.

ДопустимаяДлина (AllowedLength)

Использование:

Только чтение.

Описание:

Тип: системное перечисление ДопустимаяДлина. Содержит вариант ограничения длины строки.

Примечание:

Используется для строк ограниченной длины (т.е. свойство Длина имеет значение больше 0).

Конструкторы

Основной

Синтаксис:

Новый КвалификаторыСтроки (< Длина строки>, <Допустимая длина>)

Параметры:

<Длина строки> Необязательный

Тип: Число.

Значение по умолчанию: Если параметр не указан или равен 0, то строка по длине не ограничивается.

<Допустимая длина> Необязательный

Тип: системное перечисление ДопустимаяДлина. Вариант ограничения длины строки, если задана длина строки, отличная от 0.

Описание:

Позволяет создать объект, задав длину строки.

КвалификаторыДаты (DateQualifiers)

Используется для описания допустимых значений типа Дата.

Пример:

ПараметрыДаты = Новый КвалифихаторыДаты(ЧастиДаты,Дата);

См. также:

ОписаниеТипов, свойство КвалификаторыДаты.

Свойства

ЧастиДаты (DateFractions)

Использование:

Только чтение.

Описание:

Тип: системное перечисление ЧастиДаты. Определяет допустимые части даты.

Конструкторы

Основной

Синтаксис:

Новый КвалификаторыДаты (< Части даты> )

Параметры:

<Части даты> Необязательный

Тип: системное перечисление ЧастиДаты. Допустимые части даты.

Значение по умолчанию: ДатаВремя.

Описание:

Позволяет создать объект, задав допустимые части даты.

ДвоичныеДанные (BinaryData)

Значение содержит двоичные данные, которые считываются из файла.

Значение может быть сохранено в ХранилищеЗначений.

Хранимые данные могут быть записаны в файл.

Пример:

МояКартинка = Новый ДвоичныеДанные("С:\Мои
документы\Картинка1.bmр");
ХранилищеКартинки = Новый ХранилищеЗначения(МояКартинка);
// сохранение значения типа ХранилищеЗначения в базе данных
НовНоменклатура = Справочники.Номенклатура.СоздатьЭлемент();
НовНоменклатура.Наименование = "Диван ""Маргарита""";
// реквизит Изображение имеет тип ХранилищеЗначения
НовНоменклатура.Изображение = ХранилицеКартинки;
НовНоменклатура.Записать();
// выгрузка значения типа ДвоичныеДанные из хранилища значений в файл
Имяфайла = "С:\Мои документы\Картинка2 .bmр") ;
НовНоменклатура.Изображение.Записать(ИмяФайла);


1-311 Глава 5. Универсальные коллекции значений

Глава 5. Универсальные коллекции значений

Универсальные коллекции значений предназначены для хранения временных наборов данных в течение сеанса работы пользователя. Они нe являются объектами информационной базы и служат для вспомогательного сбора, группировки, анализа и обработки информации.

Массив

Объекты этого типа представляют собой упорядоченную совокупность значений любого типа, в том числе и типа массив, что, в частности, позволяет организовывать многомерные массивы.

Массив (Array)

Предназначен для доступа к элементам массива, его методам и конструктору.

Данный объект является коллекцией значений. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются значения элементов массива. Возможно обращение к значению элемента посредством оператора [...]. В качестве аргумента передается индекс значения.

Пример:

М = Новый Массив(4);
Сообщить("Количество: " +М.Количество());
Сообщить("Наибольший индекс массива: " +М.ВГраница());
М.Удалить(2);
Сообщить("Количество после удаления: "+М.Количество());
// Этот элемент массива имеет тип Строка:
М.Добавить("Добавили строку");
// Этот элемент массива имеет тип Число:
М.Добавить(123.45);
Сообщить("Количество после добавления: " +М.Количество());
// Добавим элемент по индексу, большему, чем: ВГраница():
М.Вставить(8,"Метод добавил 4 новых элемента");
Сообщить("Количество после добавления: "+М.Количество)));
// Массив может хранить разные типы данных:
Сообщить("Типы элементов: "+Символы.ПС+
" Для 3-го элемента: "+ТипЗнч(М[3])+Символы.ПС+
" Для 4-го элемента: "+ТипЗнч(М[4])+Символы.ПС+
" Для 5-го элемента: "+ТипЗнч(М[5]));

Результат выполнения:

Количество: 4
Наибольший индекс массива: 3
Количество после удаления: 3
Количество после добавления: 5
Количество после добавления: 9
Типы элементов:
Для 3-го элемента: Строка
Для 4-го элемента: Число
Для 5-го элемента: Неопределено

Методы

ВГраница (UBound)

Синтаксис:

ВГраница()

Возвращаемое значение:

Тип: Число. Наибольший индекс в массиве. Если количество элементов массива равно 0, возвращает -1.

Описание:

Получает наибольший индекс элемента массива.

Примечание:

Наибольший индекс соответствует количеству элементов массива минус 1.

Пример:

Для Сч = 0 по М.ВГраница() Цикл
М[Сч] = М[Сч] * 1;
КонецЦикла;

Вставить (Insert)

Синтаксис:

Вставить(<Индекс>, <3начение>)

Параметры:

<Индекс> Обязательный

Тип: Число. Индекс вставляемого значения.

<3начение> Обязательный

Тип: Произвольный. Вставляемое значение.

Описание:

Вставляет значение в массив по указанному индексу.

Пример:

М.Вставить(0, "Первый");

Добавить(Add)

Синтаксис:

Добавить(<Значение>)

Параметры:

<3начение> Обязательный

Добавляемое значение.

Описание:

Добавляет элемент в конец массива.

Примечание:

При добавлении количество элементов массива увеличивается на 1.

Пример:

М.Добавить("Первый");
М.Добавить("Второй");

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество элементов массива.

Описание:

Позволяет получить количество элементов в массиве.

Пример:

КоличествоЭлементов = К.Количество();

Очистить (Clear)

Синтаксис:

Очистить()

Описание:

Удаляет все значения из массива.

Пример:

М.Очистить() ;

Удалить (Remove)

Синтаксис:

Удалить(<Индекс>)

Параметры:

<Индекс> Необязательный.

Тип: Число. Индекс удаляемого элемента.

Описание:

Удаляет значение из массива по указанному индексу.

Пример:

М.Удалить(4);,

Конструкторы

Основной

Синтаксис:

Новый Массив (< Количество элементов 1>, ..., <Количество элементов N> )

Параметры:

<Количество элементов 1>, ..., <Количество элементов N> Необязательный

Тип: Число. Каждый параметр определяет количество элементов массива в соответствующем измерении. Может задаваться неограниченное количество параметров.

Значение по умолчанию: Если ни один параметр не указан, создается одномерный массив с нулевым количеством элементов.

Описание:

Позволяет создать массив из указанного количества элементов. Если задано несколько параметров, то будет создан массив, элементами которого являются массивы (и т.д. в зависимости от количества параметров). Фактически, конструктор позволяет создать массивы массивов, которые могут являться аналогом многомерного массива.


1-315 Структура

Структура

Структура представляет собой динамический набор данных -коллекцию значений, каждый элемент которой состоит из пар Ключ и Значение. Ключи структуры уникальны, и поэтому ими можно идентифицировать значения. Ключ может быть только строковым и должен удовлетворять требованиям, предъявляемым к именованию переменных встроенного языка. К значениям структуры можно обращаться как к свойствам объекта. При этом ключ используется как имя свойства.

Структура (Structure)

Представляет доступ к самой структуре.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа КлючИЗначение. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции.

См. также:

КлючИЗначение.

Свойства

<Имя ключа>

Использование:

Только чтение.

Описание:

Тип: Произвольный. Набор свойств содержит значения, соответствующие ключам. Имена свойств совпадают со значениями ключей.

Методы

Вставить (Insert)

Синтаксис:

Вставить (< Ключ>, <3начение>)

Параметры:

<Ключ> Обязательный

Тип: Строка. Ключ устанавливаемого элемента.

<3начение> Необязательный

Значение устанавливаемого элемента.

Описание:

Устанавливает значение элемента структуры по ключу. Если элемент с переданным значением ключа существует, то его значение заменяется, в противном случае добавляется новый элемент.

Пример:

СтруктураОтбор = Новый Структура("Дата, Клиент");
СтруктураОтбор.Вставить("Клиент", ТекКлиент);
СтруктураОтбор.Вставить("Дата", РабочаяДата);

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество элементов структуры.

Описание:

Позволяет получить количество элементов структуры.

Пример:

СтруктураОтбор.Количество() ;

Очистить (Clear)

Синтаксис:

Очистить()

Описание:

Удаляет все элементы структуры.

Пример:

СтруктураОтбор.Очистить() ;

Свойство (Property)

Синтаксис:

Свойство(<Ключ>, <Найденное значение> )

Параметры:

<Ключ> Обязательный

Тип: Строка. Ключ для поиска свойства.

<Найденное значение> Необязательный

Тип: Произвольный. В данный параметр возвращается найденное значение. Если ключа нет в структуре, то возвращается Неопределено.

Возвращаемое значение:

Тип: Булево. Истина, если ключ найден, Ложь, если ключ не найден.

Описание:

Позволяет получить значение элемента по указанному имени, а также проверить имеется ли указанное свойство.

Пример:

СтруктураОтбор.Свойство("Дата");

Удалить (Remove)

Синтаксис:

Удалить (<Ключ>)

Параметры:

<Ключ> Обязательный

Тип: Строка. Ключ удаляемого элемента.

Описание:

Удаляет элемент структуры с заданным ключом.

Пример:

СтруктураОтбор.Удалить("Дата");

Конструкторы

Основной

Синтаксис:

Новый Структура (<Ключи>)

Параметры:

<Ключи> Необязательный

Тип: Строка. Строка, содержащая имена ключей, разделенные запятыми.

Описание:

Позволяет создать структуру с ключами, значения которых передаются в параметре конструктора.

КлючИЗначение (KeyAndValue)

Объект является элементом коллекции Структура, представляя собой пару из ключа и соответствующего ключу значения.

Свойства

Значение (Value)

Использование:

Только чтение.

Описание:

Тип: Произвольный. Содержит значение элемента структуры.

Ключ (Key)

Использование:

Только чтение.

Описание:

Тип: Строка. Содержит ключ элемента структуры. Он должен соответствовать требованиям, предъявляемым к именованию переменных встроенного языка. Регистр символов при обращении к ключу не имеет значения.


1-320 Соответствие

Соответствие

Соответствие представляет собой динамический набор данных -коллекцию значений, каждый элемент которой состоит из пар Ключ и Значение. Ключи соответствия уникальны, и поэтому ими можно идентифицировать значения. В отличие от структуры, ключи соответствия могут быть произвольных типов. Рекомендуется, чтобы в качестве ключа выступало значение примитивного типа или другого типа, значение которого может только присваиваться, но не может менять свое содержимое.

При помощи ключей также можно получать значения соответствия, при этом если передать ключ, не существующий в соответствии, будет возвращено Неопределено.

Соответствие (Map)

Представляет доступ к соответствию.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа КлючИЗначение. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы соответствия.

См. также:

КлючИЗначение.

Методы

Вставить (Insert)

Синтаксис:

Вставить(<Ключ>, <3начение>)

Параметры:

<Ключ> Обязательный

Ключ устанавливаемого элемента.

<3начение> Обязательный

Значение устанавливаемого элемента.

Описание:

Устанавливает значение элемента соответствия по ключу. Если элемент с переданным значением ключа существует, то его значение заменяется, в противном случае добавляется новый элемент.

Пример:

ПараметрыОбработки = Новый Соответствие();
ПараметрыОбработки.Вставить ("Дата начала", ДатаНач);
ПараметрыОбработкм.Вставить("Дата конца", ДатаКон);

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество элементов соответствия.

Описание:

Позволяет получить количество элементов соответствия.

Пример:

ПараметрыОбработки.Количество();

Очистить (Clear)

Синтаксис:

Очистить()

Описание:

Удаляет все элементы соответствия.

Пример:

ПараметрыОбработки.Очистить();

Удалить (Remove)

Синтаксис:

Удалить(<Ключ>)

Параметры:

<Ключ> Обязательный

Ключ удаляемого элемента.

Описание:

Удаляет элемент соответствия с заданным ключом.

Пример:

ПараметрыОбработки.Удалить( "Дата конца");

Конструкторы

Основной

Синтаксис:

Новый Соответствие()

Описание:

Позволяет создать пустое соответствие (без элементов).

КлючИЗначение (KeyAndValue)

Объект является элементом коллекции Соответствие, представляя собой пару из ключа и соответствующего ключу значения.

Свойства

Значение (Value)

Использование:

Только чтение.

Описание:

Тип: Произвольный. Содержит значение элемента соответствия.

Ключ (Key)

Использование:

Только чтение.

Описание:

Тип: Произвольный. Содержит ключ элемента соответствия. Рекомендуется, чтобы в качестве ключа выступало значение примитивного типа или другого типа, значение которого может только присваиваться, но не может менять свое содержимое.


1-324 Список значений

Список значений

Список значений - это не сохраняемый в информационной базе объект, который позволяет строить для решения интерфейсных задач динамические наборы значений и манипулировать ими (добавлять, редактировать, удалять элементы, сортировать). Он может быть наполнен значениями любого типа, т.е. в одном списке типы хранимых значений могут быть разными. Одним из примеров использования данного объекта может служить организация выбора конкретного документа из списка возможных документов, сформированного по сложному алгоритму.

Условно можно представить себе список значений как таблицу, состоящую из пяти граф: индекс, пометка, значение, представление значения и картинка. Индекс определяет позицию элемента в списке значений. Индекс формируется и отслеживается автоматически, непосредственно недоступен для редактирования. Индекс первого элемента равен 0. В графе пометки содержится связанное с элементом списка значение пометки. В графе со значением хранится собственно сохраняемое значение. В графе представления хранится строка с пользовательским представлением хранимого значения. Данное представление показывается во время визуального отображения списка в элементах управления формы или при выборе значения. Если представление не указано, то при визуальном отображении списка система сформирует стандартное представление отображаемого значения. В графе картинка хранится визуальное представление, связанное с данным значением.

СписокЗначений (ValueList)

Используется для доступа к методам списка значений в целом.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа ЭлементСпискаЗначений. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции.. Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс элемента.

Пример:

// Пример перемещения элемента в поле списка формы
// вперед (вниз) на одну позицию.
Список = ЭлементыФормы.ПолеСпискаТиповЦен.Значение;
ТекЭлементСписка = ЭлементыФормы.ПолеСпискаТиповЦен.ТекущаяСтрока;
Если ТекЭлементСписка <> Неопределено Тогда
НомерСтроки = Список.Индекс(ТекЭлементСписка);
Если НомерСтроки + 1 < Список.Количество() Тогда
Список.Сдвинуть(ТекЭлементСписка, 1);
Иначе
Сообщить('Достигнут конец списка!") ;
КонецЕсли;
Иначе
Сообщить('Не выбрана строка списка типов цен!");
КонецЕсли;

Методы

Вставить (Insert)

Синтаксис:

Вставить(<Индекс>, <3начение>, <Представление> , <Пометка>, <Картинка>)

Параметры:

<Индекс> Обязательный

Тип: Число. Индекс позиции, на которую надо вставить элемент.

<3начение> Необязательный

Тип: Произвольный. Значение, которое необходимо вставить.

Значение по умолчанию: Неопределено.

<Представление> Необязательный

Тип: Строка. Строковое выражение, содержащее представление добавляемого значения.

Значение по умолчанию: Пустая строка.

<Пометка> Необязательный

Тип: Булево. Определяет, создавать новое значение с установленной пометкой или нет.

Значение по умолчанию: Ложь.

<Картинка> Необязательный

Тип: Картинка. Визуальное представление значения. Значение по умолчанию: Пустая картинка.

Возвращаемое значение:

Тип: ЭлементСпискаЗначений. Новый элемент списка значений.

Описание:

Позволяет вставить новый элемент в список значений на позицию с указанным индексом.

Пример:

СписокТиповЦен.Добавить("Все наценки", Истина);
ВыборкаТиповЦен = Справочники.ТипыЦен.Выбрать();
Пока ВыборкаТиповЦен.Следующий() Цикл
СписокТиповЦен.Вставить(0, ВыборкаТиповЦен.Ссылка, ВыборкаТиповЦен.Наценка, Ложь);
КонецЦикла ;

ВыбратьЭлемент (Chooseltem)

Синтаксис:

ВыбратьЭлемент(< Заголовок>, <Элемент>)

Параметры:

<3аголовок> Необязательный

Тип: Строка. Заголовок окна выбора.

Значение по умолчанию: Неопределено. Стандартный заголовок системы.

<Элемент> Необязательный

Тип: ЭлементСпискаЗначений. Элемент, на который следует изначально спозиционировать список значений при интерактивном выборе. Если значением параметра не является элемент списка значений, входящий в данный список, позиционирования не произойдет.

Значение по умолчанию: Неопределено.

Возвращаемое значение:

Тип: ЭлементСпискаЗначений. Выбранный элемент списка значений. При отказе от выбора возвращается Неопределено.

Описание:

Позволяет интерактивно выбрать один из элементов, входящих в список значений.

Пример:

ВыбЭлемент = СписокТиповЦен.НайтиПоЗначению(ВыбЗначение);
ВыбЭлемент = СписокТиповЦен.ВыбратьЭлемент("Выберите
тип цен:", ВыбЭлемент);
Если ВыбЭлемент = Неопределено Тогда
Сообщить("Не выбран тип цен.");
Иначе
ВывЗначение = ВыбЭлемент.Значение;
КонецЕсли ;

ВыгрузитьЗначения (UnloadValues)

Синтаксис:

ВыгрузитьЗначения()

Возвращаемое значение:

Тип: Массив. Сформированный массив.

Описание:

Позволяет выгрузить хранимые элементами значения в массив значений.

Пример:

МассивЭлементов = СписокТиповЦен.Выгрузить();

Добавить (Add)

Синтаксис:

Добавить(< Значение>, <Представление> , <Пометка>, <Картинка>)

Параметры:

<3начение> Необязательный

Тип: Произвольный. Значение, которое необходимо добавить.

Значение по умолчанию: Неопределено.

<Представление> Необязательный

Тип: Строка. Строковое выражение, содержащее представление добавляемого значения.

Значение по умолчанию: Пустая строка.

<Пометка> Необязательный

Тип: Булево. Определяет, создавать новое значение с установленной пометкой или без пометки.

Значение по умолчанию: Ложь.

<Картинка> Необязательный

Тип: Картинка. Визуальное представление значения.

Значение по умолчанию: Пустая картинка.

Возвращаемое значение:

Тип: ЭлементСпискаЗначений. Добавленный элемент списка значений.

Описание:

Позволяет добавить новый элемент в конец списка значений.

Пример:

Выборка = Справочники.ТипыЦен.Выбрать();
Пока Выборка.Следующий() Цикл
СписокТиповЦен.Добавить(Выборка.Ссылка, Выборка.Наценка, Истина);
КонецЦикла;

ЗагрузитьЗначения (LoadValues)

Синтаксис:

ЗагрузитьЗначения (< Массив значений>)

Параметры:

<Массив значений> Обязательный

Тип: Массив. Массив, содержащий значения для заполнения списка значений.

Описание:

Очищает список значений, затем заполняет его элементами со значениями, взятыми из переданного в качестве параметра массива.

Пример:

СписокТиповЦен.Загрузить(МассивЭлементов) ;

Индекс (IndexOf)

Синтаксис:

Индекс(<Элемент>)

Параметры:

<Элемент> Обязательный

Тип: ЭлементСпискаЗначений. Элемент списка значений, для которого надо определить индекс.

Возвращаемое значение:

Тип: Число. Индекс переданного элемента в списке значений. Если элемент не принадлежит данному списку, возвращается -1.

Описание:

Позволяет определить индекс элемента в списке значений.

Пример:

НомерСтроки = Список.Индекс(ТекущийЭлементСписка);

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество элементов в списке.

Описание:

Позволяет получить количество элементов списка значений.

Пример:

Сообщить ("Итого типов цен: " + СписокТиповЦен.Количество());

НайтиПоЗначению (FindByValue)

Синтаксис:

НайтиПоЗначению(<Искомое значение>)

Параметры:

<Искомое значение> Обязательный

Тип: Произвольный. Выражение со значением, которое требуется найти.

Возвращаемое значение:

Тип: ЭлементСпискаЗначений. Найденный элемент списка значений. Если ни один элемент не хранит значения, равного искомому, возвращается Неопределено.

Описание:

Позволяет найти соответствующий значению элемент списка значений.

Пример:

Если ПолеСписка1.НайтиПоЗначению(Вы6Значение) = Неопределено Тогда
Сообщить("Значение не найдено!");
КонецЕсли;

ОтметитьЭлементы (Checkltems)

Синтаксис:

ОтметитьЭлементы (<Заголовок>)

Параметры:

< Заголовок> Необязательный

Тип: Строка. Заголовок окна диалога.

Значение по умолчанию: Неопределено. Стандартный заголовок системы.

Возвращаемое значение:

Тип: Булево. Истина, если в диалоге пометки нажата кнопка ОК, иначе - Ложь.

Описание:

Позволяет интерактивно установить или снять пометки у элементов списка значений.

Пример:

Если СписокТиповЦен.ОтметитьЭлементы("Отметьте удаляемые типы цен.") Тогда
Для каждого Элемент из СписокТиповЦен Цикл
Если Элемент.Пометка = Истина Тогда
Элемент.Значение.ПолучитьОбъект().УстановитьПометкуУдаления(Истина);
КонецЕсли;
КонецЦикла;
Иначе
Сообщить("Отказ от пометки на удаление типов цен.");
КонецЕсли;

Очистить (Clear)

Синтаксис:

Очистить()

Описание:

Позволяет очистить список значений, удаляя из него все элементы.

Пример:

СписокТиповЦен.Очистить() ;

Сдвинуть (Move)

Синтаксис:

Сдвинуть (< Элемент>, <Смещение>)

Параметры:

<Элемент> Обязательный

Тип: Число, ЭлементСписка Значений. Индекс сдвигаемого элемента списка либо сам элемент.

<Смещение> Обязательный

Тип: Число. Количество позиций, на которое следует сдвинуть элемент. Положительное значение соответствует смещению элемента в сторону конца списка (увеличение индекса), отрицательное - к началу.

Описание:

Позволяет сдвинуть элемент списка значений на заданное количество позиций вперед или назад.

Пример:

// Сдвигаем первый элемент "вниз"
Список.Сдвинуть(0,1);

Скопировать (Copy)

Синтаксис:

Скопировать()

Возвращаемое значение:

Тип: СписокЗначений. Созданный список значений.

Описание:

Позволяет создать копию списка значений.

Пример:

КопияСписка = СписокТиповЦен.Скопировать();

СортироватьПоЗначению (SortByValue)

Синтаксис:

СортироватьПоЗначению(< Направление> )

Параметры:

<Направление> Необязательный

Тип: системное перечисление ТипСортировки. Способ сортировки - по возрастанию или по убыванию.

Значение по умолчанию: Возр.

Описание:

Позволяет упорядочить список значений в порядке возрастания или убывания хранимых элементами значений.

Пример:

СписокТиповЦен.СортироватьПоЗначению(ТипыСортировки.Возр);

СортироватьПоПредставлению (SortByPresent)

Синтаксис:

СортироватьПоПредставлению(< Направление>)

Параметры:

<Направление> Необязательный

Тип: системное перечисление ТипСортировки. Способ сортировки - по возрастанию или по убыванию.

Значение по умолчанию: Возр.

Описание:

Позволяет упорядочить список значений по возрастанию или по убыванию в алфавитном порядке представлений входящих в состав списка значений элементов.

Пример:

СписокТиповЦен.СортироватьПоПредставлению(ТипыСортировки.Убыв);

Удалить (Remove)

Синтаксис:

Удалить(<Элемент>)

Параметры:

<Элемент> Обязательный

Тип: Число, ЭлементСпискаЗначений. Индекс удаляемого элемента либо сам элемент.

Описание:

Позволяет удалить элемент из списка значений.

Пример:

// удаление по индексу в списке
СписокТиповЦен.Удалить(0);

// удаление по элементу
НайденныйЭлемент = СписокТиповЦен.НайтиПоЗначению(ВыбЗначение);
Если НайденныйЭлемент <> Неопределено Тогда
СписокТиповЦен.Удалить(НайденныйЭлемент);
Иначе
Сообщить("Значение не найдено!");
КонецЕсли,

ЭлементСпискаЗначений (ValueListItem)

Используется для доступа к свойствам и методам элемента списка значений.

Пример:

ВыборкаТиповЦен = Справочники.ТипыЦен.Выбрать();
ТипыЦен = Новый СписокЗначений;
Пока ВыборкаТиповЦен.Следуощий() Цикл
ТекНаценка = ВыборкаТиповЦен.Наценка;
Если ТекНаценка > 10 Тогда
ТипыЦен.Добавить(ВыборкаТиповЦен.Ссылка,
ТекНаценка);
КонецЕсли;
КонецЕсли;
Выбор = ТипыЦен.ВыбратьЗначение("Укажите
требуемую наценку.");
Если Выбор <> Неопределено Тогда
ТипЦен = Выбор.Значение;
КонецЕсли;

Свойства

Значение (Value)

Использование:

Чтение и запись.

Описание:

Тип Произвольный. Содержит хранимое элементом списка значение.

Картинка (Picture)

Использование:

Чтение и запись.

Описание:

Тип: Картинка. Содержит картинку, связанную с данным элементом списка значений.

Примечание:

Рекомендуемый размер картинки 14х14 пикселей.

Пометка (Check)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит связанное с элементом списка значение пометки.

Ложь - пометка не установлена, Истина - пометка установлена.

Представление (Presentation)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит внешнее представление элемента списка значений.


1-336 Таблица значений

Таблица значений

Таблица значений - это не сохраняемый в информационной базе объект, который позволяет строить динамические наборы значений и манипулировать ими (добавлять, редактировать, удалять элементы, сортировать). Он может быть наполнен значениями любого типа, т.е. в одной таблице типы хранимых значений могут быть разными. Одним из примеров использования данного объекта может служить организация представления в форме списка элементов справочника, отобранных по сложному алгоритму.

Необходимо отметить, что таблица значений, связанная с элементом управления ТабличноеПоле, будет иметь все колонки, имеющиеся в табличном поле, с соответствующими именами. Кроме того, таблица значений может иметь также и собственные колонки, не отображаемые в табличном поле, при этом их имена должны отличаться от имен колонок табличного поля.

ТаблицаЗначений (ValueTable)

Объект представляет собой саму таблицу значений. Все основные операции с таблицей производятся именно через этот объект. Он позволяет манипулировать строками таблицы значений и предоставляет доступ к коллекции колонок.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа СтрокаТаблицыЗначений. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции. Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс строки.

Пример:

// Пример работы с таблицей значения,
// связь с элементом управления ТабличноеПоле
// Создание описателя типов для таблицы значений
КЧ = Новый КвалификаторыЧисла(12,2);
КС = Новый КвалификаторыСтроки(20);
М = Новый Массив;
М.Добавить(Тип("Строка"));
ОписаниеТиповС = Новый ОписаниеТипов(М, , КС);
М.Очистить();
М.Добавить(Тип("Число"));
ОписаниеТиповЧ = Новый ОписаниеТипов{М, , , КЧ);
// Создание таблицы значений
Табл = Новый ТаблицаЗначений;
Сообщить("Число колонок таблицы значений: " + Табл.Колонки.Количество());
// добавим в таблицу значений три колонки
Табл.Колонки.Добавить("Отдел",ОписаниеТиповС, "Отдел");
Табл.Колонки.Добавить("Сотрудник",ОписаниеТиповС,"Фамилия сотрудника");
Табл.Колонки.Добавить("Оклад",ОписаниеТиповЧ,"Оклад");
Сообщить("Число колонок таблицы значений после добавления (1): "+Табл.Колонки.Количество());
// добавим строку
Стр=Табл.Добавить();
Стр.Отдел="Отдел 1";
Стр.Сотрудник="Иванов";
Стр.Оклад=5600;
// Добавление в форму табличного поля
ЭлементыФормы.Добавить(Тип("ТабличноеПоле"),"ТПоле",Истина);
// указание размеров и положения в форме
ЭлементыФормы.ТПоле.Верх=150; ЭлементыФормы.ТПоле.Лево=150;
ЭлементыФормы.ТПоле.Ширина=350; ЭлементыФормы.ТПоле.Высота=130;
// связь табличного поля с таблицей значений
ЭлементыФормы.ТПоле.Значение = Табл;
Сообщить("Число колонок табличного поля: " + ЭлементыФормы.ТПоле.Колонки,
Количество());
// укажем ширину колонок
ЭлементыФормы.ТПоле.Колонки[0].Ширина = 20;
ЭлементиФормы.ТПоле.Колонки[1].Ширина = 20;
ЭлементыФормы.ТПоле.Колонки[2].Ширина = 10;
ЭлементыФормы.ТПоле.Колонки[2].ТекстПодвала = 10;
ЭлементыФормы.ТПоле.ЧередованиеЦветовСтрок = Истина;
ЭлементыФормы.ТПоле.Колонки[2].ОтображатьВПодвале = Истина;
// добавим новую колонку в таблицу значений
Табл.Колонки.Добавить("Стаж",ОписаниеТиповЧ,"Стаж работы");
ЭлементыФормы.ТПоле.Колонки[3].Ширина = 10;
Сообщить("Число колонок таблицы значений после добавления (2): "+Табл.Колонки.Количество());
//в табличном поле колонка также добавляется
Сообщить("Число колонок табличного поля: "+ЭлементыФормы.ТПоле.Колонки.Количество());
// добавим новую колонку в табличное поле
ЭлементыФормы.ТПоле.Колонки.Добавить("Примечание") ;
ЭлементыФормы.ТПоле.Колонки[4].Ширина = 20;
// просмотр числа колонок таблицы значений и табличного поля
Сообщить("Число колонок таблицы значений не изменилось: "+Табл.Колонки.Количество());
Сообщить("Число колонок табличного поля увеличилось: " +Элементыформы.ТПоле.Колонки.Количество());
//показ имен и установка шрифта колонок
ШрифтШапки = Новый Шрифт ("Arial", 9, истина);
Для каждого Колонка Из Табл.Колонки Цикл
Сообщить("Имя колонки " + ": "+Колонка.Имя);
КонецЦикла;
Для каждого Колонка Из ЭлементыФормы.ТПоле.Колонки Цикл
Колонка.ШрифтШапки = ШрифтШапки;
КонецЦикла;
// ввод новой строки и данных по строке
ЭлементыФормы.ТПоле.ДобавитьСтроку();
ТекСтр = ЭлементыФормы.ТПоле.ТекущаяСтрока;
ТекСтр.Отдел = "Отдел 2"; ТекСтр.Сотрудник = "Петров";
ТекСтр.Оклад = 6700; ТекСтр.Стаж = 22;
Сообшить("Итог: Фонд = "+Табл.Итог(Табл.Колонки(2).Имя) +
" Среднее =
"+Табл.Итог(Табл.Колонки[2].Имя)/Табл.Количество());

Результат выполнения:

Число колонок таблицы значений: 0
Число колонок таблицы значений после добавления (1) : 3
Число колонок табличного поля: 3
Число колонок таблицы значений после добавления (2) : 4
Число колонок табличного поля: 4
Число колонок таблицы значений не изменилось: 4
Число колонок табличного поля увеличилось: 5
Имя колонки : Отдел
Имя колонки : Сотрудник
Имя колонки : Оклад
Имя колонки : Стаж
Итог: Фонд = 12 300; Среднее = 6 150

Свойства

Колонки (Columns)

Использование:

Только чтение.

Описание:

Тип: КоллекцияКолонокТаблицыЗначений. Предоставляет доступ к коллекции колонок таблицы значений.

Методы

Вставить (Insert)

Синтаксис:

Вставить(<Индекс>)

Параметры:

<Индекс> Обязательный

Тип: Число. Индекс вставляемой строки.

Возвращаемое значение:

Тип: СтрокаТаблицыЗначений. Вставленная строка.

Описание:

Вставляет строку на позицию в таблице значений, соответствующую указанному индексу.

Пример:

НоваяСтрока = ТаблицаЦен.Вставить(2);
НоваяСтрока.Товар = ТекТовар;
НоваяСтрока.Цена = ПолученнаяЦена;

ВыбратьСтроку (SelectRow)

Синтаксис:

ВыбратьСтроку(< Заголовок>, <Начальная строка> )

Параметры:

<3аголовок> Необязательный

Тип: Строка. Заголовок диалогового окна выбора строки. Может использоваться для подсказки пользователю.

<Начальная строка> Необязательный

Тип: СтрокаТаблицыЗначений. Указывает строку таблицы значений, на которой будет установлен курсор при открытии окна выбора.

Возвращаемое значение:

Тип: СтрокаТаблицыЗначений. Выбранная строка таблицы значений. Если пользователь отказался от выбора возвращает Неопределено.

Описание:

Вызывает модальное диалоговое окно для интерактивного выбора строки из таблицы значений.

ВыгрузитьКолонку (UnloadColumn)

Синтаксис:

ВыгрузитьКолонку (< Колонка>)

Параметры:

<Колонка> Обязательный

Тип: Число, Строка, КолонкаТаблицыЗначений. Колонка, значения которой необходимо выгрузить. В качестве значения параметра может выступать индекс колонки, имя колонки, сама колонка.

Возвращаемое значение:

Тип: Массив. Массив значений, содержащихся в колонке.

Описание:

Выгружает значения колонки в массив значений.

Добавить (Add)

Синтаксис:

Добавить()

Возвращаемое значение:

Тип: СтрокаТаблицыЗначений. Добавленная строка.

Описание:

Добавляет строку в конец таблицы значений.

Пример:

НоваяСтрока = ТаблицаЦен.Добавить();
НоваяСтрока.Товар = ТекТовар;
НоваяСтрока.Цена = ПолученнаяЦена;

ЗагрузитьКолонку (LoadColumn)

Синтаксис:

ЗагрузитьКолонку(< Массив>, <Колонка>)

Параметры:

<Массив> Обязательный

Тип: Массив. Массив значений, который выступает в качестве источника данных для колонки.

<Колонка> Обязательный

Тип: Число, Строка, КолонкаТаблицыЗначений. Колонка, в которую будут загружены значения из массива. В качестве значения параметра может выступать индекс колонки, имя колонки, сама колонка.

Описание:

Загружает колонку таблицы значений из массива значений.

ЗаполнитьЗначения (FillValues)

Синтаксис:

3аполнитьЗначения (<Значение>, <Колонки>)

Параметры:

<3начение> Обязательный

Тип: Произвольный. Значение, которым необходимо заполнить строки таблицы.

<Колонки> Необязательный

Тип: Строка. Список имен колонок, разделенных запятыми, по которым производится заполнение строк таблицы значений.

Значение по умолчанию: Если параметр не указан, или передана пустая строка, будет заполнена вся таблица.

Описание:

Заполняет все строки таблицы значений указанным значением.

Пример:

ТаблицаЦен.Заполнить(Рубли, "Валюта');

Индекс (IndexOf)

Синтаксис:

Индекс(<Строка>)

Параметры:

<Строка> Обязательный

Тип: СтрокаТаблицыЗначений. Строка таблицы значений, для которой нужно определить индекс.

Возвращаемое значение:

Тип: Число. Индекс строки таблицы значений. Если строка не принадлежит данной таблице, возвращается -1.

Описание:

Позволяет определить индекс строки таблицы значений.

Итог (Total)

Синтаксис:

Итог(<Колонка>)

Параметры:

<Колонка> Обязательный

Тип: Строка. Имя колонки, по которой необходимо посчитать итог.

Возвращаемое значение:

Тип: Число. Сумма значений по всем строкам указанной колонки.

Описание:

Позволяет просуммировать значения всех строк в указанной колонке.

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество строк таблицы значений.

Описание:

Позволяет получить количество строк таблицы значений.

Пример:

КолСтрок = ТаблицаЦен.Количество();

Найти (Find)

Синтаксис:

Найти(<Значение>, <Колонки>)

Параметры:

<Значение > Обязательный

Тип: Произвольный. Искомое значение.

<Колонки> Необязательный

Тип: Строка. Список имен колонок, разделенных запятыми, по которым производится поиск.

Значение по умолчанию: Если параметр не указан, или передана пустая строка, поиск осуществляется по всей таблице.

Возвращаемое значение:

Тип: СтрокаТаблицыЗначений. Строка, в которой содержится искомое значение. Если значение не найдено возвращается Неопределено.

Описание:

Позволяет найти значение в указанных колонках таблицы значений.

Примечание:

Метод эффективно использовать для поиска уникальных значений.

Пример:

НайденнаяСтрока = ТаблицаЦен.Найти(ВыбТовар,
"Товар");
Если НайденнаяСтрока = Неопределено
Тогда
Предупреждение("Товар не
найден!');
Иначе
ЦенаТовара = НайденнаяСтрока.Цена;
КонецЕсли;

НайтиСтроки (FindRows)

Синтаксис:

НайтиСтроки (< Параметры отбора> )

Параметры:

<Параметры отбора> Обязательный

Тип: Структура. Задает условия поиска; ключ структуры определяет имя колонки, по которой будет осуществляться поиск, а значение структуры - искомое значение.

Возвращаемое значение:

Тип: Массив. Массив строк таблицы значений, соответствующих условиям поиска.

Замечание! Массив хранит ссылки на строки таблицы значений, то есть при изменении строки в таблице, значение в массиве тоже будет измененным.

Описание:

Позволяет найти строки таблицы значений, отвечающие заданным условиям поиска.

Примечание:

Метод эффективно использовать для выборки неуникальных значений.

Очистить (Clear)

Синтаксис:

Очистить()

Описание:

Позволяет удалить все строки таблицы значений. Структура колонок остается неизменной.

Пример:

ТаблицаЦен.Очистить();

Свернуть (GroupBy)

Синтаксис:

Свернуть(< Колонки группировок , <Колонки суммирования>)

Параметры:

<Колонки группировок> Обязательный

Тип: Строка. Имена колонок, разделенные запятыми, по которым необходимо группировать строки таблицы значений.

<Колонки суммирования> Необязательный

Тип: Строка. Имена колонок, разделенные запятыми, по которым необходимо суммировать значения в строках таблицы значений.

Описание:

Осуществляет свертку таблицы значений по указанным колонкам группировки. Строки, у которых совпадают значения в колонках, указанных в первом параметре, сворачиваются в одну строку. Значения этих строк, хранящиеся в колонках, указанных во втором параметре, накапливаются.

Важно! Списки колонок не должны пересекаться. Колонки, не вошедшие ни в один из списков колонок, после выполнения метода удаляются из таблицы значений.

Пример:

ТаблицаЦен.Сверауть("Товар, Налита", "Цена");

Сдвинуть (Move)

Синтаксис:

Сдвинуть(< Строка>, <Смещение> )

Параметры:

<Строка> Обязательный

Тип: Число, СтрокаТаблицыЗначений. Индекс строки, которую нужно переместить, или сама строка.

<Смещение> Обязательный

Тип: Число. Количество строк, на которое необходимо переместить строку. Положительное значение означает, что строка будет передвинута ближе к концу таблицы значений (вниз), отрицательное - ближе к началу (вверх).

Описание:

Позволяет переместить строку на указанное количество позиций.

Пример:

// перемещение первой строки вперед на одну позицию
ТаблицаЦен.Сдвинуть(0, 1) ;

// перемещение второй строки назад на одну позицию
ТаблицаЦен.Сдвинуть(1, -1);

Скопировать (Copy)

Синтаксис:

Скопировать()

Возвращаемое значение:

Тип: ТаблицаЗначений.

Описание:

Позволяет сделать полную копию исходной таблицы значений.

Пример:

НовТаблицаЦен = ТаблицаЦен.Скопировать();

Сортировать (Sort)

Синтаксис:

Сортировать(< Колонки>)

Параметры:

<Колонки> Обязательный

Тип: Строка. Список имен колонок, разделенных запятыми, по которым производится сортировка таблицы. После каждого имени колонки через пробел может быть указано направление сортировки. Направление определяется: "Убыв" ("Desc") - упорядочивать по убыванию; "Возр" ("Asc") - упорядочивать по возрастанию. По умолчанию сортировка производится по возрастанию. Порядок указания имен колонок таблицы определяет порядок сортировки. Это означает, что сначала таблица сортируется по колонке, указанной первой. Затем группы строк с одинаковым значением в этой колонке сортируются по колонке, которая указана второй, и так далее.

Описание:

Позволяет отсортировать таблицу значений в соответствии с указанными правилами сортировки.

Пример:

ТаблицаЦен.Сортировать("Цена Убыв, Товар Возр");

Удалить (Remove)

Синтаксис:

Удалить(< Индекс>)

Параметры:

<Индекс> Обязательный

Тип: Число. Индекс строки, которую надо удалить.

Описание:

Удаляет из таблицы значений строку по указанному индексу.

Пример:

ТаблицаЦен.Удалить(ИндексУдаляемойСтроки);

СтрокаТаблицыЗначений (ValueTableRow)

Объект предоставляет собой отдельную строку таблицы значений.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа Произвольный. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются значения в колонке данной строки. Возможно обращение к значению колонки данной строки, посредством оператора [...]. В качестве аргумента передается индекс колонки.

Свойства

<Имя колонки>

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Набор свойств содержит значения в колонках таблицы значений по конкретной строке. Имена свойств совпадают с именами колонок таблицы значений.


1-349 КоллекцияКолонокТаблицыЗначений

КоллекцияКолонокТаблицыЗначений (ValueTableColumnCollection)

Объект представляет собой коллекцию колонок таблицы значений. Доступ к объекту осуществляется через свойство Колонки таблицы значений.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа КолонкаТаблицыЗначений. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции.. Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс элемента.

Свойства

<Имя колонки>

Использование:

Только чтение.

Описание:

Тип: КолонкаТаблицыЗначений. Набор свойств содержит колонки таблицы значений. Имена свойств совпадают с именами колонок.

Методы

Вставить (Insert)

Синтаксис:

Вставить(<Индекс>, <Имя>, <Тип>, <3аголовок>, <Ширина>)

Параметры:

<Индекс> Обязательный

Тип: Число. Индекс вставляемой колонки.

<Имя> Необязательный

Тип: Строка. Имя колонки.

Значение по умолчанию: Пустая строка.

<Тип> Необязательный

Тип: ОписаниеТипов. Объект, описывающий допустимые типы значений для колонки.

Значение по умолчанию: Если параметр не указан, в колонке можно будет хранить значение любого типа.

<3аголовок> Необязательный

Тип: Строка. Заголовок колонки таблицы значений. Используется при визуальном отображении таблицы значений.

Значение по умолчанию: Пустая строка.

<Ширина > Необязательный

Тип: Число. Ширина колонки в символах. Используется при визуальном отображении таблицы значений.

Значение по умолчанию: 0.

Возвращаемое значение:

Тип: КолонкаТаблицыЗначений. Вставленная колонка

Описание:

Вставляет колонку на указанную позицию в таблицу значений.

Добавить (Add)

Синтаксис:

Добавить(<Имя>, <Тип>, <3аголовок>, <Ширина>)

Параметры:

<Имя> Необязательный

Тип: Строка. Имя колонки. Значение по умолчанию: Пустая строка.

<Тип> Необязательный

Тип: ОписаниеТипов. Объект, описывающий допустимые типы значений для колонки.

Значение по умолчанию: Если параметр не указан, в колонке можно будет хранить значение любого типа.

<3аголовок> Необязательный

Тип: Строка. Заголовок колонки таблицы значений. Используется при визуальном отображении таблицы значений.

Значение по умолчанию: Пустая строка.

<Ширина> Необязательный

Тип: Число. Ширина колонки в символах. Используется при визуальном отображении таблицы значений.

Значение по умолчанию: 0.

Возвращаемое значение:

Тип: КолонкаТаблицыЗначений. Добавленная колонка.

Описание:

Добавляет колонку в конец коллекции колонок таблицы.

Индекс (IndexOf)

Синтаксис:

Индекс(<Колонка>)

Параметры:

<Колонка> Обязательный

Тип: КолонкаТаблицыЗначений. Колонка таблицы значений, для которой нужно определить индекс.

Возвращаемое значение:

Тип: Число. Индекс колонки таблицы значений. Если колонка не принадлежит данной таблице, возвращается -1.

Описание:

Позволяет определить индекс колонки таблицы значений. .

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество колонок таблицы значений.

Описание:

Позволяет получить количество колонок таблицы значений.

Очистить (Clear)

Синтаксис:

Очистить()

Описание:

Позволяет удалить все колонки таблицы значений.

Примечание:

Фактически после исполнения метода будут удалены все колонки и строки таблицы значений.

Сдвинуть (Move)

Синтаксис:

Сдвинуть(< Колонка>, <Смещение>)

Параметры:

<Колонка> Обязательный

Тип: Число, Колонка ТаблицыЗначений. Индекс сдвигаемой колонки или сама колонка.

<Смещение> Обязательный

Тип: Число. Количество колонок, на которое необходимо переместить колонку. Положительное значение означает, что колонка будет передвинута ближе к концу таблицы значений будет передвинута ближе к концу таблицы значений (вправо), отрицательное - ближе к началу (влево).

Описание:

Позволяет переместить колонку на указанное количество позиций.

Удалить (Remove)

Синтаксис:

Удалить(<Индекс>)

Параметры:

<Индекс> Обязательный

Тип: Число, КолонкаТаблицыЗначений. Индекс удаляемой колонки или сама колонка.

Описание:

Метод удаляет заданную колонку из таблицы значений.

КолонкаТаблицыЗначений (ValueTableColumn)

Объект предоставляет собой отдельную колонку таблицы значений. Доступ к объекту осуществляется через свойства коллекции колонок таблицы значений.

Свойства

Заголовок (Title)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит заголовок колонки таблицы значений. Используется при визуальном отображении таблицы значений.

Имя (Name)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит строку с именем колонки.

ТипЗначения (ValueType)

Использование:

Только чтение.

Описание:

Тип: ОписаниеТипов. Содержит объект, описывающий допустимые типы значений для колонки.

Ширина (Width)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит ширину колонки в символах. Используется при визуальном отображении таблицы значений.

Расширение табличного поля таблицы значений

Дополнительные свойства табличного поля при отображении в нем таблицы значений. Для данного расширения свойства ТекущаяСтрока и ТекущиеДанные табличного поля имеют значения типа СтрокаТаблицыЗначений.

Свойства

ФиксацияСверху (FixedTop)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит количество строк таблицы значений, фиксированных сверху, то есть не прокручиваемых при прокрутке табличного поля.

ФиксацияСнизу (FixedBottom)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит количество строк таблицы значений, фиксированных снизу, то есть не прокручиваемых при прокрутке табличного поля.

Расширение колонки табличного поля таблицы значений

Дополнительные свойства колонки табличного поля таблицы значений.

Свойства

Данные (Data)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя колонки таблицы значений. Данное свойство позволяет указать, какие данные будут отображаться и редактироваться в ячейке табличного поля.

ДанныеКартинки (PictureData)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя колонки таблицы значений, из которой следует брать картинку для отображения в колонке табличного поля. Если в колонке таблицы значений хранится картинка, будет отображена она. Если в колонке хранится число, оно будет интерпретировано как индекс картинки в наборе картинок, указанном в свойстве КартинкиСтрок колонки табличного поля.

ДанныеФлажка (CheckData)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя колонки таблицы значений, данные которой необходимо отображать в виде флажка в колонке табличного поля. Колонка таблицы значений должна иметь тип Булево или Число.

ПоказыватьИтогиВПодвале (ShowTotalslnFooter)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак отображения в подвале табличного поля итогов по колонке таблицы значений.

Примечание:

Свойство доступно для колонок, имеющих тип Число.


1-357 Дерево значений

Дерево значений

Дерево значений представляет собой динамически формируемый набор значений любого типа, сходный с объектом ТаблицаЗначений. В отличие от таблицы значений, строки дерева значений могут образовывать иерархические структуры: каждая строка дерева может иметь набор (коллекцию) подчиненных строк, каждая из подчиненных строк в свою очередь также может иметь набор подчиненных строк и так далее. При этом поиск значений, сортировка, получение итогов могут осуществляться либо по текущему уровню иерархии, либо включая все подчиненные. Дерево значений может иметь визуальное представление, если с ним связать элемент управления ТабличноеПоле. Внешний вид такого элемента будет похож на дерево групп справочника.

Необходимо отметить, что дерево значений, связанное с элементом управления ТаблкчноеПоле, будет иметь все колонки, имеющиеся в табличном поле, с соответствующими именами. Кроме того, дерево значений может иметь также и собственные колонки, не отображаемые в табличном поле, при этом их имена должны отличаться от имен колонок табличного поля.

ДеревоЗначений (ValueTree)

Используется для доступа к свойствам и методам дерева значений в целом.

Свойства

Колонки (Columns)

Использование:

Только чтение.

Описание:

Тип: КоллекцияКолонокДереваЗначений. Содержит коллекцию колонок дерева значений.

Строки (Rows)

Использование:

Только чтение.

Описание:

Тип: КоллекцияСтрокДереваЗначений. Содержит коллекцию строк 1-го уровня дерева значений.

Примечание:

Коллекции строк следующих уровней можно получить, используя свойство Строки, имеющееся у каждой строки дерева значений.

Методы

Скопировать (Copy)

Синтаксис:

Скопировать()

Возвращаемое значение:

Тип: ДеревоЗначений.

Описание:

Метод позволяет сделать полную копию исходного дерева значений.

Пример:

НовоеДеревоСостава = ДеревоСостава.Скопировать();

КоллекцияСтрокДереваЗначений (ValueTreeRowCollection)

Представляет собой коллекцию строк определенного уровня дерева значений (подчиненных какой-либо строке дерева, либо верхнего уровня).

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа СтрокаДереваЗначений. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции. Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс строки.

Методы

Вставить (Insert)

Синтаксис:

Вставить(<Индекс>)

Параметры:

<Индекс> Обязательный

Тип: Число. Индекс позиции в коллекции строк данного уровня, в которую необходимо вставить строку.

Возвращаемое значение:

Тип: СтрокаДереваЗначений. Вставленная строка.

Описание:

Вставляет строку с указанным индексом в коллекцию строк данного уровня дерева значений.

Пример:

НовыйЭлемент = СтрокиСостава.Вставить(5);
НовыйЭлемент.Затрата = Затрата;
НовыйЭлемент.Норма = Количество;

ВыгрузитьКолонку (UnloadColumn)

Синтаксис:

ВыгрузитьКолонку(< Колонка>)

Параметры:

<Колонка> Обязательный

Тип: Число, Строка, либо КолонкаДереваЗначений. Колонка, из которой нужно выгрузить значения. В качестве значения параметра может быть передан индекс колонки, имя колонки, либо колонка дерева значений.

Возвращаемое значение:

Тип: Массив. Массив, содержащий значения колонки.

Описание:

Выгружает значения, содержащиеся в колонке коллекции строк дерева значений в массив.

Примечание:

Значения из колонки выгружаются в порядке индексов строк в коллекции.

Пример:

МассивЗатрат = СтрокиСостава.ВыгрузитьКолонку("Затрата");

Добавить (Add)

Синтаксис:

Добавить()

Возвращаемое значение:

Тип: СтрокаДереваЗначений. Добавленная строка.

Описание:

Добавляет строку в конец коллекции строк данного уровня дерева значений.

Пример:

НовыйЭлемент = СтрокиСостава.Добавить();
НовыйЭлемент.Затрата = Затрата;
НовыйЭлемент.Норма = Количество;

ЗагрузитьКолонку (LoadColumn)

Синтаксис:

ЗагрузитьКолонку (< Массив> , <Колонка>)

Параметры:

<Массив> Обязательный

Тип: Массив. Массив значений для загрузки в колонку.

<Колонка> Обязательный

Тип: Число, Строка, либо КолонкаДереваЗначений. Колонка коллекции, в которую будут загружены значения из массива. В качестве значения параметра может быть передан индекс колонки, имя колонки, либо колонка дерева значений.

Описание:

Загружает значения из массива в заданную колонку коллекции строк дерева значений.

Примечание:

Значения из массива загружаются в колонку в порядке индексов.

Пример:

СтрокиСостава.ЗагрузитьКолонку(МассивЗатрат, "Затрата");

Индекс (IndexOf)

Синтаксис:

Индекс(<Строка>)

Параметры:

<Строка> Обязательный

Тип: СтрокаДереваЗначений. Строка, для которой необходимо получить индекс

Возвращаемое значение:

Тип: Число. Индекс элемента в коллекции.

Описание:

Получает индекс элемента в коллекции.

Пример:

ИндексТекСтроки = СтрокиСостава.Индекс(ТекущаяСтрока);

Итог (Total)

Синтаксис:

Итог(<Колонка>, <Включать подчиненные>)

Параметры:

<Колонка> Обязательный

Тип: Число, Строка, Колонка дерева значений. Колонка, по которой подсчитывается итог. В качестве значения параметра может быть передан индекс колонки, имя колонки, либо колонка дерева значений.

<Включать подчиненные> Необязательный

Тип: Булево. Если значение параметра Истина, в сумму будут также включены итоги по подчиненным строкам (если таковые имеются).
Значение по умолчанию: Ложь.

Описание:

Суммирует значения всех строк в указанной колонке.

Примечание:

Имеет смысл для числовых значений.

Пример:

СтоимостьПродукции = СтрокиСостава.Итог("Сумма");

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество строк в коллекции данного уровня дерева значений.

Описание:

Позволяет определить количество строк данного уровня дерева значений.

Пример:

КоличествоСтрок = СтрокиСостава.Количество();

Найти (Find)

Синтаксис:

Найти(<3начение>, <Колонки>, <Включать подчиненные>)

Параметры:

<3начение> Обязательный

Искомое значение.

<Колонки> Необязательный

Тип: Строка. Список имен колонок, в которых будет осуществляться поиск, разделенных запятыми.

Значение по умолчанию: Если параметр не указан, или передана пустая строка, поиск осуществляется по всем колонкам дерева.

<Включать подчиненные> Необязательный

Тип: Булево. Если значение параметра Истина, в поиске будут участвовать строки подчиненных коллекций (если таковые имеются).

Значение по умолчанию: Ложь.

Возвращаемое значение:

Тип: СтрокаДереваЗначений. Строка, которая содержит искомое значение. Если значение не найдено, возвращает значение Неопределено.

Описание:

Позволяет найти значение в дереве в указанных колонках коллекции строк дерева значений. Если список колонок пуст, поиск осуществляется по всем колонкам дерева.

Примечание:

Метод эффективно использовать для поиска уникальных значений.

Пример:

НайдСтрока = СтрокиСостава.Найти(ТекЗатрата,
"Затрата");
Если НайдСтрока = Неопределено
Тогда
Предупреждение("Затрата не найдена!");
Иначе
Количество = НайдСтрока.Норма ;
КонецЕсли;

НайтиСтроки (FindRows)

Синтаксис:

НайтиСтроки(<Параметры отбора> , <Включать подчиненные>)

Параметры:

<Параметры отбора> Обязательный

Тип: Структура. Задает условия поиска: ключ структуры определяет имя колонки, по которой будет осуществляться поиск, а значение структуры - искомое значение.

<Включать подчиненные> Необязательный

Тип: Булево. Если значение параметра Истина, поиск будет производится также в подчиненных коллекциях строк (если таковые имеются).

Значение по умолчанию: Ложь.

Возвращаемое значение:

Массив из строк дерева значений, соответствующих заданному условию поиска.

Замечание! Массив хранит ссылки на строки дерева значений, то есть при изменении строки в дереве, значение в массиве тоже будет изменено.

Описание:

Позволяет найти строки из коллекции строк дерева значений, соответствующие заданному условию поиска.

Примечание:

Метод эффективно использовать для выборки неуникальных значений.

Пример:

ПараметрыОтбора = Новый Структура;
ПараметрыОтбора.Вставить("Затрата", ТекЗатрата) ;
НайдСтроки = СтрокиСостава.НайтиСтроки(ПараметрыОтбора);

Очистить (Clear)

Синтаксис:

Очистить()

Описание:

Удаляет все коллекции строки данного уровня дерева значений. Если у строк данного уровня были подчиненные строки, то они также будут удалены. Структура колонок остается неизменной.

Пример:

СтрокиСостава.Очистить();

Сдвинуть (Move)

Синтаксис:

Сдвинуть(< Строка>, <Смещение>)

Параметры:

<Строка> Обязательный

Тип: Число, СтрокаДереваЗначений. Индекс строки, которую надо сдвинуть, либо сама сдвигаемая строка.

<Смещение> Обязательный

Тип: Число. Количество строк, на которые необходимо сдвинуть строку. Положительное смещение обозначает сдвиг в конец, отрицательное - в начало коллекции.

Описание:

Позволяет переместить строку на указанное количество позиций в коллекции строк данного уровня дерева значений.

Пример:

// сдвинем первую строку на следующую позицию
СтрокиСостава.Сдвинуть(0, 1) ;

// сдвинем вторую строку на предыдущую позицию
СтрокиСостава.Сдвинуть(1, -1);

Сортировать (Sort)

Синтаксис:

Сортировать(<Строка сортировки> , <Включать подчиненные>)

Параметры:

<Строка сортировки> Обязательный

Тип: Строка. Список имен колонок, разделенных запятыми, по которым производится сортировка таблицы. После каждого имени колонки через пробел может быть указано направление упорядочивания. Направление определяется: "Убыв" ("Desc") - упорядочивать по убыванию; "Возр" ("Asc") - упорядочивать по возрастанию. По умолчанию сортировка таблиці производится по возрастанию. Порядок указания имен колонок таблицы определяет порядок сортировки. Это означает, что сначала таблица сортируется по колонке, указанной первой. Затем группы строк с одинаковым значением в этой колонке сортируются по колонке, которая указана второй, и так далее.

<Включать подчиненные> Необязательный.

Тип: Булево. Если значение параметра - Истина, то будут отсортированы коллекции подчиненных строк (если таковые имеются).

Значение по умолчанию: Ложь.

Описание:

Позволяет отсортировать строки коллекции в соответствии с указанными правилами сортировки.

Пример:

СтрокиСостава.Сортировать("Норма Убыв", Истина) ;

Удалить (Remove)

Синтаксис:

Удалить(<Индекс>)

Параметры:

<Индекс> Обязательный

Тип: Число, СтрокаДереваЗначений. Индекс удаляемой строки в коллекции, либо сама удаляемая строка.

Описание:

Удаляет строку с заданным индексом из коллекции строк данного уровня дерева значений. Если у строки имеются подчиненные строки, они также будут удалены.

СтрокаДереваЗначений

Объект предоставляет собой отдельную строку дерева значений.

Свойства

<Имя колонки>

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Набор свойств содержит значения в колонках данной строки дерева значений. Имена свойств совпадают с именами колонок дерева значений.

Родитель (Parent)

Использование:

Чтение и запись.

Описание:

Тип: СтрокаДереваЗначений. Содержит строку-родителя для данной строки дерева значений. Если строка находится в корне дерева (на верхнем уровне иерархии), то свойство имеет значение Неопределено.

Строки (Rows)

Использование:

Только чтение.

Описание:

Тип: КоллекцияСтрокДереваЗначений. Содержит коллекцию строк, подчиненных данной строке дерева значений.


1-369 КоллекцияКолонокДереваЗначений

КоллекцияКолонокДереваЗначений

Объект представляет собой коллекцию колонок дерева значений. Доступ к объекту осуществляется через свойство Колонки дерева значений.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа КолонкаДереваЗначений. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции. Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс элемента.

Свойства

<Имя колонки>

Использование:

Только чтение.

Описание:

Тип: КолонкаДереваЗначений. Набор свойств содержит колонки дерева значений. Имена свойств совпадают с именами колонок дерева значений.

Методы

Вставить (Insert)

Синтаксис:

Вставить(<Индекс>, <Имя>, <Тип>, <3аголовок>, <Ширина>)

Параметры:

<Индекс> Обязательный

Тип: Число. Индекс в коллекции колонок, с которым необходимо вставить колонку.

<Имя> Необязательный

Тип: Строка. Имя колонки.

Значение по умолчанию: Пустая строка.

<Тип> Необязательный

Тип: ОписаниеТипов. Объект, описывающий допустимые типы значений для колонки.

Значение по умолчанию: Если параметр не указан, в колонке можно будет хранить значение любого типа.

<3аголовок> Необязательный

Тип: Строка. Заголовок колонки. Используется при визуальном отображении дерева значений.

Значение по умолчанию: Пустая строка.

<Ширина> Необязательный

Тип: Число. Ширина колонки в символах. Используется при визуальном отображении дерева значений.

Значение по умолчанию: 0.

Возвращаемое значение:

Тип: КолонкаДереваЗначений. Вставленная колонка.

Описание:

Вставляет колонку в заданную позицию коллекции колонок дерева значений.

Пример:

МассивТипов = Новый Массив;
МассивТипов.Добавить(Тип("Число"));
КЧ = Новый КвалификаторыЧисла(10,3);
ОписаниеЧисло = Новый ОписаниеТипов (МассивТипов, КЧ);
КолонкиСостава = ДС.Колонки;
КолонкиСостава.Вставить(2, "Количество",
ОписаниеЧисло, "Кол-во",14);

Добавить (Add)

Синтаксис:

Добавить(<Имя>, <Тип>, <3аголовок>, <Ширина>)

Параметры:

<Имя> Необязательный

Тип: Строка. Имя колонки. Значение по умолчанию: Пустая строка.

<Тип> Необязательный

Тип: ОписаниеТипов. Объект, описывающий допустимые типы значений для колонки.

Значение по умолчанию: Если параметр не указан, в колонке можно будет хранить значение любого типа.

<3аголовок> Необязательный

Тип: Строка. Заголовок колонки. Используется при визуальном отображении дерева значений.

Значение по умолчанию: Пустая строка.

<Ширина> Необязательный

Тип: Число. Ширина колонки в символах. Используется при визуальном отображении дерева значений.

Значение по умолчанию: 0.

Возвращаемое значение:

Тип: КолонкаДереваЗначений. Добавленная колонка.

Описание:

Добавляет колонку в конец коллекции колонок дерева значений.

Пример:

МассивТипов = Новый Массив;
МассивТипов.Добавить(Тип("Число")) ;
КЧ = Новый КвалификаторыЧисла(10,3);
ОписаниеЧисло = Новый ОписаниеТипов (МассивТипов, КЧ);
КолонкиСостава = ДС.Колонки;
КолонкиСостава.Добавить("Количество",
ОписаниеЧисло, "Кол-во",14);

Индекс (IndexOf)

Синтаксис:

Индекс(<Колонка>)

Параметры:

<Колонка> Обязательный

Тип: КолонкаДереваЗначений. Колонка, для которой необходимо получить индекс.

Возвращаемое значение:

Тип: Число. Индекс колонки в коллекции.

Описание:

Получает индекс указанной колонки в коллекции колонок

Пример:

ИндексТекКолонки = КолонкиСостава.Индекс(ТекущаяКолонка);

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество колонок дерева значений.

Описание:

Позволяет получить количество колонок дерева значений.

Пример:

КолонкиСостава = ДеревоСостава.Колонки;
КоличествоКолонок = КолонкиСостава.Количество();

Очистить (Clear)

Синтаксис:

Очистить()

Описание:

Метод удаляет все колонки дерева значений. При этом также удаляются все его строки.

Пример:

КолонкиСостава.Очистить();

Сдвинуть (Move)

Синтаксис:

Сдвинуть(<Колонка>, <Смещение>)

Параметры:

<Колонка> Обязательный

Тип: Числов или Колонка. Индекс сдвигаемой колонки в коллекции или сама колонка.

<Смещение> Обязательный

Тип: Число. Количество колонок, на которое необходимо сдвинуть колонку. Положительное смещение обозначает сдвиг в конец, отрицательное - в начало коллекции.

Описание:

Сдвигает колонку с заданным индексом на указанное смещение.

Пример:

// сдвинем колонку на следующую позицию
КолонкиСостава.Сдвинуть(ИндексТекущейКолонки, 1);

// сдвинем колонку на предыдущую позицию
КолонкиСостава.Сдвинуть(ИндексТекушейКолонки, -1);

Удалить (Remove)

Синтаксис:

Удалить(< Индекс>)

Параметры:

<Индекс> Обязательный

Тип: Число. Индекс удаляемой колонки в коллекции.

Описание:

Метод удаляет колонку в заданной позиции коллекции колонок дерева значений.

Пример:

КолонкиСостава.Удалить(1) ;

КолонкаДереваЗначений (ValueTreeColumn)

Описывает параметры колонки дерева значений.

Свойства

Заголовок (Title)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст заголовка колонки дерева значений. Может быть использован при визуальном представлении дерева.

Имя (Name)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя колонки.

ТипЗначения (ValueType)

Использование:

Только чтение.

Описание:

Тип: ОписаниеТипов. Содержит объект, описывающий допустимые типы значений для колонки дерева.

Ширина (Width)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит ширину колонки дерева значений в символах. Может быть использован при визуальном представлении дерева.

Расширение табличного поля дерева значений

Дополнительные свойства табличного поля при отображении в нем дерева значений. Для данного расширения свойства ТекущаяСтрока и ТекущиеДанные табличного поля имеют значения типа СтрокаДереваЗначений.

Расширение колонки табличного поля дерева значений

Дополнительные свойства колонки табличного поля, связанного с деревом значений.

Свойства

Данные (Data)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя колонки дерева значений, значения которой нужно отображать и редактировать в ячейке табличного поля.

ДанныеКартинки (PictureData)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя колонки дерева значений, из которой следует брать картинку для отображения в колонке табличного поля. Если в колонке таблицы значений хранится картинка, будет отображена она. Если в колонке хранится число, оно будет интерпретировано как индекс картинки в наборе картинок, указанном в свойстве КартинкиСтрок колонки табличного поля.

ДанныеФлажка (CheckData)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя колонки дерева значений, значения которой необходимо отображать и редактировать во флажке ячейки табличного поля.

Примечание:

Применяется для колонок табличной части булевого и числового типа.


2-001 Глава 2-1. Интерфейсные

Глава 2-1. Интерфейсные объекты

В этой главе описываются объекты, которые в основном предназначены для интерактивной работы пользователя. Это такие объекты как Форма, элементы управления, пользовательские интерфейсы и т.д. Дополнительно в этой главе освещены объекты, которые выступают значениями свойств интерфейсных объектов, например, цвета, шрифты и т.п.

Форма

Форма является одним из основных интерфейсных средств 1С:Предприятия для обеспечения взаимодействия с пользователем.

Форма (Form)

Используется для доступа к свойствам, методам и событиям формы в целом, а также к коллекции ее элементов управления. Доступ к свойствам, методам формы из ее собственного модуля может осуществляется непосредственно, используя их имена (без ссылки на какой-либо объект).

Свойства

<Имя реквизита>

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Набор свойств содержит значения реквизитов формы. Имена свойств совпадают с именами реквизитов формы как они заданы в конфигураторе.

Автозаголовок (AutoTitle)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Режим автоматического формирования заголовка формы. В этом режиме к заголовку формы будет добавляться информация, определяемая основным реквизитом формы.

См. также:

Форма, свойство Заголовок.

ВладелецФормы (FormOwner)

Использование:

Чтение и запись.

Описание:

Тип: Форма. Содержит форму, которая является владельцем данной формы. При помощи этого свойства можно устанавливать связь между двумя формами. Например, форма элемента подчиненного справочника может иметь в качестве владельца форму элемента справочника владельца, из которой она была открыта.

Высота (Height)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит высоту окна формы (в логических единицах).

Заголовок (Caption)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст заголовка формы. По умолчанию содержит значение, заданное при редактировании формы в Конфигураторе.

См. также:

Форма, свойство Автозаголовок.

ЗакрыватьПриВыборе

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак того, что форму необходимо закрывать после осуществления выбора. Если свойство имеет значение Ложь, можно использовать форму для выбора нескольких позиций или элементов. По умолчанию свойство имеет значение Истина.

См.также:

Форма, метод ОповеститьОВыборе.

Форма, событие ОбработкаВыбора.

ЗакрыватьПриЗакрытииВладельца (CloseOnOwnerClose)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак того, что форма должна закрываться при закрытии формы-владельца.

См. также:

Форма, свойство ВладелецФормы.

ИзменениеРазмера (SizeChange)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ИзменениеРазмераОкна. Содержит признак разрешения/запрещения изменения размеров окна формы.

ИмяСохраненияПоложенияОкна (WindowOptionsName)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя для сохранения размеров и положения окна данной формы. Параметры окна, настроенные и сохраненные с данным именем, впоследствии восстанавливаются при следующем показе формы.

КлючУникальности (UnequalKey)

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Ключ уникальности формы, используемый для идентификации и поиска открытых форм. Может быть автоматически назначен, если задан соответствующий параметр при получении формы.

МодальныйРежим (ModalMode)

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит признак того, что форма открыта в модальном режиме.

См. также:

Форма, метод ОткрытьМодально.

Модифицированность (Modify)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Признак изменения (модифицированности) данных в форме. Модифицированность отображается символом (*) в заголовке окна формы.

НачальноеЗначениеВыбора (InitialChoiceValue)

Использование:

Чтение и запись.

Описание:

Содержит начальное значение выбора, переданное в форму, открываемую для выбора или подбора значения из списка. При стандартном выборе значения в поле ввода или в ячейке табличного поля из связанной с ним формы выбора, в начальное значение выбора записывается значение поля. Если открытие формы выбора осуществляется из модуля, то начальное значение выбора необходимо устанавливать средствами языка до открытия формы выбора. Перед открытием формы (до события ПриОткрытии) система производит попытку позиционирования списка, связанного с основным реквизитом формы (если такой существует), на этом значении. Далее значение может быть обработано средствами языка в обработчике события ПриОткрытии.

Панель (Panel)

Использование:

Только чтение.

Описание:

Тип: Панель. Содержит главную панель формы.

ПоведениеКлавишиEnter

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ТипПоведенияКлавишиEnter. Определяет поведение при нажатии на клавишу Enter.

ПоложениеОкна (WindowLocation)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ВариантПоложенияОкна. Определяет положение окна в прикрепленном состоянии. Вариант прикрепления можно установить окну только в том случае, если он не был ранее сохранен в профиле.

РазрешитьСостояниеОбычное

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит разрешение/запрещение окну переключаться в обычное состояние.

РазрешитьСостояниеПрикрепленное

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит разрешение/запрещение окну переключаться в прикрепленное состояние.

РазрешитьСостояниеПрячущееся (EnableStateAutohide)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит разрешение/запрещение окну переключаться в прячущееся состояние.

РазрешитьСостояниеСвободное (EnableStateFloat)

Использование:

Чтение и запись.

Описание:

Тип. Булево. Содержит разрешение/запрещение окну переключаться в свободное состояние.

РежимВыбора (ChoiceMode)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак того, что форма находится в режиме выбора. Данный признак влияет на поведение при выборе элемента из главного списка формы, т.е. списка, связанного с ее основным реквизитом.

СостояниеОкна (WindowState)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ВариантСостоянияОкна. Определяет состояние окна формы. Данное состояние можно установить окну только в том случае, если состояние окна не было ранее сохранено в профиле.

Стиль (Style)

Использование:

Чтение и запись.

Описание:

Тип: Стиль. Содержит стиль отображения формы. Может иметь одно из значений системного набора значений КоллекцияСтилей или значение «автостиль».

ТекущийЭлемент (CurrentControl)

Использование:

Чтение и запись.

Описание:

Содержит текущий активный элемент формы.

Примечание:

Тип значения определяется типом элемента управления формы.

ТолькоПросмотр (Readonly)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак использования формы в режиме просмотра. В этом режиме недоступны для изменения элементы управления, связанные с реквизитами любого реквизита формы, а также элементы управления, для которых установлен признак ИзменяетДанные.

Ширина (Width)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит ширину окна формы (в логических единицах).

ЭлементыФормы (Controls)

Использование:

Только чтение.

Описание:

Тип: ЭлементыФормы. Используется для доступа к коллекции размещенных на форме элементов управления.

См. также:

ЭлементыФормы.

ЭтаФорма (ThisForm)

Использование:

Только чтение.

Описание:

Тип: Форма. Содержит данную форму. Может быть использовано в модуле формы для получения данной формы и передачи ее в качестве параметра в другие формы, глобальные процедуры и функции и т.д.


2-012 Форма. Методы

Методы

Активизировать (Activate)

Синтаксис:

Активизировать()

Описание:

Активизирует уже открытую форму.

Пример:

Если Форма.Открыта() Тогда
Форма.Активизировать() ;
КонецЕсли ;

ВводДоступен (IslnputAvailable)

Синтаксис:

ВводДоступен()

Возвращаемое значение:

Тип: Булево. Истина - ввод данных в форму возможен (форма активна). Ложь - форма не активна.

Описание:

Определяет, возможен ли ввод данных в форму. Может быть использован для того, чтобы определить, активизирована ли текущая форма.

Пример:

Если ВводДоступен() Тогда
Сообщить("Введите текст");
КонецЕсли;

ВыбратьИзМеню (ChooseFromMenu)

Синтаксис:

ВыбратьИзМеню(< Список значений> , <Элемент формы>)

Параметры:

<Список значений> Обязательный

Тип СписокЗначений. Список значений, содержащий значения, из которых будет осуществляться выбор.

<Элемент формы> Обязательный

Тип Элемент управления. Элемент формы, около которого будет открыто меню выбора. Для некоторых элементов (табличный документ, табличное поле) меню будет показано около активной области

Возвращаемое значение:

Тип ЭлементСпискаЗначений. Выбранный меню или Неопределено, если пользователь отказался от выбора.

Описание:

Позволяет выбор значение из меню. Набор значений для выбора задается списком значений. Меню будет расположено около переданного элемента формы или около его активной области.

Пример:

Список = Новый СписокЗначений;
Список.Добавить(Перечисления.ВидыДопРасходов.Доставка) ;
Список.Добавить(Перечисления.ВидыДопРасходов.Разгрузка) ;
// Перечисление "ВидыДопРасходов" содержит значения
"Транспорт",
// "Доставка", "Разгрузка". По смыслу
элемент "Транспорт" исключен
ВидДР = ВыбратьИзМеню(Список.ЭлементыФормы("КнопкаДР"));

ВыбратьИзСписка (ChooseFromList)

Синтаксис:

ВыбратьИзСписка(< Список значений> , <Элемент формы> , <Начальное значение> )

Параметры:

<Список значений> Обязательный

Тип СписокЗначений. Список значений, содержащий значения, из которых будет осуществляться выбор

<Элемент формы> Обязательный

Тип Элемент управления. Элемент формы, около которого будет открыт выпадающий список. Для некоторых элементов (табличный документ, табличное поле) выпадающий список будет показан около активной области.

<Начальное значение> Необязательный

Тип Число, ЭлементСпискаЗначений. Задает начальный элемент, который будет активным при открытии списка

Значение по умолчанию: Если параметр не указан, в списке не будет выбрано начальное значение.

Возвращаемое значение:

Тип: ЭлементСпискаЗначений. Выбранный элемент списка или Неопределено, если пользователь отказался от выбора.

Описание:

Позволяет выбрать значение из выпадающего списка. Набор значений для выбора задается списком значений. Выпадающий список будет расположен около переданного элемента формы или около его активной области.

Пример:

Список = Новый СписокЗначений;
Список Добавить(Перечисления ВидыДопРасходов.Доставка);
Список Добавить(Перечисления ВидыДопРасходов.Разгрузка);
// Перечисление "ВидыДопРасходов" содержит значения "Транспорт",
// "Доставка", "Разгрузка" По смыслу элемент "Транспорт" исключен
ВидДР = ВыбратьИзСписка(Список, ЭлементыФормы("ПолеВвода"), 1);

Закрыть (Close)

Синтаксис:

Закрыть(<Параметр закрытия>)

Параметры:

<Параметр закрытия> Необязательный

Параметр закрытия формы, открытой в модальном режиме. Эта команда будет возвращена как результат метода, открывающего форму модально.

Значение по умолчанию: Неопределено.

Описание:

Закрыть форму Если закрываемая форма была открыта в модальном режиме, то метод может передать команду закрытия методу, открывшему форму.

Пример:

Закрыть("ОК");

Обновить (Refresh)

Синтаксис:

Обновить()

Описание:

Обновляет данные, представленные в форме.

Пример:

Обновить();

ОповеститьОбАктивизацииОбъекта (NotifyActivateObject)

Синтаксис:

ОповеститьОбАктивизацииОбъекта(< Активный объект> )

Параметры:

<Активный объект> Обязательный

Тип. Ссылка на объект, либо текущая строка табличного поля. Активизированный объект.

Описание:

Оповещает формы, подчиненные данной форме об изменении активного объекта и передает ссылку на этот объект. Данное действие аналогично стандартному оповещению подчиненного справочника при изменении текущего элемента в списке справочника-владельца. Может применяться в случае, когда открытие подчиненной формы выполнено средствами языка.

Пример:

ОповеститьОбАктивизацииОбьекта(ТекущаяСтрока) ;

См. также:

Форма, событие ОбработкаАктивизацииОбъекта.

ОповеститьОВыборе (NotifyChoice)

Синтаксис:

ОповеститьОВыборе (< Значение выбора> )

Параметры:

<3начение выбора> Обязательный

Результат выбора.

Описание:

Посылает оповещение владельцу формы о выполнении выбора или подбора, передает ему выбранное значение и закрывает форму, если она открыта не в режиме множественного выбора. Данное действие аналогично выполнению выбора в форме, открытой для выбора в поле ввода или поле табличного поля. Может применяться в случае, когда открытие формы выбора или подбора выполнено средствами языка.

Пример:

ОповеститьОВыборе(ТекущаяСтрока);

См. также:

Форма, событие ОбработкаВыбора.

ОповеститьОЗаписиНовогоОбъекта (NotifyWriteNewObject)

Синтаксис:

ОповеститьОЗаписиНовогоОбъекта (< Объект>)

Параметры:

<Объект> Обязательный

Тип: Любая ссылка на объект ИБ. Добавленный объект.

Описание:

Оповещает владельца формы о записи нового объекта и передает ему ссылку на этот объект. Может быть использован, если добавление нового объекта при помощи подчиненной формы необходимо обработать в форме владельце.

Пример:

ОповеститьОЗаписиНовогоОбъекта (ДобавленнаяСтрока) ;

См. также:

Форма, событие ОбработкаЗаписиНовогоОбъекта.

ОтключитьОбработчикИзмененияДанных (DetachChangeDataHandler)

Синтаксис:

ОтключитьОбработчикИзмененияДанных(< Имя данных> )

Параметры:

<Имя данных> Обязательный

Тип: Строка. Имя данных (путь к данным), изменения которых отслеживаются обработчиком. Могут быть указаны данные, связанные с реквизитами формы, табличными частями, а также подчиненные данные - реквизиты этих объектов. Например, "Реквизит1.Наименование".

Параметр может содержать только один путь к данным, т.е. метод применяется для одного реквизита.

Описание:

Отключает процедуру-обработчик, ранее подключенную для вызова при изменении указанных данных в форме или подчиненных формах.

Пример:

ОтключитьОбработчикИзмененияДанных("ПолеВвода!");

См. также:

Форма, метод ПодключитьОбработчикИзмененияДанных.

ОтключитьОбработчикОжидания (DetachldleHandler)

Синтаксис:

ОтключитьОбработчикОжидания(< Имя процедуры>)

Параметры:

<Имя процедуры> Обязательный

Тип: Строка. Имя процедуры, которую необходимо исключить из обработки ожидания.

Описание:

Отключает ранее подключенную процедуру - обработчик ожидания.

Пример:

ОтключитьОбработчикОжидания("ПриОжидании") ;

См. также:

Форма, метод ПодключитьОбработчикОжидания.

Открыта (IsOpen)

Синтаксис:

Открыта()

Возвращаемое значение:

Тип: Булево.

Описание:

Определяет, открыта ли данная форма.

Пример:

Если Не Форма.Открыта() Тогда
Форма.Открыть();
КонецЕсли;

Открыть (Open)

Синтаксис:

Открыть()

Описание:

Открывает форму и делает ее окно активным.

Пример:

Форма = Справочники.Номенклатура.ПолучитьФормуСписка()
;
Форма.Открыть();

См. также:

Форма, метод ОткрытьМодально.

Форма, метод Закрыть.

ОткрытьМодально (DoModal)

Синтаксис:

ОткрытьМодально (< Таймаут>)

Параметры:

<Таймаут> Необязательный

Тип: Число. Время показа формы в секундах, по истечении которого форма будет закрыта с параметром закрытия Неопределено.

Значение по умолчанию: Если значение параметра не задано или равно 0, время показа не ограничено.

Возвращаемое значение:

Тип: Произвольный. Команда закрытия формы.

Описание:

Открывает форму в модальном режиме.

Пример:

ФормаСписка = Справочники.Объекты.ПолучитьФормуСписка();
ФормаСписка.ОткрытьМодально() ;

См. также:

Форма, метод Открыть. Форма, метод Закрыть.

ПодключитьОбработчикИзмененияДанных (AttachChangeDataHandler)

Синтаксис:

ПодключитьОбработчикИзмененияДанных(< Имя данных> , <Имя процедуры> , <Отслеживать подчиненные данные>)

Параметры:

<Имя данных> Обязательный

Тип: Строка. Имя данных (путь к данным), изменения которых необходимо отслеживать. Могут быть указаны данные, связанные с реквизитами формы, табличными частями, а также подчиненные данные - реквизиты этих объектов. Например, "Реквизит1.Наименование".

Параметр может содержать только один путь к данным, т.е. метод применяется для одного реквизита.

<Имя процедуры> Обязательный

Тип: Строка. Имя процедуры, подключаемой в качестве обработчика изменения данных. Процедура должна иметь один параметр, в который при вызове процедуры будет передана строка-путь к измененным данным, по структуре аналогичная параметру Имя данных.

<Отслеживать подчиненные данные> Необязательный

Тип: Булево. Признак того, что процедуру-обработчик нужно вызывать и при изменении данных, подчиненных заданным в параметре Имя данных, Например, при изменении их реквизитов.

Значение по умолчанию: Ложь.

Описание:

Подключает процедуру-обработчик, вызываемую при изменении указанных данных в форме или подчиненных формах.

Пример:

ПодключитьОбработчикИзмененияДанных("ПолеВвода1", "ПриИзменении");

См. также:

Форма, метод ОтключитьОбработчикИзмененияДанных.

ПодключитьОбработчикОжидания (AttachldleHandler)

Синтаксис:

ПодключитьОбработчикОжидания(< Имя процедуры> , <Интервал>)

Параметры:

<Имя процедуры> Обязательный

Тип: Строка. Имя процедуры, подключаемой в качестве обработчика ожидания.

<Интервал> Обязательный

Тип: Число. Интервал времени в секундах, по истечению которого должна вызываться процедура - обработчик ожидания.

Описание:

Подключает указанную процедуру в качестве обработчика ожидания. Процедура будет вызываться в период ожидания системы каждый раз по истечению указанного интервала времени.

Пример:

ПодключитьОбработчикОжидания("ПриОжидании", 1) ;

См. также:

Форма, метод ОтключитьОбработчикОжидания.

Глобальный контекст, метод ПодключитьОбработчикОжидания.

ПолучитьДействие (GetAction)

Синтаксис:

ПолучитьДействие(<Событие>)

Параметры:

<Событие> Обязательный

Тип: Строка. Имя события, для которого необходимо получить действие.

Возвращаемое значение:

Тип: Действие.

Описание:

Получает процедуру-обработчик (действие) указанного события формы.

Пример:

ТекущееДействиеПриЗакрытии = ПолучитьДействие("ПриЗакрытии");

См. также:

Действие.

УстановитьДействие (SetAction)

Синтаксис:

УстановитьДействие (<Событие> , <Действие>)

Параметры:

<Событие> Обязательный

Тип: Строка. Имя события, для которого устанавливается новое действие.

<Действие> Обязательный

Тип: Действие. Действие, которое будет выполнено при получении от формы указанного события

Описание:

Назначает новую процедуру-обработчик (действие) для указанного события формы.

Пример:

ДействиеПриЗакрытииФормы = Новый Действие("ПриЗакрытииФормы");
УстановитьДействие("ПриЗакрытии", ДействиеПриЗакрытииФормы);

См.также:

Форма, метод ПолучитьДействие, Действие.


2-023 Форма. События

События

ОбработкаАктивизацииОбъекта

Синтаксис:

ОбработкаАктивизацииОбъекта (< Активный объект> , <Источник>)

Параметры:

<Активный объект>

Объект, который был активизирован.

<Источник>

Форма - источник сообщения.

Описание:

Событие возникает при изменении активного объекта в одной из подчиненных форм или при вызове в одной из подчиненных форм метода ОповеститьОбАктивизацииОбъекта.

См. также:

Форма, метод ОповеститьОбАктивизацииОбъекта.

ОбработкаЗаписиНовогоОбъекта (ProcessWriteNewObject)

Синтаксис:

ОбработкаЗаписиНовогоОбъекта (<Объект> , <Источник>)

Параметры:

<Объект>

Добавленный в подчиненной форме объект.

<Источник>

Форма - источник события.

Описание:

Событие возникает при записи объекта в одной из подчиненных форм или при вызове в одной из подчиненных форм метода ОповеститьОЗаписиНовогоОбъекта.

См. также:

Форма, метод ОповеститьОЗаписиНовогоОбъекта.

ОбработкаОповещения (ProcessNotify)

Синтаксис:

ОбработкаОповещения(< Имя события> , <Параметр> , <Источник> )

Параметры:

<Имя события>

Тип: Строка. Имя события. Может быть использовано для идентификации сообщений.

<Параметр>

Параметр, переданный в сообщении.

<Источник>

Источник события, переданный в сообщении.

Описание:

Событие возникает при оповещении всех открытых форм методом глобального контекста Оповестить.

См. также:

Глобальный контекст, метод Оповестить.

ПередОткрытием (BeforeOpen)

Синтаксис:

ПередОткрытием(<Отказ>, <Стандартная обработка> )

Параметры:

<Отказ>

Тип: Булево. Отказ от открытия формы. Если в теле процедуры-обработчика установить данному параметру значение Истина, открытие формы выполнено не будет.

<Стандартная обработка>

Тип. Булево В данный параметр передается признак выполнения стандартной (системной) обработки события. Если в теле процедуры-обработчика установить данному параметру значение Ложь стандартная обработка события производиться не будет. Отказ от стандартной обработки не отменяет открытие.

Описание:

Событие возникает перед открытием формы, до показа ее пользователю. В обработчике события можно отказаться как от открытия формы, так и от стандартного действия при открытии.

ПриОткрытии (ОпОреп)

Синтаксис:

ПриОткрытии()

Описание:

Событие возникает при открытии формы, до показа окна пользователю.

Примечание:

В обработчике события отказаться от открытия формы нельзя.

ПриЗакрытии (OnClose)

Синтаксис:

ПриЗакрытии()

Описание:

Событие возникает до закрытия формы.

Примечание:

В обработчике события отказаться от закрытия формы нельзя.

Обработка Выбора (ProcessChoice)

Синтаксис:

ОбработкаВыбора(<Результат выбора> , <Источник выбора>)

Параметры:

<Результат выбора>

Тип: Произвольный. Результат выбора в подчиненной форме.

<Источник выбора>

Тип: Произвольный. Форма - источник события.

Описание:

Событие возникает при выборе объекта в одной из подчиненных форм или при вызове в одной из подчиненных форм метода ОповеститьОВыбореОбъекта.

См. также:

Форма, метод ОповеститьОВыборе.

ПриПовторномОткрытии (OnReopen)

Синтаксис:

ПриПовторномОткрытии()

Описание:

Событие возникает при повторном открытии формы. Повторное открытие возникает при вызове метода Открыть для уже открытой формы.

ПередЗакрытием (BeforeClose)

Синтаксис:

ПередЗакрытием {<Отказ>, <Стандартная обработка>)

Параметры:

<Отказ>

Отказ от закрытия формы. Если в теле процедуры-обработчика установить данному параметру значение Истина, закрытие формы выполнено не будет.

<Стандартная обработка>

В данный параметр передается признак выполнения стандартной (системной) обработки события. Если в теле процедуры-обработчика установить данному параметру значение Ложь стандартная обработка события производиться не будет. Отказ от стандартной обработки не отменяет закрытие.

Для форм, связанных с типами ДокументОбъект и СправочникОбъект стандартной обработкой является проверка модифицированности, задание вопроса о сохранении и сохранение объекта.

Описание:

Событие возникает перед закрытием формы. В обработчике события можно отказаться как от закрытия формы, так и от стандартной обработки при закрытии.

ПриОбновлении (OnRefresh)

Синтаксис:

ПриОбновлении( )

Описание:

Событие возникает при обновлении формы или при изменении данных формы.

ОбработкаВнешнегоСобытия (ProcessExtemalEvent)

Синтаксис:

ОбработкаВнешнегоСобытия (<Источник> , <Событие> , <Данные>)

Параметры:

<Источник>

Тип: Строка. Источник внешнего события.

<Событие>

Тип: Строка. Наименование события.

<Данные>

Тип: Строка. Данные события.

Описание:

Возникает при посылке внешним приложением сообщения, сформированного в специальном формате. Внешнее событие сначала обрабатывается всеми открытыми формами, имеющими обработчик этого события, а затем может быть обработано в процедуре глобального модуля с именем ОбработкаВнешнегоСобытия.

См. также:

Глобальный контекст, событие ОбработкаВнешнегоСобытия.

Глобальный контекст, метод 3агрузитьВнешнююКомпоненту.

Глобальный контекст, метод ПодключитьВнешнююКомпоненту.


2-038 Элементы формы

ЭлементыФормы (Controls)

Используется для доступа к элементам управления, расположенным на форме.

Данный объект является коллекцией значений. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы управления в форме. Возможно обращение к элементу управления посредством оператора [...]. В качестве аргумента передается индекс элемента в коллекции.

См. также:

Форма, свойство ЭлементыФормы.

Свойства

<Имя элемента управления>

Использование:

Только чтение.

Описание:

Набор свойств содержит элементы управления, размещенные на форме. Имена свойств совпадают с именами элементов управления.

Методы

Добавить (Add)

Синтаксис:

Добавить(<Тип>, <Имя>, <Видимость>, <Панель>)

Параметры:

<Тип> Обязательный

Тип: Тип. Тип добавляемого элемента управления.

<Имя> Обязательный

Тип: Строка. Имя создаваемого элемента управления.

<Видимость> Необязательный

Тип: Булево. Определяет, создавать новый элемент управления формы видимым или нет

Значение по умолчанию: Истина, т.е. по умолчанию элемент создается видимым.

<Панель> Необязательный

Тип: Панель. Определяет, какой именно панели формы принадлежит создаваемый элемент. Если не указан, создаваемый элемент будет принадлежать непосредственно форме.

Значение по умолчанию: Если параметр не указан, новый элемент управления будет принадлежать главной панели формы.

Описание:

Добавляет элемент управления на форму.

Пример:

ЭлементыФормы.Добавить(Тип("ПолеВвода"), "НовоеПолеВвода");

Индекс (IndexOf)

Синтаксис:

Индекс (<ЭлементФормы>)

Параметры:

<ЭлвментФормы> Обязательный

Тип:Элемент формы.

Возвращаемое значение:

Тип: Число. Индекс переданного элемента. Если элемент не принадлежит форме, возвращает -1

Описание:

Получает индекс переданного элемента формы в коллекции элементов формы.

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число.

Описание:

Позволяет получить количество размещенных на форме элементов управления.

Пример:

КолВоЭлементов = ЭлементыФормы.Количество();

Очистить (Clear)

Синтаксис:

Очистить()

Описание:

Удаляет все элементы управления с формы.

Удалить (Remove)

Синтаксис:

Удалить(<Номер элемента>)

Параметры:

<Номер элемента> Обязательный

Тип: Число. Порядковый номер элемента в коллекции элементов управления формы.

Описание:

Удаляет элемент управления с формы.

Расширение элементов управления расположенных в форме

Дополнительные свойства и методы элемента управления в форме. Эти свойства и методы появляются у любого элемента управления расположенного на форме.

Свойства

Данные (Data)

Использование:

Только чтение.

Описание:

Тип: Строка. Содержит имя связанной переменной. Для элементов управления, редактирующих данные, изменение значения в элементе управления автоматически влечет изменение значения связанной переменной. Для элементов управления, в которых не осуществляется редактирование, позволяет связать элемент управления и данные для удобства работы.

ИзменяетДанные (ModrfyData)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак того, что данный элемент управления будет менять данные. Рекомендуется использовать, например, для кнопок, при нажатии которых выполняется заполнение объекта или его модификация.

Имя (Name)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя элемента управления.

ИсточникДействий (ActtonSource)

Использование:

Чтение и запись.

Описание:

Содержит элемент управления, который является источником команд для данного элемента управления. Источником также может являться форма. Если значение свойства неопределенное, то источниками данных будет являться форма и все элементы управления, которые могут выступать в качестве источника действий.

Примечание:

Свойство имеет смысл только для элементов управления, способных принимать источники действий. Например, КоманднаяПанель.

КнопкаПоУмолчанию (DefaultButton)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак, является ли кнопка "кнопкой по умолчанию". Нажатие такой кнопки отрабатывает при нажатии сочетания клавиш Ctrl+Enter.

Примечание:

Имеет смысл только для элементов управления типа Кнопка.

КонтекстноеМеню (ContextMenu)

Использование:

Чтение и запись.

Описание:

Свойство определяет, какое контекстное меню будет показано у элемента управления. Значением свойства может являться элемент управления типа КоманднаяПанель или одна из его кнопок-подменю. Если значением является неопределенное значение, то будет открыто контекстное меню, которое предоставляет сам элемент управления (автоматический режим).

ПервыйВГруппе (FirstlnGroup)

Использование:

Чтение и запись.

Описание:

Тип: Булево Содержит признак начала группы элементов управления данным элементом управления. Установка данного свойства определяет элемент управления как первый в группе элементов управления в порядке обхода формы. Группировка элементов управления в форме влияет на обход элементов управления с помощью клавиш управления курсором. С помощью этих клавиш обход осуществляется только в пределах группы. Это справедливо для любых типов элементов управления, которые не отрабатывают самостоятельно на нажатие клавиш управления курсором.

Группа может состоять из элементов управления любого типа, в том числе и из нескольких типов. Это справедливо для всех типов элементов управления, кроме элементов типа Переключатель, которые образуют группы только между однотипными элементами управления (переключателями).

ПропускатьПриВводе (SkipWhenlnput)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак, при установке которого, элемент управления будет пропускаться при обходе элементов управления по клавише Enter. При обычном обходе (по клавише Tab) элемент управления пропущен не будет.

ТипЗначения (ValueType)

Использование:

Чтение и запись.

Описание:

Тип: ОписаниеТипов. Содержит объект, описывающий допустимые типы значений для элемента управления.

Методы

ПолучитьДействие (GetAction)

Синтаксис:

ПолучитьДействие (<Событие>)

Параметры:

<Событие> Обязательный

Тип: Строка. Имя события.

Возвращаемое значение:

Тип: Действие.

Описание:

Позволяет определить действие, которое будет исполняться при возникновении указанного события.

УстановитьДействие (SetAction)

Синтаксис:

УстановитьДействие (<Событие>, <Действие>)

Параметры:

<Событие> Обязательный

Тип: Строка. Имя события.

<Действие> Обязательный

Тип: Действие. Устанавливаемое действие.

Описание:

Метод позволяет назначить действие, которое будет исполняться при возникновении указанного события.

События

<Имя события>

Синтаксис:

<Имя события>(<Элемент>, <...>)

Параметры:

<Элемент>

Тип: тип параметра соответствует типу элемента управления, который инициировал событие. В данный параметр передается элемент управления, инициировавший событие.

<. .. >

Остальные параметры события элементов управления указываются после параметра <Элемент>.

Описание:

У всех событий элементов управления расположенных в форме присутствует общий первый параметр.


2-038 Элементы управления

Элементы управления

Элементы управления представляют собой отдельную группу объектов, предназначенных для ввода и представления информации в диалогах. Они могут располагаться на форме, использоваться для редактирования ячеек табличного поля, табличного документа.

Элементы управления могут быть связаны с различными типами данных. При этом многие действия, связанные с обработкой событий элементов управления, выполняются механизмами 1С:Предприятия автоматически: например, открытие формы списка справочника при нажатии кнопки выбора у поля ввода и последующая подстановка выбранного элемента в него может осуществляться без использования каких-либо команд встроенного языка. Однако всегда есть возможность изменить стандартную обработку события, либо добавить собственную, используя процедуры-обработчики.

В зависимости от типа данных, связанных с элементом управления, он имеет различный набор свойств, методов, событий. В данном разделе описываются общие свойства, методы, события элементов управления- дополнительные свойства, методы, события, зависящие от типа данных, и называемые расширениями элементов управления, приведены в описании соответствующих объектов.

Диаграмма

Диаграмма позволяет размещать в таблицах и формах системы 1С:Предприятие диаграммы и графики различного вида. Диаграмма представляет собой определенную фигуру или фигуры, которые строятся на основании матрицы данных М х N. Данные, организованные в виде матрицы, удобно представить как значения, полученные в результате замеров некоторой величины в определенных точках, причем замеры производились сериями. Серии диаграммы могут быть представлены строками матрицы данных, а значения в точках - столбцами (или наоборот).

Например, в диаграмме, отражающей объемы продаж различной номенклатуры по месяцам удобно представить в качестве точек месяцы, в качестве серий - виды номенклатуры.

Точки диаграммы отмечаются на координатных осях специальными маркерами. Значения в сериях объединяются общей линией либо областью одного цвета. Отдельная область, называемая легендой диаграммы, содержит список меток, соответствующих сериям.

Для большей наглядности количество выводимых серий диаграммы можно ограничить, используя одно из правил, по которому самые маленькие серии будут объединяться в общую сводную серию.

Диаграмма может быть вставлена в форму либо в табличный документ. Для вставленной в табличный документ диаграммы можно задать область табличного документа, содержащую необходимые данные (свойство ИсточникДанных).

Следует различать два режима работы диаграммы - связь с источником данных посредством свойства ИсточникДанных и наполнение диаграммы данными при помощи метода УстановитьЗначение. Данные режимы не могут комбинироваться.

Пример: в виде диаграммы можно представить в графической форме результаты отчета об объемах продаж за период в разрезе номенклатуры и покупателей.

Диаграмма (Chart)

Используется для доступа к свойствам, методам и событиям диаграммы в целом.

Свойства

АвтоРаздвижениеСерий (AutoSeriesSeparating)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление АвтоРаздвижениеСерий. Определяет режим выдвижения секторов круговых диаграмм.

Примечание:

Имеет смысл для круговых диаграмм.

АвтоУстановкаИменСерий (AutoSeriesLabels)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак автоматической генерации имен для новых серий диаграммы, состоящих из слова "Серия" и номера серии без пробела.

АвтоУстановкаИменТочек

Использование:

Чтение и запись.

Описание:

Тип Булево. Содержит признак автоматической генерации имен для новых точек диаграммы, состоящих из слова "Точка" и номера точки без пробела.

АктивнаяСерия (ActiveSeries)

Использование:

Чтение и запись.

Описание:

Тип: Строка, СерияДиаграммы. Содержит серию, для которой производится построение биржевой диаграммы.

Примечание:

Имеет смысл для биржевых диаграмм.

См. также:

ТипДиаграммы.

АктивнаяТочка (ActivePoint)

Использование:

Чтение и запись.

Описание:

Тип- Строка, ТочкаДиаграммы. Содержит точку, для которой производится построение круговой диаграммы.

Примечание:

Имеет смысл для круговых диаграмм.

БазовоеЗначение (BaseValue)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит начальное значение координат (ординаты). Часто бывает, что изменения параметра, отображаемого в диаграмме, несоизмеримо малы по сравнению с его минимальным значением. В подобных случаях для повышения наглядности можно установить в качестве базового минимальное или близкое к нему значение, отводя области изменения параметра большую область построения диаграммы

ВидПодписей (LabelType)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ВидПодписейКДиаграмме. Определяет наличие и вид подписей к областям круговой диаграммы.

Примечание:

Имеет смысл для круговых диаграмм.

Градиент (Gradient)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак градиентной закраски плоских диаграмм.

Примечание:

Используется только для плоских гистограмм.

ИсточникДанных (DataSource)

Использование:

Только запись.

Описание:

Тип: ТаблицаЗначений, ОбластьЯчеекТабличногоДокумента. Содержит источник данных диаграммы. При помощи этого свойства можно наполнять диаграмму данными, содержащимися в области табличного документа или в таблице значений.

Данные в источнике должны располагаться следующим образом:

При расположении серий в столбцах диаграммы (свойство СерииВСтроках равно Ложь):

• Если источником является таблица значений, ее первая колонка должна содержать имена точек диаграммы. Имена серий диаграммы берутся из имен колонок (имя первой колонки игнорируется).

• Если источником является область табличного документа, имена серий берутся из верхней строки области. Имена точек берутся из левого столбца области. Содержимое левой верхней ячейки игнорируется.

При расположении серий в строках диаграммы (свойство СерииВСтроках равно Истина):

• Если источником является таблица значений, ее первая колонка должна содержать имена серий диаграммы. Имена точек диаграммы берутся из имен колонок (имя первой колонки игнорируется).

• Если источником является область табличного документа, имена точек берутся из верхней строки области. Имена серий берутся из левого столбца области. Содержимое левой верхней ячейки игнорируется.

Примечание:

Обновление диаграммы при изменении данных выполняется автоматически.

КоличествоСерий (SeriesCount)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит количество серий диаграммы.

Важно! Нельзя изменять данное значение, когда диаграмма находится в режиме связи с источником данных.

См. также:

Диаграмма, свойство КоличествоТочек. СерияДиаграммы.

КоличествоТочек (PointsCount)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит количество точек диаграммы.

Важно! Нельзя изменять данное значение, когда диаграмма находится в режиме связи с источником данных.

См. также:

Диаграмма, свойство КоличествоСерий.

ТочкаДиаграммы.

МаксимумСерий (MaxSeries)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление МаксимумСерий. Определяет режим ограничения максимального количества отображаемых серий диаграммы.

См. также:

Диаграмма, свойство МаксимумСерийКоличество.
Диаграмма, свойство МаксимумСерийПроцент.

МаксимумСерийКоличество (MaxSeriesCount)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит максимальное количество выводимых в диаграмму серий. Используется, когда свойство МаксимумСерий имеет значение Ограниченно. Если общее число серий превышает максимальное, будут показаны только те серии, которые выбираются по следующему алгоритму: по каждой серии ищется максимальное точечное значение (по модулю), эти значения сортируются и из них выбираются для показа МаксимумСерийКоличество - 1 серий. Значения остальных серий суммируются и выводятся в серии "Сводная".

МаксимумСерийПроцент (MaxSeriesPercent)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит процент, ограничивающий вывод отдельных серий в диаграмму. Используется, когда свойство МаксимумСерий имеет значение Процент. Секции для показа отбираются по следующему алгоритму: выбирается абсолютный максимум по всем точкам всех серий, вычисляется пороговое значение отбора умножением выбранного максимума на МаксимумСерийПроцент/100. Если в серии есть значения, превышающие этот порог, эта серия будет показана. Значения непоказанных серий суммируются и выводятся в серии "Сводная".


2-47 Диаграмма. Свойства (2)

ОбластьЗаголовка (TitleArea)

Использование:

Только чтение.

Описание:

Тип: ОбластьЗаголовка. Содержит область заголовка диаграммы.

См.также:

ОбластьЗаголовка.

ОбластьЛегенды (LegendArea)

Использование:

Только чтение.

Описание:

Тип: ОбластьЛегенды. Содержит область легенды диаграммы.

См. также:

ОбластьЛегенды.

ОбластьПостроения (PlotArea)

Использование:

Только чтение.

Описание:

Тип: ОбластьПостроения. Содержит область построения диаграммы.

См. также:

ОбластьПостроения.

Окантовка (Outline)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак окантовки черным цветом областей на диаграмме. Применяется в диаграммах, имеющих закрашиваемые области. Вне зависимости от цвета областей (серий) окантовка наносится тонкой черной линией.

Примечание:

Имеет смысл для диаграмм с закрашиваемыми областями.

Ориентация (Orientation)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ОриентацияДиаграммы. Определяет ориентацию осей координатной системы для изометрических диаграмм.

Примечание:

Имеет смысл для изометрических диаграмм.

ОтображатьЗаголовок (ShowTitle)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак отображения области заголовка диаграммы.

См. также:

Диаграмма, свойство ОбластьЗаголовка.

ОтображатьЛегенду (ShowLegend)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак отображения области легенды диаграммы.

См. также:

Диаграмма, свойсгво ОбластьЛегенды.

Прозрачныйфон (Transparent)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак прозрачности фона.

Рамка (Border)

Использование:

Чтение и запись.

Описание:

Тип: Рамка. Содержит стиль рамки вокруг всей диаграммы.

РежимПробелов (SpaceMode)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление РежимПробеловДиаграммы. Определяет режим вывода пробелов между столбцами (областями).

Примечание:

Имеет смысл для диаграмм, имеющих столбцы или области.

Свет (Light)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак моделирования эффекта освещенности объемных диаграмм.

Примечание:

Имеет смысл для объемных диаграмм.

СводнаяСерия (ExtSeries)

Использование:

Только чтение.

Описание:

Тип: СерияДиаграммы. Содержит сводную серию диаграммы. Это серия формируется автоматически из серий, объединяемых при использовании ограничения на максимальное количество серий диаграммы.

См. также:

Диаграмма, свойство МаксимумСерий.
Диаграмма, свойство МаксимумСерийКоличество.
Диаграмма, свойство МаксимумСерийПроцент.

Серии (Series)

Использование:

Только чтение.

Описание:

Тип: СерииДиаграммы. Содержит коллекцию серий диаграммы.

См. также:

СерииДиаграммы.

СерииВСтроках (SerieslnRows)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак размещения серий диаграммы в строках.

Примечание:

Используется только при работе диаграммы с источником данных.

ТипДиаграммы (ChartType)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ТипДиаграммы. Определяет тип диаграммы.

См. также:

ТипДиаграммы.

Точки (Points)

Использование:

Только чтение.

Описание:

Тип: ТочкиДиаграммы. Содержит коллекцию точек диаграммы.

См. также:

ТочкиДиаграммы.

ЦветРамки (BorderColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет рамки вокруг всей диаграммы.

Примечание:

Не используется, если рамка имеет стиль Выпуклая или Вдавленная - в этом случае рамка рисуется притененным цветом от цвета фона.

ЦветФона (BackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона диаграммы.

Методы

Обновление (RedrawFlag)

Синтаксис:

Обновление(< Флаг>)

Параметры:

<Флаг> Обязательный

Тип: Булево. Истина - Разрешить обновление. Ложь - запретить обновление.

Описание:

Устанавливает признак обновления (пересчета и отрисовки) диаграммы. Запрет обновления диаграммы рекомендуется на время наполнения данными в целях ускорения работы системы. Если обновление разрешено, пересчет и отрисовка производятся автоматически.

Пример:

Диаграмма.Обновление(Ложь);

Очистить (Clear)

Синтаксис:

Очистить()

Описание:

Очищает диаграмму: удаляет все значения, обнуляет количество точек и серий, удаляет все имена меток.

Пример:

Диаграмма.Очистить();

ПолучитьЗначение (GetValue)

Синтаксис:

ПолучитьЗначение(< Точка>, <Серия>)

Параметры:

<Точка> Обязательный

Тип: Число, ТочкаДиаграммы. Индекс точки либо значение сама точка диаграммы.

<Серия> Обязательный

Тип: Число, СерияДиаграммы. Индекс серии либо сама серия диаграммы.

Возвращаемое значение:

Тип: ЗначениеДиаграммы. Значение диаграммы в заданной точке и серии.

Описание:

Получает значение из заданной точки и серии диаграммы.

Пример:

ОбъемПродаж = Диаграмма.ПолучитьЗначение(Точка, Серия).Значение;

См. также:

Диаграмма, метод УстановитьЗначение.

УстановитьЗначение (SetValue)

Синтаксис:

УстановитьЗначение(< Точка> , <Серия>. <3начение>, <Расшифровка>)

Параметры:

<Точка> Обязательный

Тип: Число, ТочкаДиаграммы. Индекс точки либо сама точка диаграммы.

<Серия> Обязательный

Тип: Число, СерияДиаграммы. Индекс серии либо сама серия диаграммы.

<3начение> Обязательный

Тип: Произвольный. Устанавливаемое значение. При построении диаграммы значения с типами, отличными от Число, будут интерпретироваться как числа.

<Расшифровка> Необязательный

Тип: Произвольный. Значение, используемое при расшифровке диаграммы.

Описание:

Устанавливает значение в заданной точке и серии диаграммы. Дополнительно может быть установлена расшифровка значения.

Пример:

Диаграмма.УстановитьЗначение(Точка, Серия, ОбъемПродаж);

См. также:

Диаграмма, метод ПолучитьЗначение.

События

Выбор (Select)

Синтаксис:

Выбор(<Значение диаграммы> , < Стандартная обработка>)

Параметры:

<3начение диаграммы>

Тип: ЗначениеДиаграммы.

<Стандартная обработка>

Тип:Булево.

Описание:

Возникает при двойном щелчке мыши (нажатии клавиши Enter) на диаграмме.

Примечание:

Если диаграмма расположена в табличном документе, то используется процедура-обработчик табличного документа.

ОбработкаРасшифровки (ProcessDetaHs)

Синтаксис:

ОбработкаРасшифровки(<Расшифровка>)

Параметры:

<Расшифровка>

Тип: Произвольный. Расшифровка элемента диаграммы.

Описание:

Возникает при двойном щелчке мыши или нажатии Enter на значении, точке, серии диаграммы, для которых установлено значение расшифровке.

Примечание:

Если диаграмма расположена в поле табличного документа, то используется процедура-обработчик поля табличного документа.

См. также:

ТочкаДиаграммы, свойство Расшифровка.

СерияДиаграммы, свойство Расшифровка. ЗначениеДиаграммы, свойство Расшифровка.


2-061 Диаграмма. Значения, серии, точки

ЗначениеДиаграммы (ChartValue)

Используется для доступа к свойствам значения диаграммы. Объект содержит собственно значение диаграммы в определенной точке и серии, а также значение расшифровки в точке и серии

См.также:

Диаграмма, метод ПолучитьЗначение.

Свойства

Значение (Value)

Использование:

Только чтение.

Описание:

Тип: Произвольный. Содержит собственно значение диаграммы.

Примечание:

При построении диаграммы значения с типами, отличными от Число, будут интерпретироваться как числа.

См. также:

Диаграмма, метод УстановитьЗначение.
Диаграмма, метод ПолучитьЗначение.

Расшифровка (Details)

Использование:

Только чтение.

Описание:

Тип: Произвольный. Содержит расшифровку значения диаграммы.

Серия (Series)

Использование:

Только чтение.

Описание:

Тип: Число. Индекс серии значения диаграммы.

Точка (Point)

Использование:

Только чтение.

Описание:

Тип: Число. Индекс точки значения диаграммы.

СерииДиаграммы (ChartSeriesColfection)

Представляет собой коллекцию серий диаграммы. В данную коллекцию не входит сводная серия, образующаяся при ограничении серий диаграммы.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа СерияДиаграммы. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции.

См. также:

Диаграмма, свойство Серии.

Методы

Добавить (Add)

Синтаксис:

Добавить(<Текст>)

Параметры:

<Текст> Обязательный

Тип: Строка. Название серии.

Возвращаемое значение:

Тип: СерияДиаграммы. Добавленная серия.

Описание:

Добавляет новую серию в конец коллекции серий диаграммы.

Пример:

Диаграмма.Очистить();
Для Сч = 1 По 4 Цикл
НоваяСерия = Диаграмма.Серии.Добавить("Серия К" + Сч);
КонецЦикла;

Индекс (IndexOf)

Синтаксис:

Индекс(<Серия>)

Параметры:

<Серия> Обязательный

Тип: СерияДиаграммы. Серия диаграммы.

Возвращаемое значение:

Тип: Число. Индекс переданного элемента в коллекции. Если элемент не принадлежит данной коллекции, возвращает -1.

Описание:

Получает индекс указанной серии диаграммы.

Пример:

ИндексСерии = Диаграмма.Серии.Индекс(ВыбраннаяСерия);

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число.

Описание:

Позволяет получить количество серий диаграммы.

Примечание:

Количество серий диаграммы.

Пример:

СерииДиаграммы = ДиаграммаСерии;
КоличествоСерий = СерииДиаграммы.Количество();
Сообщить("Диаграмма содержит " + КоличествоСерий + " серий");

СерияДиаграммы (ChartSeries)

Используется для доступа к свойствам и методам серии диаграммы. Позволяет установить название серии, цвет, стиль линий и задать расшифровку.

Свойства

Линия (Line)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ТипЛинииДиаграммы. Содержит стиль линий графика для данной серии диаграммы.

Примечание:

Имеет смысл для линейных графиков.

Маркер (Marker)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ТипМаркераДиаграммы. Содержит тип маркера, которым отмечаются значения в точках на графике.

Примечание:

Имеет смысл для диаграмм вида "График".

Раздвигать (Separate)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак выдвижения сектора круговой диаграммы.

Примечание:

Используется для круговых диаграмм в случае, если не установлено автоматическое раздвижение, т.е. свойство диаграммы АвтораздвижениеСерий равно Ложь.

См. также:

Диаграмма, свойство АвтоРаздэижениеСерий.

Расшифровка (Details)

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Содержит расшифровку серии диаграммы.

СводнаяСерия (ExtSeries)

Использование:

Только чтение.

Описание:

Тип: Вулево. Содержит признак того, что данная серия является сводной.

См. также:

Диаграмма, свойство СводнаяСерия.

Текст (Text)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит название серии диаграммы.

Цвет (Color)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет серии диаграммы.

ТочкиДиаграммы (ChartPointsCollection)

Представляет собой коллекцию точек диаграммы.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа ТочкаДиаграммы. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции. Возможно обращение к элементу коллекции посредством оператора [...]. В качестве apгумента передается индекс элемента.

Методы

Добавить (Add)

Синтаксис:

Добавить(< Текст>)

Параметры:

<Текст> Необязательный

Тип: Строка. Название точки.

Описание:

Добавляет точку в конец коллекции точек диаграммы.

Пример:

Диаграмма.Точки.Добавить("Март");

Индекс (IndexOf)

Синтаксис:

Индекс(< Точка>)

Параметры:

<Точка> Обязательный

Тип: ТочкаДиаграммы. Точка диаграммы.

Возвращаемое значение:

Тип: Число. Индекс переданного элемента в коллекции. Если элемент не принадлежит данной коллекции, возвращает -1.

Описание:

Получает индекс указанной точки диаграммы.

Пример:

ИндексТочки = Диаграмма.Точки.Индекс(ВыбраннаяТочка);

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество точек диаграммы.

Описание:

Позволяет получить количество точек диаграммы.

Пример:

ВсегоТочек = Диаграмма.Точки.Количество();

ТочкаДиаграммы (ChartPoint)

Используется для доступа к свойствам точки диаграммы. Позволяет установить название и расшифровку точки.

Свойства

Расшифровка (Details)

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Содержит расшифровку точки диаграммы.

Текст (Text)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит название точки диаграммы.


2-070 Области диаграммы

ОбластьЗаголовка (TitleArea)

Используется для доступа к области заголовка диаграммы. В области заголовка может содержаться название диаграммы.

См. также:

Диаграмма, свойство ОбластьЗаголовка.

Свойства

ПрозрачныйФон (Transparent)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак прозрачности фона.

Рамка (Border)

Использование:

Чтение и запись.

Описание:

Тип: Рамка. Содержит тип рамки вокруг области заголовка диаграммы.

Текст (Text)

Использование:

Чтение и запись.

Описание:

Тип: Строка- Содержит текст, выводимый в области заголовка диаграммы.

ЦветРамки (BorderColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет рамки вокруг области заголовка.

Примечание:

Не используется, если рамка имеет стиль Выпуклая или Вдавленная - в этом случае рамка рисуется притененным цветом от цвета фона.

ЦветТекста (TextCotor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста в области заголовка.

ЦветФона (BackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона диаграммы.

Шрифт (Font)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Содержит шрифт текста области заголовка.

ОбластьЛегенды (LegendArea)

Используется для доступа к области легенды диаграммы. Легенда диаграммы предназначена для описания серий диаграммы.

См. также:

Диаграмма, свойство ОбластьЛегенды.

Свойства

ПрозрачныйФон (Transparent)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак прозрачности фона.

Рамка (Border)

Использование:

Чтение и запись.

Описание:

Тип: Рамка. Содержит параметры рамки вокруг области легенды диаграммы.

ЦветРамки (BorderColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет рамки вокруг области легенды.

Примечание:

Не используется, если рамка имеет стиль Выпуклая или Вдавленная - в этом случае рамка рисуется притененным цветом от цвета фона.

ЦветТекста (TextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста в области легенды.

ЦветФона (BackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона области легенды диаграммы.

Шрифт (Font)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Содержит шрифт текста области легенды.

ОбластьПостроения (PlotArea)

Используется для доступа к области построения диаграммы. В этой области выводятся координатное пространство и фигура диаграммы.

См. также:

Диаграмма, свойство ОбластьПостроения.

Свойства

ЛинииШкалы (ScaleUnes)

Использование:

Чтение и запись.

Описание:

Тип: Линия. Содержит линии шкалы.

Примечание:

Имеет смысл для всех диаграмм, кроме круговых.

ОтображатьШкалу (ShowScale)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак отображения шкалы (координатных линий и делений).

Примечание:

Имеет смысл для всех диаграмм, кроме круговых.

ПрозрачныйФон (Transparent)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак прозрачности фона.

Рамка (Border)

Использование:

Чтение и запись.

Описание:

Тип: Рамка. Содержит тип рамки вокруг области построения диаграммы.

ЦветРамки (BorderCotor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет рамки вокруг области построения.

Примечание:

Не используется, если рамка имеет стиль Выпуклая или Вдавленная - в этом случае рамка рисуется притененным цветом от цвета фона.

ЦветТекста (TextColor)

Использование:

Чтение и запись

Описание:

Тип: Цвет. Содержит цвет текста в области построения.

ЦветФона (BackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона области построения диаграммы.

ЦветШкалы (ScaleColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет шкалы.

Примечание:

Имеет смысл для всех диаграмм, кроме круговых

Шрифт (Font)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Содержит шрифт текста области построения


2-77 Индикатор

Индикатор (Progress Bar)

Индикатор предназначен для представления текущего состояния некоторого изменяющегося числового значения. Например, может применяться для наглядного представления выполнения процесса перебора строк таблицы значений или элементов массива. Для индикатора не предусмотрено формирование каких-либо событий, он также не может изменять связанные с ним данные.

Свойства

Доступность (Enable)

Использование:

Чтение и запись.

Описание:

Тип Булево. Содержит признак доступности индикатора

Значение (Value)

Использование:

Чтение и запись.

Описание:

Содержит значение в элементе управления.

МаксимальноеЗначение (MaxValue)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит максимальное значение диапазона изменения. Если значение больше или равно максимальному, то оно будет отображаться "полным" индикатором (100%).

МинимальноеЗначение (MinValue)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит минимальное значение диапазона изменения. Если значение меньше или равно минимальному, то оно будет отображаться "пустым" индикатором (0%).

Ориентация (Orientation)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление Ориентация. Содержит ориентацию индикатора.

Подсказка (ToolTipText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст всплывающей подсказки, которая появляется при наведении курсора.

ПоказыватьПроценты (ShowPercent)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак того, что на индикаторе либо рядом с ним следует выводить процентное представление индикатора (0% - минимальный, 100% - максимальный размер полосы индикатора).

Примечание:

В режиме заполнения Плавный проценты показываются в центре, в режиме Прерывистый и ПрерывистыйНаклонный-слева от индикатора.

Рамка (Border)

Использование:

Чтение и запись.

Описание:

Тип: Рамка. Содержит параметры рамки вокруг индикатора.

СтильОтображения (Style)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление РежимСглаживанияИндикатора. Определяет стиль заполнения индикатора.

ЦветРамки (BorderColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет рамки вокруг индикатора.

Примечание:

Не используется, если рамка имеет стиль Выпуклая или Вдавленная - в этом случае рамка рисуется притененным цветом от цвета фона.

ЦветФона (BackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона индикатора.

Шаг(Step)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит число (количество процентов), на которое изменится значение индикатора при изменении значения на один шаг. Определяет порог чувствительности индикатора.

Шрифт (Font)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Содержит шрифт текста индикатора.


2-81 Поле календаря

ПолеКалендаря (CalendarBox)

Календарь предназначен для ввода и отображения даты.

Свойства

Доступность (Enable)

Использование:

Чтение и запись.

Описание:

Тип: Булево.

Значение (Value)

Использование:

Чтение и запись.

Описание:

Тип: Дата. Содержит значение, введенное в элементе управления.

Подсказка (ToolTipText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст всплывающей подсказки, которая появляется при наведении курсора.

Рамка (Border)

Использование:

Чтение и запись.

Описание:

Тип: Рамка. Содержит параметры рамки вокруг календаря.

ЦветВыходныхДней (HolidayColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет, которым будут отмечаться выходные дни.

ЦветРамки (BorderColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет рамки вокруг календаря.

Примечание:

Не используется, если рамка имеет стиль Выпуклая или Вдавленная - в этом случае рамка рисуется притененным цветом от цвета фона.

ЦветТекстаКнопки (ButtonTextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста выбранной даты, заголовка календаря, кнопок перехода на предыдущий и последующий месяц и год, выпадающего списка для выбора стандартных дат.

ЦветТекстаПоля (FieldTextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста поля календаря.

ЦветФонаКнопки (ButtonBackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона выбранной даты, заголовка календаря, кнопок перехода на предыдущий и последующий месяц и год, выпадающего списка для выбора стандартных дат.

ЦветФонаПоля (FieldBackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона поля календаря.

Шрифт (Font)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Содержит шрифт текста в календаре.

События

Выбор (Select)

Синтаксис:

Выбор(<Выбранная дата>)

Параметры:

<Вы6ранная дата>

Тип Дата. Выбранная дата.

Описание:

Возникает при нажатии на число месяца.

ПриИзменении (OnChange)

Синтаксис:

ПриИзменении()

Описание:

Возникает при смене даты.


2-085 Кнопка

Кнопка (Button)

Кнопка предназначена для запуска выполнения различных действий, например, формирования отчета или записи элемента справочника. Одна из кнопок формы может быть назначена кнопкой по умолчанию.

Свойства

ВертикальноеПоложение (VerticalAlignment)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ВертикальноеПоложение. Определяет способ вертикального расположения текста на кнопке.

Примечание:

Если в кнопке вводятся и текст, и картинка, то вне зависимости от значения свойства, картинка и текст рисуются выровненными по центру вертикально.

ГоризонтальноеПоложение (HorizontalAlignment)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ГоризонтальноеПоложение. Определяет способ горизонтального расположения текста на кнопке.

Доступность (Enable)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак доступности кнопки.

Заголовок (Caption)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст на кнопке.

Примечание:

Если текст не умещается по ширине, видимый текст будет заканчиваться троеточием. Если многострочный текст не умещается по высоте, то он будет прижат к верхней границе не зависимо от установленного способа выравнивания по вертикали, не уместившиеся строки не будут показаны.

Картинка (Picture)

Использование:

Чтение и запись.

Описание:

Тип: Картинка. Содержит картинку, отображаемую на кнопке.

Примечание:

Оптимальный размер картинки определяется размером элемента управления и размером его шрифта.

МногострочныйРежим (MultiLine)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак многострочного режима отображения текста кнопки.

Примечание:

В многострочном режиме длинный тест на кнопке (больше ширины кнопки), разделенный пробелами или переводами строк, будет переноситься на следующие строки.

Подсказка (ToolTipText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст всплывающей подсказки, которая появляется при наведении курсора.

ПоложениеКартинки (PictureLocation)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ПоложениеКартинкиКнопки. Определяет положение картинки на кнопке относительно текста.

РазмерКартинки (PictureSizeMode)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление РазмерКартинки. Определяет режим приспособления оригинальных размеров картинки к размеру области, в которой картинка отображается на кнопке. Размер области, отведенной под картинку, зависит от размера кнопки, наличия текста и значения данного свойства.

СочетаниеКлавиш (Shortcut)

Использование:

Чтение и запись.

Описание:

Тип: СочетаниеКлавиш. Содержит сочетание клавиш, при нажатии на которые произойдет выполнение действия, связанного с кнопкой.

ЦветТекстаКнопки (ButtonTextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста кнопки.

ЦветФонаКнопки (ButtonBackCotor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона кнопки.

Шрифт (Font)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Содержит шрифт текста кнопки.

События

Нажатие (Click)

Синтаксис:

Нажатие()

Описание:

Возникает при нажатии на кнопку.


2-091 Командная панель

Командная панель

Элемент управления "Командная панель" (панель инструментов) предназначен для размещения в форме набора команд, с помощью которых производится управление информацией, размещенной в форме. Командная панель представляет собой древовидную структуру кнопок командной панели. Нажатие мышью на любую из кнопок вызывает немедленное выполнение связанной с этой кнопкой команды.

КоманднаяПанель (CommandBar)

Используется для доступа к свойствам командной панели в целом.

Пример:

ОстаткиМПЗ =
РегистрыНакопления.УчетНоменклатуры;
Форма = ОстаткиМПЗ.ПолучитьФормуСписка();
КП = Форма.ЭлементыФормы.КоманднаяПанель;
НоваяРамка = Новый Рамка(ТипРамкиЭлементаУправления.Выпуклая);
КП.Рамка = Новая.Рамка;
КП.ЦветФона =
WebЦвета.ГолубойСКраснымОттенком;
КП.Подсказка = "Выводится при наведении курсора на рамку панели";
Форма.Открыть();

Свойства

Доступность (Enable)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак доступности командной панели.

Кнопки (Buttons)

Использование:

Только чтение.

Описание:

Тип: КнопкиКоманднойПанели. Содержит коллекцию кнопок, образующих командную панель.

Ориентация (Orientation)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление Ориентация. Содержит способ расположения элемента управления в форме. Если указано "Авто", то ориентация выбирается по соотношению сторон: если высота больше ширины, то элемент ориентирован вертикально, если высота меньше ширины, то элемент ориентирован горизонтально. От ориентации зависит способ вывода текста на кнопках (горизонтально или вертикально).

Подсказка (ToolTipText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст всплывающей подсказки, которая появляется при наведении курсора.

ПрозрачныйФон (Transparent)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак прозрачности фона.

Рамка (Border)

Использование:

Чтение и запись.

Описание:

Тип: Рамка. Содержит параметры рамки вокруг панели.

ЦветРамки (BorderColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет рамки и разделителей панели,

Примечание:

Не используется, если рамка имеет стиль Выпуклая или Вдавленная - в этом случае рамка рисуется притененным цветом от цвета фона.

ЦветТекстаКнопки (ButtonTextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста кнопок командной панели.

ЦветФона (BackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона командной панели.

ЦветФонаКнопки (Button BackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона кнопок командной панели.

Шрифт(Font)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Содержит шрифт текста кнопок панели.

КнопкиКоманднойПанели (CommandBarButtons)

Используется для доступа к свойствам и методам коллекции кнопок командной панели.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа КнопкаКоманднойПанели. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции. Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс элемента.

Пример:

КП = ЭлементыФормы.КоманднаяПанель1;
КнопкаНажатие = Новый Действие("НоваяНажатие");
ТипКнопки = ТипКнопкиКоманднойПанели.Действие;
НоваяКнопка = КП.Кнопки.Добавить(ТипКнопки,,,КнопкаНажатие );
НоваяКнопка.Имя = "НовКн";
НоваяКнопка.Картинка = БиблиотекаКартинок.Параметры;
НоваяКнопка.Отображение = ОтображениеКнопкиКоманднойПанели.Авто;

Свойства

<Имя кнопки>

Использование:

Только чтение.

Описание:

Тип: КнопкаКоманднойПанели. Набор свойств содержит кнопки командного интерфейса. Имена свойств совпадают с именами кнопок, как они заданы в конфигураторе.

Методы

Вставить (Insert)

Синтаксис:

Вставить(<Индекс>, <Тип>, <Текст>, <Действие>)

Параметры:

<Индекс> Обязательный

Тип: Число. Позиция в коллекции кнопок, в которую необходимо вставить кнопку.

<Тип> Необязательный

Тип: системное перечисление ТипКнопкиКоманднойПанели. Тип кнопки командной панели (разделитель, действие, подменю).

<Текст> Необязательный

Тип: Строка. Текст, который будет выводиться на кнопке.

<Действие> Необязательный

Тип: Действие. Действие, которое необходимо выполнить при нажатии на данную кнопку. Для типов кнопок Разделитель и Подменю, действие указывать не нужно.

Возвращаемое значение:

Тип: КнопкаКоманднойПанели.

Описание:

Вставляет кнопку в указанную позицию.

Пример:

КП =
ЭлементыФормы.КоманднаяПанель;
НовоеДействие
= Новый Действие("МояПроцедураВМодулеФормы");
ТипКнопки =
ТипКнопкиИнтерфейса.Действие;
НоваяКнопка = КП.Кнопки.Вставить(0, ТипКнопки,,
НовоеДействие);

Добавить(Add)

Синтаксис:

Добавить(<Тип кнопки>, <Текст>, <Действие>)

Параметры:

<Тип кнопки> Необязательный

Тип: системное перечисление ТипКнопкиКоманднойПанели. Тип кнопки интерфейса (разделитель, подменю, действие).

<Текст> Необязательный

Тип: Строка. Текст, который будет выводиться на кнопке.

<Действие> Необязательный

Тип: Действие. Действие, которое необходимо выполнить при нажатии на данную кнопку. Для типов кнопок Разделитель и Подменю, действие указывать не нужно.

Возвращаемое значение:

Тип: системное перечисление КнопкаКоманднойПанели. Добавленная кнопка.

Описание:

Добавляет кнопку в командную панель.

Пример:

КП =
ЭлементыФормы.КоманднаяПаяель;
НовоеДействие
= Новый Действие("МояПроцедураВМодулеФормы");
ТипКнопки =
ТипКнопкиИнтерфейса.Действие;
НоваяКнопка = КП.Кнопки.Добавить(ТипКнопки,,
НовоеДействие);

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество кнопок в командной панели.

Описание:

Позволяет получить количество кнопок в командной панели.

Пример:

КП = ЭлементыФормы.КоманднаяПанель;
Сообщить("Итого кнопок " + КП.Кнопки.Количество() );

Очистить (Clear)

Синтаксис:

Очистить()

Описание:

Удаляет все кнопки из командной панели.

Пример:

КП = ЭлементыФормы.КоманднаяПанель;
КП. Кнопки - Очистить () ;

Сдвинуть (Move)

Синтаксис:

Сдвинуть(< Кнопка>, <Смещение>)

Параметры:

<Кнопка> Обязательный

Тип: Число, КнопкаКоманднойПанели. Индекс кнопки, которую необходимо передвинуть, или сама кнопка.

<Смещение> Обязательный

Тип: Число. Количество кнопок, на которое необходимо сдвинуть данную. Положительное значение соответствует смещению кнопки в сторону конца командной панели (увеличение индекса), отрицательное - к началу.

Описание:

Позволяет сдвинуть кнопку на указанное количество позиций.

Пример:

// Сдвигаем первую кнопку "вправо"
КП = ЭлементыФормы.КоманднаяПанель;
КП.Кнопки.Сдвинуть(0,1);

Удалить (Remove)

Синтаксис:

Удалить(<Индекс>)

Параметры:

<Индекс> Обязательный

Тип: Число. Позиция кнопки в командной панели.

Описание:

Позволяет удалить кнопку из командной панели.

Пример:

КП = ЭлементыФормы.КоманднаяПанель;
КП.Кнопки.Удалить(0) ;

КнопкаКоманднойПанели (CommandBarButton)

Используется для доступа к свойствам кнопки командной панели.

Пример:

КП = ЭлементыФормы.КоманднаяПанель;
НовоеДействие = Новый Действие("ДобавочноеДействие');
ТипКнопки = ТипКнопкиИнтерфейса.Действие;
НоваяКнопка = КП.Кнопки.Добавить(ТипКнопки,,КнопкаНажатие);
НоваяКнопка.Имя = "НоваяКнопка";
НоваяКнопка.Отображение = ОтображениеКнопкиИнтерфейса.Картинка;
НоваяКнопка.Картинка = БиблиотекаКартинок.Лупа;
НоваяКнопка.Подсказка = "Вызов ""Добавочное действие""";
НоваяКнопка.Пояснение = "Кнопка, добавленная средствами языка";
// Сочетание клавиш
Alt+Ctrl+F3
СочетаниеКл = Новый СочетаниеКлавиш(Клавиша.F3, Истина,
Истина);
НоваяКнопка.СочетаниеКлавиш = СочетаниеКл;

Свойства

Действие (Action)

Использование:

Только чтение.

Описание:

Тип: Действие. Содержит действие, ассоциированное с кнопкой командного интерфейса. Имеет смысл только для кнопок типа Действие.

ИзменяетДанные (ModifyData)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак того, что действие, выполняемое кнопкой, приводит к изменению данных. Например, заполнение или модификация объекта.

Примечание:

Если изменение данных объекта запрещено, то действие по кнопке выполнено не будет.

Имя (Name)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит уникальное имя кнопки командного интерфейса.

Картинка (Picture)

Использование:

Чтение и запись.

Описание:

Тип: Картинка. Содержит картинку, выводимую на кнопке, при соответствующем стиле ее отображения, определяемом свойством Отображение.

Примечание:

Рекомендуемый размер картинки 16х16 пикселей.

Кнопки (Buttons)

Использование:

Только чтение.

Описание:

Тип: КнопкиКоманднойПанели. Содержит коллекцию кнопок, связанную с данной. Имеет смысл только для кнопок типа Подменю.

Отображение (Representation)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ОтображениеКнопкиКоманднойПанели. Содержит стиль отображения кнопки.

Подсказка (Tooltip)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст всплывающей подсказки, которая появляется при наведении курсора.

Пояснение (Comment)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст, выводимый в строке состояния.

СочетаниеКлавиш (Shortcut)

Использование:

Чтение и запись.

Описание:

Тип: СочетаниеКлавиш. Содержит сочетание клавиш, при нажатии на которые произойдет выполнение действия, связанного с кнопкой.

Текст (Text)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст, отображаемый на кнопке, при соответствующем стиле отображения, определяемом свойством.

ТипКнопки (ButtonType)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ТипКнопкиКоманднойПанели. Содержит тип кнопки командной панели.


2-105 Надпись

Надпись (Label)

Надпись предназначена для размещения в форме подписей к другим элементам управления, небольших поясняющих текстов, а также ссылок. Механизм ссылки позволяет связать с надписью некоторые действия, выполняемые при нажатии на неё.

Свойства

БегущаяСтрока (RunningString)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление РежимБегущейСтроки. Задает режим бегущей строки. В режиме бегущей строки содержимое надписи будет двигаться справа налево.

ВертикальноеПоложение

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ВертикальноеПоложение. Определяет способ вертикального расположения текста на кнопке.

ВыделятьОтрицательные (MarkNegatives)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак выделения текста надписи, содержащей отрицательное число, специальным цветом. Цвет выделения имеет название "Отрицательные числа" в используемом для формы стиле.

Гиперссылка (HyperLink)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак того, что надпись является гиперссылкой. Если значение свойства Истина, то текст надписи выводится с подчеркиванием, и при нажатии на надпись возникает событие Нажатие.

См. также:

Надпись, событие Нажатие.

ГоризонтальноеПоложение (HorizontalAlignment)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ГоризонтальноеПоложение. Определяет способ горизонтального расположения текста надписи.

Доступность (Enable)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак доступности надписи.

Заголовок (Caption)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст надписи.

Примечание:

Если текст не умещается по ширине, он автоматически разбивается на несколько строк с переносом по словам. Если перенос по словам невозможен, видимый текст будет заканчиваться троеточием. Если разбитый на строки текст не умещается по высоте, то он будет прижат к верхней границе не зависимо от установленного способа выравнивания по вертикали, не уместившиеся строки не будут показаны.

В режиме бегущей строки текст надписи по строкам не переносится, никогда не заканчивается троеточием. При изменении текста в режиме бегущей строки новый текст показывается только со следующего прохода.

Значение (Value)

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Содержит значение связанной переменной. Если связанной переменной нет, то заголовок надписи.

Подсказка (ToolTipText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст всплывающей подсказки, которая появляется при наведении курсора.

ПрозрачныйФон (Transparent)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак прозрачности фона.

Рамка (Border)

Использование:

Чтение и запись.

Описание:

Тип: Рамка. Содержит параметры рамки вокруг надписи.

СочетаниеКлавиш (Shortcut)

Использование:

Чтение и запись.

Описание:

Тип: СочетаниеКлавиш. Содержит сочетание клавиш, по нажатию которых происходит нажатие на надпись.

Примечание:

Используется, если надпись является гиперссылкой (свойство Ссылка имеет значение Истина).

ЦветРамки (BorderColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет рамки вокруг надписи.

Примечание:

Не используется, если рамка имеет стиль Выпуклая или Вдавленная - в этом случае рамка рисуется притененным цветом от цвета фона.

ЦветТекста (TextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста.

Примечание:

Не используется, если надпись содержит отрицательное число и свойство ВыделятьОтрицательные имеет значение Истина.

ЦветФона (BackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона элемента управления.

Примечание:

Не используется, если свойство ПрозрачныйФон имеет значение Истина.

Шрифт (Font)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Содержит шрифт текста надписи.

События

Нажатие (Click)

Синтаксис:

Нажатие()

Описание:

Возникает при нажатии на надпись, если у надписи свойство Ссылка имеет значение Истина.

См. также:

Надпись, свойство Гиперссылка.


2-114 Панель

Панель

Панель предназначена для создания форм, динамически меняющих состав своих элементов в зависимости от действий пользователя. Панель содержит одну или несколько страниц, которые могут быть представлены в виде закладок, также возможно управление страницами панели средствами встроенного языка Можно распределить элементы управления по различным страницам панели для того, чтобы в зависимости от ситуации показывать на форме только нужные элементы, а остальные - скрывать.

Панель (Panel)

Используется для доступа к свойствам и событиям панели в целом.

Свойства

Доступность (Enable)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак доступности панели.

Примечание:

Панель распространяет это свойство на все находящиеся на ней элементы управления, в т.ч. и вложенные панели. Если панель недоступна, то рамка панели, закладки и фоновая картинка панели отображаются притенёнными. Если панель недоступна, то её нельзя сделать активной, она не обрабатывает щелчки мышью и нажатия клавиш клавиатуры.

Картинка (Picture)

Использование:

Чтение и запись.

Описание:

Тип: Картинка. Содержит картинку, отображаемую на панели в качестве фона. Многостраничная панель использует одну картинку для всех своих страниц. Картинка не отображается на закладках - переключателях страниц.

ОтображениеЗакладок (ShowTabs)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ОтображениеЗакладок. Определяет режим отображения закладок.

Подсказка (ToolTipText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст всплывающей подсказки, которая появляется при наведении курсора.

ПрозрачныйФон (Transparent)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак прозрачности фона.

Примечание:

Прозрачность используется только для отображения области закладок: только в местах, где закладок нет или есть "щели" между ними, будет виден фон родительской панели. Непосредственно сама страница панели прозрачной не бывает.

РазмерКартинки (PictureSizeMode)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление РазмерКартинки. Определяет режим приспособления оригинальных размеров картинки к размеру панели.

Рамка (Border)

Использование:

Только чтение.

Описание:

Тип: Рамка. Рамка вокруг страницы и закладок. В режиме отображения закладок рамка бывает только простая одинарная, если закладки не отображаются или установлен режим "прокручивать страницы", то рамка может принимать любое значение типа Рамка.

РаспределятьПоСтраницам (SeparateByPages)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Определяет, изменяется ли состав отображаемых на панели элементов управления при переключении между страницами. Если Ложь, то страница будет только одна, а закладок много.

Страницы (Pages)

Использование:

Только чтение.

Описание:

Тип: Коллекция страниц панели. Содержит коллекцию страниц панели.

ТекущаяСтраница (CurrentPage)

Использование:

Чтение и запись.

Описание:

Тип: Страница панели. Содержит текущую страницу панели.

ЦветРамки (BorderCoIor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет рамки вокруг панели и закладок.

Примечание:

Не используется, если рамка имеет стиль Выпуклая или Вдавленная - в этом случае рамка рисуется притененным цветом от цвета фона.

ЦветТекста (TextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста на закладках панели.

ЦветФона (BackCotor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона панели.

Примечание:

Един для всех страниц и закладок. Неактивные закладки отображаются этим же цветом, но немного притененно.

Шрифт (Font)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Содержит шрифт текста на закладках панели.

События

ПриСменеСтраницы (OnPageChanged)

Синтаксис:

ПриСменеСтраницы (< Текущая страница> )

Параметры:

<Текущая страница>

Тип: Число. Страница, на которую переключена панель.

Описание:

Возникает при переключении с одной закладки на другую.

Коллекция страниц панели

Предназначен для доступа к методам коллекции страниц панели.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа Страница панели. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции. Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс страницы.

Методы

Вставить (Insert)

Синтаксис:

Вставить(<Номер элемента> , <Имя>, <3аголовок>, <3начение>, <Картинка заголовка>)

Параметры:

<Номер элемента> Обязательный

Тип: Число. Позиция, в которую должен быть помещена страница.

<Имя> Необязательный

Тип: Строка. Имя добавляемой страницы.

<3аголовок> Необязательный

Тип: Строка. Текст заголовка добавляемой страницы. Если страницы панели показываются в виде закладок, то определяет текст на закладке.

<3начение> Необязательный

Тип: Произвольный. Значение, связанное со страницей.

<Картинка заголовка> Необязательный

Тип. Картинка. Картинка, отображаемая на заголовке закладки.

Возвращаемое значение:

Тип: Страница панели.

Описание:

Вставляет страницу в нужную позицию коллекции страниц панели.

Добавить (Add)

Синтаксис:

Добавить(<Имя>, <3аголовок>, <3начение>, <Картинка заголовка>)

Параметры:

<Имя> Необязательный

Тип: Строка. Имя добавляемой страницы.

<3аголовок> Необязательный

Тип: Строка. Текст заголовка добавляемой страницы. Если страницы панели показываются в виде закладок, то определяет текст на закладке.

<3начение> Необязательный

Тип: Произвольный. Значение, связанное со страницей.

<Картинка заголовка> Необязательный

Тип: Картинка. Картинка, отображаемая на заголовке закладки.

Возвращаемое значение:

Тип: Страница панели. Созданная страница

Описание:

Добавляет страницу в коллекцию страниц панели.

Индекс (IndexOf)

Синтаксис:

Индекс(<Страница>)

Параметры:

<Страница> Обязательный

Тип: Страница панели. Страница панели.

Возвращаемое значение:

Тип: Число. Индекс панели в коллекции.

Описание:

Получает индекс страницы в коллекции страниц панели.

Пример:

ИндексТекСтраницы = Панель.Страницы.Индекс(Панель.ТекущаяСтраница);

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество страниц

Описание:

Позволяет получить количество страниц панели.

Очистить (Clear)

Синтаксис:

Очистить()

Описание:

Удаляет все страницы из коллекции страниц панели. После выполнения этого метода панель имеет одну страницу и одну закладку. Нумерация страниц коллекции начинается с 1.

Сдвинуть (Move)

Синтаксис:

Сдвинуть(< Страница>, <Смещение>)

Параметры:

<Страница> Обязательный

Тип: Число или страница. Индекс перемещаемой страницы в коллекции страниц панели, или сама страница.

<Смещение > Обязательный

Тип: Число. Количество позиций, не которое необходимо переместить страницу в коллекции. Положительное значение соответствует смещению к концу коллекции, отрицательное - к началу.

Описание:

Перемещает страницу на предыдущую или последующую позицию в коллекции страниц панели.

Пример:

Панель.Страницы.Сдвинуть(1, -1);

Удалить (Remove)

Синтаксис:

Удалить(<Номер>)

Параметры:

<Номер> Необязательный

Тип: Число. Номер удаляемой страницы в коллекции.

Описание:

Удаляет страницу из коллекции страниц панели.

Страница панели

Используется для доступа к свойствам страницы панели.

Свойства

Видимость (Visible)

Использование:

Чтение и запись.

Описание:

Тип- Булево. Содержит признак видимости страницы. Если значение Ложь, то страница не отображается.

Доступность (Enabled)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак доступности закладки.

Заголовок (Caption)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст закладки страницы.

Значение (Value)

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Содержит значение, которое может быть назначено странице и затем получено. Может использоваться для связи страницы с данными.

Имя (Name)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя страницы в коллекции страниц панели.

КартинкаЗаголовка (TitlePicture)

Использование:

Чтение и запись.

Описание:

Тип: Картинка. Содержит картинку, отображаемую на закладке страницы. Картинка отображается слева от текста при горизонтальной ориентации закладок и сверху от текста при вертикальной ориентации. Картинка автоматически уменьшается (если её размеры больше) до размера 96 пикселя по ширине и 64 по высоте с сохранением пропорций оригинального изображения.

Примечание:

Рекомендуемый размер картинки 16х16 пикселей.

Расширение элементов управления расположенных на панели

Перечисленные ниже свойства возникают у элемента управления, размещенного на панели.

Свойства

Верх (Тор)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит координату верхней границы элемента управления относительно верхней границы панели (в логических единицах).

Видимость (Visible)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак видимости элемента управления.

Высота (Height)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит высоту элемента управления (в логических единицах).

Лево (Left)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит координату левой границы элемента управления относительно левой границы панели (в логических единицах).

ПорядокОбхода (TabOrder)

Использование:

Чтение и запись.

Описание:

Тип: Число. Порядковый номер элемента управления при обходе элементов страницы панели.

ПорядокОтображения (ZOrder)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит порядок отображения элемента управления. Совокупность порядков отображения элементов управления, расположенных на одной панели, определяет, какой элемент окажется "сверху" в случае, если элементы наложены друг на друга.

Ширина (Width)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит ширину элемента управления (в логических единицах).


2-130 Переключатель

Переключатель (RadioButton)

Переключатели используют в тех случаях, когда требуется выбрать только одно числовое значение из небольшого числа возможных фиксированных вариантов. Переключатели, определяющие одно значение, относятся к одной группе. Для каждой группы переключателей необходимо назначить первый в группе элемент, которому присваивается имя изменяемого значения. Относящиеся к одной группе переключатели должны следовать строго друг за другом в порядке обхода после первого в группе.

Свойства

ВертикальноеПоложение (VerticalAlignment)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ВертикальноеПоложение. Определяет способ вертикального расположения текста переключателя.

ГоризонтальноеПоложение

Использование:

Только чтение.

Описание:

Тип: системное перечисление ГоризонтальноеПоложение. Определяет способ горизонтального расположения текста переключателя.

Доступность (Enable)

Использование:

Чтение и запись.

Описание:

Тип: Булево.

Заголовок (Caption)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст переключателя.

Примечание:

Если текст не умещается по ширине, он автоматически разбивается на несколько строк с переносом по словам. Если перенос по словам невозможен, видимый текст будет заканчиваться троеточием. Если разбитый на строки текст не умещается по высоте, то он будет прижат к верхней границе не зависимо от установленного способа выравнивания по вертикали, не уместившиеся строки не будут показаны.

Значение (Value)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит значение, введенное в элементе управления.

Подсказка (ToolTipText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст всплывающей подсказки, которая появляется при наведении курсора.

ПоложениеЗаголовка (TitleLocation)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ПоложениеЗаголовка. Определяет способ расположения текста переключателя относительно переключателя.

Прозрачныйфон (Transparent)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак прозрачности фона.

Рамка (Border)

Использование:

Чтение и запись.

Описание:

Тип: Рамка. Содержит параметры рамки вокруг переключателя.

ЦветРамки (BorderColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет рамки вокруг переключателя.

Примечание:

Не используется, если рамка имеет стиль Выпуклая или Вдавленная - в этом случае рамка рисуется притененным цветом от цвета фона.

ЦветТекста (TextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста переключателя.

ЦветТекстаПоля (FieldTextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет метки переключателя.

ЦветФона (BackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона переключателя.

ЦветФонаПоля (FieldBackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Цвет фона, на котором изображается точка переключателя.

Шрифт (Font)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Содержит шрифт текста переключателя.

События

ПриИзменении (OnChange)

Синтаксис:

ПриИзменении()

Описание:

Возникает при изменении положения переключателя.

Примечание:

Событие всегда связано с первым в группе элементом.


2-134 Поле ввода

ПолеВвода (TextBox)

Поле ввода является одним из наиболее распространенных элементов управления. Оно используется для ввода значений непосредственно в поле, для выбора значений из списков и для выбора ссылок на различные объекты. Набор различных кнопок управления существенно расширяет сферу его применения.

Свойства

АвтоВыбор (AutoSelection)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак включения/выключения режима автовыбора. Если данный режим включен, то при активизации поля, если в нем нет значения, автоматически откроется окно или список для выбора.

Примечание:

Имеет смысл только для полей, в которых значение может выбираться стандартным образом из списка или другой формы.

АвтопереносСтрок (Wrap)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак автоматического переноса длинных строк текста.

Примечание:

Имеет смысл, только если свойство МногострочныйРежим имеет значение Истина.

ВыбиратьТип (ChooseType)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак возможности выбора типа значения пользователем перед выбором самого значения. Это означает, что если в поле ввода можно вводить значения разных типов, то значение данного свойства показывает, будет ли запрашиваться тип при нажатии на кнопку выбора. Если значение Истина, то тип будет запрашиваться при каждом выборе. Если Ложь то не будет, это значит, что будет предоставляться выбор значения такого типа, значение которого присвоено полю ввода в момент выбора.

ВыделенныйТекст (SelectedText)

Использование:

Только чтение.

Описание:

Тип: Строка. Содержит выделенный пользователем текст.

ВыделятьОтрицательные

Использование:

Только чтение.

Описание:

Тип: Булево. Свойство содержит признак, будут ли отрицательные числа выделяться специальным цветом ЦветОтрицательныхЧисел.

ВысотаСпискаВыбора(ChoiceListHeight)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит высоту выпадающего списка выбора. Высота измеряется в строках.

Доступность (Enable)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак доступности поля.

Значение (Value)

Использование:

Чтение и запись.

Описание:

Содержит значение, введенное в элементе управления.

Картинка (Picture)

Использование:

Чтение и запись.

Описание:

Тип: Картинка. Содержит картинку, которая располагается непосредственно в поле ввода. Картинка всегда прижимается влево.

Примечание:

Максимальная ширина картинки, которую можно отобразить в поле ввода 20 пикселей. Оптимальная высота картинки зависит от высоты элемента управления и толщины рамки.

КартинкаКнопкиВыбора (SelButtonPicture)

Использование:

Чтение и запись.

Описание:

Тип: Картинка. Содержит картинку, отображаемую в кнопке выбора.

Примечание:

Оптимальный размер картинки определяется размером элемента управления и размером его шрифта.

КнопкаВыбора (SelectButton)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак наличия/отсутствия кнопки выбора значения в поле.

КнопкаОткрытия (OpenButton)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак наличия/отсутствия кнопки открытия значения поля.

КнопкаОчистки (ClearButton)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак наличия/отсутствия кнопки очистки поля.

КнопкаРегулирования (SpinButton)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак наличия/отсутствия кнопки регулирования (стрелочки вверх и вниз).

КнопкаСпискаВыбора (ChoiceListButton)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак наличия/отсутствия кнопки выбора из списка.

МаксимальноеЗначение (MaxValue)

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Содержит максимальное значение, которое возможно ввести в поле.

Примечание:

Тип устанавливаемого минимального значения должен допускать сравнения больше/меньше.

Маска (Mask)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит подсимвольную строку маски интерактивного ввода текста в поле.

В строке маски допустимо использование следующих специальных символов:

! - любой введенный символ преобразуется в верхний регистр;

9 - допустимо ввести произвольный символ цифры;

# - допустимо ввести произвольный символ цифры или - (знак минус) или + (знак плюс) или пробел;

N - допустимо ввести любые алфавитно-цифровые символы (буквы или цифры);

U - допустимо ввести любые алфавитно-цифровые символы (буквы или цифры) и любой введенный символ преобразуется в верхний регистр;

Х (латинского алфавита) - допустимо ввести произвольный символ;

@ - допустимо ввести любые алфавитно-цифровые символы (буквы или цифры) или (подчеркивание) или пробел;

$ - любой введенный символ, если это не точка, преобразуется в #;

^ - не допустимо вводить этот символ интерактивно пользователем, он может устанавливаться только из языка;

h - допустим ввод символов обозначения шестнадцатеричных цифр.

Примечание:

Имеет смысл только для значений типа Строка.

МинимальноеЗначение (MinValue)

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Содержит минимальное значение, которое возможно ввести в поле.

Примечание:

Тип устанавливаемого минимального значения должен допускать сравнения больше/меньше.

МногострочныйРежим (MultiLine)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак возможности ввода текста, состоящего из нескольких строк.

Подсказка (ToolTipText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст всплывающей подсказки, которая появляется при наведении курсора.

Рамка (Border)

Использование:

Чтение и запись.

Описание:

Тип: Рамка. Содержит параметры рамки вокруг поля.

РедактированиеТекста

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак возможности редактирования содержимого поля как обычного текста. Если свойство имеет значение Ложь изменить содержимое можно лишь с помощью встроенных в элемент управления кнопок.

Примечание:

Имеет смысл только для значений, которые могут редактироваться непосредственно в поле ввода.

РежимПароля (PasswordMode)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак специального режима для ввода пароля, в котором все вводимые символы отображаются символом "*" (звездочка).

СочетаниеКлавиш (ShortCut)

Использование:

Только чтение.

Описание:

Тип: СочетаниеКлавиш. Содержит сочетание клавиш, по нажатию которых происходит активизация поля.

СписокВыбора (ChoiceList)

Использование:

Чтение и запись.

Описание:

Тип: СписокЗначений. Содержит список значений для осуществления выбора по нажатию кнопки списка выбора.

Примечание:

Имеет смысл только при наличии кнопки выбора из списка.

ТолькоПросмотр (Readonly)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак возможности/невозможности интерактивного изменения значения, введенного в поле.

Примечание:

В отличие от свойства Доступность, если свойство ТолькоПросмотр равно Истина, становится невозможным редактирование поля ввода, однако на остальную работу с полем это не влияет. Например, можно выделить строковое представление содержимого поля выбора и скопировать в буфер обмена.

ЦветРамки (BorderColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет рамки вокруг поля.

Примечание:

Не используется, если рамка имеет стиль Выпуклая или Вдавленная - в этом случае рамка рисуется притененным цветом от цвета фона

ЦветТекстаКнопки (ButtonTextColor)

Использование:

Чтение и запись.

Описание:

Тип Цвет. Содержит цвет текста кнопок поля выбора.

ЦветТекстаПоля (FieldTextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста поля.

ЦветФонаКнопки (ButtonBackColor)

Использование:

Чтение и запись.

Описание:

Тип Цвет. Содержит цвет фона кнопок поля ввода

ЦветФонаПоля (FieldBackColor)

Использование:

Чтение и запись.

Описание:

Тип Цвет Содержит цвет фона поля редактирования.

ШиринаСпискаВыбора (ListSelWidth)

Использование:

Чтение и запись.

Описание:

Тип Число Содержит минимальную ширину выпадающего списка для выбора Эта ширина измеряется в так называемых средних символах шрифта, который используется в поле ввода. Фактическая минимальная ширина списка определяется эмпирическим путем. Фактическая реальная ширина списка определяется как наибольшее значение из фактической минимальной ширины и ширины поля ввода с учетом текущего размера в момент редактирования пользователем.

Примечание:

Если значение свойства равна 0, то минимальная ширина принимается равной 20 символам.

Шрифт (Font)

Использование:

Чтение и запись.

Описание:

Тип Шрифт. Содержит шрифт текста поля.

События

ПриИзменении (OnChange)

Синтаксис:

ПриИзменении()

Описание:

Событие возникает после изменения значения поля ввода, то есть при переходе на другой элемент управления, если значение текста было изменено; после отработки выбора из списка выбора, после отработки выбора из календаря, калькулятора и других модальных выборов, кроме программного назначения; после отработки автоматического приема немодального выбора (например, из списка справочника).

НачалоВыбора (BeginChoice)

Синтаксис:

НачалоВыбора(<Стандартная обработка>)

Параметры:

<Стандартная обработка>

Тип: Булево. В данный параметр передается признак выполнения стандартной (системной) обработки события. Если в теле процедуры-обработчика установить данному параметру значение Ложь стандартная обработка события производиться не будет.

Описание:

Событие возникает в момент нажатия кнопки выбора или клавиши F4.

НачалоВыбораИзСписка (BeginListChoice)

Синтаксис:

НачалоВыбораИзСписка(<Стандартная обработка>)

Параметры:

<Стандартная обработка>

Тип: Булево. В данный параметр передается признак выполнения стандартной (системной) обработки события. Если в теле процедуры-обработчика установить данному параметру значение Ложь стандартная обработка события производиться не будет.

Описание:

Событие возникает в момент нажатия кнопки выбора из списка.

Очистка (Clear)

Синтаксис:

Очистка(<Стандартная обработка>)

Параметры:

<Стандартная обработка>

Тип: Булево. В данный параметр передается признак выполнения стандартной (системной) обработки события. Если в теле процедуры-обработчика установить данному параметру значение Ложь стандартная обработка события производиться не будет.

Описание:

Событие возникает в момент нажатия кнопки очистки.

Регулирование (Regulation)

Синтаксис:

Регулирование(<Направление>, <Стандартная обработка>)

Параметры:

<Направление>

Тип: Число. Позволяет определить, какая из кнопок регулирования была нажата. При нажатии на увеличение (вверх) параметр равен 1, при нажатии на уменьшение (вниз) - равен -1.

<Стандартная обработка>

Тип: Булево. В данный параметр передается признак выполнения стандартной (системной) обработки события. Если в теле процедуры-обработчика установить данному параметру значение Ложь стандартная обработка события производиться не будет.

Описание:

Событие возникает в момент нажатия одной из кнопок регулирования.

Открытие (Open)

Синтаксис:

Открытие(<Стандартная обработка>)

Параметры:

<Стандартная обработка>

Тип: Булево. В данный параметр передается признак выполнения стандартной (системной) обработки события. Если в теле процедуры-обработчика установить данному параметру значение Ложь стандартная обработка события производиться не будет. Отказ от стандартной обработки не отменяет событие.

Описание:

Событие возникает в момент нажатия кнопки открытия.

ОбработкаВыбора (ProcessSelection)

Синтаксис:

ОбработкаВыбора(<Выбранное значение>, <Стандартная обработка>)

Параметры:

<Выбранное значение>

Тип Произвольный.

<Стандартная обработка>

Тип: Булево. В данный параметр передается признак выполнения стандартной (системной) обработки события. Если в теле процедуры-обработчика установить данному параметру значение Ложь стандартная обработка события производиться не будет. Фактически это означает, что выбор произведен не будет.

Описание:

Событие возникает после выполнения выбора при: обработке выбора из списка выбора; обработке выбора из всех модальных диалогов выбора (например, календаря, калькулятора); обработке немодального выбора (например, из списка справочника).


2-149 Поле выбора

ПолеВыбора (ComboBox)

Поле выбора предназначено для выбора одного элемента из списка Список элементов для выбора содержится в свойстве СписокВыбора и заполняется перед использованием поля выбора Кроме кнопки выбора из списка поле выбора также может иметь дополнительные кнопки управления.

Свойства

ВысотаСпискаВыбора

Использование:

Чтение и запись.

Описание:

Тип Число. Содержит высоту выпадающего списка выбора. Высота измеряется в строках.

Доступность (Enable)

Использование:

Чтение и запись.

Описание:

Тип. Булево. Содержит признак доступности поля.

Значение (Value)

Использование:

Чтение и запись.

Описание:

Содержит значение, введенное в элементе управления.

Картинка (Picture)

Использование:

Чтение и запись.

Описание:

Тип: Картинка. Содержит картинку, которая располагается непосредственно в поле выбора. Картинка всегда прижимается влево.

Примечание:

Максимальная ширина картинки, которую можно отобразить в поле выбора 20 пикселей. Оптимальная высота картинки зависит от высоты элемента управления и толщины рамки.

КартинкаКнопкиВыбора (SelButtonPicture)

Использование:

Чтение и запись.

Описание:

Тип: Картинка. Содержит картинку, отображаемую в кнопке выбора.

Примечание:

Оптимальный размер картинки определяется размером элемента управления и размером его шрифта.

КнопкаВыбора (SelectButton)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак наличия/отсутствия кнопки выбора значения в поле.

Примечание:

Стандартной обработки нажатия на кнопку выбора не предусмотрено. Необходимые действия можно провести в обработчике события ПриНачалеВыбора.

КнопкаОткрытия (OpenButton)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак наличия/отсутствия кнопки открытия значения поля.

Примечание:

Стандартной обработки нажатия на кнопку открытия значения не предусмотрено. Необходимые действия можно провести в обработчике события Открытие.

КнопкаОчистки (ClearButton)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак наличия/отсутствия кнопки очистки поля.

Примечание:

Стандартной обработки нажатия на кнопку очистки не предусмотрено. Необходимые действия можно провести в обработчике события Очистка.

КнопкаРегулирования (SpinButton)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак наличия/отсутствия кнопки регулирования (стрелочки вверх и вниз).

Примечание:

Стандартной обработки нажатия на стрелки кнопки регулирования не предусмотрено. Необходимые действия можно провести в обработчике события Регулирование.

Подсказка (ToolTipText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст всплывающей подсказки, которая появляется при наведении курсора.

Рамка (Border)

Использование:

Чтение и запись.

Описание:

Тип: Рамка. Содержит параметры рамки вокруг поля.

СписокВыбора (ChoiceList)

Использование:

Чтение и запись.

Описание:

Тип: СписокЗначений. Содержит список значений для осуществления выбора по нажатию кнопки списка выбора.

Примечание:

Данный список должен быть заполнен до использования поля выбора, например при открытии формы.

ТолькоПросмотр (Readonly)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак возможности/невозможности интерактивного изменения значения, введенного в поле.

Примечание:

В отличие от свойства Доступность, если свойство ТолькоПросмотр равно Истина, становится невозможным редактирование поля выбора, однако на остальную работу с полем это не влияет. Например, можно выделить строковое представление содержимого поля выбора и скопировать в буфер обмена.

ЦветРамки (BorderColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет рамки вокруг поля.

Примечание:

Не используется, если рамка имеет стиль Выпуклая или Вдавленная - в этом случае рамка рисуется притененным цветом от цвета фона.

ЦветТекстаКнопки (ButtonTextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста кнопок.

ЦветТекстаПоля (FieldTextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста поля выбора.

ЦветФонаКнопки (ButtonBackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона кнопок.

ЦветФонаПоля (FieldBackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона поля выбора.

ШиринаСпискаВыбора

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит минимальную ширину выпадающего списка для выбора. Эта ширина измеряется в так называемых средних символах шрифта, который используется в поле ввода. Фактическая минимальная ширина списка определяется эмпирическим путем. Фактическая реальная ширина списка определяется как наибольшее значение из фактической минимальной ширины и ширины поля ввода с учетом текущего размера в момент редактирования пользователем.

Примечание:

Если значение свойства равна 0, то минимальная ширина принимается равной 20 символам.

Шрифт (Font)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Содержит шрифт текста поля.

События

ПриИзменении (OnChange)

Синтаксис:

ПриИзменении()

Описание:

Возникает при изменении значения поля выбора. В обработчике события нельзя отказаться от изменений, но можно выполнить необходимые действия при изменении значения поля.

Примечание:

Данное событие следует после событий изменения значения поля: ОбработкаВыбора, Очистка, Регулирование.

НачалоВыбора (BeginChoice)

Синтаксис:

НачалоВыбора(<Стандартная обработка>)

Параметры:

<Стандартная обработка>

Тип: Булево. В данный параметр передается признак выполнения стандартной (системной) обработки события. Если в теле процедуры-обработчика установить данному параметру значение Ложь стандартная обработка события производиться не будет.

Описание:

Возникает при нажатии кнопки выбора или клавиши F4.

НачалоВыбораИзСписка (Begin ListChoice)

Синтаксис:

НачалоВыбораИзСписка (<Стандартная обработка> )

Параметры:

<Стандартная обработка>

Тип: Булево. В данный параметр передается признак выполнения стандартной (системной) обработки события. Если в теле процедуры-обработчика установить данному параметру значение Ложь стандартная обработка события производиться не будет.

Описание:

Возникает при нажатии кнопки выбора из списка.

Очистка (Clear)

Синтаксис:

Очистка(<Стандартная обработка>)

Параметры:

<Стандартная обработка>

Тип: Булево. В данный параметр передается признак выполнения стандартной (системной) обработки события. Если в теле процедуры-обработчика установить данному параметру значение Ложь стандартная обработка события производиться не будет.

Описание:

Возникает в момент нажатия кнопки очистки.

Регулирование (Regulation)

Синтаксис:

Регулирование(< Направление> , Стандартная обработка>)

Параметры:

<Направление>

Тип: Число. Направление регулирования. При нажатии на увеличение (стрелка вверх) равен 1, при нажатии на уменьшение (стрелка вниз) равен -1.

<Стандартная обработка>

Тип: Булево. В данный параметр передается признак выполнения стандартной (системной) обработки события. Если в теле процедуры-обработчика установить данному параметру значение Ложь стандартная обработка события производиться не будет.

Описание:

Возникает при нажатии на кнопки регулирования.

Открытие (Open)

Синтаксис:

Открытие(<Стандартная обработка>)

Параметры:

<Стандартная обработка>

Тип: Булево. В данный параметр передается признак выполнения стандартной (системной) обработки события. Если в теле процедуры-обработчика установить данному параметру значение Ложь стандартная обработка события производиться не будет.

Описание:

Возникает при нажатии на кнопку открытия. В обработчике данного события можнэ провести открытие выбранного значения.

ОбработкаВыбора (ProcessSelection)

Синтаксис:

ОбработкаВыбора(< Выбранное значение> , <Стандартная обработка>)

Параметры:

<Выбранное значение>

Тип: Произвольный. Выбранное значение.

<Стандартная обработка>

Тип: Булево. В данный параметр передается признак выполнения стандартной (системной) обработки события. Если в теле процедуры-обработчика установить данному параметру значение Ложь стандартная обработка события производиться не будет.

Описание:

Вызывается после осуществления выбора значения из списка выбора, но до помещения выбранного значения в элемент управления. В процедуре-обработчике события можно отказаться от выбора.


2-159 Поле картинки

ПолеКартинки (PictureBox)

Поле картинки предназначено для размещения на форме различных изображений. Механизм ссылки позволяет связать с полем картинки некоторые действия, выполняемые при нажатии на неё.

Свойства

Доступность (Enable)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак доступности поля картинки.

Картинка (Picture)

Использование:

Чтение и запись.

Описание:

Тип: Картинка. Содержит отображаемую в поле картинку.

Подсказка (ToolTipText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст всплывающей подсказки, которая появляется при наведении курсора.

ПрозрачныйФон (Transparent)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак прозрачности фона.

РазмерКартинки (PictureSizeMode)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление РазмерКартинки. Определяет режим приспособления оригинальных размеров картинки к размеру поля картинки.

Рамка (Border)

Использование:

Чтение и запись.

Описание:

Тип: Рамка. Содержит параметры рамки вокруг поля картинки.

СочетаниеКлавиш (Shortcut)

Использование:

Чтение и запись.

Описание:

Тип: СочетаниеКлавиш. Содержит сочетание клавиш, по нажатию которых происходит нажатие на картинку.

Примечание:

Доступно только в режиме гиперссылки.

Ссылка (Hypertink)

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит признак того, что поле картинки является гиперссылкой. Если значение свойства Истина, то при нажатии на поле картинки возникает событие Нажатие.

См. также:

ПолеКартинки, событие Нажатие.

ЦветРамки (BorderCotor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет рамки вокруг поля картинки.

Примечание:

Не используется, если рамка имеет стиль Выпуклая или Вдавленная - в этом случае рамка рисуется притененным цветом от цвета фона.

ЦветФона (BackCotor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона поля картинки.

Примечание:

Фон поля картинки просматривается в местах поля, где не рисуется картинка, или там, где на картинке прозрачные участки.

События

Нажатие (Click)

Синтаксис:

Нажатие()

Описание:

Возникает при нажатии на поле картинки, если у него свойство Ссылка имеет значение Истина.

См. также:

ПолеКартинки, свойство Ссылка.


2-163 Поле списка

ПолеСписка (ListBox)

Поле списка предназначено для выбора одного или нескольких значений из списка и является визуальным представлением объекта СписокЗначений. Строки поля списка могут содержать пометки, аналогичные флажкам, при помощи которых можно отмечать выбранные значения. Все действия по изменению списка (добавлению элементов в список, удаление из списка, сортировка списка) проводятся при помощи связанного с полем списка значений.

См. также:

Список значений.

Свойства

Доступность (Enable)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак доступности поля.

Значение (Value)

Использование:

Чтение и запись.

Описание:

Тип: СписокЗначений. Содержит значение, введенное в элементе управления.

ОтображатьКартинку (ShowPicture)

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит признак отображения картинок в строках поля списка.

См. также:

ЭлементСпискаЗначений, свойство Картинка.

ОтображатьПометку (ShowCheck)

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит признак отображения пометок в строках поля списка.

См. также:

ЭлементСпискаЗначений, свойство Пометка.

Подсказка (ToolTipText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст всплывающей подсказки, которая появляется при наведении курсора.

Рамка (Border)

Использование:

Чтение и запись.

Описание:

Тип: Рамка. Содержит параметры рамки вокруг поля.

ТекущаяСтрока (CurrentLine)

Использование:

Только чтение.

Описание:

Тип: ЭлементСпискаЗначений. Содержит текущую строку поля списка.

См.также:

ЭлементСпискаЗначений.

ТолькоПросмотр (Readonly)

Использование:

Только чтение.

Описание:

Тип: Булево. Определяет возможность редактирования поля списка. Если значение свойства Истина, то возможен только просмотр поля списка.

Примечание:

В отличие от свойства Доступность, если свойство ТолькоПросмотр равно Истина, становится невозможным редактирование поля списка, однако на остальную работу с полем это не влияет. Например, можно выделить строковое представление содержимого поля списка и скопировать в буфер обмена.

ЦветРамки (BorderColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет рамки вокруг поля.

Примечание:

Не используется, если рамка имеет стиль Выпуклая или Вдавленная - в этом случае рамка рисуется притененным цветом от цвета фона.

ЦветТекстаПоля (FieldTextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста поля.

ЦветФонаПоля (FieldBackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона поля.

События

Выбор (Select)

Синтаксис:

Выбор(<Текущий элемент>)

Параметры:

<Текущий элемент>

Тип: ЭлементСпискаЗначений. Выбранный элемент списка.

Описание:

Возникает при выборе строки из поля списка.

ПриАктивизацииСтроки

Синтаксис:

ПриАктивизацииСтроки()

Описание:

Возникает при смене текущей строки поля списка.

ПриИзмененииПометки

Синтаксис:

ПриИзмененииПометки()

Описание:

Возникает при изменении пометки строки поля списка.


2-168 Полоса регулирования

ПолосаРегулирования (TrackBar)

Полоса регулирования предназначена для наглядного визуального изменения числовых значений. Изменение значения связанной переменной происходит от минимального до максимального установленного значения при перемещении "движка" по самой полосе регулирования. Перемещение "движка" может осуществляться с помощью мыши, клавишами управления курсором и клавишами PgUp и PgDn.

Свойства

БольшойШаг (LargeStep)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит число, на которое изменится значение элемента управления при перемещении на один большой шаг. Перемещение большими шагами осуществляется при нажатии клавиш PgUp и PgDn.

Доступность (Enable)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак доступности полосы регулирования.

Значение (Value)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит значение, введенное в элементе управления.

МаксимальноеЗначение (MaxValue)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит максимальное значение диапазона изменения. Это значение устанавливается при перемещении "движка" в крайнее правое (нижнее) положение.

МинимальноеЗначение (MinValue)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит минимальное значение диапазона изменения. Это значение устанавливается при перемещении "движка" в крайнее левое (верхнее) положение.

Ориентация (Orientation)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление Ориентация. Содержит способ ориентации полосы регулирования.

Примечание:

При ориентации Авто полоса регулирования отображается горизонтально, если ее горизонтальный размер больше или равен вертикальному. Если вертикальный размер больше горизонтального - полоса регулирования отображается вертикально.

ОтображениеРазметки (MarkingStyle)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ОтображениеРазметкиПолосыРегулирования. Содержит способ, которым будет отображаться разметка полосы регулирования.

Примечание:

При отображении разметки по одной из сторон полосы регулирования сама полоса будет прижиматься к противоположной границе элемента управления. Например, если разметка отображается снизу, полоса регулирования будет прижата к верхней границе элемента управления. При отображении разметки по обеим сторонам или отключении отображения разметки полоса регулирования будет центрироваться в элементе управления.

Подсказка (ToolTipText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст всплывающей подсказки, которая появляется при наведении курсора.

ПрозрачныйФон (Transparent)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак прозрачности фона.

Рамка (Border)

Использование:

Чтение и запись.

Описание:

Тип: Рамка. Содержит параметры рамки вокруг полосы регулирования.

ЦветРамки (BorderColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет рамки "движка", самой полосы регулирования и всего элемента управления, если у него есть рамка.

Примечание:

Не используется, если рамка имеет стиль Выпуклая или Вдавленная - в этом случае рамка рисуется притененным цветом от цвета фона.

ЦветТекста (TextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет, которым отображается разметка полосы регулирования.

ЦветФона (BackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона полосы регулирования.

ЦветФонаКнопки (ButtonBackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона "движка" и самой полосы регулирования.

Шаг (Step)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит число, на которое изменится значение элемента управления при перемещении на один шаг. Определяет порог чувствительности полосы регулирования. Перемещение по шагам осуществляется при нажатии клавиш управления курсором.

ШагРазметки (MarkingStep)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит значение шага, с которым будет отображаться разметка полосы регулирования.

События

ПриИзменении (OnChange)

Синтаксис:

ПриИзменении()

Описание:

Возникает после интерактивного перемещения "движка" полосы регулирования. В момент возникновения этого события значение элемента управления соответствует новому положению "движка".


2-174 Разделитель. Рамка группы

Разделитель (Splitter)

Разделитель предназначен для интерактивного изменения пользователем частей редактируемой формы, разделенных этим элементом управления.

Свойства

Доступность (Enable)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак доступности разделителя.

Ориентация (Orientation)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление Ориентация. Содержит ориентацию разделителя. Горизонтальный разделитель делит окно формы на верхнюю и нижнюю части, вертикальный - на правую и левую.

Примечание:

При ориентации Авто разделитель отображается горизонтально, если его горизонтальный размер больше или равен вертикальному. Если вертикальный размер больше горизонтального - разделитель отображается вертикально.

Подсказка (ToolTipText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст всплывающей подсказки, которая появляется при наведении курсора.

Рамка (Border)

Использование:

Чтение и запись.

Описание:

Тип: Рамка. Содержит параметры рамки разделителя.

ЦветРамки (BorderColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет рамки разделителя.

Примечание:

Не используется, если рамка имеет стиль Выпуклая или Вдавленная - в этом случае рамка рисуется притененным цветом от цвета фона.

ЦветФона (BackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона разделителя.

РамкаГруппы (GroupBox)

Рамка группы используется для визуальной группировки нескольких элементов управления.

Свойства

Доступность (Enable)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак доступности рамки.

Заголовок (Caption)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст подписи рамки группы.

Примечание:

Для рамок типа Одинарная и Двойная заголовок отображается на самой рамке. Для рамок типа Выпуклая и Вдавленная заголовок отображается внутри рамки.

Подсказка (ToolTipText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст всплывающей подсказки, которая появляется при наведении курсора.

ПрозрачныйФон (Transparent)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак прозрачности фона.

Рамка (Border)

Использование:

Чтение и запись.

Описание:

Тип: Рамка. Содержит тип рамки группы.

Примечание:

Имеет смысл, только если свойство СкругленнаяРамка содержит значение Ложь.

СкругленнаяРамка (RoundedGroupbox)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак отображения рамки со скругленными углами.

Примечание:

Если свойство имеет значение Истина, то свойство Рамка (выбор типа рамки) не имеет смысла. В этом случае тип рамки всегда Одинарная.

ЦветРамки (BorderColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет рамки группы.

Примечание:

Не используется, если рамка имеет стиль Выпуклая или Вдавленная - в этом случае рамка рисуется притененным цветом от цвета фона.

ЦветТекста (TextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста рамки группы.

ЦветФона (BackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона рамки группы.

Шрифт (Font)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Содержит шрифт текста рамки.


2-180 Табличное поле

Табличное поле

Табличное поле - элемент управления, позволяющий работать с различными списками, наборами записей, табличными полями, а также динамическими наборами данных ТаблицаЗначений и ДеревоЗначений.

Тип значения строки табличного поля зависит от типа связанного с табличным полем значения.

ТабличноеПоле (ТаblеВох)

Используется для доступа к свойствам методам и событиям табличного поля в целом.

Свойства

АвтоВводНовойСтроки

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак автоматического ввода новой строки. В этом режиме новая строка вводится в табличное поле автоматически после окончания редактирования последнего элемента предыдущей строки.

ВертикальнаяПолосаПрокрутки

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ИспользованиеПолосыПрокрутки. Содержит признак использования вертикальной полосы прокрутки табличного поля.

ВертикальныеЛинии (VerticalLines)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак видимости вертикальных линий - разделителей колонок.

ВыделенныеСтроки (SelectedLines)

Использование:

Только чтение.

Описание:

Тип: ВыделенныеСтроки. Содержит коллекцию выделенных строк табличного поля.

См. также:

ВыделенныеСтроки.

ВысотаПодвапа (FooterHeight)

Использование:

Чтение и запись.

Описание:

Тип: Число. Высота подвала табличного поля в строках.

См. также:

Колонка табличного поля.

ВысотаШапки (HeaderHeight)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит высоту шапки табличного поля в строках.

ГоризонтальнаяПолосаПрокрутки (HorizontalScrollBar)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ИспользованиеПолосыПрокрутки. Содержит признак использования горизонтальной полосы прокрутки табличного поля.

ГоризонтальныеЛинии (HorizontalLines)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак видимости горизонтальных линий - разделителей строк.

Доступность (Enable)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак доступности табличного поля.

Значение (Value)

Использование:

Чтение и запись.

Описание:

Содержит значение связанной переменной.

Колонки (Columns)

Использование:

Чтение и запись.

Описание:

Тип: Колонки. Содержит коллекцию колонок табличного поля.

См. также:

Колонки.

НачальноеОтображениеДерева (InitialTreeView)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление НачальноеОтображениеДерева. Определяет вариант начального отображения дерева связанного с табличным полем списка при открытии.

Примечание:

Используется, если связанный с табличным полем список отображается в виде дерева.

НачальноеОтображениеСписка (InitialListView)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление НачальноеОтображениеСписка. Определяет вариант перехода на строку связанного с табличным полем списка или набора данных при открытии.

Подвал (Footer)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Определяет наличие подвала у табличного поля.

Подсказка (ToolTipText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст всплывающей подсказки, которая появляется при наведении курсора.

Рамка (Border)

Использование:

Чтение и запись.

Описание:

Тип: Рамка. Содержит параметры рамки вокруг табличного поля.

РежимВводаСтрок (LineslnputMode)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление РежимВводаСтрокТабличногоПоля. Содержит режим интерактивного ввода новых строк в табличное поле. Режим задает, куда именно будут вставлены строки табличного документа.

РежимВыбора (ChoiceMode)

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит признак того, что табличное поле находится в режиме выбора.

Текущая Колонка (CurrentColumn)

Использование:

Чтение и запись.

Описание:

Тип: Колонка табличного поля. Содержит текущую колонку табличного поля. Если данному свойству присвоить значение Колонка табличного поля, то произойдет активизация указанной колонки, если устанавливается значение Неопределено, то активная колонка сбрасывается.

См. также:

Колонка табличного поля. ТабличноеПоле, свойство ТекущаяСтрока.

ТекущаяСтрока (CurrentLine)

Использование:

Чтение и запись.

Описание:

Содержит текущую строку табличного поля.

Примечание:

Тип значения строки табличного поля приведен в описаниях расширений табличного поля у соответствующий объектов.

См. также:

ТабличноеПоле, свойство ТекущаяКолонка.

ТекущиеДанные (CurrentData)

Использование:

Только чтение.

Описание:

Содержит данные текущей строки табличного поля.

Примечание:

Тип значения данных строки табличного поля приведен в описаниях расширений табличного поля у соответствующий объектов.

ТекущийРодитель (CurrentParent)

Использование:

Чтение и запись.

Описание:

Содержит текущего родителя в режиме иерархического списка.

Примечание:

Тип зависит от типа значения, которое содержится в табличном поле.

ТолькоПросмотр (Readonly)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак возможности/невозможности интерактивного изменения содержимого табличного поля. Если значение свойства Истина, то возможен только просмотр табличного поля.

Примечание:

В отличие от свойства Доступность, если свойство ТолькоПросмотр равно Истина, становится невозможным редактирование табличного поля, однако на остальную работу с полем это не влияет Например, можно выделить строковое представление содержимого табличного поля и скопировать в буфер обмена.

ФиксацияСлева (FixedLeft)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит количество зафиксированных слева колонок. Зафиксированные колонки остаются на месте при горизонтальной прокрутке табличного поля.

ФиксацияСправа (FixedRight)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит количество зафиксированных справа колонок. Зафиксированные колонки остаются на месте при горизонтальной прокрутке табличного поля.

ЦветРамки (BorderColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет рамки вокруг табличного поля.

Примечание:

Не используется, если рамка имеет стиль Выпуклая или Вдавленная - в этом случае рамка рисуется притененным цветом от цвета фона.

ЦветТекстаВыделения (SelectionTextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста выделенных ячеек табличного поля.

ЦветТекстаПодвала

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста подвала табличного поля.

См. также:

Колонка табличного поля, свойство ЦветТекстаПодвала.

ЦветТекстаШапки (HeaderTextCotor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста шапки табличного поля.

См. также:

Колонка табличного поля, свойство ЦветТекстаШапки.

ЦветФонаВыделения

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона выделенных ячеек табличного полу.

ЦветФонаПодвала (FooterBackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона подвала табличного поля.

См. также:

Колонка табличного поля, свойство ЦветФонаПодвала.

ЦветФонаПоля (FieldBackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона табличного поля.

См. также:

Колонка табличного поля, свойство ЦветФонаПоля.

ЦветФонаЧередованияСтрок

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона чередования строк.

См. также:

ТабличноеПоле, свойство ЧередованиеЦветовСтрок.

ЦветФонаШапки (HeaderBackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона шапки табличного поля.

См. также:

Колонка табличного поля, свойство ЦветФонаШапки.

ЧередованиеЦветовСтрок (UseAlternationLinesColor)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак чередования цветов строк.

См. также:

ТабличноеПоле, свойство ЦветФонаЧередованияСтрок

Шапка (Header)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Определяет наличие шапки у табличного поля.

ШрифтПодвала (FooterFont)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Содержит шрифт, используемый при выводе надписей в подвале табличного поля.

ШрифтШапки (HeaderFont)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Содержит шрифт, используемый при выводе надписей в шапке табличного поля.


2-194 Табличное поле. Свойства. Методы

Методы

ДобавитьСтроку (AddLine)

Синтаксис:

ДобавитьСтроку()

Описание:

Добавляет строку в табличное поле, аналогично выполнению команды "Добавить".

Если табличное поле связано с таблицей или деревом значений, метод добавляет строку в таблицу или дерево значений (аналогично соответствующим методам этих объектов).

Если табличное поле связано со списком объектов, хранимых в информационной базе, метод начинает редактирование нового объекта этого списка. (Например, список объектов в форме списка справочника, или документа).

Если табличное поле связано с набором записей или табличной частью, то метод начинает редактирование новой записи. (Например, список записей в форме списка регистра сведений; табличная часть документа или справочника).

Примечание:

Если табличное поле связано с набором записей регистра сведений, то новые записи можно вводить "вручную" только если для регистра установлен режим записи "Независимый" (задается при конфигурировании). Если набор записей принадлежит регистру накопления либо для регистра сведений установлен режим записи "Подчинение регистратору", то добавление новых "ручных" записей не допускается.

Пример:

ЭлементыФормы.ТП.ДобавитьСтроку() ;

ИзменитьСтроку (ChangeLine)

Синтаксис:

ИзменитьСтроку()

Описание:

Начинает интерактивное изменение данных текущей строки, аналогично выполнению команды "Изменить".

Примечание:

Если табличное поле связано с набором записей регистра сведений, то записи можно изменять "вручную" только если для регистра установлен режим записи "Независимый" (задается при конфигурировании). Если набор записей принадлежит регистру накопления либо для регистра сведений устаЕювлен режим записи "Подчинение регистратору", то "ручное" изменение записей не допускается.

Пример:

ЭлементыФормы.ТП.ИзменитьСтроку();

Развернут (Expanded)

Синтаксис:

Развернут(<Строка>)

Параметры:

<Строка> Обязательный

Строка табличного поля. Тип значения строки табличного поля приведен в описаниях расширений табличного поля у соответствующий объектов.

Возвращаемое значение:

Тип: Булево.

Описание:

Проверяет, развернут ли узел дерева в указанной строке.

Примечание:

Используется в случае, если с табличным полем связано дерево значений или список справочника в виде дерева.

Пример:

УзелРазвернут = ЭлементыФормы.ТП1.Развернут(Строка);

Развернуть (Expand)

Синтаксис:

Развернуть(<Строка> , <С подчиненными>)

Параметры:

<Строка> Обязательный

Строка табличного поля. Тип значения строки табличного поля приведен в описаниях расширений табличного поля у соответствующий объектов.

<С подчиненными> Необязательный

Тип: Булево. Истина - раскрывать подчиненные узлы. Ложь - не раскрывать подчиненные узлы.

Значение по умолчанию: Ложь.

Описание:

Разворачивает узел в указанной строке дерева.

Примечание:

Используется в случае, если с табличным полем связано дерево значений или список справочника в виде дерева.

Пример:

// Разворот текущей строки в дереве:
ЭлементыФормы.ТП.Развернуть(ЭлементыФормы.ТП.ТекущаяСтрока, Истина);

Свернуть (Collapse)

Синтаксис:

Свернуть(< Строка>)

Параметры:

<Строка> Обязательный

Строка табличного поля. Тип значения строки табличного поля приведен в описаниях расширений табличного поля у соответствующий объектов.

Описание:

Сворачивает узел в указанной строке дерева.

Примечание:

Используется в случае, если с табличным полем связано дерево значений или список справочника в виде дерева.

Пример:

УзелРазвернут = ЭлементыФормы.ТП1.Развернут(Строка);

СкопироватьСтроку (CopyLine)

Синтаксис:

СкопироватьСтроку()

Описание:

Копирует текущую строку табличного поля, аналогично выполнению команды "Добавить копированием".

Если табличное поле связано с таблицей или деревом значений, метод добавляет копию текущей строки в таблицу или дерево значений (аналогично соответствующим методам этих объектов).

Если табличное поле связано со списком объектов, хранимых в информационной базе, метод начинает редактирование нового объекта - копии текущего. (Например, список объектов в форме списка справочника, или документа).

Если табличное поле связано с набором записей или табличной частью, то метод начинает редактирование новой записи - копии текущего (Например, список записей в форме списка регистра сведений, табличная часть документа или справочника).

Примечание:

Если табличное поле связано с набором записей регистра сведений, то новые записи можно вводить "вручную" только если для регистра установлен режим записи "Независимый" (задается при конфигурировании). Если набор записей принадлежит регистру накопления либо для регистра сведений установлен режим записи "Подчинение регистратору", то добавление новых "ручных" записей не допускается.

Пример:

ЭлементыФормы.ТП.СкопироватьСтроку();

События

Выбор (Select)

Синтаксис:

Выбор(<Выбранная строка> , <Колонка>, <Стандартная обработка>)

Параметры:

<Выбранная строка>

Выбранная строка табличного поля. Тип значения строки табличного поля приведен в описаниях расширений табличного поля у соответствующий объектов

<Колонка>

Тип Колонка табличного поля. Выбранная колонка табличного поля

<Стандартная обработка>

Тип: Булево В данный параметр передается признак выполнения стандартной (системной) обработки события. Если в теле процедуры-обработчика установить данному параметру значение Ложь стандартная обработка события производиться не будет.

Описание:

Возникает при двойном щелчке мыши (нажатии клавиши Enter) на ячейке табличного поля

ПриАктивизацииСтроки (OnActivateLine)

Синтаксис:

ПриАктивизацииСтроки()

Описание:

Возникает при активизации строки табличного поля.

См. также:

ТабличноеПоле, событие ПриАктивизацииКолонки.
ТабличноеПоле, событие ПриАктивизацииЯчейки.

ПриАктивизацииКолонки (OnActivateColumn)

Синтаксис:

ПриАктивизацииКолонки()

Описание:

Возникает при активизации колонки табличного поля.

См. также:

ТабличноеПоле, событие ПриАктивизацииСтроки.
ТабличноеПоле, событие ПриАктивизацииЯчейки.

ПриАктивизацииЯчейки (OnActivateCell)

Синтаксис:

ПриАктивизацииЯчейки()

Описание:

Возникает при активизации ячейки табличного поля.

Примечание:

Ячейка активизируется при изменении текущей строки и/или колонки. Последовательность возникновения событий: АктивизацияСтроки, АктивизацияКолонки, АктивизацияЯчейки.

См. также:

ТабличноеПоле, событие ПриАктивизацииСтроки.
ТабличноеПоле, событие ПриАктивизацииКолонки.

ПередНачаломДобавления (BeforeAddLine)

Синтаксис:

ПередНачаломДобавления (<Отказ>, <Копирование>}

Параметры:

<Отказ>

Тип: Булево. Отказ от добавления строки. Если в теле процедуры-обработчика установить данному параметру значение Истина, строка не будет добавлена.

<Копирование>

Тип: Булево. Признак добавления строки копированием. Если происходит копирование, то значение параметра Истина.

Описание:

Возникает перед началом интерактивного добавления строки.

ПередНачаломИзменения (BeforeChangeLine)

Синтаксис:

ПередНачаломИзменения(<Отказ>)

Параметры:

<Отказ>

Тип Булево. Отказ от изменения. Если в теле процедуры-обработчика установить данному параметру значение Истина, интерактивное изменение строки не начнется.

Описание:

Возникает перед началом интерактивного изменения строки табличного поля.

ПередУдалением (BeforeDeleteLine)

Синтаксис:

ПередУдалением (<Отказ>)

Параметры:

<Отказ>

Тип Булево. Отказ от удаления Если в теле процедуры-обработчика установить данному параметру значение Истина, удаление строки табличного поля не будет выполнено

Описание:

Возникает перед удалением строки или группы строк табличного поля

ПриНачалеРедактирования (OnStartEdit)

Синтаксис:

ПриНачалеРедактирования(<Новая строка>)

Параметры:

<Новая строка>

Тип Булево. Признак редактирования новой строки Имеет значение Истина, если строка была добавлена или скопирована.

Описание:

Возникает при начале редактирования старой или добавленной строки табличного поля. В процедуре - обработчике события нельзя отказаться от редактирования, но могут быть выполнены действия, необходимые при вводе новой строки, например установка начальных значений.

Примечание:

Событие возникает, если редактирование производится непосредственно в табличном поле. Перед данным событием возникает событие ПрередНачаломИзменения.

См. также:

ТабличноеПоле, событие ПередНачаломИзменения.

ПриОкончанииРедактирования (OnFinishEdit)

Синтаксис:

ПриОкончанииРедактирования (< Новая строка> )

Параметры:

<Новая строка>

Тип: Булево. Признак редактирования новой строки. Имеет значение Истина, если строка была добавлена или скопирована.

Описание:

Возникает после окончания редактирования строки табличного поля.

Примечание:

Событие возникает, если редактирование производится непосредственно в табличном поле.

См. также:

ТабличноеПоле, событие ПриНачалеРедактирования.

ПриСменеТекущегоРодителя (OnCurrentParentChanging)

Синтаксис:

ПриСменеТекущегоРодителя()

Описание:

Возникает при изменении текущего родителя в режиме иерархического списка.

См. также:

ТабличноеПоле, свойство ТекущийРодитель.

ПриВыводеСтроки (OnOutputLine)

Синтаксис:

ПриВыводеСтроки(<Оформление строки> , <Данные строки>)

Параметры:

<Оформление строки>

Тип: ОформлениеСтроки. Объект, содержащий оформление строки (шрифт, цвет) и коллекцию оформлений ячеек.

<Данные строки>

Данные выводимой строки. Параметр соответствует свойству ТекущиеДанные для выводимой строки.

Описание:

Возникает при выводе строки в табличном поле. В процедуре -обработчике события допускается изменение оформления как строки в целом, так и каждой ячейки в отдельности.

ВыборЗначения (ChooseValue)

Синтаксис:

Выбор3начения(<Стандартная обработка>)

Параметры:

<Стандартная обработка>

Тип: Булево. В данный параметр передается признак выполнения стандартной (системной) обработки события. Если в теле процедуры-обработчика установить данному параметру значение Ложь стандартная обработка события производиться не будет.

Описание:

Возникает при двойном щелчке мыши (нажатии клавиши Enter) на ячейке табличного поля, а также при выборе строки в табличном поле посредством команды "Выбрать значение" по кнопке или кнопке командного интерфейса.

Примечание:

При двойном щелчке мыши (нажатии клавиши Enter) на ячейке табличного документа данное событие следует после события Выбор. При этом если в обработчике события Выбор установить параметру Стандартная обработка значение Ложь, то событие ПриВыбореЗначения не возникнет.

См. также:

ТабличноеПоле, событие Выбор.


2-204 Колонки

Колонки (Columns)

Представляет собой коллекцию колонок табличного поля.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа Колонка табличного поля. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции. Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс колонки.

См. также:

ТабличноеПоле, свойство Колонки.

Методы

Вставить (Insert)

Синтаксис:

Вставить(<Индекс>, <Текст шапки>)

Параметры:

<Индекс> Обязательный

Тип: Число. Индекс вставляемой колонки. Если индекс равен количеству колонок, то происходит добавление колонки в конец коллекции.

<Текст шапки> Необязательный

Тип: Строка. Текст, который будет выводиться в заголовке колонки табличного поля.

Возвращаемое значение:

Тип: Колонка табличного поля. Вставленная колонка табличного поля.

Описание:

Вставляет колонку в заданную позицию коллекции колонок табличного поля.

Пример:

ЭлементыФормы.ТП.Колонки.Вставить(0, "Наименование");

Добавить (Add)

Синтаксис:

Добавить(< Текст шапки>)

Параметры:

<Текст шапки> Необязательный

Тип: Строка. Текст, который будет выводиться в заголовке колонки табличного доля.

Возвращаемое значение:

Тип: Колонка табличного поля. Добавленная колонка табличного поля.

Описание:

Добавляет колонку в конец коллекции колонок табличного поля.

Пример:

ЭлементыФормы.ТП.Колонки.Добавить("Код");

Индекс (IndexOf)

Синтаксис:

Индекс(< Элемент>)

Параметры:

<Элемент> Необязательный

Тип: Колонка табличного поля. Колонка табличного поля.

Возвращаемое значение:

Тип: Число. Индекс колонки в коллекции колонок.

Описание:

Получает индекс колонки в коллекции колонок.

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество колонок

Описание:

Позволяет получить количество колонок табличного поля.

Пример:

ВсегоКолонок = ЭлементыФормы.ТП.Колонки.Количество();

Очистить (Clear)

Синтаксис:

Очистить()

Описание:

Удаляет все колонки табличного поля.

Пример:

ЭлементыФормы.ТП.Колонки.Очистить();

Сдвинуть (Move)

Синтаксис:

Сдвинуть(<Колонка>, <Смещение>)

Параметры:

<Колонка> Обязательный

Тип: Число, Колонка табличного поля. Индекс колонки, которую нужно сдвинуть, либо сама колонка.

<Смещение> Обязательный

Тип: Число. Количество колонок, на которое нужно переместить колонку. Положительное значение означает, что колонка будет передвинута ближе к концу коллекции (вправо), отрицательное - ближе к началу (влево).

Описание:

Позволяет переместить колонку на указанное число позиций.

Удалить (Remove)

Синтаксис:

Удалить(<Индекс>)

Параметры:

<Индекс> Обязательный

Тип: Число, Колонка табличного поля. Индекс удаляемой колонки, либо сама колонка.

Описание:

Удаляет заданную колонку из табличного поля.

Пример:

// Удаление первой колонки:
ЭлементыФормы.ТП.Колонки.Удалить(0);

Колонка табличного поля

Используется для доступа к колонке табличного поля.

Свойства

Видимость (Visible)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак видимости колонки.

ВыделятьОтрицательные (MarkNegatives)

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит признак выделения текста ячейки, содержащей отрицательное число, специальным цветом. Цвет выделения имеет название "Отрицательные числа" в используемом для формы стиле.

ГоризонтальноеПоложениеВКолонке (DataHorizontalAlign)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ГоризонтальноеПоложение. Содержит способ горизонтального расположения текста в колонке.

ГоризонтальноеПоложениеВПодвале (FooterHorizontalAlign)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ГоризонтальноеПоложение. Содержит способ горизонтального расположения текста в подвале табличного поля.

ГоризонтальноеПоложениеВШапке

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ГоризонтальноеПоложение. Содержит способ горизонтального расположения текста в шапке колонки.

ДoпoлнитeльнaяKapтинкaШaпки

Использование:

Чтение и запись.

Описание:

Тип. Картинка. Содержит дополнительную пиктограмму, расположенную в шапке колонки. Картинка располагается с правой стороны колонки

Примечание:

Рекомендуемый размер картинки 14х14 пикселей.

Доступность (Enable)

Использование:

Чтение и запись.

Описание:

Тип- Булево. Содержит признак доступности колонки.

ИзменениеРазмера (SizeChange)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ИзменениеРазмераКолонки. Содержит признак изменения размера колонки.

Имя (Name)

Использование:

Чтение и запись.

Описание:

Содержит имя колонки.

КартинкаПодвала (HeaderPicture)

Использование:

Чтение и запись.

Описание:

Тип: Картинка. Содержит картинку, расположенную в подвале колонки.

Примечание:

Рекомендуемый размер картинки 14х14 пикселей.

КартинкаШапки (HeaderPicture)

Использование:

Чтение и запись.

Описание:

Тип: Картинка. Содержит картинку, расположенную в шапке колонки.

Примечание:

Рекомендуемый размер картинки 14х14 пикселей.

КартинкиСтрок (LinesPictures)

Использование:

Чтение и запись.

Описание:

Тип: Картинка. Содержит картинку, которая может выводиться в поле данных колонки.

Примечание:

Рекомендуемый размер картинки 14х14 пикселей.

ОтображатьВПодвале (ShowlnFooter)

Использование:

Чтение и запись.

Описание:

Тип. Булево. Содержит признак отображения подвала колонки в подвале табличного поля.

Примечание:

Подвал колонки в подвале табличного поля можно не выводить, если колонки расположены одна под другой.

ОтображатьВШапке (ShowlnHeader)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак отображения шапки колонки в шапке табличного поля.

Примечание:

Шапку колонки в шапке табличного поля можно не выводить, если колонки расположены одна под другой.

ПодсказкаВШапке (HeaderToolTipText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст подсказки в шапке колонки.

Положение (Location)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ПоложениеКолонки. Определяет положение колонки по отношению к предыдущей.

ПропускатьПриВводе (SkipWhenlnput)

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит признак того, что данная колонка будет пропущена при переходе по колонкам по нажатию клавиши Enter.

ТекстПодвала (FooterText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст подвала колонки.

ТекстШапки (HeaderText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст шапки колонки.

ТолькоПросмотр (Readonly)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак возможности/невозможности интерактивного изменения значения, введенного в ячейки колонки табличного поля.

Примечание:

В отличие от свойства ТолькоПросмотр объекта Табличное поле данное свойство определяет возможность редактирования только для одной колонки. В отличие от свойства Доступность, если свойство ТолькоПросмотр равно Истина, становится невозможным редактирование колонки табличного поля, однако на остальную работу с полем это не влияет. Например, можно выделить строковое представление содержимого колонки табличного поля и скопировать в буфер обмена.

ТриСостояния (ThreeState)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак того, что флажок в колонке может иметь три состояния: "Включен", "Выключен", "Не определено".

Примечание:

Имеет смысл, если для колонки задано значение флажка.

ЦветТекстаПодвала (FooterTextColor)

Использование:

Чтение и запись.

Описание:

Тип. Цвет. Содержит цвет текста подвала колонки.

См. также:

ТабличноеПоле, свойство ЦветТекстаПодвала.

ЦветТекстаПоля (DataTextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста поля данных колонки.

ЦветТекстаШапки (HeaderTextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста шапки колонки.

См. также:

ТабличноеПоле, свойство ЦветТекстаШапки.

ЦветФонаПодвала

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона подвала колонки.

См. также:

ТабличноеПоле, свойство ЦветФонаПодвала.

ЦветФонаПоля (DataBackCoIor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона поля данных колонки.

См. также:

ТабличноеПоле, свойство ЦветФонаПоля.

ЦветФонаШапки (HeaderBackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона шапки колонки.

См. также:

ТабличноеПоле, свойство ЦветФонаЩапки.

Ширина (Width)

Использование:

Чтение и запись.

Описание:

Тип: Число. Содержит ширину колонки в символах.

ШрифтПодвала (FooterFont)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Шрифт текста подвала.

См. также:

ТабличноеПоле, свойство ШрифтПодвала.

ШрифтТекста (DataFont)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Содержит шрифт, которым выводятся данные в колонке.

ШрифтШапки (HeaderFont)

Использование:

Чтение и запись.

Описание:

Тип Шрифт. Содержит шрифт текста шапки колонки.

См. также:

ТабличноеПоле, свойство ШрифтШапки.

ЭлементУправления (Control)

Использование:

Только чтение.

Описание:

Тип: ПолеВвода, ПолеВыбора, Флажок. Содержит элемент управления, который будет использован в качестве редактора значения ячейки в данной колонке табличного поля.

Методы

УстановитьЭлементУправления (SetControl)

Синтаксис:

УстановитьЭлементУправления(< Тип элемента управления>)

Параметры:

<Тип элемента управления> Обязательный

Тип: Тип. Тип элемента управления, устанавливаемого в качестве редактора.

Описание:

Устанавливает новый вид элемента управления, используемого в качестве редактора значения ячейки данной колонки табличного поля.

Пример:

ТекКолонка = ЭлементыФормы.ТП1.Колонки[2];
ТекКолонка.УстановитьЭлементУправления(Тип("Флажок"));


2-220 ВыделенныеСтроки. ОформлениеСтроки. ОформлениеЯчейки

ВыделенныеСтроки (SelectedUnes)

Представляет собой коллекцию выделенных строк табличного поля.

Данный объект является коллекцией значений. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются строки табличного поля.. Возможно обращение к строке табличного поля посредством оператора [...]. В качестве аргумента передается индекс строки.

См. также:

ТабличноеПоле, свойство ВыделенныеСтроки.

Методы

Добавить (Add)

Синтаксис:

Добавить(<Строка>)

Параметры:

<Строка> Обязательный

Строка табличного поля. Тип значения строки табличного поля приведен в описаниях расширений табличного поля у соответствующий объектов.

Описание:

Устанавливает выделение на указанную строку.

Пример:

ЭлементыФормы.ТП.ВыделенныеСтроки.Добавить(ТекСтрока);

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество выделенных строк.

Описание:

Позволяет получить количество выделенных строк табличного поля.

Пример:

КолВо = ЭлементыФормы.ТабличноеПоле1.ВыделенныеСтроки.Количество();

Очистить (Clear)

Синтаксис:

Очистить()

Описание:

Снимает выделение со всех строк.

Удалить (Remove)

Синтаксис:

Удалить(<Строка>)

Параметры:

<Строка> Обязательный

Строка табличного поля. Тип значения строки табличного поля приведен в описаниях расширений табличного поля у соответствующий объектов.

Описание:

Снимает выделение с указанной строки.

ОформлениеСтроки

Определяет оформление строки табличного документа. Используется для определения значений типа ОформлениеСтроки.

См.также:

ОформлениеЯчейки. ТабличноеПоле, событие ПриВыводеСтроки.

Свойства

ЦветТекста (TextColor)

Использование:

Чтениe и запись.

Описание:

Тип: Цвет. Содержит цвет текста строки.

ЦветФона (BackColor)

Использование:

Чтениe и запись.

Описание:

Тип: Цвет. Содержит цвет фона строки.

Шрифт (Font)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Содержит шрифт строки.

Ячейки (Cells)

Использование:

Чтение и запись.

Описание:

Содержит коллекцию значений ОформлениеЯчейки для строки

См. также:

ОформлениеЯчейки.

ОформлениеЯчейки

Определяет оформление ячейки табличного документа. Используется для определения свойства Ячейки объекта ОформлениеСтроки.

Пример:

Для каждого ОформлениеЯчейки из ОформлениеСтроки.Ячейки Цикл
ОформлениеЯчейки.ЦветФона = Новый Цвет(5, 12, 120);
КонецЦикла ;

См. также:

ОформлениеСтроки.

Свойства

Выравнивание (Align)

Использование:

Чтение и запись.

Описание:

Тип системное перечисление ГоризонтальноеПоложение Содержит режим выравнивания текста в ячейке по горизонтали.

ИндексКартинки (Picturelndex)

Использование:

Чтение и запись.

Описание:

Тип. Число. Индекс картинки в коллекции картинок.

Картинка (Picture)

Использование:

Чтение и запись.

Описание:

Тип: Картинка. Содержит картинку, выводимую в ячейке.

Примечание:

Рекомендуемый размер картинки 14х14 пикселей.

См. также:

ОформлениеЯчейки, свойство ОтображатьКартинку.

ОтображатьКартинку (ShowPicture)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак отображения картинки в ячейке.

ОтображатьТекст (ShowText)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак отображения текста.

Примечание:

Текст ячейки можно не отображать, если с ней связано значение тип Булево или Число и для отображения этого значения используется флажок.

ОтображатьФлажок (ShowCheck)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак отображения флажка в ячейке.

Примечание:

Имеет смысл для колонок типа Число и Булево. Флажок со значением типа Булево может иметь только два состояния (Истина - установлен, Ложь - снят), со значением типа Число может иметь три состояния (1 - установлен, 0 - снят, 2 - не определено).

Текст (Text)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст ячейки.

ТолькоПросмотр (Readonly)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Определяет возможность редактирования ячейки.

Примечание:

Если свойство ТолькоПросмотр равно Истина, становится невозможным редактирование ячейки табличного поля, однако на остальную работу с ячейкой это не влияет. Например, можно выделить строковое представление содержимого ячейки и скопировать в буфер обмена.

Флажок (Check)

Использование:

Чтение и запись.

Описание:

Тип: Число, Булево. Содержит значение флажка.

Примечание:

Флажок со значением типа Булево может иметь только два состояния (Истина - установлен, Ложь - снят), со значением типа Число может иметь три состояния (1 - установлен, 0 -снят, 2 - не определено).

ЦветТекста (TextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста ячейки.

Примечание:

Имеет более высокий приоритет, чем цвет текста строки.

ЦветФона (BackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона ячейки.

Примечание:

Имеет более высокий приоритет, чем цвет фона строки.

Шрифт (Font)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Содержит шрифт ячейки.

Примечание:

Имеет более высокий приоритет, чем шрифт строки.

Расширение элементов управления расположенных в табличном поле

Дополнительные параметры событий элемента управления в табличном поле. Эти параметры появляются у любого элемента управления расположенного в табличном поле.

События

<Имя события>

Синтаксис:

<Имя события>(<Элемент>, <...>)

Параметры:

<Элемент>

Тип: тип параметра соответствует типу элемента управления, который инициировал событие. В данный параметр передается элемент управления, инициировавший событие.

<...>

Остальные параметры события элементов управления указываются после параметра <Элемент>.

Описание:

У всех событий элементов управления расположенных в табличном поле присутствует общий первый параметр.


2-230 Поля табличного и текстового документов

Поле табличного документа

ПолеТабличногоДокумента (TableDocumentField)

Поле табличного документа предназначено для использования табличного документа в форме. Поле табличного документа можно использовать для ввода данных пользователем и представления информации, хранимой в системе или полученной в результате расчетов.

Объект является визуальным представлением объекта ТабличныйДокумент и имеет все присущие ему свойства и методы.

См. также:

ТабличныйДокумент.

Свойства

ВертикальнаяПолосаПрокрутки (VerticalScrollBar)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак наличия у поля табличного документа вертикальной полосы прокрутки.

ГоризонтальнаяПолосаПрокрутки (HorizontalScroHBar)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак наличия у поля табличного документа горизонтальной полосы прокрутки.

Доступность (ЕпаЫе)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак доступности поля табличного документа, а также расположенных в нем элементов управления.

Рамка (Border)

Использование:

Чтение и запись.

Описание:

Тип: Рамка. Содержит рамку вокруг поля табличного документа.

ЦветРамки (BorderCotor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет границы вокруг поля табличного документа.

События

Выбор (Select)

Синтаксис:

Выбор(<Область>, <Стандартная обработка> )

Параметры:

<Область> (необязательный)

Тип: ОбластьЯчеекТабличногоДокумента. Область, с которой связано событие.

<Стандартная обработка> (необязательный)

Тип: Булево. В данный параметр передается признак выполнения стандартной (системной) обработки события. Если в теле процедуры-обработчика установить данному параметру значение Ложь стандартная обработка события производиться не будет.

Описание:

Возникает при двойном щелчке мыши (нажатии клавиши Enter) на ячейке или рисунке таблицы.

ОбработкаРасшифровки (ProcessDetails)

Синтаксис:

ОбработкаРасшифровки(<Расшифровка>, <Стандартная обработка>)

Параметры:

<Расшифровка> (необязательный)

Тип: Произвольный. Значение расшифровки ячейки или рисунка.

<Стандартная обработка> (необязательный)

Тип: Булево. В данный параметр передается признак выполнения стандартной (системной) обработки события. Если в теле процедуры-обработчика установить данному параметру значение Ложь стандартная обработка события производиться не будет.

Описание:

Возникает при двойном щелчке мыши (нажатии клавиши Enter) на ячейке или рисунке, которые содержат значение расшифровки.

Расширение элементов управления расположенных в поле табличного документа

Дополнительные свойства и методы элементов управления, расположенных в поле табличного документа.

Свойства

Верх (Top)

Использование:

Чтение и запись.

Описание:

Содержит положение верхней границы элемента управления, отсчитываемое от верхней границы табличного документа (в миллиметрах).

Видимость (Visible)

Использование:

Чтение и запись.

Описание:

Содержит признак видимости элемента управления.

ВстроенВЯчейку (EmbeddedIntoCell)

Использование:

Чтение и запись.

Описание:

Содержит признак того, что элемент встроен в ячейку табличного документа

ВыводитьНаПечать (Print)

Использование:

Чтение и запись.

Описание:

Содержит признак вывода на печать элемента управления.

Высота (Height)

Использование:

Чтение и запись.

Описание:

Содержит высоту элемента управления (в миллиметрах).

Лево (Left)

Использование:

Чтение и запись.

Описание:

Содержит положение левой границы элемента управления, отсчитываемое от левой границы табличного документа (в миллиметрах).

Ширина (Width)

Использование:

Чтение и запись.

Описание:

Содержит ширину элемента управления (в миллиметрах).

Методы

Расположить (Place)

Синтаксис:

Расположить(<Область ячеек>)

Параметры:

<0бласть ячеек> Обязательный

Тип: ОбластьЯчеекТабличногоДокумента. Область, в которой нужно расположить элемент управления.

Описание:

Позволяет расположить элемент управления в заданной области ячеек табличного документа.

События

<Имя события>

Синтаксис:

<Имя события>(<Элемент>, <...>)

Параметры:

<Элемент>

Тип. тип параметра соответствует типу элемента управления, который инициировал событие. В данный параметр передается элемент управления, инициировавший событие.

<...>

Остальные параметры события элементов управления указываются после параметра <Элемент>

Описание:

У всех событий элементов управления расположенных в поле табличного документа присутствует общий первый параметр.

ПолеТекстовогоДокумента (TextDocumentField)

Поле текстового документа предназначено для размещения в форме окна текстового редактора. Объект является визуальным представлением объекта ТекстовыйДокумент и имеет все присущие ему свойства и методы.

Свойства

Доступность (Enable)

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит признак доступности поля.

Рамка (Border)

Использование:

Только чтение.

Описание:

Тип: Рамка. Содержит параметры рамки вокруг поля текстового документа.

ЦветРамки (BorderColor)

Использование:

Только чтение.

Описание:

Тип: Цвет. Содержит цвет рамки вокруг поля текстового документа.

Примечание:

Не используется, если рамка имеет стиль Выпуклая или Вдавленная - в этом случае рамка рисуется притененным цветом от цвета фона.

Методы

ПолучитьВыделенныйТекст

Синтаксис:

ПолучитьВыделенныйТекст()

Возвращаемое значение:

Тип: Строка. Выделенный текст в виде строки.

Описание:

Получает выделенный текст поля текстового документа.

Пример:

ВыделенныйТекст = ЭлементыФормы.ПолеТекста.ПолучитьВыделенныйТекст();


2-237 Флажок

Флажок (CheckBox)

Флажок предназначен для выбора одного значения. Используются флажки, имеющие два либо три состояния. От типа связанного с флажком значения зависит количество состояний флажка: флажок со значением типа Булево может иметь только два состояния (установлен, снят), со значением типа Число может иметь три состояния (установлен, снят, не определено).

Свойства

ВертикальноеПоложение (VerticalAlignment)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ВертикальноеПоложение. Определяет способ вертикального расположения текста флажка.

ГоризонтальноеПоложение (HorizontalAlignment)

Использование:

Только чтение.

Описание:

Тип: системное перечисление ГоризонтальноеПоложение. Определяет способ горизонтального расположения текста флажка.

Доступность (Enable)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак доступности флажка.

Заголовок (Caption)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст флажка.

Примечание:

Если текст не умещается по ширине, он автоматически разбивается на несколько строк с переносом по словам. Если перенос по словам не возможен, видимый текст будет заканчиваться троеточием. Если разбитый на строки текст не умещается по высоте, то он будет прижат к верхней границе не зависимо от установленного способа выравнивания по вертикали, не уместившиеся строки не будут показаны.

Значение (Value)

Использование:

Чтение и запись.

Описание:

Содержит значение, введенное в элементе управления.

Примечание:

Состояния флажка для типа Булево: Ложь - флажок снят, Истина - флажок установлен.

Состояния флажка для типа Число: 0 - флажок снят, 1 - флажок установлен, 2 - не определено ("серый" флажок).

Подсказка (ToolTipText)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит текст всплывающей подсказки, которая появляется при наведении курсора.

ПоложениеЗаголовка (TitleLocation)

Использование:

Чтение и запись.

Описание:

Тип: системное перечисление ПоложениеЗаголовка. Определяет способ расположения текста флажка относительно флажка.

ПрозрачныйФон (Transparent)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак прозрачности фона.

Рамка (Border)

Использование:

Чтение и запись.

Описание:

Тип: Рамка. Содержит параметры рамки вокруг флажка.

ТриСостояния (ThreeState)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак того, что флажок может иметь три возможных состояния. Третье состояние - "серый флажок". Три состояния могут быть у флажка, если тип его свойства Значение - Число. Для типа Булево предусмотрено два состояния флажка.

ЦветРамки (BorderColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет рамки вокруг флажка.

Примечание:

Не используется, если рамка имеет стиль Выпуклая или Вдавленная - в этом случае рамка рисуется притененным цветом от цвета фона.

ЦветТекста (TextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет текста флажка.

ЦветТекстаПоля (FieldTextColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет галочки флажка.

ЦветФона (BackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Содержит цвет фона флажка.

ЦветФонаПоля (FieldBackColor)

Использование:

Чтение и запись.

Описание:

Тип: Цвет. Цвет фона, на котором изображается галочка флажка.

Шрифт (Font)

Использование:

Чтение и запись.

Описание:

Тип: Шрифт. Содержит шрифт текста флажка.

События

ПриИзменении (OnChange)

Синтаксис:

ПриИзменении()

Описание:

Возникает при установке/снятии флажка.


2-227 Свойства интерфейсных объектов

Свойства интерфейсных объектов

В данном разделе описаны объекты, которые, как правило, выступают свойствами интерфейсных объектов конфигурации. Это такие объекты как шрифт, цвет, рамка и т.п.

Цвет (Color)

Объект предназначен для определения и хранения значение цвета. Цвет может определяться абсолютным значением (сочетанием красного, синего и зеленого цветов), браться из элементов стиля, из палитры Windows, или использоваться один из web-цветов.

Может присваиваться в качестве значения атрибутов других объектов, параметров методов, процедур или функций, имеющих тип Цвет.

Пример:

ЦветВажнойКнопки = Новый Цвет (255, 0, 0); // красный
ЦветОбычнойКнопки = ЦветСтиля.ЦветФонаКнопки;
Если ОстатокТовара <= Товар.ТочкаЗаказа Тогда
ЭлементыФормы.КнопкаЗаказать.ЦветФонаКнопки = ЦветВажнойКнопки;
Иначе
ЭлементыФормы.КнопкаЗаказать.ЦветФонаКнопки = ЦветОбычнойКнопки;
КонецЕсли ;

Свойства

Вид (Kind)

Использование:

Только чтение.

Описание:

Тип: системное перечисление ВидЦвета. Содержит вид цвета.

Зеленый (G)

Использование:

Только чтение.

Описание:

Тип: Число. Содержит зеленую составляющую цвета.

Примечание:

Если цвет задан не абсолютным, то содержит -1.

Красный (R)

Использование:

Только чтение.

Описание:

Тип: Число. Содержит красную составляющую цвета.

Примечание:

Если цвет задан не абсолютным, то содержит -1.

Синий (В)

Использование:

Только чтение.

Описание:

Тип: Число. Содержит синюю составляющую цвета.

Примечание:

Если цвет задан не абсолютным, то содержит -1.

Конструкторы

Основной

Синтаксис:

Новый Цвет (< Красный>, <3еленый>, <Синий>)

Параметры:

<Красный> Обязательный

Тип: Число. Значение красной составляющей цвета.

<3еленый> Обязательный

Тип: Число. Значение зеленой составляющей цвета.

<Синий> Обязательный

Тип: Число. Значение синей составляющей цвета.

Описание:

Формирует абсолютный цвет из трех цветовых составляющих.


2-246 Шрифт

Шрифт (Font)

Объект предназначен для определения и хранения значения шрифта. Шрифт может определяться абсолютным значением (именем шрифта), браться из элементов стиля, или использоваться один из шрифтов Windows.

Может присваиваться в качестве значения атрибутов других объектов, параметров методов, процедур или функций, имеющих тип Шрифт.

Свойства

Вид (Kind)

Использование:

Только чтение.

Описание:

Тип: системное перечисление ВидШрифта. Содержит вид шрифта.

Жирный (Bold)

Использование:

Только чтение.

Описание:

Тип: Булево, Неопределено. Содержит признак жирности начертания шрифта.

Примечание:

Если шрифт задан не абсолютным, то содержит Неопределено.

Зачеркивание (StrikeOut)

Использование:

Только чтение.

Описание:

Тип: Булево. Неопределено. Содержит признак зачеркивания при начертании шрифта.

Примечание:

Если шрифт задан не абсолютным, то содержит Неопределено.

Имя (Name)

Использование:

Только чтение.

Описание:

Тип Строка. Содержит имя шрифта, если оно задано (например "Times New Roman").

Примечание:

Если шрифт задан не абсолютным, то содержит пустую строку.

Наклонный (Italic)

Использование:

Только чтение.

Описание:

Тип: Булево, Неопределено. Содержит признак наклонного начертания шрифта.

Примечание:

Если шрифт задан не абсолютным, то содержит Неопределено.

Подчеркивание (Underline)

Использование:

Только чтение.

Описание:

Тип: Булево, Неопределено. Содержит признак подчеркивания при начертании шрифта.

Примечание:

Если шрифт задан не абсолютным, то содержит Неопределено.

Размер (Size)

Использование:

Только чтение.

Описание:

Тип: Число. Содержит размер шрифта, если он задан.

Примечание:

Если шрифт задан не абсолютным, то содержит -1.

Конструкторы

Основной

Синтаксис:

Новый Шрифт(< Имя шрифта>, <Размер>, <Жирный>, <Наклонный> , <Подчеркнутый> , <3ачеркнутый>)

Параметры:

<Имя шрифта> Необязательный

Тип. Строка. Системное наименование шрифта.

Значение по умолчанию: Пустая строка, то есть не изменять относительно стиля.

<Размер> Необязательный

Тип: Число. Размер шрифта.

Значение по умолчанию: -1, то есть не изменять относительно стиля

<Жирный> Необязательный

Тип: Булево. Признак жирности шрифта.

Значение по умолчанию: Неопределено, то есть не изменять относительно стиля.

<Наклонный> Необязательный

Тип. Булево. Признак наклонного начертания шрифта.

Значение по умолчанию: Неопределено, то есть не изменять относительно стиля.

<Подчеркнутый> Необязательный

Тип Булево. Признак подчеркнутого начертания шрифта.

Значение по умолчанию: Неопределено, то есть не изменять относительно стиля.

<3ачеркнутый> Необязательный

Тип. Булево. Признак зачеркнутого начертания шрифта.

Значение по умолчанию: Неопределено, то есть не изменять относительно стиля

Описание:

Используется для формирования шрифта из отдельных параметров

На основании другого шрифта

Синтаксис:

Новый Шрифт(<Шрифт>, <Ими шрифта>, <Размер> , <Жирный>, <Наклонный>, <Подчеркнутый>, <3ачеркнутый>)

Параметры:

<Шрифт> Обязательный

Тип Шрифт Шрифт, на основании которого будет формироваться новый шрифт.

<Имя шрифта> Необязательный

Тип Строка. Системное наименование шрифта.

Значение по умолчанию: Пустая строка, то есть не изменять относительно исходного шрифта.

<Размер> Необязательный

Тип Число. Размер шрифта.

Значение по умолчанию: -1, то есть не изменять относительно исходного шрифта.

<Жирный> Необязательный

Тип Булево. Признак жирности шрифта.

Значение по умолчанию: Неопределено, то есть не изменять относительно исходного шрифта.

<Наклонный> Необязательный

Тип Булево. Признак наклонного начертания шрифта.

Значение по умолчанию: Неопределено, то есть не изменять относительно исходного шрифта.

<Подчеркнутый> Необязательный

Тип Булево. Признак подчеркнутого начертания шрифта.

Значение по умолчанию: Неопределено, то есть не изменять относительно исходного шрифта.

<3ачеркнутый> Необязательный

Тип- Булево. Признак зачеркнутого начертания шрифта.

Значение по умолчанию: Неопределено, то есть не изменять относительно исходного шрифта.

Описание:

Используется для формирования шрифта на основании имеющегося шрифта. Все параметры могут быть взяты из исходного шрифта, при этом параметры, указанные в конструкторе, имеют приоритет над исходными.


2-252 Рамка.Линия.

Рамка (Border)

Объект предназначен для определения и хранения параметров рамки. Может быть использован для определения рамок элементов управления.

Свойства

Вид (Kind)

Использование:

Только чтение.

Описание:

Тип: системное перечисление ВидРамки. Содержит вид рамки, определяющий способ ее задания: абсолютный или из стиля.

ТипРамки (BorderType)

Использование:

Только чтение.

Описание:

Тип: системное перечисление ТипРамкиЭлементаУправления. Содержит тип начертания рамки.

Толщина (Width)

Использование:

Только чтение.

Описание:

Тип: Число. Содержит толщину рамки (в логических единицах).

Конструкторы

Основной

Синтаксис:

Новый Рамка(< Тип рамки>, <Толщина>)

Параметры:

<Тип рамки> Обязательный

Тип: системное перечисление ТипРамкиЭлементаУправления. Тип рамки.

<Толщина> Необязательный

Тип: Число. Толщина рамки (в логических единицах). Значение по умолчанию: 1

Описание:

Позволяет создать рамку требуемого типа и толщины.

Линия (Line)

Объект предназначен для определения и хранения параметров линии. Используется для определения типов линий, используемых в объектах ОбпастьТабличногоДокумента, РисунокТабличногоДокумента, ОбластьПостроения диаграммы.

Свойства

ТипЛинии (LineType)

Использование:

Только чтение.

Описание:

Тип: ТипЛинииРисункаТабличногоДокумента, ТипЛинииЯчейкиТабличногоДокумента, ТипЛинииДиаграммы. Содержит тип линии. Тип значения зависит от типа объекта, для которого используются линии. Для линий области табличного документа используется тип ТипЛинииЯчейкиТабличногоДокумента, для рисунка табличного документа ТипЛинииРисункаТабличногоДокумента, для линий диа-гарммы используется ТипЛинииДиаграммы.

Толщина (Width)

Использование:

Только чтение.

Описание:

Содержит толщину линии (в логических единицах).

Конструкторы

Основной

Синтаксис:

Новый Линия (< Тип линии> , <Толщина>)

Параметры:

<Тип линии> Обязательный

Тип: ТипЛинииРисункаТабличногоДокумента, ТипЛинииЯчейкиТабличногоДокумента, ТипЛинииДиаграммы. Тип линии. Тип параметра зависит от того, в каком объекте будет использоваться линия.

<Толщина> Необязательный

Тип: Число. Толщина линии (в логических единицах).

Описание:

Позволяет создать линию заданного типа и толщины


2-256 СочетаниеКлавиш. Действие. Библиотека стилей.

СочетаниеКлавиш (Shortcut)

Предназначен для получения и хранения сочетания клавиш быстрого доступа к элементам управления. Используется для определения свойств других объектов, имеющих тип СочетаниеКлавиш.

Свойства

Alt (Alt)

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит признак использования в сочетании клавиши Alt.

Control (Control)

Использование:

Только чтение.

Описание:

Тип Булево. Содержит признак использования в сочетании клавиши Control.

Shift (Shift)

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит признак использования в сочетании клавиши Shift.

Клавиша (Key)

Использование:

Только чтение.

Описание:

Тип: системное перечисление Клавиша. Содержит основную клавишу сочетания.

Конструкторы

Основной

Синтаксис:

Новый СочетаниеКлавиш(< Клавиша>, <Alt>, <Control>, <Shift>)

Параметры:

<Клавиша> Необязательный

Тип: системное перечисление Клавиша. Основная клавиша сочетания.

<Alt> Необязательный

Тип: Булево. Истина - комбинация клавиш включает Alt, Ложь - иначе.

<Сопtrol> Необязательный

Тип: Булево. Истина - комбинация клавиш включает Control, Ложь - иначе.

<Shift> Необязательный

Тип: Булево. Истина - комбинация клавиш включает Shift, Ложь - иначе.

Описание:

Позволяет сформировать сочетание из заданной клавиши и клавиш Alt, Control и Shift.

Действие (Action)

Предназначен для получения действия, которое можно назначить в качестве обработчика события элемента управления или команды пользовательского интерфейса. Для обработки такого события вызывается процедура модуля формы (глобального или общего модулей для пользовательских интерфейсов), имя которой задано при создании действия.

//В модуле описана процедура Сформировать(), выполнение которой
// назначим кнопке "Сформировать" в качестве действия при нажатии
ОбработкаНажатия = Новый Действие("Сформировать");
КнопкаСформировать = ЭлементыФормы.КнопкаСформировать;
КнопкаСформировать.УстановитьДействие("Нажатие", ОбработкаНажатия) ;

Конструкторы

Основной

Синтаксис:

Новый Действие(< Имя процедуры>)

Параметры:

<Имя процедуры> Обязательный

Тип: Строка. Имя процедуры модуля.

Описание:

Предназначен для формирования объекта из процедуры модуля.

БиблиотекаСтилей (StylesLib)

Представляет собой библиотеку стилей конфигурации.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа Стиль. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции. Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс элемента.

Свойства

<Имя стиля>

Использование:

Только чтение.

Описание:

Тип: Стиль. Набор свойств содержит стили конфигурации. Имена свойств совпадают с именами стилей, как они заданы в конфигураторе.

Методы

Индекс (IndexOf)

Синтаксис:

Индекс(<Ссылка на стиль>)

Параметры:

<Ссылка на стиль> Обязательный

Тип: Стиль. Ссылка на стиль коллекции, для которой необходимо получить индекс.

Возвращаемое значение:

Тип: Число. Индекс указанного стиля в коллекции.

Описание:

Получает индекс указанного стиля в коллекции стилей.

Пример:

ИндексСтиля = БиблиотекаСтилей.Индекс(ТекущийСтиль);

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип Число. Количество стилей в коллекции.

Описание:

Позволяет получить количество стилей в коллекции стилей.

Пример:

ВсегоСтилей = БиблиотекаСтилей.Количество();

Стиль (Style)

Представляет собой стиль, определенный в конфигурации.


2-263 Работа с пользовательским интерфейсом

Работа с пользовательским интерфейсом

Пользовательским интерфейсом в системе 1C: Предприятие называется совокупность команд главного меню и панелей инструментов, настроенных на работу с конкретными объектами данных -документами, справочниками, журналами и т.д. Как правило, пользовательский интерфейс создается для конкретной категории пользователей. Цель создания интерфейса - обеспечить быстрый доступ пользователей к той информации, которая необходима им в соответствии с их обязанностями. Интерфейсы создаются в конфигураторе, средствами языка 1C: Предприятия интерфейс нельзя добавить или удалить, но его можно включить или выключить, при этом допускается включение более одного интерфейса.

Управление интерфейсом

Предназначен для управления видимостью интерфейсов, настроенных в конфигурации.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа Элемент управления интерфейсом. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции.

Свойства

<Имя интерфейса>

Использование:

Только чтение.

Описание:

Тип: Элемент управления интерфейсом. Набор свойств содержит интерфейсы конфигурации. Имена свойств совпадают с именами интерфейсов, как они заданы в конфигураторе.

Методы

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество интерфейсов в коллекции.

Описание:

Позволяет получить количество интерфейсов.

ПереключитьИнтерфейс (SwitchInterface)

Синтаксис:

ПереключитьИнтерфейс (<Имена интерфейсов> )

Параметры:

<Имена интерфейсов> Необязательный

Тип: Строка. Перечисленные через запятую имена интерфейсов, которые следует сделать видимыми.

Описание:

Способ группового управления видимостью командных интерфейсов. При вызове данного метода сначала становятся невидимыми все интерфейсы, кроме имеющих значение Ложь у свойства Переключаемый, а затем становятся видимыми перечисленные в параметре интерфейсы.

Пример:

Интерфейсы.ПереключитьИнтерфейс("Основной,Маркетинг");

Элемент управления интерфейсом

Позволяет управлять видимостью интерфейса, настроенного в конфигураторе.

Пример:

Интерфейсы.Основной.Видимость = Истина;

Свойства

Видимость (Visible)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак видимости интерфейса.

Переключаемый (Switchable)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак, определяющий видимость интерфейса. Первоначальное значение свойства для интерфейса задается в конфигураторе. Интерфейсы, у которых данное свойство установлено в Ложь, останутся видимы после переключения интерфейсов.

См. также:

Управление интерфейсом, метод ПереключитьИнтерфейс.


2-267 Источники данных (таблицы) запросов

Глава 2. Работа с запросами

Для формирования и выполнения запросов к таблицам базы данных в системе используется специальный объект Запрос. Запрос удобно использовать когда необходимо получить сложную выборку данных, сгруппированную и отсортированную нужным образом. Одним из классических примеров его применения может служить сводка по состоянию регистра учета на определенный момент времени. Кроме того, механизм запросов позволяет легко получать информацию в различных временных разрезах.

Источники данных (таблицы) запросов

В качестве источников данных языка запросов выступают таблицы базы данных. Таблицы подразделяются на два основных класса: реальные и виртуальные.

Реальные таблицы хранятся в базе данных, то есть интерпретируются из реально существующей таблицы базы данных. В случае использования реальной таблицы могут присутствовать вычисляемые поля, значения которых вычисляются как функция нескольких реальных полей.

Виртуальные таблицы не хранятся в базе данных. При обращении к информации виртуальных таблиц система автоматически собирает информацию реальных таблиц базы данных для выполнения запроса. Виртуальная таблица может быть параметризована, то есть реальное наполнение виртуальной таблицы может определяться значениями параметров, фактические значения которых задаются в тексте запроса.

Для каждой виртуальной таблицы определяется имя, которое используется в запросах для идентификации таблицы. Имя таблицы может быть задано на английском и русском языках. Например, Справочник.Товары. Имена таблиц и полей не могут совпадать с ключевыми словами языка запросов.

Отдельный подкласс таблиц образуют так называемые объектные таблицы. В качестве объектной таблицы обязательно выступает реальная таблица базы данных. Смысловое отличие объектных таблиц от прочих следует из названия - объектные таблицы предназначены для хранения состояния объектов системы 1C Предприятие, таких как справочники, документы и т. п. Каждой объектной таблице соответствует тип объектов системы 1C Предприятие. Например, объектам типа Справочник.Товары соответствует одна таблица, объектам типа Справочник.Контрагенты - другая. Каждая отдельная запись объектной таблицы хранит состояние отдельного объекта соответствующего типа. В соответствии с этим у каждой объектной таблицы определено поле типа Ссылка на текущую запись. Кроме того, для объектных таблиц определен способ получения как пользовательского представления объекта из содержимого полей записи.

Объектные таблицы могут быть также иерархическими Для иерархических таблиц определяется специально выделенное поле Родитель, содержащее ссылку на запись, которой в соответствии с иерархией подчиняется текущая запись.

В качестве поля таблицы может фигурировать:

• поле виртуальной или реальной таблицы;

• вложенная таблица.

Основное отличие обычного поля от вложенной таблицы состоит в том, что в рамках одной записи обычному полю соответствует одно единственное значение, а вложенной таблице соответствует значение типа РезультатЗапроса с заранее заданным набором колонок. Примером вложенной таблицы может являться табличная часть документа или справочника.

В качестве типов значения полей таблиц может выступать значение типа Null. Такие значения содержатся в полях записей таблиц, для которых данное поле не определено или не имеет смысла. Например, значения такого типа содержатся в записях, относящимся к группам справочника, по полям, для которых установлено, что они могут иметь значение только у элементов этого справочника.

Таблица констант

Синтаксис:

Константы

Описание:

Предоставляет доступ к таблице, хранящей константы.

Предоставляемые поля:

<Имя константы>

Тип: Произвольный.<Имя константы>, как она задана в конфигураторе.

Таблица плана видов характеристик

Синтаксис:

ПланВидовХарактеристик.<Имя плана>

Описание:

Таблица планов видов характеристик.

Предоставляемые поля:

Ссылка

Тип: ПланВидовХарактеристик.<Имя плана>. Ссылка на вид характеристики.

ПометкаУдаления

Код

Наименование

Предопределенный

Родитель

ЭтоГруппа

<Имя реквизита>

<Имя табличной части>

Таблица плана счетов

Синтаксис:

ПланСчетов.<Имя плана>

Описание:

Таблица планов счетов.

Предоставляемые поля:

Ссылка

Тип: ПланСчетовСсылка.<Имя плана>. Ссылка на счет.

ПометкаУдаления

Предопределенный

Родитель

Код

Наименование

Вид

Забалансовый

<Имя реквизита>

<Имя табличной части>

<Имя признака учета>

ВидыСубконто

Таблица справочника

Синтаксис:

Справочник.<Имя справочника>

Описание:

Предназначена для получения записей справочника.

Предоставляемые поля:

Ссылка (Ref)

Тип: СправочникСсылка.<Имя справочника>. Содержит ссылку на элемент справочника.

ПометкаУдаления (DeleteMark)

Тип: Булево. Содержит признак пометки на удаление элемента справочника.

Код (Code)

Тип: Число, Строка. Содержит код элемента справочника.

Наименование (Description)

Тип: Строка. Содержит наименование элемента справочника.

ЭтоГруппа (Is Group)

Тип: Булево. Содержит признак того, что элемент справочника является группой Имеет значения" Истина - элемент является группой, Ложь - не является группой.

Владелец (Owner)

Тип: СправочникСсылка.<Имя справочника>. Содержит ссылку на владельца элемента справочника.

Примечание: Существует только для подчиненных справочников.

Родитель (Parent)

Тип: СправочникСсылка.<Имя справочника>. Содержит ссылку на родителя элемента справочника.

Примечание: Существует только для многоуровневых справочников.

Представление (Presentation)

Тип: Строка. Содержит представление элемента справочника.

Данное поле виртуальное и не хранится в базе данных. Поле не доступно для операций сравнения в тексте запросов.

<Имя реквизита> (<Имя реквизита>)

Тип: Произвольный. Набор полей содержит значения реквизитов элемента справочника. Имена полей соответствуют именам реквизитов справочника, как они заданы в конфигураторе.

Примечание: Поля, соответствующие реквизитам, используемым только для элементов справочника, для групп справочника будут иметь значение Null. Аналогично, поля, соответствующие реквизитам, используемым только для групп справочника, для элемента справочника будут иметь значение Null.

<Имя табличной части> (<Имя табличной части>)

Тип: РезультатЗапроса. Набор полей содержит табличные части элемента справочника. Имена полей соответствуют именам табличных частей справочника, как они заданы в конфигураторе. Результат запроса к табличной части состоит из колонки НомерСтроки и колонок с именами, соответствующими именам реквизитов табличной части.

Пример:

ВЫБРАТЬ * ИЗ Справочник.Номенклатура

Таблица документов

Синтаксис:

Документ.<Имя документа>

Описание:

Предназначена для получения записей документов.

Предоставляемые поля:

Сетка (Ref)

Тип: ДокументСсылка.<Имя документа>. Содержит ссылку на документ.

ПометкаУдаления (DeleteMark)

Тип: Булево. Содержит признак пометки на удаление документа.

Номер (Number)

Тип: Число, Строка. Содержит номер документа.

Дата (Date)

Тип: Дата. Содержит дату документа.

Проведен (Posted)

Тип: Булево. Содержит признак проведенности документа, зарегистрированного в журнале.

Представление (Presentation)

Тип: Строка. Содержит строку-представление документа.

Данное поле виртуальное и не хранится в базе данных. Поле не доступно для операций сравнения в тексте запросов.

МоментВремени (PointOfTime)

Тип: МоментВремени. Содержит момент времени документа (включает дату и ссылку на документ).

Данное поле виртуальное и не хранится в базе данных.

<Имя реквизита> (<Имя реквизита>)

Тип: Произвольный. Набор полей содержит значения реквизитов документов. Имена полей соответствуют именам реквизитов документов, как они заданы в конфигураторе.

<Имя табличной части> (<Имя табличной части>)

Тип: РезультатЗапроса. Набор полей содержит табличные части документа. Имена полей соответствуют именам табличных частей документа, как они заданы в конфигураторе. Результат запроса к табличной части состоит из колонки НомерСтроки и колонок с именами, соответствующими именам реквизитов табличной части документа.

Пример:

ВЫБРАТЬ * ИЗ Документ.РасходнаяНакладная

Таблица журнала документов

Синтаксис:

ЖурналДокументов.<Имя журнала документов>()

Описание:

Виртуальная таблица. Предназначена для получения записей журнала документов.

Предоставляемые поля:

Ссылка (Ref)

Тип: ДокументСсылка.<Имя документа>. Содержит ссылку на документ, зарегистрированный в журнале.

ПометкаУдаления (DeleteMark)

Тип: Булево. Содержит пометку удаления документа, зарегистрированного в журнале.

Номер (Number)

Тип: Число, Строка. Содержит номер документа, зарегистрированного в журнале.

Дата (Date)

Тип: Дата. Содержит дату документа, зарегистрированного в журнале

Проведен (Posted)

Тип: Булево. Содержит признак проведенности документа, зарегистрированного в журнале.

<Имя графы журнала> (<Имя графы журнала>)

Тип: Произвольный. Набор полей содержит значения граф журнала документов. Имена полей соответствуют именам граф журнала документов, как они заданы в конфигураторе.

Примечание: Для записей документов, реквизиты которых не выводятся в графе журнала, поле, соответствующее этой графе, имеет значение Null.

Пример:

ВЫБРАТЬ * ИЗ ЖурналДокументов.Торговля

Таблица плана видов расчета

Синтаксис:

ПланВидовРасчета.<Имя вида расчета>

Предоставляемые поля:

Ссылка

Тип: ПланВидовРасчетаСсылка.<Имя плана видов расчета>. Ссылка на вид расчета.

ПометкаУдаления

Предопределенный

Код

Наименование

Представление

ПериодДействияБазовый

<Имя реквизита>

БазовыеВидыРасчета

Тип: Результат запроса. Вложенная таблица базовых видов расчета. Представляет результат запроса к предопределенной табличной части плана видов расчета. Результат состоит из двух колонок: НомерСтроки и ВидРасчета. (только для планов видов расчета которым задано свойство Зависимость от базы)

ВедущиеВидыРасчета

Тип: Результат запроса. Вложенная таблица ведущих видов расчета. Представляет результат запроса к предопределенной табличной части плана видов расчета. Результат состоит из двух колонок: НомерСтроки и ВидРасчета.

ВытесняющиеВидыРасчета

Тип: Результат запроса. Вложенная таблица вытесняющих видов расчета. Представляет результат запроса к предопределенной табличной части плана видов расчета. Результат состоит из двух колонок: НомерСтроки и ВидРасчета. (только для планов видов расчета которым задано свойство Использует период действия)

<Имя табличной части>

Тип: Результат запроса. Вложенная таблица - табличная часть вида расчета. Представляет результат запроса к табличной части. Результат состоит из двух колонок: НомерСтроки и ВидРасчета, соответствующих реквизитам табличной части.

ВидыСубконто

Таблицы регистра сведений

Основная таблица

Синтаксис:

РегистрСведений.<Имя регистра>

Описание:

Предназначена для получения доступа к записям регистра сведений.

Предоставляемые поля:

Период (Period)

Тип: Дата. Содержит период, к которому относится запись регистра.

Примечание: Имеет смысл только для периодических регистров.

Регистратор (Recorder)

Тип: ДокументСсылка.<Имя документа>. Содержит ссылку на документ-регистратор движения.

Примечание: Имеет смысл только для регистров, записываемых регистратором.

НомерСтроки (LineNumber)

Тип: Число. Содержит номер строки, определяемый как порядковый номер записи в наборе записей.

Примечание: Имеет смысл только для регистров, записываемых регистратором.

Активность (Active)

Тип: Булево. Содержит признак активности записи и влияния на получение первых и последних записей

Примечание: Имеет смысл только для регистров, записываемых регистратором.

МоментВремени (PointOfTime)

Тип: МоментВремени. Содержит момент времени записи регистра.

Данное поле виртуальное и не хранится в базе данных.

Примечание: Имеет смысл только для регистров, записываемых регистратором.

<Имя измерения>

Тип: Произвольный. Набор полей содержит значения измерений регистра. Имена полей соответствуют именам измерений, как они заданы в конфигураторе.

<Имя ресурса>

Тип: Произвольный. Набор полей содержит значения ресурсов регистра. Имена полей соответствуют именам ресурсов, как они заданы в конфигураторе.

<Имя реквизита>

Тип: Произвольный. Набор полей содержит значения реквизитов регистра. Имена полей соответствуют именам реквизитов, как они заданы в конфигураторе.

Пример:

ВЫБРАТЬ * ИЗ РегистрСведений.КурсыВалют

Таблица получения среза последних (наиболее поздних) записей

Синтаксис:

РегистрСведений.<Имя регистра>.СрезПоследних(< Дата> , <Условие>)

Описание:

Виртуальная таблица. Предназначена для получения наиболее поздних записей регистра сведений на указанную дату (включительно). Включает только активные записи. По каждой комбинации измерений будет найдена наиболее поздняя запись, но не более поздняя, чем указанная дата.

Предоставляемые поля:

Период (Period)

Тип: Дата. Содержит период, к которому относится запись регистра.

Примечание: Имеет смысл только для периодических регистров.

Регистратор (Recorder)

Тип: ДокументСсылка.<Имя документа>. Содержит ссылку на документ-регистратор движения.

Примечание: Имеет смысл только для регистров, записываемых регистратором.

НомерСтроки (LineNumber)

Тип: Число. Содержит номер строки, определяемый как порядковый номер записи в наборе записей.

Примечание: Имеет смысл только для регистров, записываемых регистратором.

Активность (Active)

Тип: Булево. Содержит признак активности записи и влияния на получение первых и последних записей

Примечание: Имеет смысл только для регистров, записываемых регистратором.

<Имя измерения>

Тип: Произвольный. Набор полей содержит значения измерений регистра Имена полей соответствуют именам измерений, как они заданы в конфигураторе.

<Имя ресурса>

Тип: Произвольный. Набор полей содержит значения ресурсов регистра. Имена полей соответствуют именам ресурсов, как они заданы в конфигураторе.

<Имя реквизита>

Тип: Произвольный. Набор полей содержит значения реквизитов регистра. Имена полей соответствуют именам реквизитов, как они заданы в конфигураторе.

Параметры:

<Дата> Необязательный

Тип параметра: Значение. Тип: Дата, Момент Времени. Указывается дата или момент времени, на которые будут получены сведения.

Значение по умолчанию: Если параметр не задан, будут выбираться наиболее поздние записи, без ограничения по дате.

<Условие> Необязательный

Тип параметра Конструкция. Указывается условие на языке запросов. Условие может оперировать полями регистра сведений. Оно будет использовано для ограничения состава записей, среди которых будут выбираться наиболее поздние. То есть условие будет применяться к исходным записям, а не к уже отобранным.

Значение по умолчанию: Если параметр не задан, анализируются все активные записи регистра.

Пример:

// Получение всех наиболее поздних записей регистра сведений
ВЫБРАТЬ * ИЗ РегистрСведений.КурсыВалют.СрезПоследних()

// Получение всех наиболее поздних записей регистра сведений
// на указанную дату и по указанной валюте.
ВЫБРАТЬ * ИЗ РегистрСчедений.КурсыВалют.СрезПоследних(&ПарДата, Валюта = &ПарВалюта)

Таблица получения среза первых (наиболее ранних) записей

Синтаксис:

РегистрСведений.<Имя регистра>.СрезПервых(<Дата>, <Условно>)

Описание:

Виртуальная таблица. Предназначена для получения наиболее ранних записей регистра сведений на указанную дату (включительно). Включает только активные записи. По каждой комбинации измерений будет найдена наиболее ранняя запись, но не более ранняя, чем указанная дата.

Предоставляемые поля:

Период (Period)

Тип: Дата. Содержит период, к которому относится запись регистра.

Примечание: Имеет смысл только для периодических регистров.

Регистратор (Recorder)

Тип: ДокументСсылка.<Имя документа>. Содержит ссылку на документ-регистратор движения.

Примечание: Имеет смысл только для регистров, записываемых регистратором.

НомерСтроки (LineNumber)

Тип: Число. Содержит номер строки, определяемый как порядковый номер записи в наборе записей.

Примечание: Имеет смысл только для регистров, записываемых регистратором.

Активность (Active)

Тип: Булево. Содержит признак активности записи и влияния на получение первых и последних записей

Примечание: Имеет смысл только для регистров, записываемых регистратором.

<Имя измерения>

Тип: Произвольный. Набор полей содержит значения измерений регистра. Имена полей соответствуют именам измерений, как они заданы в конфигураторе.

<Имя ресурса>

Тип: Произвольный. Набор полей содержит значения ресурсов регистра. Имена полей соответствуют именам ресурсов, как они заданы в конфигураторе.

<Имя реквизита>

Тип: Произвольный. Набор полей содержит значения реквизитов регистра. Имена полей соответствуют именам реквизитов, как они заданы в конфигураторе.

Параметры:

<Дата> Необязательный

Тип параметра: Значение. Тип: Дата, МоментВремени. Указывается дата или момент времени, на которые будут получены сведения.

Значение по умолчанию: Если параметр не задан, будут выбираться наиболее ранние записи, без ограничения по дате.

<Условие> Необязательный

Тип параметра: Конструкция. Указывается условие на языке запросов. Условие может оперировать полями регистра сведений. Оно будет использовано для ограничения состава записей, среди которых будут выбираться наиболее ранние. То есть условие будет применяться к исходным записям, а не к уже отобранным.

Значение по умолчанию: Если параметр не задан, анализируются все активные записи регистра.

Пример:

// Получение всех наиболее ранних записей регистра сведений
ВЫБРАТЬ * ИЗ РегистрСведений.КурсВал.СрезПервых()

// Получение всех наиболее ранних записей регистра сведений на
// указанную дату и по указанной валете.
ВЫБРАТЬ * ИЗ РегистрСведений.КурсВал.СрезПервых(&ПарДата, Вал = &ПарВал)

Таблицы регистра накопления

Основная таблица

Синтаксис:

РегистрНакопления.<Имя регистра>

Описание:

Предназначена для получения записей регистра накопления.

Предоставляемые поля:

Период (Period)

Тип: Дата. Содержит период, к которому относится запись регистра.

Регистратор (Recorder)

Тип: Любая ссылка на объект ИВ. Содержит ссылку на документ-регистратор движения.

НомерСтроки (LineNumber)

Тип: Число. Содержит номер строки, определяемый как порядковый номер записи в наборе записей.

Активность (Active)

Тип: Булево. Содержит признак активности записи, т.е. влияния на получение итогов.

МоментВремени (PointOfTime)

Тип: МоментВремени. Содержит момент времени записи регистра.

Данное поле виртуальное и не хранится в базе данных.

Приход (Receipt)

Тип: Булево. Содержит признак, что данная запись является приходом.

Расход (Expense)

Тип: Булево. Содержит признак того, что данная запись является расходом.

<Имя измерения>

Тип: Произвольный. Набор полей содержит значения измерений регистра. Имена полей соответствуют именам измерений, как они заданы в конфигураторе.

<Имя ресурса>

Тип: Произвольный, Набор полей содержит значения ресурсов регистра. Имена полей соответствуют именам ресурсов, как они заданы в конфигураторе.

<Имя реквизита>

Тип: Произвольный. Набор полей содержит значения реквизитов регистра Имена полей соответствуют именам реквизитов, как они заданы в конфигураторе.

Пример:

ВЫБРАТЬ * ИЗ РегистрНакопления.Продажи

Таблица получения оборотов

Синтаксис:

РегистрНакопления.<Имя регистра>.Обороты(<Начало периода> , <Конец периода> , <Периодичность> , <Условие>, <Измерение>)

Описание:

Виртуальная таблица. Предназначена для получения оборотов за период по регистру накопления. Обороты представляют собой итоги ресурсов, подсчитанные по комбинации измерений, указанной в параметре <Измерения>. Если параметр не задан, то обороты подсчитываются по полному набору измерений.

При расчете итогов учитываются только активные записи.

Предоставляемые поля:

Период (Period)

Тип: Дата. Содержит период, к которому относится оборот регистра

Примечание: Содержит начальную дату и время периода.

Существует только в случае, если используется разворот по периодам, т.е. параметр Периодичность имеет значения Год, Квартал, Неделя, День, Регистратор,Запись.

Данное поле не может быть использовано в условии отбора записей

Регистратор (Recorder)

Тип: Любая ссылка на объект ИБ. Содержит ссылку на документ-регистратор движения.

Примечание: Существует только в случае, если параметр

Периодичность имеет значения Регистратор, Запись.

Данное поле не может быть использовано в условии отбора записей

<Имя измерения>

Тип. Произвольный Набор полей содержит значения измерений регистра. Имена полей соответствуют именам измерений, как они заданы в конфигураторе.

<Имя ресурса>Оборот (<Имя ресурса>Turnover)

Тип: Число. Набор полей содержит обороты по ресурсам регистра. Имена полей соответствуют именам ресурсов, как они заданы в конфигураторе, с добавлением слова Оборот.

Для регистров оборотов оборот подсчитывается как сумма всех движений. Для регистров остатков оборот подсчитывается как сумма всех движений Приход со знаком + (плюс) и Расход со знаком - (минус).

<Имя ресурса>Приход (<Имя pecypca>Receipt)

Тип. Число. Набор полей содержит суммы всех движений Приход по ресурсам регистра. Имена полей соответствуют именам ресурсов, как они заданы в конфигураторе, с добавлением слова Приход.

Примечание: Существует только для регистров остатков.

<Имя ресурса>Расход (<Имя pecypca>Expense)

Тип: Число. Набор полей содержит суммы всех движений Расход по ресурсам регистра. Имена полей соответствуют именам ресурсов, как они заданы в конфигураторе, с добавлением слова Расход.

Примечание: Существует только для регистров остатков.

Параметры:

<Начало периода> Необязательный

Тип параметра: Значение Тип Дата, МоментВремени, Граница. Указывается начало периода расчета итогов Значение начала периода по умолчанию включается в период расчета итогов Для исключения значения из периода его следует задавать объектом Граница с исключением граничного значения.

Значение по умолчанию: Если параметр не задан, итоги рассчитываются с самой первой записи

<Конец периода> Необязательный

Тип параметра: Значение Тип Дата, МоментВремени, Граница. Указывается конец периода расчета итогов. Значение конца периода по умолчанию включается в период расчета итогов. Для исключения значения из периода его следует задавать объектом Граница с исключением граничного значения

Значение по умолчанию: Если параметр не задан, итоги рассчитываются по самую последнюю запись.

<Периодичность> Необязательный

Тип параметра: Конструкция. Указывается дополнительный разворот итогов по периодичности. Задается один из следующих вариантов:

• Период (Period) - только за период (не разворачивать);

• Регистратор (Recorder) - разворачивать по регистратору;

• День (Day) - разворачивать по дням;

• Неделя (Week) - разворачивать по неделям;

• Месяц (Month) - разворачивать по месяцам;

• Квартал (Quarter) - разворачивать по кварталам;

• Год (Year) - разворачивать по годам.

Значение по умолчанию: Период

<Условие> Необязательный

Тип параметра: Конструкция. Указывается условие на языке запросов. Условие может оперировать полями регистра накопления. Оно будет использовано для ограничения состава записей, по которым будут выбираться обороты. То есть условие будет применяться к исходным записям, а не к уже отобранным.

Значение по умолчанию: Если параметр не задан, анализируются все активные записи регистра.

<Измерение> Необязательный

Тип параметра: Конструкция. Указывается список измерений, по которым будут развернуты итоги.

Значение по умолчанию: Если не указан, то по всем измерениям.

Пример:

// Получение всех оборотов регистра оборотов
ВЫБРАТЬ * ИЗ РегистрНакопления.Продажи.Обороты()

// Получение оборотов по регистру остатков за указанный период по указанному товару с разворотом по месяцам
ВЫБРАТЬ * ИЗ РегистрНакопления.УчетНоменклатуры.Обороты(&НачПериода, &КонПериода, Месяц, Номенклатура = &ПарНоменклатура)

Таблица получения остатков

Синтаксис:

РегистрНакопления.<Имя регистра>.Остатки(< Период>, <Условие>, <Измерение>)

Описание:

Виртуальная таблица. Предназначена для получения остатков по регистру накопления. Данные представляют собой итоги ресурсов, подсчитанные по комбинации измерений, указанной в параметре <Измерения>. Если параметр не задан, то итоги подсчитываются по полному набору измерений.

При расчете итогов учитываются только активные записи. Таблица существует только для регистров остатков.

Предоставляемые поля:

<Имя измерения>

Тип: Произвольный. Набор полей содержит значения измерений регистра. Имена полей соответствуют именам измерений, как они заданы в конфигураторе.

<Имя ресурса>Остаток (<Имя ресурса>Balance)

Тип: Число. Набор полей содержит остатки ресурсов регистра. Имена полей соответствуют именам ресурсов, как они заданы в конфигураторе, с добавлением слова Остаток.

Параметры:

<Период> Необязательный

Тип параметра: Значение. Тип: Дата, МоментВремени, Граница. Указывается период, на значение которого рассчитываются остатки. Для расчета остатков по значение периода его необходимо задавать объектом Граница со включением граничного значения.

Значение по умолчанию: Если параметр не задан, итоги рассчитываются по самую последнюю запись.

<Условие> Необязательный

Тип параметра: Конструкция. Указывается условие на языке запросов. Условие может оперировать полями регистра накопления.

Оно будет использовано для ограничения состава записей, по которым будут выбираться итоги. То есть условие будет применяться к исходным записям, а не к уже отобранным.

Значение по умолчанию: Если параметр не задан, анализируются все активные записи регистра.

<Измерение> Необязательный

Тип параметра: Конструкция. Указывается список измерений, по которым будут развернуты итоги.

Значение по умолчанию: Если не указан, то по всем измерениям.

Пример:

// Получение остатков по регистру остатков по указанному товару на указанный момент времени
ВЫБРАТЬ * ИЗ РегистрНакопления.УчетНоменклатуры.Остатки(&КонПериода,Номенклатура,&ПарНоменклатура)

Таблица получения остатков и оборотов

Синтаксис:

РегистрНакопления.<Имя регистра>.ОстаткиИОбороты(<Начало периода> , <Конец периода> , <Периодичность> , <Условие>, <Измерение>)

Описание:

Виртуальная таблица. Предназначена для получения остатков и оборотов за период по регистру накопления. Данные представляют собой итоги ресурсов, подсчитанные по комбинации измерений, указанной в параметре <Измерения>. Если параметр не задан, то итоги подсчитываются по полному набору измерений.

При расчете итогов учитываются только активные записи. Таблица существует только для регистров остатков.

Предоставляемые поля:

Период (Period)

Тип: Дата. Содержит период, к которому относятся итоги регистра.

Примечание: Содержит начальную дату и время периода.

Существует только в случае, если используется разворот по периодам, т.е. параметр Периодичность имеет значения Год, Квартал, Неделя, День, Регистратор, Запись.

Данное поле не может быть использовано в условии отбора записей.

Регистратор (Recorder)

Тип: Любая ссылка на объект ИВ. Содержит ссылку на документ-регистратор движения.

Примечание: Существует только в случае, если параметр

Периодичность имеет значения Регистратор, Запись.

Данное поле не может быть использовано в условии отбора записей.

НомерСтроки (LineNumber)

Тип Число. Содержит номер строки, определяемый как порядковый номер записи в наборе записей.

<Имя измерения>

Тип: Произвольный. Набор полей содержит значения измерений регистра. Имена полей соответствуют именам измерений, как они заданы в конфигураторе.

<Имя ресурса>Оборот (<Имя ресурсa>Turnover)

Тип Число. Набор полей содержит обороты по ресурсам регистра. Имена полей соответствуют именам ресурсов, как они заданы в конфигураторе, с добавлением слова Оборот.

Для регистров оборотов оборот подсчитывается как сумма всех движений. Для регистров остатков оборот подсчитывается как сумма всех движений Приход со знаком + (плюс) и Расход со знаком - (минус).

<Ими ресурса>Приход (<Имя pecypca>Receipt)

Тип: Число. Набор полей содержит суммы всех движений Приход по ресурсам регистра. Имена полей соответствуют именам ресурсов, как они заданы в конфигураторе, с добавлением слова Приход.

<Имя ресурса>Расход (<Имя pecypca>Expense)

Тип: Число. Набор полей содержит суммы всех движений Расход по ресурсам регистра. Имена полей соответствуют именам ресурсов, как они заданы в конфигураторе, с добавлением слова Расход.

<Имя ресурса>НачальныйОстаток (<Имя pecypca>InitialBalance)

Тип: Число. Набор полей содержит начальные остатки ресурсов регистра. Имена полей соответствуют именам ресурсов, как они заданы в конфигураторе, с добавлением слова НачальныйОстаток.

<Имя ресурса>КонечныйОстаток (<Имя pecypca>FinalBalance)

Тип: Число. Набор полей содержит конечные остатки ресурсов регистра. Имена полей соответствуют именам ресурсов, как они заданы в конфигураторе, с добавлением слова КонечныйОстаток.

Параметры:

<Начало периода> Необязательный

Тип параметра: Значение. Тип: Дата, МоментВремени, Граница. Указывается начало периода расчета итогов. Значение начала периода по умолчанию включается в период расчета итогов. Для исключения значения из периода его следует задавать объектом Граница с исключением граничного значения.

Значение по умолчанию: Если параметр не задан, итоги рассчитываются с самой первой записи.

<Конец периода> Необязательный

Тип параметра; Значение. Тип: Дата, МоментВремени, Граница. Указывается конец периода расчета итогов. Значение конца периода по умолчанию включается в период расчета итогов. Для исключения значения из периода его следует задавать объектом Граница с исключением граничного значения.

Значение по умолчанию: Если параметр не задан, итоги рассчитываются по самую последнюю запись.

<Периодичность> Необязательный

Тип параметра: Конструкция. Указывается дополнительный разворот итогов по периодичности. Задается один из следующих вариантов:

• Период (Period) - только за период (не разворачивать);

• Запись (Record) - разворачивать по записям регистра;

• Регистратор (Recorder) - разворачивать по регистратору;

• День (Day) - разворачивать по дням;

• Неделя (Week) - разворачивать по неделям;

• Месяц (Month) - разворачивать по месяцам;

• Квартал (Quarter) - разворачивать по кварталам;

• Год (Year) - разворачивать по годам.

Значение по умолчанию: Период

<Условие> Необязательный

Тип параметра: Конструкция. Указывается условие на языке запросов. Условие может оперировать полями регистра накопления. Оно будет использовано для ограничения состава записей, по которым будут выбираться итоги. То есть условие будет применяться к исходным записям, а не к уже отобранным.

Значение по умолчанию: Если параметр не задан, анализируются все активные записи регистра.

<Измерение> Необязательный

Тип параметра: Конструкция. Указывается список измерений, по которым будут развернуты итоги.

Значение по умолчанию: Если не указан, то по всем измерениям.

Пример:

// Получение всех остатков и оборотов регистра остатков
ВЫБРАТЬ * ИЗ РегистрНакопления.УчетНокенклатуры.ОстаткиИОбороты()

// Получение остатков и оборотов регистра остатков за указанный период по указанному складу
ВЫБРАТЬ * ИЗ РегистрНакоплевия.УчетНоменклатуры.ОстаткиИОбороты(&НачПериода,&КонПериода, Склад = &ПарСклад)


2-290 Язык запросов

Язык запросов

Как было описано выше, для выполнения запроса необходимо составить текст запроса. Текст запроса - это инструкция, в соответствии с которой должен быть выполнен запрос. В тексте запроса описывается, какие таблицы информационной базы используются в качестве источников данных запроса, поля таблиц, которые требуется обрабатывать в запросе, правила группировки, сортировки результатов и т д.

Инструкция составляется на специальном языке - языке запросов, и состоит из отдельных частей - секций, предложений, слов, функций и комментариев. Далее в этой главе рассматриваются назначение и способы использования всех конструкций языка запросов.

Синтаксическая диаграмма конструкций языка запросов

В данной главе синтаксис языка запросов описывается при помощи набора правил. Каждое правило описывает одну конструкцию языка. Каждая конструкция языка может содержать в себе ключевые слова, разделители (точки, запятые, круглые скобки), в свою очередь, другие конструкции языка.

Пример:

<Конструкция языка>

ЭТО_КЛЮЧЕВОЕ_СЛОВО
<Это конструкция языка>,
<Это конструкция языка>
ЭТО_ФУНКЦИЯ( <Это конструкция языка> )

В правилах, описывающих язык запросов, конструкции языка указываются в угловых скобках. Ключевые слова и названия функций описываются заглавными буквами.

Конструкции языка могут содержать необязательные элементы - ключевые слова и прочее. В правилах, описывающих язык запросов, необязательные элементы заключены в квадратные скобки «[» и «]»:

[ЭТО_НЕОБЯЗАТЕЛЬНОЕ_СЛОВО] [<Это необязательная конструкция>]

В некоторых случаях в конструкции языка может использоваться одна из нескольких альтернативных элементов. Такие элементы в правилах перечисляются через вертикальную черту «|»:

ЛИБО_ЭТО_СЛОВО | ЛИБО_ЭТО_СЛОВО
<Либо эта конструкция> | <Либо эта конструкция>

Описания всех конструкций сопровождаются примерами, поясняющими порядок их использования в языке запросов.

Комментарии в языке запросов

Текст запроса может включать комментарии. Комментарием считается часть строки, начинающаяся с последовательности символов // и продолжающаяся до конца строки:

// Это комментарий.

При выполнении запроса комментарии игнорируются.

Двуязычное представление ключевых слов

Одной из существенных особенностей языка запросов 1C: Предприятия является то, что как и во встроенном языке, все ключевые слова имеют два варианта написания: на русском и английском языках. Далее в этой главе указываются русские варианты написания ключевых слов. Ниже приведена таблица, в которой приведены соответствия русского и английского и вариантов написания ключевых слов языка запросов ...... (пропущено)

Основные секции текста запроса

Текст запроса можно описать следующим правилом:

<Текст Запроса >

<Описание запроса>
[<Объединение запросов>]
[<Упорядочивание результатов>]
[АВТОУПОРЯДОЧИВАНИЕ]
[<Описание итогов>]

Как видно из этого правила, текст запроса состоит из нескольких частей, или секций:

<Описание запроса> - это единственная обязательная секция в тексте запроса, и во многих случаях достаточно указать только ее. В секции определяются источники данных запроса, поля выборки, группировки и т. д. Эта секция, в свою очередь, описывается целым набором правил и подробно рассматривается ниже.

<Объединение запросов> - язык запросов позволяет объединять результаты выполнения нескольких запросов. Объединение запросов описано на стр. 319.

В секции <Упорядочивание результатов> можно определить условия упорядочивания строк в результате запроса. Упорядочивание результата запроса рассматривается на стр. 324.

АВТОУПОРЯДОЧИВАНИЕ позволяет включить режим автоматического упорядочивания строк в результате запроса. Данный режим описывается на стр. 331.

В секции <Описание итогов> можно указать, какие итоги необходимо рассчитывать в запросе. Описание данной секции приводится на стр. 332.

Описание запроса

Как уже было сказано, в тексте запроса должна обязательно присутствовать секция описания запроса, в которой определяются:

• поля, которые будут содержаться в результате запроса;

• источники данных запроса - исходные таблицы;

• условия, влияющие на выборку данных в запросе;

• порядок группировки результатов запроса.

Секция описания запроса состоит из нескольких взаимосвязанных предложений:

<Описание запроса>

ВЫБРАТЬ [РАЗЛИЧНЫЕ] [ПЕРВЫЕ <Количество>]
<Список полей выборки>
[ИЗ <Список источников>]
[ГДЕ <Условие отбора>]
[СГРУППИРОВАТЬ ПО <Поля группировки>]
[ИМЕЮЩИЕ <Условие отбора>]
[ДЛЯ ИЗМЕНЕНИЯ [[OF] <Список таблиц верхнего уровня>]]

Описание запроса начинается с обязательного ключевого слова ВЫБРАТЬ.

С помощью ключевого слова РАЗЛИЧНЫЕ можно указать, что в результат не должны попадать повторяющиеся строки.

Конструкция ПЕРВЫЕ <Количество> позволяет задать предельное количество строк в результате запроса. Будут отобраны самые первые (в соответствии с правилами упорядочивания результатов запроса) строки. <Количество> задается целым числом.

В секции <Список полей выборки> описываются поля, которые должны содержаться в результате запроса. Подробно правила описания полей выборки рассматриваются на стр. 300.

В предложении ИЗ <Список источников> указываются источники данных - таблицы информационной базы, содержимое которых обрабатывается в запросе. Описание источников может быть опущено только в том случае, если они полностью определены в списке полей выборки. Правила описания источников данных запроса рассматриваются на стр. 305.

Предложение ГДЕ <Условие отбора> позволяет отфильтровать результат запроса. В результат попадают только те записи, для которых указанное условие оказывается истинным. Правила описания условий отбора рассматриваются на стр. 315.

Предложение ДЛЯ ИЗМЕНЕНИЯ предназначено для указания необходимости блокировки считываемых в транзакции данных.

Предложение СГРУППИРОВАТЬ позволяет описать порядок группировки результатов запроса. Подробно группировка рассматривается на стр. 316.

Предложение ИМЕЮЩИЕ позволяет накладывать условия на результаты группировки. Описано на стр. 318.

Во всех примерах запросов в данной главе приводится текст запроса и результат запроса. Подразумевается, что текст запроса передается в качестве параметра методу Выполнить объекта Запрос.

Приведем пример достаточно простого запроса, состоящего из одного оператора ВЫБРАТЬ и списка полей выборки.

Пример:

//В отчет необходимо вывести список товарных накладных.

Выбрать Документ.РасходнаяНакладная.Ссылка

Результат запроса:

Ссылка
Расходная накладная 00005 от 01.03.2002 20:58:28
Расходная накладная 00004 от 01.03.2002 20:50:40
Расходная накладная 00003 от 23.02.2002 0:00:00
Расходная накладная 00002 от 15.01 2002 0:00:01
Расходная накладная 00001 от 25.02 2002 0:00:00
Расходная накладная 00009 от 01.03 2002 10:10:22
Расходная накладная 00016 от 07.07 2002 0:00:00

Использование слова РАЗЛИЧНЫЕ

Во многих ситуациях желательно, чтобы одинаковые строки в отчете не повторялись.

Пример:

// Необходимо узнать, каким вообще контрагентам
// отгружался товар за период.
Выбрать Документ.РасходнаяНакладная.Контрагент

Результат запроса:

Контрагент
Павильон 45 на оптовом рынке
Ярмарка одежды
Павильон 45 на оптовом рынке
Торговый дом «Буденовский»
Ярмарка одежды
Ярмарка одежды

Видно, что в результате запроса много повторяющихся строк, что снижает его наглядность. Чтобы избежать повторений, в описании запроса следует указать ключевое слово РАЗЛИЧНЫЕ.

Пример:

Выбрать Различные Документ.РасходнаяНакладная.Контрагент

Результат запроса:

Контрагент
Павильон 45 на оптовом рынке
Ярмарка одежды
Торговый дом «Буденовский»

Использование слова ПЕРВЫЕ

В некоторых случаях необходимо вывести в отчет ограниченное количество строк. Для этого в описании запроса следует указать ключевое слово ПЕРВЫЕ, и после него - требуемое количество строк.

Пример:

// Необходимо отобрать пять самых дорогих товаров.
// Выборка должна осуществляться в порядке убывания цены товара.
Выбрать Первые 5
Справочник.Номенклатура.Наименование,
Справочник.Номенклатура.ЗакупочнаяЦена
Упорядочить По Справочник.Номенклатура.ЗахупочнаяЦена Убыв

Результат запроса:

Наименование | ЗакупочнаяЦена
Кухонный комбайн Крупс | 15000
Джинсы женские | 1500
Рубашка «Ковбойка» | 1100
Брюки детские | 800
Смеситель «Ультра» | 460

Описание полей выборки

После обязательного ключевого слова ВЫБРАТЬ (и уточняющих слов РАЗЛИЧНЫЕ и ПЕРВЫЕ) в тексте запроса задается список полей выборки. Эти поля будут обрабатываться при выборке данных в запросе. Результат запроса также будет иметь набор полей, определенный в данном списке. Поля выборки описываются по следующим правилам:

<Список полей выборки>

<Поле выборки>[, <Поле выборки>[, ...] ] | *

<Поле выборки>

<Описание поля> [ [КАК] <Псевдоним поля>]

<Описание поля>

<Выражение>[.<Группа полей>]

Список полей выборки состоит из одного или нескольких элементов, разделенных запятыми. Каждое <Поле выборки> состоит из описания поля выборки и необязательного псевдонима поля.

Вместо перечисления полей в списке выборки можно указать звездочку «*». Это будет означать, что результат запроса должен содержать все поля, которые есть в исходных таблицах - источниках данных запроса, описанных в списке источников.

Замечание! При указании звездочки «*» в списке полей выборки в результат не включаются виртуальные поля исходных таблиц.

<Описание поля> определяет, каким образом должны формироваться значения поля. В простейшем случае поле выборки является ссылкой на поле исходной таблицы. Ссылка может задаваться с указанием таблицы, содержащей это поле, или без указания самой таблицы. Разыменование полей рассматривается на стр. 345.

В общем случае поле выборки может представлять собой не только ссылку на поле исходной таблицы, а некоторое <Выражение>. Подробно выражения рассмотрены на стр. 344.

Результаты запроса могут быть сгруппированы с помощью агрегатных функций, указанных в качестве выражений в полях выборки. Группировка результатов запроса рассматривается на стр. 316. Агрегатные функции описаны на стр. 345.

Каждому полю выборки может быть назначен псевдоним. В дальнейшем <Псевдоним поля> может использоваться для более удобного обращения к данному полю. Применение псевдонимов полей рассмотрено ниже.

<Группа полей> может указываться только тогда, когда поле выборки указывает на вложенную таблицу. В этом случае можно указать, какие поля должны обрабатываться в выборке по вложенной таблице. Если группа полей не указана, в выборке будут обрабатываться все поля вложенной таблицы. Обращение к вложенным таблицам описывается на стр. 303.

Псевдонимы полей в списке выборки

Если полю выборки назначить псевдоним, то в дальнейшем к этому полю можно будет обращаться, используя его псевдоним, в предложениях УПОРЯДОЧИТЬ ПО и ИТОГИ, а также при работе с результатом запроса. Такое обращение может быть более удобным и наглядным, а в некоторых случаях единственно возможным.

Ключевое слово КАК может предшествовать псевдониму поля. Это слово можно не указывать вообще, но если оно указано, повышается наглядность и удобочитаемость текста запроса.

Псевдонимы полей задаются в соответствии с правилами назначения идентификаторов переменных. Псевдонимы в запросе не могут совпадать.

Назначение псевдонимов полям само по себе никак не влияет на выборку данных в запросе.

Пример:

// Необходимо выбрать из справочника товаров
// наименования товаров и наименования групп.
Выбрать
Справочник. Номенклатура.Наименование Как Товар,
Справочник. Номенклатура.Родитель.Наименование Как Группа
из
Справочник.Номенклатура

Результат запроса:

Товар | Группа
Брюки детские | Одежда
Рубашка «Ковбойка» | Одежда
Одежда
Джинсы женские | Одежда
Свитер детский | Одежда
Сантехника
Бытовая техника
Раковина «Лилия» | Сантехника
Мойдодыр «Аквариум» | Сантехника
Смеситель «Ультра» | Сантехника

Обратите внимание, что поля в результате запроса поля называются «Товар» и «Группа». Если бы псевдонимы полей не были указаны, поля в результате запроса назывались бы «Наименование» и «Наименование1» (названия полей в результате запроса не могут совпадать, поэтому к названию второго поля автоматически добавлено «1»), что гораздо менее наглядно.

Вложенные таблицы в списке полей выборки

Поле в списке выборки может ссылаться на вложенную таблицу источника данных запроса. В этом случае поле результата запроса будет иметь тип РезультатЗапроса, то есть содержать вложенный результат запроса, сформированный на основе вложенной таблицы - источника.

По умолчанию во вложенный результат включаются все поля вложенной таблицы - источника данных. Имеется возможность явно определить группу полей, которые должны содержаться во вложенном результате запроса. Группа полей вложенного результата описывается по следующему правилу:

<Группа полей>

( <Список вложенных полей> ) | *

<Список вложенных полей>

<Вложенное поле [, <Вложенное поле>[, ...] ]

<Список вложенных полей> состоит из одного или нескольких элементов, разделенных запятыми. Если список состоит из одного элемента, его не обязательно заключать в скобки.

Вместо перечисления вложенных полей можно указать звездочку «*»; это будет означать, что во вложенный результат запроса должен содержать все поля, которые есть во вложенной таблице.

<Вложенное поле>

<Выражение> [[КАК] <Псевдоним поля>]

<Вложенное поле> может представлять некоторое выражение. В простейшем случае <Выражение> - это ссылка на поле вложенной таблицы. Подробно выражения рассмотрены на стр. 344.

Каждому вложенному полю может быть назначен псевдоним. В дальнейшем <Псевдоним поля> может использоваться для более удобного обращения к данному полю, аналогично псевдонимам полей списка выборки - см. раздел «Псевдонимы полей в списке выборки» на стр. 301.

Псевдонимы вложенным полям могут быть назначены независимо от того, задан ли псевдоним самой вложенной таблице.

Пример:

//В отчет необходимо вывести спецификацию товарных накладных,
// сам документ, номенклатуру и количество.
Выбрать
Документ.РасходнаяНакладная.Ссылка,
Документ.РасходнаяНакладная.Состав.(Номенклатура Как Товар, Количество)

Результат запроса:

Ссылка | Состав
Товар | Количество
Расходная накладная 00007 от 25.02.2002 21:03:21 | Джинсы женские | 4
Расходная накладная 00006 от 25.02.2002 0:00:00 | Джинсы женские | 5
Рубашка «Ковбойка» | 5
Расходная накладная 00005 от 24.02.2002 0:00:00 | Джинсы женские | 1
Расходная накладная 00004 от 01.03.2002 20:50:40 | Джинсы женские | 1
Расходная накладная 00003 от 23.02.2002 0:00:00 | Мойдодыр «Аквариум» | 5
Раковина «Лилия» | 8
Смеситель «Ультра» | 10

Обратите внимание, что поле «Состав» результата запроса представляет собой вложенную таблицу, имеющую поля «Номенклатура» и «Количество».

Пример:

//В отчет вывести все поля табличной части накладной.
Выбрать
Документ.РасходнаяНакладная.Ссылка,
Документ.РасходнаяНакладная.Состав.*

Описание источников запроса

Задача предложения ИЗ состоит в том, чтобы обозначить список исходных таблиц - источников данных, используемых в данном операторе ВЫБРАТЬ.

Следует, отметить, что предложение ИЗ в языке запросов является опциональным. Оно может быть опущено в том случае, если источники данных полностью квалифицированы в описании списка полей выборки, содержащегося в предложении ВЫБРАТЬ. Обратите внимание, что ряд примеров в предыдущих разделах не содержал предложения ИЗ.

После ключевого слова ИЗ указывается список источников. В общем случае список источников описывается следующим набором правил:

<Список источников>

<Источник>[, <Источник>[, ...]]

Источники данных запроса перечисляются в списке источников через запятую. Каждый <Источник> в списке источников обязательно включает в себя описание источника; кроме того, может быть указан <Перечень соединений> - правила соединений источника с другими источниками. Спецификации соединений описываются ниже.

<Источник>

<Описание источника> [ <Перечень соединений> ]

Если в качестве источника данных выступает таблица информационной базы, <Описание источника> содержит <Имя таблицы>.

<Описание источника>

<Таблица> [ [КАК] <Псевдоним источника>]

Если исходная таблица виртуальная, могут быть указаны <Параметры> ее формирования. Подробно параметры виртуальных таблиц описаны в разделе «Источники данных запросов».

<Таблица>

<Имя таблицы> [(<Параметры>)] | <Описание запроса>

В качестве источника данных запроса может выступать также вложенный запрос; в этом случае описание источника содержит <Описание запроса>. Использование вложенных запросов описано на стр. 315.

В описании источника данных может быть также назначен его псевдоним. В дальнейшем <Псевдоним источника> может использоваться для более удобного обращения к данному источнику. Применение псевдонимов источников данных рассмотрено на стр. 313.

Спецификации соединений

При определении нескольких источников в списке источников для каждой записи из первой таблицы-источника осуществляется выборка из второй таблицы-источника, и т.д. Таким образом, в результате запроса формируются все возможные комбинации всех записей из всех указанных источников.

Пример:

Выбрать
Контрагенты.Ссылка Как Контрагент,
Банки.Ссылка Как Банк
Из
Справочник.Контрагенты Как Контрагенты,
Справочник.Банки Как Банки

Результат запроса:

Контрагент | Банк
Поставщики | АКБ ИвестБанк
Поставщики | АКБ ПромСтройБанк
Трикотажная фабрика «Заря» | АКБ ИвестБанк
Трикотажная фабрика «Заря» | АКБ ПромСтройБанк
Фабрика джинсовой одежды | АКБ ИвестБанк
Фабрика джинсовой одежды | АКБ ПромСтройБанк
Покупатели | АКБ ИвестБанк
Покупатели | АКБ ПромСтройБанк
Ярмарка одежды | АКБ ИвестБанк
Ярмарка одежды | АКБ ПромСтройБанк
Торговый дом «Буденовский» | АКБ ИвестБанк
Торговый дом «Буденовский» | АКБ ПромСтройБанк
Павильон 45 на оптовом рынке | АКБ ИвестБанк
Павильон 45 на оптовом рынке | АКБ ПромСтройБанк
Бавария - фарфор | АКБ ИвестБанк
Бавария - фарфор | АКБ ПромСтройБанк
Фабрика джинсовой одежды | АКБ ИвестБанк
Фабрика джинсовой одежды | АКБ ПромСтройБанк
АКБ ПромСтройБанк | АКБ ИвестБанк
АКБ ПромСтройБанк | АКБ ПромСтройБанк

Результат запроса содержит комбинации всех контрагентов со всеми банками. Как правило, такой результат сам по себе смысла не имеет. Обычно комбинации записей из разных исходных таблиц требуется ограничить какими-либо условиями. В языке запросов имеется возможность описать такое соединение источников, указывая сами источники и определяя условия, в соответствии с которыми комбинации записей из этих источников требуется включить в результат запроса.

Соединения бывают нескольких видов, они описываются следующими правилами:

<Перечень соединений>

<Соединение> [<Перечень соединений>]

В общем случае <Перечень соединений> может содержать и описывать не только одно соединение (двух источников), но и несколько соединений нескольких источников сразу.

<Соединение>

[ВНУТРЕННЕЕ] СОЕДИНЕНИЕ <Описание источника> ПО <Условие отбора> |

ЛЕВОЕ [ВНЕШНЕЕ] СОЕДИНЕНИЕ <Описание источника> ПО <Условие отбора> |

ПРАВОЕ [ВНЕШНЕЕ] СОЕДИНЕНИЕ <Описание источника> ПО <Условие отбора> |

ПОЛНОЕ (ВНЕШНЕЕ] СОЕДИНЕНИЕ <Описание источника> ПО <Условие отбора>

<Описание источника> содержит описание исходной таблицы - см. раздел «Описание источников запроса» на стр. 305.

<Условие отбора> содержит условия, в соответствии с которыми в выборке необходимо соединить данные из исходных таблиц - источников запроса. Правила описания условий в языке запросов рассматриваются на стр. 357.

Ключевые слова ЛЕВОЕ, ПРАВОЕ и ПОЛНОЕ уточняют характер соединения. Слова ВНУТРЕННЕЕ или ВНЕШНЕЕ можно не указывать вообще, они повышают наглядность и удобочитаемость текста запроса.

Соединяемые источники не равнозначны между собой, и в некоторых случаях результат зависит от того, какая таблица указана первой, до ключевого слова СОЕДИНЕНИЕ (слева от него), а какая - второй (справа).

Внутреннее соединение

[ВНУТРЕННЕЕ] СОЕДИНЕНИЕ означает, что из обеих исходных таблиц - источников данных в результат запроса необходимо включить только те комбинации записей, которые соответствуют указанному условию. Остальные записи в результат не попадают.

Пример:

// Необходимо выяснить, какие банки является одновременно
// контрагентами (одинаковые наименования присутствует
//и в справочнике Контрагенты, и в справочнике Банки).
Выбрать
Контрагенты.Ссылка Как Контрагент,
Банки.Ссылка Как Банк
Из
Справочник.Контрагенты Как Контрагенты
Внутреннее Соединение
Справочник.Банки Как Банки
По
Контрагенты.Наименование = Банки.Наименование

Результат запроса:

Контрагент | Банк
АКБ ПромСтройБанк | АКБ ПромСтройБанк

Левое внешнее соединение

ЛЕВОЕ [ВНЕШНЕЕ] СОЕДИНЕНИЕ означает, что в результат запроса надо включить комбинации записей из обеих исходных таблиц, которые соответствуют указанному условию. Но, в отличие от внутреннего соединения, в результат запроса надо включить также еще и записи из первого (указанного слева от слова СОЕДИНЕНИЕ) источника, для которых не найдено соответствующих условию записей из второго источника.

Таким образом, в результат запроса будут включены все записи из первого источника; они будут соединены с записями из второго источника при выполнении указанного условия. Строки результата запроса, для которых не найдено соответствующих условию записей из второго источника, будут содержать NULL в полях, формируемых на основании записей из этого источника.

Пример:

//В отчет необходимо вывести всех контрагентов, а для тех,
// кто является также банком - указать ссылку на банк.
Выбрать
Контрагенты.Ссылка Как Контрагент,
Банки.Ссылка Как Банк
Из
Справочник.Контрагенты Как Контрагенты
Левое Внешнее Соединение
Справочник.Банки Как Банки
По
Контрагенты.Наименование = Банки.Наименование

Результат запроса:

Контрагент | Банк
Поставщики | NULL
Трикотажная фабрика «Заря» | NULL
Фабрика джинсовой одежды | NULL
Покупатели | NULL
Ярмарка одежды | NULL
Торговый дом «Буденовский» | NULL
Павильон 45 на оптовом рынке | NULL
Бавария - фарфор | NULL
Фабрика джинсовой одежды | NULL
АКБ ПромСтройБанк | АКБ ПромСтройБанк

Правое внешнее соединение

ПРАВОЕ [ВНЕШНЕЕ] СОЕДИНЕНИЕ означает, что в результат запроса надо включить комбинации записей из обеих исходных таблиц, которые соответствуют указанному условию. Кроме того, в результат запроса надо включить также еще и записи из второго (указанного справа от слова СОЕДИНЕНИЕ) источника, для которых не найдено соответствующих условию записей из первого источника.

Таким образом, в результат запроса будут включены все записи из второго источника; они будут соединены с записями из первого источника при выполнении указанного условия. Строки результата запроса, для которых не найдено соответствующих условию записей из первого источника, будут содержать NULL в полях, формируемых на основании записей из этого источника.

Пример:

//В отчет необходимо вывести все банки, а для тех,
// кто является также и контрагентом - указать ссылку на контрагента.
ВЫБРАТЬ
Контрагенты.Ссылка Как Контрагент,
Банки.Ссылха Как Банк
ИЗ
Справочник.Контрагенты Как Контрагенты
Правое Внешнее Соединение
Справочник.Банки Как Банки
По
Контрагенты.Наименование = Банки.Наименование

Результат запроса:

Контрагент | Банк
NULL | АКБ ИвестБанк
АКБ ПромСтройБанк | АКБ ПромСтройБанк

Полное внешнее соединение

ПОЛНОЕ [ВНЕШНЕЕ] СОЕДИНЕНИЕ означает, что в результат запроса надо включить комбинации записей из обеих исходных таблиц, которые соответствуют указанному условию. Кроме того, в результат запроса надо включить также еще и те записи из обоих источников, для которых не найдено соответствий.

Таким образом, в результат запроса будут включены все записи из обоих источников; они будут соединены друг с другом при выполнении указанного условия. Строки результата запроса, для которых не найдено соответствующих условию записей из какого-либо источника, будут содержать NULL в полях, формируемых на основании записей из этого источника.

Пример:

// В отчет необходимо вывести всех контрагентов и все банки,
// а.тех, кто является и тем, и другим - вывести в одной строке.
Выбрать
Контрагенты.Ссылка Как Контрагент,
Банки.Ссылка Как Банк
Из
Справочник.Контрагенты Как Контрагенты
Полное Внешнее Соединение
Справочник.Банки Как Банки
По
Контрагенты.Наименование = Банки.Наименование

Результат запроса:

Контрагент | Банк
Поставщики | NULL
Трикотажная фабрика «Заря» | NULL
Фабрика джинсовой одежды | NULL
Покупатели | NULL
Ярмарка одежды | NULL
Торговый дом «Буденовский» | NULL
Павильон 45 на оптовом рынке | NULL
Бавария - фарфор | NULL
Фабрика джинсовой одежды | NULL
АКБ ПромСтройБанк | АКБ ПромСтройБанк
NULL | АКБ ИвестБанк

Псевдонимы источников данных

Если источнику данных назначить псевдоним, то в дальнейшем к этому источнику можно будет обращаться, используя этот псевдоним (и уже нельзя будет обращаться через указание имени таблицы). Такое обращение может быть более удобным и наглядным, а в некоторых случаях единственно возможным.

Псевдоним задается в соответствии с правилами назначения идентификаторов переменных. Псевдонимы в запросе не могут совпадать.

Ключевое слово КАК может предшествовать псевдониму источника. Это слово можно не указывать вообще, но если оно указано, повышается наглядность и удобочитаемость текста запроса.

Назначение псевдонимов источникам само по себе никак не влияет на выборку данных в запросе.

Пример:

// Данный пример демонстрирует использование
// в списке полей выборки псевдонима Товар,
// назначенного исходной таблице Справочник.Номенклатура
Выбрать
Товар.Наименование,
Товар.Родитель
Из
Справочник.Номенклатура.Товар

Вложенные таблицы в списке источников

В списке источников могут фигурировать и вложенные таблицы - табличные части справочников и документов.

Пример:

//В отчет необходимо вывести спецификацию товарных накладных -
// показать сам документ, номенклатуру и количество.
//В списке источников указана вложенная таблица «Состав» -
// табличная часть накладной.
// Выборка ограничена восемью записями, чтобы не перегружать пример.
Выбрать Первые 8
Ссылка, Номенклатура, Количество
Из
Документ.РасходнаяНакладная.Состав

Результат запроса:

Ссылка | Номенклатура | Количество
Расходная накладная 00007 от 25.02.2002 21:03:21 | Джинсы женские | 4
Расходная накладная 00006 от 25.02.2002 0:00:00 | Джинсы женские | 5
Расходная накладная 00006 от 25.02.2002 0:00:00 | Рубашка «Ковбойка» | 5
Расходная накладная 00005 от 01.03.2002 20:58:28 | Джинсы женские | 1
Расходная накладная 00004 от 01.03.2002 20:50:40 | Джинсы женские | 1
Расходная накладная 00003 от 23.02.2002 0:00:00 | Мойдодыр «Аквариум» | 5
Расходная накладная 00003 от 23.02.2002 0:00:00 | Раковина «Лилия» | 8
Расходная накладная 00003 от 23.02.2002 0:00:00 | Смеситель «Ультра» | 10

Обратите внимание, что при указании вложенной таблицы в списке источников допускается обращение, как к полям самой вложенной таблицы, так и к полям таблицы верхнего уровня (той, которая содержит вложенную таблицу). В данном случае происходит обращение к полю «Ссылка» самого документа.

Вложенные запросы в списке источников

В списке источников запроса в качестве таблицы-источника может использоваться вложенный запрос. В этом случае описание источника содержит описание вложенного запроса. Описание вложенного запроса составляется точно так же, как и обычного: см. на стр. 295

Использование вложенного запроса в качестве источника данных ничем не отличается от использования таблицы информационной базы. В качестве полей такого источника доступны все поля, описанные в списке полей выборки вложенного запроса.

Пример:

Выбрать
Ссылка, Номенклатура, Количество
Из
(Выбрать Первые 8
Ссылка, Номенклатура, Количество
Из
Документ.РасходнаяНакладная.Состав )
Как
ВложенныйЗапрос

Результат будет точно таким же, как и в предыдущем примере.


2-315 Фильтрация результатов запроса

Фильтрация результатов запроса

Предложение ГДЕ <Условие отбора> позволяет задать условие отбора данных из исходных таблиц - источников запроса; в запросе будут обрабатываться только те записи, для которых данное условие оказывается истинным.

Воспользуемся примером из раздела «Спецификации соединений» на стр. 309, переписав его с использованием предложения ГДЕ.

Пример:

// Необходимо выяснить, какие банки являются одновременно
// контрагентами (одинаковые наименования присутствуют
// и в справочнике Контрагенты, и в справочнике Банки).
Выбрать
Контрагенты.Ссылка Как Контрагент,
Банки.Ссылка Как Банк
Из
Справочник.Контрагенты Как Контрагенты,
Справочник.Банки Как Банки
Где
Контрагенты.Наименование = Банки.Наименование

Результат запроса:

Контрагент | Банк
АКБ Промстройбанк | АКБ ПромСтройБанк

Результат, как и в примере параграфа «Внутреннее соединение», содержит всего одну запись.

Обратите внимание: совершенно необязательно, чтобы поле, фигурирующее в предложении ГДЕ, входило в список выборки.

Условие отбора может определяться и как простое логическое выражение, и как более сложное, в котором простые логические выражения соединяются между собой логическими операторами И, ИЛИ, НЕ. Подробно правила описания условий в языке запросов рассматриваются в параграфе «Условия в языке запросов».

Группировка результатов запроса

Исходные данные в запросе могут быть сгруппированы с помощью агрегатных функций, указанных в качестве полей в списке выборки. Это означает, что строки в результате запроса будут содержать результаты вычисления указанных агрегатных функций, рассчитанные (сгруппированные) по записям исходных таблиц.

Сами агрегатные функции указываются в списке полей выборки; в предложении СГРУППИРОВАТЬ ПО <Поля группировки> необходимо указать список полей, по которым следует произвести группировку. В запросе будут группироваться записи исходных таблиц, содержащие одинаковые значения указанных полей.

Список полей группировки содержит ссылки на поля исходных таблиц - источников запроса, указанные через запятую:

<Поля группировки>

<Разыменование поля> [, <Разыменование поля> [, ...] ]

Важно! При группировке результатов запроса в списке полей выборки обязательно должны быть указаны агрегатные функции, а помимо агрегатных функций в списке полей выборки допускается указывать только поля, по которым осуществляется группировка.

Исключение составляют ситуации, когда агрегатные функции применены к полям вложенной таблицы В этом случае в списке полей выборки возможны обращения к полям таблицы верхнего уровня, без группировки результатов по этим полям.

При использовании агрегатных функций предложение СГРУППИРОВАТЬ ПО может быть и не указано совсем; при этом все результаты запроса будут сгруппированы в одну единственную строку.

Пример:

// Требуется получить статистику по продаже товаров:
// максимальную, минимальную и среднюю цены в расходных накладных.
Выбрать
Накладная.Номенклатура,
Среднее (Накладная.Цена) Как Среднее,
Максимум (Накладная.Цена) Как Максимум,
Минимум (Накладная.Цена) Как Минимум
Из
Документ,РасходнаяНакладная.Состав Как Накладная
Сгруппировать По
Накладная. Номенклатура

Результат запроса:

Номенклатура | Среднее | Максимум | Минимум
Брюки детские | 1 500 | 1 500 | 1 500
Рубашка «Ковбойка» | 800 | 800 | 800
Джинсы женские | 1 520 | 1 700 | 1 500
Свитер детский | 800 | 800 | 800
Раковина Лилия | 2 250 | 2 250 | 2 250
Мойдодыр «Аквариум» | 3 166,666667 | 4 000 | 2 000
Смеситель Ультра | 1 500 | 1 500 | 1 500
Кухонный комбайн Крупс | 1 500 | 1 500 | 1 500

Условия на значения агрегатных функций

Предложение ИМЕЮЩИЕ <Условие отбора> позволяет накладывать условия на значения агрегатных функций. В других конструкциях языка запросов, например в предложении ГДЕ, указывать в условиях агрегатные функции нельзя.

Пример:

// Необходимо выбрать товары, которых продали более 20 штук.
Выбрать
Накладная.Номенклатура,
Сумма (Накладная.Количество) Как Количество
Из
Документ.РасходнаяНакладная.Состав Как Накладная
Сгруппировать По
Накладная.Номенклатура
Имеющие
Сумма (Накладная.Количество) > 20

Результат запроса:

Номенклатура | Количество
Рубашка «Ковбойка» | 30
Джинсы женские | 43
Мойдодыр «Аквариум» | 27

Важно! В условии отбора можно использовать только агрегатные функции и поля, по которым осуществляется группировка.

Объединение запросов

В языке запросов имеется возможность объединять несколько запросов; при этом записи, полученные с помощью каждого из объединяемых запросов, будут собраны в один результат запроса.

При объединении каждый запрос собирает данные независимо, а такие операции, как дополнение результатов, упорядочивание результатов и расчет итогов выполняются уже над результатом объединения запросов.

Поля результата запроса будут называться так, как описано в списке полей выборки первого из объединяемых запросов. Поля выборки остальных запросов сопоставляются с полями результата в соответствии с порядком их следования в списке полей выборки. Объединяемые запросы должны иметь одинаковое количество полей в списке полей выборки.

Если поля выборки объединяемых запросов имеют разный тип, то поля результата запроса будут иметь составной тип.

Объединение запросов описывается по следующему правилу:

<Объединение запросов>

ОБЪЕДИНИТЬ [ВСЕ] <Описание запроса>
[<Объединение запросов>]

Объединение запросов начинается с обязательного ключевого слова ОБЪЕДИНИТЬ, после которого следует описание присоединяемого запроса. Далее может присоединяться еще один запрос и т.д.

По умолчанию при объединении запросов полностью одинаковые строки в результате запроса, сформированные разными запросами, заменяются одной. Если требуется, чтобы были оставлены разные строки, необходимо указать ключевое слово ВСЕ.

Пример:

Выбрать
Накладная.Контрагент,
Накладная.Номенклатура,
Сумма(Накладная.Количество) Как Приход,
Сумма(0) Как Расход
Из
Документ.ПриходнаяНакладная.Состав Накладная
Сгруппировать По
Контрагент,
Номенклатура
Объединить Все
Выбрать
Накладная.Контрагент,
Накладная.Номенклатура,
Сумма (0) ,
Сумма (Накладная.Количество)
Из
Документ.РасходнаяНакладная.Состав Накладная
Сгруппировать По
Контрагент,
Номенклатура
Упорядочить По
Контрагент,
Номенклатура
Итоги По
Контрагент
Итоги Общие

Результат запроса:

Контрагент | Номенклатура | Приход | Расход
1 943 | 151
Трикотажная фабрика «Заря» | 443 | 4
Трикотажная фабрика «Заря» | Брюки детские | 3
Трикотажная фабрика «Заря» | Брюки детские | 100
Трикотажная фабрика «Заря» | Рубашка «Ковбойка» | 200
Трикотажная фабрика «Заря» | Джинсы женские | 1
Трикотажная фабрика «Заря» | Джинсы женские | 80
Трикотажная фабрика «Заря» | Свитер детский | 60
Трикотажная фабрика «Заря» | Кухонный комбайн Крупc | 3
Ярмарка одежды | 42
Ярмарка одежды | 20
Ярмарка одежды | 20
Ярмарка одежды | 2
Торговый дом «Буденовский» | 53
Торговый дом «Буденовский» | Брюки детские | 10
Торговый дом «Буденовский» | Рубашка «Ковбойка» | 5
Торговый дом «Буденовский» | Джинсы женские | 12
Торговый дом «Буденовский» | Свитер детский | 1
Торговый дом «Буденовский» | Раковина «Лилия» | 8
Торговый дом «Буденовский» | Мойдодыр «Аквариум» | 5
Торговый дом «Буденовский» | Смеситель «Ультра» | 10
Торговый дом «Буденовский» | Кухонный комбайн Крупc | 2
Павильон 45 на оптовом рынке | 44
Павильон 45 на оптовом рынке | Рубашка «Ковбойка» | 5
Павильон 45 на оптовом рынке | Джинсы женские | 9
Павильон 45 на оптовом рынке | Раковина «Лилия» | 10
Павильон 45 на оптовом рынке | Мойдодыр «Аквариум» | 20
Бавария-фарфор | 1 500 | 8
Бавария-фарфор | Брюки детские | 7
Бавария-фарфор | Джинсы женские | 1
Бавария-фарфор | Раковина «Лилия» | 270
Бавария-фарфор | Мойдодыр «Аквариум» | 230
Бавария-фарфор | Смеситель «Ультра» | 1 000

Упорядочивание результатов запроса

Предложение УПОРЯДОЧИТЬ ПО позволяет сортировать строки в результате запроса.

<Упорядочивание результатов>

УПОРЯДОЧИТЬ ПО <Условия упорядочивания>

<Условия упорядочивания>

<Поле упорядочивания> [<Порядок>]
[,<Поле упорядочивания> [<Порядок>][, ...]]

<Поле упорядочивания>

<Выражение> | <Упорядочивание ссылочного поля>

<Упорядочивание ссылочного поля>

<Разыменование поля>[( <Имя поля> [, <Имя поля>[, ...] ] )]

<Порядок>

ВОЗР | УБЫВ | ИЕРАРХИЯ

В предложении УПОРЯДОЧИТЬ ПО через запятую перечисляются условия, в соответствии с которыми необходимо упорядочить результат запроса. Выборки упорядочиваются сначала по первому условию, потом по второму и т. д.

<Условие упорядочивания> в общем случае может представлять собой некоторое выражение. Строки результата запроса будут упорядочены по значениям этого выражения, рассчитанным для каждой строки. Выражения языка запросов рассматриваются на стр. 344.

Упорядочивание может осуществляться в порядке возрастания или убывания значений, а для таблиц, для которых задано свойство иерархичности - так же и по иерархии (описано на стр. 326). <Порядок> может задаваться для каждого поля независимо. Правила сравнения значений описаны на стр. 360.

<Упорядочивание ссылочного поля>. Если поле упорядочивания является ссылкой на таблицу, то в скобках после самой ссылки можно указать поля этой таблицы, по которым следует осуществить упорядочивание. Упорядочивание по ссылочным полям описано на стр.329.

Поле, фигурирующее в условиях упорядочивания совсем необязательно должно попадать в результат запроса.

Важно! Если в запросе рассчитываются итоги (встречается предложение ИТОГИ ПО), то и результат запроса обязательно должен быть упорядочен по тем полям, по которым рассчитываются итоги: поля, указанные в предложении ИТОГИ ПО, обязательно требуется указать и в предложении УПОРЯДОЧИТЬ ПО.

Пример:

// Требуется отобрать 5 самых дорогих товаров,
// расположив их в порядке убывания цены.
Выбрать Первые 5
Справочник.Номенклатура.Наименование,
Справочник.Номенклатура.ЗакупочнаяЦена
Упорядочить По
Справочник.Номенклатура.ЗакупочнаяЦена Убыв

Результат запроса:

Наименование | ЗакупочнаяЦена
Кухонный комбайн Крупе | 15000
Джинсы женские | 1 500
Рубашка «Ковбойка» | 1 100
Брюки детские | 800
Смеситель «Ультра» | 460

Упорядочивание по иерархии

Для справочников можно назначать упорядочивание по иерархии справочника.

Пример:

Выбрать
Справочник.Контрагенты.Наименование,
Справочник.Контрагенты.ПолноеНаименование
Упорядочить По
Справочник.Контрагенты.Наименование Иерархия

Результат запроса:

Наименование | ПолноеНаименование
Покупатели
Павильон 45 на оптовом рынке | ПБЮЛ «Красина»
Торговый дом «Буденовский» | АО «Буденовский ТД»
Фабрика джинсовой одежды | 000 «Джинсовая одежда»
Ярмарка одежды | 000 «Ярмарка одежды»
Поставщики
АКБ ПромСтройБанк
Бавария - фарфор
Трикотажная фабрика «Заря»
Фабрика джинсовой одежды | 000 «Джинсовая одежда»

Иерархически сортировать можно только по полю, но не по некоторой операции над ним. <Поле упорядочивания> должно содержать ссылку на поле исходной таблицы - источника данных запроса.

Важно понимать, что упорядочивание по иерархии имеет смысл задавать в том случае, если в качестве источника определена именно таблица справочника, а не какая-либо другая таблица, содержащая только ссылку на справочник.

Пример:

Выбрать
Накладная.Контрагент.Наименование,
Накладная.Номер,
Накладная.Сумма
Из
Документ.РасходнаяНакладная Как Накладная
Упорядочить По
Накладная.Контрагент Иерархия

В данном примере иерархического упорядочивания не получится, поскольку нет связи со справочником, и группы из этого справочника в результат запроса не попадут.

Для упорядочивания по иерархии необходимо организовать соединение со справочником.

Пример:

Выбрать
Контрагент.Наименование,
Накладная.Номер,
Накладная.Сумма
Из
Справочник.Контрагенты Как Контрагент
Левое Соединение
Документ.РасходнаяНакладная Как Накладная
По
Накладная.Контрагент = Контрагент.Ссылка
Упорядочить По
Контрагент.Наименование Иерархия

Результат запроса:

Наименование | Номер | Сумма
Покупатели
Павильон 45 на оптовом рынке | 00007 | 6000
Павильон 45 на оптовом рынке | 00006 | 11 500
Павильон 45 на оптовом рынке | 00016 | 80 000,23
Торговый дом «Буденовский» | 00004 | 1 500
Торговый дом «Буденовский» | 00003 | 52500
Торговый дом «Буденовский» | 00002 | 16000
Торговый дом «Буденовский» | 00009 | 555
Торговый дом «Буденовский» | 00015
Торговый дом «Буденовский» | 00014 | 16500
Торговый дом «Буденовский» | 00005 | 1 500
Фабрика джинсовой одежды
Ярмарка одежды | 00001 | 54000
Поставщики
АКБ ПромСтройБанк
Бавария - фарфор | 00013 | 12 000,22
Трикотажная фабрика «Заря» | 00012 | 4500
Фабрика джинсовой одежды

Упорядочивание по ссылочным полям

В некоторых случаях в предложении УПОРЯДОЧИТЬ ПО обязательно требуется указать ссылку на какую-либо таблицу (например, если по данной ссылке в запросе рассчитываются итоги), но при этом желательно упорядочить результат запроса по полям этой самой таблицы. В этом случае в предложении УПОРЯДОЧИТЬ ПО можно указать требуемые поля в скобках после ссылки на таблицу.

Пример:

//В отчет необходимо вывести данные об отгрузке товаров по накладным,
// упорядочив результаты по наименованию товаров.
Выбрать
Накладная.Номенклатура,
Накладная.Количество,
Накладная.Номер
Из
Документ.РасходнаяНакладная.Состав Как Накладная
Упорядочить По
Накладная.Номенклатура(Наименование),
Накладная.Номер
Итоги
Сумма(Накладная.Количество)
По
Накладная.Номенклатура

В данном примере в предложении УПОРЯДОЧИТЬ ПО обязательно требовалось указать ссылку на таблицу справочника «Номенклатура», поскольку по ней рассчитываются итоги. Однако результат запроса упорядочен по наименованию справочника «Номенклатура».

Результат запроса:

Номенклатура | Количество | Номер
Брюки детские | 20
Брюки детские | 3 | 00012
Брюки детские | 7 | 00013
Брюки детские | 10 | 00014
Джинсы женские | 43
Джинсы женские | 20 | 00001
Джинсы женские | 8 | 00002
Джинсы женские | 1 | 00004
Джинсы женские | 1 | 00005
Джинсы женские | 5 | 00006
Джинсы женские | 4 | 00007
Джинсы женские | 1 | 00009
Джинсы женские | 1 | 00012
Джинсы женские | 1 | 00013
Джинсы женские | 1 | 00014
Кухонный комбайн Крупе | 2
Кухонный комбайн Крупе | 2 | 00015
Мойдодыр «Аквариум» | 27
Мойдодыр «Аквариум» | 2 | 00001
Мойдодыр «Аквариум» | 5 | 00003
Мойдодыр «Аквариум» | 20 | 00016
Раковина «Лилия» | 18
Раковина «Лилия» | 8 | 00003
Раковина «Лилия» | 10 | 00016
Рубашка «Ковбойка» | 30
Рубашка «Ковбойка» | 20 | 00001
Рубашка «Ковбойка» | 5 | 00002
Рубашка «Ковбойка» | 5 | 00006
Свитер детский | 1
Свитер детский | 1 | 00015
Смеситель «Ультра» | 10
Смеситель «Ультра» | 10 | 0003

Упорядочивание во вложенных таблицах

В предложении УПОРЯДОЧИТЬ ПО можно определять также и условия упорядочивания записей из вложенных таблиц; причем их можно комбинировать с условиями упорядочивания по таблице верхнего уровня.

При этом важен порядок указания полей таблицы одного уровня (вложенной, или верхнего уровня) относительно друг друга, но не важно, в каком порядке указаны поля таблицы одного уровня относительно полей таблицы другого уровня: упорядочивание выполняется всегда сначала по таблице верхнего уровня, а потом по вложенной таблице.

Пример:

// В отчет необходимо вывести спецификацию товарных накладных -
// показать сам документ, номенклатуру и количество.
// Документы требуется упорядочить по номеру,
//а состав - по наименованию товара.
Выбрать
Документ.РасходнаяНакладная.Ссылка,
Документ.РасходнаяНакладная.Состав(Номенклатура Как Товар, Количество)
Упорядочить По
Документ.РасходнаяНакладная.Номер,
Документ.РасходнаяНакладная.Состав.Номенклатура.Наименование

Автоупорядочивание результатов

Предложение АВТОУПОРЯДОЧИВАНИЕ позволяет включить режим автоматического формирования полей для упорядочивания результата запроса.

Автоупорядочивание работает по следующим принципам:

• Если в запросе было указано предложение УПОРЯДОЧИТЬ ПО, то каждая ссылка на таблицу, находящаяся в этом предложении, будет заменена полями, по которым по умолчанию сортируется таблица (для справочников это код или наименование, для документов - дата документа). Если поле для упорядочивания ссылается на иерархический справочник, то будет применена иерархическая сортировка по этому справочнику.

• Если в запросе отсутствует предложение УПОРЯДОЧИТЬ ПО, но есть предложение СГРУППИРОВАТЬ ПО, тогда результат запроса будет упорядочен по полям, присутствующим в ПО, в той же последовательности и, в случае если группировка велась по полям - ссылкам, то по полям сортировки по умолчанию таблиц, на которые были ссылки.

• В случае же, если в запросе отсутствуют предложения и УПОРЯДОЧИТЬ ПО и СГРУППИРОВАТЬ ПО, результат будет упорядочен по полям сортировки по умолчанию для таблиц, из которых выбираются данные, в порядке их появления в запросе.


2-332 Расчет итогов запроса

Расчет итогов запроса

Предложение ИТОГИ позволяет определить, расчет каких итогов необходим в запросе. При расчете итогов вычисляются значения агрегатных функций по выборкам с одинаковыми значениями полей - контрольных точек. Итоги добавляются в результат запроса как итоговые строки.

Порядок расчета итогов запроса описывается в соответствии со следующими правилами:

<Описание итогов>

<Итоги> [<Описание итогов>]

<Итоги>

ИТОГИ [<Список агрегатных функций>]

<Общие итоги> | <Контрольные точки>

<Список агрегатных функций>

<Агрегатная функция> [, <Агрегатная функция> [, ...] ]

<Общие итоги>

ОБЩИЕ

<Контрольные точки>

ПО <Список контрольных точек>

<Список контрольных точек>

<Контрольная точка> [, <Контрольная точка> [, ...] ]

<Контрольная точка>

<Выражение> [ИЕРАРХИЯ]

<Выражение> [[ТОЛЬКО] ИЕРАРХИЯ] |
[ПЕРИОДАМИ](Секунда|Минута|Час|День|Неделя|Месяц|Квартал|Год|Декада|Полугодие
[,<Литерал DATE>|<Идентификатор параметра>]
[,<Литерал DATE>|<Идентификатор параметра>])]
[[КАК] Псевдоним поля]

Описание итогов начинается с обязательного ключевого слова ИТОГИ. В тексте запроса допускается использовать это слово несколько раз, задавая расчет различных итогов, как описано на стр. 342.

<Список агрегатных функций> содержит перечень агрегатных функций, которые необходимо рассчитывать в итогах. Агрегатные функции рассматриваются на стр. 345.

Ключевое слово ОБЩИЕ означает, что необходимо сформировать итоговую строку по всему результату запроса. Подробнее расчет общих итогов описан на стр. 334.

Помимо общих итогов, можно задать расчет итогов по контрольным точкам. Для этого после обязательного ключевого слова ПО необходимо указать <Список контрольных точек>. Каждая <Контрольная точка > содержит <Выражение>, вычисляемое при выполнении запроса. По каждой комбинации значений этих выражений будут рассчитаны и добавлены в результат запроса итоговые строки.

Если контрольная точка является ссылкой на справочник, возможен расчет итогов по иерархии справочника. Для этого после такой ссылки надо указать обязательное ключевое слово ИЕРАРХИЯ. Иерархические итоги описаны на стр. 335.

Общие итоги

Для расчета итогов по всей таблице в предложении ИТОГИ следует указать слово ОБЩИЕ. В этом случае будут вычислены значения агрегатных функций для всех записей таблицы.

Пример:

Выбрать
Накладная.Контрагент.Наименование,
Накладная.Номер,
Накладная.Сумма
Из
Документ.РасходнаяНакладная Как Накладная
Итоги
Сумма (Накладная.Сумма) Общие

Результат запроса:

Наименование | Номер | Сумма
256 555,45
Павильон 45 на оптовом рынке | 00007 | 6000
Павильон 45 на оптовом рынке | 00006 | 11 500
Торговый дом «Буденовский» | 00005 | 1 500
Торговый дом «Буденовский» | 00004 | 1 500
Торговый дом «Буденовский» | 00003 | 52500
Торговый дом «Буденовский» | 00002 | 16000
Ярмарка одежды | 00001 | 54000
Торговый дом «Буденовский» | 00009 | 555
Павильон 45 на оптовом рынке | 00016 | 80 000,23
Трикотажная фабрика «Заря» | 00012 | 4500
Торговый дом «Буденовский» | 00015
Торговый дом «Буденовский» | 00014 | 16500
Бавария - фарфор | 00013 | 12 000,22

Расчет итогов во вложенных таблицах

В настоящей версии программы не поддерживается расчет итогов по вложенным таблицам.

Итоги по иерархии

Есть возможность рассчитать итоги по иерархии. Для этого после имени поля, для которого вычисляются итоги необходимо указать ключевое слово ИЕРАРХИЯ. В результате будут рассчитаны итоги по контрольным точкам и итоги по иерархии для контрольных точек.

Пример:

ВЫБРАТЬ
Док.Товар,
Док.Количество,
Док.Ссылка.Номер,
Док,Ссылка.Получатель
ИЗ
Документ.РасхНакл.Состав Док
УПОРЯДОЧИТЬ ПО
Док.Товар
ИТОГИ
СУММА(Количество)
ПО
Док.Товар ИЕРАРХИЯ

Результат запроса:

Товар | Количество | Номер | Получатель
Сантехника | 104
Кран | 84
Кран | 10 | РНк-1 | Урюпинскторг
Кран | 8 | РНк-3 | Маг. "Хозяин"
Кран | 44 | РНк-4 | Маг. "Гигант"
Кран | 22 | РНк-5 | Урюпинскторг
Вантус | 20
Вантус | 5 | РНк-1 | Урюпинскторг
Вантус | 1 | РНк-3 | Маг. "Хозяин"
Вантус | 14 | РНк-4 | Маг. "Гигант"
Мебель | 134
Стол | 26
Стол | 1 | РНк-1 | Урюнинскторг
Стол | 15 | РНк-2 | Маг. "Мебель"
Стол | 10 | РНк-4 | Маг. "Гигант"
Стул | 108
Стул | 55 | РНк-2 | Маг. "Мебель"
Стул | 5 | РНк-3 | Маг. "Хозяин"
Стул | 32 | РНк-4 | Маг. "Гигант"
Стул | 16 | РНк-5 | Урюпинскторг

При необходимости можно рассчитать итоги только значений по иерархии, без расчета итогов в контрольных точках. Для этого перед ключевым словом ИЕРАРХИЯ нужно указать ключевое слово ТОЛЬКО.

Пример:

ВЫБРАТЬ
Док.Товар, Док.Количество, Док.Ссылка.Номер, Док.Ссылка.Получатель
ИЗ
Документ.РасхНакл.Состав Док
УПОРЯДОЧИТЬ ПО
Док.Товар
ИТОГИ
СУММА(Количество)
ПО Док.Товар ТОЛЬКО ИЕРАРХИЯ

Результат запроса:

Товар | Количество | Номер | Получатель
Сантехника | 104
Кран | 10 | РНк-1 | Урюпинскторг
Кран | 8 | РНк-3 | Маг. "Хозяин"
Кран | 44 | РНк-4 | Маг. "Гигант"
Кран | 22 | РНк-5 | Урюпинскторг
Вантус | 5 | РНк-1 | Урюпинскторг
Вантус | 1 | РНк-3 | Маг. "Хозяин"
Вантус | 14 | РНк-4 | Маг. "Гигант"
Мебель | 134
Стол | 1 | РНк-1 | Урюнинскторг
Стол | 15 | РНк-2 | Маг. "Мебель"
Стол | 10 | РНк-4 | Маг. "Гигант"
Стул | 55 | РНк-2 | Маг. "Мебель"
Стул | 5 | РНк-3 | Маг. "Хозяин"
Стул | 32 | РНк-4 | Маг. "Гигант"
Стул | 16 | РНк-5 | Урюпинскторг

Расчет общих итогов

Для расчета итогов по всей таблице в предложении ИТОГИ следует указать слово ОБЩИЕ. В этом случае будут вычислены значения агрегатных функций для всех записей таблицы.

Пример:

ВЫБРАТЬ
Док.Товар, Док.Количество, Док.Ссылка.Номер, Док.Ссылка.Получатель
ИЗ
Документ.РасхНакл.Состав Док
ИТОГИ
СУММА(Количество)
ПО ОБЩИЕ

Результат запроса:

Товар | Количество | Номер | Получатель
238
Кран | 10 | РНк-1 | Урюпинскторг
Кран | 8 | РНк-3 | Маг. "Хозяин"
Кран | 44 | РНк-4 | Маг. "Гигант"
Кран | 22 | РНк-5 | Урюпинскторг
Вантус | 5 | РНк-1 | Урюпинскторг
Вантус | 1 | РНк-3 | Маг. "Хозяин"
Вантус | 14 | РНк-4 | Маг. "Гигант"
Стол | 1 | РНк-1 | Урюнинскторг
Стол | 15 | РНк-2 | Маг. "Мебель"
Стол | 10 | РНк-4 | Маг. "Гигант"
Стул | 55 | РНк-2 | Маг. "Мебель"
Стул | 5 | РНк-3 | Маг. "Хозяин"
Стул | 32 | РНк-4 | Маг. "Гигант"
Стул | 16 | РНк-5 | Урюпинскторг

Совместное использование итогов и группировки

В случае если итоги используются совместно с группировкой, и для итогов не указан список агрегатных функций, он будет автоматически формироваться из агрегатных полей списка выборки. В случае если запрос содержит объединение, агрегатные функции будут браться из первого запроса.

Пример:

ВЫБРАТЬ
Док.Товар, Док.Ссылка.Получатель, СУММА(Док.Количество)
ИЗ
Документ.РасхНакл.Состав Док
СГРУППИРОВАТЬ ПО
Док.Товар, Док.Ссылка.Получатель
ИТОГИ ПО
Док.Товар

Результат запроса:

Товар | Получатель | Количество
Кран | 84
Кран | Урюпинскторг | 32
Кран | Маг. "Хозяин" | 8
Кран | Маг. "Гигант" | 44
Вантус | 20
Вантус | Урюпинскторг | 5
Вантус | Маг. "Хозяин" | 1
Вантус | Маг. "Гигант" | 14
Стол | 26
Стол | Урюпинскторг | 1
Стол | Маг. "Мебель" | 15
Стол | Маг. "Гигант" | 10
Стул | 108
Стул | Урюпинскторг | 16
Стул | Маг. "Мебель" | 55
Стул | Маг. "Хозяин" | 5
Стул | Маг. "Гигант" | 32

Расчет нескольких итогов одновременно

Допускается совместное использование различных итогов, например, общих, иерархических и итогов по полю.

Пример:

Выбрать
Накладная.Контрагент.Наименование,
Накладная.Номер,
Накладная.Сумма
Из
Документ.РасходнаяНакладная Как Накладная
Упорядочить По
Накладная.Контрагент
Итоги
Сумма(Накладная.Сумма)
По
Накладная.Контрагент
Итоги
Сумма(Накладная.Сумма)
По
Накладная.Контрагент Иерархия
Итоги
Сумма(Накладная.Сумма)
Общие

Результат запроса:

Наименование | Номер | Сумма
256 555,45
Поставщики | 16 500,22
Трикотажная фабрика «Заря» | 4 500
Трикотажная фабрика «Заря» | 00012 | 4 500
Бавария - фарфор | 12 000,22
Бавария - фарфор | 00013 | 12 000,22
Покупатели | 240 055,23
Ярмарка одежды | 54 000
Ярмарка одежды | 00001 | 54 000
Торговый дом «Буденовский» | 88 555
Торговый дом «Буденовский» | 00005 | 1 500
Торговый дом «Буденовский» | 00004 | 1 500
Торговый дом «Буденовский» | 00003 | 52 500
Торговый дом «Буденовский» | 00002 | 16 000
Торговый дом «Буденовский» | 00009 | 555
Торговый дом «Буденовский» | 00015
Торговый дом «Буденовский» | 00014 | 16 500
Павильон 45 на оптовом рынке | 97 500,23
Павильон 45 на оптовом рынке | 00007 | 6 000
Павильон 45 на оптовом рынке | 00006 | 11 500
Павильон 45 на оптовом рынке | 00016 | 80 000,23

Дополнение дат

В случае, если поле, по которому рассчитываем итоги, является полем типа "Дата" то возможно дополнение результатов датами в заданном периоде. Делается это при помощи ключевого слова ПЕРИОДАМИ, после которого в скобках указывается вид периода (Секунда, Минута, Час, День, Неделя, Декада, Месяц, Квартал, Полугодие, Год), начальная и конечная даты интересуемого периода. В случае, если даты не указаны, будут использованы первая и последняя даты, участвующие в результате.

Пример:

ВЫБРАТЬ
Получатель,
НачалоПериода(Дата, Месяц) Период,
Количество(Ссылка) КоличествоПокупок
ИЗ
Документ.РасхНакл
СГРУППИРОВАТЬ ПО
Получатель,
НачалоПериода(Дата, Месяц)
ИТОГИ
Сумма(КоличествоПокупок)
ПО
Период Периодами(Месяц, ДатаВремя(2000,07,01), ДатаВремя(2000,12,01))

Результат запроса:

Получатель | Период | КоличествоПокупок
01.07.2000 0:00:00 | 3
Маг. "Мебель" | 01.07.2000 0:00:00 | 1
Урюпинскторг | 01.07.2000 0:00:00 | 1
Маг. "Хозяин" | 01.07.2000 0:00:00 | 1
01.08.2000 0:00:00 | 1
Маг. "Гигант" | 01.08.2000 0:00:00 | 1
01.09.2000 0:00:00 | 1
Урюпинскторг | 01.09.2000 0:00:00 | 1
01.10.2000 0:00:00 | 0
01.11.2000 0:00:00 | 0
01.12.2000 0:00:00 | 0

Следует иметь ввиду , что такое представление результата получится, только, если при обходе результата по группировке "Период" использовать в качестве источника измерения все записи "Период".

Псевдонимы итогов

Полям итогов - контрольным точкам, для которых считаются итоги, можно назначить псевдоним, для последующего обращения к ним из встроенного языка. Для этого после выражения - контрольной точки необходимо указать имя псевдонима аналогично тому, как это делается в списке полей выборки.

Пример:

ВЫБРАТЬ
Док.Товар, Док.Количество, Док.Ссылка.Номер, Док.Ссылка.Получатель
ИЗ
Документ.РасхНакл.Состав Док
УПОРЯДОЧИТЬ ПО
Док.Товар
ИТОГИ
СУММА(Количество)
ПО Док.Товар
ТОЛЬКО ИЕРАРХИЯ
КАК Товары

В случае если псевдоним не указан система сама даст имя итогу, так, чтобы оно было уникально. В выше приведенном примере итог будет иметь имя "Товары".


2-344 Выражения в языке запросов

Выражения в языке запросов

Во многих конструкциях языка запросов могут использоваться выражения. Выражения языка запросов описываются следующим набором правил:

<Выражение>

<Разыменование поля> |

<Агрегатная функция> |

<Встроенная функция> |

<Операция выбора> |

<Приведение типа>[.<Разыменование поля>] |

<3начение> |

<Выражение> <Бинарная операция> <Выражение> |

<Унарная операция> <Выражение> |

( <Выражение> )

<Бинарная операция>

+ | - | * | /

<Унарная операция >

- | +

В простейшем случае выражение является ссылкой на поле исходной таблицы - источника данных запроса. Ссылка может задаваться с указанием таблицы, содержащей это поле, или без указания самой таблицы. Разыменование полей рассматривается на стр.345.

Выражения в списке полей выборки, в предложениях ИМЕЮЩИЕ, ИТОГИ, УПОРЯДОЧИТЬ ПО могут быть агрегатными функциями. Агрегатные функции описаны на стр. 345.

Выражение может быть встроенной функцией языка запросов. Встроенные функции описаны на стр. 349. Могут использоваться операции выбора, описанные на стр. 354, и операции приведения типа значения, описанные на стр. 356.

В выражениях могут непосредственно указываться значения логических, числовых, строковых и др. констант; также могут использоваться значения параметров запроса, как описано на стр. 356. В выражениях к значениям соответствующих типов могут применяться бинарные и унарные операции.

Разыменование полей

Выражения языка запросов в простейшем случае представляют собой ссылки на поля таблиц информационной базы. В общем виде ссылки описываются следующими правилами:

<Разыменование поля>

[<Таблица>.]<Имя поля>[.<Имя поля>[...]]

<Таблица>

<Имя таблицы> | <Псевдоним источника>

Разыменование поля начинается с имени таблицы, содержащей это поле. Если <Имя поля> уникально - существует только у одной из таблиц среди указанных в списке источников, <Таблица> может быть опущена.

Если поле имеет ссылочный тип, язык запросов позволяет обращаться к полям таблицы, на которую ссылается поле, и так далее. Имена полей указываются через точку.

Если исходной таблице в списке источников присвоен <Псевдоним источника>, он может использоваться вместо имени таблицы в разыменовании полей этой таблицы. В противном случае указывается <Имя таблицы> (см. описание источников данных запроса).

Агрегатные функции языка запросов

В языке запросов предусмотрены агрегатные функции, которые используются при группировке результатов запроса и при подсчете итогов. Агрегатные функции предназначены для обобщения значений указанного параметра. Определены следующие агрегатные функции:

<Агрегатная функция >

СУММА ( <Выражение > ) |

СРЕДНЕЕ ( <Выражение> ) |

МИНИМУМ ( <Выражение> ) |

МАКСИМУМ ( <Выражение> ) |

КОЛИЧЕСТВО ( [РАЗЛИЧНЫЕ] <Выражение> | * )

Пример:

Выбрать
Накладная.Номенклатура.Наименование,
Сумма(Накладная.Сумма) Как Сумма,
Среднее(Накладная.Сумма) Как Среднее,
Максимум(Накладная.Сумма) Как Максимум,
Минимум(Накладная.Сумма) Как Минимум,
Количество(Накладная.Сумма) Как Колич
Из
Документ.РасходнаяНакладная.Состав Как Накладная
Сгруппировать По
Накладная.Номенклатура
Итоги Общие

Результат запроса:

Наименование | Сумма | Среднее | Максимум | Минимум | Колич
265 955,45 | 12 511,12 | 40 000,23 | 555 | 8
Брюки детские | 28 500,22 | 9 500,07 | 15000 | 3000 | 3
Рубашка «Ковбойка» | 24000 | 8000 | 16000 | 4000 | 3
Джинсы женские | 63555 | 6 355,5 | 30000 | 555 | 10
Свитер детский | 6400 | 6400 | 6400 | 6400 | 1
Раковина «Лилия» | 60 000,23 | 30000,115 | 40 000,23 | 20000 | 2
Мойдодыр «Аквариум» | 65500 | 21 833,33 | 40000 | 8000 | 3
Смеситель «Ультра» | 15000 | 15000 | 15000 | 15000 | 1
Кухонный комбайн Крупс | 3000 | 3000 | 3000 | 3000 | 1

Агрегатные функции могут использоваться в списке полей выборки, предложениях ИМЕЮЩИЕ, ИТОГИ, УПОРЯДОЧИТЬ ПО.

Агрегатная функция СУММА

Функция вычисляет арифметическую сумму всех попавших в выборку значений поля.

В качестве параметра функции можно указывать только поля, содержащие числовое значение.

Если поле не может содержать числовых значений, то применение функции СУММА к такому полю вызовет ошибку. Если поле может содержать числовые значения (имеет составной тип данных), то данная функция может быть применена к такому полю. Но если среди значений поля в выборке встретится нечисловое значение (помимо значений NULL), это вызовет ошибку.

Агрегатная функция СРЕДНЕЕ

Функция вычисляет среднее значение всех попавших в выборку значений поля.

В качестве параметра функции можно указывать только ссылки на поля, содержащие числовое значение.

Если поле не может содержать числовых значений, то применение функции СРЕДНЕЕ к такому полю вызовет ошибку. Если поле может содержать числовые значения (имеет составной тип данных), то данная функция может быть применена к такому полю. Но если среди значений поля в выборке встретится нечисловое значение (помимо значений NULL), это вызовет ошибку.

Агрегатная функция МИНИМУМ

Функция вычисляет минимальное значение из всех попавших в выборку значений поля.

В качестве параметра функции можно указывать ссылки на поля, содержащие значения любого типа.

При определении минимального значения применяются правила сравнения значений, описанные на стр. 360.

Агрегатная функция МАКСИМУМ

Функция вычисляет максимальное значение из всех попавших в выборку значений поля.

В качестве параметра функции можно указывать ссылки на поля, содержащие значения любого типа.

При определении максимального значения применяются правила сравнения значений, описанные на стр. 360.

Агрегатная функция КОЛИЧЕСТВО

Функция подсчитывает количество значений параметра, попавших в выборку. В отличие от других агрегатных функций функция КОЛИЧЕСТВО допускает три способа использования.

• Во-первых, функция позволяет подсчитать количество значений указанного поля, не равных NULL.

• Во-вторых, функция позволяет подсчитать количество различных значений указанного поля, не равных NULL. Для этого перед спецификацией поля надо указать ключевое слово РАЗЛИЧНЫЕ.

• В-третьих, функция позволяет подсчитать количество строк в результате запроса. Для этого в качестве параметра функции надо указать звездочку «*».

В качестве параметра функции можно указывать ссылки на поля, содержащие значения любого типа.

Пример:

ВЫБРАТЬ
Количество(*) Как Всего,
Количество(Различные Накладная.Номенклатура) Как Разные
Из
Документ.РасходнаяНакладная.Состав Как Накладная

Результат запроса:

Всего | Разные
24 | 8

Встроенные функции языка запросов

В языке запросов определены встроенные функции, которые могут использоваться в выражениях в списке полей выборки (см. стр. 300) и в условии отбора в предложении ГДЕ (см. стр. 315). Определены следующие встроенные функции:

<Встроенная функция>

ПОДСТРОКА( <Выражение>, <3начение>, <3начение> ) |
ГОД( <Выражение> ) |
КВАРТАЛ( <Выражение> ) |
МЕСЯЦ( <Выражение> ) |
ДЕНЬГОДА( <Выражение> ) |
ДЕНЬ( <Выражение> ) |
НЕДЕЛЯ( <Выражение> ) |
ДЕНЬНЕДЕЛИ( <Выражение> ) |
ЧАС( <Выражение> ) |
МИНУТА( <Выражение> ) |
СЕКУНДА( <Выражение> )

Функция ПОДСТРОКА

Данная функция предназначена для выделения подстроки из строки.

<Выражение>

- строка, из которой необходимо выделить подстроку. Выражение, имеющее тип Строка.

<3начение>

- позиция символа, с которого начинается выделяемая из строки подстрока. Значение типа Число.

<3начение>

- длина выделяемой подстроки. Значение типа Число.

Если в качестве первого параметра фигурирует строка, то результатом функции будет строка (возможно нулевой длины). Если в качестве первого параметра будет использовано значение NULL, то результатом функции также будет значение NULL. Другие значения считаются недопустимыми и вызывают состояние ошибки.

Пример:

Выбрать
Справочних.Контрагенты.Наименование,
Подстрока(Справочник.Контрагенты.Наименование, 3, 5) Как Подстрока

Результат запроса:

Наименование | Подстрока
Поставщики | ставщ
Трикотажная фабрика «Заря» | икота
Фабрика джинсовой одежды | брика
Покупатели | купат
Ярмарка одежды | марка
Торговый дом «Буденовский» | рговы
Павильон 45 на оптовом рынке | вильо
Бавария - фарфор | вария
Фабрика джинсовой одежды | брика
АКБ ПромСтройБанк | Б Про

Функция ГОД

Данная функция предназначена для вычисления номера года из значения типа Дата.

Параметр функции - это выражение, имеющее тип Дата.

Если в качестве параметра фигурирует значение типа Дата, то результатом функции будет значение типа Число. Если в качестве параметра будет использовано значение NULL, то результатом функции также будет значение NULL. Другие значения считаются недопустимыми и вызывают состояние ошибки.

Функция КВАРТАЛ

Данная функция предназначена для вычисления номера квартала из з гачения типа Дата. Номер квартала находится в диапазоне 1-4.

Параметр функции - это выражение, имеющее тип Дата.

Если в качестве параметра фигурирует значение типа Дата, то результатом функции будет значение типа Число. Если в качестве параметра будет использовано значение NULL, то результатом функции также будет значение NULL. Другие значения считаются недопустимыми и вызывают состояние ошибки.

Функция МЕСЯЦ

Данная функция предназначена для вычисления номера месяца из значения типа Дата. Номер месяца находится в диапазоне 1 -12.

Параметр функции - это выражение, имеющее тип Дата-

Если в качестве параметра фигурирует значение типа Дата, то результатом функции будет значение типа Число. Если в качестве параметра будет использовано значение NULL, то результатом функции также будет значение NULL. Другие значения считаются недопустимыми и вызывают состояние ошибки.

Функция ДЕНЬГОДА

Данная функция предназначена для вычисления дня года из значения типа Дата. День года находится в диапазоне 1 - 366.

Параметр функции - это выражение, имеющее тип Дата.

Если в качестве параметра фигурирует значение типа Дата, то результатом функции будет значение типа Число. Если в качестве параметра будет использовано значение NULL, то результатом функции также будет значение NULL. Другие значения считаются недопустимыми и вызывают состояние ошибки.

Функция ДЕНЬ

Данная функция предназначена для вычисления дня месяца из значения типа Дата. День месяца находится в диапазоне 1 - 31.

Параметр функции - это выражение, имеющее тип Дата.

Если в качестве параметра фигурирует значение типа Дата, то результатом функции будет значение типа Число. Если в качестве параметра будет использовано значение NULL, то результатом функции также будет значение NULL. Другие значения считаются недопустимыми и вызывают состояние ошибки.

Функция НЕДЕЛЯ

Данная функция предназначена для вычисления номера недели года из значения типа Дата.

Параметр функции - это выражение, имеющее тип Дата.

Если в качестве параметра фигурирует значение типа Дата, то результатом функции будет значение типа Число. Если в качестве параметра будет использовано значение NULL, то результатом функции также будет значение NULL. Другие значения считаются недопустимыми и вызывают состояние ошибки.

Функция ДЕНЬНЕДЕЛИ

Данная функция предназначена для вычисления дня недели из значения типа Дата. День недели находится в диапазоне 1 (понедельник) - 7 (воскресенье).

Параметр функции - это выражение, имеющее тип Дата.

Если в качестве параметра фигурирует значение типа Дата, то результатом функции будет значение типа Число. Если в качестве параметра будет использовано значение NULL, то результатом функции также будет значение NULL. Другие значения считаются недопустимыми и вызывают состояние ошибки.

Функция ЧАС

Данная функция предназначена для вычисления часа суток из значения типа Дата. Час суток находится в диапазоне 0 - 23.

Параметр функции - это выражение, имеющее тип Дата.

Если в качестве параметра фигурирует значение типа Дата, то результатом функции будет значение типа Число. Если в качестве параметра будет использовано значение NULL, то результатом функции также будет значение NULL. Другие значения считаются недопустимыми и вызывают состояние ошибки.

Функция МИНУТА

Данная функция предназначена для вычисления минуты часа из значения типа Дата. Минута часа находится в диапазоне 0 - 59.

Параметр функции - это выражение, имеющее тип Дата.

Если в качестве параметра фигурирует значение типа Дата, то результатом функции будет значение типа Число. Если в качестве параметра будет использовано значение NULL, то результатом функции также будет значение NULL. Другие значения считаются недопустимыми и вызывают состояние ошибки.

Функция СЕКУНДА

Данная функция предназначена для вычисления секунды минуты из значения типа Дата. Секунда минуты находится в диапазоне 0 - 59.

Параметр функции - это выражение, имеющее тип Дата.

Если в качестве параметра фигурирует значение типа Дата, то результатом функции будет значение типа Число. Если в качестве параметра будет использовано значение NULL, то результатом функции также будет значение NULL. Другие значения считаются недопустимыми и вызывают состояние ошибки.

Операции выбора в языке запросов

В выражениях языка запросов могут применяться операции выбора, которые позволяют получить одно из возможных значений в соответствии с указанными условиями.

Операция выбора описывается следующим набором правил:

<Операция выбора>

ВЫБОР
<Альтернативы выбора>
[ИНАЧЕ
<Выражение>]
КОНЕЦ

<Альтернативы выбора>

<Одиночный выбор> [<Альтернативы выбора>]

<Одиночный выбор>

КОГДА
<Логическое выражение>
ТОГДА
<Выражение>

В операции выбора может указываться неограниченное количество альтернативных одиночных выборов КОГДА... ТОГДА. Они обрабатываются в запросе последовательно; если <Логическое выражение> имеет значение ИСТИНА, обработка операции выбора завершается; результатом операции является значение выражения, указанного после слова ТОГДА. Логические выражения описаны на стр. 358.

Значение выражения, указанного после слова ИНАЧЕ используется в качестве результата операции выбора в том случае, если во всех ранее указанных альтернативных одиночных выборах предикат имел значение ЛОЖЬ.

Пример:

Выбрать
Справочник.Номенклатура.Наименование,
Выбор
Когда Справочник.Номенклатура.ЭтоГруппа = Истина Тогда "Это Группа"
Когда Справочник.Номенклатура.ЗакупочнаяЦена > 1000 Тогда "1000 -"
Когда Справочник.Номенклатура.ЗакупочнаяЦена > 100 Тогда "100 - 1000"
Когда Справочник.Номенклатура.ЗакупочнаяЦена > 10 Тогда "10 - 100"
Когда Справочник.Номенклатура.ЗакупочнаяЦена > 0 Тогда «0 - 10»
Иначе "Не Задана"
Конец Цена

Результат запроса:

Наименование | Цена
Брюки детские | 100 - 1000
Рубашка «Ковбойка» | 1000-
Одежда | Это группа
Джинсы женские | 1000-
Свитер детский | Не задана
Сантехника | Это группа
Бытовая техника | Это группа
Раковина «Лилия» | Не задана
Мойдодыр «Аквариум» | Не задана
Смеситель «Ультра» | 100 - 1000
Кухонный комбайн Крупе | 1000-
Мясорубка Браун | Не задана
Электронож Крупе | Не задана
Зажигалка для газовой плиты «Огонек» | Не задана
Калькулятор бухгалтерский | Не задана
Кухонная техника | Это группа
Оргтехника | Это группа

Приведение типа в языке запросов

Поля исходных таблиц могут иметь составной тип. Для таких полей возникает необходимость привести значения поля к какому-либо определенному типу. В языке запросов предусмотрена возможность приведения типа, ею можно пользоваться в списке полей выборки и в условии отбора в предложении ГДЕ.

<Приведение типа>

ВЫРАЗИТЬ ( <Выражение> КАК <Тип значения> )

<Тип значения>

БУЛЕВО | ЧИСЛО | СТРОКА | ДАТА | <Имя таблицы>

<Выражение> приводится к одному из базовых типов, или к ссылочному типу данных; в последнем случае <Имя таблицы> указывает на соответствующую таблицу информационной базы.

Если <Выражение> содержит в составном типе требуемый <Тип значения>, то приведение типа считается осуществимым, и для каждого значения указанного типа результатом будет это самое значение. Для значений других типов результатом приведения типа будет значение NULL.

Если <Выражение> не содержит в составном типе требуемый <Тип значения>, то выполнение данного запроса завершится ошибкой из-за принципиальной невозможности совершить приведение типов.

Константы и параметры в языке запросов

В выражениях языка запросов могут напрямую указываться значения типа булево, число, строка или дата. Также могут использоваться значения параметров запроса:

ИСТИНА |
ЛОЖЬ |
<Литерал типа ЧИСЛО> |
<Литерал типа СТРОКА> |
<Литерал типа ДАТА> |
<Имя параметра>

<Литерал типа ЧИСЛО>

<Целое число> [.<Целое число>]

<Литерал типа СТРОКА>

<Последовательность символов>

<Литерал типа ДАТА>

ДАТАВРЕМЯ ( <Целое число>, <Целое число>, <Целое число>[, <Целое число>, <Целое число>, <Целое число>] )

Значения типа булево, число, строка в языке запросов задаются так же, как и во встроенном языке.

Значения типа дата задаются с помощью ключевого слова ДАТАВРЕМЯ, после которого в скобках последовательно указываются год, месяц, день, час, минута, секунда. Последние три указывать необязательно.

В запрос могут передаваться параметры (см. описание объекта Запрос). Значения параметров могут использоваться в выражениях языка запросов, для этого необходимо указать символ & и после него <Имя параметра>.

Условия в языке запросов

В языке запросов используются условия отбора, в соответствии с которыми осуществляется отбор данных в предложениях ГДЕ, ИМЕЮЩИЕ и СОЕДИНЕНИЕ. Условия описываются по следующим правилам:

<Условие отбора>

<Логическое слагаемое> [ИЛИ <Логическое слагаемое>]

<Логическое слагаемое>

<Логический сомножитель> [И <Логический сомножитель>]

<Логический сомножитель>

НЕ <Логический сомножитель> | ( <Условие отбора> ) | <Логическое выражение>

В простейшем случае условие является выражением, результат которого имеет значение логического типа. Логические выражения описаны ниже.

Условия могут определяться и как более сложные логические выражения, где фигурируют простые логические выражения, соединенные между собой с помощью логических операторов И, ИЛИ, НЕ.

Логические операторы имеют приоритет:

• Самый высокий приоритет имеет логический оператор НЕ.

• Следующим по приоритету является оператор И.

• Самый низкий приоритет у оператора ИЛИ.

В условиях сначала вычисляются простые логические выражения, затем операции НЕ, затем операции И, в последнюю очередь -операции ИЛИ. Для того, чтобы обеспечить другой порядок вычислений, можно использовать круглые скобки ().

Логические выражения в языке запросов

В языке запросов в операциях выбора и в условиях отборов используются логические выражения:

<Логическое выражение>

<Выражение> |
<Выражение> <Операция сравнения> <Выражение> |
<Выражение> [НЕ] В [ИЕРАРХИИ] (<Список значений>)

<Выражение> [НЕ] В [ИЕРАРХИИ] <Описание запроса> |
<Выражение> [НЕ] МЕЖДУ <Выражение> И <Выражение> |
<Выражение> ЕСТЬ [НЕ] NULL |
<Выражение> ССЫЛКА <Имя таблицы> |
<Выражение> [НЕ] ПОДОБНО <Литерал типа СТРОКА> [СПЕЦСИМВОЛ <Литерал типа СТРОКА>]

<Операция сравнения>

> | < | = | >= | <= | <>

<Список значений>

<Выражение> [, <Выражение> [, ...] ]

Логическим выражением может быть:

• обычное <Выражение> языка запросов, если его результат имеет логический тип;

• <Операция сравнения> двух выражений языка запросов; выполняются в соответствии с правилами сравнения значений описанными на стр. 360;

• оператор проверки совпадения / не совпадения значения выражения с одним из перечисленных или со значениями, содержащимися в результате другого запроса;

• оператор проверки вхождения значения выражения в диапазон;

• оператор проверки значения выражения на NULL;

• оператор проверки ссылочного значения выражения на ссылку на определенную таблицу;

• оператор проверки строкового значения на подобие шаблону.

При сравнении значений используются правила сравнения значений, описанные на стр. 360.

Правила сравнения значений

Поскольку в языке запросов могут сравниваться значения разных типов, определены правила, по которым выполняется сравнение двух значений. Данные правила используются для:

• сравнения значений в операторах сравнения;

• определения максимального и минимального значений в агрегатных функциях МИНИМУМ и МАКСИМУМ;

• упорядочивания записей результата запроса в соответствии с порядком, заданным в предложении УПОРЯДОЧИТЬ ПО.

Если типы значений отличаются друг от друга, то отношения между значениями определяются на основании приоритета типов:

• тип NULL (самый низший);

• тип булево;

• тип число;

• тип дата;

• тип строка;

• ссылочные типы.

Отношения между различными ссылочными типами определяются на основе ссылочных номеров таблиц, соответствующих тому или иному типу.

Если типы данных совпадают, то производится сравнение значений по следующим правилам:

• у типа булево значение ИСТИНА больше значения ЛОЖЬ;

• у типа число обычные правила сравнения для чисел;

• у типа дата более ранние даты меньше более поздних;

• у типа строка сравнения производится в соответствии с установленными национальными особенностями базы данных;

• ссылочные типы сравниваются на основе своих значений (номера записи и т. п.).

Важно! Любая операция сравнения двух значений, в которой участвует хотя бы одно значение NULL, дает результат, аналогичный значению ЛОЖЬ.

Оператор проверки совпадения значения с одним из перечисленных

Оператор В позволяет проверить, совпадает ли значение выражения, указанного справа от него, с одним из значений, описанных слева. Если совпадает хотя бы с одним - результатом оператора будет ИСТИНА, иначе - ЛОЖЬ. Применение НЕ изменяет действие оператора на обратное. Сравнение значений производится по правилам, описанным на стр. 360.

Пример:

Выбрать
Справочник.Номенклатура.Наименование
Где
Справочник.Номенклатура.Родитель.Наименование В ("Бытовая техника", "Оргтехника")

Для справочников проверка может осуществляться и на принадлежность по иерархии. Результатом оператора В ИЕРАРХИИ будет ИСТИНА, если значение выражения слева является ссылкой на элемент справочника и входит во множество значений справа или иерархически принадлежит какой-нибудь группе, содержащейся в этом множестве.

Пример:

//В качестве параметра Группа в запрос передается ссылка
//на какую-либо группу справочника Номенклатура.
Выбрать
Справочник.Номенклатура.Наименование
Где
Справочник.Номенклатура.Ссылка В ИЕРАРХИИ (&Группа)

В качестве множества значений, на совпадение с которыми выполняется проверка, может фигурировать и результат запроса. В этом случае справа от оператора В необходимо указать описание запроса.

Пример:

Выбрать
Справочник.Номенклатура.Наименование
Где
Справочник.Номенклатура.Ссылка В ИЕРАРХИИ
(ВЫБРАТЬ
Справочник.Номенклатура.Ссылка
ГДЕ
Справочник.Номенклатура.Наименование = "Одежда" )

Оператор проверки вхождения значения в диапазон

Оператор МЕЖДУ позволяет проверить, входит ли значение выражения, указанного справа от него, в диапазон, указанный слева. Если входит - результатом оператора будет ИСТИНА, иначе -ЛОЖЬ Применение НЕ изменяет действие оператора на обратное. Сравнение значений производится по правилам, описанным на стр. 360.

Пример:

Выбрать
Справочник.Номенклатура.Наименование,
Справочник.Номенклатура.ЗакупочнаяЦена
Где
Справочник.Номенклатура.ЗакупочнаяЦена МЕЖДУ 100 И 1000

Оператор проверки значения на NULL

Оператор ЕСТЬ NULL позволяет проверить значение выражения слева от него на NULL. Если значение равно NULL результатом оператора будет ИСТИНА, иначе - ЛОЖЬ. Применение НЕ изменяет действие оператора на обратное.

Пример:

Выбрать

Справочник.Номенклатура.Наименование,

Справочник.Номенклатура.ЗакупочнаяЦена

Где

Справочник.Номенклатура.ЗакупочнаяЦена Есть NULL

Оператор проверки ссылочного значения

Оператор ССЫЛКА позволяет проверить, является ли значение выражения, указанного справа от него, ссылкой на таблицу, указанную слева Если да - результатом оператора будет ИСТИНА, иначе - ЛОЖЬ. Разыменование таблиц описано на стр. 345.

Пример:

ВЫБРАТЬ
Справочник.Номенклатура.Наименование,
Справочник.Номенклатура.ЕдиницаИзмерения
ГДЕ
Справочник.Номенклатура.ЕдиницаИзмерения ССЫЛКА Справочник.ЕдиницыИзмерения

Оператор проверки строки на подобие шаблону

Оператор ПОДОБНО позволяет сравнить значение выражения, указанного слева от него, со строкой шаблона, указанной справа. Значение выражения должно иметь тип строка. Если значение выражения удовлетворяет шаблону - результатом оператора будет ИСТИНА, иначе - ЛОЖЬ.

Следующие символы в строке шаблона являются служебными и имеют смысл, отличный от символа строки:

• % (процент): последовательность, содержащая любое количество произвольных символов

• _ (подчеркивание): один произвольный символ.

• [...] (в квадратных скобках один или несколько символов): любой одиночный символ из перечисленных внутри квадратных скобок. В перечислении могут встречаться диапазоны, например a-z, означающие произвольный символ, входящий в диапазон, включая концы диапазона.

• [^...] (в квадратных скобках значок отрицания, за которым следует один или несколько символов): любой одиночный символ, кроме тех, которые перечислены следом за значком отрицания.

Любой другой символ означает сам себя и не несет никакой дополнительной нагрузки.

Если в качестве самого себя необходимо записать один из перечисленных символов, то ему должен предшествовать <Спецсимвол>. Сам <Спецсимвол> (любой подходящий символ) определяется в этом же операторе после ключевого слова СПЕЦСИМВОЛ.

Например, шаблон "%АБВ[0-9][абвг]\_абв%" СПЕЦСИМВОЛ "\" означает подстроку, состоящую из последовательности символов:

буквы А, буквы Б; буквы В; одной цифры, одной из букв а, 6, в или г; символа подчеркивания; буквы а; буквы б; буквы в. Причем перед этой последовательностью может располагаться произвольный набор символов.


2-364 Выполнение и работа с запросами во встроенном языке

Выполнение и работа с запросами во встроенном языке

Для формирования запросов, выборки и обработки результатов запросов в языке предусмотрен специальный набор объектов. С помощью этих объектов выполняется формирование запроса, обход записей запроса и т.д.

Основные приемы работы

Основные приемы работы с запросами во встроенном языке 1С:Предприятия удобнее всего рассматривать на примерах. Приведем типичный пример использования запроса:

// Создадим Запрос
Запрос = Новый Запрос("ВЫБРАТЬ Товар.Наименование Наименование,
| Товар.Родитель.Наименование НаименованиеРодителя
| ИЗ Справочник.Товары Товар");
// Выполним запрос и запишем результат в переменную РезультатЗапроса.
РезультатЗапроса = 3апрос.Выполнить();
// Получим выборку из результата запроса.
Выборка = РезультатЗапроса.Выбрать();
// Пока в выборке есть записи ...
Пока Выборка.Следующий() Цикл
// ... выведем в окно сообщений поля из результата.
Товар = Выборка.Наименование;
Родитель = Выборка.НаименованиеРодителя;
Сообщить("Товар: " + Товар + " Родитель: " + Родитель);
КонецЦикла ;

Как видно из этого примера, работа с запросом ведется при помощи трех основных объектов:

• Запрос - объект, выполняющий сам запрос. Представлен в примере переменной с именем Запрос.

• РезультатЗапроса - объект, содержащий полученные при выполнении запроса данные. Представлен в примере переменной с именем РезультатЗапроса.

• ВыборкаИзРезультатаЗапроса - объект, позволяющий обходить (т.е. перебрать) записи из результата. Представлен в примере переменной с именем Выборка.

Рассмотрим подробнее объект ВыборкаИзРезультатаЗапроса. Для этого нам понадобится следующий запрос:

Выбрать
Товар, Количество
Из
Документ.РасхНакл.Состав
Упорядочить по
Товар
Итоги
Сумма(Количество) По Товар,
Товар Иерархия

Его результат представлен в таблице:

№ Товар Количество
1 | Сантехника | 104
2 | Кран | 84
3 | Кран | 10
4 | Кран | 8
5 | Кран | 44
6 | Кран | 22
7 | Смеситель | 20
8 | Смеситель | 5
9 | Смеситель | 1
10 | Смеситель | 14
11 | Мебель | 134
12 | Стол | 26
13 | Стол | 1
14 | Стол | 15
15 | Стол | 10
16 | Стул | 108
17 | Стул | 55
18 | Стул | 5
19 | Стул | 32
20 | Стул | 16

В этой таблице мы добавили столбец №, которого нет в результате запроса, но который будет использоваться нами в дальнейшем для идентификации записи в результате. Итоговые записи в таблице выделены курсивом, итоговые записи для иерархических уровней справочника выделены жирным шрифтом.

Способы обхода результата запроса

Линейный обход результата

Первый, и самый простой способ обхода - линейный. При линейном обходе выборка будет выдавать записи в той последовательности, в которой они располагаются в результате запроса. В нашем примере это будут записи с номерами 1, 2, 3, 4, 5 и так далее до записи с номером 20.

Для получения линейной выборки из результата необходимо вызвать метод Выбрать объекта РезультатЗапроса без параметров, либо с параметром ОбходРезультатаЗапроса.Прямой.

Пример:

СпособВыборки
= ОбходРезультатаЗапроса.Прямой;
Выборка1 = РезультатЗапроса.Выбрать(СпособВыборки);
// что равнозначно записи
Выборка1 = РезультатЗапроса.Выбрать();

Иерархический обход результата

Следующий способ обхода результата - иерархический. При данном обходе обходятся только записи, находящиеся на одном уровне. Для получения иерархической выборки из результата необходимо вызвать метод Выбрать объекта РезультатЗапроса с параметром ОбходРезультатаЗапроса.ПоГруппировкамСИерархией.

СпособВьборки = ОбходРезультатаЗапроса.ПоГруппировкамСИерархией;
Выборка2 = РезультатЗапроса.Выбрать(СпособВыборки);

Выборка из результата с иерархическим обходом в нашем примере обойдет только записи с номерами 1 и 11, так как только эти две записи находятся на самом верхнем уровне. Проиллюстрируем это, представив наш результат в виде дерева, где узлами будут итоговые записи, а листьями дерева будут детальные записи. Вот что у нас получится:

1 | Сантехника | 104
2 | Кран | 84
3 | Кран | 10
4 | Кран | 8
5 | Кран | 44
6 | Кран | 22
7 | Смеситель | 20
8 | Смеситель | 5
9 | Смеситель | 1
10 | Смеситель | 14
11 | Мебель | 134
12 | Стол | 26
13 | Стол | 1
14 | Стол | 15
15 | Стол | 10
16 | Стул | 108
17 | Стул | 55
18 | Стул | 5
19 | Стул | 32
20 | Стул | 16

Из этого рисунка видно, что именно записи с номерами 1 и 11, и только они находятся на первом уровне дерева, в результате чего только они и попадают в первый проход иерархической выборки.

Возникает вопрос, как получать остальные записи результата запроса. Для этого у объекта ВыборкаИзРезультатаЗапроса можно получить еще одну выборку, которая будет обходить подчиненные записи текущей записи выборки. В нашем примере в момент, когда объект Выборка2 будет позиционирован на запись с номером 1, мы запросим у него иерархическую выборку. Таким образом, мы получим выборку, которая нам вернет записи с номерами 2, 7. А когда Выборка2 будет спозиционирована на записи с номером 11, то полученная у нее иерархическая выборка вернет записи с номерами 12, 16. Так реализуется иерархический обход результатов запроса Заметим, что у выборки можно получать вложенные выборки любого типа. Так, если бы мы запросили у Выборки2, спозиционированной на записи 1, линейную выборку, то с ее помощью мы бы получили записи с номерами записей со 2-го по 10-й. Проиллюстрируем описанную методику на примере.

Пример:

Процедура ВыдатьРекурсивно(Выборка) Далее;

Процедура ВыполнитьЗапрос()
Запрос = Новый Запрос;
Текст = "Выбрать Товар, Количество
| Из Документ.РасхНакя.Состав
| Упорядочить по Товар
| Итоги Сумма(Количество) По Товар, Товар Иерархия";
РезультатЗапроса = Запрос.Выполнить();
// Получим выборку из результата запроса.
СпособВыборки = ОбходРезультатаЗапроса.ПоГруппировкамСИерархией;
Выборка = РезультатЗапроса.Выбрать(СпособВыборки);
ВыдатьРекурсивно(Выборка);
КонецПроцедуры

Процедура ВыдатьРекурсивно(Выборка)
// Пока в выборке есть записи ...
Пока Выборка. Следующий () Цикл
// ... выведем в окно сообщений поля из результата
Товар = Выборка.Наименование;
Количество = Выборка.Количество;
Сообщить("Товар: " + Товар + " Количество: " + Количество);
// продолжим выборку подчиненных записей
СпособВыборки = ОбходРезультатаЗапроса.ПоГруппировкамСИерархией;
Выдать Рекурсивно(Выборка.Выбрать(СпособВыборки));
КонецЦикла;
КонецПроцедуры

Обход результата по группам

Третий, и последний способ обхода результата - по группам. Он сходен с иерархическим обходом, но с одним различием: записи с иерархическими итогами при обходе в нем рассматриваются как детальные записи, а не как узловые. Для получения выборки по группам из результата запроса необходимо вызвать метод Выбрать объекта РезультатЗапроса с параметром ОбходРезультатаЗапроса.ПоГруппировкам.

Пример:

СпособВыборки = ОбходРезультатаЗапроса.ПоГруппировкам;
Вы6орка2 = РезультатЗапроса.Выбрать(СпособВыборки);

Перебрав в ней всё, мы получим записи с номерами 1, 2, 7, 11, 12, 16.

Пример:

Процедура ВыдатьДочерниеЗаписи(Выборка) Далее;

Процедура ВыполнитьЗапрос()
Запрос = Новый Запрос;
Текст = "Выбрать Товар, Количество
| Из Документ.РасхНакя.Состав
| Упорядочить по Товар
| Итоги Сумма(Количество) По Товар, Товар Иерархия";
РезультатЗапроса = Запрос.Выполнить();
// Получим выборку из результата запроса.
СпособВыборки = ОбходРезультатаЗапроса.ПоГруппировкам;
Выборка = РезультатЗапроса.Выбрать(СпособВыборки);
// Пока в выборке есть записи ...
Пока Выборка.Следующий() Цикл
// ... выведем в окно сообщений доля из результата
Товар = Выборка.Наименование;
Количество = Выборка.Количество;
Сообщить("Товар: " + Товар + " Итого по товару: " + Количество) ;
ВыдатьДочерниеЗаписи(Выборка.Выбрать()) ;
КонецЦикла;
КонецПроцедуры

Процедура ВыдатьДочерниеЗапися (Выборка)
// Пока в выборке есть записи . . .
Пока Выборка.Следующий() Цикл
// ... выведем в окно сообщений поля из результата
Товар = Выборка.Наименование;
Количество = Выборка.Количество;
Сообщить("Товар: " + Товар + " Количество: " + Количество);
КонецЦикла;
КонецПроцедуры

Работа с выборкой

Объект ВыборкаИзРезультатаЗапроса предназначен для обхода записей результата запроса. Можно представить себе выборку как некоторый объект, который содержит указатель на текущую запись в результате и предоставляет программе доступ ко всем полям текущей записи. Для навигации по записям запроса используются три метода:

• Следующий - перейти к следующей записи результата в соответствии с порядком обхода выборки. При первом вызове позиционирует выборку на первую запись. Когда будут выбраны все записи, данный метод просигнализирует об этом, вернув значение «Ложь».

• СледующийПоЗначениюПоля - получить следующую запись со значением в заданном поле, отличающимся от значения в этом поле текущей записи.

• НайтиСледующий - найти запись, с заданными значениями некоторых полей.

Использование метода СледующийПоЗначениюПоля

Метод позволяет сгруппировать записи результата по значениям полей.

Пример:

Выбрать
Док.Товар,
Док.Получатель,
Док.Количество
ИЗ
Документ.РасхНакл.Состав Док
Упорядочить по
Док.Товар.Наименование,
Док.Получатель.Наименование.

Его результат представлен в таблице:

№ Товар Получатель Количество
1 | Смеситель | Маг. "Гигант" | 14
2 | Смеситель | Маг. "Хозяин" | 1
3 | Смеситель | Мосгорторг | 5
4 | Кран | Маг. "Гигант" | 44
5 | Кран | Маг. "Хозяин" | 8
6 | Кран | Мосгорторг | 10
7 | Кран | Мосгорторг | 22
8 | Стол | Маг. "Гигант" | 10
9 | Стол | Маг. "Мебель" | 15
10 | Стол | Мосгорторг | 1
11 | Стул | Маг. "Гигант" | 32
12 | Стул | Маг. "Мебель" | 55
13 | Стул | Маг. "Хозяин" | 5
14 | Стул | Мосгорторг | 16

Получим линейную выборку из результата запроса и обойдем выборку при помощи метода СледующийПоЗначениюПоля.

Пример:

Выборка = РезультатЗапроса.Выбрать();
Пока
Выборка.СледующийПоЗначениоПоля("Товар") Цикл
// здесь мы получим записи с номерами 1, 4, 8, 11
Пока Выборка.СледующийПоЗначениюПоля('Получатель")
Цикл
// здесь мы сначала получим записи с номерами 1, 2, 3
// затем 4, 5, 6
// затем 8, 9, 10
// затем 11, 12, 13, 14
КонецЦикла;
КоиецЦикла ;

Следует обратить внимание на то, что во внутреннем цикле не была выбрана запись с номером 7, т.к. в ней такое же значение поля «Получатель» как и в предыдущей записи.

Заметим, что если в цикле получения по значению поля получать записи при помощи метода Следующий, то будут выбраны все записи с равным значением поля, заданного в предыдущем вызове метода СледующийПоЗначениюПоля.

Пример:

Выборка =
РезультатЗапроса.Выбрать();
Пока
Выборка.СледующийПоЗначениюПоля("Товар") Цикл
// здесь мы получим записи с номерами 1, 4, 8, 11
Пола Выборка.Следующий() Цикл
// здесь мы сначала получим записи с номерами 1, 2, 3
// затем 4, 5, 6, 7
// затем 8, 9, 10
// затем 11, 12, 13, 14
КонецЦикла;
КонецЦикла;

Методы определения типа текущей записи

В тот момент, когда выборка позиционирована на записи, мы можем у выборки узнать характеристики этой записи. Получение характеристик записи осуществляется методами:

Уровень - определяет уровень записи в результате запроса.

ТипЗаписи - определяет принадлежность записи к одному из следующих типов:

• групповой итог;

• итого по иерархии;

• детальная запись;

• общий итог.

Группировка - определяет имя поля, по которому были рассчитаны итоги.

Для иллюстрации работы этих методов посмотрим, что они будут возвращать записи для запроса, рассматриваемого в начале главы:

Выбрать
Товар, Количество Количество
Из
Документ.РасхНакл.Состав
Упорядочить по
Товар
Итоги
Сумма(Количество) По Товар, Товар Иерархия

Результат представлен в таблице:

№ Товар Количество Уровень ТипЗаписи Группировка
1 | Сантехника | 104 | 0 | ИтогПоИерархии | Товар
2 | Кран | 84 | 1 | ИтогПоГруппировке | Товар
3 | Кран | 10 | 2 | ДетальнаяЗапись
4 | Кран | 8 | 2 | ДетальнаяЗапись
5 | Кран | 44 | 2 | ДетальнаяЗапись
6 | Кран | 22 | 2 | ДетальнаяЗапись
7 | Смеситель | 20 | 1 | ИтогПоГруппировке | Товар
8 | Смеситель | 5 | 2 | ДетальнаяЗапись
9 | Смеситель | 1 | 2 | ДетальнаяЗапись
10 | Смеситель | 14 | 2 | ДетальнаяЗапись
11 | Мебель | 134 | 0 | ИтогПоИерархии | Товар
12 | Стол | 26 | 1 | ИтогПоГруппировке | Товар
13 | Стол | 1 | 2 | ДетальнаяЗапись
14 | Стол | 15 | 2 | ДетальнаяЗапись
15 | Стол | 10 | 2 | ДетальнаяЗапись
16 | Стул | 108 | 1 | ИтогПоГруппировке | Товар
17 | Стул | 55 | 2 | ДетальнаяЗапись
18 | Стул | 5 | 2 | ДетальнаяЗапись
19 | Стул | 32 | 2 | ДетальнаяЗапись
20 | Стул | 16 | 2 | ДетальнаяЗапись


2-375 Запрос (Query)

Запрос (Query)

Объект предназначен для выполнения запросов к базе данных.

Свойства

Текст (Text)

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит исходный текст выполняемого запроса.

Методы

Выполнить (Execute)

Синтаксис:

Выполнить()

Возвращаемое значение:

Тип: РезультатЗапроса.

Описание:

Позволяет выполнить запрос к базе данных.

УстановитьПараметр

Синтаксис:

УстановитьПараметр(< Имя>, <3начение>}

<Имя> Обязательный

Тип: Строка. Имя устанавливаемого параметра. Оно должно соответствовать требованиям, предъявляемым к именованию переменных встроенного языка.

<3начение> Обязательный

Тип: Произвольный. Значение устанавливаемого параметра.

Описание:

Позволяет установить параметр запроса. Параметры доступны для обращения в тексте запроса. С помощью этого метода можно передавать переменные в запрос, например, для использования в условиях запроса.

Пример:

Запрос.УстановитьПараметр("ДатаКонца", РабочаяДата);
Запрос.УстановитьПараметр("Товар", ВыбТовар);

Конструкторы

Основной

Синтаксис:

Новый Запрос (<Текст запроса>)

Параметры:

<Текст запроса> Необязательный

Тип: Строка. Текст запроса. Значение по умолчанию: Пустая строка.

Описание:

Позволяет создать запрос с указанным текстом.

РезультатЗапроса (QueryResult)

Объект содержит результат выполнения запроса. Предназначен для хранения и обработки полученных данных.

Свойства

Колонки (Columns)

Использование:

Только чтение.

Описание:

Тип: КоллекцияКолонокРезультатаЗапроса. Содержит коллекцию колонок результата запроса.

Методы

Выбрать (Choose)

Синтаксис:

Выбрать(< Тип обхода>)

Параметры:

<Тип обхода> Необязательный

Тип: системное перечисление ОбходРезультатаЗапроса. Задает тип обхода записей в получаемой выборке.

Значение по умолчанию: Прямой.

Возвращаемое значение:

Тип: ВыборкаИзРезультатаЗапроса.

Описание:

Предназначен для получения выборки записей из результата запроса.

Пример:

Выборка = РезультатЗапроса.Выбрать() ;

Выгрузить (Unload)

Синтаксис:

Выгрузить(<Тип обхода>)

Параметры:

<Тип обхода> Необязательный

Тип: системное перечисление ОбходРезультатаЗапроса. Задает тип обхода записей в получаемой выборке.

Возвращаемое значение:

Тип: ТаблицаЗначений, ДеревоЗначений. Если тип обхода задан Прямой, результат выгружается в таблицу значений, в противном случае в дерево значений.

Описание:

Позволяет выгрузить записи результата запроса в таблицу значений или дерево значений.

Пример:

ТаблицаРезультатов = РезультатЗапроса.Выгрузить();

Пустой (IsEmpty)

Синтаксис:

Пустой()

Возвращаемое значение:

Тип: Булево. Истина, если есть детальные записи; Ложь - в противном случае.

Описание:

Проверяет, есть ли в результате детальные записи.

ВыборкаИзРезультатаЗапроса (QueryResultSelection)

Свойства

<Имя поля>

Использование:

Только чтение.

Описание:

Тип: Произвольный. Набор свойств содержит значения полей записи результата запроса. Имена свойств совпадают с именами полей.

Методы

Выбрать (Choose)

Синтаксис:

Выбрать(<Тип обхода>, <Группировки>, <ГруппировкиДляЗначенийГруппировок>)

Параметры:

<Тип обхода> Необязательный

Тип: системное перечисление ОбходРезультатаЗапроса. Задает тип обхода записей в получаемой выборке.

Значение по умолчанию: ОбходРезультатаЗапроса.Прямой

<Группировки> Необязательный

Тип: Строка. Список группировок, разделенных запятыми, по которым будет производиться обход.

Для детальных записей указывается пустая строка. В случае, если группировки не указаны - будет использоваться следующая группировка, указанная в предложении запроса "ИТОГИ".

<ГруппировкиДляЗначенийГруппировок> Необязательный

Тип: Строка. Список группировок, разделенных запятыми, из которых будут выбираться значения группировок для обхода. Если указано "Все", то будут выбираться все значения группировок. Если указана пустая строка, то значения для группировок будут выбираться с предыдущей группировки.

Возвращаемое значение:

Тип: ВыборкаИзРезультатаЗапроса.

Описание:

Позволяет получить выборку вложенных записей для текущей записи результата.

Группировка (Group)

Синтаксис:

Группировка()

Возвращаемое значение:

Тип: Строка. Возвращает имя группировки текущей записи. Если группировки нет, возвращается пустая строка.

Описание:

Позволяет получить имя группировки текущей записи выборки.

Пример:

ТекГрупиировка = Выборка.Группировка();

Количество

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число.

Описание:

Количество записей в выборке.

НайтиСледующий (FindNext)

Синтаксис:

НайтиСледующий (< Структура поиска> )

Параметры:

<Структура поиска> Обязательный

Тип: Структура. Структура, которая определяет условия поиска. В ключе структуры находятся имена полей, в значениях - искомые значения.

Возвращаемое значение:

Тип: Булево. Истина, если запись найдена, Ложь - в противном случае.

Описание:

Позволяет найти запись по указанным условиям и установить указатель выборки на нее.

Примечание:

Текущая запись не рассматривается.

Пример:

СтуктураПоиска = Новый Структура("Товар, Контрагент");
СтуктураПоиска.Товар = НужныйТовар;
СтуктураПоиска.Контрагент = НужнайКонтрагент;
Пока Выборка.НайтиСледующий(СтуктураПоиска) Цикл
КонецЦидла;

Сбросить

Синтаксис:

Сбросить()

Описание:

Сбросить выборку. После вызова метода Следующий выборка спозиционируется на первую запись в ней.

Следующий (Next)

Синтаксис:

Следующий()

Возвращаемое значение:

Тип: Булево. Истина - если следующая запись выбрана. Ложь - если достигнут конец выборки.

Описание:

Выполняет получение следующей записи из результата запроса. Для обхода результата запроса нужно после получения выборки вызвать данный метод для позиционирования на первый элемент и далее вызывать до тех пор пока не будет возвращено значение Ложь.

Пример:

Пока Выборка.Следующий() Цикл
КонецЦикла;

СледующийПоЗначениюПоля (NextByFieldValue)

Синтаксис:

СледующийПоЗначениюПоля(< Имя поля>)

Параметры:

<Имя поля> Обязательный

Тип: Строка. Имя поля результата запроса, в котором будет осуществляться поиски следующего значения.

Возвращаемое значение:

Тип: Булево. Истина - если следующая запись выбрана. Ложь - в противном случае.

Описание:

Позволяет получить следующую запись по значению указанного поля. Выборка становится на следующую запись со значением в данном поле, отличающемся от текущего значения. При первом вызове - остается на текущей записи.

Пример:

Пока Выборка.СледующийПоЗначениюПоля("Товар") Цикл
КонецНикла;

ТипЗаписи (RecordType)

Синтаксис:

ТипЗаписи()

Возвращаемое значение:

Тип: системное перечисление ТипЗаписиЗапроса.

Описание:

Позволяет определить тип текущей записи выборки.

Пример:

ТекТип = Выборка.ТипЗаписи();

Уровень (Level)

Синтаксис:

Уровень()

Возвращаемое значение:

Тип: Число. Уровень текущей записи.

Описание:

Позволяет получить уровень текущей записи в иерархии и группировках. Уровень считается от начальной выборки из результата запроса.

Пример:

ТекУровень = Выборка.Уровень();

КоллекцияКолонокРезультатаЗапроса (QueryResultColumnsCollection)

Объект представляет собой коллекцию колонок результата запроса.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа КолонкаРезультатаЗапроса. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции. Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс колонки

Свойства

<Имя колонки>

Использование:

Только чтение.

Описание:

Тип: КолонкаРезультатаЗапроса. Набор свойств содержит колонки результата запроса. Имя свойства совпадают с именами полей запроса.

Методы

Индекс (IndexOf)

Синтаксис:

Индекс(<Колонка>)

Параметры:

<Колонка> Обязательный

Тип: КолонкаРезультатаЗапроса. Колонка результата запроса, для которой нужно определить индекс.

Возвращаемое значение:

Тип: Число. Индекс колонки результата запроса. Если колонка не принадлежит данной коллекции, возвращается -1.

Описание:

Позволяет определить индекс колонки результата запроса.

Пример:

РезультатЗапроса.Колонки.Индекс(Колонка);

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип Число. Количество колонок результата запроса.

Описание:

Позволяет получить количество колонок результата запроса.

Пример:

РезультатЗапроса.Колонки.Количество();

КолонкаРезультатаЗапроса (Query ResultColumn)

Объект представляет собой колонку результата запроса.

Свойства

Имя (Name)

Использование:

Только чтение.

Описание:

Тип Строка. Содержит строку с именем колонки.

ТипЗначения (ValueType)

Использование:

Только чтение.

Описание:

Тип: ОписаниеТипов. Содержит объект, описывающий допустимые типы значений для колонки.

Ширина (Width)

Использование:

Только чтение.

Описание:

Тип: Число. Содержит ширину колонки в символах.


Глава 1. Прикладные объекты

Прикладные объекты предназначены в основном для облегчения решения прикладных учетных задач. Они помогают создавать и поддерживать справочную информацию, накапливать сведения о документах и хозяйственных операциях, формировать учетные регистры. Подробнее о каждом типе прикладных объектов будет сказано в описании соответствующих разделов.

Константы

Константы в системе 1 С: Предприятие, как правило, служат для хранения информации, которая либо совсем не изменяется в процессе функционирования системы, либо изменяется достаточно редко В константах хранится информация, характеризующая прикладную задачу в целом. Наиболее простой пример подобной информации - название организации, которое, как правило, не меняется

В программных модулях для общих действий над заданными в конфигураторе константами (получение формы для управления константами, создание набора констант) служит объект КонстантыМенеджер. Для одновременного изменения значений определенной группы констант следует пользоваться объектом КонстантыНабор. Для чтения и записи значения определенной константы можно обращаться к объекту КонстантаМенеджер.

Пример:

// Получение значения константы Директор = Константы.Директор.Получить();

// Запись значения Константы.Директор.Установить("Иванов Петр Сидорович");

//Работа с набором констант НаборКонстант = Константы.СоздатьНабор("Директор,Бухгалтер") ;

НаборКонстант.Прочитать() ;

Если ПустаяСтрока(НаборКонстант.Директор) Тогда

НаборКонстант.Директор = "Иванов Сидор Петрович";

КонецЕсли ;

Если ПустаяСтрока(НаборКонстант.Бухгалтер) Тогда

НаборКонстант.Бухгалтер = "Сидоров Петр Иванович";

КонецЕсли;

НаборКонстант.Записать() ;

КонстантыМенеджер ( ConstantsManager )

Применяется в виде свойства Константы глобального контекста для предоставления доступа к константам.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа КонстантаМенеджер. <Имя константы;». Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются КонстантаМенеджер

Пример:

Константы.ПолучитьФорму().ОткрытьМодально();

Свойства

<Имя константы>

Использование:

Только чтение.

Описание:

Тип: КонстантаМенеджер.<Имя константы>.

Набор свойств содержит константы конфигурации. Имена свойств совпадают с именами констант, как они заданы в конфигураторе.

Методы

ПолучитьФорму ( GetForm )

Синтаксис:

ПолучитьФорму (< Форма>, <Владелец> , <Ключ уникальности>)

Параметры:

<Форма>Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию:

Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма

Описание:

Позволяет получить форму для управления константами.

Пример:

Константы.ПолучитьФорму().ОткрытьМодально() ;

СоздатьНабор ( CreateSet )_

Вариант синтаксиса:

По строке

Синтаксис:

СоздатьНабор(< Набор констант>)

Параметры:

<Набор констант>Обязательный

Тип: Строка. Строка, содержащая перечисленные через запятую имена констант, для управления которыми создается объект.

Если строка пустая, объект может быть использован для управления всеми константами.

Вариант синтаксиса:

По массиву Синтаксис:

СоздатьНабор(<Набор констант>)

Параметры:

<Набор констант>_ Необязательный Ключ

Тип: Массив. Массив значений, содержащий строки-имена констант и (или) соответствующие константам значен? я типа Объект описания метаданного. Этот список определяет набор констант, для управления которыми создается объест.

Если массив пустой, объект может быть использован для управления всеми константами.

Значение по умолчанию:

Пустой массив

Возвращаемое значение:

Тип: КонстантыНабор. Созданный набор констант.

Описание:

Используется для создания объекта управления константами.

// Создание набора по строке НаборКонстант = Константы.СоздатьНабор('Директор,Бухгалтер");

// Создание набора по массиву МассивКонстант = Новый Массив;

МассивКонстант.Добавить(Метаданные.Константы.Директор);

МассивКонстант.Добавить("Бухгалтер") ;

НаборКонстант = Константы.СоздатьНабор(МассивКонстант);

КонстантаМенеджер.<Имя константы> ( ConstantManager )

Предназначен для получения (чтения) и установки (записи) значения константы.

Методы

Получить ( Get )

Синтаксис:

Получить()

Возвращаемое значение:

Тип: Произвольный.

Текущее значение константы.

Описание:

Позволяет получить значение константы.

Примечание:

При каждом использовании метода происходит считывание значения из информационной базы.

Пример:

Сообщить("Директор у нас: " + Константы. Директор. Получить());

Установить ( Set )

Синтаксис:

Установить(< Значение>)

Параметры:

<3начение> Обязательный

Тип: Произвольный.

Описание:

Позволяет установить значение константы в информационной базе.

Пример:

Константы.Бухгалтер.Установить("Сидоров Петр Иванович");

КонстантыНабор ( ConstantsSet)

Предоставляет возможность проведения операций чтения и записи сразу для группы констант, в частном случае - для всех констант. Состав набора определяется с помощью параметра при создании объекта Менеджером констант. Объект также используется в форме констант для хранения, записи и считывания констант.

Пример:

НаборКонстант = Константы.СоздатьНабор ("Директор,Бухгалтер");

НаборКонстант.Прочитать() ;

Если ПустаяСтрока(НаборКонстант.Директор) Тогда

НаборКонстант.Директор = "Иванов Сидор Петрович";

КонецЕсли;

Если ПустаяСтрока(НаборКонстант.Бухгалтер) Тогда

НаборКонстант.Бухгалтер = "Сидоров Петр Иванович";

КонецЕсли;

НаборКонстант.Записать() ;

Свойства

<Имя константы>

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Набор свойств содержит константы конфигурации. Имена свойств совпадают с именами констант, как

они заданы в конфигураторе.

Непосредственно в момент обращения к данному свойству чтения или записи в информационную базу не производится. Для одновременного чтения или записи значений всех констант набора следует пользоваться методами данного объекта Прочитать и Записать.

См. также:

КонстантыНабор, метод Прочитать.

КонстантыНабор, метод Записать.

Методы

Записать ( Write )

Синтаксис;

Записать()

Описание:

Позволяет записать значения всех входящих в набор констант в информационную базу.

Пример:

НаборКонстант.Записать();

ПолучитьФорму ( GetForm )

Синтаксис:

ПолучитьФорму(<Форма>, <Владелец> , <Ключ уникальности>)

Параметры:

< Форма >_ Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип:Форма.

Описание:

Позволяет получить форму набора констант.

Пример:

НаборКонстант. ПолучитьФорму ().Открыть();

Прочитать ( Read )

Синтаксис:

Прочитать()

Описание:

Позволяет считать текущие значения входящих в набор констант из информационной базы.

Пример:

НаборКонстант.Прочитать();

Расширение формы констант

Предоставляет доступ к дополнительным методам и событиям формы, в том случае если основным реквизитом формы является набор констант.

Методы

ЗаписатьВФорме ( WritelnForm )

Синтаксис:

ЗаписатьВФорме()

Возвращаемое значение:

Тип: Булево. Истина - набор записан. Ложь - нет.

Описание:

Позволяет записать набор констант, открытый в форме.

Пример:

Если ЗаписатьВФорме() Тогда

Сообщить("Запись занесена в ИБ.");

КонецЕсли ;

События

ПередЗаписью ( BeforeWrite )

Синтаксис:

ПередЗаписью(< Отказ>)

Параметры:

<0тказ>

Тип: Булево. Признак отказа от записи объекта. Если в теле процедуры-обработчика установить данному параметру значение Истина, то запись объекта выполнена не будет.

Описание:

Событие возникает перед выполнением записи. Процедура-обработчик вызывается перед началом транзакции записи.

ПриЗаписи ( OnWrite )

Синтаксис:

ПриЗаписи(< Отказ>)

Параметры:

<0тказ>

Тип: Булево. Признак отказа от записи объекта. Если в теле процедуры-обработчика установить данному параметру значение Истина, то запись объекта выполнена не будет.

Описание:

Событие возникает при записи. Процедура-обработчик вызывается после записи, но до окончания транзакции.

ПослеЗаписи ( AfterWrite )

Синтаксис:

ПослеЗаписи()

Описание:

Событие возникает после окончания транзакции записи.


Справочники

Для работы с постоянной и условно постоянной информацией с некоторым множеством значений в системе используются объекты типа "Справочник". Обычно справочниками являются списки материалов, товаров, организаций, валют, сотрудников и др. Название и структура каждого конкретного справочника определяется при его создании в конфигураторе. На этапе конфигурирования можно описать, какими свойствами обладает каждый конкретный справочник. К настраиваемым свойствам относятся, например, длина и тип кода, количество уровней, поддержка уникальности кодов, набор реквизитов справочника. Помимо кода и наименования, механизм работы со справочниками позволяет создавать набор реквизитов для хранения любой дополнительной информации об элементе справочника.

Пример:

// Пример создания нового элемента

НовыйОбъект = Справочники.Валюты.СоздатьЭлемент();

НовыйОбъект.Код = "840";

НовыйОбъект.Наименование = "USD";

НовыйОбъект.ПолноеНаименование = "Доллары США";

НовыйОбъект.Записать() ;

// Пример обработки выборки справочника

КПЗ = Справочники.Номенклатура;

ОтборМПЗ = Новый Структура("ТипНоменклатуры");

Пусто = Перечисления.ТипыНоменклатуры.ПустаяСсылка();

ОтборМПЗ.ТипНоменклатуры = Пусто;

ВыборкаМПЗ = МПЗ.ВыбратьЭлементы(,,ОтборМПЗ, "Наименование Убыв"):

НачатьТранзакцию();

Пока ВыборкаМПЗ.Следующий() Цикл

Объект = ВыборкаМПЗ.ПолучитьОбъект();

Объект.ТипНоменклатуры = Перечисления.ТипыНоменклатуры.Товар.

Объект.Записать() ;

КонецДикла;

ЗафиксироватьТранзакцию();

СправочникиМенеджер (CatalogsManager)

Объект предназначен для управления справочниками и предоставляет доступ к значениям типа СправочникМенеджер. Доступ к объекту осуществляется через свойство глобального контекста Справочники.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа СправочникМенеджер. <Имя справочникам Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции.

Пример:

Для каждого СправМетаданные из Метаданные.Справочники Цикл

ИмяСправочника = СправМетаданные .Имя;

МенеджерСправочника = Справочники[ИмяСправочника];

ВыборкаСправочника = МенеджерСправочника .Выбрать();

Если ВыборкаСпразочника.Следующий() Тогда

Предупреждение("В информационной базе есть " + " заполненные справочники") ;

Возврат;

КонецЕсли ;

КонецЦикла ;

Свойства

<Имя справочника>

Использование:

Только чтение.

Описание:

Тип: Справочник Менеджер.<Имя справочникам Набор свойств содержит менеджеры отдельных справочников. Имена свойств совпадают с именами справочников, как они заданы в конфигураторе.

СправочникМенеджер. < Имя справочника> (CatalogsManager.<Имя справочника>)

Объект предназначен для управления справочником, как объектом конфигурации. С помощью этого объекта осуществляется поиск элементов, создание новых элементов и групп, работа с формами и макетами справочника. Доступ к объекту осуществляется через свойства объекта СправочникМенеджер. Полное имя типа объекта определяется с учетом имени справочника конфигурации. Например, для справочника Номенклатура имя типа будет выглядеть СправочникМенеджер.Номенклатура.

Методы

Выбрать ( Select )

Синтаксис:

Выбрать(<Родитель>, <Владелец>, <Отбор>, <Порядок>)

Параметры:

<Родитель> Необязательный

Тип: СправочникСсылка. <Имя справочникам Отбор по родителю. Имеет смысл только для многоуровневых справочников. Если параметр не задан или установлен в Неопределено, то отбор по родителю не производится. Чтобы отобрать элементы верхнего уровня, нужно в качестве данного параметра указать пустую ссылку на элемент справочника.

Значение по умолчанию: Неопределено.

<Владелец> Необязательный

Тип: СправочникСсылка. <Имя справочника>. Отбор по владельцу. Имеет смысл только для подчиненных справочников. Если параметр не задан или установлен в Неопределено, то отбор по владельцу не производится.

Значение по умолчанию: Неопределено.

<Отбор> Необязательный

Тип: Структура. Задает поле и значение отбора открываемой выборки. Ключ структуры описывает имя поля, а значение структуры - значение отбора по этому полю. В качестве полей для отбора могут задаваться только поле Код, Наименование и реквизиты справочника для которых в конфигураторе признак индексирования установлен в значение "Индексировать" или в значение "Индексировать с доп. упорядоч.".

Важно! Структура может содержать только один элемент.

Значение по умолчанию: Неопределено.

<Порядок> Необязательный

Тип: Строка. Строка с именем реквизита справочника, определяющая упорядочивание элементов в выборке. Может быть указано "Код", "Наименование" или имя одного из реквизитов примитивного типа (число, строка, дата, булево), для которого установлен признак "Индексирование" в значение "Индексировать" или в "Индексировать с доп. упорядоч." в конфигураторе. После имени реквизита через пробел может быть указано направление сортировки. Направление определяется: "Убыв" (" Desc") - упорядочивать по убыванию; "Возр" (" Asc") - упорядочивать по возрастанию. По умолчанию сортировка производится по возрастанию. Если параметр не указан, то порядок определяется основным представлением справочника.

Значение по умолчанию:

Пустая строка.

Возвращаемое значение:

Тип: СправочникВыборка. <Имя справочника>. Полученная выборка.

Описание:

Позволяет получить выборку элементов справочника по заданным условиям.

Пример:

МПЗ = Справочники.Номенклатура;

ОтборМПЗ = Новый Структура("ТипНоменклатуры");

Пусто = Перечисления.ТипыНоменклатуры.ПустаяСсылка();

ОтборМПЗ.ТипНоменклатуры = Пусто;

ВыборкаМПЗ = МПЗ.Выбрать(,,ОтборМПЗ, "Наименование Убыв");

Пока ВыборкаМПЗ.Следующий() Цикл

Объект = ВыборкаМПЗ.ПолучитьОбъект();

Объект.ТипНоменклатуры = Перечисления.ТипыНоненклатуры.Товар;

Попытка

Объект.Записать();

Исключение

Предупреждение("Не удалось записать объект " + Объект + "|" + ОписаниеОиибки(),60);

КонецПопытки ;

КонецЦикла ;

ВыбратьИерархически ( SelectHierarchicaly )

Синтаксис;

ВыбратьИерархически (< Родитель> , <Владелец>, <Отбор>, <Порядок>)

Параметры:

<Родитель> Необязательный

Тип: СправочникСсылка. <Имя справочника>. Отбор по родителю. Имеет смысл только для многоуровневых справочников. Если параметр не задан или установлен в Неопределено, то отбор по родителю не производится.

Значение по умолчанию: Неопределено.

<Владелец> Необязательный

Тип: СправочникСсылка. <Имя справочника>. Отбор по владельцу. Имеет смысл только для подчиненных справочников. Если параметр не задан или установлен в Неопределено, то отбор по владельцу не производится.

Значение по умолчанию: Неопределено.

<Отбор> Необязательный

Тип: Структура. Структура, в которой указывается поле отбора и значение отбора. Могут задаваться только Код, Наименование и реквизиты справочника, для которых в конфигураторе признак индексирования установлен в значение "Индексировать" или в значение "Индексировать с доп. упорядоч.".

Важно! Структура может содержать только один элемент

Значение по умолчанию: Неопределено.

<Порядок> Необязательный

Тип: Строка. Строка с именем реквизита справочника, определяющая упорядочивание элементов в выборке.

Может быть указан "Код", "Наименование" или имя одного из реквизитов примитивного типа (число, строка, дата, булево), для которого установлен признак Индексирование в значение Индексировать или Индексировать с доп. упорядоч. в метаданных. После имени реквизита через пробел может быть указано направление сортировки. Направление определяется:

  • "Убыв" ("Desc") - упорядочивать по убыванию;
  • "Возр" (" Asc") -упорядочивать по возрастанию.

По умолчанию сортировка производится по возрастанию. Если параметр не указан, то порядок определяется основным представлением справочника.

Значение по умолчанию:

Пустая строка.

Возвращаемое значение:

Тип: СправочникВыборка. <Имя справочника>. Полученная выборка.

Описание:

Позволяет получить иерархическую выборку элементов справочника по заданным условиям. При иерархической выборке для каждого элемента сначала выбираются элементы, для которых он является родителем, а затем уже выбирается следующий элемент.

Пример:

Товары = Справочники.Номенклатура;

ВыборкаСправочника = Товары.ВыбратьИерархически();

НайтиПоКоду ( FindByCode )

Синтаксис:

НайтиПоКоду(<Код>, <Поиск по полному коду> , <Родитель>, <Владелец>}

Параметры:

<Код> Обязательный

Тип: Число, Строка. Искомый код.

Строка или число в зависимости от настроек справочника в конфигураторе.

<Поиск по полному коду> Необязательный

Тип: Булево. Режим поиска по полному коду.

Если параметр устанавливается в Истина, то искомый код следует задавать в виде строки, состоящей из последовательности кодов по уровням справочника, разделенных символом "/".

Значение по умолчанию. Ложь.

<Родитель> Необязательный

Тип: СправочникСсылка. <Имя справочника>. Родитель, в пределах которого нужно выполнять поиск. Если не указан или установлен в Неопределено, то поиск будет проводиться во всем справочнике.

Значение по умолчанию: Неопределено.

<Владелец> Необязательный

Тип: СправочникСсылка. <Имя справочника>. Владелец, в пределах которого нужно выполнять поиск. Если не указан или установлен в Неопределено, то поиск будет проводиться во всем справочнике.

Значение по умолчанию:

Неопределенно.

Возвращаемое значение:

Тип: СправочникСсылка.<Имя справочника>. Ссылка на найденный элемент справочника. Если не существует ни одного элемента с требуемым кодом, то будет возвращена пустая ссылка.

Описание:

Позволяет получить ссылку на элемент по его коду.

Пример:

СтрокаКода = "840";

Волюты = Справочники.Валюты;

НайденнаяСсылка = Валюты.НайтиПоКоду(СтрокаКода);

Если НайденнаяСсылка = Валюты.ПустаяСсылка() Тогда

Сообщить( "Валюты " + СтрокаКода + " еще нет");

КонеиЕсли;

НайтиПоНаименованию ( FindByDescr )

Синтаксис:

НайтиПоНаименованию (< Наименование> , <Точное соответствие> , <Родитель>, <Владелец>)

Параметры:

<Наименование>_Обязательный

Тип: Строка. Строка, содержащая искомое наименование.

<Точное соответствие> Необязательный

Тип: Булево. Режим поиска по полному соответствию.

Поиск будет успешным, если строка поиска: в случае значения параметра Ложь - будет соответствовать левой части наименования; в случае значения параметра Истина - будет полностью совпадать с наименованием (за исключением "хвостовых" пробелов в наименовании).

Значение по умолчанию: Ложь.

<Родитель> Необязательный

Тип: СправочникСсылка. <Имя справочника>. Родитель, в пределах которого нужно выполнять поиск. Если не указан или установлен в Неопределено, то поиск будет проводиться во всем справочнике.

Значение по умолчанию: Неопределено.

<Владелец> Необязательный

Тип: СправочникСсылка. <Имя справочника>. Владелец, в пределах которого нужно выполнять поиск. Если не указан или установлен в Неопределено, то поиск будет проводиться во всем справочнике.

Значение по умолчанию: Неопределено.

Возвращаемое значение:

Тип: СправочникСсылка. <Имя справочника>. Ссылка на найденный элемент справочника. Если не существует ни одного элемента с требуемым наименованием, то будет возвращена пустая ссылка.

Описание:

Позволяет получить ссылку на элемент по его наименованию.

Примечание:

Если существует несколько элементов с указанным наименованием, то будет найден только один из них.

Пример:

СтрокаНаименоваиия = "USD";

Валюты = Справочники.Валюты;

НайденнаяСсылка = Валюты.НаЙтиПоНаименованию(СтрокаНаименования);

Если НайденнаяСсылка = Валюты.ПустаяСсылка() Тогда

Сообщить("Валюты " + СтрокаНаименования + " еще нет");

КонецЕсли;

НайтиПоРеквизиту ( FindByAttribute )

Синтаксис:

НайтиПоРеквизиту (<Имя реквизита> , <3начение реквизита>, <Родитель>, <Владелец>)

Параметры:

<Имя реквизита> Обязательный

Тип: Строка. Имя реквизита, как он задан в конфигураторе.

<3начение реквизита> Обязательный

Значение, по которому должен выполняться поиск.

<Родитель> Необязательный

Тип: СправочникСсылка. <Имя справочника>. Родитель, в пределах которого нужно выполнять поиск. Если не указан или установлен в Неопределено, то поиск будет проводиться во всем справочнике.

Значение по умолчанию: Неопределено.

<Владелец>Необязательный

Тип: СправочникСсылка. <Имя справочника>. Владелец, в пределах которого нужно выполнять поиск. Если не угазан или установлен в Неопределено, то поиск будет проводиться во всем справочнике.

Значение по умолчанию: Неопределено.

Возвращаемое значение:

Тип: СправочникСсылка.<Имя справочника>. Ссылка на найденный элемент справочника. Если не существует ни одного элемента с требуемым значением реквизита, то будет возвращена пустая ссылка.

Описание:

Позволяет получить ссылку на элемент по значению реквизита.

Примечание:

Если существует несколько элементов с указанным значением реквизита, то будет найдет только один из них.

Для реквизитов типа Строка поиск осуществляется по точному соответствию.

Пример:

СтрокаНаименования = "Доллары США" ;

Валеты = Справочники.Валюты;

НайденнаяСсылка = Валюты.НайтиПоРеквизиту ("ПолноеНаименоваяяе", СтрокаНаименования);

Если НайденнаяСсылка = Валюты.ПустаяСсылка() Тогда

Сообщить("Валюты " + СтрокаНаименования + "еде нет.");

Иначе

Сообщить('Нашли такую.") ;

КонецЕсли;

ПолучитьМакет ( GetTemplate )

Синтаксис:

ПолучитьМакет(< Макет>)

Параметры:

<Макет> Обязательный

Тип- Строка, Объект описания метаданного. Имя макета, как оно задано в конфигураторе или объект описания метаданного требуемого макета.

Возвращаемое значение:

Тип- ТабличныйДокумент. Созданный макет.

Описание:

Позволяет получить макет справочника.

ПолучитьФорму ( GetForm )

Синтаксис:

ПолучитьФорму (< Форма>, <Владелец> , <Ключ уникальности>)

Параметры:

<Форма> Обязательный

Тип: Строка. Имя формы, как оно задано в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание:

Позволяет получить форму справочника. Если получаемая форма - форма для редактирования элемента или группы справочника, то будет получена форма нового элемента или группы.

Пример:

Товары = Справочники.Номенклатура;

ФормаСписка= Товары.ПолучитьФорму("ФормаСписка") ;

Если Не ФормаСписка. Открыта () Тогда ФормаСписка.Открыть();

КонецЕсли;

ПолучитьФормуВыбора( GetFormChose )

Синтаксис:

ПолучитьФормуВыбора(< Форма >, <Владелец>, <Ключ уникальносnи>)

Параметры:

<Форма> Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение;

Тип: Форма.

Описание:

Позволяет получить форму списка для выбора элементов справочника.

Пример:

Товары = Справочники.Номенклатура;

ФормаСлиска= Товары.ПолучитьФормуВыбора();

Если Не ФормаСписка.Открыта() Тогда ФормаСписка.Открыть();

КонецЕсли;

ПолучитьФормуВыбораГруппы

Синтаксис:

ПолучитьФормуВыбораГруппы(< Форма>, <Владелец> , <Ключ уникальности> }

Параметры:

<Форма> Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание:

Позволяет получить форму списка для выбора группы справочника.

ПолучитьФормуНовогоЭлемента ( GetFormNewltem)

Синтаксис:

ПолучитьФормуНовогоЭлемента(< Форма>, <Владелец>,<Ключ уникальности> )

Параметры:

<Форма> Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание:

Позволяет получить форму нового элемента.

Пример:

Товары = Справочники.Номенклатура;

ФормаНового= Товары.ПолучитьФормуНовогоЭлемента();

ФормаНового.Открыть();

ПолучитьФормуНовойГруппы

Синтаксис:

ПолучитьФормуНовойГруппы (< Форма> , <Владелец> , <Ключ уникальности>)

Параметры:

<Форма> Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание:

Позволяет получить форму новой группы.

Пример:

Товары = Справочники. Номенклатура;

ФормаНового= Товары.ПолучитьФормуНовойГруппы();

ФормаНового.Открыть();

ПолучитьФормуСписка ( GetFormList )

Синтаксис:

ПолучитьФормуСписка (< Форма>, <Владелец> , <Ключ уникальности>)

Параметры:

<Форма> Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип:Форма.

Описание:

Позволяет получить форму списка элементов справочника.

Пример:

Товары = Справочники.Номенклатура;

ФормаСписка= Товары.ПолучитьФормуСписка();

Если не ФормаСписка.Открыта() Тогда ФормаСписка.Открыть() ;

КонецЕсли;

ПустаяСсылка ( EmptyRef )

Синтаксис:

ПустаяСсылка()

Возвращаемое значение:

Тип: СправочникСсылка.<Имя справочника>.

Описание:

Позволяет получить пустое значение ссылки на данный справочник.

Примечание:

Может использоваться, например, когда нужно передать пустую ссылку в параметр метода.

Пример:

Если найденнаяСсылка = Справочники.Валюты.ПустаяСсылка() Тогда Сообщить("Такой валюты еде нет");

КонецЕсли;

СоздатьГруппу ( CreateFolder )

Синтаксис:

СоздатьГруппу()

Возвращаемое значение:

Тип: СправочникОбъект. <Имя справочникам Созданный объект для записи группы справочника.

Описание:

Позволяет создать новую группу справочника.

Пример:

НовыйОбьект = Справочники
["Контрагенты"]
.СоздатьГруппу() ;

НовыйОбъект.Наименование = "Покупатели";

НовыйОбъект.Записать() ;

СоздатьЭлемент ( Createltem )

Синтаксис:

СоздатьЭлемент()

Возвращаемое значение:

Тип: СправочникОбъект.<Имя справочника>. Созданный объект для записи элемента справочника.

Описание:

Позволяет создать новый элемент справочника.

Пример:

НовыйОбъект = Справочники.Валеты.СоздатьЭлемент();

НовыйОбъект.Код = "840";

НовыйОбъект.Наименование = "USD";

НовыйОбъект.ПолноеНаименование = "Доллары США";

НовыйОбъект.Записать() ;

СправочникСсылка. <Имя справочника> ( CatalogRef .< Имя справочника>)

Используется для указания ссылки на элемент справочника в реквизитах других объектов и переменных встроенного языка. Данный объект не содержит средств для модификации элемента справочника, однако позволяет обращаться к его реквизитам и другой информации об элементе. При обращении к свойствам объекта будет выполняться считывание всех данных элемента справочника из информационной базы, но оно будет оптимизировано при многократном обращении к данному элементу как через этот объект, так и через другое равное ему значение.

Свойства

<Имя реквизита>

Использование;

Только чтение.

Описание:

Тип: Произвольный. Набор свойств содержит значения реквизитов справочника. Имена свойств совпадают с именами реквизитов, как они заданы в конфигураторе.

<Имя табличной части>

Использование:

Только чтение.

Описание:

Тип: Табличная часть. Набор свойств содержит табличные части справочника. Имена свойств совпадают с именами табличных частей, как они заданы в конфигураторе.

Владелец ( Owner )

Использование:

Только чтение.

Описание:

Тип: СправочникСсылка. <Имя справочника>. Содержит ссылку на владельца элемента справочника.

Примечание:

Имеет смысл только для подчиненных справочников.

Код ( Code )

Использование:

Только чтение.

Описание;

Тип: Число, Строка. Содержит код элемента справочника. Строка или число в зависимости от настроек справочника в конфигураторе.

Наименование ( Description )

Использование:

Только чтение.

Описание:

Тип: Строка. Содержит наименование элемента справочника.

ПометкаУдаления ( DeleteMark )

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит признак пометки на удаление элемента

справочника.

Родитель ( Parent )

Использование:

Только чтение.

Описание:

Тип: СправочникСсылка. <Имя справочника>. Содержит ссылку на родителя элемента справочника.

Примечание:

Имеет смысл только для многоуровневых справочников.

Ссылка ( Ref )

Использование:

Только чтение.

Описание:

Тип: СправочникСсылка. <Имя справочника>. Содержит ссылку на элемент справочника.

Примечание:

Так как СправочникОбъект и СправочникВыборка имеют одноименное свойство, то при обращении в программном модуле к данному свойству переданного в процедуру или функцию параметра не потребуется определять тип параметра:

СправочникСсылка, СправочникОбъект или СправочникВыборка.

ЭтоГруппа ( IsFolder )

Использование:

Только чтение.

Описание:

Тип: Булево. Позволяет определить является ли элемент справочника группой.

Методы

Метаданные ( Metadata )

Синтаксис:

Метаданные()

Возвращаемое значение:

Тип: Объект описания негаданного. Объект описания метаданных справочника.

Описание:

Предоставляет доступ к объекту описания метаданных справочника.

Пример:

Если Не ТоварСсылка. Пустая () Тогда

МетаданныеСправочника = ТоварСсылка.Метаданные();

Сообщить("Представление справочника - " + МетаданныеСправочника.Представление());

КонецЕсли;

ПолноеНаименование ( FullDescr )

Синтаксис;

ПолноеНаименование()

Возвращаемое значение:

Тип: Строка. Строка, включающая наименование элемента и наименования всех вышестоящих элементов.

Наименования выводятся слева направо, начиная с самого верхнего уровня, разделяются символом "/".

Описание:

Позволяет получить наименование элемента справочника с учетом наименований всех вышестоящих элементов.

Пример:

Сообщить("Полное наименование данного элемента: " + СсылкаНаЭлемент.ПолноеНаименоваиие());

ПолныйКод ( FutiCode )

Синтаксис:

ПолныйКод()

Возвращаемое значение:

Тип: Строка. Строка, включающая код элемента и коды всех вышестоящих элементов.

Коды выводятся слева направо, начиная с самого верхнего уровня, разделяются символом "/".

Описание:

Позволяет получить код элемента справочника с учетом кодов всех вышестоящих элементов.

Пример:

Сообщить <"Полный код данного элемента: " + СсылкаНаЭлемент.ПолныйКод()) ;

ПолучитьОбъект ( GetObject )

Синтаксис:

ПолучитьОбьект()

Возвращаемое значение:

Тип: СправочникОбъект. <Имя справочника>. Объект, предназначенный для модификации справочника.

Описание:

Предоставляет доступ к объекту, предназначенному для модификации справочника.

Пример:

ТипыМПЗ = Перечисления.ТипыНоменклатуры;

Если ТоварСсылка.ТипНоменклатуры = ТипыНПЗ.ПустаяСсылка() Тогда Объект = ТоварСсылка.ПолучитьОбъект();

Объект.ТипНоменклатуры = ТипыМПЗ.Товар;

Попытка

Объект.Записать();

Исключение

Предупреждение("Не удалось записать объект " + Объект + ОписаниеОшибки(),60) ;

КонецПопытки;

КонецЕсли;

ПолучитьФорму ( GetForm )

Синтаксис:

ПолучитьФорму (< Форма>, <Владелец> , <Ключ уникальности>)

Параметры:

<Форма> Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание:

Позволяет получить форму элемента справочника, на который указывает ссылка.

Пример:

Если Не ТоварСсылка.Пустая() Тогда

ТоварСсылка.ПолучитьФорму().Открыть();

Возврат ;

КонецЕсли;

ПринадлежитГруппе(BelongToGroup)

Синтаксис:

ПринадлежитГруппе (< Элемент>)

Параметры:

<Элемент> Обязательный

Тип: СправочникСсылка. <Имя справочника;». Группа, для которой определяется принадлежность элемента.

Возвращаемое значение:

Тип: Булево. Истина - элемент подчинен группе. Ложь - элемент не подчинен группе.

Описание:

Позволяет определить подчиненность элемента справочника группе с учетом всех уровней иерархии.

Примечание:

Метод определяет подчиненность группе непосредственно на момент вызова метода путем последовательного считывания всех вышестоящих элементов.

Пример:

Если ТоварСсылка. ПринадлежитГруппе(ГруппаСсылка) Тогда Сообщить("Принадлежит");

КонецЕсли;

Пустая ( IsEmpty )

Синтаксис:

Пустая ()

Возвращаемое значение:

Тип: Булево. Истина, если ссылка не указывает ни на какой

элемент

Ложь, если ссылка указывает на какой-либо элемент.

Описание:

Позволяет определить, является ли ссылка пустой или нет.

Пример:

Если ТоварСсылка.Пустая() Тогда

Предупреждение("Не выбран товар!",60);

Возврат;

КонецЕсли;

Скопировать ( Copy )

Синтаксис:

Скопировать()

Возвращаемое значение:

Тип СправочникОбъект.<Имя справочника>. Созданный объект для записи элемента справочника.

Описание:

Позволяет создать новый элемент справочника копированием существующего.

Пример:

Если Не ТоварСсылка.Пустая() Тогда

Копия = ТоварСсылка.Скопировать();

Копия.Записать();

КонецЕсли;

Уровень ( Level )

Синтаксис:

Уровень()

Возвращаемое значение:

Тип. Число. Уровень элемента справочника.

Описание:

Позволяет определить уровень элемента справочника.

Примечание:

Имеет смысл только для многоуровневых справочников. Следует учитывать, что уровень элемента может меняться, например, при переносе в другую группу (смене родителя). Для элемента, не имеющего родителей уровень будет равняться 0.

Пример:

Сообщить("Данный элемент принадлежит уровню " + СсылкаНаЭлемент.Уровень()) ;

СправочникОбъект.<Имя справочника> (CatalogObject.<Имя справочника>)

Предназначен для модификации элементов справочника. Позволяет изменять значения реквизитов элемента справочника и записывать его.

Важно! У всех событий этого объекта назначены предопределенные процедуры-обработчики. Имя процедур соответствует именам событий. Процедуры должны располагаться в модуле справочника.

Свойства

<Имя реквизита>

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Набор свойств содержит значения реквизитов справочника. Имена свойств совпадают с именами реквизитов, как они заданы в конфигураторе.

<Имя табличной части>

Использование:

Только чтение.

Описание:

Тип: Табличная часть. Набор свойств содержит табличные части справочника. Имена свойств совпадают с именами табличных частей, как они заданы в конфигураторе.

Владелец ( Owner )

Использование;

Чтение и запись.

Описание:

Тип: СправочникСсылка.<Имя справочника>. Содержит ссылку на владельца элемента справочника.

Важно! При попытке записать элемент подчиненного справочника без указания владельца будет выдаваться ошибка.

Примечание:

Имеет смысл только для подчиненных справочников.

Код ( Code )

Использование:

Чтение и запись.

Описание:

Тип: Число, Строка. Содержит код элемента справочника. Тип значения зависит от установки в конфигураторе типа кода справочника.

Наименование ( Description )

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит наименование элемента справочника.

ПометкаУдаления ( DeleteMark )

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак пометки на удаление элемента

справочника.

Родитель ( Parent )

Использование:

Чтение и запись.

Описание:

Тип: СправочникСсылка. <Имя справочника>. Содержит ссылку на родителя элемента справочника. Для элементов верхнего уровня содержит пустую ссылку.

Примечание:

Имеет смысл только для многоуровневых справочников.

Ссылка ( Ref )

Использование:

Только чтение.

Описание:

Тип: СправочникСсылка. <Имя справочника>. Содержит ссылку на элемент справочника.

Примечание:

Например, данное свойство можно использовать, если ссылку на созданный и записанный элемент справочника нужно присвоить реквизиту другого справочника.

ЭтоГруппа ( IsFolder )

Использование:

Только чтение.

Описание:

Тип: Булево. Позволяет определить, является ли элемент справочника группой.

ЭтотОбъект ( ThisObject )

Использование:

Только чтение.

Описание:

Тип: СправочникОбъект. <Имя справочника>. Содержит сам объект. Предназначено для получения объекта в модуле объекта или модуле формы.

Методы

Заблокирован ( IsLocked )

Синтаксис:

Заблокирован()

Возвращаемое значение:

Тип: Булево. Истина - элемент заблокирован. Ложь - элемент не заблокирован.

Описание:

Позволяет определить, заблокирован ли элемент данным объектом.

Примечание:

Следует учитывать, что этот метод используется для проверки блокировки объекта информационной базы конкретным объектом встроенного языка. Он не может быть использован для проверки, заблокирован ли вообще объект информационной базы, например, другими пользователями.

Пример:

Если НоменклатураОбъект.Заблокирован() Тогда НоменклатураОбъект.Разблокировать();

КонецЕсли;

Заблокировать ( Lock )

Синтаксис:

Заблокировать()

Описание:

Позволяет выполнить блокировку объекта от изменения другими режимами или пользователями.

Пример:

Попытка

Объект.Заблокировать();

Исключение

Предупреждение("Не удалось заблокировать объект " + Объект +ОписаниеОшибки(), 60);

КонецПопытки;

Записать ( Write )

Синтаксис:

Записать()

Описание:

Выполняет запись элемента справочника в информационную базу.

В процессе записи проверяется уникальность кода, если данные режим установлен в конфигурации.

Пример:

Попытка

Объект.Записать();

Исключение

Предупреждение ("Не удалось записать объект " + Объект + "|" + ОписаниеОшибки(), 60);

КонецПопытки;

Заполнить (Fill)

Синтаксис;

Заполнить(< Основание>)

Параметры:

<0снование> Обязательный

Тип: Произвольный. Значение, на основании которого выполняется заполнение элемента справочника.

Описание:

Позволяет заполнить данные элемента данными из другого объекта. Инициирует событие ОбработкаЗаполнения и вызов его процедуры-обработчика в модуле справочника. В ней может размещаться алгоритм, заполняющий данные элемента из переданного значения.

Примечание:

Для заполнения может использоваться значение любого типа.

Пример:

Объект.Заполнить(ОбьектОснование);

Метаданные ( Metadata )

Синтаксис:

Метаданные()

Возвращаемое значение:

Тип: Объект описания негаданного. Объект описания метаданных справочника.

Описание:

Предоставляет доступ к объекту описания метаданных справочника.

Пример:

МетаданныеСправочника = Объект.Метаданные();

Сообщить("Представление справочника " + МетаданныеСправочника.Представление());

Модифицированность ( Modified )

Синтаксис:

Модифицированность()

Возвращаемое значение:

Тип: Булево. Истина - если объект изменен. Ложь - если объект не изменен.

Описание:

Позволяет определить, был ли изменен объект.

Примечание:

Метод не позволяет определить, был ли изменен объект другими пользователями.

Пример:

Если Объект.Модифицированность() Тогда Объект.Записать();

КонецЕсли;

ПолноеНаименование ( FullDescr )

Синтаксис:

ПолноеНаименование()

Возвращаемое значение:

Тип: Строка. Строка, включающая наименование элемента и наименования всех вышестоящих элементов.

Наименования выводятся слева направо, начиная с самого верхнего уровня, разделяются символом "/".

Описание:

Позволяет получить наименование элемента справочника с учетом наименований всех вышестоящих элементов.

Пример:

Сообщить("Полное наименование данного элемента: " + Объект.ПолноеНаименование()) ;

ПолныйКод ( FullCode )

Синтаксис:

ПолныйКод()

Возвращаемое значение:

Тип: Строка. Строка, включающая код элемента и коды всех вышестоящих элементов.

Коды выводятся слева направо, начиная с самого верхнего уровня, разделяются символом "/".

Описание:

Позволяет получить код элемента справочника с учетом кодов всех вышестоящих элементов.

Пример:

Сообщить ("Полный код данного элемента: " + Объект.ПолныйКод());

ПолучитьМакет ( GetTemplate )

Синтаксис:

ПолучитьМакет (< Макет>)

Параметры:

<Макет> Обязательный

Тип: Строка, Объект описания метаданного. Имя макета, как оно задано в конфигураторе или объект описания метаданного требуемого макета.

Возвращаемое значение:

Тип: ТабличныйДокумент. Созданный макет.

Описание:

Позволяет получить макет справочника.

Пример:

Объект.ПолучитьМакет();

ПолучитьФорму ( GetForm )

Синтаксис:

ПолучитьФорму (<Форма> , <Владелец> , <Ключ уникальности>)

Параметры:

<Форма> Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип:Форма.

Описание:

Позволяет получить форму элемента справочника, которая содержит данный объект встроенного языка.

Пример:

Клиенты = Справочники.Контрагенты;

НовыйКлиент= Клиенты.СоздатьЭлемент();

НовыйКлиент.ПолучитьФорму() .Открыть();

ПринадлежитГруппе ( BelongsToFolder )

Синтаксис:

ПринадлежитГруппе (< Элемент>)

Параметры:

<Элемент> Обязательный

Тип: СправочникСсылка. <Имя справочника;». Ссылка на группу, для которой определяется принадлежность элемента.

Возвращаемое значение:

Тип: Булево. Истина - элемент подчинен группе.

Ложь - элемент не подчинен группе.

Описание:

Позволяет определить подчиненность элемента справочника группе с учетом всех уровней иерархии.

Примечание:

Определяет подчиненность группе непосредственно на момент вызова метода путем последовательного считывания всех вышестоящих элементов.

Пример:

Если Объект. ПринадлежитГруппе(ГруппаСсылка) Тогда Сообщить("Принадлежит") ;

КонецЕсли ;

Прочитать ( Read )

Синтаксис:

Прочитать()

Описание:

Позволяет прочесть заново данные элемента справочника.

Пример:

Объект.Прочитать();

Разблокировать ( Unlock )

Синтаксис:

Разблокировать()

Описание:

Позволяет снять блокировку элемента, если он заблокирован данным объектом.

Пример:

Объект.Разблокировать();

Скопировать ( Copy )

Синтаксис:

Скопировать()

Возвращаемое значение:

Тип: СправочникОбъект. <Имя справочника>. Созданный объект для записи элемента справочника.

Описание:

Позволяет создать новый элемент справочника копированием существующего.

Удалить ( Delete )

Синтаксис:

Удалить()

Описание:

Удаляет элемент справочника.

Важно! В отличие от метода УстановитьПометкуУдаления данный производит непосредственное удаление элемента справочника без возможности восстановления и без проверки ссылочной целостности. Использовать данный метод нужно крайне осмотрительно.

Пример:

Объект.Удалить();

Уровень ( Level )

Синтаксис:

Уровень()

Возвращаемое значение:

Тип: Число. Уровень элемента справочника.

Описание:

Позволяет определить уровень элемента справочника.

Примечание:

Имеет смысл только для многоуровневых справочников. Следует учитывать, что уровень элемента может меняться, например, при переносе в другую группу (смене родителя).

Для элемента, не имеющего родителей уровень будет равняться 0.

Пример:

Сообщить("Данный элемент принадлежит уровню " + Объект.Уровень());

УстановитьНовыйКод ( SetNewCode )

Синтаксис;

УстановитьНовыйКод(< Префикс кода>)

Параметры:

<Префикс кода> Необязательный

Тип: Строка. Строковое значение префикса. Если префикс указан, то новый код будет формироваться в пределах диапазона кодов ограниченных указанным префиксом.

Описание:

Устанавливает новый код. Если в коде присутствует числовая часть, то новый код автоматически устанавливается следующим за имеющимся максимальным. При этом определяется текущий максимальный код среди элементов данного справочника. Если передан префикс, то новый код устанавливается в пределах указанного префикса.

Примечание:

Префикс имеет смысл, если для справочника в конфигураторе выбран тип кода "Текстовый".

Пример:

Объект. УстановитьНовыйКод("Пр-");

УстановитьПометкуУдаления ( SetDeleteMark )

Синтаксис:

УстановитьПометкуУдаления(< Пометка удаления> , <Включая подчиненные> )

Параметры:

<Пометка удаления> Обязательный

Тип: Булево. Пометка.

Истина - пометка будет установлена.

Ложь - пометка будет снята.

<Включая подчиненные> Необязательный

Тип: Булево. Если параметр установлен в Истина, то будут помечены на удаление, кроме данного элемента, все его подчиненные элементы в данном справочнике и во всех подчиненных справочниках.

Если параметр установлен в Ложь, то будет помечен на удаление только данный элемент.

Значение по умолчанию: Истина.

Описание:

Позволяет установить/снять пометку на удаление. Объект при этом не удаляется из информационной базы. Окончательное удаление помеченных элементов справочника происходит при удалении помеченных объектов с проверкой ссылочной целостности данных.

Пример:

Объект. УстановитьПометкуУдаления(Истина, Истина);

ЭтоНовый ( IsNew )

Синтаксис:

ЭтоНовый()

Возвращаемое значение:

Тип Булево. Истина, если изменяется еще ни разу не записанный элемент.

Ложь, если элемент уже записан в информационную базу.

Описание:

Позволяет определить, был ли элемент уже записан в информационную базу.

Пример:

Если Объект.ЭтоНовый() Тогда

Объект.Наименование = "Новый элемент";

КонецЕсли;

События

ПриУстановкеНовогоКода

Синтаксис:

ПриУстановкеНовогоКода(<Стандартная обработка> , <Префикс>)

Параметры:

<Стандартная обработка>

Тип: Булево. В данный параметр передается признак выполнения стандартной (системной) обработки события. Если в теле процедуры-обработчика установить данному параметру значение Ложь стандартная генерация нового кода производиться не будет.

<Префикс>

Тип: Строка. Префикс, который будет использоваться для генерации кода. Может быть изменен в процедуре-обработчике события.

Описание:

Событие возникает в момент, когда выполняется установка нового кода элемента справочника.

ПриКопировании (ОпСору)

Синтаксис:

ПриКопировании (< Объект копирования>)

Параметры:

<0бъект копирования>

Тип: СправочникОбъект. <Имя справочника>. Исходный элемент, который является источником копирования.

Описание:

Событие возникает при создании элемента справочника копированием.

ОбработкаЗаполнения ( ProcessFHIing )

Синтаксис:

ОбработкаЗаполнения (< Основание>)

Параметры:

<0снование>

Тип: Произвольный. Значение, которое используется как основание для заполнения.

Описание:

Событие возникает при вводе элемента справочника на основании, а также при выполнении метода Заполнить. В процедуре- обработчике этого события должен быть описан сам алгоритм заполнения реквизитов элемента справочника на основании переданного значения.

ПередЗаписью ( BeforeWrite )

Синтаксис:

ПередЗаписью (< Отказ>)

Параметры:

<0тказ>

Тип: Булево. Признак отказа от записи элемента. Если в теле процедуры-обработчика установить данному параметру значение Истина, запись элемента выполнена не будет.

Описание:

Событие возникает перед выполнением записи элемента справочника. Процедура-обработчик вызывается после начала транзакции записи, но до начала записи элемента справочника.

ПриЗаписи ( OnWrite )

Синтаксис:

ПриЗаписи(< Отказ>)

Параметры:

<0тказ>

Тип: Булево. Признак отказа от записи. Если в теле процедуры-обработчика установить данному параметру значение Истина, то запись выполнена не будет.

Описание:

Событие возникает после записи элемента справочника в информационную базу, но до окончания транзакции записи.

ПередУдалением ( BeforeDelete )

Синтаксис:

ПередУдалением (< Отказ>)

Параметры:

<0тказ>

Тип: Булево. Признак отказа от удаления объекта. Если в теле процедуры-обработчика установить данному параметру значение Истина, удаление выполнено не будет.

Описание:

Событие возникает перед непосредственным удалением объекта из информационной базы.

СправочникВыборка.<Имя справочника> (CatalogSelection.<Имя справочника>)

Объект этого типа возвращается методами Выбрать и ВыбратьИерархически у объекта типа СправочникМенеджер и представляет собой специализированный способ перебора элементов справочника. Обход элементов выполняется системой динамически. Это означает, что использование выборки не считывает все элементы сразу, а выбирает их порциями из информационной базы. Такой подход позволяет достаточно быстро обходить с помощью выборки большие списки справочников и не загружает в память всех элементов выборки.

Пример:

Процедура УстановитьРеквизит(ИдСправочника, ИдРеквизита, ЗначениеРеквизита, СтруктураДляОтбора)

ВыборкаСправочника = Справочники[ИдСправочника].Выбрать(,,СтруктураДляОтбора);

Пока ВыборкаСправочника.Следующий() Цикл

Объект = ВыборкаСправочника.ПолучитьОбъект();

Объект(ИдРеквизита) = ЗначениеРеквизита;

Объект.Записать();

КонецЦикла;

КонецПроцедуры

Свойства

<Имя реквизита>

Использование:

Только чтение.

Описание:

Тип: Произвольный. Набор свойств содержит значения реквизитов справочника. Имена свойств совпадают с именами реквизитов, как они заданы в конфигураторе.

<Имя табличной части>

Использование:

Только чтение.

Описание:

Тип: Табличная часть. Набор свойств содержит табличные части справочника. Имена свойств совпадают с именами табличных частей, как они заданы в конфигураторе.

Владелец ( Owner )

Использование:

Только чтение.

Описание:

Тип: СправочникСсылка. <Имя справочника:». Содержит ссылку на владельца элемента справочника.

Примечание:

Имеет смысл только для подчиненных справочников.

Код ( Code )

Использование:

Только чтение.

Описание:

Тип: Число, Строка. Содержит код элемента справочника. Строка или число в зависимости от настроек справочника в конфигураторе.

Наименование ( Description )

Использование:

Только чтение.

Описание:

Тип: Строка. Содержит наименование элемента справочника.

ПометкаУдаления ( DeleteMark )

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит признак пометки на удаление элемента

справочника.

Родитель ( Parent )

Использование:

Только чтение.

Описание:

Тип: СправочникСсылка. <Имя справочникам Содержит ссылку на родителя элемента справочника.

Примечание:

Имеет смысл только для многоуровневых справочников.

Ссылка ( Ref )

Использование:

Только чтение.

Описание:

Тип: СправочникСсылка. <Имя справочника:». Содержит ссылку на элемент справочника.

ЭтоГруппа ( IsFolder )

Использование:

Только чтение.

Описание:

Тип: Булево. Позволяет определить является ли элемент справочника группой.

Методы

Метаданные ( Metadata )

Синтаксис:

Метаданные()

Возвращаемое значение:

Тип: Объект описания негаданного. Объект описания метаданных справочника.

Описание:

Предоставляет доступ к объекту описания метаданных справочника.

Пример:

МетаданныеСправочника = Выборка.Метаданные();

Сообщить("Представление справочника - " + МетаданныеСправочника.Представление());

ПолучитьОбъект ( GetObject )

Синтаксис:

ПолучитьОбъект()

Возвращаемое значение:

Тип: СправочникОбъект. <Имя справочника>. Объект, предназначенный для модификации элемента.

Описание:

Позволяет получить объект для модификации и записи элемента, на котором в данный момент спозиционирована выборка.

Пример:

Объект = ВыборкаСправочника.ПолучитьОбъект();

Следующий ( Next )

Синтаксис:

Следующий()

Возвращаемое значение:

Тип: Булево. Истина - если следующий элемент выбран. Ложь - если достигнут конец выборки.

Описание:

Выполняет получение следующего элемента выборки. Для обхода справочника нужно после получения выборки вызвать данный метод для позиционирования на первый элемент и далее вызывать до тех пор пока не будет возвращено значение Ложь.

Пример:

ВыборкаСправочника = Справочники.Валюты.Выбрать();

Пока ВыборкаСправочника.Следующй() Цикл

Сообщить("Записана валюта " + ВыборкаСправочника.Наименование);

КонецЦикла;

УровеньВВыборке ( LevellnSelection )

Синтаксис:

УровеньВВыборке()

Возвращаемое значение:

Тип: Число. Уровень в выборке.

Описание:

Позволяет определить уровень элемента справочника в выборке, полученной с помощью метода ВыбратьИерархически. Уровень выдается начиная с 0. То есть при обходе верхнего уровня выборки уровень будет равняться 0. Выдаваемые значения зависят от того, с каким отбором по родителю выполнялась выборка. Если отбор по родителю не производился, то уровень в выборке будет совпадать с уровнем элемента в справочнике.

Примечание:

Для неиерархической выборки смысла не имеет.

Пример:

МПЗ = Справочники.Номенклатура;

ВыборкаМПЗ = МПЗ.ВыбратьИерархически(ВыбГруппа,);

Пока ВыборкаМПЗ.Следующий() Цикл

Сообщить("в выборке " + ВыборкаМПЗ. Ссылка + "Уровень "+ ВыборкаНПЗ.УровеньВВыборке()) ;

Сообщить("в справочнике " + ВыборкаМПЗ.Ссылка + "Уровень "+ ВыборкаМПЗ.Ссылка.Уровень());

КонецЦикла ;

СправочникСписок.<Имя справочника> ( CatalogList . < Имя справочника>)

Объект предназначен для управления списком элементов справочника, отображаемым в табличном поле.

Пример:

СправочникСписок. Колонки. Добавить (" СтранаПроисхождения");

СправочникСписок. Порядок .Установить ("ЕдиницаИзмерения");

СправочникСписок. Отбор. СтранаПроисхождения .Установить ("Германия");

Свойства

Колонки ( Columns )

Использование:

Только чтение.

Описание:

Тип: Колонки списка. Содержит объект для управления колонками списка. Набор колонок составляется из полей справочника.

Отбор ( Filter )

Использование:

Только чтение.

Описание:

Тип: Отбор. Содержит объект Отбор, по которому осуществляется текущая фильтрация элементов справочника в списке. Имена элементов отбора совпадают с именами реквизитов справочника и критериев отбора, как они заданы в конфигураторе.

Порядок ( Order )

Использование:

Только чтение.

Описание:

Тип: Порядок. Содержит объект Порядок, по которому осуществляется текущее упорядочивание элементов справочника в списке. В качестве имен упорядочивания объекта могут выступать

имена предопределенных реквизитов Код и Наименование и имена реквизитов справочника.

Методы

Обновить ( Refresh )

Синтаксис:

Обновить()

Описание:

Позволяет обновить список элементов.

Расширение формы элемента справочника

Дополнительные методы и события формы элемента или группы

справочника.

Пример:

Процедура ПередЗаписью(Отказ)

ТилыМПЗ = Перечисления.ТипыНоменклатуры;

Если ТоварСсылка.ТипНоменклатуры = ТипыМПЗ.ПустаяСсылка() Тогда Отказ = Истина;

Предупреждение("Не выбран тип номенклатуры",0);

КонецЕсли;

КонецПроцедуры

Методы

ЗаписатьВФорме ( WritelnForm )

Синтаксис:

ЗаписатьВФорме()

Возвращаемое значение:

Тип: Булево. Истина, если объект записан, Ложь, если записать объект не удалось.

Описание:

Позволяет записать объект, открытый в форме.

Пример:

Если ЗаписатьВФорме() Тогда

Сообщить('Объект записан.");

КонецЕсли;

События

ПередЗаписью ( BeforeWrite )

Синтаксис:

ПередЗаписью(< Отказ>)

Параметры:

<0тказ>

Тип: Булево. Признак отказа от записи элемента. Если в теле процедуры-обработчика установить данному параметру значение Истина, то запись элемента выполнена не будет.

Описание:

Событие возникает перед выполнением записи объекта из формы. Процедура-обработчик данного события вызывается перед вызовом процедуры обработчика события ПередЗаписью объекта СправочникОбъект.

ПриЗаписи ( OnWrite )

Синтаксис:

ПриЗаписи(< Отказ>)

Параметры:

<0тказ>

Тип: Булево. Признак отказа от записи. Если в теле процедуры-обработчика установить данному параметру значение Истина, то запись выполнена не будет.

Описание:

Событие возникает после записи объекта, но до окончания транзакции. Процедура-обработчик данного события вызывается после вызова процедуры обработчика события ПриЗаписи объекта СправочникОбъект.

ПослеЗаписи ( AfterWrite )

Синтаксис:

ПослеЗаписи()

Описание:

Событие возникает после окончания транзакции записи объекта.

Расширение формы списка справочника

Предоставляет доступ к дополнительным методам формы, в том случае если основным реквизитом формы является список

справочника.

Пример:

Форма.ПараметрВыборГруппИЭлементов = ИcnoльзoвaниeГруппИЭлементов(»»Cwaвo^a^Iata. Элементы;

Свойства

ПараметрВыборГруппИЭлементов ( ChoiceFoldersAndltemsParameter )

Использование:

Чтение и запись.

Описание:

Тип: ИспользованиеГруппИЭлементовСправочника. Предоставляет возможность установить при открытии или повторном открытии формы списка справочника, что должно быть

выбрано в форме: любой элемент, только группы или только элементы.

При определении значения свойства используется системное перечисление

ИспользованиеГруппИЭлементовСправочмика ( CatalogFoldersAndItemsUse). Перечисление содержит следующие значения:

  • Группы ( Folders) Будут использоваться только группы справочника.
  • Элементы ( Items) Будут использоваться только элементы справочника.
  • ЭлементыИГруппы (ItemsAndFolders) Будут использоваться и элементы и группы справочника.

ПараметрВыборПоВладельцу ( ChoiceByOwnerParameter )

Использование:

Чтение и запись.

Описание:

Тип: СправочникСсылка. <Имя справочника>. Предоставляет возможность установить при открытии или повторном открытии формы списка справочника начальное значение владельца подчиненного справочника, по которому может быть осуществлен выбор элемента.

ПараметрОтборПоВладельцу

Использование:

Чтение и запись.

Описание:

Тип: СправочникСсылка. <Имя справочника>. Предоставляет возможность установить при открытии или повторном

открытии формы списка справочника начальное значение владельца подчиненного справочника, по которому должен быть показан список справочника.

Расширение поля ввода справочника

Дополнительные свойства поля ввода справочника.

Пример:

Клиент = ЭлементыФормы.ПолеВводаКонтрагента;

Клиент. БыстрыйВыбор = Истина;

Клиент. ВыборГруппИЭлементов = ОтборГруппИЭлеиентовСпрааочнюса. Группы;

Свойства

БыстрыйВыбор ( QuickChoice )

Использование:

Чтение и запись.

Описание:

Тип: Булево. Предоставляет доступ к управлению режимом выбора значения. Если свойство установлено в Истина, то выбор будет выполняться из выпадающего списка.

ВыборГруппИЭлементов ( ChoiceFoldersAnd Items )

Использование:

Чтение и запись.

Описание:

Тип: ИспользованиеГруппИЭлементовСправочника. Предоставляет доступ к управлению режимом выбора групп и элементов справочника: любой элемент, только группы или только элементы.

При определении значения свойства используется системное перечисление

ИспользованиеГруппИЭлементовСправочмика ( CatalogFoldersAndItemsUse). Перечисление содержит следующие значения:

  • Группы ( Folders) Будут использоваться только группы справочника.
  • Элементы ( Items) Будут использоваться только элементы справочника.
  • ЭлементыИГруппы (ItemsAndFolders) Будут использоваться и элементы и группы справочника.

ВыборПоВладельцу ( ChoiceByOwner )

Использование:

Чтение и запись.

Описание:

Тип: СправочникСсылка. <Имя справочника>. Содержит ссылку на элемент-владелец для поля ввода подчиненного справочника. Данное значение будет использовано при выборе элемента.

Расширение табличного поля списка справочника

Дополнительные свойства, методы и события табличного поля списка справочника. Для данного расширения свойство ТекущаяСтрока табличного поля содержит значение типа СправочникСсылка. Свойство ТекущиеДанные табличного поля содержит коллекцию значений данных строки, набор значений которой определяется колонками объекта СправочникСписок.

Свойства

Дерево ( Tree )

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит способ отображения поля списка.

Если свойство установить в Истина, то поле будет отображаться в виде дерева.

ИерархическийПросмотр ( HierarchicalView )

Использование:

Чтение и запись.

Описание:

Тип: Булево. Предоставляет доступ к управлению способу просмотра списка справочника. Если свойство установлено в Истина, то будет выполняться иерархический просмотр' (по родителям), иначе будут выводиться сразу все элементы справочника.

ИзменятьИерархическийПросмотр ( EnableChangeHierarchicalView )

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак того, может ли пользователь изменять иерархический просмотр (включать и выключать).

ИзменятьТекущегоРодителя ( EnableChangeCurrentParent )

Использование;

Чтение и запись.

Описание:

Тип: Булево. Содержит признак того, может ли пользователь

изменять текущего родителя.

НастройкаОтбора ( FilterSetting )

Использование:

Только чтение.

Описание:

Тип: Коллекция. Предоставляет доступ к настройкам отбора списка элементов справочника. Представляет собой коллекцию значений типа Управление элементом отбора. Свойства коллекции содержат объекты для управления элементом отбора. Имена свойств совпадают с именами доступных для справочника элементов отбора.

НастройкаПорядка ( OrderSetting )

Использование:

Только чтение.

Описание:

Тип: Коллекция. Предоставляет доступ к настройкам порядка списка элементов справочника. Представляет собой коллекцию значений типа Управление элементом порядка. Свойства коллекции содержат объекты для управления элементом порядка. Имена свойств совпадают с именами доступных для справочника элементов упорядочивания.

СпособРедактирования ( EditType )

Использование:

Чтение и запись.

Описание:

Тип: РежимРедактированияСписка. Предоставляет доступ к управлению способом редактирования элементов справочника.

При определении значения свойства используется системное перечисление РежимРедактированияСписка ( ListEditMode). Перечисление содержит следующие значения:

  • ВДиалоге ( InDialog) Для редактирования элемента списка поля вызывается специальный диалог.
  • ВСписке ( InList) Элементы редактируется непосредственно в поле списка.
События

ПередУстановкойПометкиУдапения ( BeforeSetDeletingMark )

Синтаксис:

ПередУстановкойПометкиУдаления (< Отказ>)

Параметры:

<0тказ>

Тип: Булево. Признак отказа от изменения пометки удаления объекта. Если в теле процедуры-обработчика установить данному параметру значение Истина, то пометка удаления изменена не будет.

Описание:

Событие возникает перед установкой пометки удаления из формы списка справочника.

Примечание:

Установка пометки на удаление приводит к записи объекта и, соответственно, вызывает события ПередЗаписыо и ПриЗаписи объекта СправочникОбъект.

ПередНачаломДобавления ( BeforeAddLine )

Синтаксис:

ПередНачаломДобавления (< Отказ>, <Копирование> , <Родитель>, <Группа>)

Параметры:

<0тказ>

Тип: Булево. Признак отказа от добавления строки. Если в теле процедуры-обработчика установить данному параметру значение Истина, то строка списка справочника добавлена не будет.

<Копирование>

Тип: Булево. Определяет режим копирования. Если Истина, то строка списка справочника добавляется копированием.

<Родитель>

Тип: СправочникСсылка. <Имя справочника;». Ссылка на элемент, который будет использован при добавлении в качестве родителя.

<Группа>

Тип: Булево. Определяет, что добавляется - группа или элемент справочника. Если Истина, то добавляется группа.

Описание:

Событие возникает перед добавлением строки списка справочника. Данное событие для табличного поля справочника возникает "вместо" одноименного события объекта ТабличноеПоле.

Примечание:

Расширяется набор параметров по сравнению с одноименным событием объекта ТабличноеПоле.

См. также:

ТабличноеПоле, событие ПередНачаломДобавления.

Расширение колонки табличного поля списка справочника

Дополнительные свойства колонки табличного поля списка справочника.

Свойства

Данные ( Data )

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя колонки списка справочника. Данное свойство позволяет указать, какие данные будут отображаться в ячейке табличного поля.

ДанныеФлажка ( CheckData )

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя колонки списка справочника, значения которой будут отображаться флажком ячейки табличного поля. Колонка списка справочника должна иметь тип Булево или Число.

OтoбpaжaтьCтaндapтнyюKapтинкy(DisplayStandaгdPicture)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак отображения в колонке стандартной картинки, обозначающей элемент справочника и его состояние.


Документы

Документ - одно из основных понятий системы 1С:Предприятие. При помощи документов организуется ввод в систему информации о совершаемых хозяйственных операциях, а также ее просмотр и корректировка.

В большинстве своем документы, которые создаются в процессе настройки конфигурации задачи, являются электронными аналогами стандартных бумажных документов, являющихся основаниями для тех или иных учетных действий или расчетов. Тем не менее, использование этого типа данных может выходить далеко за рамки простой фиксации изменений, внесенных в учетные регистры.

Структура каждого конкретного вида документа определяется при его создании в конфигураторе. У любого вида документа существуют реквизиты, которые создаются автоматически - это Дата и Номер. Номер создается, если при конфигурировании длина номера указана больше 0. Другие реквизиты документа определяются в конфигураторе отдельно для каждого создаваемого

вида документа.

ДокументыМенеджер ( DocumentsManager )

Объект предназначен для управления документами и предоставляет доступ к значениям типа ДокументМенеджер. Доступ к

объекту осуществляется через свойство глобального контекста Документы.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа ДокументМенеджер.<Имя документа>. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции.

Пример:

// менеджер документов предоставляет доступ к менеджеру

// документа РасходнаяНакладная.

НовДок = Документы.РасходнаяНакладная.СоздатьДокумент();

См. также:

Глобальный контекст, свойство Документы.

Свойства

<Имя документа>

Использование:

Только чтение.

Описание:

Тип: ДокументМенеджер.<Имя документа>. Набор свойств содержит менеджеры отдельных документов. Имена свойств совпадают с именами документов, как они заданы в конфигураторе.

ДокументМенеджер. < Имя документа > (DocumentManager.<Имя документа>)

Объект предназначен для управления документом, как объектом конфигурации. С помощью этого объекта осуществляется поиск документов, получение выборки документов, создание нового документа, работа с формами и макетами документа. Доступ к объекту осуществляется через свойства объекта

ДокументыМенеджер. Полное имя типа объекта определяется с учетом имени документа конфигурации. Например, для документа РасходнаяНакладная имя типа будет выглядеть ДокументМенеджер.РасходнаяНакладная.

Пример:

Результат = Документы.РасходнаяНакладная.НайтиПоНомеру(НомерДок, РабочаяДата) ;

Если Результат.Пустая() Тогда

Предупреждение("Документ не найден!");

Иначе

Результат.ПолучитьФорму().Открыть() ;

КонецЕсли;

Методы

Выбрать ( Select )

Синтаксис:

Выбрать (<Дата начала> , <Дата окончания>, <Отбор>, <Порядок>)

Параметры:

<Дата начала> Необязательный

Тип: Дата. Дата и время начала периода выборки документов.

Значение по умолчанию: Пустая дата, то есть выбираются все документы, начиная с самого первого документа в системе.

<Дата окончания> Необязательный

Тип: Дата. Дата окончания периода выбираемых документов

Значение по умолчанию: Пустая дата, то есть выбираются все документы, заканчивая самым последним документом в системе.

<0тбор> Необязательный

Тип: Структура. Задает поле и значение отбора открываемой выборки. Ключ структуры описывает имя поля, а значение структуры - значение отбора по этому полю. В качестве полей для отбора могут задаваться только поле Дата и реквизиты документа, для которых в конфигураторе признак индексирования установлен в значение "Индексировать" или в значение "Индексировать с доп. упорядочиванием".

Важно! Структура может содержать только один элемент.

Значение по умолчанию: Неопределено.

<Порядок> Необязательный

Тип: Строка. Задает реквизит документа, по которому упорядочивается выборка документов. Может быть указано поле Дата или имя реквизита документа, для которого признак индексирования в конфигураторе установлен в значения "Индексировать" или "Индексировать с доп. упорядочиванием". После указания имени через пробел может быть указано направление сортировки.

Направление определяется:

  • "Убыв" ("Desc") - упорядочивать по убыванию, и
  • "Возр" (" Asc") - упорядочивать по возрастанию.

По умолчанию выборка упорядочивается по возрастанию.

Значение по умолчанию: Если порядок не задан, выборка упорядочивается по хронологии документов.

Возвращаемое значение:

Тип: ДокументВыборка.<Имя документа>. Сформированная выборка.

Описание:

Метод предназначен для получения выборки документов за определенный период. Получаемая выборка может быть упорядочена по реквизитам документа.

Пример:

Выборка = Документы.РасходнаяНакладяая.Выбрать(ДатаНач, ДатаКон);

НайтиПоНомеру ( FindByNumber )

Вариант синтаксиса: Для документов с непериодической нумерацией

Синтаксис:

НайтиПоНомеру(<Номер документа>)

Параметры:

<Номер документа> Обязательный

Тип: Число, Строка. Номер искомого документа. Тип передаваемого значения зависит от установки в конфигураторе представления номера документа.

Вариант синтаксиса: Для документов с нумерацией в пределах периода

Синтаксис:

НайтиПоНомеру (< Номер документа> , <Дата интервала>)

Параметры:

<Номер документа> Обязательный

Тип: Число, Строка. Номер искомого документа. Тип передаваемого значения зависит от установки в конфигураторе представления номера документа.

<Дата интервала> Обязательный

Тип: Дата. Дата из интервала, в котором проводится поиск по номеру. Сам интервал определяется как период уникальности номеров документа, в который входит указанная дата. Например, если номера документов уникальны в пределах месяца и задана дата 10 декабря 2001 года, то поиск будет проводиться в интервале с 01 по 31 декабря 2001 года.

Возвращаемое значение:

Тип: ДокументСсылка.<Имя документа>. Если документ не найден, возвращается пустая ссылка на документ.

Описание:

Находит документ по номеру. Для документов с нумерацией в пределах периода поиск осуществляется в указанном периоде.

ПолучитьМакет ( GetTemplate )

Синтаксис:

ПолучитьМакет(< Макет>)

Параметры:

<Макет> Обязательный

Тип: Строка, Объект описания метаданного. Имя макета, как оно задано в конфигураторе или объект описания метаданного требуемого макета.

Возвращаемое значение:

Тип: ТабличныйДокумент.

Описание:

Метод позволяет получить один из макетов, определенных для документа в конфигурации.

ПолучитьФорму ( GetForm )

Синтаксис:

ПолучитьФорму(< Форма>, <Владелец>, <Ключ уникальности>)

Параметры:

<Форма> Обязательный

Тип: Строка. Имя формы, как оно задано в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание:

Позволяет получить форму документа. Если получаемая форма -форма для редактирования документа, то будет получена форма нового документа.

ПолучитьФормуВыбора ( GetFormChoice )

Синтаксис:

ПолучитьФормуВыбора (< Форма>, <Владелец>, <Ключ уникальности>)

Параметры:

<Форма> Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание:

Позволяет получить форму списка для выбора документов.

ПолучитьФормуНовогоДокумента ( GetFormNewDcou merit )

Синтаксис:

ПолучитьФормуНовогоДокумента (< Форма> , <Владелец> , <Ключ уникальности>)

Параметры:

<Форма> Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет

активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание:

Позволяет получить форму нового документа.

ПолучитьФормуСписка ( GetFormList )

Синтаксис:

ПолучитьФормуСписка (< Форма>, <Владелец>, <Ключ уникальности>)

Параметры:

<Форма> Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание:

Позволяет получить форму списка документов.

ПустаяСсылка ( EmptyRef )

Синтаксис:

ПустаяСсылка()

Возвращаемое значение:

Тип: ДокументСсылка.<Имя документа>.

Описание:

Метод предназначен для получения пустой ссылки на документ. Например, может использоваться, когда нужно передать пустую ссылку в параметр метода или процедуры.

СоздатьДокумент ( CreateDocument )

Синтаксис:

СоздатьДокумент()

Возвращаемое значение:

Тип: ДокументОбъект.<Имя документа>.

Описание:

Создает новый документ.

Пример:

// создание нового документа

РасходнаяНакладная НовДок = Документы.РасходнаяНакладная.СоздатьДокумент();

НовДок.Записать();

ДокументСсылка. < Имя документа> ( DocumentRef .< Имя документа>)

Используется для указания ссылки на документ в реквизитах других объектов и переменных встроенного языка. Данный объект не содержит средств для модификации документа, однако позволяет обращаться к его реквизитам и другой информации об документе. При обращении к свойствам объекта будет выполняться считывание всех данных документа из информационной базы, но оно будет оптимизировано при многократном обращении к данному документу как через этот объект, так и через другое равное ему значение.

Свойства

<Имя реквизита>

Использование:

Только чтение.

Описание:

Тип: Произвольный. Набор свойств содержит значения реквизитов документа. Имена свойств совпадают с именами реквизитов, как они заданы в конфигураторе.

<Имя табличной части>

Использование:

Только чтение.

Описание:

Тип: Табличная часть. Набор свойств содержит табличные части документа. Имена свойств совпадают с именами табличных частей, как они заданы в конфигураторе.

Дата ( Date )

Использование:

Только чтение.

Описание:

Тип: Дата. Содержит дату и время документа.

Номер ( Number )

Использование:

Только чтение.

Описание:

Тип: Число, Строка. Содержит номер документа. Тип значения зависит от установки в конфигураторе представления номера

документа.

ПометкаУдаления ( DeleteMark )

Использование;

Только чтение.

Описание:

Тип: Булево. Содержит признак пометки на удаление документа.

Проведен ( Posted )

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит признак проведенности документа.

Ссылка ( Ref )

Использование:

Только чтение.

Описание:

Тип: Документ-Ссылка. <Имя документа;». Содержит ссылку на документ. Это значение может быть записано в информационную базу для полей соответствующего типа.

Методы

Метаданные ( Metadata )

Синтаксис:

Метаданные()

Возвращаемое значение:

Тип: Объект описания метаданного.

Описание:

Позволяет получить объект описания метаданных документа. Другой путь получения того же значения - через свойство глобального контекста Метаданные. Например: Метадан-ные.Документы.РасходнаяНакладная.

Пример:

Если ВыбДокумент.Метаданные().Реквизиты.Контрагент.Выбран() Тогда Контрагент = ВыбДокумент.Контрагент;

КонецЕсли;

МоментВремени ( PointOfTime )

Синтаксис:

МоментВремени()

Возвращаемое значение:

Тип: МоментВремени.

Описание:

Позволяет получить момент времени документа.

ПолучитьОбъект ( GetObject )

Синтаксис:

ПолучитьОбъект()

Возвращаемое значение:

Тип: ДокументОбъект. <Имя документа>.

Описание:

Позволяет получить по ссылке объект для модификации и записи документа (ДокументОбъект.<Имя документа>).

Пример:

Объект = ВыбДокумент.ПолучитьОбъект();

ПолучитьФорму ( GetForm )

Синтаксис:

Получитьформу (< Форма> , <Владелец>, <Ключ уникальности>)

Параметры:

<Форма> Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности>Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание:

Позволяет получить форму документа.

Пример:

ВыбДокумент.ПолучитьФорму(). Открыть();

Пустая ( IsEmpty )

Синтаксис:

Пустая()

Возвращаемое значение:

Тип: Булево.

Описание:

Позволяет получить признак пустой ссылки на документ. Это означает, что ссылка не ссылается ни на один объект базы данных. Если ссылка пустая, метод возвращает значение Истина. Может использоваться, например, для проверки выбранности документа в элементе управления.

Пример:

Если ВыбДокумент. Пустая() Тогда

Предупреждение ("Выберите документ !");

КонецЕсли;

Скопировать ( Copy )

Синтаксис:

Скопировать()

Возвращаемое значение:

Тип: ДокументОбъект.<Имя документа>.

Описание:

Позволяет скопировать существующий документ.

Пример:

Объект = ВыбДокумент.Скопировать();

См. также:

ДокументОбъект.<Имя документа>. событие ПриКопировании.


ДокументОбъект

ДокументОбъект. < Имя документа > (DocumentObject.<Имя документа>)

Объект для модификации документов. Позволяет изменять реквизиты документа и записывать его.

Важно! У всех событий этого объекта назначены предопределенные процедуры-обработчики. Имена процедур соответствуют именам событий. Процедуры должны располагаться в модуле документа.

См. также:

ДокументСсылка.<Имя документа>

ДокументВыборка.<Имя документа>

Свойства

<Имя реквизита>

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Набор свойств содержит значения реквизитов документа. Имена свойств совпадают с именами реквизитов, как они заданы в конфигураторе.

<Имя табличной части>

Использование:

Только чтение.

Описание:

Тип: Табличная часть. Набор свойств содержит табличные части документа. Имена свойств совпадают с именами табличных частей, как они заданы в конфигураторе.

Дата ( Date )

Использование:

Чтение и запись.

Описание:

Тип: Дата. Содержит дату и время документа.

Движения ( Movements )

Использование:

Только чтение.

Описание:

Тип: Коллекция. Предоставляет доступ к коллекции наборов движений документа. Свойства коллекции содержат наборы движений документа, которые включены для данного документа в метаданных. Имена свойств совпадают с именами объектов метаданных, по которым могут совершаться движения, как они заданы в конфигураторе.

Номер ( Number )

Использование:

Чтение и запись.

Описание:

Тип: Число, Строка. Содержит номер документа. Тип значения зависит от установки в конфигураторе представления номера

документа.

ПометкаУдаления ( DeleteMark )

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит признак пометки на удаление документа.

ПринадлежностьПоследовательностям ( BelongingSequences )

Использование:

Только чтение.

Описание:

Тип: Коллекция. Предоставляет доступ к наборам записей последовательностей, в которых регистрируется документ. Представляет собой коллекцию значений типа ПоследовательностьНаборЗаписей. Свойства коллекции содержат наборы записей последовательностей. Имена свойств совпадают с именами последовательностей как они заданы в конфигураторе.

Проведен ( Posted )

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит признак проведенности документа.

Ссылка ( Ref )

Использование:

Только чтение.

Описание:

Тип: ДокументСсылка. <Имя документа:». Содержит ссылку на документ. Это значение может быть записано в информационную базу для полей соответствующего типа.

ЭтотОбъект ( ThisObject )

Использование:

Только чтение.

Описание:

Тип: ДокументОбъект. <Имя документа>. Содержит сам объект базы данных. Предназначено, в основном, для получения данного объекта встроенного языка в модуле объекта или модуле формы.

Методы

Заблокирован ( IsLocked )

Синтаксис:

Заблокирован()

Возвращаемое значение:

Тип: Булево. Истина, если документ заблокирован, Ложь в противном случае.

Описание:

Метод позволяет определить, заблокирован ли документ данным

объектом.

Примечание:

Следует учитывать, что этот метод используется для проверки блокировки объекта информационной базы конкретным объектом встроенного языка. Он не может быть использован, чтобы проверить, заблокирован ли вообще объект информационной базы.

Пример:

Если РасходнаяНакладнаяОбъект.Заблокирован() Тогда РасходнаяНакладнаяОбъект.Разблокировать();

КонецЕсли;

Заблокировать( Lock )

Синтаксис:

Заблокировать()

Описание:

Выполняет блокировку объекта от изменения другими режимами или пользователями.

Пример:

Попытка

НовДокумент.Заблокировать();

Исключение

Предупреждение("Невозможно заблокировать документ.");

КонецПопытки ;

Записать ( Write )

Синтаксис:

Записать (<Режим записи> , <Режим проведения> )

Параметры:

< Режим записи> Необязательный

Тип: РежимЗаписиДокумента. Позволяет выбрать один из возможных режимов записи.

Значение по умолчанию: Запись

При определении значения параметра используется системное перечисление РежимЗаписиДокумента ( DocumentWritingMode).

<Режим проведения> Необязательный

Тип: РежимПроведения. Позволяет выбрать один из возможных режимов проведения.

Значение по умолчанию: Неоперативный

При определении значения параметра используется системное перечисление РежимПроведения (PostingMode).

Описание:

Выполняет запись документа в информационную базу.

Примечание:

Для документов с поддержкой уникальности номеров, в процессе записи, если нужно, проверяется уникальность номера.

Пример:

Попытка

НовДокумент. Записать (РежимЗаписиДокумента. Проведение);

Исключение

Предупреждение("Невозможно провести документ.");

КонецПопытки ;

См. также:

ДокументОбъект.<Имя документа>, событие ПередЗаписью.

ДокументОбъект.<Имя документа>, событие ПриЗаписи.

Заполнить ( Fill )

Синтаксис:

Заполнить(< Основание>)

Параметры:

<0снование> Обязательный

Тип: Произвольный. Значение, на основании которого выполняется заполнение документа.

Описание:

Позволяет заполнить данные документа данными из другого объекта. Инициирует событие ОбработкаЗаполнения и вызов его процедуры-обработчика в модуле документа. В ней может размещаться алгоритм, заполняющий данные документа из переданного значения.

Примечание:

Для заполнения может использоваться значение любого типа.

Пример:

РасходнаяНакладнаяОбъект.Заполнить(ВыбКонтрагент);

См. также:

ДокументОбъект.<Имя документа> . событие ОбработкаЗаполнения.

Метаданные ( Metadata )

Синтаксис:

Метаданные()

Возвращаемое значение:

Тип:Объект описания метаданного.

Описание:

Позволяет получить объект описания метаданных документа. Другой путь получения того же значения - через свойство глобального контекста Метаданные. Например: Метадан-ные.Документы.РасходнаяНакладная.

Пример:

Если ВыбДокумент. Метаданные().Реквизиты .Контрагент. Выбран() Тогда Контрагент = ВыбДокумент.Контрагент;

КонедЕсли;

Модифицированность ( Modified )

Синтаксис:

Модифицированность()

Возвращаемое значение:

Тип: Булево. Истина, если документ модифицирован и Ложь - если нет.

Описание:

Позволяет получить признак модифицированное™ документа.

Пример:

Если РасходнаяНакладнаяОбьект. Модифицированность() Тогда Предупреждение("Документ был изменен.");

КонецЕсли;

МоментВремени ( PointOfTime )

Синтаксис:

МоментВремени()

Возвращаемое значение:

Тип: МоментВремени.

Описание:

Позволяет получить момент времени документа.

ПолучитьГраницуАктуальности ( GetActualBound )

Синтаксис:

ПолучитьГраницуАктуальности()

Описание

Возвращаемое значение:

Тип: МоментВремени. Граница актуальности для документа.

Описание:

Позволяет определить границу актуальности для документа. Граница актуальности определяется как момент времени наиболее позднего движения по тем оперативным регистрам, по которым данный документ может записывать движения. Состав этих регистров задается при настройке метаданных документа.

ПолучитьМакет ( GetTemplate )

Синтаксис:

ПолучитьМакет (<Макет>)

Параметры:

<Макет> Обязательный

Тип: Строка, Объект описания метаданного. Имя макета, как оно задано в конфигураторе или объект описания метаданного требуемого макета.

Возвращаемое значение:

Тип: ТабличныйДокумент.

Описание:

Позволяет получить макет документа.

ПолучитьФорму ( GetForm )

Синтаксис:

ПолучитьФорму (< Форма>, <Владелец> , <Ключ уникальности>)

Параметры:

<Форма> Необязательный

Тип: Строка, Объект описания негаданного. Имя формы, как оно задано в конфигураторе или объект описания ме-таданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип:Форма.

Описание:

Позволяет получить форму документа, которая содержит данный объект встроенного языка.

Пример:

ВыбДокумент.ПолучитьФорму().Открыть();

Прочитать ( Read )

Синтаксис:

Прочитать()

Описание:

Метод считывает данные документа из информационной базы. Необходим для перечитывания документа заново.

Пример:

РасходнаяНакладнаяОбъект. Прочитать();

Разблокировать ( Unlock )

Синтаксис:

Разблокировать()

Описание:

Метод выполняет разблокировку документа, если он заблокирован этим объектом.

Пример:

РасходнаяНакладнаяОбъект.Разблокировать();

Скопировать ( Copy )

Синтаксис:

Скопировать()

Возвращаемое значение:

Тип: ДокументОбъект.<Имя документа>

Описание:

Позволяет скопировать существующий документ.

Пример:

Объект = ВыбДокумент.Скопировать();

Си. также:

ДокументОбъект.<Имя документа>, событие ПриКопировании.

Удалить ( Delete )

Синтаксис:

Удалить()

Описание:

Метод удаляет документ из базы данных.

Важно! В отличие от метода УстановитьПометкуУдаления, данный производит непосредственное удаление документа без возможности восстановления и без проверки ссылочной целостности. Использовать данный метод нужно крайне осмотрительно.

Пример:

ТекстВопроса = "Удалить документ без возможности восстановления";

Ответ = Вопрос(ТекстВопроса, РежимДиалогаВопрос.ДаНет);

Если Ответ = КодВозвратаДиалога.Да Тогда РасходнаяНакладнаяОбьект.Удалить();

КонецЕсли;

УстановитьВремя ( SetTime )

Синтаксис:

УстановитьВремя (< Режим определения времени> , <Использовать журналы>)

Параметры:

<Режим определения времени> Необязательный

Тип: Автовремя. Устанавливает режим автоматического определения времени при записи нового документа.

Значение по умолчанию: ТекущееИлиПоследним.

При определении значения параметра используется системное перечисление Автовремя ( AutoTime).

<Использовать журналы> Необязательный

Тип: Булево. В данный параметр может быть передан признак, устанавливать ли время с использованием журналов, в которых отражается данный документ.

Значение по умолчанию: Ложь.

Описание:

Метод устанавливает режим определения времени при записи документа.

УстановитьНовыйНомер ( SetNewNumber )

Синтаксис:

УстановитьНовыйНомер (< Префикс номера>)

Параметры:

<Префикс номера> Необязательный

Тип: Строка. Префикс устанавливаемого номера. Значение по умолчанию: Пустая строка

Описание:

Устанавливает новый номер документа для заданного префикса номера.

Примечание:

Для документов с нумерацией в пределах периода, номер устанавливается в соответствии с установленной датой документа.

Пример:

РасходнаяНакладнаяОбъект.УстановитьНовыйНомер(ПрефиксИБ);

См. также:

Документ-Объект.<Имя документа>, событие ПриУстановкеНовогоНомера.

УстановитьПометкуУдаления ( SetDeleteMark )

Синтаксис:

УстановитьПометкуУдаления (< Пометка удаления>)

Параметры:

<Пометка удаления> Обязательный

Тип: Булево. Признак пометки удаления документа. Если значение Истина - пометка на удаление будет установлена, если Ложь - снята.

Описание:

Позволяет установить/снять пометку на удаление документа. Документ при этом не удаляется из информационной базы. Окончательное удаление помеченных документов происходит при удалении помеченных объектов с проверкой ссылочной целостности данных.

Пример:

РасходнаяНакладнаяОбъект.УстановитьПометкуУдаления(Истина);

ЭтоНовый ( IsNew )

Синтаксис:

ЭтоНовый()

Возвращаемое значение:

Тип: Булево. Для новых документов, которые еще не были записаны, метод возвращает значение Истина. Если документ уже записан, то Ложь.

Описание:

Позволяет определить, записан ли документ в базу данных.

Пример:

Если РасходнаяНакладнаяОбъект.ЭтоНовый() Тогда РасходнаяНакладнаяОбъехт.Записать();

КонецЕсли;

События

ПриУстановкеНовогоНомера ( OnSetNewNumber )

Синтаксис:

ПриУстановкеНовогоНомера (< Стандартная обработкам, <Префикс>)

Параметры:

<Стандартная обработка>

Тип: Булево. В данный параметр передается признак выполнения стандартной (системной) обработки события. Если в теле процедуры-обработчика установить данному параметру значение Ложь, стандартная генерация нового номера производиться не будет.

<Префикс>

Тип: Строка. Префикс, который будет использоваться для генерации номера. Может быть изменен в процедуре-обработчике события.

Описание:

Событие возникает в момент, когда выполняется установка нового номера документа.

См. также:

ДокументОбъект.<Имя документа>, метод УстановитьНовыйНомер.

ПриКопировании (ОпСору)

Синтаксис:

ПриКопировании (<Объект копирования>)

Параметры:

<0бъект копирования>

Тип: ДокументОбъект. <Имя документа>. Исходный документ, который является источником копирования.

Описание:

Событие возникает при создании документа копированием.

См. также:

ДокументСсылка.<Имя документа>, метод Скопировать.

ОбработкаЗаполнения ( ProcessFilling)

Синтаксис:

ОбработкаЗаполнения (< Основание>)

Параметры:

<0снование>

Тип: Произвольный. Значение, которое используется как основание для заполнения.

Описание:

Событие возникает при вводе документа на основании, а также при выполнении метода Заполнить. В процедуре-обработчике этого события должен быть описан сам алгоритм заполнения реквизитов документа на основании переданного значения.

См. также:

ДокументОбъект.<Имя документа>, метод Заполнить.

ПередЗаписью ( BeforeWrite )

Синтаксис:

ПередЗаписью (<Отказ>, <Режим записи>)

Параметры:

<0тказ>

Тип: Булево. Признак выполнения записи документа. Если в теле процедуры-обработчика установить данному параметру значение Истина, то запись документа выполнена не будет.

<Режим записи>

Тип: РежимЗаписиДокумента. В данный параметр передается текущий режим записи документа. Позволяет определить в теле процедуры режим записи.

При определении значения параметра используется системное перечисление РежимЗаписиДокумента (DocumentWrifcingMode).

Описание:

Событие возникает перед выполнением записи объекта. Процедура-обработчик вызывается после начала транзакции записи, но до начала записи документа.

См. также:

ДокументОбъект.<Имя документа> метод Записать.

ПриЗаписи ( OnWrite )

Синтаксис:

ПриЗаписи{<Отказ>)

Параметры:

<0тказ>

Тип: Булево. Признак выполнения записи документа. Если в теле процедуры-обработчика установить данному параметру значение Истина, то запись документа выполнена не будет.

Описание:

Событие возникает при записи объекта. Процедура-обработчик вызывается после записи документа, но до окончания транзакции записи.

См.также:

ДокументОбъект. <Имя документа>, метод Записать.

ПередУдалением ( BeforeDelete )

Синтаксис:

ПередУдалением (< Отказ>)

Параметры:

<0тказ>

Тип: Булево. Признак удаления документа. Если в теле процедуры-обработчика установить данному параметру значение Истина, то удаление документа выполнено не будет.

Описание:

Событие возникает перед удалением объекта из базы.

ОбработкаПроведения ( ProcessPosting )

Синтаксис:

ОбработкаПроведения (< Отказ>, <Режим проведения>)

Параметры:

<0тказ>

Тип: Булево. Признак проведения документа. Если в теле процедуры-обработчика установить данному параметру значение Истина, то проведение документа выполнено не будет.

<Режим проведения>

Тип: РежимПроведения. В данный параметр передается текущий режим проведения.

При определении значения параметра используется системное перечисление РежимПроведения ( PostingMode).

Описание:

Событие возникает при проведении документа. Основное назначение процедуры-обработчика данного события - генерация движений по документу.

Примечание:

Если для данного вида документа в конфигурации установлено автоматическое удаление движений, то перед возникновением события все движения по документу будут удалены.

См. также:

ДокументОбъект.<Имя документа>, метод Записать.

ОбработкаУдаленияПроведения ( ProcessUnposting)

Синтаксис:

ОбработкаУдаленияПроведения (< Отказ>)

Параметры:

<0тказ>

Тип: Булево. Признак отмены проведения документа. Если в теле процедуры-обработчика установить данному параметру значение Истина, то отмена проведения документа произведена не будет.

Описание:

Событие возникает при отмене проведения документа.


ДокументВыборка

ДокументВыборка.<Имя документа> ( DocumentSelection .< Имя документа>)

Объект этого типа возвращается методом Выбрать у объекта типа ДокументМенеджер и представляет собой специализированный способ перебора документов.

Обход документов выполняется системой динамически. Это означает, что использование выборки не считывает все документы сразу, а выбирает их порциями из информационной базы. Такой подход позволяет достаточно быстро обходить с помощью выборки большие списки документов и не загружает в память всех элементов выборки.

Важно! Данному объекту доступны все свойства объекта ДокументСсылка.

См. также:

ДокументСсылка.<Имя документа>

ДокументОбъект.<Имя документам>

Свойства

<Имя реквизита>

Использование:

Только чтение.

Описание:

Тип: Произвольный. Набор свойств содержит значения реквизитов документа. Имена свойств совпадают с именами реквизитов, как они заданы в конфигураторе.

<Имя табличной части>

Использование:

Только чтение.

Описание:

Тип: Табличная часть. Набор свойств содержит табличные части документа. Имена свойств совпадают с именами табличных частей, как они заданы в конфигураторе.

Дата ( Date )

Использование:

Только чтение.

Описание:

Тип: Дата. Содержит дату и время документа.

Номер ( Number )

Использование:

Только чтение.

Описание:

Тип: Число, Строка. Содержит номер документа. Тип значения зависит от установки в конфигураторе представления номера

документа.

ПометкаУдаления ( DeleteMark )

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит признак пометки на удаление документа.

Проведен ( Posted )

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит признак проведенности документа.

Ссылка ( Ref )

Использование:

Только чтение.

Описание:

Тип: ДокументСсылка. <Имя документа>. Содержит ссылку на документ. Это значение может быть записано в информационную базу для полей соответствующего типа.

Методы

ПолучитьОбъекг ( GetObject )

Синтаксис:

ПолучитьОбъект()

Возвращаемое значение:

Тип: ДокументОбъект.<Имя документа>.

Описание:

Позволяет получить объект для модификации и записи документа, на котором в данный момент спозиционирована выборка.

Следующий ( Next )

Синтаксис:

Следующий()

Возвращаемое значение:

Тип: Булево. Возвращает значение Истина, если получен следующий документ из выборки, и Ложь - если не получен (выборка документов завершена).

Описание:

Выполняет получение очередного документа выборки. Для обхода списка документов нужно после получения выборки использовать данный метод для позиционирования на первый и последующие документы выборки до тех пор, пока он не вернет значение Ложь.

ДокументСписок.<Имя документа>

Объект предназначен для управления списком документов, отображаемым в табличном поле.

Свойства

Колонки ( Columns )

Использование:

Только чтение.

Описание:

Тип: Колонки списка. Содержит объект для управления колонками списка.

Отбор ( Filter )

Использование:

Только чтение.

Описание:

Тип: Отбор. Содержит объект Отбор, по которому осуществляется текущая фильтрация документов в списке. Имена элементов отбора совпадают с именами реквизитов документа и критериев отбора, как они заданы в конфигураторе.

Порядок ( Order )

Использование:

Только чтение.

Описание:

Тип: Порядок. Содержит объект Порядок, по которому осуществляется текущее упорядочивание документов в списке. В качестве имен упорядочивания объекта могут выступать имена предопределенных реквизитов Дата и Номер и имена реквизитов документа.

Методы

Обновить ( Refresh )

Синтаксис:

Обновить()

Описание:

Вызывает перечитывание данных списка из базы данных.

Расширение формы документа

Дополнительные свойства, методы и события формы документа.

См. также:

Расширение табличного поля списка документов.

Свойства

Автовремя ( AutoTime )

Использование:

Только чтение.

Описание:

Тип: Автовремя. Содержит способ установки времени при записи нового документа.

При определении значения свойства используется системное перечисление Автовремя ( AutoTime ).

ИспользоватьРежимПроведения ( UsePostingMode )

Использование:

Чтение и запись.

Описание:

Тип: ИспользованиеРежимаПроведения. Содержит режим проведения документа. Значение данного свойства будет использоваться для определения режима проведения, если оно будет вызываться средствами формы (методом ЗаписатьВФорме, стандартным действием команды).

При определении значения свойства используется системное перечисление ИспользованиеРежимаПроведения ( PostingModeUse ).

См. также:

Расширение формы документа, метод ЗаписатьВФорме.

ПриЗаписиПерепроводить

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак режима записи проведенного документа. Если установлено значение Истина, проведение будет автоматически выполняться при записи проведенного документа.

Методы

ЗаписатьВФорме ( WritelnForm )

Синтаксис:

ЗаписатьВФорме()

Возвращаемое значение:

Тип: Булево. Истина, если документ успешно записан. Ложь в противном случае.

Описание:

Записывает документ, открытый в данный момент в форме.

См. также:

Расширение формы документа, свойство ИспользоватьРежимПроведения.

События

ПередЗаписью ( BeforeWrite )

Синтаксис:

ПередЗаписью(< Отказ>)

Параметры:

<Отказ>

Тип: Булево. Признак выполнения записи документа. Если в теле процедуры-обработчика установить данному параметру значение Истина, то запись документа выполнена не будет.

Описание:

Событие возникает перед выполнением записи объекта. Процедура-обработчик вызывается перед началом транзакции записи документа.

Примечание:

Данное событие возникает до события ПередЗаписью объекта ДокументОбъект.

См. также:

ДокументОбъект. <Имя документа>, событие ПередЗаписью.

ПриЗаписи ( OnWrite )

Синтаксис:

ПриЗаписи{<Отказ>)

Параметры:

<Отказ>

Тип: Булево. Признак выполнения записи документа. Если в теле процедуры-обработчика установить данному параметру значение Истина, то запись документа выполнена не будет.

Описание:

Событие возникает при записи объекта. Процедура-обработчик вызывается после записи документа, но до окончания транзакции записи.

Примечание:

Данное событие возникает после события ПриЗаписи объекта ДокументОбъект.

Си. также:

ДокументОбъект.<Имя документа> событие ПриЗаписи.

ПослеЗаписи ( AfterWrite )

Синтаксис:

ПослеЗаписи()

Описание:

Событие возникает после записи объекта. Процедура-обработчик вызывается после записи документа, и после окончания транзакции записи, то есть к моменту вызова этой процедуры запись документа полностью завершена.

Расширение табличного поля списка документов

Дополнительные свойства, методы и события табличного поля списка документов. Для данного расширения свойство ТекущаяСтрока табличного поля содержит значение типа Документе ссылка. Свойство ТекущиеДанные табличного поля содержит коллекцию значений данных строки, набор значений которой определяется колонками объекта ДокументСписок.

Свойства

НастройкаОтбора ( FilterSetting )

Использование:

Только чтение.

Описание:

Тип: Коллекция. Предоставляет доступ к настройкам отбора списка документов. Представляет собой коллекцию значений типа Управление элементом отбора. Свойства коллекции содержат объекты для управления элементом отбора. Имена свойств совпадают с именами доступных для документа элементов отбора.

НастройкаПорядка ( OrderSetting )

Использование:

Только чтение.

Описание:

Тип: Коллекция. Предоставляет доступ к настройкам порядка списка документов. Представляет собой коллекцию значений типа Управление элементом порядка. Свойства коллекции содержат объекты для управления элементом порядка. Имена свойств совпадают с имена доступных элементов упорядочивания

СтандартныйПериод ( StandartPeriod )

Использование:

Чтение и запись.

Описание:

Тип: НастройкаПериода. Содержит объект НастройкаПериода, в соответствии с которым осуществляется настройка периода списка документов при открытии формы, содержащей данное табличное поле.

См. также:

НастройкаПериода.

События

ПередУстановкойПометкиУдаления ( BeforeSetDeletingMark )

Синтаксис:

ПередУстановкойПометкиУдаления (<Отказ>)

Параметры;

<Отказ>

Тип: Булево. Признак изменения пометки удаления документа. Если в теле процедуры-обработчика установить данному параметру значение Истина, то пометка удаления изменена не будет.

Описание:

Событие возникает перед установкой пометки удаления в списке документов.

ПередПроведением ( BeforePosting )

Синтаксис:

ПередПроведением(<Отказ>)

Параметры:

<Отказ>

Тип: Булево. Признак проведения документа. Если в теле процедуры-обработчика установить данному параметру значение Истина, то проведение документа выполнено не будет.

Описание:

Событие возникает перед интерактивным проведением документа в списке.

ПередОтменойПроведения ( BeforeUnposting )

Синтаксис:

ПередОтменойПроведения (< Отказ>)

Параметры:

<Отказ>

Признак отмены проведения документа. Если в теле процедуры-обработчика установить данному параметру значение Истина, то отмена проведения документа выполнена не будет.

Описание:

Событие возникает перед интерактивной отменой проведения документа в списке.

ПередИзменениемДаты(ВеТогеРа1еСЬапде)

Синтаксис:

ПередИзменениемДаты (< Отказ>)

Параметры:

<Отказ>

Признак изменения даты и времени документа. Если в теле процедуры-обработчика установить данному параметру значение Истина, то изменение даты документа выполнено не будет.

Описание:

Событие возникает перед изменением даты документа при использовании интерактивной команды смены времени.

Расширение колонки табличного поля списка документов

Дополнительные свойства колонки табличного поля списка документов.

Свойства

Данные ( Data )

Использование:

Чтение и запись.

Описанием

Тип: Строка. Содержит имя колонки списка документов. Данное свойство позволяет указать, какие данные будут отображаться в ячейке табличного поля.

ДанныеФлажка ( CheckData )

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя колонки списка документов, значения которой будут отображаться флажком ячейки табличного поля. Колонка списка документов должна иметь тип Булево или Число.

ОтображатьСтандартнуюКартинку

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак отображения в колонке стандартной картинки, обозначающей документ и его состояние.


Журналы документов

Журналы документов являются средством для отображения в едином списке документов нескольких видов. Журнал документов может иметь несколько форм и макетов табличного документа.

ЖурналыДокументовМенеджер ( DocumentsJournalsManager )

Объект предназначен для управления журналами документов и предоставляет доступ к значениям типа ЖурналДокументовМенеджер. Доступ к объекту осуществляется через свойство глобального контекста

ЖурналыДокументов.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа ЖурналДокументовМенеджер.<Имя журнала документов>. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции.

Пример:

// менеджер журналов документов предоставляет доступ к

// менеджеру журнала Реализация.

Выборка = ЖурналыДокументов.Реализация.Выбрать();

См. также:

Глобальный контекст, свойство ЖурналыДокументов.

Свойства

<Имя журнала документов>

Использование:

Только чтение.

Описание:

Тип: ЖурналДокументовМенеджер.<Имя журнала документов>. Набор свойств содержит менеджеры отдельных журналов документов. Имена свойств совпадают с именами журналов документов, как они заданы в конфигураторе.

ЖурналДокументовМенеджер. <Имя журнала документов> ( DocumentsJournalManager.< Имя журнала документов>)

Предназначен для управления журналом документов, как объектом конфигурации. С помощью этого объекта можно получить выборку документов, регистрируемых в журнале, работать с формами и макетами конкретного журнала документов. Доступ к объекту осуществляется через свойство объекта ЖурналыДокументовМенеджер.

Полное имя типа объекта определяется с учетом имени журнала документов конфигурации. Например, для журнала документов Реализация имя типа будет выглядеть ЖурналДокументовМенеджер.Реализация.

Пример:

Выборка = ЖурналыДокументов. Реализация. Выбрать();

Пока Выборка.Следующий() Цикл // обработка выборки

КонецЦикла;

Методы

Выбрать ( Select )

Синтаксис:

Выбрать(<Дата начала>, <Дата окончания>}

Параметры:

<Дата начала> Необязательный

Тип: Дата. Дата и время начала периода выборки документов.

Значение по умолчанию: Пустая дата, то есть выбираются все документы, начиная с самого первого документа в системе.

<Дата окончания> Необязательный

Тип: Дата. Дата окончания периода выбираемых документов.

Значение по умолчанию: Пустая дата, то есть выбираются все документы, начиная с самого первого документа в системе.

Возвращаемое значение:

Тип: Документ Выборка. <Имя документа>.

Описание:

Предназначен для получения выборки документов, регистрируемых в журнале, за определенный период.

Пример:

ВыборкаИзЖурнала = ЖурналыДокументов.Торговля.Выбрать(, РабочаяДата);

ПолучитьМакет ( GetTemplate )

Синтаксис:

ПолучитьМакет(< Макет>)

Параметры:

<Макет> Обязательный

Тип: Строка, Объект описания метаданного. Имя макета, как оно задано в конфигураторе или объект описания метаданного требуемого макета.

Описание:

Позволяет получить один из макетов, определенных в конфигурации для журнала документов.

Пример:

МакетРеестра = ЖурналыДокументов.Общий.ПолучитьМакет("Реестр");

ПолучитьФорму ( GetForm )

Синтаксис:

ПолучитьФорму(< Форма>, <Владелец>, <Ключ уникальности>)

Параметры:

<Форма> Необязательный

Тип: Строка, Объект описания метаданного- Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда

будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание;

Позволяет получить форму журнала документов.

Пример:

ФормаЖурнала = ЖурналыДокументов .Общий.ПолучитьФорму();

ЖурналДокументовВыборка.<Имяжурнала> ( DocumentsJournalSelection .<Имя журнала>)

Объект этого типа возвращается методом Выбрать у объекта ЖурналДокументовМенеджер и представляет собой специализированный способ перебора документов, регистрируемых в журнале.

Обход документов выполняется системой динамически. Это означает, что использование выборки не считывает все документы сразу, а выбирает их порциями из информационной базы. Такой подход позволяет достаточно быстро обходить с помощью выборки большие списки документов и не загружает в память всех элементов выборки.

Свойства

<Имя графы>

Использование:

Только чтение.

Описание:

Набор свойств содержит значения реквизитов документов, отображаемых в соответствующих графах журнала. Имена свойств совпадают с именами граф журнала, как они заданы в конфигураторе.

Дата ( Date )

Использование:

Только чтение.

Описание:

Тип: Дата. Содержит дату и время текущего документа выборки.

Ссылка ( Ref )

Использование:

Только чтение.

Описание:

Тип: Документ-Ссылка. <Имя документа;». Содержит ссылку на текущий документ выборки.

Методы

ПолучитьОбъект ( GetObject )

Синтаксис:

ПолучитьОбъект()

Описание:

Позволяет получить объект для модификации и записи документа, на котором в данный момент спозиционирована выборка.

Следующий ( Next )

Синтаксис:

Следующий()

Возвращаемое значение:

Возвращает значение Истина, если получен следующий документ из выборки, и Ложь - если не получен (выборка документов завершена).

Описание:

Выполняет получение очередного документа выборки. Для обхода списка документов нужно после получения выборки использовать данный метод для позиционирования на первый и последующие документы выборки до тех пор, пока он не вернет значение Ложь.

ЖурналДокументовСписок.<Имя журнала> ( DocumentsJournalList .< Имя журнала>)

Предназначен для управления списком документов, регистрируемых в журнале, отображемым в табличном поле.

См. также:

ДокументСписок. <Имя документа>.

Свойства

Колонки ( Columns )

Использование:

Только чтение.

Описание:

Тип: Колонки списка. Содержит колонки списка журнала документов. В списке журнала могут быть использованы колонки с графами журнала, а также с датой, номером и видом документа.

Отбор ( Filter )

Использование:

Только чтение.

Описание:

Тип: Отбор. Содержит объект Отбор, по которому осуществляется текущая фильтрация документов в списке журнала.

В списке журнала документов доступен отбор по графам журнала, дате, номеру и виду документов, а также критериям отбора, в которые входят регистрируемые в журнале документы.

Для отбора по виду документов используется тип Объект описания метаданного.

Порядок ( Order )

Использование:

Только чтение.

Описание:

Тип: Порядок. Содержит объект Порядок, по которому осуществляется текущее упорядочивание документов в журнале. В качестве свойств объекта могут выступать дата, номер документа и графы журнала. Имена свойств совпадают с именами граф, как они заданы в конфигураторе.

Важно! При упорядочивании по графе, содержащей ссылочные типы, происходит группировка документов в списке без упорядочивания по представлению. Например, если в графе "Автор документа" отображаются реквизиты документов типа СправочникСсылка. Пользователи, при упорядочивании по этой графе получим сгруппированный по авторам список документов, но не обязательно в алфавитном порядке.

Примечание:

Необходимо отметить, что визуальная настройка порядка в журнале отличается от настройки средствами встроенного языка тем, что может использовать только упорядочивание по датам документов.

Методы

Обновить ( Refresh )

Синтаксис:

Обновить()

Описание:

Вызывает перечитывание данных списка.

Расширение колонки табличного поля журнала документов

Дополнительные свойства колонки табличного поля, связанного с журналом документов.

Свойства

Данные ( Data )

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя колонки журнала, значения которой будут отображаться в ячейке табличного поля.

ДанныеФлажка ( CheckData )

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя колонки журнала, значения которой будут отображаться и редактироваться флажком ячейки табличного поля.

Примечание:

Содержит имя колонки журнала, значения которой будут отображаться и редактироваться во флажке ячейки табличною поля.

ОтображатьСтандартнуюКартинку

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак отображения в колонке стандартной картинки, обозначающей документ и его состояние.

Расширение табличного поля журнала документов

Дополнительные свойства, методы и события табличного поля журнала документов. Для данного расширения свойство ТекущаяСтрока табличного поля содержит значение типа ДокументСсылка. Свойство ТекущиеДанные табличного поля содержит коллекцию значений данных строки, набор значений которой определяется колонками объекта ЖурналДокументовСписок,

Свойства

НастройкаОтбора ( FilterSetting )

Использование:

Только чтение.

Описание:

Тип: Коллекция. Предоставляет доступ к настройкам отбора списка документов, регистрируемых в журнале. Представляет собой коллекцию значений типа Управление элементом отбора. Свойства коллекции содержат объекты для управления элементом отбора. Имена свойств совпадают с именами доступных в журнале элементов отбора.

НастройкаПорядка ( OrderSetting )

Использование:

Только чтение.

Описание:

Тип: Коллекция. Предоставляет доступ к настройке порядка списка документов, регистрируемых в журнале. Представляет собой коллекцию значений типа Управление элементом порядка. Для журнала документов эта коллекция состоит из одного элемента, соответствующего упорядочиванию списка документов по дате. Свойство коллекции содержит объект для управления элементом порядка и имеет имя Дата.

СтандартныйПериод ( StandartPeriod )

Использование:

Чтение и запись.

Описание:

Тип: НастройкаПериода. Содержит объект НастройкаПериода в соответствии с которым осуществляется

настройка периода списка документов при открытии формы, содержащей данное табличное поле.

См. также:

НастройкаПериода.

События

ПередУстановкойПометкиУдаления ( BeforeSetDeletingMark )

Синтаксис:

ПередУстановкойПометкиУдаления (< Отказ>)

Параметры:

<0тказ>

Тип: Булево. Признак изменения пометки удаления документа. Если в теле процедуры-обработчика установить данному параметру значение Истина, то пометка удаления изменена не будет.

Описание:

Событие возникает перед установкой пометки удаления в списке

документов.

ПередПроведением ( BeforePosting )

Синтаксис:

ПередПроведением (< Отказ> )

Параметры:

<0тказ>

Тип: Булево. Признак проведения документа. Если в теле процедуры-обработчика установить данному параметру значение Истина, то проведение документа выполнено не будет.

Описание:

Событие возникает перед интерактивным проведением документа в списке.

ПередОтменойПроведения ( BeforeUnposting )

Синтаксис:

ПередОтменойПроведения (< Отказ>)

Параметры:

<0тказ>

Тип: Булево Признак отмены проведения документа. Если в теле процедуры-обработчика установить данному параметру значение Истина, то отмена проведения документа выполнена не будет.

Описание:

Событие возникает перед интерактивной отменой проведения документа в списке.

ПередИзменениемДаты ( BeforeDateChange )

Синтаксис:

ПередИзменениемДаты (< Отказ>)

Параметры:

<0тказ>

Тип: Булево. Признак изменения даты и времени документа. Если в теле процедуры-обработчика установить данному параметру значение Истина, то изменение даты документа выполнено не будет.

Описание:

Событие возникает перед изменением даты документа при использовании интерактивной команды смены времени.


Перечисления

Перечисления являются средством для работы с элементами данных, список возможных значений которых жестоко задан в данной прикладной задаче. Ссылки на элементы перечисления могут быть использованы в реквизитах объектов конфигурации.

Например, в конфигурации можно задать перечисление "ВидыКонтраентов", определяющее допустимые виды контрагентов, со значениями "Организация" и "ФизЛицо".

Набор значений перечисления задается при конфигурировании.

ПеречисленияМенеджер ( EnumsManager )

Объект предназначен для управления перечислениями и предоставляет доступ к значениям типа ПеречислениеМенеджер. Доступ к объекту осуществляется через свойство глобального контекста Перечисления.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа ПеречислениеМенеджер. <Имя перечисления>. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции.

Пример:

ВидКонтрагента = Перечисления.ВидыКонтаргентов.Организация;

Свойства

<Имя перечисления>

Использование:

Только чтение.

Описание:

Тип: ПеречислениеМенеджер.<Имя перечислениям Набор свойств содержит менеджеры отдельных перечислений. Имена свойств совпадают с именами перечислений, как они заданы в конфигураторе.

ПеречислениеМенеджер. < Имя перечисления>

Предназначен для получения ссылок на значения перечисления (в том числе пустой ссылки). Доступ к объекту осуществляется через свойство объекта ПеречисленияМенеджер.

Полное имя типа объекта определяется с учетом имени конкретного перечисления конфигурации. Например, для перечисления ВидыКонтаргентов имя типа будет выглядеть Перечисления.ВидыКонтаргентов.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа ПеречислениеСсылка. <Имя перечисления>. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции.

Свойства

<Имя значения>

Использование:

Только чтение.

Описание:

Тип: ПеречислениеСсылка.<Имя перечисления>. Набор свойств содержит значения перечисления. Имена свойств совпадают с именами значений перечислений, как они заданы в конфигураторе.

Методы

ПустаяСсылка ( EmptyRef )

Синтаксис:

ПустаяСсылка()

Возвращаемое значение:

Тип: ПеречислениеСсылка. <Имя перечисления>. Пустая ссылка на значение перечисления.

Описание:

Позволяет получить пустую ссылку на значение данного перечисления.

Пример:

НеизвВидКонтаргемта = Перечисления.ВидыКонтаргентов.ПустаяСсылка();

ПеречислениеСсылка. < Имя перечисления>

Представляет собой ссылку на значение перечисления. Используется для ссылки на значение перечисления в реквизитах объектов информационной базы и переменных встроенного языка.

Методы

Пустая ( IsEmpty )

Синтаксис:

Пустая()

Возвращаемое значение:

Тип: Булево. Истина, если ссылка не указывает ни на какое значение, Ложь, если ссылка указывает на какое-либо значение перечисления.

Описание:

Позволяет определить, является ли ссылка пустой.

Пример:

ВидКонтаргента = Контрагент.Вид;

Если ВидКонтаргента.Пустая() Тогда

Сообщить(" +Контрагент + ". Неизвестный вид контрагента!");

КонецЕсли;

Отчеты

Отчеты используются для получения сводной информации на основании данных, введенных в системе. Обычно отчет содержит алгоритмы получения и обработки информации, формы, при помощи которых организуется интерфейс для ввода параметров алгоритмов и представления результатов их работы, а также макеты, используемые для вывода результатов выполнения алгоритма в табличный документ.

Примером применения отчетов может быть получение сводных данных о хозяйственной деятельности в необходимых для анализа разрезах.

ОтчетыМенеджер ( ReportsManager )

Объект предназначен для управления отчетами и предоставляет доступ к значениям типа ОтчетМенеджер. Доступ к объекту осуществляется через свойство глобального контекста Отчеты.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа ОтчетМенеджер. <Имя отчета>. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции.

Свойства

<Имя отчета>

Использование:

Только чтение.

Описание:

Тип: ОтчетМенеджер. <Имя отчета>. Набор свойств содержит менеджеры отдельных отчетов. Имена свойств совпадают с именами отчетов, как они заданы в конфигураторе.

ОтчетМенеджер. < Имя отчета >

Предназначен для управления отчетом, как объектом конфигурации. С помощью этого объекта можно получить отчет, работать с формами и макетами отчета. Доступ к объекту осуществляется через свойство объекта ОтчетыМенеджер.

Полное имя типа объекта определяется с учетом имени отчета в конфигурации. Например, для отчета Продажи имя типа будет выглядеть ОтчетыМенеджер.Продажи.

Методы

ПолучитьМакет ( GetTemplate )

Синтаксис:

ПолучитьМакет(<Макет>)

Параметры:

<Макет> Обязательный

Тип: Строка, Объект описания метаданного. Имя макета, как оно задано в конфигураторе или объект описания метаданного требуемого макета.

Возвращаемое значение:

Тип: ТабличныйДокумент. Макет отчета.

Описание:

Позволяет получить макет отчета.

Пример:

МакетОтчета = Отчеты.ОстаткиНоменклатуры.ПолучитьМакет("Основной");

ПолучитьФорму ( GetForm )

Синтаксис:

ПолучитьФорму (< Форма>, <Владелец> , <Ключ уникальности>)

Параметры:

<Форма> Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип:Форма.

Описание:

Позволяет получить форму отчета.

Пример:

ФормаОтчета = Отчеты.Продажи.ПолучитьФорму();

Создать ( Create )

Синтаксис:

Создать()

Возвращаемое значение:

Тип: ОтчетОбъект.<Имя отчета>. Объект отчета.

Описание:

Позволяет создать новый экземпляр отчета.

Пример:

ОтчетОстаткиНоменклатуры = Отчеты.ОстаткиНоменклатуры.Создать();

ОтчетОбъект.<Имя отчета >

Представляет собой объект отчета. Используется для доступа к реквизитам и табличным частям, формам и макетам отчета.

Свойства

<Имя реквизита>

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Набор свойств содержит реквизиты отчета. Имена свойств совпадают с именами реквизитов отчета, как они заданы в конфигураторе.

<Имя табличной части>

Использование:

Только чтение.

Описание:

Набор свойств содержит табличные части отчета. Имена свойств совпадают с именами табличных частей отчета, как они заданы в конфигураторе.

ЭтотОбъект ( ThisObject )

Использование:

Только чтение.

Описание:

Тип: ОтчетОбъект. <Имя отчета>. Содержит данный объект отчета. Свойство предназначено для получения объекта в модуле объекта отчета или модуле формы.

Методы

ПолучитьМакет ( GetTemplate )

Синтаксис:

ПолучитьМакет (< Макет>)

Параметры:

<Макет> Обязательный

Тип: Строка, Объект описания метаданного. Имя макета, как оно задано в конфигураторе или объект описания метаданного требуемого макета.

Возвращаемое значение:

Тип: ТабличныйДокумент. Макет отчета.

Описание:

Позволяет получить макет отчета.

Пример:

ОтчетОПродажах = Отчеты.Продажи.Создать();

МакетОтчета = ОтчетОПродажах.ПолучитьМакет ("Продажи") ;

ПолучитьФорму ( GetForm )

Синтаксис:

ПолучитьФорму(< Форма>, <Владелец>, <Ключ уникальности>)

Параметры:

<Форма> Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание:

Позволяет получить форму отчета.

Пример:

ОтчетОПродажах = Отчеты.Продажи.Создать();

ФормаОтчета = ОтчетОПродажах.ПолучитьФорму();

Обработки

Обработки предназначены для реализации различных обработок информации и сервисных функций. Обычно обработка содержит алгоритмы получения и обработки информации, формы, при помощи которых организуется интерфейс для ввода параметров алгоритмов и представления результатов их работы, а также может содержать макеты, используемые для вывода результатов выполнения алгоритма обработки в табличный документ.

Примерами применения обработок могут служить загрузка и выгрузка данных для обмена с другими приложениями, регламентные и контрольные операции над данными информационной базы, групповые обработки документов и справочников, универсальные формы и механизмы, используемые для большого количества объектов конфигурации.

ОбработкиМенеджер ( ProcessingsManager )

Объект предназначен для управления обработками и предоставляет доступ к значениям типа ОбработкаМенеджер. Доступ к объекту осуществляется через свойство глобального контекста Обработки.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа ОбработкаМенеджер. <Имя обработки;». Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции.

См. также:

Глобальный контекст, свойство Обработки.

Свойства

<Имя обработки>

Использование:

Только чтение.

Описание:

Тип: ОбработкаМенеджер. <Имя обработки>. Набор свойств содержит менеджеры отдельных обработок. Имена свойств совпадают с именами обработок, как они заданы в конфигураторе.

ОбработкаМенеджер. <Имя обработки>

Предназначен для управления обработкой, как объектом конфигурации. С помощью этого объекта можно получить обработку, работать с формами и макетами обработки. Доступ к объекту осуществляется через свойство объекта ОбработкиМенеджер.

Полное имя типа объекта определяется с учетом имени обработки в конфигурации. Например, для обработки ОбработкаДокументов имя типа будет выглядеть ОбработкиМенеджер.ОбработкаДокументов.

Методы

ПолучитьМакет ( GetTemplate )

Синтаксис:

ПолучитьМакет(<Макет>)

Параметры:

<Макет> Обязательный

Тип: Строка, Объект описания метаданного. Имя макета, как оно задано в конфигураторе или объект описания метаданного требуемого макета.

Возвращаемое значение:

Тип: ТабличныйДокумент. Макет обработки.

Описание:

Позволяет получить макет обработки.

Пример:

ИдМакета = "ОбработкаДокументов";

МакетОбр = Обработки.ОбработкаДокументов.ПолучитьМакет(ИдМакета);

ПолучитьФорму ( GetForm )

Синтаксис:

ПолучитьФорму(< Форма>, <Владелец>, <Ключ уникальности>)

Параметры:

<Форма> Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание:

Позволяет получить форму обработки.

Пример:

ИдФормы = "ОсновнаяФорма";

ФормаОбр = Обработки. ОбработкаДокументов. ПолучитьФорму( ИдФормы);

Создать ( Create )

Синтаксис:

Создать()

Возвращаемое значение:

Тип: ОбработкаОбъект. <Имя обработки>. Объект обработки.

Описание:

Позволяет создать новый экземпляр обработки.

Пример:

ОбработкаДокументов = Обработки.ОбработкаДокументов.Создать();

ОбработкаОбъект. < Имя обработки >

Представляет собой объект обработки. Используется для доступа к реквизитам и табличным частям, формам и макетам обработки.

Свойства

<Имя реквизита>

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Набор свойств содержит реквизиты обработки. Имена свойств совпадают с именами реквизитов обработки, как они заданы в конфигураторе.

<Имя табличной части>

Использование:

Только чтение.

Описание:

Набор свойств содержит табличные части обработки. Имена свойств совпадают с именами табличных частей, как они заданы в конфигураторе.

ЭтотОбъект ( ThisObject )

Использование:

Только чтение.

Описание:

Тип: ОбработкаОбъект. <Имя обработки>. Содержит данный объект обработки. Свойство предназначено для получения объекта в модуле объекта или модуле формы.

Методы

ПолучитьМакет ( GetTemplate )

Синтаксис:

ПолучитьМакет(<Макет>)

Параметры:

<Макет> Обязательный

Тип: Строка, Объект описания негаданного. Имя макета, как оно задано в конфигураторе или объект описания мета-данного требуемого макета.

Возвращаемое значение:

Тип: ТабличныйДокумент. Макет обработки.

Описание:

Позволяет получить макет обработки.

ПолучитьФорму ( GetForm )

Синтаксис:

ПолучитьФорму (< Форма-», <Владелец>, <Ключ уникальности>)

Параметры:

<Форма> Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание:

Позволяет получить форму обработки.

Внешние обработки

Внешние обработки служат для решения тех же задач, что и объекты типов Отчет и Обработка, но в отличие от них не входят в состав конфигурации, а могут быть сохранены в отдельных файлах.

Примером применения таких объектов могут быть обработки, предоставляющие дополнительные функции, расширяющие основные сервисные функции конфигурации, периодически изменяющиеся формы отчетности (например регламентированной), универсальные обработки, которые могут быть использованы в различных конфигурациях.

МенеджерВнешнихОбработок ( ExternalProcessingsManager )

Объект предназначен для управления внешними обработками и позволяет получать значения типа ВнешняяОбработка при помощи метода Создать. Доступ к объекту осуществляется через свойство глобального контекста ВнешниеОбработки.

Методы

ПолучитьФорму ( GetForm )

Синтаксис:

ПолучитьФорму (< Полное имя файла> , <Имя формы>, <Владелец>, <Ключ уникальности>)

Параметры:

<Полное имя файла> Обязательный

Тип: Строка. Путь к файлу внешней обработки.

<Имя формы> Необязательный

Тип: Строка, Объект описания метаданных. Имя формы, как оно задано в конфигураторе.

Значение по умолчанию: Если параметр не указан, то используется форма, заданная в качестве основной.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

Значение по умолчанию: Неопределено.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована найденная форма.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание:

Позволяет получить форму внешней обработки.

Создать ( Create )

Синтаксис:

Создать(<Полное имя файла>)

Параметры:

<Полное имя файла> Обязательный

Полное имя файла внешней обработки.

Возвращаемое значение:

Тип: ВнешняяОбработка. Объект внешней обработки.

Описание:

Позволяет получить объект внешней обработки по указанному файлу внешней обработки.

ВнешняяОбработка ( ExternalProcessing )

Представляет собой объект внешней обработки. Используется для получения реквизитов и табличных частей внешней обработки, форм и макетов.

Свойства

<Имя реквизита>

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Набор свойств содержит реквизиты внешней обработки. Имена свойств совпадают с именами реквизитов внешней обработки, как они заданы в конфигураторе.

<Имя табличной части>

Использование:

Только чтение.

Описание:

Набор свойств содержит табличные части внешней обработки. Имена свойств совпадают с именами табличных частей, как они заданы в конфигураторе.

Методы

ПолучитьМакет ( GetTempIate )

Синтаксис:

ПолучитьМакет (< Макет>)

Параметры:

<Макет> Обязательный

Тип: Строка, Объект описания метаданного. Имя макета, как оно задано в конфигураторе или объект описания метаданного требуемого макета.

Возвращаемое значение:

Тип: ТабличныйДокумент. Макет внешней обработки.

Описание:

Позволяет получить макет внешней обработки.

Пример:

МакетОбработки = ВнешОбработка. ПолучитьМакет("Шаблон");

ПолучитьФорму ( GetForm )

Синтаксис:

ПолучитьФорму (< Форма>, <Владелец>, <Ключ уникальности> )

Параметры:

<Форма> Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр ие указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда

будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание:

Позволяет получить форму внешней обработки.

Пример:

ФормаОбработки = ВнешОбработка.ПолучитьФорму("ТлавнаяФорма");


Регистры сведений

Основная задача регистра сведений - хранить существенную для прикладной задачи информацию, состав которой развернут по определенной комбинации значений и, при необходимости, развернут во времени. Регистры сведений информация в которых развернута во времени, называются периодическими.

Например, если мы хотим хранить информацию о цена конкурентов на продаваемые нами товары, то собранная информация о ценах разворачивается по товарам и конкурентам. А если мы хотим отслеживать динамику изменений цен, и будем заносить их периодически, то хранимая информация разворачивается также и во времени.

Регистр сведений, фактически, представляет собой массив данных, необходимый, чтобы реализовать функцию, которая может выдать необходимую информацию по определенному набору аргументов. Аргументы функции называются измерениями, а результат функции - ресурсами. В приведенном выше примере регистр "ЦеныКонкурентов" будет содержать измерения "Конкурент" и "Товар", и ресурс "Цена". Ресурсов может быть больше чем один: например, можно хранить оптовую и розничную цены.

Для разворота этой информации во времени используется поле "Период" регистра. Оно не вносится в качестве измерения, а добавляется системой автоматически при создании периодического регистра.

Для периодических регистров сведений система поддерживает такие стандартные операции, как получение наиболее позднего или наиболее раннего значения по определенной комбинации измерений (например, получение последней введенной цены по конкретному товару и конкретному конкуренту), а также получения среза наиболее поздних или ранних значений. Например, могут быть получены все последние введенные цены по различным товарам и конкурентам.

Если регистр не периодический, то поле "Период" для него не создается. В приведенном примере регистр "ЦеныКонкурентов" может быть непериодическим, если мы не хотим хранить историю изменения цен, а хотим иметь только актуальные цены. Тогда функция регистра сможет ответить на вопрос "какая сейчас цена у такого-то конкурента на такой-то товар", но не сможет ответить на вопрос "какая была цена у такого-то конкурента на такой-то товар в начале года".

Из описанных принципов работы регистра сведений вытекает то, что в системе может быть только одна запись с определенным набором и периодом измерений. Действительно, по одному товару по одному конкуренту может быть только одна цена. Если по какой-либо причине мы можем получить несколько цен и хотим занести эту информацию в базу данных, то нам нужно создать еще одно измерение для хранения того значения, по которому эти цены могут различаться. Например, можно завести измерение "ИсточникИнформации". Тогда можно будет вводить цены конкурентов в разрезе источников.

Уникальность записей по набору измерений принципиально отличает регистры сведений от регистров накоплений, которые позволяют вводить несколько записей с одинаковым значением измерений и периодом.

Строки регистра сведений, содержащие информацию о значениях ресурсов для определенных значений измерений и конкретного периода, называются записями. Записи в регистр сведений можно вносить двумя способами: вручную или документами.

Эти два варианта влияют на способ внесения информации, а не на основную логику работы регистра.

Документ, которым вносится запись в регистр сведений, называется регистратором.

Регистры, записываемые независимо, могут свободно редактироваться вручную или средствами встроенного языка. При этом если измерение такого регистра назначено как "ведущее" и значением измерения является ссылка на объект базы данных, то будет считаться, что запись регистра имеет смысл, только пока существует этот объект. Например, если назначить ведущим измерение "Конкурент", то считается, что запись имеет смысл только как информация по данному конкуренту. Соответственно, при удалении конкурента записи по нему будут удалены автоматически.

Если регистр записывается регистратором, то это значит, что записи будут жестко подчинены регистраторам - документам. Обычно это значит, что записи будут порождаться при проведении документов. Соответственно, при удалении документа записи будут удаляться автоматически. В отличие от ведущих измерений, регистратор может быть только один.

В программных модулях для общих действий над регистром сведений (поиск, выбор и создание записей регистра) служит объект РегистрСведенийМенеджер. Для чтения, записи и удаления отдельных записей регистра сведений, не управляемого регистраторами, служит объект РегистрСведенийМенеджерЗаписи. Для считывания и занесения набора записей в информационную базу по определенному условию отбора служит объект РегистрСведенийНаборЗаписей. Для динамического обхода записей регистра служит объект РегистрСведенийВыборка.

РегистрыСведенийМенеджер ( InformationRegistersManager )

Объект предназначен для управления регистрами сведений и предоставляет доступ к значениям типа РегистрСведенийМенеджер. Доступ к объекту осуществляется через свойство глобального контекста РегистрыСведе-ний.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа РегистрСведенийМенеджер.<Имя регистра сведений>. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции.

Пример:

// менеджер регистров сведений предоставляет доступ к менеджеру

// конкретного регистра (Курсы валет).

Форма = РегистрыСведений.КурсыВалот.ПолучитьФормуСписка();

Форма.Открыть();

Свойства

<Имя регистра сведений>

Использование:

Только чтение.

Описание:

Тип: РегистрСведенийМенеджер.<Имя регистра сведений>. Набор свойств содержит менеджеры отдельных регистров сведений. Имена свойств совпадают с именами регистров сведений, как они заданы в конфигураторе.

РегистрСведенийМенеджер.<Имя регистра сведений>(InformationRegisterManager.<Имя регистра сведений>)

Предназначен для управления данными конкретного регистра сведений. Позволяет осуществлять поиск, выбирать и создавать записи регистра сведений.

Методы

Выбрать ( Select )

Вариант синтаксиса: Для периодического регистра

Синтаксис;

Выбрать{<Начало интервала> , <Конец интервала> , <Отбор>)

Параметры:

<Начало интервала» Необязательный

Тип: Дата, МоментВремени или Граница. Начало интервала, за который будут выдаваться записи периодического регистра сведений. Если не указан, то будут выдаваться записи с самого ранней включительно.

Значение по умолчанию: Неопределено.

<Конец интервала> Необязательный

Тип: Дата, МоментВремени или Граница. Конец интервала, за который будут выдаваться записи периодического регистра сведений. Если не указан, то будут выдаваться записи до самой поздней включительно.

Значение по умолчанию: Неопределено. Описание

<Отбор> Необязательный

Тип: Структура. Задает поле и значение отбора открываемой выборки. Ключ структуры описывает имя поля, а значение структуры - значение отбора по этому полю. В качестве полей для отбора могут задаваться измерения, для которых в конфигураторе признак индексирования установлен в значение "Индексировать" или установлен признак "Ведущее".

Важно! Структура может содержать только один элемент.

Значение по умолчанию: Неопределено.

Вариант синтаксиса: Для непериодического регистра Синтаксис:

Выбрать(< Отбор>)

Параметры:

<0тбор> Необязательный

Тип: Структура. Задает поле и значение отбора открываемой выборки. Ключ структуры описывает имя поля, а значение структуры - значение отбора по этому полю. В качестве полей для отбора могут задаваться измерения, для которых в конфигураторе признак индексирования установлен в значение "Индексировать" или установлен признак "Ведущее".

Важно! Структура может содержать только один элемент. Значение по умолчанию: Неопределено.

Возвращаемое значение:

Тип: РегистрCведенийВыборка.<Имя регистра сведений>. Сформированная выборка записей регистра сведений.

Описание:

Позволяет сформировать выборку записей регистра сведений.

Пример:

Курсы = РегистрыСведений.КурсыВалют;

ОтборВалют = Новый Структура("Валюта");

ОтборВалют.Валюта = ВыбВалюта;

ВыборкаКурсовВалют = Курсы.Выбрать(,,ОтборВалот);

Пока ВыборкаКурсовВалот.Следующий() Цикл

Сообщить("Дата " + ВыборкаКурсовВалот.Период *

" Валюта "+СокрЛП(ВыборкаКурсовВалст.Валюта) +

", Курс "+ ВыборкаКурсовВалют.Курс );

КонецЦикла;

ВыбратьПоРегистратору ( SelectByRecorder )

Синтаксис:

ВыбратьПоРегистратору (< Регистратор>)

Параметры:

<Регистратор> Обязательный

Тип: ДокументСсылка. <Имя документа>. Ссылка на документ, являющийся регистратором для записей регистра.

Возвращаемое значение:

Тип: РегистрСведенийВыборка.<Имя регистра сведений>. Сформированная выборка записей регистра сведений.

Описание:

Позволяет получить выборку по регистратору записей регистра сведений. Применяется для регистров сведений, для которых в конфигураторе установлен режим записи "Подчинение регистратору".

Пример:

ВыборкаЦен = РегистрыСведений.МаркетингЦен.ВыбратьПоРегистратору(ВыбРегистратор);

Пока ВыборкаПев.Следующий() Цикл

Сообщить("Дата " + ВыборкаЦен. Регистратор. ДатаДокумента *

" Номенклатура "+СокрЛП(ВыборкаЦен.Номенклатура) +

", Конкурент "+ ВыборкаЦен.Конкурент );

КонецЦикла ;

Получить ( Get )

Вариант синтаксиса: Для периодического регистра

Синтаксис:

Получить(<Период>, <Измерение 1>, ..., <ИзмерениеN >)

Параметры:

<Период> Обязательный

Тип: Дата, МоментВремени. Определяет момент времени, на который необходимо получить значения ресурсов. Если указанный момент времени не совпадает с периодом ни одной записи регистра, то будет возвращена структура, содержащая пустые значения.

<Измерение 1>, ..., <Измерение N > Необязательный

Тип: Произвольный. Набор параметров, который определяет перечень значений измерений, по которым должен выполняться поиск. Порядок параметров должен соответствовать порядку измерений регистра как он задан в конфигураторе. Измерения могут задаваться с пропусками. Не указанное значение просто запятая. Фиксируются только указанные измерения.

Вариант синтаксиса: Для непериодического регистра Синтаксис:

Получить(< Измерение 1>, ..., <Измерение N >)

Параметры:

<Измерение 1>, . . ., <Измерение N > Необязательный

Тип: Произвольный. Набор параметров, который определяет перечень значений измерений, по которым должен выполняться поиск. Порядок параметров должен соответствовать порядку измерений регистра как он задан в конфигураторе. Измерения могут задаваться с пропусками. Не указанное значение просто запятая. Фиксируются только указанные измерения.

Возвращаемое значение:

Тип: Структура. Структура, содержащая значения ресурсов.

Описание:

Позволяет получить значения ресурсов записи регистра, соответствующей указанным значениям измерений регистра и периоду (для периодических регистров).

ПолучитьМакет ( GetTemplate )

Синтаксис;

ПолучитьМакет(< Макет>)

Параметры:

<Макет> Обязательный

Тип:Строка, Объект описания метаданного. Имя макета, как оно задано в конфигураторе или объект описания метаданного требуемого макета.

Возвращаемое значение:

Тип: ТабличныйДокумент. Созданный макет.

Описание:

Позволяет получить макет регистра сведений.

Пример:

Таб = СоздатьОбъект("ТабличныйДокумент");

Макет = РегистрыСведений.КурсыВалют.ПолучитьМакет("ТаблицаКурсов");

Таб.Вывести(Макет.ПолучитьОбласть("Шапка"));

Таб.Показать();

ПолучитьПервое ( GetFirst )

Синтаксис:

ПолучитьПервое (< Начало периодам, <Измерение 1> , ..., <Измерение N > )

Параметры:

<Начало периода > Необязательный

Тип: Дата, МоментВремени или Граница. Определяет момент времени, начиная с которого необходимо получить значения ресурсов. Если параметр не указан, то будут возвращены значения ресурсов самой первой записи регистра.

Значение по умолчанию: Неопредепено.

<Измерение 1>, . . - , <Измерение N > Необязательный

Тип: Произвольный. Набор параметров, который определяет перечень значений измерений, по которым должен выполняться поиск. Порядок параметров должен соответствовать порядку измерений регистра как он задан в конфигураторе. Измерения могут задаваться с пропусками. Не указанное значение просто запятая. Фиксируются только указанные измерения.

Возвращаемое значение:

Тип: Структура. Возвращает структуру, содержащую значения ресурсов.

Описание:

Позволяет получить значения ресурсов наиболее ранней записи регистра, соответствующей указанным периоду и значениям измерений регистра. Метод применим только для периодических регистров сведений. Поиск по периоду осуществляется "включительно", т.е. если существует запись с таким же значением одноименного свойства, то она и будет найдена.

Пример:

МаркетингЦен = РегистрыСведений.МаркетингЦен;

Цена = МаркетингЦен.ПолучитьПервое(ВыбДата, ВыбКлиент, ВыбТовар).Цена;

ПолучитьПоследнее ( GetLast )

Синтаксис:

ПолучитьПоследнее (< Конец периода> , <Измерение 1>, ..., <Измерение N > )

Параметры;

<Конец периода > Необязательный

Тип: Дата, МоментВремени или Граница. Определяет момент времени, по который необходимо получить значения ресурсов. Если параметр не указан, то будут возвращены значения ресурсов самой последней записи регистра.

Значение по умолчанию: Неопределено.

<Измерение 1>, . . . , <Измере ние N > Необязательный

Тип: Произвольный. Набор параметров, который определяет перечень значений измерений, по которым должен выполняться поиск. Порядок параметров должен соответствовать порядку измерений регистра как он задан в конфигураторе. Измерения могут задаваться с пропусками. Не указанное значение просто запятая. Фиксируются только указанные измерения.

Возвращаемое значение:

Тип: Структура. Возвращает структуру, содержащую значения ресурсов.

Описание:

Позволяет получить значения ресурсов наиболее поздней записи регистра, соответствующей указанным периоду и значениям измерений регистра. Метод применим только для периодических регистров сведений.

Пример:

Доллары = Справочники.Валюты.НайтиПоНаименованио("USD");

Курсы = РегистрыСведений.КурсыВалют;

ТекКурс = Курсы.ПолучитьПоследнее(ТекущаяДата(), Доллары);

Сообщить("Текущий курс доллара: " + ТекКурс.Курс + " руб.");

ПолучитьФорму ( GetForm )

Синтаксис:

ПолучитьФорму (< Форма>, <Владелец>, <Ключ уникальности> )

Параметры:

<Форма> Обязательный

Тип: Строка. Имя формы, как оно задано в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание:

Позволяет получить форму регистра сведений.

Пример:

КурсыВалют = РегистрыСведений.КурсыВалют;

ФормаВалют = КурсыВалют.ПоялчитьФорму("ФормаСписка");

ФормаВалют.Открыть();

ПолучитьФормуРедактированияЗаписи ( GetRecordEditingForm )

Синтаксис:

ПолучитьФормуРедактированияЗаписи(< Форма>, <Владелец>, <Ключ уникальности>)

Параметры:

<Форма> Необязательный

Тип. Строка, Объект описания метаданного Имя формы, как оно задано в конфигураторе или объект описания ме-тадаиного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип Форма Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип' Произвольный В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию. Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип Форма.

Описание:

Позволяет получить форму редактирования записи регистра сведений

Пример:

РегистрыСведений.КурсыВалют.ПолучитьФормуСписка().Открыть();

ПолучитьФормуСписка ( GetFormList )

Синтаксис:

ПолучитьФормуСписка (< Форма> , <Владелец> , <Ключ уникальности>)

Параметры:

<Форма> Необязательный

Тип Строка, Объект описания метаданного Имя форты, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию- Если параметр не указан, то используется основная форма, заданная в конфигураторе

<Владелец> Необязательный

Тип Форма. Форма, которая будет являться владельцем открываемой формы

<Ключ уникальности> Необязательный

Тип Произвольный В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она

Значение по умолчанию Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип Форма.

Описание:

Позволяет получить форму списка регистра сведений.

Пример:

РегмстрыСвеяений.КурсыВалют.ПолучитьФормуСписка().Открыть();

СоздатьКлючЗаписи ( CreateRecordKey )

Синтаксис:

СоздатьКлючЗаписи (< Значения ключа> )

Параметры:

<3начения клоча> Обязательный

Тип: Структура. Структура, содержащая значения для заполнения свойств ключа записи.

Имена элементов структуры должны соответствовать именам ключевых полей.

Возвращаемое значение:

Тип: РегистрСведенийКлючЗаписи.<Имя регистра сведений>. Созданный ключ записи.

Описание:

Позволяет создать ключ записи по переданной структуре.

СоздатьМенеджерЗаписи ( CreateRecordManager )

Синтаксис:

СоздатьМенеджерЗаписи()

Возвращаемое значение:

Тип: РегистрСведенийМенеджерЗаписи.<Имя регистра сведений>. Созданный менеджер записи регистра сведений.

Описание:

Создает объект для управления записью регистра сведений.

Пример:

РегистрыСведений.КурсыВалют.СоздатьМенеджерЗаписи();

СоздатьНаборЗаписей ( CreateRecordSet )

Синтаксис:

СоздатьНаборЗаписей()

Возвращаемое значение:

Тип: РегистрСведенийНаборЗаписей.<Имя регистра сведений>. Созданный набор записей.

Описание:

Позволяет создать набор записей регистра сведений. Набор записей создается пустым.

Пример:

КурсыВалют = РегистрыСведений.КурсыВалют;

НаборКурсов = КурсыВалют.СоздатьНаборЗаписей();

СрезПервых ( SliceFirst )

Синтаксис:

СрезПервых(<Начало периода>, <Отбор>)

Параметры:

<Начало периода> Необязательный

Тип: Дата, МоментВремени или Граница. Определяет момент времени, начиная с которого необходимо выбрать записи.

Значение по умолчанию: Неопределено.

<Отбор>Необязательный

Тип: Структура. Структура, содержащая отбор по измерениям регистра.

В переданной структуре должны содержаться те измерения, по которым должны быть отфильтрованы записи. В элементе структуры задается имя и значение отбора.

Значение по умолчанию: Неопределено.

Возвращаемое значение:

Тип: ТаблицаЗначений. Таблица значений, заполненная данными найденных записей регистра сведений.

Описание:

Позволяет получить наиболее ранние записи регистра, соответствующие установленным в параметрах метода значениям ключевых полей. Записи подбираются для каждого сочетания из всех имеющихся значений измерений регистра. Метод применим только для периодических регистров сведений.

Пример:

МаркетингЦен = РегистрыСведений.МаркетингЦен;

ОбновленныеСегодняЦены = МаркетингЦен.СрезПервых(ТекущаяДата());

СрезПоследних ( SliceLast )

Синтаксис:

СрезПоследних{<Конец периода> , <Отбор>)

Параметры:

< Конец периода > Необязательный

Тип. Дата, МоментВремени или Граница. Определяет момент времени, заканчивая которым необходимо выбрать записи.

Значение по умолчанию: Неопределено.

<Отбор> Необязательный

Тип: Структура. Структура, содержащая отбор по измерениям регистра.

В переданной структуре должны содержаться те измерения, по которым должны быть отфильтрованы записи. В элементе структуры задается имя и значение отбора.

Значение по умолчанию: Неопределено. Описание

Возвращаемое значение:

Тип: ТаблицаЗначений. Таблица значений, заполненная данными найденных записей регистра сведений.

Описание:

Позволяет получить наиболее поздние записи регистра, соответствующие установленным в параметрах метода значениям ключевых полей. Записи подбираются для каждого сочетания из всех имеющихся значений измерений регистра. Метод применим только для периодических регистров сведений.

Пример:

МаркетингЦен = РегистрыСведений МаркетингЦен ;

ТекущиеЦеныКонкурентов = МаркетингЦен.СрезПоследних(ТекущаяДата());

РегистрСведенийВыборка.<Имя регистра сведений > ( InformationRegisterSelection .< Имя регистра сведений >)

Объект этого типа возвращается методами Выбрать и ВыбратьПоРегистратору у объекта типа РегистрСведенийМенеджер и представляет собой специализированный способ перебора записей регистра сведений.

Обход записей выполняется системой динамически. Это означает, что использование выборки не считывает все записи сразу, а выбирает их порциями из информационной базы Такой подход позволяет достаточно быстро обходить с помощью выборки большое количество записей и не загружает в память всех элементов выборки.

Свойства

<Имя измерения>

Использование:

Только чтение.

Описание:

Набор свойств содержит значения измерений регистра сведений. Имена свойств совпадают с именами измерений, как они заданы в конфигураторе.

<Имя реквизита>

Использование:

Только чтение.

Описание:

Набор свойств содержит значения реквизитов регистра сведения. Имена свойств совпадают с именами реквизитов, как они заданы

в конфигураторе.

<Имя ресурса>

Использование:

Только чтение.

Описание:

Набор свойств содержит значения ресурсов регистра сведений. Имена свойств совпадают с именами ресурсов, как они заданы в конфигураторе.

Активность ( Active )

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит признак активности записи. Используется для регистров сведений, для которых в конфигураторе установлен режим записи "Подчинение регистратору".

Примечание:

Записи, для которых значение данного свойства установлено в Ложь, не будут учитываться при получении сведений на определенный момент времени

См. также:

РегистрСведенийНаборЗаписей.<Имя регистра сведений>, метод УстановитьАктивность.

НомерСтроки ( LineNumber )

Использование:

Только чтение.

Описание:

Тип: Число. Содержит уникальный номер строки данной записи в списке записей по регистратору, указанному в значении свойства Регистратор. Используется для регистров, управляемых регистратором.

Период ( Period )

Использование:

Только чтение.

Описание:

Тип: Дата. Содержит дату и время записи периодического регистра сведений.

Примечание:

Для непериодических регистров сведений смысла не имеет.

Регистратор ( Recorder )

Использование:

Только чтение.

Описание:

Тип: ДокументСсылка. <Имя документа>. Содержит регистратор, который занес данную запись регистра сведений.

Примечание:

Для регистра, у которого в конфигураторе установлен режим записи "Независимый", смысла не имеет.

Методы

ПолучитьМенеджерЗаписи(GetRecorderManager)

Синтаксис:

ПолучитьМенеджерЗаписи()

Возвращаемое значение:

Тип: РегистрСведенийМенеджерЗаписи.<Имя регистра сведений>. Менеджер записи регистра сведений.

Описание:

Позволяет получить объект для модификации, записи и удаления записи регистра сведений, на которой в данный момент спозиционирована выборка.

Следующий ( Next )

Синтаксис:

Следующий()

Возвращаемое значение:

Тип: Булево. Истина - запись выбрана.

достигнут конец выборки.

Описание:

Выполняет получение очередной записи выборки. Для обхода записей регистра нужно после получения выборки вызвать данный метод для позиционирования на первую запись и далее вызывать до тех пор, пока не будет возвращено значение Ложь.

Пример:

// найдем максимальную цену у конкурентов на товар ВыбТовар

МаркетингЦен = РегистрыСведений.МаркетингЦен;

ОтборПоТовару = Новый Структура("Номенклатура");

ОтборПоТовару.Номенклатура = ВыбТовар;

ЦеныТовара = МаркетингЦен.Выбрать(,,ОтборПоТовару);

МаксЦена = 3;

Конкурент = "Не найден";

Пока ЦеныТовара.Следующий() Цикл

Если ЦеныТовара.Цена > МаксЦена Тогда МаксЦена = ЦеныТовара.Цена;

Конкурент = ЦеныТовара.Конкурент;

КонецЕсли;

КонецЦикла;

Предупреждение("Максимальня цена " + СокрЛП(ВыбТовар) + " = " + МаксЦена + " руб. у " + СокрЛП (Конкурент) + ".");

РегистрСведенийСписок.<Имя регистра сведений>( InformationRegisterList .< Имя регистра сведений>)

Объект предназначен для управления списком записей регистра сведений, отображаемым в табличном поле.

Свойства

Колонки ( Columns )

Использование:

Только чтение.

Описание:

Тип: Колонки списка. Содержит объект для управления колонками списка. Набор колонок составляется из полей регистра.

Отбор ( Filter )

Использование;

Только чтение.

Описание:

Тип: Отбор. Содержит объект Отбор, по которому осуществляется текущая фильтрация записей регистра в списке. В качестве свойств объекта могут выступать поля регистра накопления. Имена свойств совпадают с именами полей регистра.

Примечание:

Отбор возможен по значениям измерений, периоду (для периодических регистров), регистратору (для регистров, управляемых регистраторами), номеру строки (для регистров, управляемых регистраторами).

Порядок ( Order )

Использование:

Чтение и запись.

Описание:

Тип: Порядок. Содержит объект Порядок, по которому осуществляется текущее упорядочивание записей регистра в списке. В качестве свойств объекта могут выступать измерения, ресурсы и реквизиты регистра, а также предопределенные поля: для регистров, управляемых регистраторами - Регистратор . НомерСтроки , Активность; для периодических регистров -Период. Имена свойств совпадают с именами полей.

Методы

Обновить ( Refresh )

Синтаксис:

Обновить()

Описание:

Вызывает перечитывание данных списка.

РегистрСведенийМенеджерЗаписи.<Имя регистра сведений> ( InformationRegisterRecordManager .< Имя регистра сведений>)

Позволяет читать, записывать и удалять отдельную запись регистра сведений. Используется только для регистров сведений, неизменяемых регистраторами, т.е. для которых в конфигураторе установлен режим записи "Независимый".

Пример:

Курс = РегистрыСведений.КурсыВалют.СоздатьМенеджерЗаписи();

Курс.Валюта = ВыбВалюта ;

Курс.Период = ТекущаяДата();

Курс.Прочитать() ;

Если Не Курс.Выбран() Тогда

Курс.Период = ТекущаяДата() ;

Курс.Валюта = ВыбВалюта;

Курс.Курс = 41.35;

Курс.Кратность = 1;

КонецЕсли;

Если ВвестиЧисло(Курс.Курс, "Введите курс на сегодня",15,5) Тогда Курс.Записать() ;

КонецЕсли;

Свойства

<Имя измерения>

Использование:

Чтение и запись.

Описание:

Набор свойств содержит значения измерений регистра сведений. Имена свойств совпадают с именами измерений, как они заданы в

конфигураторе.

<Имя реквизита>

Использование:

Чтение и запись.

Описание:

Набор свойств содержит значения реквизитов регистра сведения. Имена свойств совпадают с именами реквизитов, как они заданы в конфигураторе.

<Имя ресурса>

Использование:

Чтение и запись.

Описание:

Набор свойств содержит значения ресурсов регистра сведений. Имена свойств совпадают с именами ресурсов, как они заданы в конфигураторе.

Период ( Period )

Использование:

Чтение и запись.

Описание:

Тип: Дата. Содержит дату и время записи периодического регистра сведений.

Примечание:

Для непериодических регистров сведений смысла не имеет.

Методы

Выбран ( Selected )

Синтаксис:

Выбран()

Возвращаемое значение:

Истина - если запись считана, Ложь - запись не считана.

Описание:

Позьоляет определить, считана запись или нет.

Пример:

Если Не Курс.Выбран() Тогда

Предупреждение("Курс не считан");

КонецЕсли;

Записать ( Write )

Синтаксис:

Записать (<3амещать>)

Параметры:

<3амещать> Необязательный

Тип: Булево. Позволяет установить или отключить режим замещения существующей записи с тем же набором значений измерений регистра и с тем же периодом (для периодических регистров). Если значение Истина: если запись регистра сведений с таким набором существует, то выполняется замещение. Если значение Ложь: замещение не выполняется, если запись с таким набором существует, то выдается сообщение об ошибке.

Значение по умолчанию: Истина.

Описание:

Позволяет занести в информационную базу запись регистра сведений с текущими значениями свойств. Если запись регистра сведений была предварительно считана из информационной базы, то при выполнении метода считанная запись удаляется. С помощью параметра Замещать регулируется, будет ли метод замещать запись, если в момент выполнения метода существует другая (исключая считанную) запись с такими же значениями измерений регистра и с таким же периодом для периодических регистров.

Пример:

Курс. Записать(1) ;

Модифицированность ( Modified )

Синтаксис:

Модифицированность()

Возвращаемое значение:

Тип: Булево. Истина - изменен. Ложь - не изменен.

Описание:

Позволяет определить, изменен ли объект по отношению к считанным значениям.

Примечание:

Метод не позволяет определить, была ли изменена соответствующая запись в регистре другими пользователями.

Пример:

Если Курс.Модифицированность() Тогда

Курс.Записать();

КонецЕсли;

ПолучитьФорму ( GetForm )

Синтаксис:

ПолучитьФорму(< Форма>, <Владелец>, <Ключ уникальности>)

Параметры:

<форма> Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание:

Позволяет получить форму записи регистр -ведений.

Пример:

Курс.ПолучитьФорму().Открыть() ;

Прочитать ( Read )

Синтаксис:

Прочитать()

Описание:

Считывает запись регистра сведений по установленным значениям ключевых полей.

Пример:

Курс.Прочитать()

Удалить ( Delete )

Синтаксис:

Удалить()

Описание:

Позволяет удалить запись с установленными значениями ключевых полей.

Пример:

Курс.Удалить();


РегистрСведенийНаборЗаписей

РегистрСведенийНаборЗаписей.<Имя регистра сведений > ( InformationRegisterRecordSet < Имя регистра сведений>)

Представляет собой коллекцию записей регистра сведений. Позволяет выполнять считывание записей по определенному условию отбора из информационной базы, добавлять, удалять и модифицировать записи в наборе. Также может быть выполнена запись в информационную базу по определенному условию. При записи может выполняться замещение всех имеющихся в информационной базе записей по данному условию на записи, содержащиеся в наборе.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа РегистрСведенийЗапись.<Имя регистра сведений>. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции. Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс записи.

Пример:

КурсыВалют = РегистрыСведений.КурсыВалют;

НаборКурсов = КурсыВалют.СоздатьНаборЗалисей();

Доллар = Справочники.Валюты.НайтиПоНаименованию("USD");

НаборКурсов.Отбор.Валюта.Установить(Доллар);

НаборКурсов.Отбор.Период.Установить(НачалоДня(ТекуцаяДата());

НаборКурсов.Прочитать() ;

Если НаборКурсов.Количество() = 0 Тогда

НовыйКурс = НаборКурсов.Добавить();

НовыйКурс.Валюта = Доллар;

НовыйКурс.Период = ТекущаяДата();

ИначеЕсли НаборКурсов. Количество()=1 Тогда

НовыйКурс = НаборКурсов[0] ;

Иначе

Предупреждение("Курс валюты задается один раз в день.", 60);

Возврат;

КонецЕсли;

НовыйКурс.Курс = 31.44;

НовыйКурс. Кратность =1;

НаборКурсов.Записать() ;

Сообщить("Курс " + СокрЛП(НовыйКурс.Валюта) + " на сегодня: " + НовыйКурс.Курс +" руб.");

Свойства

Отбор ( Filter )

Использование;

Только чтение.

Описание:

Тип: Отбор. Содержит объект Отбор, по которому осуществляется текущая фильтрация записей при считывании или записи набора. Список свойств объекта зависит от свойств регистра: для регистров сведений, для которых в конфигураторе установлен режим записи "Подчинение регистратору", отбор возможен только по регистратору, для периодических регистров сведений отбор возможен по периоду и значениям измерений, для непериодических - только по значению измерений.

Важно! Отбор может устанавливаться только на равенство.

Методы

Вставить ( Insert )

Синтаксис:

Вставить{<Индекс>)

Параметры:

<Индекс> Обязательный

Тип: Число. Индекс позиции, на которую надо вставить новую запись.

Возвращаемое значение:

Тип: РегистрСведенийЗапись.<Имя регистра сведений>. Созданная запись регистра.

Описание:

Позволяет вставить новую запись в набор на указанную позицию.

Важно! Метод доступен только для набора записей регистра сведений, в котором записи подчинены регистратору.

Пример:

НоваяЦена = НаборЦенКонкурентов.Вставить(0);

Выбран ( Selected )

Синтаксис:

Выбран()

Возвращаемое значение:

Тип: Булево. Истина, если не изменялся.

Ложь, если изменялся. В частности, если набор не считывался и не записывался, а также если записывался с добавлением записей.

Описание:

Позволяет определить считан ли набор записей.

Примечание:

При изменении отбора считается, что набор перестает быть считанным.

Пример:

Если Не НаборКурсов.Выбран() Тогда НаборКурсов.Прочитать() ;

КонеиЕсли;

Выгрузить ( Unload )

Синтаксис:

Выгрузить()

Возвращаемое значение:

Тип: ТаблицаЗначений. Созданная таблица значений.

Описание:

Позволяет скопировать в таблицу значений все записи набора. Структура полученной таблицы совпадает со структурой набора записей.

Пример:

ТаблицаКурсов = НаборКурсов.Выгрузить();

ВыгрузитьКолонку( UnloadColumn )

Синтаксис:

ВыгрузитьКолонку(<Имя поля>)

Параметры:

<Имя поля> Обязательный

Тип: Строка. Имя поля записей набора, значения из которого будут выгружены в массив.

Возвращаемое значение:

Тип: Массив. Сформированный массив значений.

Описание:

Позволяет выгрузить значения заданного поля у записей набора в массив значений. Значения записей выгружаются в элементы массива, имеющие тот же индекс.

Пример:

МассивКурсов = НаборКурсов.ВыгрузитьКолонку("Курс");

Добавить ( Add )

Синтаксис:

Добавить()

Возвращаемое значение:

Тип: РегистрСведенийЗапись.<Имя регистра сведений>. Запись регистра сведений, помещенная в набор.

Описание:

Позволяет создать новую запись в наборе.

Пример:

НовыйКурс = НаборКурсов.Добавить();

Загрузить( Load )

Синтаксис:

Загрузить(<Таблица значений>)

Параметры:

<Таблица значений> Обязательный

Тип: ТаблицаЗначений. Таблица значений, по которой производится заполнение набора записей.

Описание:

Очищает набор записей и заполняет его значениями из переданной таблицы значений. Заполняются значения у колонок, имена которых совпали.

Пример:

НаборКурсов.Загрузить(ТаблКурсов) ;

ЗагрузитьКолонку ( LoadColumn )

Синтаксис:

ЗагрузитьКолонку (<Массив>, <Имя поля>)

Параметры:

<Массив> Обязательный

Тип: Массив. Массив, содержащий значения для заполнения колонки набора.

<Имя поля> Обязательный

Тип: Строка. Имя поля записей набора, в которое будут загружаться значения из массива.

Описание:

Позволяет заполнить заданное поле у записей набора значениями, взятыми из массива. Значения записей заполняются из элементов массива, имеющих тот же индекс.

Пример:

НаборКурсов.ЗагрузитьКолонку(МассивКурсов, "Курс");

Записать ( Write )

Синтаксис:

Записать (< 3амещать> )

Параметры:

<3амещать> Необязательный

Тип: Булево. Замещать записи по установленному отбору. Если значение параметра Истина, то перед записью существующие записи будут удалены.

Значение по умолчанию: Истина.

Описание:

Позволяет записать набор записей в информационную базу. В зависимости от переданного параметра, может быть выполнено добавление записей или их замещение. Если указано замещение, то перед выполнением записи будет выполнено удаление существующих записей в соответствии с текущими установками отбора, если данный параметр установлен в Ложь, то запись будет выполнена только в случае отсутствия в информационной базе других записей с такими же значениями измерений и периодом (для периодических регистров). Если для регистра сведений, подчиненного регистратору, выполняется добавление записей, то после выполнения записи набор очищается.

Пример:

НаборКурсов.Записать();

Индекс ( IndexOf )

Синтаксис:

Индекс(< Запись>)

Параметры:

<3апись> Обязательный

Тип: РегистрСведенийЗапись.<Имя регистра сведений>. Запись набора, для которой необходимо получить индекс.

Возвращаемое значение:

Тип: Число. Индекс записи в наборе.

Описание:

Позволяет определить индекс записи в наборе.

Пример:

Если НовыйКурс. Индекс() =0 Тогда

Сообщить("Это первая запись о курсе в наборе.");

КонецЕсли ;

Итог ( Total )

Синтаксис:

Итог(<Имя поля>)

Параметры:

<Имя поля> Обязательный

Тип: Строка. Имя поля записей набора, по которому необходимо подсчитать итог.

Возвращаемое значение:

Тип: Число. Числовое значения результата вычисления.

Описание:

Позволяет вычислить итог по одному из полей набора.

Пример:

СреднийКурс = НаборКурсов.Итог("Курс") / НаборКурсов.Количество();

Сообщить("Средний курс " + СреднийКурс);

Количество ( Count )

Синтаксис:

Количество()

Возвращаемое значение:

Тип- Число. Количество записей в наборе.

Описание:

Позволяет получить количество записей в наборе.

Пример:

Для Сч = 0 По НаборКурсов. Количество () -1 Цикл

ДатаКурса = НаборКурсов(Сч].Период;

ТекКурс = НаборКурсов[Сч]-Курс;

Сообщить ("Курс на " + ДатаКурса + " - "+ ТекКурс + " руб.");

КонецЦикла;

Модифицированность ( Modified )

Синтаксис:

Модифицированность()

Возвращаемое значение:

Тип: Булево. Истина - записи изменены.

Ложь - записи не изменены.

Описание:

Позволяет определить, были ли изменены элементы данной коллекции после считывания или записи набора.

Примечание:

Метод не позволяет определить, были ли изменены соответствующие записи в регистре другими пользователями.

Пример:

Если НаборКурсов.Модифицированность () Тогда НаборКурсов.Записать();

КонецЕсли;

Очистить ( Clear )

Синтаксис:

Очистить()

Описание;

Позволяет удалить все записи из набора.

Пример:

НаборКурсов.Очистить();

ПолучитьФорму ( GetForm )

Синтаксис:

ПолучитьФорму (< Форма>, <Владелец> , <Ключ уникальности>)

Параметры:

<Форма> Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет акта визирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание:

Позволяет получить форму набора записей регистра сведений.

Пример:

НаборКурсов.ПолучитьФорму("ФормаНабораЗаписей").Открыть();

Прочитать ( Read )

Синтаксис:

Прочитать()

Описание:

Позволяет выполнить чтение записей из информационной базы по установленному отбору.

Пример:

КурсыВалют = РегистрыСведений.КурсыВалют;

НаборКурсов = КурсыВалют .СоздатьНаборЗаписей();

НаборКурсов.Прочитать();

Сдвинуть ( Move )

Синтаксис:

Сдвинуть(< Запись>, <Смещение>)

Параметры:

<3апись> Обязательный

Тип: Число, РегистрСведенийЗапись.<Имя регистра сведений>. Индекс сдвигаемой записи либо сама запись.

<Смещение> Обязательный

Тип: Число. Количество позиций, на которое следует сдвинуть запись. Положительное значение соответствует смещению записи в сторону конца списка записей набора (увеличение индекса), отрицательное - к началу.

Описание:

Позволяет сдвинуть запись в наборе на указанное число позиций.

Важно! Метод доступен только для набора записей регистра сведений, в котором записи подчинены регистратору.

Удалить ( Remove )

Синтаксис:

Удалить(< Запись>)

Параметры:

<3апись> Обязательный

Тип: Число, РегистрСведенийЗапись.<Имя регистра сведений>. Индекс удаляемой записи либо сама запись.

Описание:

Позволяет удалить запись из набора.

Пример:

НаборКурсов.Удалить(0);

УстановитьАктивность ( SetActive )

Синтаксис:

УстановитьАктивность (<Активность>)

Параметры:

<Активность> Обязательный

Тип: Булево. Признак активности. Истина - записи активны. Ложь - записи не активны.

Описание:

Позволяет установить значение свойства Активность для всех записей набора.

Пример:

НаборКурсов.УстановитьАктивность(Истина);

РегистрСведенийЗапись.<Имя регистра сведений>( InformationRegisterRecord .< Имя регистра сведений >)

Предоставляет доступ к записи регистра сведений. Объект не создается непосредственно, а предоставляется другими объектами, связанными с регистром сведений. Например, данный объект представляет записи регистра в наборе записей.

Свойства

<Имя измерения>

Использование:

Чтение и запись.

Описание:

Набор свойств содержит значения измерений регистра сведений. Имена свойств совпадают с именами измерений, как они заданы в конфигураторе.

<Имя реквизита>

Использование:

Чтение и запись.

Описание:

Набор свойств содержит значения реквизитов регистра сведения. Имена свойств совпадают с именами реквизитов, как они заданы в конфигураторе.

<Имя ресурса>

Использование:

Чтение и запись.

Описание:

Набор свойств содержит значения ресурсов регистра сведений. Имена свойств совпадают с именами ресурсов, как они заданы в

конфигураторе.

Активность ( Active )

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит признак активности записи. Используется для регистров сведений, для которых в конфигураторе установлен режим записи "Подчинение регистратору".

Примечание:

Записи, для которых значение данного свойства установлено в Ложь, не будут учитываться при получении "первых" или "последних" записей регистра, а также при получении сведений на определенный момент времени.

См. также:

РегистрСведенийНаборЗаписей.<Имя регистра сведений>, метод УстановитьАктивность.

НомерСтроки ( LineNumber )

Использование:

Только чтение.

Описание:

Тип: Число. Содержит уникальный номер строки данной записи в списке записей по регистратору, указанному в значении свойства Регистратор. Используется для регистров, управляемых регистратором.

Период ( Period )

Использование:

Чтение и запись.

Описание:

Тип: Дата. Содержит дату и время записи периодического регистра сведений.

Примечание:

Для непериодических регистров сведений смысла не имеет.

Регистратор ( Recorder )

Использование:

Только чтение.

Описание:

Тип: ДокументСсылка. <Имя документа>. Содержит регистратор, который занес данную запись регистра сведений.

Примечание:

Для регистра, у которого в конфигураторе установлен режим записи "Независимый", смысла не имеет.

Методы

МоментВремени ( PointOfTime )

Синтаксис:

МоментВремени()

Возвращаемое значение:

Тип: МоментВремени.

Описание:

Позволяет определить момент времени, соответствующий записи регистра. Применяется для регистров сведений, для которых в конфигураторе установлен режим записи "Подчинение регистратору".

РегистрСведенийКлючЗаписи.<Имя регистра сведений >( InformationRegisterRecordKey .< Имя регистра сведений>)

Набор значений, однозначно идентифицирующих запись регистра. Объект используется в тех случаях, когда необходимо сослаться на определенную запись. Например, он выступает в качестве значение свойства ТекущаяСтрока табличного поля, отображающего список записей регистра.

Важно! Данный объект нельзя использовать как устойчивый идентификатор записи, например, как ссылку для элементов справочника. Фактически имеет смысл только пока запись есть и не перезаписывалась.

Свойства

<Имя измерения>

Использование:

Чтение и запись.

Описание:

Набор свойств содержит значения измерений регистра сведений. Имена свойств совпадают с именами измерений, как они заданы в

конфигураторе.

Период ( Period )

Использование:

Чтение и запись.

Описание:

Тип: Дата. Содержит дату и время записи периодического регистра сведений.

Примечание:

Для непериодических регистров сведений смысла не имеет.

Регистратор ( Recorder )

Использование:

Только чтение.

Описание:

Тип: ДокументСсылка. <Имя документа>. Содержит регистратор, который занес данную запись регистра сведений.

Примечание:

Имеет смысл только для регистра, у которого в конфигураторе установлен режим записи "Подчинение регистратору" и периодичность "По позиции регистратора".

Расширение формы записи регистра сведений

Предоставляет доступ к дополнительным методам и событиям фор мы, в том случае если основным реквизитом формы является

запись регистра сведений.

Методы

ЗаписатьВФорме ( WritelnForm )

Синтаксис:

ЗаплсатьВФорме()

Возвращаемое значение:

Тип: Булево. Истина - объект записан.

Ложь - нет.

Описание:

Позволяет записать объект, открытый в форме.

Пример:

Если ЗаписатьВФорме() Тогда

Сообщить("Запись занесена в ИБ.");

КонецЕсли;

События

ПередЗаписью ( BeforeWrite )

Синтаксис:

ПередЗаписьо (< Отказ>)

Параметры:

<0тказ>

Тип: Булево. Признак отказа от записи объекта. Если в теле процедуры-обработчика установить данному параметру значение Истина, то запись объекта выполнена не будет.

Описание:

Событие возникает перед выполнением записи объекта. Процедура-обработчик вызывается перед началом транзакции записи объекта.

ПриЗаписи ( OnWrite )

Синтаксис:

ПриЗаписи(< Отказ>)

Параметры:

<0тказ>

Тип: Булево. Признак отказа от записи объекта. Если в теле процедуры-обработчика установить данному параметру значение Истина, то запись объекта выполнена не будет.

Описание:

Событие возникает при записи объекта. Процедура-обработчик вызывается после записи объекта, но до окончания транзакции записи.

ПослеЗаписи ( AjterWrite )

Синтаксис:

ПослеЗаписи()

Описание:

Событие возникает после окончания транзакции записи объекта.

Расширение табличного поля списка записей регистра сведений

Дополнительные свойства и методы табличного поля списка записей регистра сведений. Для данного расширения свойство ТекущаяСтрока табличного поля содержит значение типа РегистрСведенийКлючЗаписи. Свойство ТекущиеДанные табличного поля содержит коллекцию значений данных строки, набор значений которой определяется колонками объекта РегистрСведенийСписок.

Свойства

ВыбиратьСрез ( SelectSlice )

Использование:

Чтение и запись.

Описание:

Тип: ИспользованиеСреза. Содержит вариант получения среза записей для периодического регистра сведений.

При определении значения свойства используется системное перечисление ИспользованиеСреза ( SliceUse ).

НастройкаОтбора ( FilterSetting )

Использование:

Только чтение.

Описание:

Тип: Коллекция. Предоставляет доступ к настройкам отбора списка записей регистра сведений. Представляет собой коллекцию значений типа Управление элементом отбора. Свойства коллекции содержат объекты для управления элементом отбора. Имена свойств совпадают с именами доступных элементов отбора.

НастройкаПорядка ( OrderSetting )

Использование:

Только чтение.

Описание:

Тип: Коллекция. Предоставляет доступ к настройкам порядка списка записей регистра сведений. Представляет собой коллекцию значений типа Управление элементом порядка. Свойства коллекции содержат объекты для управления элементом порядка. Имена свойств совпадают с именами доступных для регистра сведений элементов упорядочивания.

СпособРедактирования ( EditType )

Использование:

Чтение и запись.

Описание:

Тип: РежимРедактированияСписка. Содержит способ редактирования поля списка записей регистра сведений.

При определении значения свойства используется системное перечисление РежимРедактированияСписка ( ListEditMode ).

СтандартныйПериод

Использование:

Чтение и запись.

Описание:

Тип: НастройкаПериода. Содержит объект НастройкаПериода, в соответствии с которым осуществляется настройка периода списка записей при открытии формы, содержащей данное табличное поле.

Примечание:

Для непериодического регистра сведений смысла не имеет.

См. также:

НастройкаПериода.

Расширение формы списка записей регистра сведений

Предоставляет доступ к дополнительным свойствам формы, в том случае если основным реквизитом формы является список

записей регистра сведений.

Пример:

Доллар = Справочники.Валюты.НайтиПоНаименованию("USD");

КурсыВалот = РегистрыСведений.КурсыВалют;

Форма = КурсыВалют.ПолучитьФормуСписка();

ОтборПоВалюте = Новый Структура("'Валюта");

ОтборПоВалюте.Валюта = Доллар;

Форма.ПараметрОтборПоИзмерению = ОтборПоВалюте;

Форма.Открыть();

Свойства

ПараметрОтборПоИзмерению ( FilterByDimensionParameter )

Использование:

Чтение и запись.

Описание:

Тип: Структура. Предоставляет возможность установить начальное значение отбора по значениям измерений при открытии или повторном открытии формы списка регистра сведений. Содержит объект Структура, имена свойств которого должны соответствовать именам измерений регистра, значения свойств -устанавливаемым значениям отбора.

ПараметрОтборПоРегистратору ( FilterByRecorderParameter )

Использование:

Чтение и запись.

Описание:

Тип: ДокументСсылка. <Имя документа>. Предоставляет возможность установить начальное значение отбора по регистратору при открытии или повторном открытии формы списка регистра сведений.

Примечание:

Имеет смысл только для регистров сведений, подчиненных регистраторам.

Расширение колонки табличного поля списка записей регистра сведений

Дополнительные свойства колонки табличного поля списка записей регистра сведений.

Свойства

Данные ( Data )

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя колонки списка записей регистра сведений. Данное свойство позволяет указать, какие данные будут отображаться в ячейке табличного поля.

ДанныеФлажка ( CheckData )

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя колонки списка записей регистра сведений, значения которой будут отображаться флажком ячейки

табличного поля. Колонка списка записей регистра сведений должна иметь тип Булево или Число.

ОтображатьСтандартнуюКартинку

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак отображения в колонке стандартной картинки, обозначающей запись регистра сведений и ее состояние.

Расширение табличного поля набора записей регистра сведений

Дополнительные свойства и методы табличного поля набора записей регистра сведений. Для данного расширения свойства ТекущаяСтрока и ТекущиеДанные табличного поля содержат значение типа РегистрСведенийЗапись.

Свойства

ОбновлятьПриИзмененииОтбора ( UpdateOnFilterChange )

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак автоматического обновления набора записей при изменении параметров отбора. Если значение данного свойства установлено в Ложь, то при изменении параметров отбора обновления не произойдет.

Расширение колонки набора записей регистра сведений

Дополнительные свойства колонки табличного поля для набора записей регистра сведений.

Свойства

Данные ( Data )

Использование:

Чтение и запись.

Описание:

Тип Строка. Содержит имя колонки набора записей регистра сведений. Данное свойство позволяет указать, какие данные будут отображаться в ячейке табличного поля.

ДанныеФлажка ( CheckData )

Использование:

Чтение и запись.

Описание:

Тип Строка. Содержит имя колонки набора записей регистра сведений, значения которой будут отображаться флажком ячейки табличного поля. Колонка набора записей регистра сведений должна иметь тип Булево или Число.

ОтображатьСтандартнуюКартинку (DisplayStandardPicture)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак отображения в колонке стандартной картинки, обозначающей запись регистра сведений и ее состояние.

Расширение формы набора записей регистра сведений

Предоставляет доступ к дополнительным методам формы, в том случае если основным реквизитом формы является набор записей регистра сведений.

Методы

ЗаписатьВФорме ( WritelnForm )

Синтаксис:

ЗаписатьВФорме()

Возвращаемое значение:

Истина - объект записан. Ложь - нет.

Описание:

Позволяет записать объект, открытый в форме.

Пример:

Если ЗаписатьВФорме() Тогда

Сообщить("Объект записан.') ;

КонецЕсли;

События

ПередЗаписью ( BeforeWrite )

Синтаксис:

ПередЗаписью (< Отказ>)

Параметры:

<Отказ>

Тип: Булево. Признак отказа от записи объекта. Если в теле процедуры-обработчика установить данному параметру значение Истина, то запись объекта выполнена не будет.

Описание:

Событие возникает перед выполнением записи объекта. Процедура-обработчик вызывается перед началом транзакции записи объекта.

ПриЗаписи ( OnWrite )

Синтаксис:

ПриЗаписи(< Отказ>)

Параметры:

<Отказ>

Тип: Булево. Признак отказа от записи объекта. Если в теле процедуры-обработчика установить данному параметру значение Истина, то запись объекта выполнена не будет.

Описание:

Событие возникает при записи объекта- Процедура-обработчик вызывается после записи объекта, но до окончания транзакции записи.

ПослеЗаписи ( AfterWrite )

Синтаксис:

ПослеЗаписи()

Описание:

Событие возникает после окончания транзакции записи объекта.


Регистры накопления

Регистры накопления в системе 1С:Предприятие используются для накопления информации о наличии и движении средств -товарных, денежных и других. Информация о хозяйственных операциях в регистры накопления вводится с использованием документов (регистраторов) и используется, например, для получения отчетных форм.

Регистр накопления представляет собой n-мерную систему координат, в узлах которой хранятся совокупные данные. Оси такой системы координат будем называть измерениями регистра, а хранящиеся в узлах данные - ресурсами регистра Содержимое регистра накопления можно представить в виде таблицы с количеством колонок, равным сумме измерений и ресурсов регистра накопления.

Помимо измерений и ресурсов, для регистра накопления может быть создан набор реквизитов. Реквизиты позволяют включать в движения регистров различную дополнительную информацию. Реквизиты не влияют на значения ресурсов регистра и могут использоваться для анализа движений регистра.

В системе 1С:Предприятие возможно использование регистров накопления двух типов: регистры остатков и регистры оборотов. Для регистра остатков методы встроенного языка позволяют получить остатки регистра накопления на заданный момент времени. Есть возможность фильтрации по значениям измерений, а также получения остатков в разрезе других измерений. Регистры оборотов предназначены для хранения информации, для которой понятие остатка лишено смысла, например, сумм продаж в разрезе покупателей.

В программных модулях для общих действий над регистром накопления (получение остатков и оборотов по данным регистра накопления, поиска нужных записей, формирования выборок, создания форм и макетов) служит объект РегистрНакопленияМенеджер. Для считывания и занесения набора записей в информационную базу по определенному условию отбора служит объект РегистрНакопленияНаборЗаписей. Для динамического обхода записей регистра служит объект PerистрНакопленияВыборка.

РегистрыНакопленияМенеджер ( AccumulationRegistersManager )

Объект предназначен для управления регистрами накопления и предоставляет доступ к значениям типа РегистрНакопления. Доступ к объекту осуществляется через свойство глобального контекста РегистрыНакопления.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа РегистрНакопленияМенеджер.<Имя регистра накопления>. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции.

Свойства

<Имя регистра накопления>

Использование:

Только чтение.

Описание:

Набор свойств содержит менеджеры отдельных регистров накопления. Имена свойств совпадают с именами регистров накопления, как они заданы в конфигураторе.

РегистрНакопленияМенеджер.<Имя регистра накопления>

Предназначен для управления данными конкретного регистра накопления. Позволяет получать остатки и обороты по данным регистра накопления, формировать выборки, создавать формы и макеты.

Методы

Выбрать ( Select )

Синтаксис:

Выбрать(<Начало интервала> , <Конец интервала> , <Отбор>)

Параметры:

<Начало интервала> Необязательный.

Тип: Дата, МоментВремени или Граница.. Начало интервала, за который будут выбираться записи регистра накопления.

Если не указан, то будут выбираться записи с самого ранней включительно.

Значение по умолчанию: Неопределено.

<Конец интервала> Необязательный

Тип: Дата, МоментВремени или Граница.. Конец интервала, за который будут выбираться записи регистра накопления.

Если не указан, то будут выбираться записи до самой поздней включительно.

Значение по умолчанию: Неопределено.

<Отбор> Необязательный

Тип: Структура. Задает поле и значение отбора открываемой выборки. Ключ структуры описывает имя поля, а значение структуры - значение отбора по этому полю. В качестве полей для отбора могут задаваться измерения, для которых в конфигураторе признак индексирования установлен в значение "Индексировать".

Важно! Структура может содержать только один элемент.

Значение по умолчанию: Неопределено.

Возвращаемое значение:

Тип: РегистрНакопленияВыборка.<Имя регистра накопления>. Сформированная выборка записей регистра накопления.

Описание:

Позволяет получить выборку записей регистра накопления.

Пример:

// Посчитаем, сколько отгружено с начала года

МПЗ = РегистрыНакопления.УчетНоменклатуры;

ОтборПоТовару = Новый Структура("Номенклатура");

ОтборПоТовару.Номенклатура = ВыбТовар;

НачДата = НачалоГода(ТекущаяДата()) ;

КонДата = ТекущаяДата() ;

ВыборкаМПЗ = МПЗ.Выбрать(НачДата,КонДата,ОтборПоТовару);

Расход =0;

Пока ВыборкаМПЗ.Следующий() Цикл

Если ВыборкаМПЗ.Расход Тогда

Расход = Расход + ВыборкаМПЗ.Количество;

КонецЕсли;

КонецЦикла ;

Предупреждение("Отгружено с начала года " + СокрЛП(ВыбТовар) + " = "+ Расход + " шт.");

ВыбратьПоРегистратору

Синтаксис:

ВыбратьПоРегистратору (< Регистратор>)

Параметры:

<Регистратор> Обязательный

Тип: Документ-Ссылка. <Имя документа>. Ссылка на документ, являющийся регистратором для записей регистра.

Возвращаемое значение:

Тип: РегистрНакопленияВыборка.<Имя регистра накопления>. Сформированная выборка записей регистра накопления.

Описание:

Позволяет получить выборку по регистратору записей регистра накопления.

Обороты ( Turnovers )

Синтаксис:

Обороты(<Начало периода> , <Конец периода> , <Отбор>, <Измерения>, <Ресурсы>)

Параметры:

<Начало периода> Необязательный

Тип: Дата, Момент Времени, Граница. Момент времени, начиная с которого необходимо получить обороты. Если параметр не указан или установлен в Неопределено, то обороты будут получены начиная с момента ведения информационной базы. Если в качестве параметра передана Дата или МоментВремени, то обороты за указанную дату (момент времени) будут включены в результирующую таблицу значений.

Значение по умолчанию: Неопределено.

<Конец периода > Необязательный

Тип: Дата, МоментВремени, Граница. Момент времени, определяющий конец периода за который необходимо получить обороты. Если параметр не указан или установлен в Неопределено, то обороты будут получены до самого позднего движения регистра. Если в качестве параметра передана Дата

или Момент Времени, то обороты за указанную дату (момент времени) будут включены в результирующую таблицу значений.

Значение по умолчанию: Неопределено.

<От6ор> Необязательный

Тип: Структура. Структура, содержащая набор значений измерений регистра, по которым надо отбирать обороты. Имя ключа структуры должно совпадать с именем измерения регистра, заданного в конфигураторе.

Значение по умолчанию: Неопределено.

<Измерения> Необязательный

Тип: Строка. Список измерений, для которых надо разворачивать обороты. Строка, содержащая имена измерений, разделенные запятыми. Если параметр не указан или указана пустая строка, то обороты будут сформированы по всем измерениям.

Значение по умолчанию: Пустая строка.

<Ресурсы> Необязательный

Тип: Строка. Список ресурсов, для которых надо получить обороты. Строка, содержащая имена ресурсов, разделенные запятыми.

Если параметр не указан или указана пустая строка, то обороты будут сформированы по всем ресурсам.

Значение по умолчанию: Пустая строка.

Возвращаемое значение:

Тип: ТаблицаЗначений. Сформированная таблица значений.

Описание:

Позволяет получить обороты регистра накопления за заданный момент времени. Есть возможность фильтрации по значениям измерений. Возвращает таблицу значений, содержащую колонки с измерениями, указанными в параметре Измерения, и по две колонки на каждый ресурс, указанный в параметре Ресурсы. На звания колонок для ресурсов формируются следующим образом "<Имя ресурса>Приход" и "<Имя ресурса>Расход".

Пример:

ОстаткиМПЗ = РегистрыНакопления.ОстаткиМПЗ;

ФильтрМПЗ = Новый Структура("Номенклатура","Склад");

ФильтрМПЗ.Номенклатура = ВыбМПЗ;

ФильтрМПЗ.Склад = ВыбСклад;

ТабОборотов = ОстаткиМПЗ.Обороты(ДатаНач, ДатаКон, ФильтрМПЗ, "Номенклатура,Склад", "Количество") ;

Остатки ( Balance )

Синтаксис:

Остатки(< Момент времени> , <Отбор>, <Измерения>, <Ресурсы>)

Параметры:

<Момент времени> Необязательный

Тип: Дата, МоментВремени, Граница. Момент времени, на который необходимо получить остатки. Если параметр не указан или установлен в Неопределено, то будут получены текущие остатки (на максимальную дату движений регистра). Если в качестве параметра передана Дата, то остатки будут получены на начало дня, если МоментВремени - то в остатках не будут учтены движения регистра, произошедшие в тот же момент времени.

Значение по умолчанию: Неопределено.

<Отбор> Необязательный

Тип: Структура. Структура, содержащая набор значений измерений регистра, по которым надо отбирать итоги. Имя Ключа структуры должен совпадать с именем измерения регистра, заданного в конфигураторе.

Значение по умолчанию: Неопределено. Описание

<Измерения> Необязательный

Тип: Строка. Список измерений, для которых надо получить остатки. Строка, содержащая имена измерений, разделенные запятыми.

Если параметр не указан или указана пустая строка, то остатки будут сформированы по всем измерениям.

Значение по умолчанию: Неопределено.

<Ресурсы> Необязательный

Тип: Строка. Список ресурсов, для которых надо получить остатки. Строка, содержащая имена ресурсов, разделенные запятыми.

Если параметр не указан или указана пустая строка, то остатки будут сформированы по всем ресурсам.

Значение по умолчанию: Пустая строка.

Возвращаемое значение:

Тип: ТаблицаЗначений. Сформированная таблица значений.

Описание:

Позволяет получить остатки регистра накопления на заданный момент времени. Есть возможность фильтрации по значениям измерений, а также получения остатков в разрезе других измерений. Возвращает таблицу значений, содержащую колонки с измерениями, указанными в параметре Измерения, и колонки с ресурсами, указанными в параметре Ресурсы.

Замечание! Использование данного метода имеет смысл только для регистров, у которых в конфигураторе указан вид регистра "Остатки".

Пример:

ОстаткиМПЗ = РегистрыНакопления.ОстаткиМПЗ;

ФигьтрМПЗ = Новый Структура() ;

ФильтрМПЗ.Вставить("Номенклатура",ВыбМПЗ);

ФильтрМПЗ.Вставить("Склад", ВыбСклад) ;

ТабОстатков = ОстаткиМПЗ. Остатки (ВыбДата, ФильтрМПЗ, "Номенклатура,Склад", "Количество") ;

ПересчитатьИтоги ( RecalcTotals )

Синтаксис:

ПересчитатьИтоги()

Описание:

Позволяет осуществить полный пересчет итогов регистра накопления.

Пример:

Регистры.ОстаткиМПЗ.ПересчитатьИтоги();

ПолучитьМакет ( GetTemplate )

Синтаксис:

ПолучитьМакет(< Макет>)

Параметры:

<Макет> Обязательный

Тип: Строка, Объект описания метаданного. Имя макета, как оно задано в конфигураторе или объект описания метаданного требуемого макета.

Возвращаемое значение:

Тип: ТабличныйДокумент. Созданный макет.

Описание:

Позволяет получить макет регистра накопления.

ПолучитьПериодРасчитанныхИтогов

Синтаксис:

ПолучитьПериодРасчитанныхИтогов()

Возвращаемое значение:

Тип: Дата. Период рассчитанных итогов.

Описание:

Позволяет получить период рассчитанных итогов. Имеет смысл только для регистров остатков.

Пример:

ВыбДата = Регистры.ОстаткиМПЗ.ПолучитьПериодРасчитанныхИтогов();

См. также:

РегистрНакопленияМенеджер.<Имя регистра накопления>. Метод УстановитьПериодРассчитанныхИтогов.

ПолучитьФорму ( GetForm )

Синтаксис:

ПолучитьФорму(<Форма>, <Владелец>, <Ключ уникальности>)

Параметры:

<Форма> Обязательный

Тип: Строка. Имя формы, как оно задано в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание:

Позволяет получить форму регистра накопления.

ПолучитьФормуСписка ( GetFormList )

Синтаксис:

ПолучитьФормуСписка (< Форма>, <Владелец> , <Ключ уникальности>}

Параметры:

<Форма> Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание:

Позволяет получить форму списка регистра накопления.

Пример:

РегистрыНакопления.УчетНоменклатуры.ПолучитьФормуСписка().Открыть();

СоздатьКлючЗаписи ( CreateRecordKey )

Синтаксис:

СоздатьКлючЗаписи(< Значения ключа>)

Параметры:

< Значения ключа> Обязательный

Тип: Структура.

Возвращаемое значение:

Тип: РегистрНакопленияКлючЗаписи.<Имя регистра накопления>. Созданный ключ записи.

Описание:

Создает ключ записи по переданной структуре.

СоздатьНаборЗаписей ( CreateRecordSet )

Синтаксис:

СоздатьНаборЗаписей()

Возвращаемое значение:

Тип: РегистрНакопленияНаборЗаписей.<Имя регистра накопления>. Созданный набор записей.

Описание:

Позволяет создать набор записей регистра накопления. Набор записей создается пустым.

Пример:

ОстаткиТоваров = РегистрыНакопления.УчетНоменклатуры;

НаборЗаписейМПЗ = ОстаткиТоваров.СоздатьНаборЗаписей();

УстановитьПериодРассчитанныхИтогов ( SetTotalsMaxPeriod )

Синтаксис:

УстановитьПериодРассчитанныхИтогов(< Период>)

Параметры:

<Период> Обязательный

Тип: Дата. Период, на который необходимо рассчитать итоги.

Описание:

Позволяет установить период, на который рассчитаны итоги. Периодичность расчета - месяц. Период устанавливается на начало месяца. Имеет смысл только для регистров остатков.

Примечание:

Период, на который рассчитаны итоги, влияет только на производительность получения остатков по данному регистру. Для получения итогов регистра после установленного периода расчета будут использоваться полученные в результате использования метода результаты.

Пример:

Регистры.ОстаткиМПЗ.УстановитьПериодРасчитанныхИтогов(ВыбДата) ;

РегистрНакопленияВыборка.<Имя регистра накопления> ( AccumulationRegisterSelection .< Имя регистра накопления>)

Объект этого типа возвращается методами Выбрать и ВыбратьПоРегистратору у объекта типа РегистрНакопленияМенеджер и представляет собой специализированный способ перебора записей регистра накопления.

Обход записей выполняется системой динамически. Это означает, что использование выборки не считывает все записи сразу, а выбирает их порциями из информационной базы. Такой подход позволяет достаточно быстро обходить с помощью выборки большое количество записей и не загружает в память всех элементов выборки.

Свойства

<Имя измерения>

Использование:

Только чтение.

Описание:

Набор свойств содержит значения измерений регистра накопления. Имена свойств совладают с именами измерений, как они заданы в конфигураторе.

<Имя реквизита>

Использование:

Только чтение.

Описание:

Набор свойств содержит значения реквизитов регистра накопления. Имена свойств совпадают с именами реквизитов, как они заданы в конфигураторе.

<Имя ресурса>

Использование:

Только чтение.

Описание:

Набор свойств содержит значения ресурсов регистра накопления. Имена свойств совпадают с именами ресурсов, как они заданы в конфигураторе.

Активность ( Active )

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит флаг, определяющий влияние записи на итоги регистра накопления.

Если значение Ложь, то запись не учитывается в итогах регистра.

НомерСтроки ( LineNumber )

Использование:

Только чтение.

Описание:

Тип: Число. Содержит уникальный номер строки данной записи в списке записей по регистратору, указанному в значении свойства Регистратор.

Период ( Period )

Использование:

Только чтение.

Описание:

Тип: Дата. Содержит дату и время записи регистра накопления.

Приход ( Receipt )

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит флаг записи, обозначающий, что запись отражает увеличение ресурсов регистра.

Расход ( Expense )

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит флаг записи, обозначающий, что запись отражает уменьшение ресурсов регистра.

Регистратор ( Recorder )

Использование:

Только чтение.

Описание:

Тип: ДокументСсылка. <Имя документа>. Содержит ссылку на документ, внесший запись регистра накопления.

Методы

Следующий ( Next )

Синтаксис:

Следующий()

Возвращаемое значение:

Тип: Булево. Истина - запись выбрана.

Ложь- запись не выбрана - достигнут конец выборки.

Описание:

Выполняет получение следующей записи выборки. Для обхода записей регистра нужно после получения выборки вызвать данный метод для позиционирования на первую запись и далее вызывать до тех пор, пока не будет возвращено значение Ложь.

РегистрНакопленияСписок.<Имя регистра накопления> ( AccumulationRegisterUst .< Имя регистра накопления>)

Объект предназначен для управления списком записей регистра накопления, отображаемым в табличном поле.

Пример:

Форма = РегистрыНакопления.УчетНоменклатуры.ПолучитьФормуСписка();

Форма.СписокРегистраНакопления.Порядок.Установить ("Склад");

Форма.СписокРегистраНакопления.Отбор.Номенклатура.Установить(ВыбТовар);

Форма.Открыть();

Свойства

Колонки ( Columns )

Использование:

Только чтение.

Описание:

Тип: Колонки списка. Содержит объект для управления колонками списка. Набор колонок составляется из полей регистра.

Отбор ( Filter )

Использование:

Только чтение.

Описание:

Тип: Отбор. Содержит объект Отбор, по которому осуществляется текущая фильтрация записей регистра в списке. В качестве свойств объекта могут выступать поля регистра накопления. Имена свойств совпадают с именами полей регистра.

Примечание:

Отбор возможен по значениям измерений, периоду, регистратору, номеру строки и признакам: активность, приход и расход,

Порядок ( Order )

Использование:

Чтение и запись.

Описание:

Тип: Порядок. Содержит объект Порядок, по которому осуществляется текущее упорядочивание записей регистра в списке. В качестве свойств объекта могут выступать предопределенные поля Период, Регистратор, НомерСтроки, Активность, а также измерения, ресурсы и реквизиты регистра. Имена свойств совпадают с именами полей.

Методы

Обновить ( Refresh )

Синтаксис:

Обновить()

Описание:

Вызывает перечитывание данных списка.

РегистрНакопленияНаборЗаписей.<Им я регистра накопления> ( AccumulationRegisterRecordSet .< Имя регистра накопления>)

Представляет собой коллекцию записей регистра накопления. Позволяет выполнять считывание записей из информационной базы по определенному регистратору, добавлять, удалять и модифицировать записи в наборе. Также может быть выполнена запись в информационную базу по определенному условию. При записи обычно выполняется замещение всех имеющихся в информационной базе записей по данному условию на записи, содержащиеся в наборе. Если записи не замещаются, то после выполнения записи набор очищается.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа РегистрНакопленияЗапись.<Имя регистра накопления>. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции.. Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс записи.

Свойства

Отбор ( Filter )

Использование:

Только чтение.

Описание:

Тип: Отбор. Содержит объект Отбор, по которому осуществляется текущая фильтрация записей при считывании или записи набора. Позволяет отобрать записи с определенным регистратором при считывании или записи набора.

Важно! Отбор может устанавливаться только на равенство.

Примечание:

Для установки фильтрации используется стандартный объект, через который устанавливается предопределенный элемент отбора.

Методы

Вставить ( Insert )

Синтаксис:

Вставить(<Индекс>)

Параметры:

<Индекс> Обязательный

Тип: Число. Индекс позиции, на которую надо вставить новую запись.

Возвращаемое значение:

Тип: РегистрНакопленияЗапись.<Имя регистра накопления>. Созданная запись регистра.

Описание:

Позволяет вставить новую запись в набор на указанную позицию.

Выбран ( Selected )

Синтаксис:

Выбран()

Возвращаемое значение:

Тип: Булево. Истина, если считан.

Ложь, если иначе. В частности, если набор не считывался и не записывался, а также если записывался с добавлением записей.

Описание:

Позволяет определить, считан ли набор записей.

Примечание:

При изменении отбора считается, что набор перестает быть считанным.

Выгрузить ( Unload )

Синтаксис:

Выгрузить()

Возвращаемое значение:

Тип: ТаблицаЗначений. Сформированная таблица значений.

Описание:

Создает таблицу значений и копирует в нее все записи набора. Структура полученной таблицы совпадает со структурой набора записей.

ВыгрузитьКолонку ( UnloadColumn )

Синтаксис:

ВыгрузитьКолонку(< Имя поля>)

Параметры:

<Имя поля> Обязательный

Тип: Строка. Имя поля записей набора, значения из которого будут выгружены в массив.

Возвращаемое значение:

Тип: Массив. Сформированный массив значений.

Описание:

Позволяет выгрузить значения заданного поля у записей набора в массив значений. Значения записей выгружаются в элементы массива, имеющие тот же индекс.

Добавить( Add )

Синтаксис:

Добавить()

Возвращаемое значение:

Тип: РегистрНакопленияЗапись.<Имя регистра накопления>. Запись регистра сведений, помещенная в набор.

Описание:

Позволяет создать новую запись в наборе.

Загрузить ( Load )

Синтаксис:

Загрузить(< Таблица значений>)

Параметры:

<Таблица значений> Обязательный

Тип: ТаблицаЗначений. Таблица значений, содержащая данные для заполнения набора записей.

Описание:

Очищает набор записей и заполняет его значениями из указанной таблицы значений. Заполняются значения доступных для записи свойств записей регистра накопления, имена которых совпали с именами колонок таблицы значений.

ЗагрузитьКолонку ( LoadColumn )

Синтаксис:

ЗагрузитьКолонку( <Массив> , <Имя поля>)

Параметры:

<Массив> Обязательный

Тип: Массив. Массив, содержащий значения для заполнения колонки набора.

<Имя поля> Обязательный

Тип: Строка. Имя поля записей набора, в которое будут загружаться значения из массива.

Описание:

Позволяет заполнить заданное поле у записей набора значениями, взятыми из массива. Значения записей заполняются из элементов массива, имеющих тот же индекс.

Записать ( Write )

Синтаксис:

Записать(< Замещать> )

Параметры:

<3амещать> Необязательный

Тип: Булево. Замещать записи по установленному отбору.

Если значение параметра Истина, то перед записью существующие записи будут удалены.

Значение по умолчанию: Истина.

Описание:

Позволяет занести в информационную базу набор записей регистра накопления. В зависимости от переданного параметра может быть выполнено добавление записей или их замещение. Если указано замещение, то перед выполнением записи будет выполнено удаление всех существующих записей в соответствии с текущими установками отбора.

Индекс ( IndexOf )

Синтаксис:

Индекс(< Запись>)

Параметры:

<3апись> Обязательный

Тип: РегистрНакопленияЗапись.<Имя регистра накопления>. Запись набора, для которой необходимо получить индекс.

Возвращаемое значение:

Тип: Число. Индекс записи в наборе.

Описание:

Позволяет определить индекс записи в наборе.

Итог ( Total )

Синтаксис:

Итог(<Имя поля>)

Параметры:

<Имя поля> Обязательный

Тип: Строка. Имя поля записей набора, по которому необходимо подсчитать итог.

Возвращаемое значение:

Тип: Число. Числовое значения результата вычисления.

Описание:

Позволяет вычислить итог по одному из полей набора.

Количество ( Count )

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество записей в наборе.

Описание:

Позволяет получить количество записей в наборе.

Пример:

Сообщить(" Записей в наборе - " + НаборЗаписейМПЗ. Количество());

Модифицированность ( Modified )

Синтаксис:

Модифицированность()

Возвращаемое значение:

Тип: Булево. Истина - если записи изменены.

Ложь - если записи не изменены.

Описание:

Позволяет определить, были ли изменены записи в наборе.

Пример:

Если НаборЗаписейМПЗ.Модифицированность() Тогда НаборЗаписейМПЗ.Записать();

КонецЕсли;

Очистить ( Clear )

Синтаксис:

Очистить()

Описание:

Позволяет очистить набор, удаляя из него все записи.

ПолучитьФорму ( GetForm )

Синтаксис:

ПолучитьФорму(<Форма> , <Владелец> , <Ключ уникальности>)

Параметры:

<Форма> Необязательный

Тип. Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания ме-таданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип Форма.

Описание:

Позволяет получить форму набора записей регистра накопления.

Прочитать ( Read )

Синтаксис:

Прочитать()

Описание:

Позволяет выполнить чтение записей из информационной базы по установленному отбору.

Пример:

ОстаткиМПЗ = РегистрыНакопления.УчетНоменклатуры;

НаборЗаписейМПЗ ОстаткиМПЗ.СоздатьНаборЗаписей();

Док = НаборЗаписейМПЗ.Отбор.Регистратор;

Док.Установить(ВыбДок);

НаборЗаписейМПЗ.Прочитать();

Сдвинуть ( Move )

Синтаксис:

Сдвинуть(< Запись>, <Смещение>)

Параметры:

<3апись> Обязательный

Тип: Число, РегистрНакопленияЗапись.<Имя регистра накопления>. Индекс сдвигаемой записи либо сама запись.

<Смещение> Обязательный

Тип" Число. Количество позиций, на которое следует сдвинуть запись. Положительное значение соответствует смещению записи в сторону конца списка записей набора (увеличение индекса), отрицательное - к началу.

Описание:

Позволяет сдвинуть запись в наборе на указанное число позиций.

Удалить ( Remove )

Синтаксис:

Удалить (< Запись> )

Параметры:

<3апись> Обязательный

Тип. Число, РегистрНакопленияЗапись.<Имя регистра накопления>. Индекс удаляемой записи либо сама запись.

Описание:

Позволяет удалить запись из набора по указанному индексу записи или объекту записи регистра накопления.

УстановитьАктивность ( SetActive )

Синтаксис:

УстановитьАктивность(< Активность> )

Параметры:

<Активность> Обязательный

Тип: Булево. Истина - записи учитываются в итогах регистра.

Ложь - записи не учитываются в итогах регистра.

Описание:

Позволяет изменить значение свойства Активность у всех записей, входящих в набор.

Пример:

НаборЗаписейМПЗ.УстановитьАктивность(Истина);

РегистрНакопленияЗапись.<Имя регистра накопления> ( AccumumationRegisterRecord .< Имя регистра накопления>)

Используется для доступа к записи регистра накопления. Объект не создается непосредственно, а предоставляется другими объектами, отвечающими за регистр накопления. Например, данный объект представляет записи регистра в наборе записей.

Свойства

<Имя измерения>

Использование:

Чтение и запись.

Описание:

Набор свойств содержит значения измерений регистра накопления. Имена свойств совпадают с именами измерений, как они заданы в конфигураторе.

<Имя реквизита>

Использование:

Чтение и запись.

Описание:

Набор свойств содержит значения реквизитов регистра накопления. Имена свойств совпадают с именами реквизитов, как они заданы в конфигураторе.

<Имя ресурса>

Использование:

Чтение и запись.

Описание:

Набор свойств содержит значения ресурсов регистра накопления. Имена свойств совпадают с именами ресурсов, как они заданы в конфигураторе.

Активность ( Active )

Использование:

Только чтение.

Описание:

Тип: Булево. Содержит флаг, определяющий влияние записи на итоги регистра накопления.

Если значение Ложь, то запись не учитывается в итогах регистра.

См. также:

РегистрНакопленияНаборЗаписей.<Имя регистра накопления>, метод УстановитьАктивность.

НомерСтроки ( LineNumber )

Использование:

Только чтение.

Описание:

Тип: Число. Содержит уникальный номер строки данной записи в списке записей по регистратору, указанному в значении свойства Регистратор.

Период ( Period )

Использование:

Чтение и запись.

Описание:

Тип: Дата. Содержит дату записи регистра накопления.

Приход ( Receipt )

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит флаг записи, обозначающий, что запись отражает увеличение ресурсов регистра. Если установить значение Истина, то значение свойства Расход будет установлено в Ложь. Если установить значение Ложь, то значение свойства Расход будет установлено в Истина.

Расход ( Expense )

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит флаг записи, обозначающий, что запись отражает уменьшение ресурсов регистра. Если установить значение Истина, то значение свойства Приход будет установлено в Ложь. Если установить значение Ложь то, значение свойства Приход будет установлено в Истина.

Регистратор ( Recorder )

Использование:

Только чтение.

Описание:

Тип: ДокументСсылка.<Имя документа>. Содержит документ, внесший запись регистра накопления.

Методы

МоментВремени ( PointOfTime )

Синтаксис:

МоментВремени()

Возвращаемое значение:

Тип: МоментВремени.

Описание:

Позволяет определить момент времени, соответствующий записи регистра.

РегистрНакопленияКлючЗаписи.<Имя регистра накопления> ( AccumumationRegisterRecordKey .< Имя регистра накопления>)

Набор значений, однозначно идентифицирующих запись регистра. Объект используется в тех случаях, когда необходимо сослаться на определенную запись. Например, он выступает в качестве значение свойства ТекущаяСтрока табличного поля, отображающего список записей регистра.

Важно! Данный объект нельзя использовать как устойчивый идентификатор записи, например, как ссылку для элементов справочника. Фактически имеет смысл только пока запись есть и не перезаписывалась.

Свойства

НомерСтроки ( LineNumber )

Использование:

Только чтение.

Описание:

Тип: Число. Содержит уникальный номер строки данной записи в списке записей по регистратору, указанному в значении свойства Регистратор.

Регистратор ( Recorder )

Использование:

Только чтение.

Описание:

Тип: ДокументСсылка. <Имя документа>. Содержит ссылку на документ, внесший запись регистра накопления.

Расширение колонки табличного поля списка записей регистра накопления

Дополнительные свойства колонки табличного поля списка записей регистра накопления.

Свойства

Данные ( Data )

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя колонки списка записей регистра накопления. Данное свойство позволяет указать, какие данные будут отображаться в ячейке табличного поля.

ДанныеФлажка ( CheckData )

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя колонки списка записей регистра накопления, значения которой будут отображаться флажком ячейки табличного поля. Колонка списка записей регистра накопления должна иметь тип Булево или Число.

ОтображатьСтандартнуюКартинку

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак отображения в колонке стандартной картинки, обозначающей запись регистра накопления и ее состояние.

Расширение колонки набора записей регистра накопления

Дополнительные свойства колонки табличного поля для набора записей регистра накопления.

Свойства

Данные ( Data )

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя колонки набора записей регистра накопления. Данное свойство позволяет указать, какие данные будут отображаться в ячейке табличного поля.

ДанныеФлажка ( CheckData )

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя колонки набора записей регистра накопления, значения которой будут отображаться флажком ячейки табличного поля. Колонка набора записей регистра накопления должна иметь тип Булево или Число.

ОтображатьСтандартнуюКартинку

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак отображения в колонке стандартной картинки, обозначающей запись регистра накопления и ее состояние.

Расширение табличного поля списка записей регистра накопления

Дополнительные свойства и методы табличного поля списка записей регистра накопления. Для данного расширения свойство ТекущаяСтрока табличного поля содержит значение типа РегистрНакопленияКлючЗаписи. Свойство ТекущиеДанные табличного поля содержит коллекцию значений данных строки, набор значений которой определяется колонками объекта РегистрНакопленияСписок.

Пример:

ОстаткиМПЗ = РегистрыНакопления.УчетНоменклатуры;

Форма = ОстаткиМПЗ.ПолучитьФормуСписка();

Список = Форма.ЭлементыФормы.Список;

Список.СтандартныйПериод.ВариантНастройки = ВариантНастройкиПериода.Период;

Список.СтандартныйПериод.ЗначениеПериода = ТекущаяДата();

Список.СтандартныйПериод.Вариант Периода = ВариантПериода.Месяц,Форма.Открыть();

Свойства

НастройкаОтбора ( FitterSeffing )

Использование:

Только чтение.

Описание:

Тип: Коллекция. Предоставляет доступ к настройкам отбора списка записей регистра накопления. Представляет собой коллекцию значений типа Управление элементом отбора. Свойства коллекции содержат объекты для управления элементом отбора. Имена свойств совпадают с именами доступных для регистра накопления элементов отбора.

НастройкаПорядка ( OrderSetting )

Использование:

Только чтение.

Описание:

Тип: Коллекция. Предоставляет доступ к настройкам порядка списка записей регистра накопления. Представляет собой коллекцию значений типа Управление элементом порядка. Свойства коллекции содержат объекты для управления элементом порядка. Имена свойств совпадают с именами доступных для регистра накопления элементов упорядочивания.

СтандартныйПериод ( StandartPeriod )

Использование:

Чтение и запись.

Описание:

Тип: НастройкаПериода. Содержит объект НастройкаПериода, в соответствии с которым осуществляется настройка периода списка записей при открытии формы, содержащей данное табличное поле.

См. также:

НастройкаПериода.

Расширение формы списка записей регистра накопления

Предоставляет доступ к дополнительным свойствам формы, в том случае если основным реквизитом формы является список записей регистра накопления.

Пример:

Приходные = Документы.ПриходнаяНакладная;

Док = Приходные.НайтиПоНомеру ("0003",ТекущаяДата());

ОстаткиМПЗ = РегистрыНакопления.УчетНоменклатуры;

Форма = ОстаткиМПЗ.ПолучитьФормуСписка();

Форма.ПараметрОтборПоРегистратору = Док;

Форма.Открыть();

Свойства

ПараметрОтборПоРегистратору ( FilterByRecorderParameter )

Использование:

Чтение и запись.

Описание:

Тип: ДокументСсылка. <Имя документа>. Предоставляет возможность установить начальное значение отбора по регистра- -тору при открытии или повторном открытии формы списка регистра накопления.

Расширение табличного поля набора записей регистра накопления

Дополнительные свойства и методы табличного поля набора записей регистра сведений. Для данного расширения свойства ТекущаяСтрока и ТекущиеДанные табличного поля содержат значение типа РегистрНакопленияЗапись.

Свойства

ОбновлятьПриИзмененииОтбора ( UpdateOnFilterChange )

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак автоматического обновления набора записей при изменении параметров отбора. Если значение

данного свойства установлено в Ложь, то при изменении параметров отбора обновления не произойдет.

Расширение формы набора записей регистра накопления

Предоставляет доступ к дополнительным методам формы, в том случае если основным реквизитом формы является набор записей регистра накопления.

Методы

ЗаписатьВФорме ( WritelnForm )

Синтаксис:

ЗаписатьВФорме()

Возвращаемое значение:

Тип: Булево. Истина - объект записан.

Ложь - нет.

Описание:

Позволяет записать объект, открытый в форме.

Пример:

Если ЗаписатьВФорме() Тогда

Сообщить("Объект записан.");

КонецЕсли;

События

ПередЗаписью ( BeforeWrite )

Синтаксис:

ПередЗаписью(< Отказ>)

Параметры:

<Отказ>

Тип: Булево. Признак отказа от записи объекта. Если в теле процедуры-обработчика установить данному параметру значение Истина, то запись объекта выполнена не будет.

Описание:

Событие возникает перед выполнением записи набора. Процедура-обработчик вызывается перед началом транзакции записи объекта.

ПриЗаписи ( OnWrite )

Синтаксис:

ПриЗаписи(< Отказ>)

Параметры:

<Отказ>

Тип: Булево. Признак отказа от записи объекта. Если в теле процедуры-обработчика установить данному параметру значение Истина, то запись объекта выполнена не будет.

Описание:

Событие возникает при записи набора. Процедура-обработчик вызывается после записи объекта, но до окончания транзакции записи.

ПослеЗаписи ( AfterWrite )

Синтаксис:

ПослеЗаписи()

Описание:

Событие возникает после окончания транзакции записи набора.


Критерии отбора

Критериями отбора задаются предопределенные правила, по которым может выполняться отбор документов в списках и журналах документов, элементов справочников в списках справочников.

Критерии отбора могут иметь одну или несколько форм для визуального представления результатов отбора.

Настройка критериев отбора производится на этапе конфигурирования прикладной задачи.

КритерииОтбораМенеджер ( FiltersManager )

Объект предназначен для управления критериями отбора и предоставляет доступ к значениям типа КритерииОтбораМенеджер. Доступ к объекту осуществляется через свойство глобального контекста КритерииОтбора.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа КритерииОтбораМенеджер.<Имя критерия> Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции.

Пример:

ФормаОтб = КритерииОтбора.Контрагенты.ПолучитьФорму("ОсновнаяФорма");

См. также:

Глобальный контекст, свойство КритерииОтбора.

Свойства

<Имя критерия отбора>

Использование;

Только чтение.

Описание:

Тип КритерииОтбораМенеджер. <Имя критерия;-. Набор свойств содержит менеджеры отдельных критериев отбора. Имена свойств совпадают с именами критериев отбора, как они заданы в конфигураторе.

КритерииОтбораМенеджер. < Имя критерия>

Предназначен для управления критерием отбора, как объектом конфигурации. С помощью этого объекта можно получить ссылки на объекты, отобранные по критерию и работать с формами конкретного критерия отбора. Доступ к объекту осуществляется через свойство объекта КритерииОтбораМенеджер.

Полное имя типа объекта определяется с учетом имени критерия отбора конфигурации. Например, для критерия отбора Контрагенты имя типа будет выглядеть КригерийОтбораМенеджер.Контрагенты.

Методы

Найти ( Find )

Синтаксис:

Найти(<Значение поиска> )

Параметры:

<3начение поиска> Обязательный

Значение, по которому будет выполняться поиск. Тип значения должен соответствовать типу критерия отбора.

Возвращаемое значение:

Тип: Массив. Массив ссылок на объекты, в которых используется указанное значение отбора.

Описание:

Позволяет найти объекты информационной базы, входящие в состав отбора, в которых использовано указанное значение отбора.

Примечание:

Состав объектов метаданных, входящих в состав отбора, задается при конфигурировании.

Пример:

МассивСсылок = КритерииОтбора.Контрагенты.Найти(ВыбКонтрагент);

Для Каждого Ссылка Из МассивСсылок Цикл Сообщить(Ссылка);

КонецЦикла;

ПолучитьФорму ( GetForm )

Синтаксис:

ПолучитьФорму (< Форма> . <Владелец> , <Ключ уникальности>}

Параметры:

<Форма> Необязательный

Тип: Строка, Объект описания метаданного. Имя формы, как оно задано в конфигураторе или объект описания метаданного требуемой формы.

Значение по умолчанию: Если параметр не указан, то используется основная форма, заданная в конфигураторе.

<Владелец> Необязательный

Тип: Форма. Форма, которая будет являться владельцем открываемой формы.

<Ключ уникальности> Необязательный

Тип: Произвольный. В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована она.

Значение по умолчанию: Если параметр не указан, сначала всегда будет искаться уже открытая форма.

Возвращаемое значение:

Тип: Форма.

Описание:

Позволяет получить форму журнала документов.

КритерийОтбораСписок.<Имя критерия>

Предназначен для управления списком отобранных документов и/или элементов справочников, отображаемых в табличном поле (списком критерия отбора).

Свойства

Отбор ( Filter )

Использование:

Чтение и запись.

Описание:

Тип: Отбор. Содержит объект Отбор, по которому осуществляется текущая фильтрация списка критерия отбора.

Данный отбор состоит из одного элемента отбора ЗначениеОтбора ( SelectValue ), при помощи которого можно фильтровать документы и элементы справочников в списке критерия отбора.

Методы

Обновить ( Refresh )

Синтаксис:

Обновить()

Описание:

Вызывает перечитывание данных списка.

Расширение формы критерия отбора

Дополнительные свойства формы, связанной со списком критерия отбора.

Свойства

ПараметрОтборПоЗначению

Использование:

Только чтение.

Описание:

Содержит параметр, используемый для передачи форме значения отбора.

Расширение табличного поля списка критерия отбора

Дополнительные методы табличного поля списка критерия отбора. Для данного расширения свойства ТекущаяСтрока, ТекущиеДанные табличного поля содержат значения типа: Любая ссылка на объект ИБ.


Последовательности

Последовательности предназначены обеспечения проведения документов в непрерывной хронологической последовательности. Последовательность может иметь измерения, в разрезе которых можно контролировать и поддерживать последовательность проведения документов. Существует также доступ к записям регистрации отдельных документов в последовательности.

Последовательности Менеджер ( SequencesManager )

Объект предназначен для управления последовательностями и предоставляет доступ к значениям типа ПоследовательностьМенеджер. Объект также позволяет восстанавливать сразу несколько последовательностей. Доступ к объекту осуществляется через свойство глобального контекста Последовательности.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа ПоследовательностьМенеджер.<Имя последовательности>. Для объекта доступен обход коллекции посредством оператора Для каждого ... из... Цикл. При обходе выбираются элементы коллекции.

Свойства

<Имя последовательности>

Использование:

Только чтение.

Описание:

Тип: ПоследовательностьМенеджер.<Имя последовательности>. Набор свойств содержит менеджеры отдельных последовательностей. Имена свойств совпадают с именами последовательностей, как они заданы в конфигураторе.

Методы

Восстановить ( Restore )

Синтаксис:

Восстановить (< Момент времени>, <Последовательности>)

Параметры:

<Момент времени> Необязательный

Тип: Дата, Момент Времени. Момент времени, на который восстанавливаются последовательности.

Значение по умолчанию: Неопределено.

<Последовательности> Необязательный

Тип: ТаблицаЗначений. Набор последовательностей, которые необходимо восстановить. Задается таблицей значений, состоящей из двух колонок. Первая колонка должна содержать значение, идентифицирующее последовательность: строку - имя последовательности, как оно задано в конфигураторе, либо объект описания метаданного последовательности. Вторая колонка должна содержать набор комбинаций значений измерений последовательности, которые надо восстанавливать в данной последовательности. Этот набор задается как таблица значений, в колонках которой содержатся соответствующие значения измерений. Имена колонок должны соответствовать именам измерений последовательности. Если набор комбинаций не указан, то будет восстановлена вся последовательность.

Значение по умолчанию: Неопределено.

Описание:

Позволяет восстановить указанные последовательности на заданный момент времени. Для каждой последовательности можно задать комбинации значений измерений, по которым нужно восстанавливать последовательность. При этом будут перепроведены все документы, входящие в указанные последовательности по заданным измерениям.

Пример:

ТабПоследовательностей = Новый ТаблицаЗначений;

ТабПоследовательностей.Колонки.Добавить("ИмяПоследовательности");

ТабПоследовательностей.Колонки.Добавить("НаборКомбинаций") ;

ПустаяТаблица = Новый ТаблицаЗначений;

Стр = ТабПоследовательностей.Добавить();

Стр.ИмяПоследовательности = "УчетТоваров" ;

Стр.НаборКомбинаций = ПустаяТаблица;

Последовательности.Восстановить(РабочаяДата, ТабПоследовательностей);

ПоследовательностьМенеджер.<Имя последовательности> ( SequenceManager .< Имя последовательности>)

Предназначен для управления последовательностью, как объектом конфигурации. С помощью этого объекта можно получать и устанавливать границы последовательности, проверять принадлежность документа последовательности, проверять непрерывность последовательности по определенный момент времени, а также восстанавливать последовательность.

Доступ к объекту осуществляется через свойство объекта ПоследовательностиМенеджер. Полное имя типа объекта определяется с учетом имя последовательности в конфигурации.

Например, для последовательности УчетТоваров имя типа будет выглядеть ПоследовательностиМенеджер.УчетТоваров.

Методы

Восстановить ( Restore )

Синтаксис:

Восстановить (<Момент времени> , <Отбор>)

Параметры:

<Момент времени> Необязательный

Тип: Дата, Момент Времени. Момент времени, по который восстанавливается последовательность.

Значение по умолчанию: Если параметр не указан, то восстанавливать последовательность до последнего принадлежащего ей документа.

<Отбор> Необязательный

Тип: ТаблицаЗначений. Набор комбинаций значений измерений, которые надо восстанавливать в данной последовательности. Задается как таблица значений, в колонках которой содержатся соответствующие значения измерений. Имена колонок должны соответствовать именам измерений последовательности. Если набор комбинаций не указан, то будет восстановлена вся последовательность.

Значение по умолчанию: Если не указан, то по всем измерениям. Описание:

Позволяет восстановить последовательность по заданный момент времени по заданным измерениям. При этом будут перепроведены все документы, входящие в последовательность по заданным измерениям.

Пример:

Момент = Новый МоментВремеяи(Док.Дата, Док.Ссылка);

Отбор = Новый ТаблицаЗначений;

Отбор.Колонки.Добавить("Товар");

Отбор.Добавить().Товар = Товар;

Последовательности.УчетТоваров.Восстановить(Момент, Отбор);

ПолучитьГраницу ( GetBoundary )

Синтаксис:

ПолучитьГраницу (< Отбор> )

Параметры:

<Отбор> Необязательный

Тип: Структура. Структура, задающая отбор по измерениям последовательности. Ключ структуры определяет измерение последовательности, по которому будет осуществляться отбор, а значение структуры - значение измерения.

Если измерение отсутствует в структуре, то по нему отбор осуществляться не будет.

Значение по умолчанию: Если параметр не указан, то по всем значениям измерений.

Возвращаемое значение:

Тип: МоментВремени. Момент времени, соответствующий минимальной границе последовательности.

Описание:

Позволяет получить минимальную границу последовательности по заданным значениям измерений.

Пример:

Отбор = Новый Структура ("Товар");

Отбор.Вставить("Товар", ТекТовар) ;

ГП = Последовательности.УчетТоваров.ПолучитьГраницу(Отбор);

ПолучитьГраницы ( GetBoundaries )

Синтаксис:

ПолучитьГраницы (< Разрез> , <Отбор> )

Параметры:

<Разрез> Обязательный

Тип: Строка. Имена измерений последовательности, по которым нужно получить границы, перечисленные через запятую.

<Отбор> Необязательный

Тип: ТаблицаЗначений. Набор комбинаций значений измерений, по которым надо получить границы. Задается как таблица значений, в колонках которой содержатся соответствующие значения измерений. Имена колонок должны соответствовать именам измерений последовательности. Если значения измерений не указаны, то по всем значениям измерений.

Значение по умолчанию: Если параметр не указан, то по всем значениям измерений.

Возвращаемое значение:

Тип: ТаблицаЗначений. Таблица значений, в первой колонке которой содержится момент времени границы, а в последующих -значения измерений, в разрезе которых выбирались границы.

Описание:

Позволяет получить границы последовательности в разрезе заданных измерений последовательности и с отбором по заданным значениям измерений последовательности.

Пример:

Отбор = Новый ТаблицаЗначений;

Отбор.Колонки.Добавить("Товар");

Разрез = "Товар";

Последов = Последовательности.УчетТоваров;

ТабГраницы = Последов.ПолучитьГраницы(Разрез, Отбор);

Принадлежит (Belong)

Синтаксис:

Принадлежит(< Документ>, <Отбор>)

Описание

<Документ> Обязательный

Тип: ДокументСсылка. <Имя документа>. Проверяемый документ.

<Отбор> Необязательный

Тип: Структура. Структура, задающая отбор по измерениям последовательности. Ключ структуры определяет измерение последовательности, по которому будет осуществляться отбор, а значение структуры - значение измерения. Если измерение отсутствует в структуре, то по нему отбор осуществляться не будет.

Возвращаемое значение;

Тип: Булево.

Описание:

Позволяет проверить, принадлежит ли указанный документ последовательности с заданными измерениями.

Пример:

Отбор = Новый Структура;

Отбор.Вставить("Товар", ТекТовар);

Принадлежит = Последовательности.УчетТоваров.Принадлежит(Док, Отбор);

Проверить ( Validate )

Синтаксис:

Проверить(<Момент времени>, <Отбор>)

Параметры:

<Момент времени> Обязательный

Тип: Дата, Момент Времени. Момент времени, по который проверяется последовательность.

<Отбор> Обязательный

Тип: Структура. Структура, задающая отбор по измерениям последовательности. Ключ структуры определяет измерение последовательности, по которому будет осуществляться отбор, а значение структуры - значение измерения.

Если измерение отсутствует в структуре, то по нему отбор осуществляться не будет.

Возвращаемое значение:

Тип: Булево. Истина - последовательность не нарушена, Ложь - последовательность нарушена.

Описание:

Проверяет, что по указанный момент времени последовательность по заданным измерениям не нарушена.

Пример:

Момент = Новый МоментВремени(Док.Дата, Док.Ссылка);

Отбор = Новый Структура;

Отбор.Вставить("Товар", Товар) ;

Непрерывна = Последовательности.УчетТоваров.Проверить(Момент, Отбор) ;

УстановитьГраницу ( SetBoundary )

Синтаксис:

УстановитьГраницу (< Момент времени> , <Отбор>)

Параметры:

<Момент времени> Обязательный

Тип: МоментВремени, Дата. Момент времени, на который устанавливается граница последовательности.

<Отбор> Обязательный

Тип: Структура. Структура, задающая отбор по измерениям последовательности. Ключ структуры определяет измерение последовательности, по которому будет осуществляться отбор, а значение структуры - значение измерения.

Описание:

Позволяет установить границу последовательности по заданным значениям измерений.

Пример:

Отбор = Новый Структура ("Товар");

Отбор.Вставить("Товар", ТекТовар) ;

Последовательности.УчетТоваров.УстановитьГраницу(ТекМомент, Отбор) ;

Последовательность3апись.< Имя последовательности ( SequenceRecord .< Имя последовательности >)

Представляет собой запись регистрации документа в последовательности.

Свойства

<Имя измерения>

Использование:

Чтение и запись.

Описание:

Набор свойств содержит значения измерений последовательности, с которыми документ зарегистрирован в последовательности. Имена свойств совпадают с именами измерений последовательности, как они заданы в конфигураторе.

ПоследовательностьНаборЗаписей.<Имя последовательности>

Представляет собой набор записей регистрации документа в последовательности. Этот набор формируется автоматически при записи документа по заданным соответствиям реквизитов документа и измерениям последовательности. Объект позволяет считывать набор записей регистрации из информационной базы, добавлять, удалять и модифицировать записи в наборе, записывать набор.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа ПоследовательностьЗапись.<Имя последовательности;-. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции.. Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс элемента.

См. также:

ДокументОбъект. <Имя документа>, свойство ПринадлежностьПоследовательностям.

Свойства

Регистратор ( Recorder )

Использование:

Только чтение.

Описание:

Тип: ДокументСсылка. <Имя документа>. Содержит регистратор, с которым связан данный набор записей последовательности.

Методы

Добавить ( Add )

Синтаксис:

Добавить()

Возвращаемое значение:

Тип: ПоследовательностьЗапись.<Имя последовательности>. Запись регистрации документа в последовательности.

Описание:

Добавляет новую запись регистрации документа в набор.

Записать ( Write )

Синтаксис:

Записать()

Описание:

Позволяет записать набор записей регистрации документа в информационную базу.

Индекс ( IndexOf )

Синтаксис:

Индекс(< Запись>)

Параметры:

<3апись> Обязательный

Тип: ПоследовательностьЗапись.<Имя последовательности>. Запись, индекс которой необходимо получить.

Возвращаемое значение:

Тип: Число. Индекс указанной записи в наборе.

Описание:

Получает индекс указанной записи в наборе.

Количество ( Count )

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество записей регистрации в наборе.

Описание:

Получает количество записей регистрации в наборе.

Модифицированность ( Modified )

Синтаксис:

Модифицированность()

Возвращаемое значение:

Тип: Булево.

Описание:

Проверяет, был ли модифицирован набор записей после последнего считывания или записи.

Очистить ( Clear )

Синтаксис:

Очистить()

Описание:

Удаляет все записи регистрации из набора.

Прочитать ( Read )

Синтаксис:

Прочитать()

Описание:

Позволяет прочесть набор записей регистрации документа из информационной базы.

Удалить ( Remove )

Синтаксис:

Удалить(< Запись>)

Параметры:

<Запись> Обязательный

Тип: Число или ПоследовательностьЗапись. Удаляемая из набора запись. Может быть указан индекс записи в наборе или сама запись.

Описание:

Удаляет указанную запись регистрации документа из набора.


Универсальные объекты

Табличная часть

Табличные части предназначены для хранения наборов однородной информации, принадлежащих объекту (справочнику, документу, отчету или обработке) и не используемых самостоятельно. Строки табличной части не являются самостоятельными объектами базы данных, доступ к ним осуществляется только при помощи индекса строки в табличной части объекта.

Табличные части обычно имеют визуальное представление в виде элемента управления ТабличноеПоле.

Примером использования табличной части может быть многострочная часть документа, каждая строка которой содержит одинаковый набор реквизитов. Например, в документе "Заказ" - таблица, содержащая перечень товаров и услуг с указанием количества, стоимости, налогов и т.д.

Табличная часть

Используется для доступа к методам табличной части в целом.

Данный объект является коллекцией значений. В качестве элемента коллекции выступает значение типа Строка табличной части. Для объекта доступен обход коллекции посредством оператора Для каждого ... из ... Цикл. При обходе выбираются элементы коллекции. Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс строки.

Методы

Вставить ( Insert )

Синтаксис:

Вставить(<Индекс>)

Параметры:

<Индекс> Обязательный

Тип: Число. Индекс позиции в табличной части, в которую необходимо вставить строку.

Возвращаемое значение:

Тип: Строка табличной части. Вставленная строка.

Описание:

Вставляет в табличную часть строку с указанным индексом.

Пример:

Ответы.Вставить(1);

Выгрузить ( Unload )

Синтаксис:

Выгрузить()

Возвращаемое значение:

Тип; ТаблицаЗначений. Таблица значений, содержащая строки табличной части. Имена колонок таблицы значений совпадают с именами колонок табличного поля. Колонка, содержащая номер строки, выгружается в колонку с именем НомерСтроки.

Описание;

Выгружает табличную часть в таблицу значений.

Пример:

ТаблицаСостава = Состав.Выгрузить();

ВыгрузитьКолонку ( UnloadColumn )

Синтаксис:

ВыгрузитьКолонку(< Колонка>)

Параметры:

<Колонка> Обязательный

Тип- Число, Строка. Колонка, из которой нужно выгрузить значения. В качестве значения параметра может быть передан индекс колонки, имя колонки.

Возвращаемое значение:

Тип: Массив. Массив, содержащий значения колонки.

Описание:

Выгружает значения, содержащиеся в колонке табличной части в массив.

Примечание:

Значения из колонки выгружаются в порядке индексов строк в табличной части.

Пример:

Товары = Состав.ВыгрузитьКолонку("Номенклатура");

Добавить ( Add )

Синтаксис:

Добавить()

Возвращаемое значение:

Тип: Строка табличной части. Добавленная строка.

Описание:

Добавляет строку в конец табличной части.

Пример:

Состав.Добавить();

Загрузить ( Load )

Синтаксис:

Загрузить (< Таблица> )

Параметры:

<Таблица> Обязательный

Тип: ТаблицаЗначений. Таблица значений, откуда загружается табличная часть. Колонки таблиц совмещаются по именам.

Описание:

Загружает табличную часть из таблицы значений. При этом все прежние строки табличной части удаляются. При загрузке значения в колонках табличной части заполняются значениями из колонок таблицы значений с совпадающими именами.

Пример:

Состав.Загрузить(ТаблицаСостава);

ЗагрузитьКолонку ( LoadColumn )

Синтаксис:

ЗагрузитьКолонку (< Массив>, <Колонка>)

Параметры:

<Массив> Обузательный

Тип: Массив. Массив значений для загрузки в колонку.

<Колонка> Обязательный

Тип: Число, Строка. Колонка, в которую будут загружены значения из массива.

В качестве значения параметра может быть передан индекс колонки, либо имя колонки.

Описание:

Загружает значения из массива в заданную колонку табличной части.

Примечание:

Значения из массива загружаются в колонку в порядке индексов.

Пример:

Состав.ЗагрузитьКолонку(Товары, "Номенклатура") ;

Индекс ( IndexOf )

Синтаксис:

Индекс(< Строка>)

Параметры:

<Строка> Обязательный

Тип: Строка табличной части- Строка табличной части, для которой необходимо получить индекс.

Возвращаемое значение:

Тип: Число. Индекс строки.

Описание:

Получает индекс стоки в табличной части.

Пример:

ИндексТекСтроки = Состав.Индекс(ЭлементыФормы.Состав.ТекущаяСтрока);

Итог (Total)

Синтаксис:

Итог (<Колонка> )

Параметры:

<Колонка> Необязательный

Тип; Число, Строка. Индекс либо имя колонки, по которой подсчитывается итог.

Возвращаемое значение:

Тип: Число.

Описание:

Суммирует значения всех строк в указанной колонке.

Примечание:

Имеет смысл для числовых значений.

Пример:

ВсегоПоДокументу = Сумма.Итог("Всего");

Количество ( Count )

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество строк табличной части.

Описание:

Позволяет получить количество строк табличной части.

Пример:

ВсегоСтрок = Состав.Количество();

Найти ( Find )

Синтаксис:

Найти(< Значение>, <Колонки>)

Параметры:

<3начение> Обязательный

Тип: Произвольный. Искомое значение.

<Колонки> Необязательный

Тип: Строка. Список имен колонок, в которых будет осуществляться поиск, разделенных запятыми.

Значение по умолчанию: Если параметр не указан или передана пустая строка, поиск осуществляется по всей таблице.

Возвращаемое значение:

Тип: Строка табличной части. Строка, которая содержит искомое значение. Если значение не найдено возвращает значение Неопределено

Описание:

Позволяет найти значение в указанных колонках табличной части. Если список колонок пуст, поиск осуществляется по всей табличной части.

Примечание:

Метод эффективно использовать для поиска уникальных значений.

Пример:

НайдСтрока = Состав.Найти(ТекТовар, "Номенклатура');

Если НайдСтрока = Неопределено Тогда

Предупреждение("Товар не найден !");

Иначе

Количество = НайдСтрока.Количество;

КонецЕсли;

НайтиСтроки ( FindRows )

Синтаксис:

НайтиСтроки (< Параметры отбора>)

Параметры:

<Параметры отбора> Обязательный

Тип: Структура. Задает условия поиска: ключ структуры определяет имя колонки, по которой будет осуществляться поиск, а значение структуры - искомое значение.

Возвращаемое значение:

Тип: Массив. Массив из строк табличной части, соответствующих заданному условию поиска.

Замечание! Массив хранит ссылки на строки табличной части, то есть при изменении строки в табличной части, значение в массиве тоже будет изменено.

Описание:

Позволяет найти строки табличной части, соответствующие заданному условию поиска.

Примечание:

Метод эффективно использовать для выборки неуникальных значений.

Пример:

ПараметрыОтбора = Новый Структура;

ПараметрыОтбора.Вставить("Номенклатура", ТекТовар);

НайдСтроки = Состав.НайтиСтроки(ПараметрыОтбора);

Очистить ( Clear )

Синтаксис:

Очистить ()

Описание:

Удаляет все строки табличной части.

Пример:

Состав.Очистить();

Свернуть ( GroupBy )

Синтаксис:

Свернуть(<Колонки группировок, <Колонки суммирования>)

Параметры:

<Колонки группировок> Обязательный

Тип: Строка. Имена колонок, разделенные запятыми, по которым необходимо группировать строки табличного поля.

<Колонки суммирования> Необязательный

Тип: Строка. Имена колонок, разделенные запятыми, по которым необходимо суммировать значения в строках табличного поля.

Описание:

Осуществляет свертку табличной части по указанным колонкам группировки. Строки, у которых совпадают значения в колонках, указанных в первом параметре, сворачиваются в одну строку. Значения этих строк, хранящиеся в колонках, указанных во втором параметре, накапливаются.

Важно! Оба списка колонок должны покрывать всю табличную часть. Списки колонок не должны пересекаться.

Пример:

Состав.Свернуть("Номенклатура", "Количество, Сумма, Всего"');

Сдвинуть ( Move )

Синтаксис:

Сдвинуть(< Строка>, <Смещение>)

Параметры:

< Строка> Обязательный

Тип: Число, Строка табличной части. Индекс строки, которую нужно сдвинуть, либо сама сдвигаемая строка.

<Смещение> Обязательный

Тип: Число. Количество строк, на которое необходимо переместить строку. Положительное значение означает, что строка будет передвинута ближе к концу табличной части (вниз), отрицательное - ближе к началу (вверх).

Описание:

Позволяет переместить строку табличной части на указанное количество позиций.

Пример:

// сдвиг 2-й строки на предыдущую позицию

Состав.Сдвинуть(1, -1);

// сдвиг 2-й строки на следующую позицию

Состав.Сдвинуть(1, 1);

Удалить ( Remove )

Синтаксис:

Удалить(< Индекс>)

Параметры:

<Индекс> Обязательный

Тип: Число, Строка табличной части. Индекс удаляемой строки в табличной части, либо сама удаляемая строка.

Описание:

Удаляет строку с указанным индексом из табличной части.

Пример:

Состав.Удалить(3);

Строка табличной части

Используется для доступа к свойствам и методам строки табличной части.

Свойства

<Имя колонки>

Использование:

Чтение и запись.

Описание:

Набор свойств содержит значения в колонках строки табличной части. Имена свойств совпадают с именами колонок табличной части.

Расширение табличного поля табличной части

Для данного расширения свойства ТекущаяСтрока и ТекущиеДанные табличного поля имеют значения типа Строка табличной части.

Расширение колонки табличного поля табличной части

Дополнительные свойства колонки табличного поля, связанного с табличной частью.

Свойства

Данные ( Data )

Использование:

Чтение и запись.

Описание:

Тип: Строка. Содержит имя колонки табличной части, значения которой будут отображаться и редактироваться в ячейке табличного поля.

ДанныеФлажка ( CheckData )

Использование:

Чтение и запись.

Описание:

Тип- Строка. Содержит имя колонки табличной части, значения которой будут отображаться и редактироваться во флажке ячейки

табличного поля.

Примечание:

Применяется для колонок табличной части булевого и числового типа.

ОтображатьИтогиВПодвале (ShowTotalsInFooter)

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак показа итогов по колонке в подвале табличного поля.

Примечание:

Данное свойство доступно для колонок, имеющих числовой тип.

Отбор

Отбор

Используется для установки и хранения условий фильтрации элементов в списках и наборах записей. Отбор элементов в списках помогает, если необходимо выбрать элементы по определенному критерию из большого списка элементов.

Отбор представляет собой коллекцию элементов отбора. Используется для управления элементами отбора, доступными для данного списка набора записей. Каждый из элементов может устанавливать одно условие. Весь объект представляет собой составное условие, состоящее из отдельных условий, описываемых элементами, соединяющимися по "И".

Свойства

<Имя элемента отбора>

Использование:

Только чтение.

Описание:

Тип: Элемент отбора. Набор свойств содержит элементы отбора, установленные для данного отбора. Имена свойств совпадают с именами полей отбора для данного отбора.

Методы

Сбросить ( Reset )

Синтаксис:

Сбросить()

Описание:

Отключает признак использования отбора у всех элементов отбора.

Пример:

СправочникСписок.Отбор.Сбросить();

См. также:

Элемент отбора, свойство Использование.

Элемент отбора

Используется для управления параметрами отбора по одному элементу отбора.

Свойства

ВидСравнения ( ComparisonKind )

Использование:

Чтение и запись.

Описание:

Тип: ВидСравнения. Содержит способ сравнения, используемый при фильтрации по элементу отбора.

При определении значения свойства используется системное перечисление ВидСравнения ( ComparisonKind).

Значение ( Value )

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Содержит значение, по которому будет осуществляться фильтрация.

ЗначениеПо ( ValueTo )

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Содержит правое значение сравнения, если в качестве вида сравнения используется интервал.

ЗначениеС ( ValueFrom )

Использование:

Чтение и запись.

Описание:

Тип: Произвольный. Содержит левое значение сравнения, если в качестве вида сравнения используется интервал.

Использование ( Usage )

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак использования элемента отбора в фильтре. Если свойство имеет значение Истина, то будет выполняться фильтрация по данному элементу отбора, иначе элемент отбора не будет участвовать в фильтрации.

Методы

Установить ( Set )

Синтаксис:

Установить (< Значение> , <Использование> )

Параметры:

<3начение> Необязательный

Тип Произвольный. Значение сравнения.

<Использование> Необязательный

Тип Булево. Признак использования отбора по значению. Значение по умолчанию: Истина.

Описание:

Устанавливает значение отбора и флаг использования. При выполнении данного метода вид сравнения устанавливается в значение Равно.

Примечание:

Метод имеет смысл применять, если необходимо установить и значение и использование отбора.

Управление элементом отбора

Предназначен для управления доступностью интерактивного изменения условий отбора.

Свойства

Доступность ( Enable )

Использование:

Чтение и запись.

Описание:

Тип: Булево. Содержит признак доступности интерактивного изменения условий отбора.

Имя (Name)

Использование:

Только чтение.

Описание:

Тип: Строка. Имя элемента управления элементом отбора. Совпадает с именем свойства в коллекции элементов управления отбором.

Порядок

Порядок предназначен для упорядочивания элементов в списках справочников, документов, журналов, регистров.

Порядок

Используется для установки и хранения упорядочивания данных в различных списках.

Методы

Индекс (IndexOf)

Синтаксис:

Индекс(<ЭлементПорядка>)

Параметры:

<ЭлементПорядка> Обязательный

Тип: ЭлементПорядка. Элемент порядка, индекс которого требуется определить.

Возвращаемое значение:

Тип: Число. Индекс в коллекции указанного элемента порядка. Если такого нет, возвращает -1.

Количество (Count)

Синтаксис:

Количество()

Возвращаемое значение:

Тип: Число. Количество входящих в коллекцию элементов порядка.

Очистить (Clear)

Синтаксис:

Очистить()

Описание:

Очищает все признаки упорядочивания

Установить (Set)

Синтаксис:

Установить(<Строка порядка>)

Параметры:

<Строка порядка> Необязательный

Тип: Строка. Список имен полей, разделенных запятыми, по которым производится упорядочивание. После каждого имени поля через пробел может быть указано направление сортировки. Направление определяется: "Убыв" ("Desc") - упорядочивать по убыванию; "Возр" ("Asc") - упорядочивать по возрастанию. По умолчанию упорядочивание производится по возрастанию. Порядок указания имен полей определяет порядок выполнения упорядочивания. Это означает, что будет выполняться упорядочивание по полю, указанному первым. Затем группы строк с одинаковым значением в этом поле упорядочиваются по полю, которое указано вторым, и так далее.

Описание:

Устанавливает упорядочивание по заданным полям в выбранном направлении.

Пример:

СписокСправочника.Порядок.Установить("Код Убыв, Наименование Возр");

Элемент порядка
Свойства

Данные (Data)

Использование:

Только чтение.

Описание:

Тип: Строка. Имя данных, используемых в установке порядка.

Направление (Direction)

Использование:

Только чтение.

Описание:

Тип: НаправлениеСортировки. Направление сортировки (возрастание или убывание

Методы

Установить (Set)

Синтаксис:

Установить(<Значение>, <Использование>)

Параметры:

<Значение> Обязательный

Тип: Произвольный. Значение сравнения.

<Использование> Необязательный

Тип: Булево. Признак использования отбора по значению.

Значение по умолчанию: Истина.

Описание:

Устанавливает значение отбора и флаг использования. При выполнении данного метода вид сравнения устанавливается в значение Равно.

Примечание:

Метод имеет смысл применять, если необходимо установить и значение и использование отбора.

Управление элементом порядка

Предназначен для управления доступностью интерактивного изменения порядка сортировки.

Свойства

Доступность ( Enable )

Использование:

Чтение и запись.

Описание:

Тип Булево. Содержит признак доступности интерактивного изменения порядка сортировки.

Имя (Name)

Использование:

Только чтение.

Описание:

Тип: Строка. Имя элемента управления элементом порядка. Совпадает с именем свойства в коллекции элементов управления порядком

НастройкаПериода ( PeriodSetting)

Предназначен для ввода периодов. При помощи объекта можно настраивать интервалы просмотра в различных хронологических списках.

Свойства

ВариантНастройки ( SettingMode )

Использование:

Только запись.

Описание:

Тип: ВариантНастройкиПериода. Определяет закладку, на которой будет открыт диалог редактирования периода.

При определении значения свойства используется системное перечисление ВариантНастройкиПериода ( PeriodSettingVariant).

ВариантНачала ( BeginningVariant)

Использование:

Чтение и запись.

Описание:

Тип: ВариантГраницыИнтервала. Определяет вариант начала периода.

При определении значения свойства используется системное перечисление ВариантГраницыИнтервала ( RangeBorderVariant).

Вариант-Окончания ( EndingVariant )

Использование:

Чтение и запись.

Описание:

Тип ВариантГраницыИнтервала. Определяет вариант окончания периода.

При определении значения свойства используется системное перечисление ВариантГраницыИнтервала ( RangeBorderVariant).

ВариантПериода ( PeriodVariant )

Использование:

Чтение и запись.

Описание:

Тип ВариантПериода. Содержит вариант периода настраиваемого интервала.

При определении значения свойства используется системное перечисление ВариантПериода ( PeriodVariant).

ДатаНачала ( DateFrom )

Использование:

Чтение и запись.

Описание:

Тип: Дата. Содержит дату начала периода.

Примечание:

Имеет смысл, если свойство ВариантНачала имеет значение КонкретнаяДата.

ДатаОкончания ( DateTo )

Использование:

Чтение и запись.

Описание:

Тип: Дата. Содержит дату окончания периода.

Примечание:

Имеет смысл, если свойство ВариантОкончания имеет значение КонкретнаяДата.

ЗначениеПериода ( PeriodValue )

Использование:

Чтение и запись.

Описание:

Тип: Дата. Дата периода настраиваемого интервала. От этой даты будет отсчитываться период, если задано значение свойства ВариантПериода.

РедактироватьКакИнтервал ( EditAslnterval )

Использование:

Чтение и запись.

Описание:

Тип: Булево. Определяет видимость закладки "Интервал" в диалоге для визуальной настройки периода.

РедактироватьКакПериод ( EditAsPeriod )

Использование:

Чтение и запись.

Описание:

Тип: Булево. Определяет видимость закладки "Период" в диалоге для визуальной настройки периода.

СмещениеНачала ( BeginningShift )

Использование;

Чтение и запись.

Описание:

Тип: Число. Количество дней до рабочей даты для начала интервале.

Примечание:

Имеет смысл, если свойство ВариантНачала имеет значение Смещение.

СмещениеОкончания ( EndingShrft )

Использование:

Чтение и запись.

Описание:

Тип. Число. Количество дней после рабочей даты для конца интервала.

Примечание:

Имеет смысл, если свойство ВариантОкончания имеет значение Смещение.

Методы

ПолучитьДатуНачала ( GetDateFrom )

Синтаксис:

ПолучитьДатуНачала()

Возвращаемое значение:

Тип: Дата.

Описание:

Возвращает дату начала периода.

Примечание:

Если граница интервала задана как БезОграничения, то будет возвращена пустая дата.

Пример:

ДатаНач = НП.ПолучитьДатуНачала();

ПолучитьДатуОкончания ( GetDateTo )

Синтаксис:

ПолучитьДатуОкончания()

Возвращаемое значение:

Тип: Дата.

Описание:

Возвращает дату конца периода.

Примечание:

Если граница интервала задана как БезОграничения, то будет возвращена пустая дата.

Пример:

ДатаКон = НП.ПолучитьДатуОкончания();

Представление ( Presentation )

Синтаксис:

Представление()

Возвращаемое значение:

Тип: Строка.

Описание:

Позволяет получить строковое представление настроенного периода.

Редактировать ( Edit )

Синтаксис:

Редактировать()

Возвращаемое значение:

Тип: Булево. Истина, если нажата кнопка "ОК".

Описание:

Открывает диалог ввода периода в модальном режиме. В зависимости от значения свойств РедактироватьКакИнтервал и РедактироватьКакПериод диалог визуальной настройки имеет обе закладки или одну из них. Если использовано обе закладки активность той или иной из них задается свойством ВариантНастройки.

Пример:

НП.Редактировать();

УстановитьПериод ( SetPeriod )

Синтаксис:

УстановитьПериод(< Дата начала> , <Дата окончания>)

Параметры:

<Дата начала> Необязательный

Тип Дата Дата начала периода.

<Дата окончания> Необязательный

Тип Дата Дата окончания периода.

Описание:

Устанавливает период редактирования. Если это возможно, объекту автоматически подбирается вариант периода и значение периода

Пример:

НП.УстановитьПериод('2002040Г,'20020531');

Конструкторы

Основной

Синтаксис:

Новый НастройкаПериода()

Описание:

Позволяет создать новую настройку периода. По умолчанию у созданного объекта свойства определены следующим образом:

• РедактироватьКакИнтревал - Истина;

• РедактироватьКакПериод - Истина;

• ВариантНачала - ВезОграничения;

• ВариантОкончания - БезОграничения;

• ВариантНастройки - Интервал.

МоментВремени ( PointOfTime)

Предназначен для получения и хранения момента времени для объекта в базе данных Содержит дату и время, а также ссылку на объект базы данных Используется в качестве значений свойств и параметров методов других объектов, имеющих тип МоментВремени

Момент времени используется в тех случаях, когда важно различать моменты времени для объектов, имеющих одинаковую дату и время, например для сравнения положений документов на времен той оси

Свойства

Дата ( Date )

Использование:

Только чтение.

Описание:

Тип Дата. Содержит дату и время момента времени.

Ссылка ( Ref )

Использование:

Только чтение.

Описание:

Тип Любая ссылка на объект ИБ. Содержит ссылку на объект в базе данных.

Методы

Сравнить (Compare)

Синтаксис:

Сравнить(<Момент времени>)

Параметры:

<Момент времени> Обязательный

Тип: МоментВремени. Момент времени, с которым производится сравнение.

Возвращаемое значение:

Тип: Число. -1 - если момент времени меньше момента времени, с которым выполняется сравнение, 0 - если момент времени равен моменту времени, с которым выполняется сравнение, 1 - если момент времени больше момента времени, с которым выполняется сравнение.

Описание:

Позволяет сравнить момент времени с другим моментом времени.

Пример:

Момент1 = Новый МоментВремени(Док1.Дата, Док1);

Момент2 = Новый МоментВремени(Док2.Дата, Док2);

Если Момент1.Сравнить(Момент2) = -1 Тогда Момент1 = Момент2;

КонецЕсли;

Конструкторы

Основной

Синтаксис:

Новый МоментВремени (<Дата>. <Ссылка>)

Параметры:

<Дата> Обязательный

Тип: Дата. Дата и время.

<Ссылка> Необязательный

Тип: Любая ссылка на объект ИБ. Ссылка на любой объект в базе данных.

Описание:

Позволяет сформировать момент времени по дате и ссылке на объект в базе данных.

Граница ( Bound )

Предназначен для получения и хранения границы некоторого интервала значений. Содержит граничное значение интервала, а также признак включения или исключения граничного значения в интервал.

Используется в качестве значений свойств и параметров методов других объектов, имеющих тип Граница.

Граница используется в тех случаях, когда важно указание включения или исключения граничного значения, например при получении остатков и оборотов регистров накопления, срезов и значений регистров сведений, для задания интервалов запросов.

Свойства

ВидГраницы ( BoundKind )

Использование:

Только чтение.

Описание:

Тип: ВидГраницы. Содержит признак включения/исключения граничного значения в интервал.

При определении значения свойства используется системное перечисление ВидГраницы ( BoundKind).

Значение ( Value )

Использование:

Только чтение.

Описание:

Тип: Произвольный. Содержит значение границы.

Конструкторы

Основной

Синтаксис:

Новый Граница (< Значение> , <Вид границы> )

Параметры:

<3начение> Обязательный

Значение границы.

<Вид границы> Необязательный

Тип: ВидГраницы. Включение/исключение граничного значения.

Значение по умолчанию: Если параметр не задан, используется вариант границы с включением граничного значения.

При определении значения параметра используется системное перечисление ВидГраницы ( BoundKind).

Описание:

Позволяет создать новую границу с заданными характеристиками.


1С: V8.0

1С: Предприятие 8.0
Описание встроенного языка

ОГЛАВЛЕНИЕ

Введение |
Глава 1-1. Общее описание языка
 | Операторы и синтаксические конструкции
 | Основные приемы работы
Глава 1-2. Встроенные функции языка
 | Функции работы со значениями типа Строка
 | Функции работы со значениями типа Число
 | Функции работы со значениями типа Дата
 | Функции преобразования значений
 | Функции форматирования
 | Прочие
Глава 1-3. Глобальный контекст
 | Свойства
 | Процедуры и функции интерактивной работы
 | Функции для вызова диалога ввода данных
 | Функции форматирования
 | Функции обращения к конфигурации
 | Процедуры и функции сеанса работы
 | Процедуры и функции сохранения значений
 | Процедуры и функции работы с операционной системой
 | Процедуры и функции работы с внешними компонентами
 | Процедуры и функции работы с файлами
 | Процедуры и функции работы с информационной базой
 | Процедуры и функции работы с данными информационной базы
 | События
Глава 1-4. Общие объекты
 | ХранилищеЗначения
 | Картинка
 | УникальныйИдентификатор
 | Коллекция
 | ТекстовыйДокумент
 | ТабличныйДокумент
 | Работа с объектами метаданных
 | Работа с файлами
 | XBase
 | Описание типов значений
Глава 1-5. Универсальные коллекции значений
 | Массив
 | Структура
 | Соответствие
 | Список значений
 | Таблица значений
 | Дерево значений
Глава 2-1. Интерфейсные
 | Форма
 | Диаграмма
 | Командная панель
 | Панель
 | Переключатель
 | ПолеВвода
 | ПолеВыбора
 | ПолеКартинки
 | ПолеСписка
 | ПолосаРегулирования
 | Разделитель
 | РамкаГруппы
 | ТабличноеПоле
 | ПолеТабличногоДокумента
 | ПолеТекстовогоДокумента
 | Флажок
 | Свойства интерфейсных объектов
 | Работа с пользовательским интерфейсом
Глава 2-2. Работа с запросами
 | Источники данных (таблицы) запросов
 | Язык запросов
 | Запрос
 | РезультатЗапроса
 | ВыборкаИзРезультатаЗапроса
 | Коллекция КолонокРезультатаЗапроса
 | Колонка РезультатаЗапроса
Глава 3-1. Прикладные объекты
 | Константы
 | Справочники
 | Документы
 | Журналы документов
 | Перечисления
 | Отчеты
 | Обработки
 | Внешние обработки
 | Регистры сведений
 | Регистры накопления
 | Критерии отбора
 | Последовательности
 | Универсальные объекты


Системные перечисления

АвтоРаздвижениеСерий

Все | Раздвигать все серии
Максимум | Выдвигать максимальную серию
Минимум | Выдвигать минимальную серию
Нет | Не раздвигать серии автоматически

ВариантПоложенияОкна

Верх | Прикреплять сверху
Лево | Прикреплять слева
Низ | Прикреплять снизу
Право | Прикреплять справа

ВариантСостоянияОкна

Обычное | Окно располагается только внутри рабочей области программы
Прикрепленное | Окно может "прикрепиться" к границам рабочей области программы
Прячущееся | Автоматически скрывающееся окно
Свободное | Окно может свободно перемещаться по всему экрану (не только внутри рабочей области программы)

ВертикальноеПоложение

Верх | Выравнивание текста по верхнему краю.
Низ | Выравнивание текста по нижнему краю.
Центр | Выравнивание текста по центру.

ВидКартинки

Абсолютная | Картинка, хранящаяся в объекте встроенного языка
ИзБиблиотеки | Картинка из библиотеки картинок
Пустая | Пустая картинка

ВидПодписейКДиаграмме

Значение | В качестве подписи выводится значение в серии
ЗначениеПроцент | В качестве подписи выводится строка, состоящая из значения в серии и процента от общей суммы
Нет | Нет подписей и подсказок
Процент | В качестве подписи выводится процент от общей суммы
Серия | В качестве подписи выводится имя серии
СерияЗначение | В качестве подписи выводится строка, состоящая из имени серии и значения в серии
СерияЗначениеПроцент | В качестве подписи выводится строка, состоящая из имени серии, значения в серии и процента от общей суммы
СерияПроцент | В качестве подписи выводится строка, состоящая из имени серии и процента от общей суммы

ВидЦвета

WebUseT | Цвет задан одним из web-цветов
WindowsUBeT | Цвет задан одним из цветов палитры Windows
Абсолютный | Цвет задается абсолютным значением, то есть сочетанием красной, зеленой и синей составляющих
АвтоЦвет | Цвет подбирается автоматически
ЭлементСтиля | Цвет задается одним из цветов элементов стиля

ВидШрифта

WindowsШрифт | Шрифт задается одним из шрифтов Windows
Абсолютный | Шрифт задается абсолютными характеристиками: именем шрифта, размером и другими
АвтоШрифт | Шрифт подбирается автоматически
ЭлементСтиля | Шрифт задается одним из цветов элементов стиля

ВидРамки

Абсолютная | Рамка задается абсолютными параметрами: типом и толщиной
ЭлементСтиля | Рамка задается как элемент стиля

ГоризонтальноеПоложение

Авто | Горизонтальное выравнивание текста элемента управления или области табличного документа будет определяться автоматически, исходя из типа отображаемого значения. Числовые значения будут прижиматься к правой границе, остальные - к левой
Лево | Выравнивание теста по левому краю.
ПоШирине | Текст форматируется таким образом, чтобы занимать всю ширину элемента управления или области табличного документа.
Право | Выравнивание текста по правому краю.
Центр | Выравнивание теста по центру.

ДопустимаяДлина

Переменная | Строка имеет переменную длину. Если длина присваиваемой строки будет меньше установленной, то строка не будет дополняться пробелами до необходимой длины. Если длина присваиваемой строки будет больше установленной, строка будет обрезаться.
Фиксированная | Строка имеет фиксированную длину. Если длина присваиваемой строки будет меньше установленной, то строка будет дополняться пробелами справа до необходимой длины. Если длина присваиваемой строки будет больше установленной, строка будет обрезаться.

ДопустимыйЗнак

Любой | Число может иметь любой знак (положительный или отрицательный)
Неогрицательный | Число должно быть строго не отрицательным

ИзменениеРазмераКолонки

Изменять | Размер колонки может изменяться при масштабировании или пользователем
НеИзменять | Размер колонки не может изменяться при масштабировании или пользователем

ИзменениеРазмераОкна

Изменять | Разрешить изменения размеров окна формы
НеИзменять | Запретить изменения размеров окна формы

ИспользованиеПолосыПрокрутки

ИспользоватьАвтоматически | Полоса прокрутки появляется, если содержимое элемента формы не может быть размещено полностью в отведенной для него области
ИспользоватьВсегда | Полоса прокрутки всегда присутствует, даже если все содержимое элемента формы умещается в отведенную область. В этом случае ползунок полосы будет отсутствовать, кнопки полосы прокрутки будут недоступны
НеИспользовать | Не использовать полосу прокрутки

ИспользованиеРасшифровкиТабличногоДокумента

БезОбработки | Обработка расшифровки не вызывается.
Строка | Обработка расшифровки вызывается для всех ячеек строки, следующей за ячейкой, содержащей значение расшифровки.
Ячейка | Обработка расшифровки вызывается для каждой ячейки области, содержащей расшифровку.

Клавиша

0...9 | Цифровые клавиши на основной части клавиатуры
A...Z | Буквенные клавиши
(A...Z) | Используется латинское обозначение
Backspace | Backspace
F1...F12 | Функциональные клавиши
NumO...Num9 | Цифровые клавиши на дополнительной части клавиатуры
NumAdd | Плюс на дополнительной части клавиатуры
NumDecimal | Точка на дополнительной части клавиатуры
NumDivide | Деление на дополнительной части клавиатуры
NumMultiply | Умножение на дополнительной части клавиатуры
NumSubtract | Минус на дополнительной части клавиатуры
Space | Пробел
Нет | Нет клавиши

КодВозвратаДиалога

Да | Выбрана кнопка "Да"
Нет | Выбрана кнопка "Нет"
ОК | Выбрана кнопка "ОК"
Отмена | Выбрана кнопка "Отмена"
Повтор | Выбрана кнопка "Повтор"
Пропустить | Выбрана кнопка "Пропустить"
Стоп | Выбрана кнопка "Стоп"
Таймаут | Закончилось время ожидания ответа

МаксимумСерий

НеЗадано | Отображать все серии
Ограничено | Отображается не более определенного количества серий. Количество серий определяется свойством МаксимумСерийКоличество объекта Диаграмма.
Процент | Отображаются только те серии, чей максимум больше или равен заданному проценту от абсолютного. Для этого для каждой серии находится максимальное абсолютное значение и абсолютный максимум по всем сериям. Процент определяется значением свойства МаксимумСерийПроцент объекта Диаграмма

НачальноеОтображениеДерева

НеРаскрывать | Не раскрывать уровни дерева
РаскрыватьВерхнийУровень | Раскрывать только верхний уровень дерева
РаскрыватьВсеУровни | Раскрывать все уровни дерева

НачальноеОтображениеСписка

Конец | При открытии табличного поля переходить в конец связанного с полем списка или набора данных
Начало | При открытии табличного поля переходить в начало связанного с полем списка или набора данных

ОбходРезультатаЗапроса

ПоГруппировкам | Обход записей результата запроса по группировкам
ПоГруппировкамСИерархией | Обход записей результата запроса по группировкам с учетом иерархии
Прямой | Прямой тип обхода записей результата запроса. При таком способе обход осуществляется без группировок и иерархии

Ориентация

Авто | Ориентация элемента управления определяется автоматически
Вертикально | Элемент управления расположен вертикально
Горизонтально | Элемент управления расположен горизонтально

ОриентацияДиаграммы

ЮгВосток
ЮгЗапад

ОтображениеЗакладок

НеИспользовать | Не использовать закладки
Сверху | Закладки располагаются сверху в одну строку. Если закладки не умещаются полностью на верхней стороне панели, то они уменьшаются, отображая только часть текста названия, дополненного троеточием
Сверху Многострочный | Закладки располагаются сверху в несколько строк, если не умещаются на верхней стороне панели. При выборе закладки порядок строк закладок не изменяется
Сверху Многострочный СПерестановкой | Закладки располагаются сверху в несколько строк, если не умещаются на верхней стороне панели. При активизации закладки содержащая ее строка перемещается в самый низ области строк закладок
Сверху СПрокруткой | Закладки располагаются сверху в одну строку с прокруткой. Если все закладки не умещаются на верхней стороне панели, то справа от закладок выводятся кнопки перемещения по закладкам (прокрутки)
Слева Вертикально | Закладки располагаются в одну строку слева, текст закладок отображается вертикально. Если закладки умещаются на левой стороне панели, то они уменьшаются, отображая только часть текста названия, дополненного троеточием
Слева Горизонтально | Закладки располагаются в одну строку слева, текст закладок отображается горизонтально. Если закладки умещаются на левой стороне панели, то в нижней части области закладок появляются кнопки для прокрутки списка закладок
Снизу | Закладки располагаются снизу в одну строку. Если закладки не умещаются полностью на нижней стороне панели, то они уменьшаются, отображая только часть текста названия, дополненного троеточием
Снизу Многострочный | Закладки располагаются снизу в несколько строк, если не умещаются на нижней стороне панели. При выборе закладки порядок строк закладок не изменяется
Снизу Многострочный СПерестановкой | Закладки располагаются снизу в несколько строк, если не умещаются на нижней стороне панели. При активизации закладки содержащая ее строка перемещается в самый верх области строк закладок
Сиизу СПрокруткой | Закладки располагаются снизу в одну строку с прокруткой. Если все закладки не умещаются на нижней стороне панели, то справа от закладок выводятся кнопки перемещения по закладкам (прокрутки).
Справа Вертикально | Закладки располагаются в одну строку справа, текст закладок отображается вертикально. Если закладки умещаются на правой стороне панели, то они уменьшаются, отображая только часть текста названия, дополненного троеточием
Справа Горизонталыю | Закладки располагаются в одну строку справа, текст закладок отображается горизонтально. Если закладки умещаются на правой стороне панели, то в нижней части области закладок появляются кнопки для прокрутки списка закладок

ОтображениеКнопкиКоманднойПанели

Авто | Стиль отображения кнопки определяется командной панелью. Например, кнопка с таким стилем отображения, вставленная в панель инструментов будет отображаться в виде картинки, а вставленная в подменю - в виде картинки и текста
Картинка | На кнопке отображается только картинка, без текста
Надпись | На кнопке отображается только текст, без картинки
НадписьКартинка | На кнопке отображается и текст и картинка

ОтображениеРазметкиПолосыРегулирования

НеОтображать | Не отображать разметку
СверхуИлиСлева | Отображать разметку сверху от полосы регулирования, если элемент управление имеет горизонтальную ориентацию, или слева - если вертикальную
СнизуИлиСправа | Отображать разметку снизу от полосы регулирования, если элемент управление имеет горизонтальную ориентацию, или справа - если вертикальную
СОбоихСторон | Отображать разметку с обеих сторон от полосы регулирования. Если элемент управление имеет горизонтальную ориентацию, то сверху и снизу, если вертикальную - то слева и справа

ПоложениеЗаголовка

ЗаголовокСлева | Заголовок располагается слева от отметки
ЗаголовокСправа | Заголовок располагается справа от отметки

ПоложениеКолонки

ВТойЖеКолонке | Колонка находится на той же строке, что и предыдущая, вместе они образуют составную колонку
НаСледующейСтроке | Колонка находится на следующей строке, при этом образуется составная колонка
НоваяКолонка | В новой колонке (справа)

ПоложениеКартинкиКнопки

КартинкаСлева | Картинка прижимается к левой границе кнопки
КартинкаСправа | Картинка прижимается к правой границе кнопки

РазмерКартинки

Авторазмер | Если область, в которой отображается картинка, больше чем размеры картинки, используется режим РеальныйРазмер, в противном случае используется режим Пропорционально
Пропорционально | Картинка растягивается или сжимается таким образом, чтобы занять всю высоту или ширину отведенной для нее области, сохраняя при этом соотношение высоты и ширины оригинальной картинки
Растянуть | Растянуть или сжать картинку таким образом, чтобы она занимала всю область, отведенную для ее отображения
РеальныйРазмер | Сохранять реальные размеры картинки. Если область, в которой отображается картинка, меньше ее размеров, из середины картинки вырезается прямоугольник нужного размера
Черепица | Картинка, сохраняя свои оригинальные размеры, будет периодически повторяться, заполняя всю отведенную для нее область

РежимБегущейСтроки

Быстро | Быстрое перемещение текста
Медленно | Медленное перемещение текста
НеИспользовать | Не использовать режим бегущей строки
Нормально | Средняя (нормальная) скорость перемещения текста
ОченьБыстро | Очень быстрое перемещение текста
ОченьМедленно | Очень медленное перемещение текста

РежимВводаСтрокТабличногоПоля

ВКонецОкна | Новая строка будет вводиться в конец окна
ВКонецСписка | Новая строка будет вводиться в конце списка
ПередТекущейСтрокой | Новая строка будет вводиться перед текущей строки
ПослеТекущейСтроки | Новая строка будет вводиться после текущей строки

РежимДиалогаВыбораФайла

ВыборКаталога | Диалог выбора каталога
Открытие | Диалог выбора файла для открытия
Сохранение | Диалог выбора файла для сохранения

РежимДиалогаВопрос

ДаНет | Кнопки "Да" и "Нет"
ДаНетОтмена | Кнопки "Да", "Нет" и "Отмена"
ОК | Кнопка "ОК"
ОКОтмена | Кнопки "ОК" и "Отмена"
ПовторОтмена | Кнопки "Повтор" и "Отмена"
СтопПовторПропустить | Кнопки "Стоп", "Повтор" и "Пропустить"

РежимПробеловДиаграммы

Нет | Не использовать пробелы
ПолнаяШирина | Пробел в половину ширины фигуры
ПоловинаШирины | Пробел в половину ширины фигуры

РежимРабочейДаты

ИспользоватьТекущуюДату | использовать текущую дату в качестве рабочей. В этом режиме рабочая дата не может быть изменена ни интерактивно, ни программно
Назначать | назначать рабочую дату программно или интерактивно

РежимСглаживанияИндикатора

Плавный | Плавное заполнение
Прерывистый | Прерывистое заполнение - прямоугольниками
ПрерывистыйНаклонный | Прерывистое заполнение - наклонными параллелограммами

СтатусСообщения

БезСтатуса | Без пиктограммы
Важное | Пиктограмма - два красных восклицательных знака
Внимание | Пиктограмма - красный восклицательный знак
Информация | Пиктограмма - символ "i"
Обычное | Пиктограмма - синий треугольник
ОченьВажное | Пиктограмма - три красных восклицательных знака

ТипДиаграммы

Биржевая | Биржевая диаграмма строится для данных, представленных одной серией значений по четыре значения на точку. Одна точка диаграммы определяется группой из четырех значений (точек): цена открытия, максимальная, минимальная, цена закрытия. Параметры для отображения (текст и расшифровка) берутся из первых точек каждой группы (т.е. из точек 0, 4, 8 ...). Группы, имеющие меньше четырех значений, не учитываются при построении. Значения цены открытия и цены закрытия отмечаются горизонтальными линиями, интервал между максимальной и минимальной ценой отмечается вертикальной линией.
БиржеваяСвеча | Биржевая "свеча". Отличается от биржевой диаграммы тем, что интервал между ценой открытия и ценой закрытия отмечается прямоугольником.
Гистограмма | Вертикальная гистограмма. Строится...
Гистограмма Горизонтальная | Горизонтальная гистограмма. Строится...
Гистограмма Горизонтальная Объемная | Горизонтальная объемная гистограмма. Строится...
Гистограмма Объемная | Вертикальная объемная гистограмма. Строится...
Гистограмма СНакоплением | Вертикальная гистограмма с накоплением: значения в каждой серии суммируются со значениями в предыдущих. Строится...
Гистограмма СНакоплением Горизонтальная | Горизонтальная гистограмма с накоплением: значения в каждой серии суммируются со значениями в предыдущих. Строится...
Гистограмма СНакоплением Горизонтальная Объемная | Горизонтальная объемная гистограмма с накоплением: значения в каждой серии суммируются со значениями в предыдущих Строится...
Гистограмма СНакоплением Объемная | Вертикальная объемная гистограмма с накоплением: значения в каждой серии суммируются со значениями в предыдущих. Строится...
График | Линейный график. Соседние значения внутри одной серии соединяются прямыми линиями, значения в точках могут быть отмечены маркерами. Строится на основании данных, представленных одной или несколькими сериями значений для нескольких точек.
График ПоШагам | Линейный график ступенями. Значения внутри одной серии в соседних точках соединены между собой горизонтальными линиями. Строится...
График СОбластями | Линейный график с закрашиванием области между линией графика и линией базового значения. Разные серии перекрывают друг друга. Строится...
График СОбластями ИНакоплением | Линейный график с закрашиванием области и накоплением. Значения в каждой серии суммируются со значениями в предыдущих, поэтому области разных серий не перекрывают друг друга. Строится...
Изометрическая | Изометрическая прямоугольная диаграмма ("Манхеттен"). Значения отмечаются прямоугольными параллелепипедами разной высоты. Строится...
Изометрическая Лента | Изометрическая диаграмма, значения внутри одной серии объединяются лентой. Строится...
Изометрическая Непрерывная | Изометрическая непрерывная диаграмма. Значения внутри одной серии объединяются лентой, области от лент до плоскости базового значения заполняются. Строится...
Изометрическая Пирамида | Изометрическая диаграмма. Значения отмечаются пирамидами разной высоты. Строится...
Круговая | Круговая диаграмма. Строится на основании данных, представленных набором серий значений для одной точка.
Круговая Объемная | Круговая объемная диаграмма. Строится на основании данных, представленных набором серий значений для одной точки.

Строится ... на основании данных, аналогичных данным диаграммы вида График.

ТипЗаписиЗапроса

ДетальнаяЗапись | Детальная (конечная) запись результата запроса
ИтогПоГруппировке | Итоговая запись по группировке запроса
ИтогПоИерархии | Итоговая запись по иерархии запроса
ОбщийИтог | Общая итоговая запись запроса

ТипКодировкиТекста

ANSI | Файл в формате ANSI
OEM | Файл в формате DOS
UTF16 | Файл в формате UTF16
UTF8 | Файл в формате UTF8

ТипЛинииДиаграммы

НетЛинии | Нет линии
Пунктир | Пунктирная линия
ПунктирТочка | Линия "пунктир - точка"
ПунктирТочкаТочка | Линия "пунктир - точка - точка"
Сплошная | Сплошная линия
Точечная | Точечная линия

ТипМаркераДиаграммы

Квадрат | Квадратный маркер
Круг | Круглый маркер
Нет | Нет маркера
Ромб | Ромбический маркер

ТипОбластиЯчеекТабличногоДокумента

Колонки | Область состоящая из колонок
Прямоугольник |
Строки |
Таблица |

ТипНаправленияПереходаТабличногоДокумента

БезПерехода | После редактирования оставаться на отредактированной ячейке.
ПоСтолбцам | После редактирования переходить к следующей ячейке в столбце.
ПоСтрокам | После редактирования переходить к следующей ячейке в строке.

ТипПоведенияКлавишиEnter

КнопкаПоУмолчанию | Нажатие "Enter" воспринимается как нажатие кнопки по умолчанию
ПереходПоЭлементамФормы | При нажатии "Enter" происходит переход к следующему элементу управления по порядку обхода

ТипКнопкиКоманднойПанели

Действие | Кнопка данного типа представляет собой обычную кнопку панели. Кнопке может быть установлено Действие, которое будет выполнено при нажатии на кнопку
Подменю | Кнопка данного типа аналогична кнопке типа Действие, но при нажатии на нее будет открыто связанное с данной кнопкой подменю, а не выполнено действие
Разделитель | Визуально кнопка данного типа представляет собой горизонтальную или вертикальную (в зависимости от расположения командной панели) черту. Кнопки такого типа не имеют визуальных свойств (картинка, текст и т.д.). Используется для разделения групп кнопок в панели инструментов.

ТипРазмещенияТекстаТабличногоДокумента

Авто | Не помещающийся по ширине текст будет показан в соседних по горизонтали ячейках, если в них нет текста.
Забивать | Видимая часть текста будет ограничена левой и правой границами ячейки, если при этом текст не умещается полностью, то все символы видимой части будут отображаться как "#". (Применяется для предотвращения неправильного восприятия обрезанного текста).
Обрезать | Видимая часть текста будет ограничена левой и правой границами ячейки.
Переносить | Не помещающийся по ширине текст будет переноситься на следующие строки ячейки.

ТипРамкиЭлементаУправления

БезРамки | Без рамки
Вдавленная | Вдавленная рамка
Выпуклая | Выпуклая рамка
Двойная | Двойная рамка
ДвойноеПодчеркивание | Двойная рамка снизу (двойное подчеркивание)
Одинарная | Одинарная рамка
Подчеркивание | Одинарная рамка снизу (подчеркивание)

ТипРисункаТабличногоДокумента

Группа | Группа
Диаграмма | Диаграмма
Картинка | Картинка
Объект | OLE Объект
Примечание | Примечание
Прямая | Прямая линия
Прямоугольник | Прямоугольник
Текст | Текст
Эллипс | Эллипс

ТипСортировки

Возр | Сортировка по возрастанию
Убыв | Сортировка по убыванию

ТипСмещенияТабличногоДокумента

БезСмещения | Не смещать ячейки.
ПоВертикали | Смещать ячейки по вертикали.
ПоГоризонтали | Смещать ячейки по горизонтали.

ТипУзораТабличногоДокумента

БезУзора | Нет узора
Сплошной | Сплошное заполнение одним цветом
Узор1 | Узор 1
Узор2 | Узор 2
... | ...
Узор17 | Узор 17

ТипФайлаТабличногоДокумента

HTML | Файл в формате HTML.
MXL | Файл табличного документа 1С:Предприятия.
MXL7 | Файл табличного документа 1С:Предприятия версии 7.7
ТХТ | Текстовый файл.
XLS | Файл в формате MS Excel.

ЧастиДаты

Время | Значение состоит только из времени (без даты)
Дата | Значение состоит только из даты (без времени)
ДатаВремя | Значение состоит из даты и времени


Системные перечисления

РежимЗаписиДокумента ( DocumentWritingMode)

Запись (Write) | В этом случае будут сохранены изменения, внесенные в документ, и движения.
ОтменаПроведения (Unposting) | В этом случае будут сохранены изменения документа, после чего инициирована отмена проведения документа. Оба действия производятся в одной транзакции.
Проведение (Posting) | В этом случае будут сохранены все изменения документа, после чего инициировано проведение документа. Оба действия производятся в одной транзакции.

РежимПроведения (PostingMode)

Неоперативный (NotOperational) | Неоперативное проведение, т.е. проведение выполняется не в реальном времени. Например, используется при проведении задним числом.
Оперативный (Operational) | Оперативное проведение, т.е. проведение выполняется в реальном времени. При этом удобно, например, выполнять контроль текущих остатков.

Автовремя ( AutoTime)

НеИспользовать (NotUse) | Не использовать установку времени документа. Это означает, что если в дате документа время не нулевое - оно будет сброшено (время - 0:00:00).
Первым ( First) | Установить время документа так, что бы он оказался первым на свою дату. Если при этом дата документа совпадает с рабочей по дню, то время документа будет установлено не позже, чем текущее.
Последним ( Last) | Установить время документа так, что бы он оказался последним на свою дату. Если при этом дата документа совпадает с рабочей по дню, то время документа будет установлено не раньше, чем текущее.
ТекущееИлиПервым ( CurrentOrFirst) | Если дата документа совпадает с рабочей, то будет установлено текущее время. Если дата документа не совпадает с рабочей, то устанавливается такое время, чтобы документ оказался первым за день.
ТекущееИлиПоследним ( CurrentOrLast) | Если дата документа совпадает с рабочей, то будет установлено текущее время. Если дата документа не совпадает с рабочей, то устанавливается такое время, чтобы документ оказался последним за день.

ИспользованиеРежимаПроведения ( PostingModeUse )

Авто ( Auto ) | Режим проведения будет подбираться системой автоматически исходя из даты документа, позиции документа по отношению к границе актуальности и других параметров.
Запрашивать (Ask ) | Режим проведения будет запрашиваться у пользователя перед проведением.
Неоперативный (NotOperational) | Проведение будет выполняться в неоперативом режиме.
Оперативный (Operational ) | Проведение будет выполняться в оперативном режиме.

ИспользованиеСреза ( SliceUse )

НеИспользовать (NotUse ) | Срез не будет использоваться.
Первые ( First ) | Будут выбираться первые (наиболее ранние) записи.
Последние ( Last ) | Будут выбираться последние (наиболее поздние) записи.

РежимРедактированияСписка ( ListEditMode )

ВДиалоге (InDialog ) | Для редактирования элемента списка поля вызывается специальный диалог.
ВСписке ( Inlist ) | Элементы редактируется непосредственно в поле списка.

ВидСравнения ( ComparisonKind)

Больше | Сравниваемое значение больше заданного в условии
БолышеИлиРавно | Сравниваемое значение больше или равно заданному в условии.
Интервал | Сравниваемое значение лежит в заданном интервале не включая границы интервала.
ИнтервалВключаяГраницы | Сравниваемое значение лежит в заданном интервале включая границы интервала.
ИнтервалВключаяНачало | Сравниваемое значение лежит в заданном интервале включая начальную и не включая конечную границу интервала.
ИнтервалВключаяОкончание | Сравниваемое значение лежит в заданном интервале не включая начальную и включая конечную границу интервала.
Меньше | Сравниваемое значение меньше заданного в условии.
МенышеИлиРавно | Сравниваемое значение меньше или равно заданному в условии.
Неравно | Проверка на неравенство. Для строковых значений регистр символов не учитывается
Равно | Проверка на равенство. Для строковых значений регистр символов не учитывается.
Содержит | Сравниваемое значение содержит подстроку, заданную в условии сравнения.

ВариантНастройкиПериода ( PeriodSettingVariant)

Интервал | Закладка "Интервал".
Период | Закладка "Период".

ВариантГраницыИнтервала ( RangeBorderVariant)

БезОграничения | Начало или конец интервала не ограничиваются.
Год | Начало интервала задается датой начала года рабочей даты, конец интервала - датой конца года рабочей даты.
Квартал | Начало интервала задается датой начала квартала рабочей даты, конец интервала - датой конца квартала рабочей даты.
КонкретнаяДата | Начало или конец интервала задаются конкретной датой.
Месяц | Начало интервала задается датой начала месяца рабочей даты, конец интервала - датой конца месяца рабочей даты.
Неделя | Начало интервала задается датой начала недели рабочей даты, конец интервала - датой конца недели рабочей даты.
РабочаяДата | Начало интервала задается датой началом дня рабочей даты, конец интервала - концом дня рабочей даты.
Смещение | Начало интервала задается датой за несколько дней до рабочей даты, конец интервала - через несколько дней после рабочей даты.

ВариантПериода ( PeriodVariant)

Год | Период задан годом.
День | Период задан одним днем.
ДеньСНачалаГода | Период с начала года до заданного дня.
ДеньСНачалаКвартала | Период с начала квартала до заданного дня.
ДеньСНачалаМесяца | Период с начала месяца до заданного дня.
Квартал | Период задан кварталом.
КварталСНачалаГода | Период с начала года до конца заданного квартала.
Месяц | Период задан месяцем.
МесяцСНачалаГода | Период с начала года до конца заданного месяца.
МесяцСНачалаКвартала | Период с начала квартала до конца заданного месяца.
ПроизвольныйИнтервал | Период задан произвольным интервалом.

ВидГраницы ( BoundKind)

Включая | Граница включает граничное значение.
Исключая | Граница исключает граничное значение.