Приложение 1: Коды ошибок

Код ошибки | Описание ошибки
600 | Начатая операция не закончена.
601 | Обнаружен недопустимый дескриптор порта.
602 | Указанный порт уже открыт.
603 | Буфер вызывающего слишком мал.
604 | Указаны недопустимые сведения.
605 | Невозможно установить сведения о порте.
606 | Указанный порт не подключен.
607 | Обнаружено недопустимое событие.
608 | Указано несуществующее устройство.
609 | Указан несуществующий тип устройства.
610 | Указан недопустимый буфер.
611 | Указанный маршрут недоступен.
612 | Указанный маршрут не распределен.
613 | Указан недопустимый тип сжатия.
614 | Недостаточно доступных буферов.
615 | Указанный порт не найден.
616 | Асинхронный запрос приостановлен.
617 | Модем или другое устройство связи уже отключено.
618 | Указанный порт не открыт.
619 | Указанный порт не подключен.
620 | Не удалось определить конечные точки.
621 | Системе не удалось открыть файл телефонной книги.
622 | Системе не удалось загрузить файл телефонной книги.
623 | Системе не удалось найти запись телефонной книги для этого подключения.
624 | Системе не удалось обновить файл телефонной книги.
625 | Система обнаружила недопустимые данные в файле телефонной книги.
626 | Не удалось загрузить строку.
627 | Не удалось найти ключ.
628 | Подключение было закрыто.
629 | Подключение было закрыто удаленным компьютером.
630 | Модем или другое устройство связи было отключено из-за ошибки оборудования.
631 | Пользователь отключил модем или другое устройство связи.
632 | Обнаружен неправильный размер структуры.
633 | Модем или другое устройство связи уже используется или не настроено.
634 | Не удалось зарегистрировать компьютер в удаленной сети.
635 | Произошла неизвестная ошибка.
636 | Устройство, подключенное к порту, не соответствует ожидаемому.
637 | Обнаружена строка, которую не удалось преобразовать (конвертировать).
638 | Запрос просрочен
639 | Нет доступной асинхронной сети.
640 | Произошла ошибка, затрагивающая NetBIOS.
641 | Серверу не удалось выделить NetBIOS-ресурсы, необходимые для поддержки этого клиента.
642 | Одно из компьютерных NetBIOS-имен уже зарегистрировано в удаленной сети.
643 | Ошибка сетевого адаптера сервера.
644 | Всплывающие сетевые сообщения получаться не будут.
645 | Произошла внутренняя ошибка проверки подлинности.
646 | Вход в это время дня для пользователя с данной учетной записью не разрешен.
647 | Учетная запись отключена.
648 | Срок действия пароля для учетной записи истек.
649 | Учетная запись не имеет прав для дозвона.
650 | Сервер удаленного доступа не отвечает.
651 | Модем или другое устройство связи сообщило об ошибке.
652 | Отклик от модема или другого устройства связи не был распознан.
653 | Макрос, требуемый модемом или другим устройством связи, не найден в INF-файле устройства.
654 | Команда или отклик в секции INF-файла устройства ссылается на неопределенный макрос.
655 | Макрос <сообщения> не найден в секции INF-файла устройства.
656 | Макрос <отключения по умолчанию> в секции INF-файла устройства ссылается на неопределенный макрос.
657 | Не удалось открыть INF-файл устройства.
658 | Слишком длинное имя устройства в INF-файле устройства или в INI-файле носителя.
659 | INI-файл носителя ссылается на неизвестное имя устройства.
660 | INF-файл устройства не содержит ответов для этой команды.
661 | В INF-файле устройства отсутствует команда.
662 | Произошла попытка установить макрос, не перечисленный в секции INF-файла устройства.
663 | INI-файл носителя ссылается на неизвестный тип устройства.
664 | Недостаточно памяти.
665 | Модем или другое устройство связи не настроено должным образом.
666 | Модем или другое устройство связи не работает должным образом.
667 | Системе не удалось прочесть INI-файл носителя.
668 | Подключение было прервано.
669 | Недопустимое использование параметра в INI-файле носителя.
670 | Системе не удалось прочесть имя секции из INI-файла носителя.
671 | Системе не удалось прочесть тип устройства из INI-файла носителя.
672 | Система не удалось прочесть имя устройства из INI-файла носителя.
673 | Системе не удалось прочесть использование из INI-файла носителя.
674 | Системе не удалось прочесть максимальную скорость подключения из INI-файла носителя.
675 | Системе не удалось прочесть максимальную несущую скорости подключения из INI-файла носителя.
676 | Телефонная линия занята.
677 | Вместо модема или другого устройства связи ответил человек.
678 | Ответ не получен.
679 | Системе не удается определить несущую.
680 | Отсутствует гудок.
681 | Модем или другое устройство связи сообщило о возникновении общей ошибки.
682 | Произошла ошибка при записи имени секции.
683 | Произошла ошибка при записи типа устройства.
684 | Произошла ошибка при записи имени устройства.
685 | Произошла ошибка при записи максимальной скорости подключения.
686 | Произошла ошибка при записи максимальной несущей частоты.
687 | Произошла ошибка при записи коэффициента загрузки.
688 | Произошла ошибка при записи коэффициента отключения по умолчанию.
689 | Произошла ошибка при чтении коэффициента отключения по умолчанию.
690 | ERROR_EMPTY_INI_FILE
691 | Доступ запрещен, поскольку такие имя пользователя или пароль недопустимы в этом домене.
692 | В модеме или другом устройстве связи произошла аппаратная ошибка.
693 | ERROR_NOT_BINARY_MACRO
694 | ERROR_DCB_NOT_FOUND
695 | Конечные автоматы не запущены.
696 | Конечные автоматы уже запущены.
697 | Цикл ответа не завершен.
698 | Несоответствие формата ключевого имени ответа ожидаемому формату в INF-файле устройства.
699 | Ответ модема или другого устройства связи вызвал переполнение буфера.
700 | Развернутая команда в INF-файла устройства слишком длинна.
701 | Установленная скорость подключения для модема не поддерживается этим COM-драйвером.
702 | Получен неожидаемый ответ от устройства.
703 | Подключению требуются некоторые данные от пользователя, но приложение не допускает взаимодействия с пользователем.
704 | Недопустимый номер ответного вызова.
705 | Недопустимое состояние авторизации.
706 | ERROR_WRITING_INITBPS
707 | Произошла ошибка, связанная с протоколом X.25.
708 | Данная учетная запись просрочена.
709 | Произошла ошибка при смене пароля домена. Возможно, пароль слишком короткий или совпадает с предыдущим.
710 | При работе с этим модемом произошла последовательность ошибок переполнения.
711 | Не удалось запустить диспетчера службы удаленного доступа. Дополнительная информация находится в журнале событий.
712 | Инициализация двустороннего порта. Подождите несколько секунд и перезвоните.
713 | Нет доступных линий ISDN.
714 | Нет доступных ISDN-каналов для выполнения звонка.
715 | Из-за низкого качества телефонной линии произошло слишком много ошибок.
716 | IP-конфигурация службы удаленного доступа непригодна для использования.
717 | Нет доступных IP-адресов в статическом пуле IP-адресов службы удаленного доступа.
718 | Истекло время ожидания допустимого отклика с удаленного компьютера.
719 | Подключение было прервано удаленным компьютером.
720 | Попытка подключения не удалась, поскольку удаленному и локальному компьютерам не удалось согласовать управляющие протоколы PPP.
721 | Удаленный компьютер не отвечает.
722 | От удаленного компьютера получены недопустимые данные. Данные были проигнорированы.
723 | Телефонный номер, включая префикс и суффикс, слишком длинный.
724 | IPX-протокол не может быть использован для выполнения исходящих звонков по модему или другому устройству связи, поскольку этот компьютер не настроен на исходящие звонки (он является IPX-маршрутизатором).
725 | IPX-протокол не может быть использован для выполнения входящих звонков по модему или другому устройству связи, поскольку этот компьютер не настроен на входящие звонки (IPX-маршрутизатор не установлен).
726 | IPX-протокол не может быть использован для выполнения исходящих звонков на более чем одном модеме или другом устройстве связи одновременно.
727 | Нет доступа к "TCPCFG.DLL".
728 | Системе не удается найти IP-адаптер.
729 | Пока не будет установлен протокол IP, использовать протокол SLIP невозможно.
730 | Регистрация компьютера не завершена.
731 | Протокол не настроен.
732 | Этот компьютер и удаленный компьютер не смогли согласовать протоколы управления PPP.
733 | Этот компьютер и удаленный компьютер не смогли согласовать протоколы управления PPP.
734 | Протокол управления PPP-связью был прерван.
735 | Запрошенный адрес был отвергнут сервером.
736 | Удаленный компьютер завершил работу протокола управления.
737 | Обнаружено замыкание на себя.
738 | Сервер не назначил адрес.
739 | Протокол проверки подлинности, требуемый удаленным сервером, не может использовать сохраненный пароль. Перезвоните и введите пароль явно.
740 | Обнаружено недопустимое правило дозвона.
741 | Локальный компьютер не поддерживает требуемый тип шифрования данных.
742 | Удаленный компьютер не поддерживает требуемый тип шифрования данных.
743 | Удаленному компьютеру требуется шифрование данных.
744 | Система не может использовать номер подсети IPX, назначенный ей удаленным компьютером. Дополнительная информация находится в журнале событий.
745 | ERROR_INVALID_SMM
746 | ERROR_SMM_UNINITIALIZED
747 | ERROR_NO_MAC_FOR_PORT
748 | ERROR_SMM_TIMEOUT
749 | ERROR_BAD_PHONE_NUMBER
750 | ERROR_WRONG_MODULE
751 | Номер ответного вызова содержит недопустимые символы. Допустимы только следующие 18 символов: цифры (от 0 до 9), T, P, W, (, ), -, @, и символ пробела.
752 | При обработке этого сценария была обнаружена синтаксическая ошибка.
753 | Подключение не может быть разорвано, поскольку оно создано мультипротокольным маршрутизатором.
754 | Системе не удается найти многоканальный пучок.
755 | Система не может выполнить автоматический дозвон, поскольку это подключение имеет параметры для конкретного звонящего пользователя.
756 | Это подключение уже выполнено.
757 | Службы удаленного доступа не могут запускаться автоматически. Дополнительную информацию можно найти в журнале событий.
758 | Для этого подключения уже разрешен общий доступ к подключению Интернета (ICS).
759 | Произошла ошибка при изменении параметров общего доступа к подключению Интернета.
760 | Произошла ошибка при разрешении маршрутизации.
761 | Произошла ошибка при разрешении общего доступа к подключению Интернета.
762 | При настройке общего доступа к локальной сети произошла ошибка.
763 | Невозможно разрешить общий доступ к подключению Интернета. Более чем одно подключение по локальной сети будет использовано совместно.
764 | Считыватели смарт-карт не установлены.
765 | Не удается разрешить общий доступ к подключению Интернета. Подключение по локальной сети уже настроено на использование IP-адреса, который распределяется автоматически.
766 | Не удалось найти сертификат. Подключениям, которые используют этот L2TP-протокол через IPSec, требуется установка на компьютере сертификата компьютера.
767 | Не удается разрешить общий доступ к подключению к Интернет. Подключение локальной сети, выбранной в качестве частной, настроено на использование более одного IP-адреса. Измените параметры настройки подключения к локальной сети.
768 | Ошибка шифрования данных при попытке подключения.
769 | Указанное назначение недостижимо.
770 | Удаленный компьютер отверг попытки подключения.
771 | Попытка подключиться не удалась, поскольку сеть перегружена.
772 | Аппаратура удаленного компьютера несовместима с типом запрашиваемого вызова.
773 | Попытка подключиться не удалась из-за изменения адреса назначения.
774 | Попытка подключиться не удалась из-за временной ошибки.
775 | Подключение было блокировано удаленным компьютером.
776 | Подключиться не удалось, поскольку удаленный компьютер вошел в режим "Не беспокоить".
777 | Попытка подключения не удалась, поскольку на удаленном компьютере не работает модем или другое устройство связи.
778 | Невозможно проверить идентичность сервера.
779 | Для выполнения исходящих звонков с помощью этого подключения используйте смарт-карту.
780 | Пробная функция недопустима для этого подключения.
781 | Попытка шифрования не удалась, поскольку не найден доступный сертификат.
782 | Общий доступ к подключению (NAT) установлен как протокол маршрутизации, и должен быть удален перед разрешением общего доступа к подключению к Интернета.
783 | Не удается разрешить общий доступ к подключению к Интернет. Подключение локальной сети, выбранной в качестве частной, либо не существует, либо разорвано. Убедитесь, что подключен сетевой адаптер.
784 | Невозможно использовать это подключение во время загрузки, поскольку оно использует имя пользователя, отличное от пользователя смарт-карты. Для использования его во время загрузки, измените используемое имя на имя владельца смарт-карты.
785 | Невозможно использовать это подключение во время загрузки, поскольку оно настроено на использование смарт-карты. Измените свойства этого подключения, чтобы использовались данные смарт-карты.
786 | Попытка L2TP-подключения не удалась, поскольку отсутствует допустимый сертификат на вашем компьютере для проверки подлинности.
787 | Попытка L2TP-подключения не удалась, поскольку не удалось проверить подлинность удаленного компьютера на уровне безопасности.
788 | Попытка L2TP-подключения не удалась, поскольку на уровне безопасности не удалось согласовать параметры с удаленным компьютером.
789 | Попытка L2TP-подключения не удалась из-за ошибки, произошедшей на уровне безопасности во время согласований с удаленным компьютером.
790 | Попытка L2TP-подключения не удалась из-за ошибки проверки сертификатов.
791 | Попытка L2TP-подключения не удалась, поскольку не найдена политика безопасности.
792 | Попытка L2TP-подключения не удалась, поскольку истекло время согласования режима безопасности.
793 | Попытка L2TP-подключения не удалась из-за ошибки согласования режима безопасности.
794 | Установленный RADIUS-атрибут "Кадрированный протокол" (Framed Protocol) для этого пользователя имеет значение не PPP.
795 | Установленный RADIUS-атрибут "Тип туннеля" (Tunnel Type) для этого пользователя имеет некорректное значение.
796 | Установленный RADIUS-атрибут "Тип службы" (Service Type) для этого пользователя не имеет значения ни "Кадрированный" (Framed), ни "Кадрированный для ответных вызовов" (Callback Framed).
797 | Попытка подключения не удалась, поскольку не найден модем или другое устройство связи. Убедитесь, что модем или другое устройство связи действительно установлено.
798 | Не удалось найти сертификат, который был бы использован с протоколом расширенной проверки подлинности (EAP).


Приложение 2: Коды состояний

Номер состояния | Кодовое название | Описание состояния
При соединении устройств
0 | RASCS_OpenPort | Идет открытие коммуникационного порта устройства
1 | RASCS_PortOpened | Коммуникационный порт устройства был успешно открыт
2 | RASCS_ConnectDevice | Идет процесс соединения коммуникационных устройств (в случае модемного соединения, "Идет набор номера...")
3 | RASCS_DeviceConnected | Коммуникационное устройство было соединено с другим и готово для передачи бинарных данных
4 | RASCS_AllDevicesConnected | В случае использования множественного соединения: все устройства соединены с другими и готовы для передачи бинарных данных
16 | RASCS_WaitForModemReset | Ожидание инициализации модема или другого коммуникационного устройства
При аутентификации (проверки данных)
5 | RASCS_Authenticate | Запрашивание подтверждения и проверки данных
6 | RASCS_AuthNotify | Уведомление об авторизации (требуется авторизация для соединения)
7 | RASCS_AuthRetry | Повторная авторизация
8 | RASCS_AuthCallback | Удаленный компьютер запрашивает обратный звонок для последующей авторизации
9 | RASCS_AuthChangePassword | Уведомление об изменении пароля удаленного соединения
10 | RASCS_AuthProject | Регистрация компьютера в сети
11 | RASCS_AuthLinkSpeed | В случае использования множественного соединения: сбор информации от всех устройств о скорости соединения
12 | RASCS_AuthAck | Запрос удаленного компьютера о подтверждении авторизации
13 | RASCS_ReAuthenticate | Запрос на повторную авторизацию
14 | RASCS_Authenticated | Проверка данных завершена
18 | RASCS_Projected | Компьютер зарегистрирован в сети
19 | RASCS_StartAuthentication | Начало процесса аутентификации
4097 | RASCS_RetryAuthentication | Запрос на повторную аутентификацию
4099 | RASCS_PasswordExpired | Пароль более не действителен
Состояния обратного звонка
15 | RASCS_PrepareForCallback | Идет подготовка к обратному звоку
17 | RASCS_WaitForCallback | Ожидание обратного звонка
20 | RASCS_CallbackComplete | Обратный звонок был завершен
4098 | RASCS_CallbackSetByCaller | Запрос на обратный звонок был установлен клиентом
Состояния соединения
4096 | RASCS_Paused или RASCS_Interactive | Запрос на операцию с ожиданием ввода данных от пользователя
21 | RASCS_LogonNetwork | Вход в удаленную сеть
8192 | RASCS_Connected или RASCS_DONE | Подключение к сети было успешно завершено и готово к работе
8193 | RASCS_Disconnected | Связь была прервана


Приложение 3: Модификаторы телефонного номера

№ п/п | Модификатор | Применение | Описание | Пример
1 | W | В любой части телефонного номера. Только при импульсном наборе | "Ждать наборного тона". Используется при выходе на междугороднюю линию. Позволяет "подождать" гудка перед набираемой частью. | 8W600100
2 | P | Перед набираемым номером | Устанавливает импульсный набор номера | P8W600100
3 | T | Перед набираемым номером | Устанавливает тональный набор номера | T222322
4 | @ | В любой части телефонного номера | Ждать ответной паузы. Модем в течение 30-ти секунд ждет 5-ти секундной тишины в телефонной линии. | P2@22322
5 | R | После телефонного номера | Войти в режим ответа после набора телефонного номера. Используется, если модем на другой стороне не инициирует автоматически сигнал ответа. | T222322R
6 | , | В любой части телефонного номера | Пауза на 2 секунды | P,222322
7 | ! | В любой части телефонного номера | Пауза на 0,5 секунды | P!222322
8 | / | В любой части телефонного номера | Пауза на 0,125 секунды | P2/22322


Приложение 4: Оптимизация Интернет-соединений

Примечание: Если вы пользуйтесь ОС Microsoft Windows NT5 (Windows 2000, XP, 2003...) то смысла нет целиком читать данную статью. В этих ОС Интернет-подключения уже оптимизированы. Также рекомендую воспользоваться утилитой Internet-Tweak (сайт: www.magellass.com).

Также примите во внимание некоторые советы:

1. Освобождение канала (bandwidth), зарезервированного за сервисом QoS

Это такая хитрющая штука, о которой я бы вжись не догадался, если бы не прочитал на сайте улучшалок ХР. Как оказалось, Windows XP по умолчанию выделяет часть Интернет-канала для очень полезной штуки, которая называется Quality of Service (QoS). Назначение QoS - улучшать распределение трафика программ, написанных с учетом QoS API. Другое дело, что этих программ днем с огнем не сыскать (вернее, у меня лично они не стоят), поэтому резервирование канала под ненужный сервис - непозволительная роскошь. Вот что нужно проделать для того, чтобы освободить и без того узкий канал отечественного соединения с Интернетом:

В меню Start - Run запустите редактор групповых полисов: gpedit.msc. Имейте ввиду, что для выполнения всех этих процедур вам необходимо войти в систему как Администратор. В разделе Computer Configuration (в левом окне) выберите Administrative Templates. Далее Network и затем в правой панели выберите QoS Packet Scheduler и кликните на нем два раза. Выберите опцию limit reservable bandwidth и опять-таки кликните на ней два раза. В открывшемся окне включите Enabled, а затем укажите лимит канала в процентах равный нулю. ОК и выйдите из программы. Но это еще не все.

Отправляйтесь в сетевую конфигурацию (иконка Network Connections в Контрольной панели). Выделите свое соединение и из контекстного меню запустите Properties
В закладке Networking убедитесь, что протокол QoS Packet Scheduler подключен (enabled). Если его там нет, то добавьте из списка (через кнопку Install). Перегрузите компьютер.

Все эти сложные пассы с насильственным включением сервиса и последующим выделением под него нулевого канала вызваны тем, что если просто отключить Quality of Service, то, как это часто бывает у наших антипятов, система все равно будет резервировать под него 20 % канала.

Отключение заданий по расписанию (scheduled tasks)

Всякий раз, как MSIE 6.0 соединяется с сервером, он тратит время на проверку наличия заданий по расписанию, связанных с данным адресом. Поскольку я никогда не пользовался и не планирую пользоваться функцией синхронизации Проводника, то я отключил планировщик заданий:

В реестре нужно удалить следующий ключ - HKEY_LOCAL_MACHINE \ Software \ Microsoft \ Windows \ CurrentVersion \ explorer \ RemoteComputer \ NameSpace \ {D6277990-4C6A-11CF-8D87-00AA0060F5BF}.

Оптимизация соединения Windows 98 и Millenium:

Пока цивилизованный мир вовсю осваивает Интернет, используя широкополосный доступ посредством выделенных линий, всевозможных кабельных модемов, ISDN, ADSL и прочих недоступных нашему пользователю прибамбасов, мы с вами довольствуемся дешевой и доступной (пока не ввели повременку) модемной связью, не забывая периодически ругать ее за плохое качество и низкую скорость передачи данных.

Однако грамотным пользователям достаточно хорошо известно, что иногда удается заметно ускорить свою работу с Интернетом, если удачно настроить некоторые слабо документированные параметры операционной системы Windows 9x. То, что при настройке соединения с Интернет-провайдером надо первым же делом выставить параметры протокола TCP/IP, стало уже догмой и многие даже не задумываются, насколько общепринятые настройки подходят именно для их конкретного соединения.

Тем более что при этом совершенно не нужно обладать какими-то особыми знаниями - программ, предназначенных для автоматического внесения в реестр Windows всех необходимых изменений настолько много, что создается впечатление, будто все начинающие программисты набираются опыта именно на "ускорителях Интернета". А между тем, слепо изменяя установленные в Windows по умолчанию значения на среднестатистические, следуя советам, почерпнутым из порой сомнительных источников, вы можете с равной вероятностью как улучшить скорость прокачки файлов, так и ухудшить ее.

Tочно так же, оставив в покое настройки ОС, вы в ряде случаев будете зря терять время и деньги, не используя по максимуму свой Интернет-доступ. Что же это за таинственные параметры и каким образом следует выбирать наиболее оптимальные в каждом конкретном случае значения?

MTU
Первым делом, конечно же, надо разобраться с давно навязшим в зубах параметром MTU - Maximum Transmission Unit. В реестре он задается таким образом:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\
Services\Class\NetTrans\000х
"MaxMTU"="1500"

Это максимальный размер пакета данных, который может быть передан за один физический кадр по протоколу TCP/IP. Дело в том, что данные от компьютера к компьютеру в Интернете идут не сплошным потоком, а этими самыми кадрами - пакетами строго определенного размера. Если бы все компании и фирмы, имеющие хоть какое-то отношение к Интернету, договорились о едином стандарте на размер этих пакетов, то мы бы использовали каждый такой кадр по максимуму, полностью заполняя каналы передачи данных своими битами.

Однако это не так. Мало того, что при установке нового соединения два удаленных компьютера должны согласовать между собой размер кадра, так еще и по пути к месту назначения пакет преодолевает целый ряд промежуточных серверов и маршрутизаторов, настройки MTU которых могут быть совершенно различными. При этом слишком большой пакет в пути, скорее всего, будет фрагментироваться и заполняться "воздухом", "балластом", что негативно скажется на эффективности связи.

Так, если ваш провайдер имеет установки MTU=576, а у вас в Windows задано MTU=1500, то каждый ваш пакет будет им разбиваться на три по 576 байт: 576+576+576=1728 - то есть 228 байт балласта будут добавляться к каждому вашему пакету. Но даже если провайдер тоже поставил у себя MTU=1500, то при связи с удаленным сервером вполне может попасться маршрутизатор с меньшим значением MTU и пакеты опять-таки будут фрагментироваться, замедляя передачу данных.

Несколько спасает ситуацию включенная в "виндах" по умолчанию функция автоматического определения MTU - "PMTU Discovery" или, как ее иногда называют, "MTU Auto Discovery", однако процедура вычисления MTU для каждого соединения требует немало времени, что чуть тормозит работу при прокачке небольших файлов и веб-серфинге. Да и в случае несогласования ваших параметров с параметрами провайдера эта функция вряд ли вам поможет. Конечно, существуют некие более или менее общепринятые стандарты для данного параметра: так, например, для Ethernet MTU равен 1500 байт, для SLIP - 1006, для PPPoE -1492, для PPP (то есть модемной связи с Интернетом) - 576.

Но на деле ваш провайдер может выбрать отличное от этих значений число, исходя из каких-то своих соображений. Мы же в результате либо не загружаем свой канал связи полностью, отправляя кадры меньшего размера, чем это позволяет провайдер и часто посещаемые серверы, либо наоборот, наши установки превышают необходимое значение и большие пакеты идут фрагментированными, что еще более снижает возможности линии связи.

Каждый такой пакет данных в действительности состоит из нескольких сегментов - нескольких заголовков и фактических данных. Та его часть, в которой содержатся только фактические данные, называется MSS (Maximum Segment Size) - это еще один параметр протокола TCP, определяющий самый большой сегмент данных TCP, которые могут быть переданы за один раз. То есть, MTU = MSS + заголовки TCP/IP. В реестре MSS задается так:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\
Services\VxD\MSTCP
"DefaultMSS"="ваше число"

Для заголовка тоже имеется общепринятый размер - это 40 байт (20 байт IP и 20 байт TCP), следовательно, обычно MSS = MTU - 40. По этой причине в определении оптимального размера MTU есть некоторые тонкости.

Давайте изучим передачу данных при разном размере MTU по широкополосной линии T1 (пропускная способность - 1 544 000 бит/с), используя следующую формулу:
[(MSS + заголовок) * 8 бит/байт] / [1 544 000 бит/с] = задержка на один хоп (то есть на каждый компьютер в Сети по пути нашего пакета). Используя в этой формуле разные величины MTU, мы можем вычислить задержку одного пакета. Если MTU=1500, тогда задержка = (1460 + 40) * 8 / 1 544 000 = 7,772 мс. Если же MTU=576, то задержка = (536 + 40) * 8 / 1 544 000 = 2,984 мс.

Предположим, что по пути пакета встречается 10 серверов, тогда при MTU=1500 получим задержку 77,72 мс, а при MTU=576 - 29,84 мс - разница весьма заметна.

Таким образом, очевидно, что меньшие пакеты будут переданы быстрее просто из-за ограничения производительности линии. Однако не все так просто.
Используя ту же формулу, давайте посчитаем, за какой промежуток времени будет передан файл размером 1 Мбайт по той же широкополосной линии T1. Один мегабайт равен 1024 кбайт или 1 048 576 байт. Если MTU=1500, то, как мы выяснили, задержка на один хоп составит 7,772 мс.

Сколько при этом понадобится послать пакетов? 1 МБ / MSS = 1 048 576 / 1460 = 718,2, то есть всего требуется 719 эффективных пакетов, чтобы передать 1 мегабайт данных. Далее, умножаем 719 пакетов на 7,772 мс, получаем 5588,083 мс, или 5,588 секунд задержки на один хоп. Если же мы передаем свой файл через 10 хопов, что встречается чаще, чем один, то получаем 55,88 сек. - это время, которое мы (вернее, провайдер, имеющий линию T1) потратим на передачу файла в 1 МБ при идеальной связи. Если же MTU=576, то: 1 МБ / MSS = 1 048 576 / 536 = 1956,300, то есть при таком MTU нужно 1957 пакетов, чтобы передать 1 мегабайт.

Далее, умножаем количество пакетов на задержку каждого из них: 1957 * 2,984 = 5840,580 мс, или 5,841 секунды на один хоп. Ну и соответственно на 10 хопов придется 58,41 сек. Как видим, из-за того, что при использовании больших пакетов передается меньше заголовков, реальная скорость передачи файла получается выше.

Для того чтобы передать 1 мегабайт при использовании MTU = 1500 нужно переслать "довесок" заголовков из 28 760 байт, тогда как при использовании MTU=576 получаем аж 1957 * 40 = 78 280 байт, то есть дополнительные 49 520 байт заголовков на каждый мегабайт полезной информации. Для нашей 10-хоповой передачи это выливается в лишних 2,52 секунды при передаче каждого мегабайта даже при сверхбыстрой связи.

Эта разница, возможно, будет еще немного выше на практике, так как современные реализации TCP/IP стремятся использовать еще большие заголовки (например, дополнительные 12 байтов заголовка для отметок времени). Если же провести аналогичные расчеты для связи по модему на скорости
33 600 кбит/с, то получим, что на передачу мегабайта информации на расстояние одного хопа, то есть непосредственно вашему провайдеру, будет потрачено в идеале 256 секунд при MTU=1500 и 268 секунд при MTU=576.

Разница на одном переходе 12 секунд или около 4,5%! Но не следует забывать, что эти цифры получатся при условии отсутствия фрагментации пакетов, то есть если у вашего провайдера MTU=1500. Если же это не так, то, разумеется, больший, чем нужно, пакет будет фрагментироваться - разбиваться на несколько пакетов и даже разбавляться "воздухом", и связь ухудшится на 10-50%.

Таким образом, логично считать, что большие пакеты в итоге все-таки предпочтительнее, и если ваш провайдер настроил свои серверы и маршрутизаторы на большие пакеты, то надо стремиться использовать это на всю катушку, но не забывать и о том, что в Интернете встречаются серверы с MTU=576 (об этом чуть ниже мы еще поговорим). Тем не менее, если чистая производительность не является окончательной целью, то меньшие пакеты будут более "быстрыми", поскольку они требуют меньше времени для своих путешествий по Сети.

Этот эффект может перевешивать все другие достоинства больших пакетов в некоторых Интернет-приложениях и онлайновых играх за счет уменьшения времени отклика удаленного сервера при передаче небольших объемов информации.

В Интернете по пути следования ваших пакетов, вероятно, встретятся самые разные серверы с самыми разными настройками, но для начала все-таки желательно определить наилучшее значение MTU при связи только с вашим провайдером, поскольку именно оно может оказать решающее значение при оптимизации вашего доступа в Сеть.

В Windows 95 разработчиками по умолчанию было выбрано MTU=1500, что якобы не соответствует оптимальному для модемного соединения значению, которое всеми считается равным 576. В Windows 98 корпорация Microsoft уже исправила этот недостаток, и теперь по умолчанию при соединениях ниже 128 килобит в секунду мы имеем MTU=576, что вроде бы должно чаще оказываться наилучшим вариантом. Попробуем разобраться, так ли оно на самом деле.

Итак, есть несколько способов определить значение MTU, оптимальное для связи с вашим Интернет-провайдером.
1. Послать письмо с вопросом в службу технической поддержки провайдера. Тут в принципе все понятно - если работники провайдера сами в курсе своих собственных настроек, то они дадут вам квалифицированный ответ, который, впрочем, не помешает все-таки и проверить самолично на практике.

2. Подключиться к Интернету в терминальном режиме - иногда при осуществлении регистрации пользователя в одной из строк появляется рекомендуемое значение MTU. Для этого войдите в папку "Удаленный доступ", найдите там значок своего соединения и, щелкнув по нему правой кнопкой мыши, выберите пункт "Свойства".

На странице "Общие" открывшегося меню жмите кнопку "Настроить" возле строки с названием вашего модема и в диалоге свойств модема переходите на вкладку "Дополнительно", где установите флажок "Выводить окно терминала после соединения". Теперь соединяйтесь с провайдером и при появлении окна терминала вводите вручную имя пользователя и пароль по соответствующим запросам. Если после этого вы увидите что-то типа "Entering PPP mode. Your IP address is ххх.ххх.ххх.ххх. MaxMTU is 1524", то вам повезло - вы получили MTU провайдера. Но и тут нелишним будет проверить это значение лично.

3. И, наконец, ручное определение MTU.

Определение MTU вручную

Для адекватных результатов экспериментов обязательно необходимо выставить в операционной системе максимальный размер MTU=1500. Поэтому, если вы уже пытались изменять этот параметр с помощью какой-то программы или вручную в реестре, то обязательно отмените все внесенные изменения, вернув default-настройки.

В этом вам помогут утилиты Internet Tweak 2001 (http://www.magellass.com/), NetBoost 99 (http://www.download.ru/), iSpeed (http://www.hms.com/), MTUSpeed (http://www.mjs.u-net.com/), BlazeNET (http://www.indeavour.com/html_about_blazenet.htm) - выбирайте по вкусу. В реестре же вам придется проконтролировать это в разделе:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\
Services\Class\NetTrans\000х

Если найдете там параметр MaxMTU, то смело удаляйте его. Далее, открываем "Панель управления" (Control Panel) - "Сеть" (Network), выбираем "Контроллер удаленного доступа" (Dial-Up Adapter) и жмем кнопку "Свойства" (Properties). На вкладке "Дополнительно" (Advanced) появившегося меню устанавливаем большой размера IP-пакета ("IP Packet Size" - "Large"). Тем самым мы установили для нашего соединения MTU=1500. Перегружаем компьютер, чтобы изменения вступили в силу.

Теперь надо установить соединение с Интернетом и посмотреть, будут ли фрагментироваться пакеты различного размера. Для этого можно использовать и стандартную программу Ping из комплекта Windows, задавая ей такие параметры: ping -f -l 1500 ххх.ххх.ххх.ххх, где "ххх.ххх.ххх.ххх" - IP-адрес тестируемого сервера, а "-I" - это буква L, а не единица.

Но гораздо удобнее применять что-нибудь типа утилит CyberKit (http://www.cyberkit.net/ или IPTools (http://www.ks-soft.net/ip-tools.eng/index.htm) - в них есть приятный графический интерфейс вместо анахронизма командной строки Ping. Определяем сначала этой же многофункциональной программой IP-адрес одного из серверов вашего провайдера, тем самым мы избежим запросов к DNS-серверу во время тестирования.

Примените для этого вкладку "TraceRoute", введя в поле адреса URL провайдера. Теперь полученный IP вводим на странице "Ping", задаем для начала размер пакета 1500 и ставим флажок "Don't fragment" - "Не фрагментировать". В поле, где задается количество тестовых пакетов ставьте штук 5-6 - для того чтобы исключить случайные ошибки. Кстати, тест лучше проводить глубокой ночью, когда на линиях сидит мало народа и помех в телефонных сетях минимум.

Если никакого ответа не получено и наш пакет потерян, так как фрагментировать мы его запретили, а его размер слишком велик для настроек оборудования провайдера, то начинаем постепенно уменьшать величину пакета до тех пор, пока не станем получать отклики от сервера со значением этого самого "пинга". Так, например, для провайдера CEA мы получим размер неделимого пакета в 1472 байта. Означает ли это, что он использует MTU=1472?

Нет, у него MTU=1500, просто Ping прибавляет к нашим данным заголовок, который по-разному учитывается удаленными серверами, например, CEA не принимает во внимание заголовок IP (20 байтов) и ICMP (8 байтов) при отчете о своем MTU. Если же вам не повезло, и ваш провайдер выбрал меньшее значение, то ищите его среди таких чаще всего попадающихся цифр (также не забывая и о заголовке пакета): 1524, 1152, 1024, 1006, 576, 568, 560, 552, 548, 536, 528, 520, 512.

Таким образом, мы выяснили, что можно выбирать любой MTU, вплоть до 1500. Попробуйте теперь осуществить загрузку одного и того же ZIP-файла размером 1 мегабайт с одного и того же быстрого сервера при разных значениях MTU - максимальном, полученном от провайдера, и рекомендуемом 576. Для чистоты эксперимента отключите автоопределение MTU - параметр PMTU Discovery (о том, как его найти в реестре, читайте в конце статьи).

Скорее всего, вы обнаружите, что наши расчеты, говорящие о предпочтительности больших пакетов, справедливы. Проведите и такой эксперимент: "пингуйте" наибольшим нефрагментируемым пакетом (в нашем случае это 1472, то бишь MTU=1500) сайты, занесенные в список закладок. Вас ждет удивительное открытие - оказывается, большинство сайтов прекрасно воспринимают MTU=1500 и все пакеты до них доходят нефрагментированными.

Где же тот самый MTU=576, который якобы преобладает в Интернете? Проверьте также и свою любимую сетевую игру при разных MTU. Исходя из полученных данных, а не из того, что вам советуют всевозможные "эксперты", сами никогда не проделывавшие подобных опытов, а повторяющие только то, что принято за истину на загнивающем Западе, вы уже гораздо более объективно определите, какое же значение наилучшим образом согласуется с вашим Интернет-доступом - наибольшее или меньшее.

Действительно, на качество и скорость работы в Сети сильное влияние оказывает фрагментация пакетов, которая происходит, если большой пакет проходит через сеть, имеющую MTU меньше, чем длина вашего пакета.

Можно, конечно, перестраховаться и выбрать самый минимальный размер MTU, при котором пакеты наверняка не будут фрагментироваться, но это может сказаться на быстродействии вашей системы еще более пагубно, чем использование больших пакетов. На самом же деле, главное - чтобы ваш MTU не превосходил MTU провайдера, при включенной же функции PMTU система сама найдет для ваших пакетов такой путь в Сети, при котором они не будут фрагментироваться.

Кстати, если вы обнаружите, что у провайдера установлено MTU=512 и менее, то есть смысл подумать о его смене - слишком много шлака будет передаваться вместе с вашими данными.

Другие параметры

Не только от одного MTU зависит качество вашей работы в Интернете, существует немало и других параметров протокола TCP, с которыми стоит поэкспериментировать. Конечно, есть уже некоторые готовые рекомендации и в этом случае, но, бездумно им доверяя, вы имеете шанс получить совсем не тот результат, к которому стремитесь.

Поэтому и тут крайне желательно для каждого параметра провести свой эксперимент, определяя, какой эффект вызывает его изменение в вашей конкретной системе. Многие из этих параметров легко выставляются с помощью все тех же незамысловатых утилит, что и MTU.

RWIN (receive window, окно приема) - размер буфера, в котором накапливается содержимое области данных (MSS) нескольких полученных пакетов, прежде чем передается дальше, например, в браузер. При недостаточном размере этого буфера иногда происходит его переполнение и поступающие пакеты отвергаются и теряются.

Размер RWIN обязательно должен быть кратен MSS и обычно для лучшей эффективности модемного соединения кратность рекомендуется устанавливать равной 4-8. Однако чрезмерно большой размер буфера также нежелателен, особенно на плохих линиях - при потере всего одного пакета в случае сбоя на линии будет повторно затребован не один потерянный пакет, а все пакеты из этого буфера, что займет некоторое время.

В реестре этот параметр находится здесь:

HKEY_LOCAL_MACHINE\System\CurrentControl
Set\Services\VxD\MSTCP
"DefaultRcvWindow"="ваше значение"

TTL (time to live, время жизни) - количество хопов, то есть промежуточных серверов, через которые может пройти ваш пакет в поисках своего места назначения. Каждый такой сервер добавляет единицу к специальному счетчику в заголовке вашего пакета, и, когда счетчик достигает максимально разрешенного значения, пакет считается заблудившимся и прекращает свое существование. По умолчанию TTL равен 32, что сегодня явно недостаточно для разросшегося Интернета: нередки случаи, когда удаленный сервер находится более чем в 32 переходах, поэтому TTL следует увеличить как минимум до 64:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP
"DefaultTTL"="64"

IPMTU - Internet Protocol MTU - в Windows 98, по сути, это то же самое, что и MTU, но применительно только к контроллеру удаленного доступа. В реестре он упоминается несколько раз:

HKEY_LOCAL_MACHINE\System\CurrentControlSet
\Services\Class\Net\000х
"IPMTU"="1500"

HKEY_LOCAL_MACHINE\System\CurrentControlSet\
Services\Class\Net\000х\Ndi\params\IPMTU
"default"="1500"
@="1500"

PMTU (Path MTU, путевое значение MTU) - этот параметр разрешает Windows самой определять оптимальное значение MTU при организации соединения с каждым сервером. При этом серверу посылается ряд нефрагментируемых пакетов разного, постепенно уменьшающегося размера и как только очередной пакет достигнет сервера, его размер и считается оптимальным. На эту процедуру, разумеется, требуется некоторое время и по умолчанию она включена, в связи с чем часто советуют ее дезактивировать, что, пожалуй, все-таки довольно спорно - потерять на этом времени можно больше из-за того, что наилучший размер блока данных определен не будет и пакеты пойдут фрагментированными.

Выключается же этот режим так:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP
"PMTUDiscovery"="0"

PMTUBlackHole Detect (обнаружение "черных дыр") - установка этого параметра разрешает протоколу TCP пытаться обнаружить никуда не ведущие роутеры и те, что не возвращают ICMP-сообщений о необходимости фрагментации при определении наилучшего MTU. Это также, как и любая дополнительная процедура, может замедлять работу в Интернете - попробуйте поэкспериментировать с ее отключением:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP
"PMTUBlackHoleDetect"="0"

SessionKeepAlive (поддержание соединения) - определяет, как часто будут посылаться специальные пакеты информации, предотвращающие отключение вас сервером в случае отсутствия активности в Сети с вашей стороны. Минимум - одна минута, по умолчанию - один час в Windows Me / 9x и два часа в Windows 2000. Рекомендуемый интервал - 10 минут, параметр задается в секундах:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP "SessionKeepAlive"="600"

SlowNet - отключение этой функции может сократить задержки в передаче данных, но сей эффект уловить не так-то просто.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\
Class\Net\000х
"SLOWNET"=hex:00

NDI Cache (Network Device Interface Cache) - кэш, в котором хранятся данные о маршрутах движения пакетов, по умолчанию его размер равен нулю. Чтобы его задействовать наиболее оптимально, необходимо установить его размер равным 16 при модемном соединении или 32 при более скоростных подключениях:

HKEY_LOCAL_MACHINE\System\CurrentControlSet
\Services\VxD\NWLink\Ndi\params\cachesize
@="16"

В реестре обычно рекомендуется выставить еще некоторые параметры, влияние которых на качество связи проследить вообще чрезвычайно сложно, но попробовать поэкспериментировать с их значениями можно:

HKEY_LOCAL_MACHINE\System\CurrentControl
Set\Services\VxD\NWLink\Ndi\params\maxconnect
@="64"
"max"="128"
"min"="2"

HKEY_LOCAL_MACHINE\System\CurrentControlSet\
Services\VxD\NWLink\Ndi\params\maxsockets
@="255"
"max"="1020"
"min"="32"

HKEY_LOCAL_MACHINE\System\CurrentControlSet\
Services\VxD\NETBEUI\Ndi\params\ncbs
"default"="32"
"max"="255"
"min"="8"

HKEY_LOCAL_MACHINE\System\CurrentControlSet\
Services\VxD\NETBEUI\Ndi\params\sessions
"default"="32"
"max"="117"
"min"="4"

А нижеследующие параметры устраняют, по заверениям Microsoft, какие-то "глюки" Windows и увеличивают скорость работы вашего браузера:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\
Services\VxD\MSTCP
"BSDUrgent"="1"
"Tcp1323Opts"=dword:00000003
"SackOpts"="1"

А вот так вы увеличите количество одновременных подключений к серверу, что часто бывает весьма полезно:

[HKEY_USERS\.DEFAULT\Software\Microsoft\
Windows\CurrentVersion\Internet Settings]
"MaxConnectionsPer1_0Server"=dword:0000000a =10
"MaxConnectionsPerServer"=dword:00000008 =8

Процедура оптимизации Интернет-соединения - дело весьма хлопотное и неоднозначное. Несмотря на то, что программ, предназначенных якобы для двукратного улучшения связи одним кликом мыши, - пруд пруди. И тут, как мы выяснили, совсем не факт, что MTU=576, которое везде рекомендуется западными программистами и экспертами, будет оптимальным и для нас в России. Наши провайдеры сплошь и рядом выбирают для себя MTU=1500, а при "пинговании" удаленных серверов мы обнаруживаем, что пакет такого размера, вопреки всем утверждениям, проходит чаще всего нефрагментированным. При этом, как видно из наших вычислений, чем больше MTU, тем эффективнее используется ваш Интернет-доступ.

Возможно, наши рассуждения несколько спорны и противоречат общепринятым догмам на этот счет, поэтому, для того чтобы настроить вашу систему на максимальную производительность, вам придется лично: во-первых, выяснить действительное значение MTU своего провайдера; во-вторых - выбрав это значение, убедиться, что пакеты такого размера при связи с чаще всего вами посещаемыми серверами не будут фрагментироваться; в-третьих - провести эксперименты с закачкой одного и того же файла при разных значениях MTU; и в-четвертых - проверить, как сказывается изменение MTU на сетевых играх, если вас они, конечно, интересуют. Исходя их итогов этих опытов и стоит решать, какой размер максимального неделимого пакета вам следует в результате выбрать.

То, что везде рекомендуется, для вас может оказаться наихудшим вариантом. Аналогично наберитесь терпения и проверьте влияние и других параметров на быстродействие системы - я упомянул далеко не все, над чем можно поизвращаться. При этом можно даже проверять MTU провайдера регулярно - раз в месяц, в два - не изменилось ли оно, но это уже для маньяков, хоть и не представляет никакой сложности, как мы с вами убедились выше.

"Компьютеры и оргтехника: Оптимизация модемного соединения"


Интеграция в ОС

Интенграция в Windows

Версия 4.1 программы MuxaSoft Dialer содержит принципиально новый механизм интеграции программы в операционную систему Windows. Теперь вы можете инициировать дозвон из абсолютно любой программы, включая The Bat!, FlashGet, ReGet и др. Новый механизм перехватывает все обращения к подсистеме дозвона, а инициирующей программе сообщает об ошибке соединения.

Для использования в полной мере этой возможности необходимо правильно настроить саму программу-инициатора. После перехвата MDialer-ом звонка, программа-инициатор выдает ошибку "Соединение не может быть установлено", поэтому программа-инициатор долна быть настроена на автоматический повтор попыток установки связи. В случае с FlashGet, после инициирования дозвона сообщит неизвестную ошибку, а после успешного соединения через MDialer благополучно начнет загрузку файлов.

Механизм интеграции успешно работает в ОС Windows 2000, Xp, Server 2003, 98, Millenium.
В ОС Windows 98 и Millenium не прроисходит интеграция в стандартные средства дозвона Windows (Удаленный доступ к сети) из-за использования им старого 16-ти битного механизма дозвона. Интеграция происходит только со сторонними программи и броузерами.

см. также:

  • Возможности программы


Расширенные настройки профиля

Для записи экспертных ключей откройте ваш профиль (файл MDP) в любом текстовом редакторе (например, Блокнот). Все параметры вводятся в секцию [Advanced Options]:

UseHighcolorTrayIcons=2 | Показывать ли полноцветные значки в системном лотке Windows. 0 - использовать 16-тицветные значки, 1 - использовать полноцветные значки, 2 - автоопределение по типу ОС
SecondLevelControlTime=500 | Время в миллисекундах через которое будет проверятся состояние текущего соединения на предмет его обрыва или некорректного завершения
SchedulerQueryTime=40000 | Время в миллисекундах через которое будет проверятся задачи в планировщике. Рекомендуется использовать время не менее 30 секунд (30000 мсек) но не более 1 минуты (60000 мсек)
ThirdLevelControlTime=1000 | Время в миллисекундах через которое будет опрашиваться Windows на предмет появления новых соединений, поражденных не диалером. Используется для перехвата контроля над соединенями.
ExitProgramDelay=500 | Время в миллисекундах которое отводиться на завершение работы всех компонент диалера и его самого
HotMenuShowDelay=250 | Время в миллисекундах через которое появится меню "горячих" настроек после щелчка мыши.
ConMenuShowDelay=250 | Время в миллисекундах через которое появится контекстное меню после щелчка мыши.
ToolTipDelay=0.8 | Время в секундах через которое появится подсказка после движения мыши по значку в системном лотке.
SingatureAlgoritm=&HA1 | Алгоритм извлечения контрольной суммы данных. &HA1 - Secure Hash Algorithm (256 Bit) (внутренняя поддержка) 32769 - Message Digest 2 32770 - Message Digest 4 32771 - Message Digest 5 32772 - Secure Hash Algorithm (256/512 Bit)
EncryptAlgoritm=&HB1 | Алгоритм шифрования данных. &HB1 - RC4 (внутренняя поддержка) 26113 - DES 26121 - Third DES 112 26115 - Third DES 26114 - RC2 26625 - RC4 26626 - SEAL 43521 - DH SF 43522 - DH EPHEM 26122 - SkipJack 26124 - CyLink
SaveStatCounters=0 | Сохранять статистику в регистры. 0 - не сохранять (показывать за сеанс), 1 - сохранять (показывать за период)
RemoteConnsLimit=255 | Максимальное количество одновременных соединений для удаленного администрирования.
PingTimeOut=15000 | Таймаут для операции PING

см. также:

  • Возможности программы


Основное контекстное меню

С основного контекстного меню начинается работа с программой. В этом меню сосредоточены основные возможности и окна программы. Меню содержит такие пункты как:

  • Параметры - открывает окно параметров программы
  • Состояние - открывает окно состояния программы и соединения
  • Монитор - выводит монитор соединения
  • Статистика - открывает программу Log Manager для просмотра статистики соединений
  • Список соединений, установленных на вашем компьютере. Из этого списка вы выбираете нужные вам соединения для установки связи (перебора номеров и соединений).
  • Звонить - команда на установку связи с первым успешным соединением из выбранных
  • Разъединить - команда на успешный разрыв связи с провайдером и переход в режим Ожидание.
  • Высказаться - открывает ваш почтовый клиент и создает новое сообщение, направленное в службу технической поддержки
  • Обновить MDialer - открывает окно вашего браузера и перенаправляет на страницу разработчиков
  • Выход - завершение работы программы.

Для вызова данного меню нужно нажать один раз правой кнопкой мыши на значок MDialer-а "Желтый телефон" в системном лотке. Мен отобразиться через несколько долей секунд.

см. также:

  • Hot-меню программы
  • Возможности программы


Hot-меню (меню горячих настроек)

Hot-меню - специальное меню, которое позволяет настроить некоторые параметры соединения двумя щелчками мыши. Для вызова этого мен необходимо щелкнуть левой кнопкой мыши по значку MDialer-а в системном лотке.

В зависимости от состояния диалера меню будет выглядеть по-разному.

Если вы не подключены к сети, будет выведено меню Hot-Dial (меню для быстрого дозвона к указанному провайдеру).

Если вы подключены к сети, идет дозвон или авторизация, будет выведено меню "Горячих" настроек, которое состоит из пунктов:

  • Лимитировать время в сети (включает/выключает лимит проведения в сети по времени)
  • Контроль потока данных (включает/выключает функцию TR-Control соединения - контроль активного трафика за промежуток времени)
  • Проверка скорости соединения (включает/выключает функцию Speed-Control - контроль скорости подключения к провайдеру).
  • PING-овать сервер (включает/выключает функцию Ping-Control для данного соединения - контроль ответа от сервера провайдера или любого другого).
  • Показать статистику (открывает программу Log Manager с открытой статистикой для данного соединения)
  • Сбросить счетчики статистики (сбрасывает счетчики статистики за период для данного соединения)

Вы можете вызвать это меню в момент начала дозвона, процесса авторизации или непосредственно в состоянии Он-Лайн.

Если вы вызовите меню горячих настроек в режиме ожидания программы, вы увидите меню быстрого дозвона.

Данное меню было разработано специально для соединения с провайдером двумя кликами мышки: нажмите на учетную запись необходимого провайдера и соединение установиться автоматически.

Внимание! Если вы дозванивайтесь таким методом, номера телефонов и соединения не будут перебираться при ошибке соединения! Звонок будет осуществлен по первому разрешенному номеру.

Также имеет место опция Не начинать дозвон из других программ. Это очень полезная опция и предназначена для управления интеграцией диалера с ОС Windows (см. Интеграция с ОС)

см. также:

  • Интеграция с ОС
  • Возможности программы
  • Контекстное меню


Окно Монитор соединения

Монитор удаленного соединения используется для получения оперативной статистики соединения как за текущий сеанс так и за весь период. Монитор вызывается через контекстное меню программы (пункт Монитор).

Монитор состоит из 4-х частей:

  • главного таймера соединения
  • слева представлены описания пунктов счетчиков
  • справа представлены значения счетчиков
  • кнопки управления монитором

Монитор имеет степень прозрачности и настраивается в соответствующем разделе параметров (см. Настройка монитора). В мониторе могут отображаться данные как за сеанс так и за весь период.

см. также:

  • Настройка монитора
  • Возможности программы


Окно Параметры

Данное окно является самым главным окном программы, где происходит ее настройка и управление. Окно, как и любое другое окно Windows содержит и характеризуется:

  • заголовок окна со значком программы, названием окна и кнопкой закрытия.
  • окно не имеет возможности растяжения по высоте и ширине
  • на панели слева представлены вкладки страниц настройки программы
  • над этой панелью находится название вкладки, описание ее назначения и значок, характеризующий ее назначение
  • кнопки Закрыть и Справка с соответствующими функциями.

Все окна программы имеют графический нестандартный вид и оптимизированы под особенности интерфейса Windows XP. Области, разделяющие смысловые функции элементов (фреймы) выполнены в градиентном виде (т.е. их граница), что дает четкое их выделение среди других элементов.

Все настраиваемые возможности разбиты на категории, а они в свою очередь, на разделы. Раздел "Параметры" содержит вкладки, которые содержат возможности настройки программы в целом, ее поведение, опции и т.д.

Раздел "Соединения" содержит вкладки, настройки которых связаны и задаются для конкретного соединения.

Раздел "Прочее" несет в себе дополнительные сервисные возможности программы.

Также существует раздел "Модули", в которой отображаются подключаемые расширения к программе

см. также:

  • возможности программы
  • системные требования


Окно Статус программы

Окно статуса программы отображает состояния соединения и программы. Состояний программы всего пять:

  • Инициализация программы (происходит при запуске программы)
  • Ожидание команды (основной режим, происходит при отсутствии подключения)
  • Соединение с сервером (открытие порта, набор номера, установка модемной связи, установка TCP-связи)
  • Авторизация (проверка пользователя и пароля, установка соединения)
  • Он-Лайн (при соединении с сервером и получения доступа в сеть)

Почти каждое состояние отображается в анимации данного окна.
Состояний соединения гораздо больше, и их количество увеличивается с новой версией Windows. Также существует огромное количество ошибок соединения, возможных при его установке. Сведения о кодах ошибок и кодах состояний вы можете найти в соответствующих приложениях.

Окно состояния имеет:

  • анимированную картинку, отображающую состояние программы
  • информационные поля:
    • кол-во попыток соединения (номер текущей попытки)
    • название соединения, по которому устанавливается связь

  • поле выбора телефона*
  • списки ошибок и состояний текущей сессии
  • кнопки расширения текста ошибки и состояний
  • ссылки на соответствующие команды:
    • свернуть окно**
    • перейти к следующему номеру
    • прервать операцию соединения и вернуться к стандартному режиму

* - поле выбора телефона содержит все телефоны доступных соединений. Если выбор телефона происходит по другому соединению, начинается дозвон по другому соединению. При дозвоне методом "Hot Dial", в этом списке будет отображен только один телефонный номер (первый).

** - восстановить окно состояние можно выбрав пункт Состояние в контекстном меню программы.

см. также:

  • Приложение А (коды ошибок программы)
  • Приложение Б (коды состояний)


Лицензионное соглашение

1. Общее

Настоящее лицензионное соглашение (далее, соглашение) заключается между вами, конечным пользователем (далее, пользователь) и разработчиком, командой MuxaSoft Team (далее команда, разработчик).

2. Распространение

Программа распространяется бесплатно и без каких-либо ограничений, в том числе и без ограничений на извлекаемую от этого прибыль. Единственное требование - распространять программу только в оригинальном архиве. Оригинальный архив может распространяться через компьютерные сети, может быть включен в другие архивы, дистрибутивы программ, сборники программ на CD-ROM и прочее. Никаких специальных разрешений на это не требуется.

Вы можете распространять программу только в оригинальном ее виде. Также запрещается переводить программу на любые другие языки.

3. Ответственность

Вы не можете изменять, декомпилировать, дизассемблировать и изучать код программы другими способами. Любое подобное неавторизованное использование приводит к немедленному и автоматическому прекращению действия данной лицензии. Также такие действия влекут за собой уголовную и административную ответственность, согласно местному законодательству.

4. Гарантии

Программа распространяется по принципу "как есть". При этом не предусматривается никаких гарантий, явных или подразумеваемых. Команда не несет никакой ответственности за моральный и материальный ущерб, связанный с использованием или невозможностью использования данной программы. ВЫ ИСПОЛЬЗУЕТЕ ЭТУ ПРОГРАММУ НА СВОЙ СОБСТВЕННЫЙ РИСК.

Команда оставляет за собой право отменить действие данной лицензии для любой из следующих версий программы. Установка и использование программы означает, что Вы принимаете все положения настоящего лицензионного соглашения.

Если Вы не согласны с условиями данной лицензии, то должны удалить файлы программы со своих устройств хранения информации и отказаться от ее использования. По всем вопросам, связанным с распространением, установкой и использованием программы, если таковые у Вас возникнут, Вы можете обратиться к лидеру команды разработчиков .

Все права принадлежат команде разработчиков MuxaSoft и охраняются авторскими правами и лицензией на свободно-распространяемое ПО.

По всем правовым вопросам вы можете обращаться к лидеру команды MuxaSoft по e-mail: info@muxasoft.com

© 2003, MuxaSoft Team. Все права защищены. Все торговые марки принадлежат их владельцам.


Содержание

Добро пожаловать в справочную систему MuxaSoft Dialer версии 4.1!

Здесь вы сможете найти ответы на все ваши вопросы, а также рекомендации по настройке и использованию программы. Слева представлено полное содержание справочной системы. Внизу представлены основные пункты справочной системы.

Перед тем как писать в службу технической поддержки, обязательно ознакомьтесь с материалами справочной системы.

Лицензионное соглашение
Лицензионное соглашение между вами и разработчиками. Здесь указаны
ограничения на распространение программы, гарантии и т.д.
Официальный сайт разработчиков

На этом узле вы всегда можете загрузить самые свежие версии программы,
получить ответы на дополнительные вопросы на форуме и т.д.
Служба технической поддержки

Если у вас возникнут вопросы при работе с программой, вы можете задать их нам.
Служба технической поддержки ответит на все ваши вопросы
Часто задаваемые вопросы
В этом разделе вы можете найти ответы на часто задаваемые вопросы.
Возможно, ваш вопрос уже задавался.

© 1998-2003, MuxaSoft Team. Все права защищены.
Все торговые марки принадлежат их владельцам.


Установка и удаление программы

Оригинальная версия программы имеет классическую программу-инсталлятор с русским интерфейсом. Только загрузив программу с наших оригинальных узлов мы гарантируем полную работоспособность и отсутствие вирусов.

Оригинальная версия программы поставляется только в виде EXE-файла с полным набором системных файлов и файлов программы. Обычно файл имеет название mdialer4.exe. Однако существует и NRL-версия дистрибутива, которая поставляется в виде самораспаковывающегося RAR SFX-архива. Такая версия дистрибутива поставляется только с базовыми библиотеками. NRL-версия устанавливается на ОС Windows XP.

Для начала установки программы дважды щелкните на имеющийся файл программы (обычно mdialer4.exe). Программа имеет классический РУССКИЙ дружественный интерфейс. Нажмите на кнопку Далее, затем откорректируйте по необходимости путь (стандартный путь для установки – папка MuxaSoft Dialer 4 в стандартной директории программ “Program Files”). После несколько шагов начнется копирование файлов и установка всех компонентов программы. После установки программы вы получите уведомление об этом. На возможное предложение о перезагрузке компьютера (особенно Windows 98) желательно ответить положительно!

Все! Программа готова к запуску и настройке! Для запуска программы нажмите на кнопку Пуск (Start), затем перейдите во вкладку Программы \ MuxaSoft Dialer 4.0 (Programs \ MuxaSoft Dialer 4.0) .

Полностью 100%-совместимая с Windows программа-инсталлятор дает возможность удалить программу стандартными средствами Windows через Панель управления / Установка и удаление программ. Откройте пункт MuxaSoft Dialer 4.0, нажмите Удалить и подтвердите удаление

см. также:

  • возможности программы
  • системные требования


Официальные узлы

Самую свежую версию программы вы всегда можете загрузить на нашем официальном сайте (http://www.muxasoft.com/). Промежуточные бета-версии для тестирования новых возможностей получают только члены нашей команды и группа ограниченного бетатестирования. если вы хотите получать все версии программы, иметь возможность ознакомления с новыми возможностями программы, а также если вы хотите оказать нам услугу, вы должны стать членом команды ограниченного тестирования.

Награды ведущих софт-каталогов:

Как стать членом команды ограниченного тестирования?

Очень просто. Вам нужно всего лишь подписаться на почтовую рассылку Новости MuxaSoft на нашем сайте. В этом случае на ваш адрес электронной почты будут приходить описания и ссылки на новые бета-версии наших программ. Ваши адреса электронной почты, а также анкета, заполненная при подписке, является конфиденциальной информацией, принадлежащей нам и сервису subscribe.ru. Со своей стороны мы гарантируем неразглашение и конфиденциальность этой информации.

Где еще можно скачать программу?

На следующих софт-каталогах мы размещаем новые версии программ:

  • freeware.ru
  • download.ru
  • listsoft.ru
  • panvasoft.com
  • softvariant.ru
  • freesoft.ru
  • softodrom.ru
  • vingrad.ru

И это далеко не полный список ресурсов. В первые дни после выхода новой версии программы мы размещаем новость на некоторых новостных сайтах:

  • nnm.ru
  • units.ru
  • xdd.ru

Сколько зеркал программ существует на данный момент и где они находятся?

На данный момент существует 3 зеркала, с которых вы можете без проблем скачать программу:

  • хост-сервер TUTBY.COM (Россия, Москва ("Ростелеком"))
  • хост-сервер BY.RU (Россия, Санкт-Петербург)
  • анонимный FTP-сервер MYSIB.COM (Россия, Иркутск)

Список наших дистрибутив-серверов постоянно расширяется.

см. также:

  • установка и удаление программы


Интерфейс COM API для построения программ удаленного управления

Общие настройки программы

Настройка программы происходит в соответствующем окне программы, которое вызывается через контекстное меню. В самой первой вкладке сосредоточено большинство настроек программы.

Все опции в первой вкладке ("Общие параметры") разделяются на 2 группы:
- общие параметры программы
- общие параметры набора номера

1. Общие параметры программы

1.1. Загружать программу вместе с Windows.
 Эта опция позволяет установить загрузку программы MDialer вместе с операционной системой Windows. Программа прописывается в системном реестре Windows только для текущего пользователя.

1.2. Начинать дозвон при старте программы.
Опция позволяет начинать дозваниваться до провайдера сразу после загрузки программы. Полезна если у вас безлимитный выход в Интернет по отдельной телефонной линии или вам нужен Интернет сразу после загрузки компьютера.

1.3. Показывать монитор при установке соединения.
 Позволяет показывать монитор (окно оперативной информации о соединении) сразу после установки соединения с сетью. См. Монитор.

1.4. Показывать окно состояния при наборе номера.
Если эта опция установлена, то окно состояния соединения будет показываться автоматически при начале дозвона и скрываться при успешном подключении к сети. См. Окно состояния.

1.5. Прятать монитор при разрыве соединения.
Эта опция позволяет настроить окно монитора так, чтобы он автоматически скрывался после разрыва соединения.

2. Общие параметры набора номера.

2.1. Префикс.
В это поле записывается префикс телефонного номера (цифры и знаки, которые будут следовать перед телефонным номером). Опция полезна, если для выхода на городскую линию используется дополнительные цифры (напр. "9"). Например, если телефон "222322" а префикс "9W" то номер будет выглядеть так: "9W222322".

2.2. Постфикс.
Тоже самое, что и префикс, только наоборот: цифры и знаки, которые будут следовать после телефонного номера. Например, если телефон "222322" а постфикс "000" то номер будет выглядеть так: "222322000".

2.3. Пауза.
Данное поле устанавливает в секундах паузу перед набором номера в случае их перебора (ожидание перед набора номера после разъединения с ошибкой). Данная опция полезна при частой занятости телефонного пула провайдера.

2.4. Попыток.
Максимальное количество попыток соединения. Если значение равно нулю, то программа будет дозваниваться бесконечно.

2.5. Автодозвон.
Данная опция позволяет установить реагирование программы на ошибки соединения. Если опция установлена, то программа будет автоматически перезванивать при разрывах связи и при ошибках набора (линия занята и т.п.).

см. также:

  • Приложение В (символы в телефонном номере)


Команды удаленного управления программой

Вводимый формат команды: “Команда Аргумент_1 Аргумент_N”.

Команда | Аргументы | Описание
JOIN | Логин, Пароль. | Самая первая команда – команда входа в систему. Нужно ввести в качестве первого аргумента – Логин, в качестве 2-го – пароль. Эти данные можно уточнить у администратора. Пример: JOIN Dima QWERTY
DIAL |  | Команда на начало дозвона. Пример: DIAL
HANGUP |  | Команда разъединения Пример: HANGUP
STATE |  | Получение информации о текущем состоянии программы и соединения. Отображает ту же информацию, что и подсказка при наведении мыши на значок программы в системном лотке. Пример: STATE
CHECK | Имя соединения | Помечает соединение как Доступное для дозвона. Альтернативно нажатию на соединение в меню программы. Пример: CHECK My-Internet
UNCHECK | Имя соединения | Помечает соединение как НЕ доступное для дозвона. Альтернативно нажатию на соединение в меню программы. Пример: UNCHECK My-Internet
SESSIONS |  | Отображает информацию о подключенных пользователях в систему удаленного управления. Пример: SESSIONS
RESET |  | Сброс сессии Пример: RESET
DISCONNECT |  | Отключение пользователя от системы управления и завершение сеанса. Пример: DISCONNECT
ECHO | ON/OFF | Включение/выключения локального эха (для терминалов, не отображающих собственный ввод данных) Пример: ECHO ON
ASCII | ON/OFF | Включение DOS-кодировки вводимых/выводимых данных Пример: ASCII ON

см. также:

  • Возможности программы
  • Удаленное управление


Зачем удаленное управление?

Зачем использовать удаленное управление?

В 4-й версии MDialer-а появилась уникальная возможность - удаленное управление. Для управления программой с другого компьютера необходима только программа-терминал и выход в Интернет или в локальную сеть, куда подключен компьютер с MDialer-ом.

Эта возможность реализована для управления диалером по локальной сети, где модем установлен на другом компьютере и доступа к этому ПК нет или затруднен.

Все, что необходимо знать при удаленном администрировании - IP или имя компьютера в сети и порт, на который происходит соединение! Также нужно иметь привилегии на соединение с указанным портом.

Управление диалером можно осуществить стандартными средствами любого компьютера на базе операционных систем Windows, Linux, Unix, MacOS, OS/2 и т.д. Для этого нужна обычная терминальная программа, умеющая работать по сети (Socket-ы) по TCP/IP или IPX/SPX-протоколам. Желательно, чтобы терминал понимал кодировку Windows-1251.

Рассмотрим пример управления на базе Windows 98. Откройте стандартное средство TelNet (Пуск/Выполнить, введите TelNet). Перед вами появится консоль. В меню Соединение выберите пункт Подключение и введите в поле “Имя компьютера” IP-адрес или имя компьютера, к которому производиться подключение, в поле “Порт” введите номер порта, указанного в Параметрах программы MDialer, к которому будет производиться подключение. Далее нажмите Соединение.

Если вы все сделали правильно, через несколько секунд на экране появится пригласительный текст с просьбой войти в систему.

Управление осуществляется через вводимые вами команды. После каждой команды необходимо нажать клавишу Ввод.

Для того, чтобы назначить учетную запись для авторизации по удаленному управлению, необходимо ее создать. Учетные записи хранятся в папке Administrators в директории программы. Откройте любой текстовый редактор и отредактируйте запись. Логин – имя файла. Расширение файла – CFG.

Содержание учетной записи:

[AccessRules]

Password -- пароль на вход пользователя. Пример – Password=QWERTY
DisableCommands – запрещенные команды пользователя. Пример – DisableCommands=SESSIONS;DIAL;HANGUP
TraceCommands – вести ли отчет о действиях пользователя. 1 – вести, 0 – не вести.

см. также:

  • Возможности программы
  • Команды управления


Поиск

Идет поиск...
Идет поиск по справочной системе... Подождите, пожалуйста...
В процессе поиска строка загрузки страниц браузера может моргать.


Запуск приложений и проигрывание звуков

На любое событие программы вы можете назначить определенные действия, например, на событие Подключение к сети вы можете назначить запуск вашей любимой почтовой программы, а на событие Отключение от сети - ее закрытие. Для этого зайдите во вкладку Приложения и звуки. Перед вами появиться список действий, который разделен на следующие колонки:

  • Команда (действие в ответ на событие)
  • Выполнение (событие)
  • Путь к файлу (кроме системных действий)

Нажмите Добавить для добавления нового действия. Перед вами появиться окно. Сначала нужно выбрать действие - операцию, которая будет выполняться при наступления события. Возможные команды:

  • Запустить программу
  • Закрыть программу
  • Воспроизвести звук
  • Выключить компьютер
  • Перезагрузить компьютер
  • Войти в ждущий режим (Suspend)

Далее вам необходимо назначить событие для выполнение выбранного действия:

  • Подключение к сети (установка соединения с сетью и переход в режим Он-Лайн)
  • Отключение от сети (разрыв соединения, переход из состояния Он-Лайн в Офф-Лайн)
  • Запись статистики (выполняется каждые 20 секунд, 30 либо 1 минуту в зависимости от типа тарификации и только в режиме Он-Лайн)
  • Возникновение ошибки (появление ошибки соединения, которая приведет к разрыву связи)
  • Закрытие программы (выход их программы MDialer)
  • Подключение через удаленный интерфейс (при подключении пользователя с удаленного компьютера к диалеру)
  • Запуск программы MDialer
  • Начало дозвона

Далее следует ввести параметры действия. Только действия Запустить программу, закрыть программу и воспроизвести звук имеют параметры выполнения).

1) Запустить программу.
Вам нужно выбрать или ввести имя файла, который будет открываться (если выбрана самостоятельная программа, то она будет запущена, иначе файл откроется ассоциированной с ним программой). Далее введите командную строку, если она необходима. Также вы можете настроить параметры запуска программы:

  • Не выполнять если загружена (сначала диалер сканирует память на присутствие программы, и если уже программа запущена действие игнорируется)
  • Дождаться закрытия программы (диалер будет ждать и не выполнит другие действия, пока запущенная программа не будет закрыта)
  • Пауза после загрузки программы (диалер подождет указанное время после загрузки программы перед запуском других действий)
  • Настройка состояния главного окна программы (свернутая, развернутая и т.д.).

2) Закрыть программу.
Вам нужно лишь выбрать программу для закрытия. Программа закрывается "мягко" - сначала все окна программы, что должно привести к ее корректной выгрузке, а затем, если программа все еще находится в памяти, жесткое завершение процесса.

3) Воспроизвести звук.
Программа воспроизведет указанный звуковой файл. Вы можете его предварительно прослушать. Поддерживаются все форматы файлов, которые поддерживаются программой Windows Media Player (в том числе и MP3).

Также вы можете редактировать добавленные пункты, удалять их и временно останавливать.

см. также:

  • Возможности программы


Установка условий соединения

Отдельной возможностью программы является контроль качества установленного соединения и его последующий контроль. Вы можете контролировать:

  • физическую скорость соединения с сетью (Connection Speed Control)
  • реальную скорость потока (Traffic Control)
  • ограничивать время, проведенное в сети
  • ответ от сервера (Ping Control)
  • время установки соединения (Carrier Control)

Эти функции устанавливаются в двух вкладках: Контроль и Пинг и лимиты. В первой вкладке вы можете установить первые 3 возможности программы. Для этого перейдите во вкладку Контроль и выберите необходимые опции.

Контроль физической скорости соединения
Позволяет контролировать физическую скорость подключения модема. Проверяется сразу после установки физического соединения. Вы можете назначить максимальный порог и минимальный. Если скорость не будет совпадать с допустимым диапазоном, произойдет пересоединение с сетью по ошибке Скорость больше или меньше допустимой.

Контроль потока данных
Позволяет контролировать реальную скорость канала. Например, если за 1 минуту было принято менее 500 килобайт данных, то связь будет переустановлена. Опция полезна в случае плохих линий и частых пересогласованиях скорости. Установите соответствующие опции в разделе Контроль потока данных.

Ограничение времени OnLine
Полезна в случаях предоставления "бесплатных" первых минут. Позволяет переустановить связь в случае превышения временного порога времени on-line. Можно вводить дробные значения, напр. 0.5 минут.

Контроль ответа от сервера
Позволяет ping-овать сервер (посылать ему запрос на который он должен дать ответ). Если по истечение 15-ти секунд ответа не будет получено (5 попыток) то связь переустанавливается. Для настройки необходимо указать адрес сервера (напр. belpak.minsk.by) и интервал опроса. Настраивается во вкладке Пинг и лимиты.

Время ожидания соединения
Полезна в случаях не распознавания сигнала "занято" некоторыми модемами. Через определенное время позволяет разорвать связь (от начала набора номера). Установите, напр. 30 секунд и если в течение этого времени связь не будет установлена, программа начнет звонить заново.

см. также:

  • Возможности программы


Настройка соединений

Настройка соединений - самая важная часть настроек программы. От того, как правильно они будут сконфигурированы зависит корректная работа программы. Настройка соединений подразделяется на:

  • настройку данных авторизации
  • ввод альтернативных телефонов
  • ввод интервалов запрета набора номера
  • настройка расширенных параметров соединения

Зайдите во вкладку Параметры группы Соединения. Вы увидите древовидный иерархический список. При первом запуске программы диалер импортирует настройки соединений Windows, а именно телефоны и, в некоторых случаях, логины. Нажмите на имя нужного соединения и нажмите на кнопку Добавить. Под списком вы увидите форму для ввода нового телефонного номера. В поле Номер телефона введите один из альтернативных телефонных номеров для дозвона к провайдеру, а в поле Комментарий введите комментарий к введенному телефонному номеру. Затем нажмите Принять. Созданный телефонный номер отобразиться на уровне ниже соединения (под ним). Повторите операцию для ввода всех альтернативных телефонов.

Внимание! Старайтесь не вводить в номерах телефонов дефисы и пробелы. Многие модемы эти символы игнорируют, однако они могут являться модификаторами телефонного номера (см. Приложение В).

Также вы можете установить запрет на набор телефонного номера в определенное время суток. Эта опция полезна для провайдеров с ограниченным по времени тарифом, напр. ночным или вечерним. Для установки интервала запрета на звонок по данному телефонному номеру выделите нужный телефонный номер и нажмите Добавить. Вы увидите форму для ввода интервала запрета звонка. Введите в 24-х часовом формате типа часы:минуты необходимый запрет и нажмите на кнопку Принять. Данную операцию вы можете повторить несколько раз для одного телефона для введения нескольких интервалов. Установите ограничения на необходимые телефоны дозвона.

Для успешного соединения с сетью программе важно знать данные для авторизации и некоторые другие параметры. Выберите необходимое соединение. Внизу будут представлены некоторые данные, которые нужно ввести:

  • логин (имя пользователя для авторизации)
  • пароль
  • домен (зачастую оставляется пустым, если не указано обратное, вводится в основном для GPRS-соединений и подключений в интрасеть)
  • callback (ваш телефонный номер, если вы хотите использовать возможность обратного звонка)

Эти данные запоминаются при изменении автоматически. Они надежно шифруются в соответствие с настройками безопасности. Далее следует выбрать метод набора номера. Если ваша телефонная линия подключена к цифровой АТС (телефонной станции), предпочтительнее выбрать тональный набор номера. Преимущество такого типа набора номера заключается в скорости набора и безошибочности. Выберите Импульсный набор номера, если ваша АТС не поддерживает тональный набор номера. Вы можете обратиться в сервисную службу АТС для выяснения этого вопроса.

Если вы считаете себя продвинутым пользователем, вы можете установить расширенные параметры соединения. Для этого нажмите на кнопку Параметры в группе Экспертные настройки соединения.

В появившемся окне доступны четыре опции для настройки:

  • Включить динамик модема (включает динамик модема)
  • Включить программное сжатие (включает дополнительную компрессию данных, что способствует увеличению скорости передачи веб-страниц)
  • Выполнять скрипты соединения (в некоторых случаях способствует выполнению скриптов соединения, подробнее в разделе Часто задаваемые вопросы)
  • Строка инициализации модема (задается строка инициализации модема, состоящая из AT-команд модема и служащая для настройки параметров модема перед установкой соединения).

Все дополнительные параметры сохраняются только для выбранного соединения и не используются другими соединениями.

см. также:

  • Приложение В (символы в телефонном номере)
  • Обратный звонок
  • Приложение Д (строка инициализации)


Интеллектуальная обработка ошибок соединения

В программе реализован механизм, который позволяет задать необходимую реакцию на определенные ошибки соединения. Это полезно в случаях, если вы не хотите, чтобы модем перезванивал при ошибке "Неверный пароль" или выдавал предупреждение при ошибке "Нет гудка".

Для настройки этого механизма откройте окно Параметры программы и выберите вкладку Обработка ошибок. Нажмите Добавить. В появившемся окне выберите нужную ошибку (ориентируйтесь по ее номеру) и выберите необходимое действие:

  • Перезванивать (стандартная реакция на ошибку, позволяет переустановить связь в случае возникновения ошибки)
  • Считать за успешное завершение (диалер благополучно разорвет соединение и перейдет в режим ожидания)
  • Показывать сообщение (позволяет показывать сообщение при возникновении ошибки)
  • Игнорировать (диалер пропустит сообщение об ошибке)*

* - если ошибка влечет за собой разрыв связи, то 2-й уровень контроля соединения благополучно отследит разорвавшиеся соединение и инициирует ошибку соединения.

см. также:

  • Возможности программы


Журнал работы программы

Данная функция программы позволяет просматривать журнал событий и ошибок программы за определенный день. Все записи журнала делятся на события и ошибки. Вы можете управлять журналом через вкладку Журнал работы в окне Параметры. Установите опцию Вести журнал работы программы для начала ведения журнала. Вы можете просматривать журнал за определенный день.

Журналы хранятся в подпапке Logs папки программы. Вы можете их читать в любом текстовом редакторе. Если вы хотите удалить журнал, вы можете выбрать его во вкладке Журнал работы и нажать Удалить журнал или через окно проводника Windows, удалив соответствующий файл.

Журнал работы программы является очень удобным средством для просмотра событий и ошибок программы, когда вас не было рядом (например, вы ставите закачку файла на ночь, а утром хотите посмотреть журнал).

см. также:

  • Возможности программы


Настройка суточных лимитов соединения

Данная возможность является очень полезной, если ваш провайдер ограничивает трафик или стоимость соединения, или вы сами не хотите превышать определенные расходы на Интернет за сутки.

Вы можете установить лимиты для:

  • суммарного трафика
  • расходов

Для установки суточных лимитов откройте окно Параметры программы, войдите во вкладку Пинг и лимиты, установите опцию Суточный лимит времени/затрат, установите необходимые лимиты и их условия. Вы можете вводить дробные значения, напр. 2.75. Если вы превысите суточный лимит, будет показано оповещающее диалоговое окно, в котором вам будет доступна информация о лимите, текущему значению. Вам также представиться выбрать действия:

  • не напоминать в дальнейшем (в текущем сеансе соединения)
  • разъединить соединение
  • звонить по другому номеру

Лимит действует только для одних суток.

см. также:

  • Возможности программы


Общие настройки программы

Настройка программы происходит в соответствующем окне программы, которое вызывается через контекстное меню. В самой первой вкладке сосредоточено большинство настроек программы.

Все опции в первой вкладке ("Общие параметры") разделяются на 2 группы:
- общие параметры программы
- общие параметры набора номера

1. Общие параметры программы

1.1. Загружать программу вместе с Windows.
 Эта опция позволяет установить загрузку программы MDialer вместе с операционной системой Windows. Программа прописывается в системном реестре Windows только для текущего пользователя.

1.2. Начинать дозвон при старте программы.
Опция позволяет начинать дозваниваться до провайдера сразу после загрузки программы. Полезна если у вас безлимитный выход в Интернет по отдельной телефонной линии или вам нужен Интернет сразу после загрузки компьютера.

1.3. Показывать монитор при установке соединения.
 Позволяет показывать монитор (окно оперативной информации о соединении) сразу после установки соединения с сетью. См. Монитор.

1.4. Показывать окно состояния при наборе номера.
Если эта опция установлена, то окно состояния соединения будет показываться автоматически при начале дозвона и скрываться при успешном подключении к сети. См. Окно состояния.

1.5. Прятать монитор при разрыве соединения.
Эта опция позволяет настроить окно монитора так, чтобы он автоматически скрывался после разрыва соединения.

2. Общие параметры набора номера.

2.1. Префикс.
В это поле записывается префикс телефонного номера (цифры и знаки, которые будут следовать перед телефонным номером). Опция полезна, если для выхода на городскую линию используется дополнительные цифры (напр. "9"). Например, если телефон "222322" а префикс "9W" то номер будет выглядеть так: "9W222322".

2.2. Постфикс.
Тоже самое, что и префикс, только наоборот: цифры и знаки, которые будут следовать после телефонного номера. Например, если телефон "222322" а постфикс "000" то номер будет выглядеть так: "222322000".

2.3. Пауза.
Данное поле устанавливает в секундах паузу перед набором номера в случае их перебора (ожидание перед набора номера после разъединения с ошибкой). Данная опция полезна при частой занятости телефонного пула провайдера.

2.4. Попыток.
Максимальное количество попыток соединения. Если значение равно нулю, то программа будет дозваниваться бесконечно.

2.5. Автодозвон.
Данная опция позволяет установить реагирование программы на ошибки соединения. Если опция установлена, то программа будет автоматически перезванивать при разрывах связи и при ошибках набора (линия занята и т.п.).

см. также:

  • Приложение В (символы в телефонном номере)


Настройка монитора

Вторая вкладка параметров позволяет установить параметры монитора соединения (окна оперативной статистики соединения, см. Монитор). Все параметры монитора делятся на две группы:
- установка параметров отображения статистики
- установка пунктов в мониторе

1. Установка параметров отображения статистики.

В этой группе вы можете настроить вид монитора (цвета, шрифт, прозрачность) и опцию отображения статистики за весь период (счетчики). Следует отметить, что настройка прозрачности окна доступна только для пользователей операционных систем Windows 2000, XP, 2003 и более поздних. Опция Показывать статистику за сеанс/за период позволяет отображать данные в мониторе (трафик, время, затраты) за весь период, начиная с момента установки этой опции и заканчивая обнулением счетчиков.

Счетчики - отдельная область хранения данных в файле статистики для отображения данных за весь период времени. Пересчитывать каждый раз статистику нецелесообразно, т.к. на это тратятся много системных ресурсов ЦП и памяти. Для этого созданы счетчики. Счетчиков всего четыре:

- счетчик времени
- счетчик входящего трафика
- счетчик исходящего трафика
- счетчик расходов

Вы можете обнулить счетчики в соответствующем пункте программы LogManager или через меню Горячих настроек в режиме он-лайн.

2. Настройка пунктов монитора.

При помощи несложного интерфейса настройки пунктов монитора вы можете добавлять, удалять и двигать пункты статистики в мониторе. Всего доступно 11 пунктов данных:

входящий трафик (принятая информация за сессию или счетчик трафика за период)

исходящий трафик (переданная информация за сессию или счетчик трафика за период)

затраты за сеанс (расходы за сеанс, составленные из стоимости вх. трафика + исх. трафика + повременной оплаты)

затраты за период (счетчик затрат за период)

входящий поток (скорость потока принимаемой информации, измеряется в килобайтах за секунду)

исходящий поток (скорость потока передаваемой информации, измеряется в килобайтах за секунду)

IP-адрес клиента (IP-адрес вашего компьютера в сети Интернет)

IP-адрес сервера (IP-адрес центрального сервера провайдера, откуда поступают данные)

скорость (показывает скорость подключения к Интернету в килобитах за секунду (бодах))

имя соединения (имя учетной записи соединения)

телефон (телефон, по которому вы звонили для соединения с провайдером).

см. также:

  • Монитор


Настройка и использование планировщика

Планировщик используется для выполнения запланированных операций с соединениями в определенное время. Эта функция весьма полезна, если вы ставите закачку, например, на ночь.

Основной интерфейс планировщика находится во вкладке Планировщик окна Параметры. Вы увидите список задач планировщика, в котором будут отображены следующие сведения:

  • название задачи
  • тип задачи
  • время и дата последнего запуска
  • состояние задачи

Вы можете добавлять, удалять, изменять статус и параметры задачи. Для добавления задачи нажмите на кнопку Добавить. Перед вами появиться окно, в котором необходимо ввести параметры задачи, такие как:

  • имя задачи (напр. "Дозвон в 5:00")
  • опция Активировать задачу позволяет поставить задачу на выполнение сразу же после добавления.Если вы хотите задействовать задачу позже, выключите эту возможность.
  • опция Выполнить задачу после добавления позволяет запустить задачу сразу же для проверки ее выполнения.
  • расписание выполнения (вы должны выбрать периодичность выполнения задачи, а также ввести дату, время, отметить месяцы и дни выполнения (если необходимо)
  • далее вы должны настроить действие:
    • Проигрывать звук - позволяет проигрывать звук при выполнении действия.
    • Запуск приложения - позволяет запустить необходимое приложение.
    • Выполнить команду - позволяет выполнить системную команду программы, напр. Разъединить или Соединить*.
    • Показать сообщение - позволяет показывать ваше сообщение.

    * - для операций над соединениями, такие как Начать дозвон, необходимо предварительно выбрать соединения для набора номера!

см. также:

  • Возможности программы


Настройка параметров безопасности

Выберите пункт Безопасность в окне параметров программы. Здесь вы можете установить пароль на запуск программы и выбрать параметры шифрования пароля.

Возможность задания пароля на запуск программы является очень полезной, если вы хотите ограничить доступ к программе. При установке пароля файл профиля надежно шифруется с учетом введенного вами пароля, а также специального случайного сгенерированного ключа, хранящегося в Хранилище паролей Windows. Это позволяет исключить доступ к программе простым копированием зарезервированного файла профиля. Если вы забудете пароль к программе, вам придется удалить файл профиля и все данные ввести заново, в том числе все пароли и телефоны.

В области настройки параметров шифрования вы можете установить степень надежность ваших паролей. Опция "Шифровать логин, пароль и домен" позволяет зашифровать ваши конфиденциальные данные соединения надежными алгоритмами шифрования данных, а опция "Защищать от использования на других компьютерах" позволит зашифровать данные с учетом особенностей аппаратной конфигурации вашего компьютера, исключив использование вашего профиля на других компьютерах.

см. также:

  • Возможности программы


Графики

Диаграммы в статистике

В версии 4.0 появилась возможность выведения различных диаграмм статистики, на основе основных атрибутов статистики. Выможете просмотреть диаграммы по следующим параметрам:

  • расходы за соединение и время соединения
  • по входящему и исходящему трафику
  • физическим ошибкам соединения и скорости соединения
  • логическим ошибкам соединения.

Диаграммы строятся на базе выведенных сведений за указанный период времени. Каждая диаграмма имеет легенду цвета.

Внимание! В диаграммах Качество линии и Качество провайдера может не быть графика вообще. Это означает, что ошибок соединения не было вообще, либо модем их исправил. Обычно, качество линии и провайдера вы можете контролировать только с выключенной опцией Коррекция ошибок в свойствах модема (через свойства соединения).

см. также:

  • Возможности программы
  • Просмотр статистики


Счетчики статистики

Счетчики статистики созданы для подсчета промежуточных итогов по основным параметрам статистики и выведения их на Монитор, Всплывающее меню и т.д.

Счетчики - специальные ячейки в файле статистики, в которые записывается суммарная информация соединения (затраты, трафик, время). Счетчики можно обнулить и тогда они будут отображать суммарную статистику за период, начиная с их обнуления.

Для того чтобы изменить значения счетчиков статистики или их обнулить, откройте файл статики, выберите в меню Файл пункт Свойства и выберите вкладку Счетчики. Вы можете изменить значение каждого счетчика или обнулить их.

см. также:

  • Приложение В (символы в телефонном номере)


Безопасность статистики

Вся статистика храниться в файлах с расширением MDS в папке "Data" папки программы. Все данные статистики шифруются надежным алгоритмом шифрования, что позволяет исключить изменение данных статистики при помощи любого шестнадцатеричного редактора, листика и ручки, как это было возможно в версии 2.0 и 3.0.

Каждая запись статистики хранит в себе контрольну сумму данных этой записи. Если при чтении контрольной суммы записи статистики не совпадает с вычисленной программой, запись помечается как "Поврежденная" и не выводиться пользователю. Данная возможность позволяет не считать ошибочные и поврежденные данные, которые были либо не правильно записаны в файл статистики, либо изменены.

В версии 4.1 программы MuxaSoft Dialer появилась возможность защитить паролем файл статистики от записи сторонними пользователями. Если файл статистики защищен таким образом, в нижнем правом углу программы появиться значок "Замок". Для установки пароля на запись необходимо открыть защищаемый файл статистики и выбрать в меню Файл пункт Свойства. Далее, в появившемся диалоговом окне необходимо выбрать вкладку Безопасность и установить пароль стандартным способом.

Если вы забудете пароль на изменение данных, вы никогда более не сможете изменить данные. В таком случае необходимо удалить файл статистики. Он будет создан автоматически при следующем подключении, а все данные предыдущей статистики будут потеряны.

см. также:

  • Возможности программы


Просмотр статистики

Статистика по соединениям - одна из важнейших возможностей программы, ради которой она создавалась. Как только MDialer устанавливает соединение с сетью, включается механизм подсчета статистики, которая записывается каждые 30 секунд в файл статистики в зашифрованном виде.

Файл статистики состоит из заголовка и записей статистики. В каждую запись записываются следующие данные о соединении:

  • время начала соединения (время установки связи) и время разрыва соединения;
  • расходы за соединение (расходы по входящему и исходящему трафику (отдельно), и по времени);
  • входящий и исходящий трафик;
  • имя пользователя, начавшего дозвон;
  • номер телефона, по которому производился дозвон;
  • количество ошибок (физически неправильно принятых пакетов или пакетов с неправильной компоновкой, повтор передачи которых был затребован операционной системой);
  • скорость соединения, на которой была установлена связь.

Эти и другие сведения вы можете посмотреть в статистике. Статистику конкретного соединения можно вызвать двумя способами:

  1. при установленном соединении вызвать меню горячих настроек и выбрать пункт Показать статистику.
  2. в любом состоянии программы вызвать контекстное меню и выбрать пункт статистика. В появившемся окне выбрать в меню Файл пункт Открыть, далее необходимо выбрать соединение и нажать ОК.

Просмотр статистики осуществляется отдельной программой MuxaSoft Log Manager, которая входит в комплект поставки программы MuxaSoft Dialer. В главном окне программы (при открытом файле статистики) расположены четыре вкладки статистики:

  • Статистика (список установленных соединений за выбранный период статистики). Внизу списка указаны итоговые значения аргументов статистики за указанный период.
  • Диаграммы
  • Качество линии
  • Качество провайдера

см. также:

  • Возможности программы


Разработчики программы

Официальный сайт: http://muxasoft.com/
Служба технической поддержки: support@muxasoft.com
ICQ службы технической поддержки: 9400928

Администратор: info@muxasoft.com
Телефон для контактов: +375 (29) 758-77-32

Основная команда разработчиков программы
Программист | Личко Игорь
Идея, разработка первых версий | Свинарев Михаил
Основной бета-тестер | Кондратьев Иннокентий
EX-разработчик | Мингалев Виталий
Служба технической поддержки | Никитин Роман
Разработка веб-сайта команды
Программирование | Личко Игорь
Дизайн | Соколов Кирилл
Команда закрытого бетатестирования
Alex Cooper
Andrex
Kesh
Coach
May aka MX
XXtreme
Gleb Farat
Stas Grishin
Alx©
Выражаем благодарность
Новостному сайту NoName Archive (nnm.ru) и в частности Doc()-у за регулярную публикацию программы на первой полосе
Андрею aka Bios Killer за написание отдельных компонент программы на языке C++, в частности механизма интеграции программы в операционную систему на низком уровне
Глебу Фарату за предоставленный анонимный FTP-сервер ftp.mysib.com
Порталу KIZ.BY ("Красота и Здоровье") за предоставленный HTTP-сервер и хостинг-компании TUTBY.COM, которым физически принадлежит сервер, за предоставление пол-теробайта исходящего трафика в месяц
Андрею Климову, автору программы DialUP Prof за предоставленные исходные коды своей программы
Корпорации Microsoft за предоставленные примеры использования технологии Microsoft CryptoAPI и Microsoft RAS API, а также ответов на некоторые технические вопросы по использованию основных интерфейсов Windows
Интернет-провайдеру " Магистраль" за предоставление выхода в сеть Интернет
Михаилу Свинареву за написание некоторых компонент программы, в частности тарифной сетки и древовидного списка соединений
Веб-сайту Visual Basic Streets за предоставление универсального аудио-кодека, способного проигрывать файлы в формате MP3
Сервису Subscribe.ru за предоставленную "серебренную" рассылку
Также выражаем благодарность более 1000 бета-тестерам ограниченного тестирования за тестирование программы

© 1998-2003, MuxaSoft Team


Часто задаваемые вопросы

Часто задаваемые вопросы (ревизия 3 от 1 октября 2003 г.)

Содержание:

  1. На каком языке написана программа?
  2. Программа работает с модемом напрямую?
  3. Что такое Callback?
  4. На какие ОС рассчитана программа?
  5. У меня выдает скорость 9600 кбит/сек и не считает трафик
  6. Почему не выводится окно терминала?
  7. Проблемы с выполнением скриптов
  8. Как импортировать статистику из версии 3 или 2?
  9. Как программа интегрируется в операционную систему?
  10. А нельзя ли при соединении с Интернетом синхронизировать системное время ?
  11. Можно ли проигрывать MP3-файлы?
  12. Что означает пустой график VLQ (его нет просто) в логменеджере?
  13. Куда мне слать багрепорты, предложения?
  14. Как мне связаться с администрацией?
  15. Где я могу обновить диалер?
  16. Что за Уровни Контроля Соединения (CCL)?
  17. Могу я "перехватить" уже существующее соединение?
  18. Я забыл свой пароль для доступа в Интернет.
  19. Как можно зашифровать свой файл настроек?
  20. Что такое Плагины?
  21. Могу я написать свой плагин?
  22. Могу я опубликовать свой плагин?
  23. Ошибка при прописывании логина - данные не совпадают после цикла шифрования и дешифрования
  24. Что за PLQ и VLQ?
  25. А куда в версии 4.1 делся запрет звонков по определенным номерам в определенное время?
  26. Можно ли её заставить округлять время соединения (минуты) до целой величины?
  27. Хочу приобрести Muxa Soft Dialer 4.1. Как осуществить? Помогите.
  28. Не удается зарегистрировать библиотеку: Функция DllRegisterServer вызвала ошибку 0x80029C4A.
  29. Если на стандартном windows-подключении соединение с Интернетом стабильно происходит на скорости подключения 46000 - 50300 то при использовании Вашего продукта для дозвона скорость подключения может колебаться от показателя 26600 до 45000...
  30. Он обнуляет инициализационную строку модема
  31. Количество отработанного времени округляется в обратную сторону при поминутной тарификации
  32. Как пользоваться Callback'ом.
  33. Как с помощью вашей программы после установки соединения запускать еще одно соединение (например VPN)?
  34. Почему монитор считает затраты раз в 20-30 секунд?
  35. Хотелось бы чтобы был бы пароль на изменение параметров и/или сделать так чтобы нельзя было никак добраться до пароля соединения с провайдером
  36. Как мне посмотреть контроль времени за какой-либо период, например за последние 10 дней?
  37. Не определяется сигнал "занято"...
  38. Как обнулить статистику
  39. Что такое RAS?
  40. Почему программа так много "жрет" памяти?
  41. Совместим ли MDialer с Windows XP?
  42. Совместим ли MDialer с Windows NT4?
  43. Совместим ли MDialer с Windows 95?
  44. Решена ли ошибка 2000-го года в программе?
  45. Ваша программа есть большой троян! Вы #@%&*#!!!
  46. Ваша программа удалила всё на моем винте и перепрошила БИОС! Вы ответите за это!
  47. Будет ли программа переведена на другие языки?
  48. Когда будет следующая версия программы?
  49. Что за MSVBVM60.DLL? Это виртуальная машина JAVA?
  50. Какие еще библиотеки использует программа ?
  51. Как защитить статистику от неавторизированной записи?
  52. Я удалила некоторые соединения из статистики, но они появились после очередного открытия файла.
  53. При запуске программы под Windows XP система выдает звук критической ошибки, но программа загружается и работает стабильно.

1. На каком языке написана программа
Программа написана на языке VisualBasic и откомпилирована при помощи компилятора Microsoft VisualBasic 6.0 Service Pack 3.

2. Программа работает с модемом напрямую?
Нет. Программа работает с модемом через стандартный интерфейс Microsoft RAS (Remote Access Service)

3. Что такое Callback?
Calback - одна из возможных услуг провайдера, которая позволяет в некоторых случаях произвести соединение с более высокой скоростью и избавиться от повременной оплаты за телефонные переговоры. Принцип этой услуги прост - после установки соединения провайдер разрывает связь и перезванивает уже вам, после чего идет проверка пользователя и окончательный вход в сеть. Эту услугу поддерживают очень не многие провайдеры, а в некоторых странах она вообще не поддерживается.

4. На какие ОС рассчитана программа?
Прежде всего программа оптимизирована под ОС Microsoft Windows 2000, XP и Server 2003. Они построены на базе нового, более стабильного ядра WinNT5x и являются более приоритетным решением, чем напр. Microsoft Windows 98. Однако программа работоспособна и под ОС семейства 9x (Windows 98 Second Edition, Windows Millenium).

5. У меня выдает скорость 9600 кбит/сек и не считает трафик
Такая ошибка очень распространена при работе программы под ОС Microsoft Windows 98 Second Edition и Microsoft Windows Millenium, когда в системе присутствует более чем один контроллер сетевых подключений. Это может быть как обычная сетевая карта, так и виртуальный контроллер, например, VPN-соединения. А решается все просто: в любом текстовом редакторе откройте файл <Папка программы>\Profiles\<Ваше имя>.mdp. Найдите группу "[Advanced Options]" и в ней найдите строчку "NetworkAdapter". Далее, параллельно откройте Панель управления, перейдите в пункт Сеть. В списке будут присутствовать сетевые адаптеры, службы, сервисы и протоколы. Сетевые адаптеры отмечены зеленой иконкой с изображением зеленой платы. Вам нужен контроллер удаленного доступа. Обычно он называется "Контроллер удаленного доступа" (или Dial-Up Adapter). Запомните его имя и впишите его в строчку "NetworkAdapter". Получиться что-то типа "NetworkAdapter=Контроллер удаленного доступа". Перезагрузите программу. После этого все должно работать.

6. Почему не выводится окно терминала?
В ОС Windows NT5x (Windows 2000, Windows XP, Windows Server 2003) весьма проблематично реализовать такой механизм из-за особенностей безопасности этих ОС. Мы постараемся сделать все возможное для воплощения этой возможности в следующих версиях программы.

7. Проблемы с выполнением скриптов
Да, существуют некоторые проблемы при выполнении скриптов, которые требуют интерактивного режима работы. Это некоторым образом связано с окном терминала. Мы постараемся сделать все возможное для воплощения этой возможности в следующих версиях программы.

8. Как импортировать статистику из версии 3 или 2?
Статистика в первых трех версиях программы храниться в DAT-файлах в папке программы с именем <Имя соединения>.dat. Запустите программу MuxaSoft Dialer 4.1, вызовите основное контекстное меню и выберите в нем пункт Статистика. В появившемся окне выберите в меню Файл пункт Конвертация из старой версии. В появившемся диалоговом окне выберите необходимый dat-файл и нажмите Открыть. Статистика автоматически импортируется. Нажмите Сохранить для сохранения статистики.

9. Как программа интегрируется в операционную систему?
В версии 4.1 был переработан механизм интеграции в операционную систему. Теперь вы можете в любой программе звонить диалером. Модуль интеграции программы (msdint.dll, msdinthlp.dll) перехватывает вызов функции начала дозвона из всех запущенных программ, передает команду на дозвон диалеру, а вызвавшей программе передает ошибку соединения ERROR_NO_CONNECTION (Соединение не может быть установлено). Да, большинство программ отреагируют на ошибку соединения и скажут, что связь не установлена, но соединение установиться корректно. В случаях интеграции, в программах класса Download-Managers (качалки) необходимо установить бесконечный повтор попыток при ошибке соединения.

10. А нельзя ли при соединении с Интернетом синхронизировать системное время ?
Программа итак уже занимает 1,5 мегабайта памяти. Если туда приклеить модуль для работы с SNTP-сервером, программа возрастет еще на 100 килобайт. Мы обязательно сделаем эту функцию, но она будет реализована в виде автономного плагина (модуля расширения).

11. Можно ли проигрывать MP3-файлы?
Да. В версии 4.1, благодаря универсальному звуковому кодеку возможно проигрывание всех файлов, кодеки которых установлены в системе. Если файлы не воспроизводятся, попробуйте установить кодек, например, Fraunhofer IIS MPEG Layer 3 Codec.

12. Что означает пустой график VLQ (его нет просто) в логменеджере?
VLQ (Virtual Level Quality), качество виртуальной организации пакетов. Если графика нет, значит этот параметр равен нулю. Это означает хорошую работу провайдера и его программного обеспечения.

13. Куда мне слать багрепорты, предложения?
На e-mail службы технической поддержки, support@muxasoft.com.

14. Как мне связаться с администрацией?
E-Mail: info@muxasoft.com
ICQ: 118909595
Телефон: +375(29) 758-77-32

15. Где я могу обновить диалер?
На официальном сайте MuxaSoft.

16. Что за Уровни Контроля Соединения (CCL)?
Для слежения за соединениями в программе реализованы 3 уровня контроля за соединениями. Первый уровень контроля представляет собой некий "приемник" системных сообщений Windows, что позволяет получать статус соединения, ошибки и т.д. Второй уровень соединения контролирует соединение на предмет его непредвиденного обрыва. т.е. если соединение перестало существовать (разрыв соединения по внешней причине), а Windows не отослала программе соответствующее сообщение, этот механизм поможет отловить такое соединение. Третий уровень работает аналогично, но уже не на обрыв соединения, а на его появление. т.е. если вы установили соединение не из программы, механизм отловит такое соединение и возьмет над ним контроль.

17. Могу я "перехватить" уже установленное соединение?
Да. Это делается автоматически при появлении такого соединения.

18. Я забыл свой пароль для доступа в Интернет.
Логин, пароль и домен шифруются стойкими алгоритмами, которые достаточно сложно расшифровать не зная ключа защиты. А если включено шифрование с аппаратной зависимостью, то взлом становится практически невозможным. Даже разработчики не смогли бы узнать такой пароль. Также шифруется вся статистика.

19. Как можно зашифровать свой файл настроек?
Защитив программу паролем. И даже простая замена MDP-файла старым ни к чему не приведет. Секретный ключ, который храниться в Хранилище паролей Windows, изменяется каждый раз при завершении программы и файл перекодируется в соответствие с ним.

20. Что такое Плагины?
Плагины - автономные модули программы. Они могут подключаться к диалеру для расширения его базовых функций. Плагины можно скачать с Интернета, отключать и подключать. Плагин представляет собой COM-компонент с расширением DLL и построенный по спецификации MuxaSoft Client-Side Plugins Specification.

21. Могу я написать свой плагин?
Да, можете. Для этого скачайте с официального сайта пример плагина на языке VB. Также вам может потребоваться спецификация такого плагина. Ее вы тоже можете найти на официальном сайте.

22. Могу я опубликовать свой плагин?
Да. Для этого почитайте Правила публикации, которые написаны в спецификации плагинов.

23. Ошибка при прописывании логина - данные не совпадают после цикла шифрования и дешифрования
Такая ошибка может появиться при некорректной регистрации модуля безопасности программы. Переустановите программу с нуля в другую директорию, предварительно сохранив только файлы статистики. Если это не поможет, откройте консоль (Пуск\Выполнить, введите "cmd" (для WinNT5) или "command" для Win98/Me), перейдите в папку с программой MDialer командами "CD", далее наберите такую команду(без кавычек): "regsvr32 security.dll", а затем, "regsvr32 statistic.dll". На обе команды ОС должна дать положительный ответ.

24. Что за PLQ и VLQ?
PLQ (Physical Level Quality) - качество соединения на физическом уровне, зачастую отражает качество оборудования и линии.
VLQ (Virtual Level Quality) - качество соединения на уровне организации пакетов, их оформления. Отражает качество ПО провайдера.

25. А куда в версии 4.1 делся запрет звонков по определенным номерам в определенное время?
Оно переместилось в основной древовидный список соединений и телефонов. Для добавления нового запрета выберите нужный телефон и нажмите Добавить.

26. Можно ли её заставить округлять время соединения (минуты) до целой величины?
Да. В новой версии появилась возможность установки поминутной тарификации с округлением до полной минуты.

27. Хочу приобрести Muxa Soft Dialer 4.1. Как осуществить? Помогите.
Программа является свободно-распространяемой, во всяком случае, пока.

28. Не удается зарегистрировать библиотеку: Функция DllRegisterServer вызвала ошибку 0x80029C4A.
В некоторых бета-версиях версии 4.1 при установке может появиться такая ошибка. На самом деле это просто ошибка в скрипте инсталлятора. Данное сообщение необходимо игнорировать. На корректную работоспособность программы это не повлияет.

29. Если на стандартном windows-подключении соединение с Интернетом стабильно происходит на скорости подключения 46000 - 50300 то при использовании Вашего продукта для дозвона скорость подключения может колебаться от показателя 26600 до 45000...
Возможно, вы неправильно скопировали телефонный номер (возможно, присутствует задерживающий модификатор) или немного другая строка инициализации. В принципе, это невозможно, ведь программа является неким расширением стандартной звонилки Windows.

30. Он обнуляет инициализационную строку модема
Да. В версии 4.1 появилась возможность задавать строку инициализации для каждого соединения отдельно. Задайте строку инициализации в настройке соединения для каждого соединения.

31. Количество отработанного времени округляется в обратную сторону при поминутной тарификации
Да. Также как и трафик. Это особенность подсчета поминутной тарификации. Возможно в следующих версиях программы мы сможем исправить этот недостаток.

32. Как пользоваться Callback'ом.
Очень просто. Во-первых, нужно удостовериться, что данная услуга поддерживается вашим провайдером и она активирована. Во-вторых, нужно установить в параметрах соединения в поле Callback свой телефонный номер для перезванивания. Все. Если все настроено правильно, все будет работать.

33. Как с помощью вашей программы после установки соединения запускать еще одно соединение (например VPN)?
Никак. Возможно, в следующих версиях программы такая возможность будет реализована. Но на данном этапе программа не поддерживает VPN-соединения.

34. Почему монитор считает затраты раз в 20-30 секунд?
Для экономии ресурсов компьютера. Для записи в статистику, ее шифрования, подсчета трафика и стоимости нужно много ресурсов.

35. Хотелось бы чтобы был бы пароль на изменение параметров и/или сделать так чтобы нельзя было никак добраться до пароля соединения с провайдером
Пароль зашифрован. Ну а если вы хотите, чтобы никто не добрался к настройкам программы, вам следует установить пароль на запуск программы. При установке этой функции файл профиля надежно шифруется с динамически-изменяемым ключом.

36. Как мне посмотреть контроль времени за какой-либо период, например за последние 10 дней?
При открытии статистки вы можете задать начальный и конечный период вывода статистики в диалоговом окне Открытие статистики.

37. Не определяется сигнал "занято"...
Это проблема скорее модема, чем диалера. Программа не работает напрямую с модемом и у нее нет спектрального анализа сигнала, как например в VentaFax. Однако вы можете подсчитать примерное время на установку соединения и вписать их в параметры функции Время ожидания соединения.

38. Как обнулить статистику?
Если речь идет об очистке статистики, то вы можете удалить все записи через программу LogManager и нажать Сохранить для сохранения статистики. Если речь идет о очистке счетчиков статистики за период, вы можете воспользоваться тем же LogManager-ом, открыв файл статистики, выбрав пункт Свойства в меню Параметры, перейдя во вкладку Счетчики и нажав Сброс. Также вы можете, находясь в режиме OnLine, вызвать меню "горячих" настроек программы, выбрать Сбросить счетчики.

39. Что такое RAS?
RAS - Remote Access Services, - набор библиотек, который использует Windows для установки соединения с удаленной сетью. Позволяет использовать все возможности удаленных соединений, такие как Callback. Также позволяет "разбирать" данные на TCP/IP-пакеты и взаимодействовать с модемом на уровне драйвера.

40. Почему программа так много "жрет" памяти?

Итак. Давайте разберемся с этим вопросом один раз и навсегда. Процесс mdialer32.exe занимает в памяти от 8 Мб до 11 Мб, в зависимости от режима работы. Давайте разберемся, что же так много занимает:

msvbvm60.dll - жрет около 1,5 мб
mscomctl.ocx, mswinsck.ocx жрет около 2-х мб
около 15-ти dll-ок запускаемых с программой - все остальное
сама программа занимает в памяти около 2,5 Мб (VM Usage)
Итак. Рассмотрим процесс запуска программы:

загружается в память exe-файл (вернее его часть программного кода)
программа подгружает все необходимые библиотеки для работы функцией LoadLibrary
начинается интерпретация программы до ее завершения
Все библиотеки (msvbvm60.dll, mscomctl.ocx...) являются shared-компонентами. Это означает, что они загружаются в память только один раз за сессию Windows. Эти файлы используют многие программы. Когда диалер напр. вызывает загрузку DLL в память, Windows ищет DLL-шку в памяти и если она уже загружена, создает экземпляр класса объекта. Соответственно вероятность того, что либа будет загружена не такая уж большая.

Параметр Memory Usage в программе TaskManager не показывает сколько программа заняла места в памяти. Этот параметр показывает, сколько программа занимает в памяти вместе со всеми компонентами и shared-библиотеками... Давайте это докажем. Смотрим вкладку Perfomance -> Availiable Physical Memory. Диалер не загружен. Значение равно 75000 (~ 75 Мб). Запускаем диалер, значение стало 71400 (~71,5 Мб) (своп отключен полностью). Итак, сколько же он занял оперативки? 3,5 мегабайта.

Нужно смотреть на параметр VM Size (сколько выделено памяти на процесс), вот он и равен 3 846, т.е. около 3,6 Мб.

41. Совместим ли MDialer с Windows XP?
Полностью. Программа писалась именно для этой ОС.

42. Совместим ли MDialer с Windows NT4?
Нет. Возможно, с последним Service pack программа заработает, но это не гарантируется.

43. Совместим ли MDialer с Windows 95?
Нет. Эта ОС не предоставляет необходимые функции для работы диалера.

44. Решена ли ошибка 2000-го года в программе?
Полностью. Для сохранения даты используется 8 байт, как и в любой программе под ОС Windows.

45. Ваша программа есть большой троян! Вы #@%&*#!!!
При загрузке с официальных узлов заражение вирусом исключено. На серверах постоянно идет проверка на вирусы, да и к тому же инсталлятор имеет CRC-защиту. Если вы загрузили программу с неофициального узла, то сообщите нам об этом. Мы сделаем все возможное, чтобы эта программа больше не появилась на сервере.

46. Ваша программа удалила всё на моем винте и перепрошила БИОС! Вы ответите за это!
Одно скажу: мы гарантируем, что в нашей программе НЕТ специально предусмотренных функций для всего вышеперечисленного. Программа использует стандартные API-функции работы с диском на высоком уровне. Если это и привело к сбою в системе, то все претензии к корпорации Microsoft.

47. Будет ли программа переведена на другие языки?
Будет английская коммерческая версия программы. На другие языки программа переводиться не будет по коммерческим причинам.

48. Когда будет следующая версия программы?
Мы планируем ее где-то на Май - Июнь 2003 - го года.

49. Что за MSVBVM60.DLL? Это виртуальная машина JAVA?
Нет, это библиотека Microsoft VisualBasic Runtime Library. Если у вас ее нет, то вы можете загрузить с нашего сайта файл vb6run.exe и запустить его. Это официальное обновление ко всем версиям Windows.

50. Какие еще библиотеки использует программа ?
Программа написана так, чтобы использовать только стандартные библиотеки Windows. Программа не использует компоненты Microsoft Common Controls и Microsoft Common Dialog Controls. Однако, многие функции работы с графическим интерфейсом реализованы через стандартные API-функции.

51. Как защитить статистику от неавторизированной записи?
В версии 4.1 появилась возможность установки пароля на запись статистики. Для этого в окне свойств статистики (Файл\Свойства) введите пароль. После этого внизу (в строке состояния) программы появиться иконка "замочка", похожая на иконку SSL в Internet Explorer.

52. Я удалила некоторые соединения из статистики, но они появились после очередного открытия файла.
Вы не сохранили статистику. Для этого нажмите на пункт Сохранить в меню Файл.

53. При запуске программы под Windows XP система выдает звук критической ошибки, но программа загружается и работает стабильно.
Да, и отчего он воспроизводиться пока не понятно. Звук воспроизводиться из-за установленной поддержки тем Windows XP. Без них программа выглядит хуже, но не выдает этого звука. Решения проблемы:
- отключить звук критической ошибки
- удалить файл mdialer32.exe.manifest и logman32.exe.manifest
- удалить программу и установить без поддержки тем Windows XP.


Content

Общие настройки программы

Настройка программы происходит в соответствующем окне программы, которое вызывается через контекстное меню. В самой первой вкладке сосредоточено большинство настроек программы.

Все опции в первой вкладке ("Общие параметры") разделяются на 2 группы:
- общие параметры программы
- общие параметры набора номера

1. Общие параметры программы

1.1. Загружать программу вместе с Windows.
 Эта опция позволяет установить загрузку программы MDialer вместе с операционной системой Windows. Программа прописывается в системном реестре Windows только для текущего пользователя.

1.2. Начинать дозвон при старте программы.
Опция позволяет начинать дозваниваться до провайдера сразу после загрузки программы. Полезна если у вас безлимитный выход в Интернет по отдельной телефонной линии или вам нужен Интернет сразу после загрузки компьютера.

1.3. Показывать монитор при установке соединения.
 Позволяет показывать монитор (окно оперативной информации о соединении) сразу после установки соединения с сетью. См. Монитор.

1.4. Показывать окно состояния при наборе номера.
Если эта опция установлена, то окно состояния соединения будет показываться автоматически при начале дозвона и скрываться при успешном подключении к сети. См. Окно состояния.

1.5. Прятать монитор при разрыве соединения.
Эта опция позволяет настроить окно монитора так, чтобы он автоматически скрывался после разрыва соединения.

2. Общие параметры набора номера.

2.1. Префикс.
В это поле записывается префикс телефонного номера (цифры и знаки, которые будут следовать перед телефонным номером). Опция полезна, если для выхода на городскую линию используется дополнительные цифры (напр. "9"). Например, если телефон "222322" а префикс "9W" то номер будет выглядеть так: "9W222322".

2.2. Постфикс.
Тоже самое, что и префикс, только наоборот: цифры и знаки, которые будут следовать после телефонного номера. Например, если телефон "222322" а постфикс "000" то номер будет выглядеть так: "222322000".

2.3. Пауза.
Данное поле устанавливает в секундах паузу перед набором номера в случае их перебора (ожидание перед набора номера после разъединения с ошибкой). Данная опция полезна при частой занятости телефонного пула провайдера.

2.4. Попыток.
Максимальное количество попыток соединения. Если значение равно нулю, то программа будет дозваниваться бесконечно.

2.5. Автодозвон.
Данная опция позволяет установить реагирование программы на ошибки соединения. Если опция установлена, то программа будет автоматически перезванивать при разрывах связи и при ошибках набора (линия занята и т.п.).

см. также:

  • Приложение В (символы в телефонном номере)


aaa


TopFrame

Официальный сайт: | http://muxasoft.com
Служба поддержки: | support@muxasoft.com
ICQ: | 9400928


Использование функции Обратный звонок

Обратный звонок (Callback)

CallBack можно перевести как "обратный звонок". Механизм прост: вы звоните провайдеру, начинается авторизация, сервер обрубает связь, а компьютер готовиться к приему входящего звонка. Далее, провайдер звонит уже вам, происходит соединение, и вы в Сети! Это освобождает от повременной платы за использование телефонной линии.

Однако имеется ряд органичений при таком способе соединения. Во-первых, это скорость. Чтобы добиться скорости > 33600 бит/сек необходимо подключение вашего компьютера к цифровой телефонной станции (АТС), современный модем, поддерживающий протокол соединения V.92, поддержка этого протокола провайдером и наичие хорошего цифрового пула у провайдера.

Заметим, что в некоторых странах, в частности в Республике Беларусь, отсутствует такая услуга, как Обратный звонок.

Для установки такого соединения необходимо вписать номер вашего телефона (куда будет звонить сервер провайдера) в поле Callback в свойствах соединения.

см. также:

  • Возможности программы


Командная строка

В версии 4.1 предусмотрена командная строка, для запуска программы с уже установленными действиями.
Доступные ключи:

  • mdialer32.exe -force_9x
    запускает программу в форсированном режиме работы как в ОС Windows 98/Windows Millenium

  • mdialer32.exe -force_nt
    запускает программу в форсированном режиме работы как в ОС Windows 2000/XP/Server 2003...

  • mdialer32.exe -debug
    позволяет запустить программу с расширенными возможностями (применяется для отладки). В таком режиме можно запустить сколь угодно экземпляров программы. Также программа не будет реагировать на некоторые ошибки.

  • mdialer32.exe -trace
    прозволяет диагностировать ошибку, возникающую при запуске программы. Выдает сообщения об совершении последующих действий программы. Посдеднее действие перед ошибкой можно считать не успешно завершенным и причиной ошибки.

  • mdialer32.exe -dial [Соединение] [Телефонный номер], пример:
    mdialer32.exe -dial
    mdialer32.exe -dial Соединение
    mdialer32.exe -dial Соединение Номер

    Позволяет осуществить дозвон (только если диалер не загружен) по указанному соединению и телефону. Если телефон не указан, озвон идет по первому телефонному номеру, соответствующего соединения. Если соединение не указано, программа начинает дозвон в соответствие с установками.

  • mdialer32.exe -hangup
    завершает все установленные соединения.

см. также:

  • Возможности программы


Расширение программы (доп. модули)

Модульные расширения программы

В версии 4.0 программы MDialer появилась возмоность подключения дополнительных модулей программы, разработанных как независимыми разработчиками, так и MuxaSoft. Главная задача таких модулей - обеспечить адаптацию программы для конкретного пользователя, не загромождая возможностями программы других пользователей.

Все модульные расширения хранятся в папке Plugins папки программы MDialer. Достаточно просто скопировать файл расширения в эту папку и перезагрузить диалер. Дополнительные возможности будут доступны в главном окне программы (окне Параметры).

Все расширения комплектуются программой-имплонтатором (программой, которая автоматически установит модуль в программу). Достаточно запустить такую программу и диалер будет пополнен новыми возможностями.

Загрузить модули программы вы можете на нашем официальном сайте.

см. также:

  • Возможности программы


Возможности программы

Автоматическая установка связи без вмешательства пользователя
Вы можете просто дать команду программе на установку связи и пойти выпить чашечку кофе – программа будет пытаться дозвониться еще и еще, пока не будет установлена связь.
Подсчет затрат за услуги связи
В программе реализована возможность подсчета затрат как по времени соединения, так и по входящему и исходящему трафику.
Интеллектуальная обработка ошибок
Вы можете указать программе как реагировать на определенные ошибки, возникающие в процессе дозвона и нахождения в сети!
Перехват управления над уже установленными соединениями
Программа постоянно “следит” за наличием новых соединений в системе. Если вы звоните посредством других программ (например, почтовой программой) диалер в течение нескольких секунд перехватит соединение и начнет считать статистику в автоматическим режиме.
Система повышенной безопасности
Мощные криптографические системы защищают ваши конфиденциальные данные от утечки.
Удаленное управление программой по локальным сетям
Вы можете управлять программой с другого компьютера по локальной или глобальной (Internet) сети из любой операционной системы
Защита программы паролем
Защита паролем обеспечивает шифрование профиля пользователя с рандомным сохранением ключа шифрования в Хранилище паролей Windows
Аппаратно-зависимое шифрование
Шифрование данных осуществляется по аппаратно-зависимому алгоритму – исключение простого переноса конфигурационного файла на другой компьютер и использование его там!
Встроенный планировщик
Планировщик ведет себя подобно планировщику Windows, но предназначен для управления диалером
Отчетность по соединениям
В запись о состоянии соединения в отчет записывается вся необходимая статистическая и аналитическая информация, например, отчетность об ошибках соединения
Просмотр и управление статистикой
Мощное средство управления статистикой MuxaSoft LogManager II не только показывает статистику о соединениях, но и ведет графики (диаграммы) о затратах, трафике, качестве соединения и т.д
Периодическое сохранение статистики
Статистика сохраняется каждые 30 секунд – исключение неверной записи статистики при аварийном завершении работы компьютера

см. также:
  • принцип работы программы
  • системные требования


Принцип работы программы

Как происходит установка связи с провайдером и что для этого нужно? Не ответив на этот вопрос, вы не поймете как работает диалер.

Первым шагом к подключению к сети является собственно подготовка модема и набор телефонного номера. Это выполняет модем встроенными в него функциями, полностью автоматизируя этот процесс вплоть до полной установки модемной связи с другим модемом. После физического подключения сразу идет процесс авторизации – проверки имени пользователя (логина) и пароля. В новых версиях Windows появилась возможность более защищенной авторизации – шифрование данных различными способами и т.д.

Необходимо специальным образом передавать данные провайдеру и от него. Это называется Пакетная Передача Данных (протокол PPP, Point-to-Point Protocol) – одна из подсистем протокола более низкого уровня – TCP/IP. После успешной авторизации вы можете работать в сети!

Такие технические пути установки связи – взаимодействие с конкретным модемом, модуляция/демодуляция данных, криптографические функции – все это уже реализовано в операционной системе Windows и объединено в единый механизм – Remote Access Service (RAS).

Программа MuxaSoft Dialer использует эти функции и обеспечивает установку и управление соединением на уровне операционной системы. Это позволяет работать с новыми функциями более поздних операционных систем. Ведь никто не сможет работать лучше чем сама ОС!

Собственно программа MuxaSoft Dialer – некая оболочка стандартного средства дозвона Windows.

см. также:
  • возможности программы
  • системные требования


Принцип работы программы

Четвертая версия программы имеет гораздо больше возможностей и более требовательна к системным ресурсам. Однако программа в состоянии работать даже на 486-х компьютерах – все будет сказываться на скорости программы.

Рекомендуемые системные требования:

  • Процессор: 266 MHz
  • ОЗУ: 64 мегабайт или более
  • Жесткий диск: 10 мегабайт свободного места на жестком диске
  • Операционная система: Программа оптимизирована для работы с Windows 98, Millenium, 2000 и XP. Желательно наличие Windows XP или Windows Server 2003.

О занимаемой памяти программы:

Итак. Давайте разберемся с этим вопросом один раз и навсегда. Процесс mdialer32.exe занимает в памяти от 8 Мб до 11 Мб, в зависимости от режима работы. Давайте разберемся, что же так много занимает:

  • msvbvm60.dll - жрет около 1,5 мб
  • mscomctl.ocx, mswinsck.ocx жрет около 2-х мб
  • около 15-ти dll-ок запускаемых с программой - все остальное
  • сама программа занимает в памяти около 2,5 Мб (VM Usage)

Итак. Рассмотрим процесс запуска программы:

  • загружается в память exe-файл (вернее его часть программного кода)
  • программа подгружает все необходимые библиотеки для работы функцией LoadLibrary
  • начинается интерпретация программы до ее завершения

Все библиотеки (msvbvm60.dll, mscomctl.ocx...) являются shared-компонентами. Это означает, что они загружаются в память только один раз за сессию Windows. Эти файлы используют многие программы. Когда диалер напр. вызывает загрузку DLL в память, Windows ищет DLL-шку в памяти и если она уже загружена, создает экземпляр класса объекта. Соответственно вероятность того, что либа будет загружена не такая уж большая.

Параметр Memory Usage в программе TaskManager не показывает сколько программа заняла места в памяти. Этот параметр показывает, сколько программа занимает в памяти вместе со всеми компонентами и shared-библиотеками... Давайте это докажем. Смотрим вкладку Perfomance -> Availiable Physical Memory. Диалер не загружен. Значение равно 75000 (~ 75 Мб). Запускаем диалер, значение стало 71400 (~71,5 Мб) (своп отключен полностью). Итак, сколько же он занял оперативки? 3,5 мегабайта.

Нужно смотреть на параметр VM Size (сколько выделено памяти на процесс), вот он и равен 3 846, т.е. около 3,6 Мб.

см. также:
  • возможности программы


Что такое диалер?

В страны России и СНГ еще нескоро придет то время, когда каждый пользователь будет выходить в сеть Интернет через выделенные линии, мобильную GPRS и CDMA-связь, спутниковые каналы, DSL-линии и высокоскоростные радиоканалы.

В наше время подавляющее большинство пользователей пользуется модемным (dial-up) методом подключения к Интернету. Из этого вытекают некоторые трудности:

  • повременная оплата
  • оплата за трафик
  • многократный дозвон к провайдеру
  • частые обрывы связи
  • низкая скорость соединения
  • занятость телефонной линии

Все эти проблемы частично решают многофункциональные программы-дозвонщики, которые в состоянии посчитать примерную сумму расходов, скорость соединения, самостоятельно дозвониться к провайдеру по указанным соединениям и/или телефонам, автоматически восстановить связь с провайдером и т.д.

Одна из таких программ – MuxaSoft Dialer версии 4.

MuxaSoft Dialer 4 (сокращенно MDialer) способен самостоятельно дозвониться к провайдеру через модем, обработать ошибки соединения, вести подробную статистику по каждому соединению (вплоть до качества связи), тарифицировать время и трафик с учетом выходных и праздничных дней, сообщить о превышении лимитного параметра, автоматически разорвать связь в определенное время, интегрироваться в ОС Windows на низком уровне (позволяет перехватывать начало дозвона из других программ, напр. FlashGet, ReGet, TheBat! Opera, Internet Explorer и т.д.), перехватить и взять под свой контроль уже существующее соединение и т.д.

Также эта программа зачастую обеспечивает лучшее хранение (более безопасное) пароля и логина, чем остальные программы такого рода, а благодаря возможности установки пароля на сам запуск программы и хранении его в Хранилище паролей Windows, взломать программу не предстоит возможным.

Просмотр статистики ведется через специальную программу MuxaSoft LogManager, которая поставляется вместе с MDialer-ом. Обеспечивается наглядное представление данных в виде списка и диаграмм, а благодаря счетчикам вы можете быстро следить за статистикой за определенный промежуток времени (что-то типа хронометра). Также в новой версии LogManager предусмотрена возможность задания пароля на сохранение данных (никто без вашего ведома не сможет ничего сделать).

см. также:
  • принцип работы программы
  • системные требования


LeftFrame

Поиск:

Введите слово или фразу, по которой вы хотите осущесвтлять поиск:

Содержание:

Лицензионное соглашение
Введение
 | Что такое диалер?
 | Принцип работы
 | Возможности
 | Системные требования
Подготовка к запуску
 | Установка и удаление
 | Официальные узлы
Интерфейс программы
 | Окно Параметры
 | Окно Состояние
 | Монитор
 | Контекстное меню
 | Hot-меню
Настройка программы
 | Основные настройки
 | Настройка монитора
 | Безопасность
 | Настройка соединений
 | Приложения и звуки
 | Планировщик
 | Журнал работы
 | Установка лимитов
 | Установка условий
 | Обработка ошибок
Расширенные настройки
 | Настройки профиля
 | Интеграция в Windows
Удаленное управление
 | Зачем и как использовать
 | Команды и ответы
Статистика
 | Просмотр статистики
 | Диаграммы
 | Счетчики
 | Безопасность
Использование возможностей
 | Командная строка
 | Модульные расширения
 | Обратный звонок
Техническая поддержка
 | Разработчики
 | Обновления
 | Часто задаваемые вопросы
Приложения
 | Коды ошибок соединения
 | Коды состояний
 | Символы в телефонном номере
 | Оптимизация интернет-соединений